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1 Software Introduction

1.1 Qverview

Houseplan 2.0 is a versatile and intuitive 3D modeling and real-time rendering software, providing a lightweight yet robust
solution for visualizing and presenting design schemes. Now featuring enhanced Al rendering tools, terrain tools, component editing
tools and sun-shadow simulation tools, it has become even more powerful, offering improved accuracy and flexibility for architects,

urban planners, and designers.
1.2 System requirements

1.2.1 Hardware requirements

Minimum Recommended
CPU Intel 15-6 processor Intel 15-9 and above
Monitors 1440 x 900 true color display 1920 x 1080 or higher configuration
Video Card Nvidia GTX1050Ti Nvidia GTX1660Ti or higher
RAM 16GB 16GB or higher
Hard Drive 4G 8G
Others Mouse, trackba(;lesircz;nother pointing Mouse, trackball or another pointing device
1.2.2 Software Configuration
0S Win 7 (64-bit) / Win10 (64-bit) / Win 11(64-bit)

1.3 Houseplan 2.0 Interface Overview

The user interface consists of a quick access toolbar, ribbon, property palette, status bar, file tab, command line and workspace.
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|/ Undetined __ LI Undetineatne |

Quick Access Toolbar: Allows quick access to frequently used tools such as New, Open, Save, Save As, Undo, Redo, Layer

Control, Element on/off and Layers.

Ribbon: Displays task-based tools relevant to the current workspace that consists of nine tabs. Each tab consists of a series of

panels of related functions.

Home Insert Edit Modeling View Material Scene Video Services

NEEBEBE|E @ oo0 8 & BN EHO0A D S =

New Open Save Save Save | Properties Settings | Line Rectangle Box | Building C g Balcony Window Door Rooftop Awning Outdoor Building Move

As  Selected Extrusion H Gallery ® Stairs Curtain Wall Attachment Components |

File Manage Draw Building

Property Palette: Displays the properties of selected object and can be modified.
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Properties E x
B Bunilding

Auto Hide

builaroe

it difference

Status Bar: It is composed by cursor coordinate position, tools that affect the drawing environment (Orthogonal, Polar Axis,
Snap, Follow, and Reference), The units used by the current drawing, slider to adjust camera speed, view mode buttons (Isometric,

Perspective), and effect switch buttons (Shadow, Anti-Aliasing, Light Projection).

-68.474, -35.897, 0.000 ( xis | Snap | Follow |Reference

Scene Units: Meters Camera Speed ———————+————@—— | Isometric | Perspective | Shadow | Anti-Aliasing | Light Projection

File Tab: Located above the command line, displays one or more opened files.

Untitled1 Untitled2 Untitled3 Untitled4 Untitled5

Command Line: Shows the command prompt during the execution of a tool or command.

COMMAND:RECTANGLE
SPECIFY FIRST ANGLE POINT:
SPECIFY THE OTHER ANGULAR POINT:

Command:

Workspace: Displays visible area of current opened file.
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2 Home Menu

This chapter introduces basic features of Houseplan 2.0, such as creating and saving projects, parameter settings, drawing
lines, planes, and volumes, designing building models, deconstructing interior structure, etc., allowing users to quickly create new

projects and improve design efficiency.

2.1 File Panel

2.1.1 New

Select "Home Tab > File Panel > E New" to create a new blank drawing.

2.1.2 Open

Select "Home Tab > File Panel > Open" to open a file in *.cpi format.
Note: Multiple documents can be opened at the same time, and you can switch between documents by Ctrl+ Tab, and copy

(Ctrl+ C) and paste (Ctrl+ V) data between documents.

2.1.3 Save

Select "Home Tab > File Panel > E Save" to save the current file.
Note:
(1) Saved file is in *.cpi format. When saving an existing file, the original file will be saved as *.cpi.bak. If the original
file is needed, remove the .bak suffix.
(2) The default auto save interval is 30 minutes. Set the save interval and location in "Home Tab > Manage Panel >

Settings > Auto Save".

2.1.4 Save As

Select "Home Tab > File Panel > E Save As" to save the current file as *.cpi format only.

2.1.5 Save Selected

Select "Home Tab > File Panel > E Save Selected" to select and save existing objects or elements on workspace as *.cpi
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format.

2.2 Manage Panel

2.2.1 Properties

Select "Home Tab > Manage Panel > Properties" to close/open the property palette.

Properties ﬂ X
B Slope Roof

Color attached to la. .. A ide

lane height
oard heizht 0. 3000

Extension panel type Flat wall entity

Projection arealm’)

Detailed parameter 0. 0000

Flat top height 0. 0000

Hanging board enclosure Yes

2.2.2 Settings

Allows to manage Houseplan 2.0 parameters regarding to command shortcut customization, workspace background color,

auto save function, switch themes, Units Setup and reset to default option.

Select "Home Tab > Manage Panel > Settings" to open the following dialog box.

Simplify Commands Set Background Auto Save

Switch Theme nits Setup Reset
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2.2.2.1 Simplify Commands

fif

Sets a key shortcut to quick access a command similar as command alias. Select "Home Tab > Manage Panel >

Settings > Simplify Commands" to open the following dialog box.

Simplity Commands

s I S5 I Y
Home Insert Edit Modeling View Material Scene Video g1
Serial number  Command description Command name Simplify command
1 Mew MNEW
2 Open OPEMN
3 Save SAVE
4 Save As SANEAS
5 Save Selected SAVESEL
[+ Properties SHOW _SZ¥5
7 Settings SetParam
3 Palyline PLIME PL
9 Line Segment LINE L
10 Arc ARC
11 Spline SPLINE SPL
12 Cirde CIRCLE ClI
13 Ellipse ELLIPSE
14 Regular Polygon MPOLYGOM
15 Vertical Line FACEVERTICALLIMNE
15 Spiral Line SPIRALLINE
17 Cloud Line CLOUD
18 Rectangle RECTAMNGLE REC

1. Enter a custom shortcut command in the "Simplify Command" column, and enter it on the command line when it is used.

2. Click on the =3 button to save the simplified command.
3. Click on the button to open a list of defined "simplify command" for easy access and modification.
4. Update the simplified command list by clicking on the £ putton to import the simplified command list configuration file.

5. Click the L= button to select a storage location to export the current list of simplified commands as a configuration file.

2.2.2.2 Set Background

Sets the background color of the workspace in axonometric mode. Select "Home Tab > Manage Panel > Settings >

Set Background". Select the color, and click "OK" to apply the settings.
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Simplify Commands Set Background Auto Save

Switch Theme Units Setup Reset

TTTTLE
EEEE T
EEEEAT
EEEET
TEEEEE
EEEEET

2.2.2.3 Auto Save

Sets the interval and save path for backup files to be saved automatically. Select "Home Tab > Manage Panel > Settings >
Auto Save" to bring up the following dialog box.

Interval {min): | 30

ot |

Save path: C:\Users\Administrator\Documents\HousePlan Da |

Confirm Cancel

Enter or select the interval time and click the [D button to set the save path; click the "Confirm" button to apply the settings.

Note: The backup file format is *.cpi.

2.2.2.4 Switch Theme

Toggles the available skin or themes provided by Houseplan 2.0. Select "Home Tab > Manage Panel > Settings >
Switch Theme " to switch the theme.
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Housepian 2.0 - [ Untitied1 ]

EEHO MO~ =

Houseplan 2.0 - [ Untitied1 ]

e errain S eo Service
DBE!B EIQE@E@IHEAWJI@ = EDDMHEJ@@E( Al
File Manage Draw Bald ing SDDD I Al

2.2.2.5 Units Setup

Sets the drawing units for the current drawing. The common

units in metric system are millimeters, centimeters, meters, and

the common units in imperial system are inches, feet. seene Units: Meters

Conver to: Meters
Select " Home Tab > Manage Panel > Settings >

Confirm Cancel

II

Units Setup", the dialog box will pop up, select the required units

in the list and click "Confirm" button to activate the settings.
Notes:
(1) The unit of the drawing is determined by the most recent setting.
(2) The status bar will synchronously display the currently set unit.
(3)If you switch to a different unit method, the dimensions will be automatically converted to the current unit value.
However, this does not apply to merged files or imported data such as tilt data, point cloud data, or manual data.
(4) When copying a scene to another scene, the unit of the selected scene will match that of the target scene, and related

values will be automatically adjusted.

2.2.2.6 Reset

Select "Home Tab > Manage Panel > Settings > Reset", to restore all settings in the software to the state they were in

when the software was installed.

2.3 Draw Panel

2.3.1 Line
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2.3.1.1 Polyline

Creates a polyline. Select "Home Tab > Draw Panel > Line > Polyline", there are two ways to draw.
1. Direct draw a polyline
(1) Draw a straight-line segment: After specifying the starting point, specify the next point, or continue specifying more
points until the target position, and press Enter.
(2) To draw a circular line segment: Type or input “A” and press Enter, specify the next point, or continue specifying

more points until the target position, and press Enter.
Note: The arc is tangent to the previous segment of the polyline.

During the process of drawing a single line segment, straight lines and arcs can be drawn at any time by switching
between the “L” and “A” keys. To close, enter “C” and press enter; to abandon the previous operation, enter “U” and press
enter.

2. Drawing 3D polylines

Type or input “S” to enter and specify the next point, or you can continue specifying the second and third points until the

target position and press Enter. To close, enter “C” and press Enter; to abort the previous operation, enter “U” and press enter.

Note: When drawing a three-dimensional polyline,

Follow | Reference

open the "polar axis", as shown in the figure, so Orthogonal Polar Axis | Snap
that you can snap to the auxiliary lines when

drawing.

2.3.1.2 Line Segment

Creates line segments. Select "Home Tab > Draw Panel > Line > . Line Segment", specify the start and end

points, and generate a line segment.

2.3.1.3 Arc

Creates an arc. Select "Home Tab > Draw Panel > Line > E Arc" and there are two ways to draw.
1. Draws an arc by directly specifying three points.

2. Enter or type “C” and press enter, draw the arc by the specified circle center. Specify the circle center, start point and end

point to generate.

2.3.1.4 Spline
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Creates a spline. Select the item "Home Tab > Draw Panel > Line > Spline" to draw a spline at the specified
point.

1. Draw an unclosed spline: Specify the starting point and endpoint tangents separately to generate the splines.

2. Draw a closed spline: Enter or type “C” and specify the tangent direction. To abort the previous operation, type “U” and

press enter.

2.3.1.5 Circle

Creates a circle. Select "Home Tab > Draw Panel > Line > @ Circle" to create a circle with the specified center

and radius.

2.3.1.6 Ellipse

Creates an ellipse. Select "Home Tab > Draw Panel > Line > Ellipse" to create an ellipse with the specified

center and axis length.

2.3.1.7 Regular Polygon

Creates a regular polygon. Select "Home Tab > Draw Panel > Line > MY Regular Polygon", enter a value to
determine the number of sides, and then start drawing. There are three ways to generate.
1. Draws a square polygon internal to a circle: Specifying the center pointand entering

the radius generates a square polygon with the following effect.

2. Draw a regular polygon based on the specified side lengths: Input or Enter “E” and

press Enter to specify two points as the lengths of the sides of the regular polygon.

3. To draw a square polygon tangent to a circle: Input or Enter “C”, specify the
center point, enter the radius, and generate a square polygon with the

following effect.

2.3.1.8 Vertical Line

-]
Creates vertical lines. Select "Home Tab > Draw Panel > Line >

Vertical Line", specify the first point, and use the normal direction to the plane of the point as the direction of the vertical line, and

specify the second point or enter a value to determine the length of the vertical line.
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Note: If the specified point does not snap to a plane, the generated plumb line is perpendicular to the XOY plane.

2.3.1.9 Spiral Line

Creates spiral object. Select "Home Tab > Draw Panel > Ling > dl Spiral Line". First specify the center of the

bottom circle, then directly specify or enter a value to determine the bottom radius and top radius, then enter a value to determine
the number of turns and equal degrees, and then directly specify or enter a value to determine the height to draw the spiral.
Note: You can modify alias, layer color, bottom radius, top radius, tilt angle, number of spiral tums, helix height, floor elevation

and other parameters in property palette.

2.3.1.10 Cloud Line

Creates a cloud line. Select "Home Tab > Draw Panel > Line > @ Cloud Line", specify the starting point, and
move the cursor to draw. There are three ways to draw.

1. Direct drawing forward cloud lines.
2. Enter or input “F” and press Enter to draw reverse cloud line.
3. Enter or input “A” and press Enter to set the arc length.

Note: You can modify alias, layer color, whether it is closed, and the floor elevation in property palette.

2.3.2 Rectangle

2.3.2.1 Rectangle

Creates a rectangular plane. Select "Home Tab > Draw Panel > Rectangle > Rectangle" and specify two corner
points to draw a rectangle.

Note: You can modify alias, layer color, length, width, number of building floors, floor elevation and other parameter information

in property palette.

2.3.2.2 Polygon

Creates a polygonal plane. Select "Home Tab > Draw Panel > Rectangle > Polygon", specify the starting point,

and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort the previous operation, type “U” and press

enter.

2.3.2.3 Spline Plane
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Creates a spline plane. Select "Home Tab > Draw Panel > Rectangle > Spline Plane", enter the plane width, and

draw at the specified point.

2.3.3 Box

2.3.3.1 Box

Creates a box. Select "Home Tab > Draw Panel > @ 4 Box", specify two corner points, and then specify or

enter a value to determine the height.

2.3.3.2 Cylinder

Creates a cylinder. Select "Home Tab > Draw Panel > @ Box > & Cylinder", specify the center of the circle first, then

specify or enter values to determine the radius and height respectively.

2.3.3.3 Cone

Box > m Cone" to specify the center of the base, and then

Creates a cone. Select "Home Tab > Draw Panel > @

specify or enter values to determine the base radius, top radius and height.

2.3.3.4 Donut

Creates a ring volume. Select "Home Tab > Draw Panel > @ s Donut ", specify the center of the circle first,

then specify the radius and circle radius directly or enter a value.

2.3.3.5 Pyramid

Creates a prismatic cone. Select "Home Tab > Draw Panel > @ Box > iEa Pyramid", first specify the center point, then
enter a value to determine the number of sides of the base polygon of the pyramid, then directly specify or enter a value to determine

the radius of the base external circle, the radius of the top external circle and the height.

2.3.3.6 Sphere

Creates a sphere. Select "Home Tab > Draw Panel > @

then specify the radius directly or enter a value to determine the radius.

2.4 Building Panel
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2.4.1 Building Extrusion

Extrudes planes, 3d solids, or surfaces of buildings to achieve building definitions or modifications of their shape. Select

"Home Tab > Building Panel > E Building Extrusion" to extrude the building in the following two ways.

1. Building Extrusion: Move the cursor to a plane to highlight it, then press and hold the left button to extrude or enter a value

M T

to determine the extrude distance.

(1) Select a plane and extrude (Y) (all entities
move) or [click the entities on selected plane
(stay) / extrude without entities move (N) / enter

distance value]:

(2) Select a plane and extrude (N) (no entity move)
or [click the entities on selected plane (move)
/ extrude with all entities move (Y) / enter

distance value]:

2. Standard Floor Extrusion:
When the building is extruded upwards, if there is a plane object or 3D solid or volume that is less than 2 meters away from

the building around the top floor of the building, then it will be copied out each floor as the building floor is extruded.
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Note:
(5) The building must have at least one floor to take effect.
(&) Only supports the above-ground floors of the building.
Building Properties:

(1) Building name: Allows input a
building name.

(2) Building height: Automatically
calculates the building height
and it cannot be modified.
Building height = difference
between interior and exterior

height + (floor height * number

of floors) + height of roof
components. When there is

more than one roofing component, the higher one is counted in the building height.

(3) Floor Properties: To set the properties of the floor, double click on the property palette or click on "=~ button to open

the dialog box shown below.

Page 14 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

Floor number Floor height Area(m?) Factor Capacity factor
5 3.0000 301.97 1.0000 1.0000
4 3.0000 301.97 1.0000 1.0000
3 3.0000 301.97 1.0000 1.0000
2 3.0000 301.97 1.0000 1.0000
1 3.0000 301.97 1.0000 1.0000
Sum 18.0000 1811.82

(1) Define floor: Click = button and select a floor in the list to bind interior elements to selected floors
(should use “Show Floor” tool to hide the selected floor roof). You can select many floors, modify interior
elements of one floor and others will change too.

Note:
@ Hold down SHIFT or CTRL to select multiple floors.

@ After binding, different colors represent different standard floors.

) —ral =
Awning Outdoor Glass Building Move Show Draw Floor
Stairs Curtain Wall Attachment Components Floors Wall Haole

Building
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B 8 2
Floor number  Floor height Area(m?) Factor Capacity factor
6 3.0000 301.97 1.0000 1.0000
5 3.0000 301.97 1.0000 1.0000
4 20000 301.9; 1.0000 1.0000
3 3.0000 301.97 1.0000 1.0000
2 3.0000 301.97 1.0000 1.0000
3 301.97 1.0000 1.0000

1811.82

Floor Properties

[Ele =

Floor number ‘ Floor height [

Area(m?)

Floor Properties X

H = =
Floor number ‘ Floor height [ Area(m?) Factor ‘ Capacity factor ‘
[ 3.0000 201.97 1.0000 1.0000
5 3.0000 301.97 1.0000 1.0000
4 3.0000 301.97 1.0000 1.0000
3 3.0000 301.97 1.0000 1.0000
2 3.0000 301.97 1.0000 1.0000
1 3.0000 301.97 1.0000 1.0000
Sum 18.0000 1811.82
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Floor number ‘ Floor height ‘ Area(m?) ’ Factor | Capacity factor ’
6 3.0000 301.97 1.0000 1.0000 *
5 3.0000 301.97 1.0000 1.0000
3 3.0000 301.97 1.0000 1.0000 o
2 3.0000 301.97 1.0000 1.0000
1 3.0000 301.97 1.0000 1.0000
Sum 18.0000 1811.82
‘ ole
® el0

(2) Separate floor: Click IE'I button and select one or more floors in the list. When same interior elements are

bonded to other floors, this tool helps disconnect the selected floor to others, when you modify the

separated floor, others will be not changed.

Floor Properties

= [E] =

Floor number | Floor height | Area(m?) | Factor
6 3.0000 301.97 1.0000

| Capacity factor |
1.0000

4 3.0000 301.97 1.0000 1.0000

3 3.0000 301.97 1.0000 1.0000

2 3.0000 301.97 1.0000 1.0000

1 3.0000 301.97 1.0000 1.0000
Sum 18.0000 1811.82

Modify the interior elements like furniture or walls in the selected floor.
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Floor Properties
B 8 =

Floor number | Floor height | Area(m?) ‘ Capacity factor ‘
301.97

&

5th. Floor

Double-click other bonded floors to see the interior elements in place (no changed).

b
CRERE 1
Floor number | Floor height ‘ Area(m?) | Factor ‘ Capacity factor | %
6 3.0000 301.97 1.0000 1.0000 r ®
5 3.0000 301.97 1.0000 1.0000 *

2 3.0000 301.97 1.0000 1.0000
1 3.0000 301.97 1.0000 1.0000
1811.82

(3) Delete bonded Floor: Click button and select a defined floor in the list to delete the specified floor in

multiple instanced standard floor.
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Floor Properties

Continue?

All interior entities bound to this floor will be deleted.

Floor Properties

= & (=

Floor number ] Floor height |
3.0000

Area(m?)
301.97

301.97

301.97

301.97
1811.82
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Floor Height: Displays the height of

Properties
B Building

each floor, can be changed manually.
Area: Displays the geometric area of
the current floor.

Factor: Affects the calculation of the
area, converted according to the
height of the floor.

Capacity Factor: Affects the capacity
area, counted by the height of the

floor.

(4) Number of floors: The number of floors above

which is to shown when there is no above-ground floor.

there is no basement.

(8) Apron: Floor lines can be turned on and off.

to the default floor height.

2.4.2 Cross-section Extrusion

1. Extruding directly with any plane edges as boundary.
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difference

and below ground can be modified and the building dynamically changes accordingly.

(5) Indoor and outdoor height difference: The difference between the indoor and the outdoor floor on the ground floor,
(6) Above-ground height of basement: The height of the basement above the ground; this item is not displayed when
(7) Base area: The software calculates the base area based on the building outline and cannot be modified.

(9) Elevation: Reads the building's z coordinate in the scene; can be modified manually.

(1) Extruding planes and volumes automatically generates buildings with the corresponding number of floors according

(2) The data in the property palette updates in real time during extrusion.

Extrudes a plane into a volume or 3D solid. Select "Home Tab > Building Panel > EE Cross-section Extrusion”, move the

cursor to the plane, hold down the left button to extrude or enter a distance. There are two types of extrusion.

2. Type “S” and press Enter to extrude with the outermost edges of a plane as the boundary when lines or edges split the plane.
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Note:
(1) When no boundary is specified, the edges of a plane or volume, or other lines on the plane, "splits" a plane into

several areas, and the cursor will snap to one of the individual areas, extruding it into a volume; when the entity

boundary is specified, the edges outside the selected entity will no longer "split" the entity interval.

(2) When cross-section extrusion is performed on a volume, the newly generated volume is integral to the original entity,
which is a local extrusion and transformation of the original entity. Whereas lines or planes on the volume are used

to divide a given plane into parts and act as auxiliary lines.
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(3) As shown below, it is convenient to extrude section planes on a building.

2.4.3 Building Gallery

Houseplan 2.0 provides a wide range of building base outlines and enables the organization of building assets by adding,

deleting and modifying operations on the building gallery, providing easy access to design projects.

Select "Home Tab > Building Panel > {at Building Gallery" to open the following dialog box.
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Building Gallery

| —1
AF DE'EtE @ E
Bu

Te Clear 002 003 004
Rename
Import DWG
Import Resource [dl'-‘::L;h] i__I:‘
Export Resource o0& 007 008
. DE'EtE
00s
Mew
Area(m2): 208.77 Outine: 16,5600 = 15,1100
%, r

1. Applying the gallery: Drag the building outline directly into workspace.

001 ooz 003

B
B
H

00s 006 o7

[ului=} 010 011

&
n
@

013 014 015 016

3
b
1
]

Area(m?): 410.50 Qutiine: 41.0000 x 15.0000

2. New: Right-click on a blank space in the gallery list to create a new gallery.

3. Edit the gallery: Right-click on the gallery name to show the context menu, as shown above.

Page 23 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

(1) Delete: Removes the selected gallery title from the list.
(2) Clear: Removes all building outlines in the selected gallery title.
(3) Rename: Changes the name of the selected gallery title.

(4) Import DWG: Building outlines can be imported into the gallery by selecting the "Import DWG" command, which

brings up the dialog box shown below.

Impaort file

@  Enter directly or click on the o B

button to select the folder where the C:Program Fles\Gstarsoft Houseplensample\dng | ... |
drawings need to be imported. Spedfy the balcony layer name(Others are buildings):
IINT
@ Enter the balcony layer name at
Specify Balcony Layer Name, and the Confirm Cancel

entities for the other layers default to

the building outline.

& Erase i|Exp!ode ':l Boolean ﬁ: vimy \" g, g
Note [C= Offset [B, Stretch 4k Mirror g v J‘ <t -
o O 7 os L 5 [} = Layer
} Move Rotate “g Copy -/~ v g Properties L 4
. . L ]
@ The imported drawing must be Modity v 2
*

closed lines, and the layers need to
be regularized.

@ The building outline imported by
the user should be a dwg format file
and the drawing units should be in

meters.

(5) Export Resource, Import Resource.

(D Exports the building outline drawings under this category, as well as the *.bmp and *.ini files generated from
the *.dwg drawings of the building outline, as compressed files in *.zip format.

@ Imports the exported * zip file into the gallery.
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Building Gallery

[ —
Apz Delete Eﬂ
Bur
Ter Clear 002 003 004
Rename
Import DWG
Import Resource [d;;h] i :
Export Resource 008 007 ong
ong 010 011
Area(m): Cutline:

HousePlan Contents > HousePlan Building Gallery Resources

Name

| 009
Bl Gallery Resource

& villazip

78~ villazip (evaluation copy)

File Commands Tools

Favorites Options Help

B G EMme

Add  Extract To

View Delete Find

q villa.zip - ZIP archive, unpacked size 682,717 bytes

Name

&| 001.bmp
5 001.dwg
%1 00%.ini

|&] 002.bmp
¥ 002.dwg
] 002ini

|&] 003.omp
¥ 003.dwg
] 003.ini

&| 004.bmp

~

Total 33 files, 682,717 bytes

Note: When importing, the user will be prompted whether to import by appending, select "Yes" to keep the existing outline

drawings under the category, and import all the drawings in *.zip into the gallery, and replace the files with the same

name directly; select "No" to delete the existing outline drawings under the category, and import the building outline in

*

Zip.
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4. Delete: Right-click on the building outline to delete.

5. Building planar attributes: Building outline dimensions and its single layer area, and household type, can facilitate statistical

analys IS. Building Gallery
(1) Area: the area of the building base. . E .
partment Efﬂ
Bungalow
(2) Outline: the length and width of the
building outline.
0a5 006
Note:
. L]
(DThe area does not include the base 009 o
area of the ba|00ny. Area(m?): 745.76 Outline: 42,8400 x 21,6600

(2)After the building is extruded, the
software automatically calculates the

number of households that come with the building as well as the household type information.

2.4.4 Balcony

Inserts preset or custom balconies on buildings. Select "Home Tab > Building Panel > Balcony" to open the following

dialog box.
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0 convex balcony | Concave balcony () Concave /Convex balcony

Mode  Custom

1 2

3 4
Y Q{(ﬁ% i
5 5

isingle @ cColumn || Middle

1. Types of balconies: Convex, concave and concave-convex.
2. There are two ways to define a convex balcony:
(1) Mode: Inserts balconies according to the
parameters set.
(2) Custom: Defines the balcony based on
the outline of an existing plane.
3. You can manually set width, deep, thickness and
height of selected balcony type.

4. Insertion method:

(1) Single: Inserts one balcony at a time.
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Balcony

© Convex balcony () Concave balcony () Concave/Convex balcony

Mode  Custom
3 4 HZ
o [T S

Hi[06000 |  Ha: [0.9000

> |

(Column [ |Middle ~ Insert

) Concave balcony (| Concave/Convex balcony

© Convex balcony

(2) Column: Generates a balcony on the selected floor, as well as on each floor above it.

(3) Middle: Automatically snaps the middle point of a building plane edge.
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Balcony

© Convex balcony (' Concave balcony () Concave/Convex balcony

Mode  Custom

1

Al v
WITH I

3

Y
A

_ISingle |°Column I jMiddIe

5. Direct insertion: Select the balcony type, set the size, select your insertion method, then click "Insert" button. After selecting
the above-ground floor of the building, specifying the edge and entering the distance, the balcony will be inserted
successfully.

6. Custom insertion: Select the convex balcony, switch to the "Custom" tab, set the size, select your insertion method, click
"OK" button. After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the
above-ground floor of the building, the balcony will be inserted.

Note:

(1) When inserting a balcony, Houseplan 2.0 automatic generates water apron on first floor balconies.

(2) Inserting preset balconies will automatically corner when they encounter building angles.

(3) When defining a convex balcony, if the original position insertion method is not checked, the edge closer to the point
where the cursor is clicked on the plane that you selected will be highlighted in red, and this edge will be specified
as the insertion edge.

(4) After inserting a balcony its properties can be modified in the property palette.

(5) Snapping building plane edge activates auxiliary lines when inserting balconies to facilitate precise insertion.

2.4.5 Window

Inserts preset or custom windows on buildings. Select "Home Tab > Building Panel > Window" to open the dialog box
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shown below.

O Flat window () Bulge Window () Bay window
Mode  Custom

. .
1 2
. .
3 4
. .
5 &
. .
7 8

Isingle € Column [ Middle

W | L.a000 e

H: |1.5000 w

Windowsill height: |0.9000 -
[ window cover
Width: |0.1000
Depth: | 0.1000

Glass depthy | 0, 1000

1. Types of window: Flat, bulge and bay window.
2. There are two ways to define a flat window:
(1) Mode: Inserts windows according
to the parameters set.
(2) Custom: Defines the window
based on the outline of an existing

plane.

Page 30 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

3. You can manually set width, deep, thickness and height of selected window type.
4. Insertion method:

(1) Single: Inserts one window at a time.

Window

O Flat window () Bulge Window () Bay window
Mode

[ winge®Cover
Width: |0.1000 |

Depth; |0.1000 |

\J. m. m. H.
G‘ m. A. I\J.

=

3

=9

[=]

=

%

=

[}

2

= T

b i

Glass depth: |0.1000 |

Osingle | ) Column [ Middle Insert

Window

O Flat window () Bulge Window () Bay window

Mode  Custom

. |0.1000
Depth: |0.1000 |

Glass depth: | 0.1000 |

q. m. w. H.
F m. A. I\J.

) Column [ Middle
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(2) Column: Generates a window on the selected floor, as well as on each floor above it.

(3) Middle: Automatically snaps the middle point of a building plane edge.

O Flat window (! Bulge Window [ Bay window

Mode  Custom

1 2
3 4
5 &
Width:
. o
Glass depth: | 0.1000
7 ) 8

I Single [ middle

5. Direct insertion: Select the window type, set the size, select your insertion method, then click "Insert" button. After selecting
the above-ground floor of the building, specifying the edge and entering the distance, the window will be inserted
successfully.

6. Custom insertion: Select the flat window, switch to the "Custom" tab, set the size, select your insertion method, click "0K"
button. After selecting a horizontal plane, planes that are not surfaces of buildings without holes, and selecting the above-
ground floor of the building, the window will be inserted.

Note:

(1) When customizing a flat or convex window, the window directly generates at the location of the plane if the plane is
on a building wall.

(2) Inserting preset windows will automatically corner when they encounter architectural angles.

(3) When defining a bay window, if the original position insertion method is not checked, the edge closer to the point

where the cursor is clicked on the plane that you selected will be highlighted in red, and this edge will be specified

Page 32 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

as the insertion edge.

2.4.6 Door

Inserts preset or custom doors on the building. Select "Home Tab > Building Panel > Door" to open the dialog box

shown below.

Mode  Custom

Wi 1.8000 ot

H: | 2.1000 w

[] Door cover width: |0.1500
Door cover depth: |0.0500

[] Mumber of steps: |3
Step width: | 1.3000

[] Awning height: |3.0000

1 2
[
I
3 4
5 =

singe @ Column [ | Middle

1. There are two ways to define a door:

(1) Mode: Inserts doors according to the parameters set.

(2) Custom: Defines the door based on the outline of an existing plane.
2. You can manually set width, deep, thickness and height of selected door type.
3. Insertion method:

(1) Single: Inserts one door at a time.
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(2) Column: Generates a door on the selected floor, as well as on each floor above it.

(3) Middle: Automatically snaps the middle point of a building plane edge.

4. Direct insertion: Select the door type, set the size, select your insertion method, then click "Insert" button. After selecting
the above-ground floor of the building, specifying the edge and entering the distance, the door will be inserted successfully.

5. Custom insertion: Select the door, switch to the "Custom" tab, set the size, select your insertion method, click "OK" button.
After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the above-ground
floor of the building, the door will be inserted.

Note:
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(1) Inserting or drawing preset doors will automatically corner when they encounter architectural angles.
(2) When a building has a basement level, the insertion of doors is done separately above and below ground.
(3)When insert a door, the edge closer to the cursor click point, when the plane is selected are highlighted in red, and

this edge is used as the insertion edge.

2.4.7 Rooftop

2.4.7.1 Crenelated Parapet Wall

A crenelated parapet wall is a low wall around the roof of a building that serves as a protection. Select "Home Tab > Building

Panel > ﬂ Rooftop > Crenelated Parapet Wall" and enter a value to determine the height of the crenelated parapet wall.

Note:
(1) Crenelated parapet wall is counted towards building height, building height = indoor and outdoor height difference
+ (floor height * number of floors) + height of crenelated parapet walls.
(2) When painting the material, the crenelated parapet wall and the main volume of the building are painted separately,

and when painting the crenelated parapet wall, a single-sided painting method is available.
2.4.7.2 Flat Rooftop

A flat roof is a type of exterior roof form with a gentle roof that can be made into a terrace, roof garden, etc.

This feature is used to add a flat roof to a building. Select "Home Tab > Building Panel > ﬂ Rooftop > Flat Rooftop"

and select the top plane of the building to create.
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Note:
(1) Flat roofs do not count towards building height.

(2) The property palette allows you to modify the flood height, elevation angle, thickness, eave length and extension type.
2.4.7.3 Sloped Rooftop

The sloped roof is automatically generated based on the outline of the building roof and the parameters set. Select "Home

Tab > Building Panel > ﬂ Rooftop > Sloped Rooftop" to open the dialog box.

Mumber of slopes:  Full slope w

Slope gradient:  30.00

Eawes: 1.0000

Cancel

1. Full slope: Automatically generates a full slope roof based on the outline of the roof. After setting the slope and eaves, click

on the "Confirm" button and select the top plane of the building to generate it.
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Number of slopes: ~ Full slope v
Slope gradient:  30.00

Eaves: 1,0000

Confirm Cancel

2. Double slope: Generate a sloped roof with two slopes. After setting the slope and eaves, click on the "Confirm" button and
there are two ways of generating them.
(1) Generate gable: Select a single vertical plane of a building to generate a gable.

(2) Generate multiple gables: Enter “D” and press enter, select a building vertical plane, and all vertical planes in the

same direction as that plane will generate a gable.

3. Four slope: Generate a four-slope roof. After setting the slope and eaves, click on the "Confirm" button.
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4. Arc top: Creates a curved roof. After setting the slope and eaves, click on the "Confirm" button.
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5. Description of full sloped roof parameters: .
Properties

Once a sloped roof is selected, its properties H Slope Roof

. . C attached to lawvers
can be viewed in the property palette as shown

Boom plane height

below. Hanging board height

Extenzion panel type

(1) Hanging board height: Sets the height

of the hanging board. Detailed parameter

i . Flat top height
(2) Extension panel type: Switch between

oard enclosure

flat wall and adjoining balcony.
(3) Flat top height: Enter a value to make
the roof flatten from the top.

(4) Detailed parameter: To modify the slope and eaves of a sloped roof, double-click directly on the roof or click on the

" button of detailed parameter to open the dialog box shown below.

Edit Sloped Roof

Click the "Slope" or "Eave" to change its value. Click "Confirm" button to regenerate the roof according to the new
parameters.
(5) Hanging board enclosure: Set whether the hanging board is closed or not.
Note:
(1) Created full-slope roofs cannot switch styles on property palette.

(2) After changing the flat roof height, roof cannot be arched.
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(3) Arch roof does not support closed hanging board.

(4) When modifying the detailed parameters, a gable may be generated if the slope is changed to 90 degrees.

(5) Sloped roofs count towards building height. Building height = difference between interior and exterior heights +
(floor height * number of floors) + half of the roof height of the sloped roof.

6. Description of Arc roof parameters: Once an arc roof is selected, its properties can be viewed in the property palette as

shown below.
Properties
(1) Hanging board height: Set the height of = Slope Roof
the hanging board. Coler
Eoom Pl:EIILE he1 5==':].'|.t
(2) Style: Switch between double slope, four et Doerd Bed

slope and arc top.
e gradient
(3) Slope gradient: Enter a value to make the aves length
‘ralactlo :"-:-:".:'.I
arc of the roof increase or decrease its s e Ay
zing board enclosurs

radius.

(4) Eaves length: Enter a value to increase
gaves length of arc roof.
(b) Hanging board enclosure: Set whether the hanging board is closed or not.
7. Description of Double slope roof parameters: Once a double slope roof is selected, its properties can be viewed in the

property palette as shown below.

Properties
(1) Hanging board height: Set the height of = Slope Boof
the hanging board. Eetlars
Foom P].EIILF_' hei 5==':].'|.t
(2) Style: Switch between double slope, Hanzing board height

four slope and arc top.

Frojection areaflm®)

(3) Flattop height: Enter a value to make the Flat top heizht

roof flatten from the top. Bai soeting duils ero
Detailed parameter

(4) Turn rooftop into arc: Click the - Hanging board enclosure

button on the property palette to open
the dialog box shown below, set the

arcing parameters and then click the "Confirm" button to arc the roof.
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Turn Rooftop Into Arc

Chute length: 1.0000

Chute gradient: 20

Chute ratio(%): 25

(5) Detailed parameter: Modify the slope and eaves of a sloped roof.

(6) Hanging board enclosure: Set whether the hanging board is closed or not.

2.4.7.4 Dormer Window

Inserts a dormer window on the sloped roof. Select "Home Tab > Building Panel > Rooftop > Dormer Window" to

open the dialog box shown below. Select the dormer window and specify the location on the sloped roof to insert it.

Place Dormer Window X
/\ o= |—|—? an
|
L ‘,‘ !
Double slope ~ Three slopes Flat top Full sloped top
m M

Flatrooftop  Arcrooftop  Flatwindow
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Place Dormer Window

A |
,m |——|——‘ an

Double slope  Three slopes Flat top Ful sloped top

i ) o) AN

i

Flatrooftop  Arcrooftop  Flat window

Note:

(1) Curved roofs and sloped roofs that are arched do not support the insertion of dormer windows.

(2) You can modify dormer window properties directly on the property palette.

2.4.8 Awning

Inserts an awning on the building according to the set parameters. Select "Home Tab > Building Panel >

open the following dialog box.
1. There are two ways to define an
awning:

(1) Mode: Inserts awnings
according to the parameters
set.

(2) Custom: Defines the awning
based on the outline of an

existing plane.

Awning" to

Mode  Custom
o
W 20000
D= 1.0000 e
Height: 2,7000 -~ W
“iSingle ) Column | Middle

2. You can manually set width, deep, thickness and height of selected awning type.

3. Insertion method:

(1) Single: Inserts one awning at a time.
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(2) Column: Generates an awning on the selected floor, as well as on each floor above it.

(3) Middle: Automatically snaps the middle point of a building plane edge.

Mode  Custom

W 2,0000 v
D 1.0000

© column Middle
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4. Direct insertion: Select the awning type, set the size, select your insertion method, then click "Insert" button. After selecting
the above-ground floor of the building, specifying the edge and entering the distance, the awning will be inserted
successfully.

5. Custom insertion: Select the awning, switch to the "Custom" tab, set the size, select your insertion method, click "OK" button.
After selecting a horizontal plane (planes that are not surfaces buildings) without holes, and selecting the above-ground
floor of the building, the awning will be inserted.

Note:

(1) Automatic cornering of inserted awnings when they encounter building angles.

(2) You can modify an awning’s properties directly on the property palette.

2.4.9 Outdoor Stairs

Inserts outdoor stairs on the building according to the set parameters. Select "Home Tab > Building Panel > =888 Outdoor

Stairs" to open the following dialog box.

Outdoor Stairs

Y2 6000 Direction: Clockwise v

B: 5.4000 © Top cover () Top rooftop

o Run to the
Railings: 1.0000 __Middle accompanying
wall

1. There are two ways to generate it:
(1) Insert: Insert the stairs directly according to the set parameters. Click on the "Insert" button, select the upper floor of
the building and insert it by specifying the location directly or by obtaining a positioning edge and entering the

distance.
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(2) Custom:; Define the stairs based on existing planes. By clicking on the "Custom" button, two types of insertion are
possible.

(D Insert with the wall: Select a rectangular plane, then select the upper floor of the building, and directly
specify or obtain the positioning edge line and enter the distance to insert.

(2 Insertin original position: Enter “Y” and press Enter, then select a rectangular plane, click a surface of the
above-ground floor of the building, then you can insert the outdoor stairs by using the position of the
rectangular plane as a reference.

2. Parameter Note:
(1) Direction: Setting the running direction of the stairs: clockwise and counterclockwise.
(2) Top cover: Setting stairs with or without topping.
(3) Top rooftop: Whether the stairs reach the roof.
(4) Run to the accompanying wall: Whether the handrail on one side of the stairs is against the wall.
(5) Middle: Automatically snaps the middle point of a building plane edge.
(6) Railings: Sets the height of the railings.
Note:
(1) Automatic generation of aprons for outdoor stairs.

(2) You can modify stair properties directly on the property palette.

2.4.10 Glass Curtain Wall

]
Defines or draw a glass curtain wall on a building wall. Select "Home Tab > Building Panel > Glass Curtain Wall" to

open the following dialog box.
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Glass Curtain Wall

Lo E &

Frame width:

q. m. w. H.

Frame depth:

Unit width:

Unit height:

0.0000

0.0000

3.0000

3.0000

After selecting a curtain wall type and set its parameters. There are four ways to generate a glass curtain wall.

1. Define the glass curtain wall according to the wall or plane of the building. Click on the '=&! button, the select a building

wall to generate glass curtain wall.
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2. Generate a glass curtain wall on all walls of the building. Generate by clicking on the button and selecting the building

with above-ground floors.

3. Draw the glass curtain wall on the building wall according to the width. Click on the =1 button, place the cursor over a

building wall and specify three points to finish the operation. To draw through other building walls, enter “C” and press

ENTER.

4. Draw polygonal glass curtain wall on the building wall. Click on the @ button to draw the glass curtain wall as a polygon.
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Note: The property palette can adjust the border width, border depth, unit width and unit height.

2.4.11 Building Attachments

Attachments are decorations that are placed outside of buildings walls. Select "Home Tab > Building Panel > @ Draw

Attachments" to open the dialog box shown below.

Building Attachment

|Osooe

Cross-secti

Width(w):

Height(h):
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1. Insertion method:

(1) Single: Drawing one attachment at a time.

(2) Column: Generates one attachment for each floor in the selected floor and above.
2. There are two ways to generate it.

(1) Generate attachments based on existing cross-sections:

(D) Click "Stratum" button, select the upper floor of the building, snap and get the positioning edge line, input

distance and specify orientation to generate the attachment.

(2) Click "Along edge" button, select the edge of the
building or building wall, left-click to end the
drawing and specify the orientation.

(3) Click the "Draw" button, select the edge of the
building or building wall, left-click to end the
drawing and specify the orientation.

(2) Generate attachment according to custom cross-section:

Take "stratum" as an example, click the "stratum" button,

select a plane or line, select one side of the plane or line
as baseline and specify insertion base point. You need to
select the above-ground floors of the building to determine where to add the attachment, then select the red path or

input distance to specify a path, and finally specify the orientation of the section to generate it.
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g
4

3. Interrupt: Click "Interrupt" button and specify two points on the attachment to break.

Note:
(1) You can change attachment object on the properties palette.
(2) Only the parameters of "W”, “H" can be modified in the cross-section style.
(3)When customizing the section, the attachment is drawn as solid if a plane is selected, or hollow if a closed line is

selected.

2.4.12 Edit Components
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2.4.12.1 Move Components

Changes the position of components like windows, doors, awnings and stairs on the building. Select "Home Tab > Building

—
Panel > Move Components", select the component and press Enter, then drag the mouse or enter the distance from the

specified base point to move them.

o ——

Note:
(1) Moving elements supports the selection of balconies, windows, doors, awnings, outdoor stairs, steps along the line
and area layering.
(2) When specifying the base point, the component shall be specified on the building's vertical plane.

(3) When moving a component, the component moves along the side vertical plane of the building.
2.4.12.2 Copy Components

Copies the building component and insert the copy at a suitable location on the building. Select "Home Tab > Building Panel >

Edit Components > Copy Components" and select building components and specifying the base point, insert a single

component directly at the specified location, or type L to insert a column of components at the specified location.
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Note: Copy components tool supports selecting balconies, windows, doors, awnings, outdoor stairs, other components, stairs

along the line and outside wall region, etc.
2.4.12.3 Mirror Components

Mirrors building components and insert copies at appropriate locations on the building. Select "Home Tab > Building Panel >

— E=e
Edit Components > Mirror Components “and select the building component, specify the position of the axis of symmetry,

and then follow the prompts on the command line to confirm whether to delete the source object.
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Note:
(@ Mirror components tool supports the selection of balconies, windows, doors, awnings, outdoor stairs, other
components, stairs along the line and outside wall region, etc.

@ Mirrors can only be generated on the face or opposite face of the component.

2.4.12.4 Separate Components

Splits a column or group of building components into a single component or groups of components. Select "Home Tab >

e—
Jommm 1

Building Panel > Edit Components > ===1 Separate Components”and select the components you want to singly divide.

Note: Separate components tool supports the selection of balconies, windows, doors, awnings, other components, etc.

2.4.12.5 Delete Components

Deletes building components individually. Select "Home Tab > Building Panel > Edit Components > Delete

Components” and select the components to be singled out for deletion.
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Note: Delete components tool supports the selection of balconies, windows, doors, awnings, and other components.

2.4.13 Show Floors

-
Hides or unhides a selected building floor. Select "Home Tab > Building Panel > Show Floors" to select a floor, and

the floors above that selected floor will be hidden, showing the interior structure and making it easy to see the building's interior

layout. Click on the building again to restore the building to its original state.
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2.4.14 Draw Wall

Draws interior walls inside a building. Select "Home Tab > Building Panel > Draw Wall" to open the following dialog

box.

B ~ B teft  Omdde | Right

Thick:  0.2400 Heght:  3.0000 | Blevation: | 0.0000

[

1. Draw Walls: After setting the parameters in the dialog box, select Straight Wall, Curved Wall or Rectangular Wall, and specify
start and end points. You can switch the wall type in the command line prompt. You can draw continuously, enter “U” to go

back to the previous step, and right-click to end the drawing.
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2. Parameter description: The wall has three directions: left, middle and right. Wall thickness, wall height and elevation can be
set.
Note:
(1) Check the "Elevation" box to specified height as wall elevation, otherwise use the default height as the wall elevation.
(2) You can modify wall properties on the property palette.
(3) Drawn walls have pinch points that can be dragged directly and merge intersection points.
(4) Command line allows drawing wall continuously, right-click to end to continue drawing, right-click again to end
drawing, press Escape keyboard to exit drawing.
(5) Changing parameters while drawing can be continue the drawing with the new parameters.

(6) The next time you open the dialog box the last set wall direction and parameters are remembered.

2.4.15 Floor Hole

Draws hollow areas on selected building floor. Select "Home Tab > Building Panel > Floor Hole" to open the following

box.

Floor Hole

0
sen o
S

Railing height: | 1.0000 )

1. Draw: After setting the parameters, click the "Draw" button, and draw directly at the specified point on the floor. You can
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draw continuously, enter U to go back to the previous step, and right-click to end drawing.
2. Definition: Select objects such as planes, closed lines, and spline planes to generate.
Note:
(D Holes are sub-entities of buildings and railings are sub-entities of holes; railings change as the shape of the hole
changes.
(2) The instances between each layer of railings are changed together: editing one floor changes all other floors; however,

one floor can be deleted individually without affecting the other floors.

2.4.16 Draw Railings

Draws railings on specific entity. Select "Home Tab > Building Panel > [E| Draw Railings" to open the dialog box shown

below.

Draw Railings

i :g@:

i Starting floor: | Current floor -

[}
[a}]

Ending floor; | Current floor -~

9 funn] Railings height(h): 1.0000
\y

yEpd

7 & Railings edge-distance(w): 0.1000
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1. Draw along edge: Specify start and end points on the edge of an existing floor hole or the edge of staircase.

2. Free drawing: Specify any point inside the building to draw. Continuous drawing: enter U to go back to the previous step

and right click to end the drawing.

3. Define rail: Select a line or plane and right click to convert the selected line entity or plane to a railing.
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Note:
(1) Starting and ending floors are invalid for railings drawn on the exterior of a building.
(2) The direction of the railing distance from the edge: can automatically determine the boundary of the staircase or hole
to offset the railing inwards; cannot determine the boundary of the original position drawn without offsetting.

(3) You can modify railing properties on property palette.

2.4.17 Stairs

2.4.17.1 Stairs

Select "Home Tab > Building Panel > Stairs > Stairs " to open the dialog box shown below.
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o o e

Length(]): 3.6600
;flllm,iitn S ———
SN B, g
il = Width{w):  2,5600
\._q_ I —
07 03

1. Draw to match: Adapts the length and width of existing stair openings by drawing a rectangle.

2. Select to match; The length and width of the stairway opening can be adapted by selecting a rectangular plane.
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3. Insert staircase: Specifies an insertion point to insert the staircase into workspace.

4. Rotate 90 degrees clockwise, 90 degrees counterclockwise, 180 degrees: Rotates the stairs on workspace and adapt the
bounding box length and width.
5. Flip left/right, flip front/back: Mirrors the stairs and adapts the bounding box length and width.

6. Stair queues: Replicates the array of stairs, starting from the selected stair location level going upward.
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ML

o

I

S

7. Parameter Note:
(1) Height: Automatically match the floor height when placed, or floor height can be entered manually.
(2) Length: Specify two points as the total length of the stairs.
(3) Width: Specify two points as the total width of the stairs.
Note:
(1) If stair is placed inside the building, the stair height automatically matches the floor height; if it is placed outside the
building, the height is the original dimension.
(2) Double-click on the stair pattern or drag the stair into workspace to insert it.
(3) The leather band also attaches to walls (interior and exterior) when moving, copying and scaling stairs.

() You can modify stairs properties on the property palette.

2.4.17.2 Draw Stairs

Draws a single staircase. Select "Home Tab > Building Panel > Stairs > Draw Stairs" to open the dialog box.
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Height of flight: 3.0000 [ | starting height: | 0.0000
() Step width: ] Railings:  Both ~
0 step height:  9.1300 Trend: Up w

1. Draw: Draws the stairs according to the set parameters. Click on the "Draw" button and there are two ways to generate it.

(1) First specify the starting point to determine the location of the stair segment, followed by specifying length and
direction of the stair.
(2) Select the stair width line, enter “S” and press Enter, select the line or the edge of the plane, and specify length and
direction of the stairs.
2. Define: Selects two lines to define the stairs. Click the "Define" button and select one of the lines as start of the staircase,

then select the other side line to create stairs.
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3. Parameter Note:
(1) Click on the word "Height of flight" in blue to specify two points as stair heights.
(2) Click on "Starting height" in blue to designate a point as the floor elevation of the staircase.
(3) Click on "Step width" in blue to specify two points as the width of the step.
(4) Stair railings are generated in four ways: on both sides, on the left, on the right and none.
(b) Trend: Stairs can be going either up or down.
Note:
(1) Check the checkbox before "Starting height" to use the entered or specified height as the floor elevation of the stair,
otherwise use the captured height as the floor elevation of the section.
(2) Step width and step height are preceded by radio boxes. If one is checked, the other parameter will be greyed out.

(3) You can modify stairs properties on property palette.

2.4.18 Furniture Gallery

Adds furniture entities such as sofas, beds, and tables into buildings. Select "Home Tab > Building Panel > Ej Furniture

Gallery", and the following dialogue will pop up.
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Furniture Gallery

Bathroon]
B MNew
€ Delete
K
L Clear
c Edit
5
T Import
Tea Table
Wardrobe

Mew

Children's Bath Crock

01

Closestool 03

Closestool 01

Closestool 04

Bathtub 03

Closestool 02

Add Object
Add File

Closestonl 05

1. Apply: Double-click or directly drag the furniture preview in the gallery to place at specified position.

Note: Previews that appear in grey in the gallery will automatically download if clicked. They can be placed on building
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floors only after the download is complete.
2. Edit the entity library list: right-click the furniture gallery list.
(1) New: Creates a new furniture gallery.
(2) Delete: Deletes the newly created furniture gallery.
(3) Clear: Clears all newly added furniture entities in the selected gallery.
(4) Edit: Renames the newly created furniture gallery.
(5) Import: Selects a folder and import the model files within.
3. Edit furniture gallery:
(1) Add Object: Right-click on a blank space in the furniture gallery, click "Add Object", and select an entity in the scene
to add.
(2) Add File: Right-click on a blank space in the furniture gallery, click "Add File", and select any *.cpi, *.fbx, *.skp,
*.08gb, *.0sg, *.obj, *.rvt, *.3ds format file in the pop-up dialog box to add the model files.

(3) Delete model: Right-click on a preview image, click "Delete" to delete the newly added model.

2.5 3D Operations Panel

2.5.1 Move

Moves selected entity according to X, Y, Z axes. Select "Home Tab > 3D Operations Panel > E Move'", select entities

other than roads, right-click to end the selection. Place the cursor on the axis, select axial direction, axial plane or axis center, drag

or enter a value to determine the displacement distance.
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Note:
(1) Roads cannot be displaced using spatial displacement, which is achieved by using the “M” move command.
(2) Default to local axes, which can be switched to global axes by entering “S” and press Enter on the command line.
(3) When the axis is selected, the entity can be moved in any direction.

(#) The default axis is at the center of the selected entity, and the axis position can be reassigned.

2.5.2 3D Rotate

Rotates selected entity according to X, Y, Z axes. Select "Home Tab > 3D Operations Panel > H 3D Rotate".
Note:
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(1) The default axes can be switched to
global axes by entering “S” and
press Enter on the command line.

(2) 3D rotation supports the selection of
entities other than single-sided
planes, building components, and
animation paths.

(3) Some entities support Z-axis rotation

only, except for lines, planes and
volumes.

() Can be rotated at any angle when cursor is placed on the inner circle of the axis; when placed on the outer circle of
the axis, it is rotated according to the screen plane.

(5) The default axis is at the center of the selected entity, and the axis position can be reassigned.

2.5.3 3D Scale

Scales selected entity in space according to axes. Select "Home Tab > 3D Operations panel > I ¥ 3D Scale"
Note:
(1) Default to local axes, which can be switched to global axes by entering S and press Enter on the command line.
(2) 3D scaling supports the selection of planes, bodies, background entities, vegetation entities, skeletal animations and
free-form modeled entities.

(3)If the cursor is placed at the center of the XYZ axis, all objects can be scaled as whole.

(4) The default axis is at the center of the selected entity, and the axis position can be reassigned.
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2.6 Al Effect

Generate different styles of Al images and videos based on the currently selected entity in the workspace.

roA

Select "Home Tab > Al panel > Al Effect' IS8l to open the dialog box shown below.

Al = o X

E =
Picure [ Source Tnage AT Inages™.

[Please enter the prompt word: | | Generate

Video
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1. Set Parameters: Click on the E@L button to open the dialog box shown below:

Set Parameters P-4

Number: }1 vi Base similarity:

Style
7i ; »b
- " 4 | | Localupload |

F . - R ]
Qil painting Sketch Anime
Background

(1) Number: Sets the number of generated images.

(2) Base similarity: Sets similarity to the base image.

(3) Style: Sets style. You can also click the “Local upload” button, select a local image to be the generated style.

(4) Background: Sets background. Among them, clicking the “Local upload” button, you can select a local image as the

generated style;

2. Pickup: Click on the “ " button, and select the entities from the workspace to generate the effect, right click to end

selection, and the selected entity will be displayed in the “Source Image” tab, as shown below:

Page 70 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

3. Generate: Allows inputting the prompt words. After setting the number, similarity, style, background, and prompts, you
can click the “Generate” button to generate the entities in the “Source Image” tab to Al effect image, and the result will

be displayed in the “Al Images” tab, as shown in the figure below:

4. Picture: The generated Al effect will be displayed in the “Picture” list at the same time. Double-click on a picture in the

list to view a larger version of it in the “Al Images” tab. Right-click on the picture list to bring up the following menu:

Al

I
o
X

u
W
=

Source Image | AI Images

-ty V[ N
GenerateVideo' 3]  Changes in light and shadow

Delete item Lens changes

Delete all
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(1)  Generate video: Changes in light and shadow: Generates an effect video with dynamic changes in light and shadow
based on the Al effect image.

(2) Lens changes: Generates a video of the effect of the dynamic change of the lens based on the Al effect image.

(3) Delete item: Deletes the selected effect image.

(4) Delete all; Deletes all images in the picture list.

5. Video: The effect video generated from the Al effect image is displayed in the “Video” list, as shown below:

Al - o X

S =S|

Pictun

Picture01

Double-click a video to view the corresponding video effect in the “Result” window. Right-click on the video under in the video

list to open the menu as shown below:
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Al Images

(1) Delete item: Deletes the selected video.
(2) Delete all; Deletes all videos in this list.

6. Exporting:

(1) Exporting Images: Select the generated Al effect image, click the =, button, select the save path in the pop-
up box, and click the “OK” button, the pop-up dialog box shown below:
Image Export Settings ot

Wide: pixel  High:| 1152 picel

Then you can set the width and height, and click the “Confirm” button to save the effect image in .png format to a local location.

=

(2) Exporting Videos: Select the generated Al effect video, click the ” button, select the save path in the pop-up

box, click the “OK” button to save the video in mp4 video format to a local location.
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3 Terrain

This chapter introduces a series of advanced terrain features, enabling users to more effectively manage and design terrain-

related content.

Houseplan 2.0 - [ Untitled1 |

Ter

ame e g View Scene ideo Services
i _ 5 L0713 G AN oen

vation Contour  Draw Fl enerate Defin onnect  Add Editable Delete Terrain  Flatten S| then Attach Terrain Generate  Import Import  TIF Export
nt- Llinev | Ground Terrain Terrain To Roads A Editable Area Stretch~ Terrain ain St Slope DEM  TIF  Image = DEM
Elevation Terrain Edit Import Export

3.1 Elevation Panel

3.1.1 DWG Elevation

DWG and DXF drawings containing elevation information can be imported into Houseplan. The software converts this data into

elevation points or contour lines, which can then be used to create terrain models. Select "Terrain Menu> Elevation Panel >

DWG Elevation" to open its dialog box.

DWG Elevation =
Select DWG:
Elevation data layer ELevation point entity type
Block
Text
Point
Drawing Units: Meter e
Confirm Cancel

1. Specify the path of DWG and DXF drawings in the dialog box, check the elevation data layer and the entity type of elevation
points, select the drawing unit, and click the “OK” button to start importing.

2. Parameter description:
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(1) Elevation data layers: Checked, import the layer; unchecked, do not import the layer.
(2) Elevation point entity type: Blocks, text or points can be imported and converted to elevation points separately.

(3) Drawing Unit: Drop down to select the drawing unit for the imported CAD drawing.

(1) Numbers, blocks, and point entities in DWG and DXF drawings are recognized as elevation points.

(2) Multi-segment lines in DWG, DXF drawings are recognized as contour lines.

DWG Elevation X

sectDwG: [V Rt DeiosBeraten e v []

Do
Einet
Fpont

3.1.2 Elevation Point

OFEB B E /| Undefined -

Home Terrain Insert Edit Modeling
[] L1 [ [2
DWG Elevation Zontour Draw Flat Generate Define Connect  Add Ed
Elevatior Point Line Ground  Terrain Terrain To Roads Are

in
|:| Create Elevation Point

EI Batch Convert Texts to Points

Calibrate Elevation Points

3.1.2.1 Create Elevation Point

Elevation points, marked with elevation values, are typically utilized alongside contour lings to convey elevation data for
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geomorphic features. They are created based on a specified location and elevation value. Select "Terrain Menu> Elevation Panel >

DElevation Point> DCreate Elevation Point". To set an elevation point, first determine the elevation value by either entering it
directly or typing S and pressing Enter on the command line to select an elevation point, contour label, or number text for the value.

Then, specify the location of the elevation point by either clicking on the desired location or entering the coordinates (x, y) manually.

3961 3193 2914
3% 3%@6%3%;2&2%57 o8l
32.% /g %%%5673
oot a1sE 3048 255
£33 FBB oy e

351478 =
o4
2673 Fo274

F3623,
F2324 2488 + T343l - =
E o4t 753 pag 316773106 —otas
- )70 73013 —Pp67 723142278
7B T sy T e TS
i —2346"‘_27'42 -3072 g 2095
276 *-‘2225840‘8 3 s F

2589
. F208!1 o
_;812;;—'149‘33* :22@55;
r
1797 1955 F2r07 o576 520297
Aded T pos3 F Feedllo 1803 1688

72089 7% -/ F705

2454 A5 FI1520

1884 20 . £1686 1549 F1567
= ~1792 L O¥:

B 77 ¢ 1354 F1555
e FI57 *_15215'1%1—5{]&51 413 71366

A3 #1785 1248 1360

F505

Note: The right property bar allows you to modify the parameters of elevation value, character height, angle and font of the

glevation point.

3.1.2.2 Batch Convert Texts to Points

Batch converts number text to elevation points. Select "Terrain Menu> Elevation Panel > DEIevation Point> Batch
Convert Texts to Points". According to the command line prompt, select the number to be converted to elevation points, right-click

to end selection, then select one of the numbers, directly specify or enter the coordinate value to determine the relative position of

the elevation point and text.
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768 857 839

7172
761 876
10P9 1044

878 997

1015 1009

1050 120 j1og

151
12 - 1204

Note: Locked objects in the underlay layer cannot be used as conversion objects, if you want to convert them, you can first

enable them, and then batch convert to points.

3.1.2.3 Calibrate Elevation Points

Calibrates the location of all elevation points. Select "Terrain Menu> Elevation Panel > DElevation Point>
Calibrate Elevation Points". According to the command line prompt, select the elevation point to be used as a representative, and
directly specify or enter the coordinate value to determine the position of the target point.

Note:

(1) The elevation points on the drawing are divided into two parts, the cross mark and the elevation figures, as follows:

100C
_|,

The elevation number is used to indicate the elevation value of the elevation point (such as the above figure, it means
the elevation of the elevation point is 10.00), and the center of the cross mark is the actual position (x,y) of the elevation
point. The elevation point created or imported will take the lower left corner of the elevation number as the position of
the elevation point by default, if this is not the actual position of the elevation point, you need to correct the elevation

point to the actual position.
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(2) This command corrects the position of all elevation points in the scene. If you want to modify an elevation point, you can

use the Move function directly.

3.1.3 Contour Line

/| Undefined

Insert Edit Modeling

B 3aE
DWG  Elevation Contour | Draw Flat Generate Define Connect
Elevation Point | Line Ground  Terrain Terrain To Roads
Elevation ain
Draw Contours

——| Define Contours

__1—_ | Generate Contours

__T—_ | Label Contours

3.1.3.1 Draw Contours

This function is used to draw contour lines. Select "Terrain Menu> Elevation Panel > Contour Line> Draw
Contours". According to the command line prompts, enter numerical values or select existing elevation points, numbers, etc. to

obtain elevation values, and draw contour lines in the form of polylines.

3.1.3.2 Define Contours
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Defines line entities as contour lings. Select "Terrain Menu> Elevation Panel > IE==|Contour Line> ==& Define Contours",
Enter numerical values or select existing elevation points, numbers, etc. to obtain elevation values, and select undefined line

entities to define as contour lines.,

3.1.3.3 Generate Contours

Generates contour lines based on the existing terrain and the differences in elevation between contour intervals. Select

"Terrain Menu> Elevation Panel > [E=liContour Line> <=8 Generate Contours". Contour lines are generated by selecting the
terrain and entering a value to determine the height difference between the contour lines. Enter Q on the command line to clear all

contour lines in the current scene.
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Note: Contour step difference refers to the vertical distance between two adjacent contour lines. For example, if you set the
contour step difference to 5, a contour line will be generated every 5 meters of elevation based on the terrain's height. Larger step
differences result in sparser contour lines and faster generation, while smaller step differences produce denser contour lings but

may take longer to generate.

3.1.3.4 Label Contours

Contours". According to the command line prompt, directly mark the elevation value of the contour line at the selected position, or

enter F to perform linear labeling.

e ———
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Note: Linear labeling, i.e., drawing line segments and marking the elevation values of the contour lines that intersect them.

3.2 Terrain Panel

Bl E

Draw Flat Generate Define Connect
Ground Terrain Terrain To Roads
Terrain

3.2.1 Draw Flat Ground

|—+
Draws horizontal terrain. Select "Terrain Menu> Terrain Panel > i Draw Flat Ground", Draw rectangular terrain directly or

type P Enter to draw polygonal terrain.

Note: The right property bar allows you to adjust the terrain display mode, the color of the accompanying layer, and if the

lowest point in the terrain is not on point 0, then the right property bar allows you to set whether or not to display the side slopes.

3.2.2 Generate Terrain

Generates terrain based on contour lines, elevation points. Select "Terrain Menu> Terrain Panel > Generate Terrain",

Select elevation points, contour lines, and after selecting the object, you can choose whether to delete the selected original data

according to the command line prompts, enter Y to delete the selected source data after generating terrain; enter N to retain the
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selected source data after generating terrain

Note: The terrain parameters can be adjusted in the right property bar, as described in “3.2.1 Draw Flat Ground”.

3.2.3 Define Terrain

Defines closed objects as terrain. Select "Terrain Menu> Terrain Panel > EDefine Terrain", Generate terrain by selecting

closed polylines, undefined surfaces, mesh surfaces or fox models, etc.

Note: The terrain parameters can be adjusted in the right property bar, as described in “3.2.1 Draw Flat Ground”.

3.2.4 Connect To Roads

Connects topography, planned land use, or undefined planes to the road in accordance with the road's elevation information.
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Select "Terrain Menu> Terrain Panel > Define Terrain". Selecting terrain that is tangent to the roadway so that it meets the

road.

Note: The terrain parameters can be adjusted in the right property bar, as described in “3.2.1 Draw Flat Ground”

3.3 Edit Panel

Bli M &

Add Editable Delete Terrain Flatten Smoothen Attach Terrain Generate
Area Editable Area Stretch  Terrain  Terrain Surface Slope
Edit

3.3.1 Add Editable Area

Defines editable areas on the terrain, allowing flexible control of the editing range to enhance the speed and efficiency of

terrain modifications. Select "Terrain Menu> Edit Panel > Add Editable Area", There are three ways to draw editable area:

1. Draw rectangular editable areas directly.

2. Type P to enter and draw the polygon editable area.

3. Type A Enter to generate editable areas for all selected terrain.

After drawing the editing area, follow the command line prompts to enter a value for the cell grid size. This completes the

definition of the editable area.
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Note:

(D Houseplan automatically calculates an appropriate cell grid size based on the terrain's dimensions, or users can set
their own value.
@ A smaller cell grid size allows for finer terrain edits but may slow down the generation and editing processes.
3 The cell grid size is displayed in the property column under Editable Area > Shapable 1. Multiple editable areas can
be defined for the same terrain, corresponding to Shapable 1, Shapable 2, Shapable 3, and so on, each with its own
adjustable parameter.

@ Other editing tools are only available when there is an editable area.

3.3.2 Delete Editable Area

Removes editable areas from terrain. Select "Terrain Menu> Edit Panel > H Add Editable Area", Select the editable area

to delete.
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3.3.3 Terrain Stretch

3.3.3.1 One-Way Stretch

Adjusts the height of the terrain within the editable area, allowing for quick shaping of the terrain. Select "Terrain Menu> Edit

Panel > 2] Torrain Stretch> Lo One-Way Stretch”, The dialog box

shown below pops up:
1. Parameter description:
(1) Range: Diameter of the area modified during stretching.
(2) Attenuation; The diameter of the area attenuated during
stretching.
(3) Strength: Speed of modification during stretching.
(4) Height: Maximum height of the terrain bulge when stretched.
(5) Direction; The direction when stretching, can choose up or
down.
2. After setting the parameters, click the “Stretch” button and drag the

mouse up or down in the editable area.
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Note: If there are sharp edges in the stretching process, you can adjust the cell grid size to make it smooth, see “3.3.1 Add

Editable Area” for details.

3.3.3.2 Two-Way Stretch

Stretches the terrain up and down in the editable area to adjust the height according to the size of the setup area. Select

"Terrain Menu> Edit Panel > Terrain Stretch> Lo Two-Way Stretch", The dialog box shown below pops up:

Two-Way Stretch 4

1. Parameter description:
(1) Range: Diameter of the area modified during stretching.

(2) Attenuation: The diameter of the area attenuated during stretching.
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2. After setting the parameters, click the “Stretch” button and drag the mouse up or down in the editable area.

Note:
(1) You can enter any value in the input box, and the number on the slider will follow the value in the input box.
(2) If there are sharp edges in the stretching process, you can adjust the cell grid size to make it smooth, see “3.3.1

Add Editable Area” for details.

3.3.3.3 Stretch Along Planes

Modifies the height of the terrain by dragging the plane area within the editable area. Select "Terrain Tab> Edit Panel>

Terrain Stretch> Stretch Along Planes", Click on an undefined plane on the terrain and drag the mouse up or down.
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Note: If there are sharp edges in the stretching process, you can adjust the cell grid size to make it smooth, see “3.3.1 Add

Editable Area” for details.

3.3.4 Flatten Terrain

Levels the terrain to the same height within the editable area to create flat

Flatten Terrain *
ground. Select "Terrain Tab>Edit Panel >mFlatten Terrain",The dialog box

@cirde (O Rectangle

shown below pops up:
1. Parameter description:
(1) Circle: Levels of terrain in the form of circular ranges.

(D  Range: The diameter of the area modified by the leveling.

@  Flatten Height: Sets the height of the terrain after leveling, e 1

1.00 5,50 10.00

Flatten Height:

or click on the blue font “Flatten Height” and click on any location in

the workspace to set the height of that point as the leveling height of

the terrain.
(2) Rectangle: Levels the terrain in the form of a rectangular range, as

shown below:
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Flatten Terrain *

(Oicirde (@) Rectangle

Length: 1
1.00 5.50 10.00
Width: |
1.00 5.50 10.00
Flatten Height:

Confirm

@  Length: The length of the area modified by the pushpin.

@  Width: The width of the area modified by the pushpin.

@  Flatten Height: Sets the height of the terrain after leveling, or click on the blue font “Flatten Height” and click
on any location in the scene to set the height of that point as the leveling height of the terrain.

2. After setting the parameters, click the “Confirm” button and click or drag the mouse in the editable area.

3.3.5 Smoothen Terrain

Modifies the terrain evenly within the editable area to make smooth fransitions. Select "Terrain Tab>Edit Panel>

Smoothen Terrain", The dialog box shown below pops up:
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Smoothen Terrain *

Brush  Range

Range 1

1.00 5.50 10.00

Strength | 0.50
0.00 1.00

1. Brush:
(1) Range: Diameter of the area modified during smoothing.
(2) Strength: Controls how much the terrain is changed during smoothing.

2. Range: Smooths the terrain by drawing a range, the dialog box is shown below:

Smoothen Terrain pe

Brush FRange

Strength | 0.50
0.00 1.00

Drag the slider to modify the smoothing intensity, click the “Draw” button, according to the command line prompts, there
are two ways of drawing

(1) Draw the range directly as a drawn polygon.

(2) Define the range: Enter D and follow the command line prompts to select an undefined plane or the horizontal plane,
or closed polylines. Hold down the left mouse button and drag to smooth the range. Adjust as needed, then right-click to finish

the command.
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Note: The cell grid size determines how smooth the terrain will be, the smaller the grid size the smoother the terrain will be.

3.3.6 Attach Terrain Surface

Aligns entities within the terrain either horizontally or directly to the terrain surface. Select "Terrain Tab>Edit PaneI>E

Attach Terrain Surface". According to the command line prompts, select the reference terrain and the landing object. There are two
ways to land:

1. When referencing the terrain, you can either directly select an entity to land it in a horizontal manner, or enter T and press
Enter to select the entity, which will then land attached to the terrain, following its contours.

2. When referencing objects other than the terrain, simply select the entity to land it horizontally.
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Note:
(D  Entities that can follow the terrain's contours when landing include roads, lawns, hardened grounds, library models,
undefined planes, and grid surfaces.

@  This command can be used with or without an editable area.

3.3.7 Generate Slope

3.3.7.1 Generate Slope

Shapes a sloping piece of terrain for entities within the terrain boundaries. Select "Terrain Tab>Edit Panel> '- Generate

Slope M=l Generate Slope". According to the command line prompt, select the entity to generate the berm, enter the values to

determine the slope and break width, you can generate the berm.
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Note:
@ Linear entities (lines, isochrones, labels), editable polygons, etc. do not support the generation of slope.

@  This command can be used with or without an edit area.
3.3.7.2 Generate Slope From Lines

Line entities on the terrain are selected to generate terrain with slopes according to the set parameters. Select "Terrain Tab>Edit

Pane| > ===l Generate Slope> : Generate Slope From Lines", According to the command line prompts, enter the values to

determine the slope and break width, select the undefined line, and specify the direction of the berm to generate the berm on the

specified side.

Page 93 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

3.4 Import Panel

|:||-:r-1 TIF BEH

Import Import  TIF Export
DEM TIF  Image DEM
Import Export

A Digital Elevation Model (DEM) is a 3D representation of ground elevation, created using an ordered numerical array. It is a
subset of the broader Digital Terrain Model (DTM), and various terrain features can be derived from it.

TIF terrain data is a raster image format widely used for storing terrain information. These files, with the extensions .tif or tiff,
comply with OGC specifications and are commonly referred to as GeoTIFFs. TIF terrain data usually includes height values, often

with 8-bit depth, and is frequently used for satellite imagery and terrain modeling.

3.4.1 Import DEM

Imports terrain files in DEM format in Houseplan and generate terrain. Select "Terrain Tab>Import Pane|>|mport DEM".
Select the DEM file to be imported and click the “Open” button.

GstarCAD 2020 Ma' ~ 1
GstarCAD 2020 Vs /
GstarCAD 2021 Ma
GstarCAD 2021 Vs #
GstarCAD 2022 Ma
GstarCAD 2022 SP1
GstarCAD 2023 Ma
GstarCAD 2024 Mar
GstarCAD 2025
GstarCAD Architect
GstarCAD Mechanic

Houseplan

File name: [newdem.des Dem Files (*.dem)

Note:

@ DEMis a digital elevation model that digitally simulates the surface topography with limited terrain elevation data.

@ The imported DEM file can be re-edited by the terrain function.
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3.4.2 Import TIF

Import terrain files in TIF format into the system to generate terrain. Select "Terrain Tab>Import Panel>|mport TIF".

Select the TIF file to be imported, click the “Open” button, according to the command line prompt, enter the value to determine the

rendering level, you can complete the TIF import.

Note: Terrain rendering level: Smaller values produce more detailed models, while larger values create more simplified models.

3.4.3 TIF Image

Applies TIF maps as materials to terrain. Select "Terrain Tab>Import Panel> = Import TIF". Select the TIF map to be

imported, click the “Open” button, according to the command line prompts, select the terrain, enter the value to determine the

rendering level, you can complete the TIF map.

19 T Image

52025011

Note: Terrain rendering level: Smaller values produce more detailed models, while larger values create more simplified models.
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3.5 Export Panel

3.5.1 Export DEM

Exports of terrain as a file in DEM/TIF format. Select "Terrain Tab>Export Panel >Export DEM", In the pop-up dialog box,

select the save location and save type, enter the file name and click the “Save” button to export.

194 Export DEM/TIF

Save as type: Dem Files (*.dem)

Note: When there is only one piece of terrain in the drawing, you are not prompted to select the terrain and the Export dialog

box opens directly.
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4 |nsert Menu

This chapter introduces the import and management of project underlay and data, as well as the project publishing and

exporting functions, which assist in creating a detailed and realistic rendering effect.
4.1 Import Panel

4,1.1 DWG Underlay

Imports DWG or DXF files to be used as drawing underlay for project design. Select "Insert Tab > Import Panel > DWG
Underlay" to open its dialog box.

DWG Underlay >

Select solution:

Result validity range:

Units used on original drawing:  Unidentificz | |Rescale

| Content within view anly
| original height
Do not import block
Do not import positive entities

Do notimport invisible entities

<Previous(F) Next{M) = Cancel(C)

1. Select: Click on the L= | button and select a DWG or DXF file to be imported.
2. Result validity range: Automatically calculates and displays the size range of all objects in the inserted drawing as a whole

image.

DWG Underlay X

Select solution:

C:\Program Files\Gstarsoft\Houseplanisample \dwg\Sal E]

[Result validty range: 40.12.,.728.34. |

Units used an original drawing:  Meters [IRescale

[] Content within view only
[ Original height
Do not import block
Do not import positive entities

Do not impart invisible entities

<Previous(P) | Next(N)> Cancel(C)
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3. Units used on original drawing: Automatically

DWG Underlay .
identify the unit of the imported drawing, which
Select solution:
cannot be directly modified. If you want to modify, C: Program Fies\Gstarsoft Houseplansample dg'Sa .. |
you need to click the “Rescale” button to activate the Result validity range: 40.12...%29.34...
unit drop-down list, and then you can adjust the unit. Units used on original rawing: |Meters | Rescale
Millimeters
L . . . o Centimeters
4. Content within view only: When checking this option, (] Content within =
ncnes
) o . | Original height |Feet
only the objects that are visible in the workspace Unidentification
Do not import block
when you save the DWG drawing will be imported, Do not import positive entities
otherwise, every object in the drawing will be Do not import invisible entities
imported.

Unit in DWG drawings is imported as meter

5. Original height: Check this option to import

<Previous(P) Next{M) = Cancel(C)

according to the original height of objects drawn in

the CAD drawing.
6. Do not import blocks: Block entities in CAD drawings will not be imported.
7. Do not import invisible entities: Entities that are frozen, closed, or on locked layers will not be imported.

8. After setting the parameters, click the "Next" button and the following dialog box will pop up.

DWG Underiay

Edit  Line/Plane Layer
[ = M

A - Defpoints

v ]  ARCH_DOORS

v O ARCH_WALL

v = ARCH_WINDOWS

m ] ARCH_FURNITURE
v - ARCH_STAIRS

v (] ARCH_FLOOR_LIVING

Check a layer to import as editable layer, otherwise import as
underiay layer

<Previous(P) Next(N)> Cancel(C)
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(1) Checkbox: You can check the drawing layers to be imported into workspace. Objects belonging to imported layers
are visible and ready to be edited. If you uncheck drawing layers, objects are visible and dimmed in the workspace,

those objects cannot be modified because they are locked.

DWG Underlay

Edit | Line/Plane Layer
= o

[ =]

’— = Defpoints

v [ ARCH_DOORS

v [ ARCH_WALL

& =

[ ] [ ARCH_FURNITURE l
v T ARCH_STARS

v ] ARCH_FLOOR_LIVING

i Check a layer to import as editable layer, otherwise import as|
underlay layer

e PTG e s e <Previous(P) Next(N)> Cancel(C)

(2) Import type: — imports objects that belong to a layer as polylings, ™ imports objects as planes or 2D surfaces.
Click the icon to switch between them, double click the icon to select all layers at once. Click the "Next" button to

start importing.

Properties
H Plane

DWG Underlay ’ (S

Custom color 255,0.255

Edit ‘ Line/Pane  Layer

0

Defpoints
ARCH_DOORS
ARCH_WALL

I— Building number offloors
v

vl

i
¥
v

Elevation

O
O
O
O
O
]
=]
=

ARCH_FLOOR_LIVING

Check a layer to import as editable layer, otherwise import as
underlay layer

Note: DWG supports versions 2002-2021.
4.1.2 DWG Layer Management
Manages imported DWG/DXF drawing layers. You can set storage, snap and hidden states of drawing layers that are currently
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turned off (not editable) and convert them into editable ones in workspace.

Select 'Insert Tab > Import Panel > 444 DWG Layer Management"

DWG Layer Management

| ] ] =
Underlay layer: Converts to a solid layer:
Layer Stcrrage| Snap | Hide | Layer
I_ Awming . |7 . |7 . I_ 0
[ Baleony [ I r [ Internal Road
[~ Buildin [v [¥ r [ R
[ Colunn [ ra r Railing
[ Text
I_ Water Ponl

1. Underlay layers: Displays the name, storage, snap and hidden status of imported DWG file.
(1) Storage: Sets whether the underlay layers can be saved.
(2) Snap: Sets whether the underlay layers can be snap.
(3) Hide: Sets whether the underlay layers can be displayed.
Note: Double click any checkbox to select the corresponding column at once.

2. Underlay layer check box: Check a layer name to make it visible in workspace but not editable.

- R e e ]
s = 4 (0] [=
01 o] o o :
e 1T e
| | Layee
[T ARCH_DOORS
[T ARCH_FLOOR_L
ARCH_STAIRS
()
e =
0o | . =
== ' = L1 | Wndertay tayer:
| f | || St
[ ARCH_DOORS
[~ ARCH_FLOOR_L
{ ARCH_STAIRS
-
=
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3. Convert to editable layer: Check a layer name in the list to later convert into not editable.

4. Click ™ button to start layer conversion. Check the layer name whether is located (Underlay layer or Convert to

editable layer list), in the conversion process, click the button again to abort.

DWG Layer Management X |DWG Layer Management X
|4 @] = s 4B =
Underlay layer: Converts to a solid layer: Underlay layer: Converts to a solid layer:
Layer Raopejeijcide (X ‘ Layer Storage  Snap  Hide iuyu
[ ARCHDOORS [ [ [ | |[™ ARCH_FURNITURE [ ARCH_DOORS  |v ¥ T | |[T ARCH_FURNITURE
Cimsmmy £ H o B
[TARCH.STAIRS [v [ [ [~ ARCH_STAIRS [~ ©
[~ ARCH_WALL W = ARcHwaLL [
| v’ ARCH_WINDOWS |2

5. Click -F | button to move objects belonging to a selected layer to specific position in workspace.
6. Click ™ ' button to delete all DWG layers keeping the editable layers visible in workspace.

7. Click = ' button (it is recommended to uncheck all underlay layers to see the selection effect), select any object in

the workspace, the corresponding layer will be located and selected in the dialog box.

4.1.3 Merge Projects

Merges other *.cpi files into current project. Select the "Insert Tab > Import Panel > Merge Projects" to open the
following dialog box.

Merge Projects

File: |

Original coordinate Specify coordinate

Click the LI button and select the CP! file to be merged.

Original coordinate: Inserts the file according to original coordinates stored.

Specify coordinate: Inserts the file according to the specified coordinates.
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4.1.4 Other Formats

Inserts files in different formats into Houseplan 2.0 to be used as design references.

Select "Insert Tab > Import Panel > B Other Formats" to open the dialog box shown below.

‘ Hou.. > House...
i Organize ~ New folder
i‘\_ H M Desktop

E Documents o )

= 3 iamond+Cabin.skp

S Downloads [l 5‘3 House+16x16x6.skp

@ Music obj (1).0bj

& Pictures B objobj

A i ® videos . pcm-housed.xyz
1 —— 1 —=) = Local Disk (C) . testSample.rcp
File name: \ vl i—é"(”)
all(*.*)
JPG(*jpg)
BMP(*.bmp)
PNG(*.png)
FBX file(*fbx)
SketchUp file(*.skp)
OSGB file(*.osgb)
0OSG file (*.0sg)
ile (~obj)
Z_X

dem (*.dem)

1. Select *.jpg, *.bmp, *.png type files, and specify the insertion location.
2. Select *.fbx file, there are two ways to insert them; Insert at specified position or Type Y to insert by original coordinates.

3. Select *.osgh, *.0sg, *.obj, *.3ds type files, , click the "Open" button to open the dialog box shown below.

Import Settings

Scene Units: Meters

(1) Scene Units: Display the current drawing units.
(2) File Units: Set the units of the drawing to be imported.

4. Select *.skp file, click the "Open" button to open the dialog box shown below.
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(1) Import hidden objects: The option is

checked by default, hidden components will

Import hidden objects

be created and imported; if unchecked,

hidden components will not be imported. []import the two-sided model

[ ] Import Edges/Profiles

(2) Import the two-sided model: If checked, the

front and back sides of the skp model will be

created and imported: if unchecked, only one
side of the skp model will be analyzed,
created and imported.

(3) Import Edges/Profiles: If checked, the edges and profiles of the skp model will be created and imported; if unchecked,
the edges and profiles will not be imported.

5. Select *.rvt file, and click "Open" button to import it.

'

6. Select .tif file, click "Open" button, and follow the command line prompts to enter a value to determine the rendering level

to complete the TIF import.
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7. Select *.dem file and click "Open" button to import it.
Note:
(1) The imported osgb data is model data. To import oblique photography data, please use the "Oblique Photography”
function.
(2) Import version description: SketchUp supports up to version 2023;Revit supports up to version 2024;Fbx format
supports up to version 2022.
(3) For the first import of the rvt format model, you need to be in a networked state and apply for permission from the
SErver.
(4) The tif file is imported with the mapping render level, the smaller the value, the clearer the mapping; the larger the
value, the blurrier the mapping.
(5)DEM is digital elevation model, which enable the digital simulation of ground terrain from limited terrain elevation

data.
4.2 Imagery Panel

4.2.1 Oblique Photograph

Imports oblique photography data or merge it into the current project. Select "Insert Tab > Imagery Panel > Oblique

Photograph" to open the dialog box shown below.
1. Import: Right-click on the blank space to

open the context menu, click "Import" to Oblique Photograph

open the dialog box shown below. Click Project Path
Please right dick to import pro...

the "= button to select the oblique
photography file, click the "Original

coordinate" button to import the scene Oblique photography: [.]

according to the in-situ coordinates; click
Criginal coordinate Spedfy coordinate

the "Specify Coordinate" button to import

the scene according to the specified
coordinates.

2. Right-click on the layer node name to open the context menu, as shown above.
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(1) Rename: Change the name of the project.

Note: Naming rules: after

) . Oblique Photograph
importing, all data are added

h sk data" i Project
the  skew ata’ - prefix -] Oblique photography data...
followed by sorting numbers, Rename
Delete
from 1, 2, ... The name in Positioni
asitioning

brackets reads the name of

the oblique  photography Import

folder, and the name cannot

be changed.
(2) Delete: Delete the imported
oblique data and retain the source files.
(3) Positioning: Click "Positioning" to locate this oblique data in the scene.
Note:
(1) Only oblique photography project data of osgb files with the same name as the sub files under the path is
supported (eg:Tile_1 /Tile_1.0sgb).
(2) After importing a project, you need to specify a new path when the path is invalid. When it is invalid, the path

location is displayed in blue.

4.2.2 Point Cloud Data

This function imports point cloud data (collection of vectors in a 3D coordinate system) into Houseplan 2.0.

Select "Insert Tab > Imagery Panel > B Point Cloud Data" to open the following dialog box.

Point doud data:  F:'Downloads'Point Cloud Data |

Dilute ratio: 30

Original coordinate Spedify coordinate
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1. Point cloud data: Click on the D button to select a file in *.las format.

2. Dilute ratio: The ratio of the number of data points to be reduced during the point cloud data processing. The larger the
value, the greater the number of data points and the slower the transformation process; the smaller the value, the smaller
the number of data points and the faster the transformation process.

3. Original coordinate: Click on the "Original coordinate" button to import the scene according to the original coordinates.

4. Specify coordinate: Click the "Specify Coordinate" button to import the scene according to the specified coordinates.

Note:

(1) After inserting the point cloud data, when using this function again, if the dilution value is the same as the last value,
it can be directly inserted into the scene in in-situ coordinates or the specified coordinates; if the dilution value is
changed, the data needs to be converted again.

(2) Dilution ratio range:1-100.

4.2.3 Data Classification

A large amount of model data is automatically classified, and the number of data files after classification is significantly reduced
and more organized. This function can solve the problems of low loading efficiency and high consumption of scene rendering when

users process large batches of data.

Select "Insert Tab > Imagery Panel > Data Classification" to open the dialog box shown below.

Data Classification

Destination Path: C:/Users/administrator, CTPDN | ,,, | Data Source: F:/DownloadsManual Data
= HExdusi.\r?_h’llla_Project o —
gs:gﬂggn Manual Data_DX
Bl river channel Manual Data_HX
Eroad Manual Data_1Z
B Terrain Manual Data_ZW
[ sprite

Compile Exit

Right-click in the margin to open the right-click menu, as shown below.
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Data Classification

Destination Path: Data Source:
Select Data source
Right dlick to create new projects
Create new projects
Import projects
Compile Exit

1. New Project: Click on "Create new projects" and the following dialog box will pop up.

Data Classification

Destination Path:

Data Source:

Right dick to create new projects

Project name:

Save path:

Exdusive_Villa_Project

Select Data source

F:/Downloads Manual Data [I]

Enter the project name, select the save path, click the "Confirm" button, and five layers will be automatically created,

as shown in the figure.
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Destination Path: C:/Users/Administrator, CTPDN Data Source:

(=R~ Exdusive_Villa_Project
B Building
ﬂ\u‘egemion
B river channel
Broad
Terrain
B sprite

Select Data source

Compile Exit

The checkbox controls the display and hiding of that layer.

2. To open the compiled data, select "Import Project”, which brings up the following dialog box.

Data Classification

Destination Path: C:/Users/Administrator. CTPDK |, Data Source:

= B Exdusive_villa_Project Salect Data source
B Building
H\iegeiaion
B river channel
BElroad

B Terrain
B sprite Artificial models: C:YUsers\Administrator, CTPDMUM D

Original coordinate Specify coordinate

After selecting the compiled project.zml file, click the "Original Coordinate" button to insert the scene according to
its original coordinates; click the "Specify Coordinate" button to insert the scene according to the specified coordinates.

3. Right-click on the layer node name to open the context menu, as shown in the following image.
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(1) Rename: Changes the name of
the project.

(2) Delete: Deletes layers, retain
local source files and data can
be restored after deletion.

(3) Positioning: Locates the item
location in the scene.

4, Compilation process.

Destination Path: C:/Users/Administrator, CTPDM

Data Source:

=l -~ Exdusive_Villa_Project
B Building
H'u'egemiun
Eriver channel
Eroad
ETerrain

B sprite

Rename

| Select |

Delete

Paositioning

(1) Right-click on a new project in a blank space in the compiled data area.

(2) Import the data source, click on the L+

button and select the source data to be compiled.

(3) Select the compiled data layer and then check the corresponding data source in the table on the right to map the

layer to the data source.

(4) Click “Compile” button to compile the current layer data.

Note: The data source needs to save as osgb files for buildings, plants, rivers, roads, terrain, and vignettes in a scene separately.

4.2.4 Orthoimagery

Resamples the distorted drawings to a new correct orthoimage. The original remote sensing image with distortions is

resampled in grayscale according to the correct geometric relationship. Select "Insert Tab > Imagery Panel > Orthoimagery

" to open the dialog box shown below.

Orthoimagery

Mame

Mew

Result path

Compile
Import
Fename
Positioning

Delete
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1. New: Right-click on the blank space to open

Show I Name l Result path

the context menu, click "New", and the ﬁ

following dialog box appear. After entering the

Name:

image data name, click the "Confirm" button to

Cancel

create new image data; click the "Cancel"

button to cancel the operation and close the

dialog box.
2. Right-click on the data list to open the context menu, as shown.

(1) Compile: Click on "Compile" and the

following dialog box will pop up.
(1) Path: the path of the generated e
. Data Source:
project.
(2 Data source; the original data path. Terminated
Click the " button, select the result

path and data source, click the "Compiling"
button to start the compilation; click the "Terminated" button to terminate the compilation.

(2) Import: Click on "Import" to open the dialog box shown below.

Import The Results

Outcome path :

Criginal coordinate Specify coordinate

Click the " button to select the generated result, click the "Original coordinate" button to insert the scene
according to the original coordinates; click the "Specify coordinate" button to insert the scene according to the specified
coordinates.

(3) Rename: Changes the name of the image data.

(4) Positioning: Locates this image data in the scene.
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(5) Delete: Deletes the current image data.

Note:

(1) When selecting the already generated results for import by clicking on the " button, they can only be
imported in the in-situ coordinates.
(2) Check Show to show the data in the scene; uncheck Show to hide the data in the scene.

(3) The source data for the orthogonal projection are in tif, jpg format (with coordinates).

4.2.5 Flatten Oblique Image

Flattens selected area of an oblique photography. Select the "Insert Tab > Imagery Panel > Flatten Oblique Image" item,

and there are three types of flattening.
1. Define the flattened area by drawing polylines.
2. Define the flattened area by typing “S” and press Enter to draw 3D polylines.
3. Define the flattened area by typing “D” and press “S” to select closed line or plane.
Note:
(1) When drawing a horizontal area, the horizontal plane is formed at the height of the first point at the time of drawing
and is flattened according to the drawn outline.
(2) When drawing a three-dimensional area, a plane is defined by the first three points and flattened according to the
drawn outline.
(3) When defining the flattening area, flatten the image by the outline and height of the selected object.
() Define the flattened area to be less than or equal to the flattened image area, less than the image base outline, and

the bottom of the image must not be overhanging.
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Atter flattening, select the oblique photography model in the scene and click on the "' button after the "Flattened Area" field
in the properties bar to open the dialog box shown. The dialog box shows the names of all the flattened areas. Select the name and
the corresponding flattened area in the scene is highlighted; double-click the name to quickly locate the selected area. Right-click
on the name to open the context menu:

1. Delete: The selected flattened area is deleted and the oblique

photography data for that area is restored to its pre-flattened state. Hame
277 |
2. Delete all: All flattened areas are deleted and the oblique photography Delete
) , . . Delete all
data in the scene is restored to its original state.
Rename
3. Rename: Modifies the name of the flattened area.

4.2.6 Oblique Data Filter

Deletes or saves oblique photography area according to different cutting methods. Select "Insert Tab > Imagery Panel>

B Oblique Data Filter" to open the following dialog box.

Oblique Data Filter

0 I & R Height: |Permeate

Save selected as Delete selected Delete unselected

1. There are four ways to draw the edit range:
(1) Rectangle: Click = hutton to draw a rectangular editing area.
(2) Polygons: Click 2 button to draw a polygon editing area.
(3) Circles: Click © button to draw a circular editing area.

(4) Select: Click ™ button to select a graphic as the edit area: the selected drawing can only be a line or volume.

Note:
(1) The editing area can be adjusted in extent by dragging and dropping the clip point and its position can be
moved.

(2) When a custom editing area is selected, the volume of the original reference is removed and a new editing area
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is created, and the new editing area is also dragged with clip points.
(3) Only one editing area can exist in the scene, and when a new editing area is drawn, the last one is automatically
deleted.
2. Permeate; Draw a planar edit area that includes all data on the plane and in the infinite mapping range above and below the
plane.
3. Automatically pick: Draw an edit area and picks the highest point in the range as the model height to generate a 3D edit
area.
4. Height: When drawing an edit area, if a height value is manually inputted, the 3D edit area is generated with the given value.
5. Delete Selected: The original data within the edit area is deleted and the scene is loaded with the remaining data.
6. Delete Unselected: The original data outside the edit area range is deleted and the scene is loaded with the remaining data.

7. Save As Selected: The data within the edit area is saved separately, and the original data is retained.

4.3 Qutput Panel

4.3.1 Publish

Creates an .exe file that can be executed independently, and can realize video roaming , environment changing, and properties

display. Select "Insert Tab > Output Panel > Publish" to enter the Publish Preview screen.

1. Menu: hover the cursor at the bottom to show the menu; move cursor away to hide the menu, as shown above.
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(1) Gallery: Click the "Gallery" button to turn on/off the left side gallery. When the gallery is on, hover the cursor on the
left side of the screen to show the gallery; move the cursor away to hide it. Click on any video within the gallery to

roam or position to the appropriate viewpoint.

Interactive simulation publishing

Start Roam

[ZIO%
o M B Ao

(D) Click on the =] button to set the path roaming parameters.

() Click on (] button to preview the view of the path.

(3 Click on button to draw grounded paths in the publish scenario.
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(@) Click on EI button to stop preview the view of the path.
(5 Click on EI button to pause the previewing and click again to continue the previewing.

() Click = button to clear the drawn grounded path or the path being used in the gallery.

(3) Effect Environment; Manage the environment effects in the publishing scene. For more details, see the "Scene Tab >

Environment Panel > Environment" function.

Clear sky Sunrise Sunset Rain

Lighting

Efect parametér

Night vision settings

Night vision settings

Light up type: @ Enclosed Balcony 8 Glass Door

@ Glass Window @ Light Strip

Lighting rate: 4 v ]

Brightness: 40

(1) Weather: Double-click on a weather image to apply the corresponding weather effects.

(2) Lighting: Set the shadow effect in the scene and adjust the azimuth and altitude angle parameters of the sun.
When shadows are on, adjusting the azimuth and altitude will affect the effect of the shadows.

(3) Effect Parameters: Click on the "Effect Parameters", you can modify the parameters of Solar, ambient, fog
effect, volumetric light and HDR to enhance the ambient effect.

(@) Night vision settings: The lighting category, lighting rate and brightness can be modified separately to adjust
the lighting effect in night mode.

(4) Properties: Click the "Properties" button to turn on/off the properties column on the right side of the screen. Click one
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element of the building and the properties column will display related information.

AW \ \\\\\\‘\\\“\“l\\“\l

L T ’

(5) Data Management: Specify

Data -~ -~2ment

the path to correctly load

the oblique photography

data in the scene.
(6) Publish: Click the "Publish"

button to package the file and save as .exe (executable application).
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<« > ™ 7 « Des... > Newf... v C Search New folder

Organize v New folder

Date modified

| v mispC

No items match your search.

> £ Desktop
> &) Documents

> _»L_ Downloads

File name: | Sample0l.exe

Save astype: Publish type(*.exe)

A Hide Folders Cancel

2. Context menu: Right-click in the scene to open the context menu.

Orbit(0O)
Eye view(D)
Full view(A)
Pan(P)

View control(J)

i
r.9

A RGNS

¥ '

o Previous view(l)

Front face(F)
Window view(W)

W e P

(1) Orbit: Dynamically moves the observer around the model while maintaining the same focus point. Pressing “Ctrl +

middle mouse wheel” enables orbit view as well. If you have an entity selected and then use this function, the view
is rotated with that entity as the center point.
(2) Eye view: Turns on human eye view perspective. Press and drag the left button in the scene to view around by human

perspective.
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(3) Full view: Displays all entities in the workspace to the maximum extent possible.

(4) Pan: Moves the position of the view without changing the position or scale of the objects in the drawing. Press and
hold the middle mouse wheel enables Pan operation as well.

(5) View control: Switches current workspace 3D perspective view from different
directions. Click on the corresponding blue arrow to set the view direction,
and click on the "Plane" button in any view, the view will turn to the plane

state.

(6) Previous view: Returns to previous view performed.
(7) Front face: Selects the plane on the volume to display its front view.
(8) Window view: Maximizes the display of selected area, and enables full display and return to the previous view.

3. Title: Double click on the title in the top left corner of the scene to open the dialog box shown below.

Interactive simulation publishing House DeSign Motion

Edit Title

Text: House Design Motion

Font: Microsoft YaHeilUl v /

Textheight: 32

Color:

(1) Text: Set the title name.
(2) Font: Sets the font of the title.
(3) Text height: Sets the size of the font.

(4) Color: Set the color of the font.

4. Full-screen: Click the . button in the upper right corner to enter full screen, and press Esc to exit. Double-click the left
mouse button to enter or exit full screen; in full screen, hover the cursor at the top to show the title bar; title bar will be

hidden after the cursor moves out of it.
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5. Minimize: Click on the = button in the upper right corner to minimize the software to the taskbar.

6. Close: Click the button in the upper right corner to exit the publishing scene and return to the software scene.
Note:
(D) A gallery is a collection of highlights and video paths saved in a scene.
(2) The gallery does not show highlights saved under the axonometric view. The highlights and roam paths are saved
with the associated environment scene.
(3 It's necessary to resave the gallery after modifying the scene to update the preview image.
() Labels for particle entities in published scenarios and in published .exe files will be automatically hidden.

(5) Page Up/Page Down allows you to switch the gallery.

4.3.2 Export

Exports the follow file formats; *.dwg, *.bmp, *. jpg, *.png, *.0sgb, *.fbx, *.skp, *.3ds, *.obj. Select "Insert Tab > Output

Panel > Export" to open the following dialog box.
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Exporting
< > v ¢ Des., » Newf.. w &) Search Mew folder o
COrganize « Mew folder = - a
Mame Date modified Type
~ [ This PC
i Untitled3.dwg 2023/9/12 9:28 Auto
> Gl Desktop |
> é Documents
> i Downloads
File name: | Samplell.dwg >
Save as type: [ Aute CAD file (*.dwg) w
Auto CAD file (*.dwqg)
30 Studio (*.3ds)
# Hide Folders FEX file (*.fbx)
JPEG Image (*,jpg) J

OB file(*.obj)

~ |PMG Image (*.png)

SKP file (*.skp)

Windows BitMap (*.brnp)
osgh(*.osgh)

ol o

1. Select the *.dwg format, click "Save" button and select the CAD

version to export. Export Settings

2. Select the *.3ds, *.fbx, *.obj, *.osgh formats, click "Save"
Scene Units: Meters

B Model Centered

button, and the following dialog box will pop up.
(1) Scene Units: Display the current drawing units.
(2) File Units: Set the units of the drawing to be exported.
(3) When Model Centered is checked: The model | Change Origin

coordinates will be centered. That is, the coordinates of Exit

the center point at the bottom of the model bounding box

are set to (0,0,0) for exporting.
(4) When Change Origin is checked: The model origin is changed, and the specified point is set as the origin of the
model.

(5) When both Model Centered and Change origin are unchecked: The origin and model position will not be changed,
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and the model will be exported according to the actual position in the current drawing.
Note: Model Centered and Change origin options are mutually exclusive, only one can be checked, or both are unchecked.
3. Select *.bmp, *.jpg, *.png format, click "Save" button, and the following dialog box will pop up.

(1) Output size: Sets the width and height of the exported

Image Export Settings

image in pixel. _ o
Output size Maximum size
. . . \ ) Wide: EEE ixel Wide: 4096 pixel
(2) Maximum size: The system will display the maximum o —_—
High: 712 pixel High: 4096 pixel
pixels of the exported image supported by the system. frEreeEs CrerEsEE
59.8cm¥ 25, 1cm 144, 5cm¥ 144, Scm
(3) Watermark pattern: S
. . | Watermark
(1) Watermark: If checked, exported image will have _
Tile Spacng X |10 Yy |10
Watermark. Watermark
(2) Tile, spacing: Select "Tile" to display the watermark fransparency
. . Confi G |
pattern according to the default spacing; select o

"Spacing" to display the watermark pattern

according to the specified spacing.

(3) Watermark image: Click on the | *** ' button to select an image in

*.bmp or *.jpg format as the watermark image.

(@) Transparency: Drag the slider to set the transparency of the Ei::i:nmiom — 5
watermark image, 1 is opaque, 100 is fully transparent. Uit
(4) Click the "Confirm" button to export the image in the appropriate format. Unit_commom e .
4. Select *.skp format, click "Save" button, and the following dialog box will pop o & Model Centered
. S

| Change Origin
(1) Export Version: Select the exported .skp file version's standards.

Cancel

(2) Unit Conversion: Convert units when exporting to keep the same units L

as in SketchUp.
(3) Model Centered: When checked, the exported objects will be automatically centered to the origin coordinates.
(4) Export Line: Exporting lines, spline.
(5) Ignore Material: Exported models without materials.
(6) Change Origin: When checked, the model origin is changed, and the specified point is set as the origin of the model.

Note:
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(Dlfafile in *.dwg, *.osgb, *.3ds, *.obj, *.skp or *.fbx format is selected for exporting, the entities in the background
layer of the current drawing are not exported.

(2) When exporting renderings, it is recommended to turn on "Anti-aliasing, Shadow, Light Projection".

4.4 VR Panel

441 VR

With Houseplan 2.0 and VR devices, users can immerse themselves in the 3D scene they have created, realizing a real-time
virtual scene browsing experience that allows them to observe in detail from different perspectives.
Before using the VR tool, please make sure that the SteamVR application has been installed correctly on your computer, and

that the SteamVR program and the VR device are turned on and connected to the same network, and then select "Insert Tab > VR

Panel > m VR" to open the following dialog box:

0 Start VE/AR,

Click the "OK" button to enter the VR scene. And click the "VR" function again to end the VR browsing.

Controller operation:

1. Teleport: Press and hold the trigger located in front of the controller. Once the green light illuminates, direct the light towards
the desired target point, then release the trigger to initiate teleportation

2. Recenter: Press the controller side button to return to the initial position;

3. Directional control:

1) Move forward/backward: Hold the controller horizontally and push the controller's joystick forward/backward;

2) Pan left/right: Hold the controller horizontally and push the controller's joystick left/right accordingly;

3) Move up/down: Hold the controller vertically and push the controller's joystick forward/backward to achieve the desired
movement;

The aforementioned operations are demonstrated using the controller of the Quest 3 headset as an example. Operations for
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other headset are similar to those of the Quest headsets
Note:
Houseplan 2.0 currently supports VR devices such as Quest and HTC. For detailed information on how to use the device and

its controller, please visit the official website of the respective VR device.
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5 Edit Menu

This chapter introduces the basic features of modifying the amount, size, shape, and position of model outlines. Using these

features can help the user easily improve the effects of the project.

5.1 Modify Panel

5.1.1 Copy

Copies an object to specified distance and direction. Select "Edit Tab > Modify Panel > hat Copy", select the object, specify

the base point and target point, and copy continuously.

5.1.2 Cut

Copies an object to clipboard and cut. Select "Edit Tab > Modify Panel > E Cut" and select the object to cut.

5.1.3 Paste

Inserts an object from clipboard into workspace. Select "Edit Tab > Modify Panel > Paste" and there are two ways to

paste. You can insert the object directly at the designated position or Enter “Y” and press Enter to insert at the original coordinates.

5.1.4 Erase

Deletes a selected object. Select "Edit Tab > Modify Panel > Erase".

5.1.5 Move

i Move" to select the

Moves an object to the specified distance and direction. Select "Edit Tab > Modify Panel > ;
object. There are two ways to move it.

1. Move directly by the global coordinate system: selecting the object and specifying the base and target points to move.

2. Enter “M” and press enter, select the reference plane, select the entity to be moved, and specify the base and target points

to move along the reference plane.

5.1.6 Rotate
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o+

Rotates an object around at specified base point. Select "Edit Tab > Modify Panel > 'L___,-' Rotate", select the object, specify
the base point. There are two types of rotation.
1. Rotation is accomplished by directly specifying or entering a value to determine the angle of rotation.
2. To rotate the entity at a reference angle, enter “R” and press enter.
(1) After directly entering a value to determine the reference angle, specify or enter a value to determine the new angle.
Note: The angle at which the final entity is rotated = new angle - reference angle.
(2) Specify the angle to determine the reference angle, such as: specify the base point ¢, specify the reference angle
after the first point a, specify the second point b, specify the new angle with reference to a point @ on the edge, and

rotate the edge ab to be parallel to the edge cd. The effect is shown in the following figure.

L
Befaore £
b

d

Aft
= Beference

5.1.7 Scale

Scales selected object, keeping the proportion of the object unchanged after scaling. Select "Edit Tab > Modify Panel > H
Scale", select the object, specify the base point. There are two ways to zoom in.
1. Scale by directly specifying or entering a value to determine the scaling ratio.
2. Scales the entity by the reference length. Enter R and press enter.
(1) After entering a value directly to determine the reference length, specify or enter a value directly to determine the new
length.
(2) Specify the length to determine the reference length, such as: specify the base point ¢, specify the reference length
after the first point a, specify the second point b, specify a point d on the reference edge to determine the new length,

and scale the ab edge to a length equal to the cd edge. The effect is shown in the following figure.
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b
Lfter Before Reference

Note: Scale factor = new length / reference length, example; enter 0.5 to reduce to 0.5 times the original length.

5.1.8 Mirror

Creates a mirror copy of selected object. Select "Edit Tab > Modify Panel > Mirror", select the object. If you enter “N”,
after mirroring, the source object is not deleted; if you enter “Y”, after mirroring, the source object is deleted. There are two types of
mirroring.

1. Mirroring by direct reference to the line joining the two specified points.

2. Type “Z” and press Enter to use the Z axis as reference.

The effect is shown in the following figure.

S

P

Before After

5.1.9 Offset

L
Creates concentric circles, parallel lines and isometric curves of selected object. Select "Edit Tab > Modify Panel > I.'J=
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1. Specify directly or enter a value to determine the offset distance: Select the object to be offset and specify the point to
determine the side on which the offset is to be made.

2. Make the newly generated line entity pass through the specified point: Enter “T” and press enter, select the object to be
offset, and then specify the pass-through point.
9.1.10 Trim

Trims intersected 2D objects. Select "Edit Tab > Modify Panel > = Trim", first select the boundary line, then select the
object to be trimmed. The effect is shown in the following figure.

EBoundary line
4’//Tmn object [

»

~

1

Before

After

You can also select multiple line entities with intersection points at the same time, and then select the object to be trimmed.
The effect is shown in the following figure.

i . .
+ Trim object
b
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Before After
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Note:
(D Trimming objects can be line segments, polylines, arcs, clouds and splines.
(2) Trimming can only be successful when the selected line intersects with the boundary line.
5.1.11 Extend

Extends the selected boundaries or edges. The objects are extended so that the edges of other objects can be converged.

Select "Edit Tab > Modify Panel > Extend" item, select the boundary line, and then select the object to be extended. The

effect is shown in the figure below.

— Extension line —

Before After

You can also select multiple line entities with intersection points at the same time, execute the Extend command and select

the object to be extended. The effect is shown in the following figure.

Extension line —

Before Lfter

Note:

(1) Extension objects can be line segments, polylines or arcs.
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(2) The extension can only be successful when the extension of the selected line has an intersection with the boundary

line.

5.1.12 Break

Breaks the selected object between two points. You can create a gap between two specified points on an object, breaking it

into two objects. Select "Edit Tab > Modify Panel > Break", select the object, use the clicked position as the first break
point, and then specify the second break point; to re-designate the first break point, enter “F” to specify the first and second break
points to break.

Note: The supported line entities are line segments, polylines, arcs, clouds, splines, and ellipses.

5.1.13 Stretch

Stretches objects crossed by a selection window or polygon. Objects that are partially enclosed by a crossing window are

stretched. Select "Edit Tab > Modify Panel > [ Stretch", select the 2D object to be moved or stretched, specify the base point

first, and then the second point. The effect is as shown below.

10?02ﬂ7
C=o@=0C__ O

Before After

Note:
(1) Box select one or more points of a line entity to locally stretched.

(2) Point or box select the entire line entity to move it as a whole.

5.1.14 Fillet

Adds rounded corners to intersected 2D objects or volume. Select "Edit Tab > Modify Panel > Fillet".
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. Rounding the corners of the 3D

volume is generated by selecting
the edges of the 3D volume; The
effect is shown in the following

figure.

. Type “R” and press Enter to set the

radius of the rounded corner.

5.1.15 Chamfer

. Rounding of line entities: Selecting two non-parallel lines, set radius of the rounded corners.

Before

After

Adds chamfers to intersected 2D objects or volume. Select "Edit Tab > Modify Panel > Chamfer" item.

1

. Chamfering intersected 2D

objects, selecting two non-
parallel lines, generated at the set

chamfer distance.

. Chamfering of 3D volume is

generated by selecting the
chamfered main plane and

chamfered edges.

5.1.16 Smooth

Before

. Enter “D” and press Enter to set the chamfer distance.

Lfter

Converts a polyline into a spline. Select "Edit Tab > Modify Panel > ! Smooth" and select a polyline.

5.1.17 Explode

Decomposes selected objects. Select "Edit Tab > Modify Panel > ﬂ Explode" and select objects to explode.

Note:

(1) Break into planes when the selected object is a volume.

(2) Break into lines when the selected object is a plane.
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(3) Break into line segments when the selected object is a polyline.
() Selecting a spline converts it to a polyline.

(5) Select grouped entities to Ungroup.

9.1.18 Array

5.1.18.1 Array Copy
Quickly generates multiple copies of objects or other components by a set distance or number. Select "Edit Tab > Modify

Panel > |II] Array > |II] Array Copy" to open the following dialog box.

Array Copy

According to layer Reference " | Entire row

Crriginal position  |Reference Amount 5 | Base point
Select lines " |Follow Amount 5 __|Base point
Draw line " |Faollow Amount 5 _|Basepoint  Two-dimensional

1. By Floor: Generate copies by building floor or opening.
(1) Reference.
(D Check "Reference" to use the selected building's vertical plane as a reference plane.
@) If "Reference" is unchecked, the building's vertical plane within 2 meters is used as the reference plane.
(2) Entire column.
(D Check "Entire column” to generate a copy of the column with the selected entity in-situ.

@ Uncheck "Entire column" to generate a column or layer of copies starting from the entity's location and following

the cursor position.

For example, check "Reference" and uncheck "Entire column". Click the "By Layer" button, first select the vertical plane
of the building as a reference, and then select the entities to be arrayed, so that the cursor moves up and down (by layer) and

specifies the end point to generate multiple copies of the entities between the two points. The effect is shown in the following

figure.
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2. Pick Point: Generates multiple copies starting with the selected entity.
(1) Reference.
(D Check "Reference" to generate a copy in the direction of the selected reference line.
@ With "Reference" unchecked, specify two points to determine a line and generate a copy along that line.
(2) Amount.
(O Amount: generate copies of the amount entered in the text box (including the original entity).
@) Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two adjacent copies,
and generate copies at this spacing.
(3) Base point.
(D Check "Base point" to specify the position relative to the original entity, using that point as the starting point for
the reference.
(2 The entity center point is used as the base point without checking the "Base Point" box.
For example, check "Reference”, "Number", and "Base". Click the "Home" button, select the edges of the building, entities,
etc., then select the entities to be arrayed, specify the base point, move the cursor, and specify the end point to generate

multiple copies of the entities between the two points. The effect is shown in the following figure.
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3. Select Line: Generates a copy along the selected path.
(1) Follow.
(1) Check "Follow" and the resulting copy is rotated to match the path orientation.
(2) If "Follow" is unchecked, the copy is generated at the original angle.
(2) Amount.
(1) Amount: generate copies in the amount entered in the text box.
(2) Distance: Click "Quantity" in blue font and switch to "Distance”. Set the distance between two adjacent copies,
and generate copies at this spacing.
(3) Base point.
(1) Check "Base point" to specify the position relative to the original entity, i.e. the position of the final copy relative
to the path.
(2) If "Base point" is unchecked, the entity center point is the base point, i.e. the center points of the copies are all
on the path line.
For example, check "Follow", "Number", and "Base point". Click the "Select Line" button, first select the path line, then
select the entity to be arrayed, according to the relative position of the base point and the original entity, along the path line to

generate a copy. The effect is shown in the following figure.
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______

Before

Note: If the specified base point is offset by a distance from the original entity, the final generated copy is also offset by
a corresponding distance from the path.
4. Draw Line: Generates a copy along the 2D or 3D line.
(1) Follow.
(1) Check "Follow" and the resulting copy is rotated to match the path orientation.
(2) If "Follow" is unchecked, the copy is generated at the original angle.
(2) Amount.
(1) Amount: the default quantity. Generate copies of the amount entered in the text box.
(2) Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two adjacent copies,
and generate copies at this spacing.
(3) Base point.
(1) Check"Base point" to specify the position relative to the original entity, i.e. the position of the final copy relative
to the path.
(2) If "Base point" is unchecked, the entity's center point is used as the base point, i.e. the center points of the
copies are all on the path line.
(4) Two dimensional.
(1) Two-dimensional: by default, path lines are drawn in the same way as two-dimensional polylines.
(2) 3D: Click on the blue font "2D" and switch to "3D". Draws the path line in the same way as a three-dimensional
polyline.

For example, check "Follow", "Number", and "Base point" to draw in 2D by default. Click the "Draw Line" button, select
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the entity to be arrayed, specify the base point first, then specify the location of the first copy to be generated, and use it as
the starting point to create the entity. Then draw the path in the same way as drawing a polyline, and right-click to end the

generation. The effect is shown in the following figure.

%

Before

5.1.18.2 Planar Array

o o WRSTPRN ||
Generates multiple copies of selected object. Select "Edit Tab > Modify Panel > Array > ||| Planar Array" to open

the dialog box shown below.

Apply

Number of rows : & Row spadng: 1

Mumber of columns : 4 Column spadng : 1

Angle : 0 Select :

1. Parameter settings.
(1) Setting the number and spacing of copies.
(2) Setthe angle of the array, either manually or by clicking on the blue font "Angle" and specifying two points for drawing
the line, using the angle between the line and the positive direction of the X-axis as the angle of the line.
2. Click on "Select" in blue and select the objects (entities other than roads and terrain).

3. Click the "Apply" button to complete the array and generate multiple copies.
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5.1.19 Group

5.1.19.1 Entity Group

Groups multiple objects into a whole to facilitate operations such as moving, rotating, copying or deleting them. Select "Edit

Tab > Modify Panel > Group > Entity Group", and select multiple objects for grouping.
Note:
(1) Groups do not support buildings and components.
(2)Press ctrl + shift to select a single entity within the group.
(3) Can group entities already in a group.

(4) Select an entity while pressing down “ctrl + Alt” key to separate it from the group.

5.1.19.2 Entity Ungroup

e r_
Removes the grouping relationship. Select " Edit Tab > Modify Panel > Group > (™= Entity Ungroup', and select

grouped objects to ungroup. You can also use "explode" function to ungroup entities. When ungrouping entities in multi-layered

groups, each single action only ungroups the outermost group.

5.1.20 Text

Inserts text into workspace. Select "Edit Tab > Modify

Panel > EI Text" item to open the following dialog box. Enter text
Note:
(1) When the cursor is on an arc, the text is adjusted to

the angle of the tangent plane.

Font: txt.shx ~ Textheight: 2.50

(2) In the properties palette, the position, angle, screen-
Color: 255,255,255 Thickness: |0.00

facing properties and spacing of the text can be

Confirm

modified.
(3)You can double-click the text, or click the "Content"

item in the property palette, and select button to modify the text content.

5.2 Measurement Panel

Page 136 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

5.2.1 Distance

Measures the distance between two points. Select "Edit Tab > Measurement Panel > |-l Distance ", specify two points,

and display the distance value on the command line. When measuring, the distance is displayed in real time in the program.

9.2.2 Line Angle

Measures the angle between two lines in the same plane. Select "Edit Tab > Measurement Panel > ._ Line Angle", select
two lines, and display the angle value on the command line.
Note:
(1) When an arc is selected, the angle of the tangent line is measured.

(2) The line angle is displayed in real time in the program during the measurement.

95.2.3 Plane Angle

Measures the angle between any two plane entities. Select "Edit Tab > Measurement Panel > 4 Plane Angle", select two

planes, and display the angle value on the command line.
Note:
(1) Does not support measuring curved planes.

(2) When measuring, the plane angle is displayed in real time in the program.

5.3 Positioning Panel

9.3.1 Normal Move
Moves a selected object along the normal direction of the selected plane or edge. Select "Edit Tab > Positioning Panel >

Normal Move", follow the command line prompt, place the cursor on the plane or edge of the selected object, highlight it and

drag horizontally or vertically.
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%k

(1) The cursor can snap to the planes or edges of entities. For example, the sides and top/bottom of a building can be

Note:

snapped, as well as the edges of entities such as balconies, planes, etc.

(2) When aplane is snapped, the whole plane is highlighted and the red cross cursor is displayed. At this point, drag
along the plane in the vertical direction in a forward or reverse direction as indicated by the arrow to achieve
continuous operation.

(3) When snapping to the edge or plane of a curved shape, move along the perpendicular direction of its tangent line.

(4) During dragging, move the cursor to other planes to align entities. Generally, select a plane in the same direction
as a reference. For example, when selecting the top plane of a building to move, holding the left button down moves
the cursor to the top plane of another building or other entity to make the tops of both at the same height.

(5 Line entities are not supported.

5.3.2 Bottom Leveling

Adjusts the floor elevation of selected object from its base point. Select "Edit Tab > Positioning Panel > = Bottom
Leveling", according to the command line prompt, select the reference plane first, and enter the height relative to the reference plane,

then select the object. You can adjust the elevation of the entity according to the reference plane and the relative height.
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When selecting entities, enter “W”. You can box select multiple entities and adjust the height uniformly.
Note:

(1) When areference plane is selected, the plane is displayed in red when it is clicked on the plane of a volume. When
there is no plane at the clicked location, a horizontal plane is automatically created in red, centered on the clicked
point, to indicate the reference plane.

(2) If the relative height is set, the leveled elevation = the height of the reference plane + the relative height. For
example, if the reference plane is specified at a height of 10 m and the relative height is set at 2 m, a building is
selected whose lowest point elevation is 12 m.

(3) Roads are not supported. Roads can be modified via the property palette for starting and end height or elevation.

5.3.3 Axis Rotation

Rotates a selected object by the specified axis and angle. Select "Edit Tab > Positioning Panel > o Axis Rotation",
according to command line prompt, put the cursor on the edge of the entity itself and click or enter the angle to rotate around this

edge as the axis. You can click continuously to rotate.
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Enter “S” to rotate object by using the edge lines of other entities as axes. For example, after entering “S”, first select entity A
as the rotation object, right-click to end the selection, at which point the cursor is placed on the edge line of entity B and clicked,
i.e., the edge line of B is used as the axis to rotate, to rotate A.

Note:

(1) Rotated objects support lines, planes (except grid planes), editable polygons and text.
(2) Text cannot be rotated on its own axis. Text can be rotated by selecting another object as the axis of rotation.
(3) The rotation axis supports the selection of most entities, except for special entities such as background scenes and

text.

5.3.4 Rotate to Horizontal

Take the center point of a line or plane and rotate it so that it is parallel to the XOY plane. Select "Edit Tab > Positioning Panel >

E Rotate to Horizontal" and select the object to rotate it horizontally.

~ gy

Before After
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Note:
(1) If the point is on a line, rotate the clicked line segment to horizontal by its midpoint; if the point is on the plane of a
plane or volume, rotate the clicked plane to horizontal by its center.

(2) Grid planes are not supported.
5.3.5 Rotate Vertical
Take the center point of a line or plane and rotate it so that it is perpendicular to the XQY plane. Select "Edit Tab > Positioning

Plane > E Rotate to Vertical" and select the object to rotate horizontally.

5.3.6 Adjacent Entities

Fits the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel > E Adjacent Entities", first

select the plane or edge of object 1 as reference, then select the plane or edge of object 2 to fit together with object 1.

Before After
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Note:
(1) When the plane of a volume is selected, it is aligned with the center of the plane.
(2) When the edges of the entity are selected, they are aligned at the midpoint of the edges.

(3) Reference entities and parallel entities can be any one of: buildings and components, line and other entities.

5.3.7 Align Entities

Aligns the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel > i Align Entities" item,

first select the plane or edge of object 1 as reference, then select a plane or edge of object 2, and align with object 1.

Before After

Note: Reference and parallel objects can be any one of: buildings and components, lines and other objects.

9.3.8 Arrange

5.3.8.1 Arrange Along Line

Arranges entities in order along a path. Select "Edit Tab > Positioning Panel > IIIArrange Along Line" and follow the

command line prompts as follows.
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Before

Eeference object Entity net distance

m— ] .

‘ MNormal net distance

Feference hine

1. Enter a value to determine the normal net distance. For example; the distance between the object and the reference line
when it is finally lined up.

2. Select the edge lines of the objects as reference lines. Next, enter values to determine the distance between aligned entities
and select the entities to be aligned.

3. Finally, select the reference entity, and the other entities are arranged equidistantly with the reference entity as the base.

5.3.8.2 Directional Copy

Copies a selected object in parallel or perpendicular direction to the reference line. Select "Edit Tab > Positioning Panel >

E Directional Copy", and follow the command line instructions as follows.
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1. Select lines or solid edges as reference lines.
2. Select the entity to be copied, and at this point move the cursor to the parallel, perpendicular, or Z-axis direction of the
reference line, using the center of the entity as the base point to specify where the copy is to be generated. Enter S to

reassign the base point for copying.
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6 Modeling Menu

This chapter introduces various traditional and advanced modeling features that allow users to create, modify and refine

the buildings and entities in the scheme according to the rendered effect.
6.1 Advanced Modeling Panel

Advanced Modeling has powerful modeling capabilities, providing flexible and versatile point, line, plane-related operations

to deal with all kinds of complex modeling process easily and efficiently.

6.1.1 Advanced Modeling

Select "Modeling Tab > Advanced Modeling Panel > - Advanced Modeling" to open the dialog box shown below.

Advanced Modeling H x

Vertex: 0O Edge: O Polygan: 0O Edged Faces i

/Create r‘u"ertex rEdge rPnIygnn rEIement rDbject I

[ Rectangle ] Box Convert
MGon Sphere
Paolyaon Cylinder
Circle Torus
Ellipse Cone
Donut Pyramid
Star
Polygon Ohject Convert
Transform: Q) Select Move Rotate Scale [ JLock
State: [ Snap " | orthogonal " | 1gnore BadkFading [ |Local
Constraint: | % f Z XY ¥Z X

Note: In the vertex, edge, polygon, element and object tabs of advanced modeling, the Copy, Delete, Move, Rotate, Scale and

Delete functions or tools under "Edit" tab are not available.
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6.1.2 Display Mode

Click ™ button in the upper right corner of the panel to expand the drop-down list, as shown below.

1. Edged Faces: Editable polygons are displayed as "model + wireframe" by default.
2. Wireframe: Displays in wireframe form.
3. Facets: Displays in model mode.

Note: You can use the shortcut key F9 to cycle through the three display modes.

6.1.3 Vertex, Edge, Polygon

Dynamically displays the total number of vertices,

Vertex: 146 Edge: 306

lings, and planes of editable polygons.
Note: Contains both selected and unselected,

hidden ones are not counted.

6.1.4 Transform

6.1.4.1 Select

|Eu:|ged Faces e |

Wireframe
Facets
Edged Faces

Polygon: 162

Select is a status command that defaults to the selected state. Normally, objects can be added to the selection set by "selecting

them one by one" or "window selecting" for subsequent operations. As shown below:

1. To add objects to the selection set, you need to hold down the "Cirl" key and select the object to be added.

2. To remove individual objects from the selection set, you need to hold down the "Alt" key and select the object to be removed.

3. To invert the current selection of objects, you need to hold down the "Shift" key and select the object to invert the selection.

Note: The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated at
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any time.
6.1.4.2 Move

0 Move

Selects and moves the object. When in the selected state, the object is moved in the following ways.

1. Move directly, click on an object and drag the mouse directly to move the object.

2. Select and move. Add the object to be moved to the selection set first, and move it by specifying the reference point in the

selection set as the base point.

3. Right-click the Move button and set the move distance of the selected object in the pop-up window.
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Move Transform Type-ln

The direction of movement is determined by the mouse and the current reference coordinate system. To restrict the object's
movement relative to the plane defined by the X, Y or Z axes or any two of them, click the corresponding button on the Constraints
toolbar or click directly on the axis to temporarily lock the corresponding axis.

Note:

(D You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK"
button to batch copy objects along the direction with equal intervals.

(2) The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated
at any time.

(3) This command corresponds to the move command in the UV Editor.
6.1.4.3 Rotate

0 Rotate

Selects and rotates the object. When is selected, the object is rotated in the following ways.

1. Direct rotation, click on an object and drag the mouse directly to rotate the object.
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2. Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying the reference point in

the selection set as the base point.

3. Right-click the Rotate button and set the rotation angle of the selected object in the pop-up window.
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Rotate Transform Type-ln

Fi-

The direction of rotation is determined by the mouse and the current reference coordinate system. To restrict the rotation of the
object to the plane defined by the X, Y or Z axis or any two of them, click the corresponding button on the Constraints toolbar or
click the axis directly on the axis to temporarily lock the corresponding axis. If the XY, YZ or XZ axes are locked at the same time, the
model will remain unchanged.

Note:

(D) You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK"
button to batch rotate objects with equal angle.

(2) The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated
at any time.

(3) This command corresponds to the rotation command in the UV Editor.

6.1.4.4 Scale

Selects and scales the object. When O 5cale in the selected state, the object is scaled in the following ways.

1. Direct scaling, click on an object and drag the mouse directly to scale the object.
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2. Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the reference point in

the selection set as the base point.

3. Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window.
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Scale Transform Type-In

w: 100,000 ¥, 100,000 7. 100.000

The direction of scaling is determined by the mouse and the current reference coordinate system. To restrict object scaling to
the plane defined by the X, Y or Z axis or any two of them, click the corresponding button on the Constraints toolbar, or click directly
on the axis to temporarily lock the corresponding axis.

Note:

(D You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and click the "OK"
button to batch copy objects with equal proportion.

(2) The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can be activated
at any time.

(3) This command corresponds to the scale command in the UV Editor.
6.1.4.5 Lock

Enables or disables selection locking, which prevents accidental selection of other entities in complex scenes.

By default, this button is unchecked. By checking the lock button and enabling this feature, you can click or drag the cursor
anywhere in the viewport without losing that current selection set or adding unwanted new objects to the current selection set. To
cancel or change the selection, uncheck the lock item.

On the toolbar, check the lock button and activate one of the move, rotate, or scale buttons. Drag anywhere in the viewport to

move, rotate, or scale the objects in the selection set.

6.1.5 State
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6.1.5.1 Snap

Snap Mode Settings

When creating and editing editable polygons in the Advanced

Modeling panel, you can enable the snap function to assist in the & Endpoint __|Center of drde
operation for precise positioning. Click the checkbox & Snap at the Midpaint Closest point
bottom of the panel to turn the snap function on or off. Right click on | Intersection &4 Plane

. - . .
the checkbox & Snap to open the dialog box shown below. SPEmErm e

M ick box(0-50):  ©
You can set snapping options, where "plane" refers to the ouse pick box(0-50)

. . Mouse capture frame(2-20): 10
surface of a plane or entity. Click the "Select All" button to check all —

. . ) Cursor length (1-100): &
the boxes; click the "Confirm" button to apply the settings. -

Select all Cancel

Note: When snapping to the circle center of an arc, you need

to hover the cursor over the edge line to display the center of

7
b

the circle.
6.1.5.2 Orthogonal

Restricts the operation to horizontal or vertical orientation. Click the checkbox

User
& orthogonal 3t the bottom of the panel to turn the orthogonal function on or off. Right-click

the checkbox B Orthogonal tg gpen the following men. e
1. Select "World": Operation is performed in the world coordinates direction (i.e., the
axes in the lower left corner of the software).
2. Select "User": Operation is performed in the self-defined axis direction.
You can follow the command line prompts and enter the angle with the X direction of the world coordinate system as the
X-axis direction in the user coordinate system; or select the edge or line as the orthogonal direction; you can also draw the
ling to obtain it. Enter “D” and press ENTER, specify two points, and draw the orthogonal direction. If you need to clear the
defined orthogonal direction, enter “C” and press ENTER.
Note:
(1) When orthogonal is turned on, operations such as drawing can only be performed in the X, Y or Z axis directions.

(2) When both snapping and orthogonal are enabled, snapping takes precedence.

(3) When drawing a line to obtain it, the two points are drawn with different directions and different angles.

6.1.5.3 Ignore BackFacing
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When this option is enabled, only points, lines, and planes visible in the workspace can be selected. With this option disabled,
all points, lines, and planes in the viewport can be selected. Click the checkbox Edl Ignore BackFacing at the bottom of the panel to

turn this feature on or off.

6.1.5.4 Local

The native position, i.e., the object's own coordinates. Click the checkbox & Lacal at the bottom of the panel to turn this function
on or off.
Note:
(1) When its own coordinates are checked, the axial direction of the operation is affected; when its own coordinates are
unchecked, it is the axial direction in world coordinates.
(2) The operations affected are move, rotate, scale, mirror, array, align, transform, etc.

(3) You can view the direction of the entity's own coordinates by using the "Axis Transformation" function.

6.1.6 Constraint

Constraints, i.e., axial constraints. Click the button at the bottom of the panel to turn on or off the constraint function for the

corresponding axis, as the following figure shows.

Constraint: | * L z XY Y7 X

Note:

(1) Axis constraints affect the axes of move and zoom functions. For example, if you constrain the x-axis, you can only
move in the x-axis direction when you perform a move. Similarly, if the xy-axis is constrained, the movement can
only be made in the XQY plane.

(2) When "Snap" is checked, movement is in the direction of the constraint, although it is possible to move by snap point.

(3) You can also achieve the constraint effect by dragging the cursor in an axial direction without checking the "Constraint"
box.

6.2 Create Tab

Converts objects such as planes and volumes into editable polygonal entities.

6.2.1 Polygon Tools
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6.2.1.1 Rectangle

Creates a rectangular plane. Select "Create Tab > Polygon > Rectangle", specify the first corner point, drag it to the target
location as another corner point.
Note: After activating the drawn rectangular plane, its alias, accompanying layer color, smoothing, length, width and other

parameters can be modified on the property palette.

6.2.1.2 NGon

Creates a regular polygonal plane. Select "Create Tab > Polygon > NGon", enter a value to determine the number of sides,
and then start drawing. There are three ways to generate.
1. Draws a square polygon internal to a circle: Specifying the center point and entering the radius generates a square polygon.
2. Draw a regular polygon based on the specified side lengths: Input or Enter “E” and press Enter to specify two points as the
lengths of the sides of the regular polygon.
3. To draw a square polygon tangent to a circle: Input or Enter “C”, specify the center point, enter the radius, and generate a
square polygon.
Note:
(1) The generated result is an editable plane.
(2) You can modify polygonal plane properties on properties palette.
(3)If the drawn polygon plane has been edited, the number of sides and the internal tangent radius parameters in the

property palette cannot be modified.

6.2.1.3 Polygon

Creates polygonal planes. The generated result is an editable plane. Select "Create Tab > Polygon > Polygon", specify the
starting point, and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort the previous operation, type

“U” and press enter.

6.2.1.4 Circle

Creates a circular plane. Select "Create Tab > Polygon > Circle" to create a circle with the specified center and radius.

6.2.1.5 Ellipse

Creates an elliptical plane. Select "Create Tab > Polygon > Circle" to create an ellipse with the specified center and axis

length.
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6.2.1.6 Donut

Creates a ring with a circular cross section. Select "Create Tab > Polygon > Donut", specify the center of the circle, and
then set the inner and outer radii respectively.
Note:
(D) To set the radius, specify the location with the mouse or enter the value at command line.
(2) The property palette allows you to modify parameters such as alias, accompanying layer color, smoothing, outer

circle radius, inner circle radius, center point, etc.
6.2.1.7 Star

Creates a star-shaped closed plane. Select "Create Tab > Polygon > Star", specify the center point, enter a value to
determine the number of star angles, and then set the outer and inner radii.
Note:
(1) To set the radius, specify the position with the mouse or enter the value at command line.
(2) The property palette allows you to modify information about parameters such as alias, accompanying layer color,

smoothing, corner points, outer radius, inner radius, center point, etc.

6.2.2 Object Tools

6.2.2.1 Box

Creates a box. Select "Create Tab > Object > Box", draw the bottom side of the box, enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

length section, width section, height section, length, width, height, center, elevation, etc.

6.2.2.2 Sphere

Creates a sphere. Select "Create Tab > Object > Sphere", specify the center of the sphere, enter the radius.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

number of sides, radius, center, elevation, etc.

6.2.2.3 Cylinder

Creates a cylinder. Select "Create Tab > Object > Cylinder", draw the base of the cylinder, enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

number of sides, height section, face section, radius, height, center, elevation, etc.
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6.2.2.4 Torus

Creates a ring volume. Select "Create Tab > QObject > Torus ", specify the center of the circle, enter the circle radius and the
radius of the torus.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

number of sides, section, rotate angle, inner circle radius, out circle radius, center, elevation, etc.

6.2.2.5 Cone

Creates a cone. Select "Create Tab > Object > Cone", specify the center of the circle, enter the radius of the top and bottom
planes, enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

number of sides, height section, face section, bottom radius, top radius, height, center, elevation, etc.
6.2.2.6 Pyramid

Creates a pyramid. Select "Create Tab > Object > Pyramid", specify the center point, enter the number of sides, enter the
radii of the top and bottom external circles, and enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached to layers, smooth,

number of sides, bottom radius, top radius, height, center, elevation, etc.

6.2.3 Convert Tools

6.2.3.1 Convert

Converts objects such as volumes, planes and buildings into editable polygons. Select "Create Tab> Convert > Convert'
and select the entity to convert it to an editable polygon.
Note: All entities except oblique photography, point cloud, and imagery data, can be converted to editable polygons and their

points, lines, and planes edited.

6.3 Vertex Tab

6.3.1 Delete

Erases the selected point. Select "Vertex Tab > Delete" and select the vertex to delete. The planes formed with this point will

be deleted together after deletion.
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6.3.2 Copy

Copies the selected point. Select "Vertex Tab > Copy", select the point, specify the base point, and then specify the target

point to create a copy.

6.3.3 Select Invert

Selects all points in the current workspace other than the selected points. Select the "Vertex Tab > Select Invert" item to

select the object, all points other than the object are selected.

6.3.4 FFD

Adds control vertices to the selected point, making it more

evenly to adjust the shape of an object. Select “Vertex Tab > FFD” Free Transformation
to open the dialog box shown. © Control Points Lattice Set Volume
FFD Style

1. Control Points: When using FFD under this submode, the

. : . . FFD 2x2x2 FFD 3x3x3
lattice frame will be shown in yellow and the control points -

on it can be selected and manipulated to change the shape FFD du4x4 Custom
of the object. A single or multiple control points can be Current mode:  Cuboid mode
adjusted at the same time. Current selection:  FFD 3x3x3

2. Lattice: When using FFD under this submode, the lattice

Select
frame will be shown in orange. The frame can be moved, \, y

rotated, or scaled. By default, if the frame is moved or
scaled, only vertices within the volume of the object can be used for transformation.

3. Set Volume: Mainly used to set the initial state of lattice frame. Under this mode, when using FFD the frame will be shown
in green. The control points can be adjusted without affecting the shape of the object. This provides better control when

transforming irregular objects.
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4. FFD style: The default setting is rectangular mode, with three

Custorm FFD Parameter

different FFD styles: "FFD 2x2x2", "FFD 3x3x 3" and "FFD
© cuboid mode Cylinder mode
4x4x4" You can also customize the style by clicking the R
"Customize" button to bring up the dialog box shown below. Points in X direction: 3
(1) Cuboid mode: Creates rectangular shape lattice free- Points in ¥ direction: 3 }g
form transformations, where the number of edit points Points in Z direction: | 3
in the XYZ axis can be set separately in the rectangular Cylinder parameters
parameters. Default Parameter:  FRD duef wd
(2) Cylinder mode: Creates cylindrical shape lattice free Radial points: |4
form. Radial, lateral and height edit points can be set Side points: |6 }Eﬁ
separately. Height points: |4
5. Set the parameters, select the editable polygon, and the FFD -
Cancel
edit box will appear on the selected volume to enter the 3 i

transformation edit mode.

Note:

(1) During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will

end.

(2) During operations, the three submodes can be switched to one another.

(3) The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher
the number of segments, the higher the precision.

(4) The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points,
the smaller the range controlled by a single point.

(5) Ignoring back side is valid for FFD edit points.

(&) Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time;
if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as
one volume and then use FFD transformation.

(7) When FFD editing, move, rotate, and scale under "Edit" tab are not available.

6.3.5 Slice

Specifies a slicing line to generate a slicing plane. New vertices and lines will be generated where the model and the plane
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intersect. Select "Vertex Tab > Slice", and select two points.

6.3.6 Chamfer

Fillets selected points. Slice the selected edge to create a new
plane. Select the "Vertex Tab > Chamfer ", select the vertex to be
sliced fillet. Set the slicing amount and segment parameters in the
dialog box, and click Confirm.

Parameter Description:

1. Slicing amount: Specifies the size of the chamfered plane.

2. Segment: Input value between 1 and 10.

3. Open sliced corners: Decides whether the cut corners are closed.

Vertex Slicing

Slicing amount:

(] [l

Segment: 1

Open sliced corners; ]

Vertex Slicing

Slicing amount: 2.000 =

Segment:

Open sliced corners: ]

Vertex Slicing
Slicing amount:
Segment:

Open sliced corners:

s
s

x

6.3.7 Cut

Cuts planes to create new vertices and lines. Select "Vertex Tab > Cut", then click on an entity to continuously specify positions

to cut the plane of the entity.

6.3.8 Tessellate

Page 160 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

Tessellates models by choosing to split the selected planes with edge

Tessellate
midpoint connections or with vertex connections.
After selecting a vertex, select "Vertex Tab > Tessellate", to open the O Edge Face
following dialogue.

- Y
Tension: 1

Choose to tessellate either edge or face, set tension, and click Confirm

to apply. Cancel

6.3.9 Drag

Drag select, with which vertices will be automatically selected when the cursor hovers over them. Select "Vertex Tab > Drag",

hold down left mouse button, and hover over vertices to select them.

6.3.10 Target Weld

Drag the selected point to the target point to be merged (as close as possible) to automatically perform the merge. Select

"Vertex Tab > Target Weld" and select the starting point and target point to merge.

Note:
(1) The starting point and the target point must be on the same line.
(2) When the planes on which the points are located are not closed, points which do not lie on the same line may be
welded.
(3) When points on different entities need to be merged, multiple entities should be "Attach" before merging.
6.3.11 Break

Breaks a shared vertex into multiple independent vertices for separate editing. Select "Vertex Tab > Break" and select the vertex

to break.

6.3.12 Weld

Welds multiple vertices of an editable polygon together into a single vertex. Select "Vertex Tab > Weld", select the vertex and
enter the weld distance, and the vertices within the range are welded as one.
Note:
(1) A successful weld is achieved when the distance entered is greater than or equal to the distance between any vertices

to the average position of the combined vertices.
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(2) The vertices selected must be vertices in the same plane on the entity.

@ When vertices on different entities are to be welded, multiple entities must be "Attach" before welding.

6.3.13 Exit

All points will exit the editing state. Select "Vertex Tab> Exit" to exit the editing state.

6.3.14 Remove

Removes a selected point. Unlike Erase, removing vertices does not destroy the integrity of the plane. Select "Vertex Tab >

Remove" item to remove the selected point.

6.3.15 Connect

Connects points on editable polygons with lines. Select "Vertex Tab > Connect", and draw lines by clicking on vertices.

Note: while connecting vertices, the connecting line cannot intersect with other lines.

6.3.16 To Edge

By selecting a point, the line associated with that point is selected and switched to line mode.

Select "Vertex Tab > To Edge" item and select the line to select the line that connects this point.

6.3.17 Shrink

Shrink vertex selection towards the inner circumference direction from the currently selected point.
Select the "Vertex Tab> Shrink" item, select the vertex, and then shrink the selection one turn inward along the selected range.
Note:

(1) Automatically selects the vertices on the lines that shares sides with this point.

(2) The Ignore Backfacing option has no influence on this command.

6.3.18 Grow

Extends vertex selection of the currently selected vertices in the peripheral direction.
Select the "Vertex Tab > Grow" item, select the vertex, and then expand the selection one turn outward along the selected
range.

Note:
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(1) Automatically selects the vertices on the lines that shares sides with this point.

(2) The Ignore Backfacing option has no influence on this command.

6.4 Edge Tab

6.4.1 Delete

Erases the line on the selected editable polygon. Select "Edge Tab > Delete" and select the line to delete. The planes formed

with this line will be deleted together after deletion.

6.4.2 Copy

Copies lines on editable polygons into separate 3D polylines. Select "Edge Tab > Copy", select the line, specify the base

point, and then specify the target point to create a copy.

6.4.3 Select Invert

Selects all lines in current workspace other than the selected lines. Select the "Edge Tab > Select Invert" item to select the

object, all lines other than the object are selected.

6.4.4 FFD

Adds control vertices to the selected edge to evenly adjust the shape of the object. Select “Edge Tab > FFD” to open the
dialog box shown.

1. Control Points: When using FFD under this submode, the

Free Transformation

[attice frame will be shown in yellow and the control points O Control Points () Lattice St Volume

on it can be selected and manipulated to change the shape FFD Style

of the object. A single or multiple control points can be FFD 2xdx2

adjusted at the same time. FFD Sxdxd Custom

2. Lattice: When using FFD under this submode, the lattice

Current mode:  Cuboid mode

frame will be shown in orange. The frame can be moved, Current selection:  FFD 3x3x3

rotated, or scaled. By default, if the frame is moved or

Select

scaled, only vertices within the volume of the object can be

used for transformation.

3. Set Volume: Mainly used to set the initial state of lattice
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frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without

affecting the shape of the object. This provides better control

when transforming irregular objects. Custom FFD Parameter
4. FFD style: The default setting is rectangular mode, with three © Cuboid mode Cylinder mode
different FFD styles: "FFD 2x2x 2", "FFD 3x3x 3" and "FFD Cuboid parameters

Points in X direction: 3

4x4x4" You can also customize the style by clicking the

Points in ¥ direction: 3 }:@
"Customize" button to bring up the dialog box shown below.
Points in Z direction: 3

(1) Cuboid mode: Creates rectangular shape lattice free-

. . . Cylinder parameters
form transformations, where the number of edit points ! P

) ) ) Default Parameter: FED 46 =4
in the XYZ axis can be set separately in the rectangular
Radial points: 4
parameters.

Side points: [ }
(2) Cylinder mode: Creates cylindrical shape lattice free
Height paints: 5
form. Radial, lateral and height edit points can be set

separately. Cancel

5. Set the parameters, select the editable polygon, and the FFD

edit box will appear on the selected volume to enter the
transformation edit mode.
Note:
(1) During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will
end.
(2) During operations, the three submodes can be switched to one another.
(3) The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher
the number of segments, the higher the precision.
() The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points,
the smaller the range controlled by a single point.
(5) Ignoring back side is valid for FFD edit points.
(&) Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time;
if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as
one volume and then use FFD transformation.

(7) When FFD editing, move, rotate, and scale under "Edit" tab are not available.
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6.4.5 Slice

Specifies a slicing line to generate a slicing plane. New vertices and lines will be generated where the model and the plane

intersect. Select "Edge Tab > Slice", and select two points.

6.4.6 Cut

Cuts planes to create new vertices and lines. Select "Edge > Cut", then click on an entity to continuously specify positions

to cut the plane of the entity.

6.4.7 Tessellate

Teszellate

Tessellates models by choosing to split the selected planes with edge
0 Edge Face
midpoint connections or with vertex connections. After selecting a vertex, select
"Edge Tab > Tessellate", and the following dialogue appears. Choose to tessellate Tenson: |1 ~ ©
either edge or face, set tension, and click Confirm to apply. Cancel

6.4.8 Drag

Drag select, with which lines will be automatically selected when the cursor hovers over them. Select "Edge Tab > Drag", hold

down left mouse button, and hover over lines to select them.

6.4.9 Fence

Fence select. Select all lines that intersect the line you draw. Select "Edge Tab > Fence", draw a polyline, and all intersecting

lines will be selected.

6.4.10 Create Shape

Extracts the contour lines. Select the "Edge Tab > Create Shape " item and select the line to generate a 3D polyline.

Note: The 3D polyline generated can only be edited if you exit advanced modeling mode.

6.4.11 Measure

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide

the ling or plane. Select the item "Edge Tab > Measure" and the dialog box pops up:

Page 165 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

Measure

Ohject Method
O Line One line

Flane

Salid

Equipartition parameter

Segment: |2 = = +
Shrink: |0 - - +
Slider: |0 oo +

Apply Cance

1. Object; You can choose lines, planes, and solids.

(1) Line: "One line", an equal division of the selected line.

(2) Plane:
(1) One line, one plane: An equal division of the selected plane according to the vertical direction of the selected

line.

(2) Multi-line: Equally divide the associated planes based on the selected polyline.

(3) Solid:
(1) One line: The volume is divided equally according to the vertical direction of the selected line.

(2) Two lines: The volume is divided equally according to the two lines chosen.

2. Equipartition parameter: You can enter the value directly, or click the s button to adjust how many segments you want to
add, or you can drag the slider to adjust it.
(1) Segment: The default value is 2, means an equal division into 2 parts.
(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.
(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must

belong to the same entity and must be coplanar.
6.4.12 Exit
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All lines will exit the editing state. Select "Edge Tab> Exit" to exit the editing state.

6.4.13 Remove

elevation point (such as the above figure, it means the elevation of the elevation point is 10.00), and the center of the cross
mark is the actual position (x,y) of the elevation Note: After selecting the object:
(1) Right-click or press space: Removes the line and its endpoints, and the two planes that have a common side with
the line are combined into one plane.

(2) Press Enter: Removes the line and keeps the endpoints.

6.4.14 To Vertex

In line mode, select the point on the selected line and switch to point mode. Select "Edge Tab > To Vertex " and after selecting

the line, the point on the line is selected.

6.4.15 To Polygon

In line mode, select the plane associated with the selected line and switch to plane mode. Select "Edge Tab > To Polygon "

and after selecting the line, the associated plane is selected.

6.4.16 Shrink

Shrink the selection of lines in the inward direction of the currently selected line. Select "Edge Tab > Shrink" item, select the

ling, and then shrink the selection one turn inward along the selected range.

6.4.17 Grow

Extends the selection of lines in the outward direction of the currently selected line. Select "Edge Tab > Grow" item, select the

line, and then expand the selection by one circle along the selected range.

6.4.18 Chamfer

Slices the selected edge to create a new plane. Select the "Edge Tab> Chamfer", select the line to be sliced, and the following
dialog box appears.
Set the slicing amount and segment parameters in the dialog box, and click Confirm.

Parameter Description:
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1. Slicing amount: Specifies the size of the chamfered plane.
2. Segment: Integer between 1 and 10.

3. Open slice corners; Decides whether the cut corners are closed.

Vertex Slicing

Slicing amount: 5,000
Segment: 1

Open sliced corners:

6.4.19 Bridge

Within the same model, the Bridge command can create a plane between edges, and the new bridging plane will be a part of

the original mesh. Select " Edge Tab > Bridge", and the following dialogue will pop up:

Bridge
Segments: 1 = Type:
Taper: 0.000 = Offset: 0.000 =
Twist 1: 0 = Twist 2: 0 =
Cancel

Set number of segments, type, taper, offset, twist 1 and twist 2 parameters, click "Confirm" to apply.

Parameter Description:

1. Segments: Sets the number of equal segments for the plane generated by the bridge.

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available.

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value tapers it smaller;
positive value tapers it larger.

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount of taper is

greatest at the center of the bridge.
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5. Twist1. Twist2: Rotates the order of connection between the edges of the two selections. The two controls let you set a

different twist amount for each end of the bridge.

y/ N
lll._l\_\\\\\\}§§§ )\

6.4.20 Ring

Creates one edge ring based on the current sub-object selection and selects the results. Select "Edge Tab > Ring " to select

W

a line of a quadrilateral and press enter, then the opposite ling is selected. For example, if the you select the line “i”, the line “i+2”

will be RING selected.

Advanced Modeling H x

Vertex: 0O Edge: 16 Polygon: 0 Edged Faces ~

Create rVer‘tex /Edge rPo\ygon rEIement rDbJect |

Delete Fence Grow
Copy Create Shape Chamfer
Select Invert Measure Bridge
FFD Exit Ring
Slice Remove Loop
Cut To Vertex Border
Tessellate To Palygon Cap
Drag Shrink. Insert Vertex
Transform: @ Select () Move () Rotate I 5cale | ILodk
State: @@Snap | |Orthogonal [ 1gnore BackFadng [Local
Constrant: [ X EY

Note: The command is only available to the quadrilateral plane.

6.4.21 Loop

Creates one edge loop based on the current sub-object selection and selects the results. Select the "Edge Tab > Loop", and
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after selecting the line and pressing enter, connecting lines are selected.

Advanced Modeling H %

Vertex: 0 Edge: 16 Polygon: 0 Edged Faces ~

Create r‘u"ertex /Edge rPongon rEIement rObject I

Delete Fence Grow
Copy Create Shape Chamfer
Select Invert Measure Bridge
FFD Exit Ring
e
Cut To Vertex Border
Tessellate To Polygon Cap
Drag Shrink Insert Vertex
Transform: ) Select " Move ") Rotate I Scale [ Ilock
State: [ Snap | Orthogonal " |Ignore BackFacing [ Local
Constraint: i z XY Yz x

Note: The command is only available to the quadrilateral plane.

6.4.22 Border

Quickly select border lines. Select "Edge Tab > Border", after selecting lines and press enter, all lings on the edge will be

selected.

6.4.23 Cap

In line mode, select the boundary line that needs to be sealed to generate a new plane. Select the "Edge Tab > Cap" and
select the closed line on the editable polygon to seal.
Note: Window select the editable polygon, and the system automatically searches for the closed lines on the current polygon,

and automatically excludes those that already have planes.

6.4.24 Insert Vertex

Manually add points to the edge for subdivision. Select "Edge Tab > Insert Vertex " and specify the insertion point on the line.

6.5 Polygon Tab

6.5.1 Delete

Erases the selected plane. Select "Polygon Tab > Delete" and select the plane to delete.

Page 170 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

6.5.2 Copy

Copies the selected plane. Select "Polygon Tab > Copy", select the plane, specify the base point, and then specify the target

point to create a copy.

6.5.3 Select Invert

Selects all planes in the current scene other than the selected plane. Select the "Polygon Tab > Select Invert" item to select

the object, all planes other than the object are selected.

6.5.4 FFD

Adds control vertices to the selected plane to evenly adjust the shape of the object. Select “Polygon Tab > FFD” to open the
dialog box shown.

1. Control Points: When using FFD under this submode, the

Free Transformation

|attice frame will be shown in yellow and the control points , ,
0 control Points Lattice Set Volume

on it can be selected and manipulated to change the shape FFD Style

of the object. A single or multiple control points can be FFD 2x2x2

justed at the same time.
adjusted at the same time FFD 4x4x4 Custom

2. Lattice: When using FFD under this submode, the lattice

Current mode:  Cuboid mode

frame will be shown in orange. The frame can be moved,
Current selection:  FFD 3x3x3

rotated, or scaled. By default, if the frame is moved or

Select

scaled, only vertices within the volume of the object can be

used for transformation.

3. Set Volume: Mainly used to set the initial state of lattice
frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without
affecting the shape of the object. This provides better control when transforming irregular objects.

4. FFD style: The default setting is rectangular mode, with three different FFD styles: "FFD 2 x2x2", "FFD 3x3x 3" and
"FFD 4x4x4". You can also customize the style by clicking the "Customize" button to bring up the dialog box shown

below.
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Custom FFD Parameter

0 cuboid mode

Cuboid parameters
Points in X direction:

Paints in Y direction:

Points in Z direction:

Cylinder parameters
Default Parameter:
Radial points:
Side points:

Height points:

Cylinder mode

3 &
1
3
4
@
6 }._@
_1.
Cancel

(1) Cuboid mode: Creates rectangular shape lattice free-form transformations, where the number of edit

points in the XYZ axis can be set separately in the rectangular parameters.

(2) Cylinder mode: Creates cylindrical shape lattice free form. Radial, lateral and height edit points can be

set separately.

5. Set the parameters, select the editable polygon, and the FFD edit box will appear on the selected volume to enter the

transformation edit mode.

Note:

(1) During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will

end.

(2) During operations, the three submodes can be switched to one another.

(3) The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher

the number of segments, the higher the precision.

() The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points,

the smaller the range controlled by a single point.

(5) Ignoring back side is valid for FFD edit points.

(&) Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time;
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if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as
one volume and then use FFD transformation.

(7) When FFD editing, move, rotate, and scale under "Edit" tab are not available.

6.5.5 Slice

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect.

Select "Polygon > Slice", and select two points.

6.5.6 Cut

Cuts planes to create new vertices and lines. Select "Polygon Tab> Cut", then click on an entity to continuously specify

positions to cut the plane of the entity.

6.5.7 Tessellate

Tessellates models by choosing to split the selected planes with edge sl
midpoint connections or with vertex connections. After selecting a vertex, select O £dge ==
"Polygon Tab > Tessellate", and the following dialogue appears. Choose to tessellate Tension: 1 =
either edge or face, set tension, and click Confirm to apply.
Cancel
6.5.8 Drag L f

Drag select, with which planes will be automatically selected when the cursor

hovers over them. Select "Polygon Tab > Drag", hold down left mouse button, and hover over lines to select them.

6.5.9 Fence

Fence selected. Select all lings that intersect the line you draw. Select "Polygon Tab > Fence", draw a polyline, and all

intersecting lines will be selected.

6.5.10 Smooth

Smooths the selected entity. Select "Polygon Tab > Smooth", after select editable polygons, and the following dialog box
appears.

Sets number of iterations whether to display smooth effect, click "Confirm" to apply.
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Parameter Description:

[terations: Controls number of vertices that are

Show Smooth
0 show

| Hidden

TurboSmoath

added to the polygon to smooth the mesh.

Show: The smooth effect will be displayed. Iterations: U -

Hide: The smooth effect will not be displayed.

Note: When the number of iterations is 0, only

display smoothness is active.

6.5.11 Measure

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide

the line or plane. Select the item "Polygon Tab > Measure" and the dialog box pops up:

Object Method

I Line Ore line, One plane
Q Plane Multiine

) Solid

Equipartition parameter

Segment: |2 — = +
Shrink: |0 _ - +
Slider: |0 s - +

Apply Cancel

1. Object: You can choose lines, planes, and solids.
(1) Line: "One line", an equal division of the selected line.
(2) Plane:
(1) One ling, one plane: An equal division of the selected plane according to the vertical direction of the selected
line.
(2) Multi-line: Equally divide the associated planes based on the selected polyline.

(3) Solid:

Page 174 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

(1) One line: The volume is divided equally according to the vertical direction of the selected line.

(2) Two lines: The volume is divided equally according to the two lines chosen.

2. Equipartition parameter: You can enter the value directly, or click the - button to adjust how many segments you want to
add, or you can drag the slider to adjust it.
(1) Segment: The default value is 2, means an equal division into 2 parts.
(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.
(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must

belong to the same entity and must be coplanar.

6.5.12 Exit

All planes will exit the editing state. Select "Polygon Tab> Exit" to exit the editing state.

6.5.13 Detach

Breaks the selected plane into a new volume. Select "Polygon Tab > Detach " to select a plane for breaking, which is shown

in gray by default.

6.5.14 To Edge

While under the Polygon mode, select the lines on the selected plane and jump to the Edge mode. Select "Polygon Tab > To

Edge" and after selecting the plane, the lines on the plane are selected and switched to the Edge Tab.

6.5.15 To Element

In polygon mode, select the elements related to the selected polygon and switch to element mode.
After selecting a polygon, select "Polygon Tab > To Element", and the related elements will be selected and switched to the

Element Tab.

6.5.16 Shrink

Shrinks the selection of planes in the inward direction of the currently selected plane. Select "Polygon Tab > Shrink" item,

select the plane, and then shrink the selection one turn inward along the selected range.
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6.5.17 Grow

Adds planes on the outward direction of the currently selected plane into selection. Select "Polygon Tab > Grow" item, select

the plane, and then expand the selection by one circle along the selected range.

6.5.18 Flip Normal

Flips the planes with reverse direction of normal in the selection set so that the UV material can be displayed properly. Select
"Polygon Tab > Flip Normal " item and select the plane.
Note: The selected plane is flipped 180° along the center of its own, the results of modifications by other commands to the

editable polygon like Weld and Break, will not be changed.

6.5.19 Bridge

Within the same model, the Bridge command creates a connecting plane between edges, and the bridging plane will be part

of the original mesh. Select "Polygon Tab > Bridge", and the following dialogue will pop up:

Segments: 1 = Type:

Taper: 0.000 = Offset: 0,000

Twist 12 0 = Twist 2: 0

Set number of segments, bridge type, taper, offset, twist 1 and twist 2 parameters, click Confirm to apply.

Parameter Description:

1. Segments: Sets the number of equal segments for the plane generated by the bridge.

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available.

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value tapers it smaller;
positive value tapers it larger.

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount of taper is

greatest at the center of the bridge.
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5. Twist1. Twist2: Rotates the order of connection between the edges of the two selections. The two controls let you set a

different twist amount for each end of the bridge.

P i o

o |

==\

L

6.5.20 Qutline

Offsets the selected plane within the selection by the same proportion. Select "Polygon Tab > Outline" item, select the polygon

plane, and drag the cursor or enter a value to determine the offset distance.

6.5.21 Extrude Polygon

Performs vertical or horizontal extrusion of multiple planes of editable polygons within a selection set according to polygons,
groups, or local normal. Select "Polygon Tab > Extrude Polygon" and select the plane. Set the parameters in the dialog box and
click the "Confirm" button to squeeze the selected plane.

1. Polygons: Vertical or lateral extrusion in

the normal direction of the selected plane

itself. - -
_Palygon © Group _IPart normal

2. Group: Vertical or lateral extrusion in the

Height: 1.000 =] Outline: 0.000 =]

average normal direction of the selected

planes.
3. Local normal: Selected planes adjacent to
each other are merged in the direction of

their combined normal for vertical or lateral extrusion.

6.5.22 Extrude
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Extrudes the selected plane. Select "Polygon Tab > Extrude" item, the selected object will be highlighted, drag the mouse or
enter the exact value to extrude. Entering “Y” on the command line will retain the selected plane; entering “N” will not retain the
selected plane; before pressing Enter to finish the command, you can select any additional planes to continue extruding.

Note: Align the cursor to other entities when extruding, then the selected extrusion plane can be extruded to the same height

as the selected entity.

6.6 Element Tab

6.6.1 Delete

Erases the selected element. Select "Element Tab > Delete" and select the element to delete. Erases a single instance element

and also deletes other instance entities of the same source.

6.6.2 Copy

Copies the selected element. Select "Element Tab > Copy", select the element, specify the base point, and then specify the

target point to create a copy.

6.6.3 Select Invert

Selects all elements in the current scene other than the selected element. Select the "Element Tab > Select Invert" item to

select the object, all elements other than the object are selected.

6.6.4 FFD
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Adds control vertices to the selected elements to evenly adjust

Free Transformation

the object shape. Select “Element Tab > FFD” to open the dialog box
O Control Pointz Lattice Set Volume
FFD Style

1. Control Points: When using FFD under this submode, the
: o 2212

lattice frame will be shown in yellow and the control points

shown.

) ) FFD S Custom
on it can be selected and manipulated to change the shape

. . . . Current mode:  Cuboid mod
of the object. A single or multiple control points can be BRecmote |

) . Current selection:  FFD 3x3x3
adjusted at the same time. — |

2. Lattice: When using FFD under this submode, the lattice Select

frame will be shown in orange. The frame can be moved,
rotated, or scaled. By default, if the frame is moved or
scaled, only vertices within the volume of the object can be used for transformation.

3. Set Volume: Mainly used to set the initial state of lattice frame. Under this mode, when using FFD the frame will be shown
in green. The control points can be adjusted without affecting the shape of the object. This provides better control when
transforming irregular objects.

4. FFD style: The default setting is rectangular mode, with three Custom FFD Parameter

different FFD styles: "FFD 2x2x 2", "FFD 3x3x 3" and "FFD 0 cuboid made Cylinder mode

4x4x4" You can also customize the style by clicking the Cuboid parameters

Points in X direction: 3

"Customize" button to bring up the dialog box shown below.
Points in ¥ direction: 3 }_\@

(1) Cuboid mode: Creates rectangular shape lattice free-
Points in Z drection: 3

form transformations, where the number of edit points

. . . Cylinder parameters
in the XYZ axis can be set separately in the rectangular 4 P

t Default Parameter: FFD 4xG=4
parameters.

Radial points: 4
(2) Cylinder mode: Creates cylindrical shape lattice free
Side points: [ }
form. Radial, lateral and height edit points can be set
Height points: =
separately.

5. Set the parameters, select the editable polygon, and the FFD Cancel

edit box will appear on the selected volume to enter the

transformation edit mode.

Note:
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(1) During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will
end.

(2) During operations, the three submodes can be switched to one another.

(3) The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher
the number of segments, the higher the precision.

() The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points,
the smaller the range controlled by a single point.

(5) Ignoring back side is valid for FFD edit points.

(&) Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time;
if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as
one volume and then use FFD transformation.

(7) When FFD editing, move, rotate, and scale under "Edit" tab are not available.

6.6.5 Slice

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect.

Select "Element Tab > Slice", and select two points.

6.6.6 Cut

Cuts elements to create new vertices and lines. Select "Element Tab > Cut", then click on an entity to continuously specify

positions to cut the plane of the entity.

6.6.7 Tessellate

Tessellates models by choosing to split the selected planes with edge Tessellate
midpoint connections or with vertex connections. 0 Edge Face

After selecting a vertex, select "Element Tab > Tessellate", and the following s | 1

dialogue will pop up:

Choose to tessellate either edge or face, set tension, and click Confirm to

apply.

6.6.8 Drag
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Drag select, with which objects will be automatically selected when the cursor hovers over them. Select "Element Tab > Drag",

hold down left mouse button, and hover over objects to select them.

6.6.9 Fence

Fence selected. Select all elements that intersect the line you draw. Select "Element Tab > Fence", draw a polyline, and all

intersecting elements will be selected.

6.6.10 Smooth

Smooths the selected entity. Select "Element Tab > Smooth", and the following dialogue will pop up:

Sets number of iterations and whether to display smooth effect, click Confirm to apply.

Parameter Description:

[terations: Controls number of vertices that are

S th
added to the element to smooth the mesh.

Show: The smooth effect will be displayed. TurboSmooth

Hide: The smooth effect will not be displayed. Iterations: 0

Note: When the number of iterations is 0, only (

-

v

 Confim |

Show Smooth
© show

(") Hidden

Cancel

display smoothness is active.

6.6.11 Measure

Selects a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide

the line or plane. Select the item "Element Tab > Measure" and the dialog box pops up:
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Measure

Ohject Method

Line One line

Plane Two lines
0 solid

Equipartition parameter

Segment: |2 =
Shrink: |0 s - +

Slider: |0 - +

Apply Cance

1. Object; You can choose lines, planes, and solids.

(1) Line: "One line", an equal division of the selected line.

(2) Plane:
(1) One line, one plane: An equal division of the selected plane according to the vertical direction of the selected

line.

(2) Multi-line: Equally divide the associated planes based on the selected polyline.

(3) Solid:
(1) One line: The volume is divided equally according to the vertical direction of the selected line.

(2) Two lines: The volume is divided equally according to the two lines chosen.

2. Equipartition parameter: You can enter the value directly, or click the s button to adjust how many segments you want to
add, or you can drag the slider to adjust it.
(1) Segment: The default value is 2, means an equal division into 2 parts.
(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.
(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must

belong to the same entity and must be coplanar.
6.6.12 Exit
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All elements will exit the editing state. Select "Element Tab> Exit" to exit the editing state.

6.6.13 Detach

Breaks the selected element into a new, independent object. Select "Element Tab > Detach" and select the polygon to be
broken, which is grayed out by default.
Note:
(1) The entity to which the relationship is attached is separable.
(2)If the volume is divided into separate parts by operations such as removing points and lines, one of the parts

(elements) can be separated.

6.6.14 To Polygon

Selects polygons related to an element and switch to the Polygon mode.
After selecting an element, select "Element Tab > To Polygon", and the related polygons will be selected, while jumping to

the Polygon Tab.

6.7 Object Tab

6.7.1 Delete

Erases editable polygons or other entities. Select "Object Tab > Delete" and select the object to delete.

6.7.2 Copy

Creates copies of editable polygons. Select "Object Tab > Copy", select the object, specify the base point, and then specify
the target point to create a copy. The default is no instance copy. Enter “Y” and press Enter, and the entity generated by the copy

has an instance relationship with the original entity. You can copy on indefinitely before entering and exiting this command.

6.7.3 Select Invert

Selects all editable polygons in the current scene other than the selected volume. Select the "Object Tab > Select Invert"
item to select the object, the editable polygons other than the object are selected. Hidden editable polygons cannot be reverse

selected.

6.7.4 FFD
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FFD is a special lattice transformation editing tool. A lattice frame will be visible after selecting a model (a lattice frame is a
frame that envelops the object), and the shape of the object can be adjusted using the control points on the frame to produce a
smooth transformation and avoid tearing. FFD can be used directly as an editing tool or as an implied space shifting tool. Select
"Object Tab > FFD" to open the dialog box shown.

1. Control Points: When using FFD under this submode, the

Free Transformation

lattice frame will be shown in yellow and the control points © Control Points () Lattice cet Volume

on it can be selected and manipulated to change the shape FFD Style

of the object. A single or multiple control points can be FFD 2xdx2

adjusted at the same time. FFD 43 Custom

2. Lattice: When using FFD under this submode, the lattice

Current mode:  Cuboid mode

frame will be shown in orange. The frame can be moved, Current selection:  FFD 3x3x3

rotated, or scaled. By default, if the frame is moved or

Select

scaled, only vertices within the volume of the object can be

used for transformation.
3. Set Volume: Mainly used to set the initial state of lattice
frame. Under this mode, when using FFD the frame will be shown in green. The control points can be adjusted without

affecting the shape of the object. This provides better control when transforming irregular objects.
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4. FFD style: The default setting is rectangular mode, with three

Custom FFD Parameter

different FFD styles: "FFD 2x2x2", "FFD 3x3x 3" and "FFD

Cuboid mod :
444", You can also customize the style by clicking the O Cubcid mode Cylinder mode

Cuboid parameters

"Customize" button to bring up the dialog box shown below. e B

(1) Cuboid mode: Creates rectangular shape lattice free- Pointsin ¥ drection: 3 } @

form transformations, where the number of edit points Points in Z drection: 3

in the XYZ axis can be set separately in the rectangular
Cylinder parameters

rameters.
parameters Default Parameter: FFD 4x6=4

(2) Cylinder mode: Creates cylindrical shape lattice free Raddpants: |4

form. Radial, lateral and height edit points can be set oo }g

I

separately. Height points:

5. Set the parameters, select the editable polygon, and the FFD

Confirm Cancel

edit box will appear on the selected volume to enter the

transformation edit mode.

Note:

(1) During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the command will

end.

(2) During operations, the three submodes can be switched to one another.

(3) The precision of the FFD edit point on the object is related to the number of segments of the object itself. The higher
the number of segments, the higher the precision.

(4) The fewer the number of FFD edit points, the larger the range controlled by a single point; the more FFD edit points,
the smaller the range controlled by a single point.

(5) Ignoring back side is valid for FFD edit points.

(&) Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities at the same time;
if you need to execute deformation commands on multiple 3D entities at the same time, you can " Attach" them as
one volume and then use FFD transformation.

(7) When FFD editing, move, rotate, and scale under "Edit" tab are not available.

6.7.5 Slice

Specifies a slicing line to generate a slicing plane. New planes will be generated where the model and the plane intersect.
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Select "Object Tab > Slice", and select two points.

6.7.6 Cut

Cuts an editable 3D solid into multiple entities. Select "Object Tab > Cut", select the entity to be cut, specify the starting point,
and draw a polyline as the cutting line; or enter S and press Enter, and select a line as the cutting line to cut the 3D entity.
Note:
(1) Two points specified Cutting line is not available to cut 3D objects in the 3D View (available when in the Front, back,
top, bottom, left or right View).
(2) Selected cutting lines are available to cut 3D objects when in the Front, back, top, bottom, left or right View.

(3) The selected cutting line must go through the model.

6.7.7 Tessellate

Tessellate

Tessellates models by choosing to split the selected planes with edge
0 Edge Face
midpoint connections or with vertex connections.
) . . Tension: 1 =
After selecting a vertex, select "Object Tab > Tessellate", and the following o N
dialogue appears. Choose to tessellate either edge or face, set tension, and click Cancel
Confirm to apply. 1 i
6.7.8 Drag

Drag select, with which 3D objects will be automatically selected when the cursor hovers over them. Select "Object Tab >

Drag", hold down left mouse button, and hover over objects to select them.

6.7.9 Fence

Fence selected. Select all 3D objects that intersect the line you draw. Select "Object Tab > Fence", draw a polyline, and right-

click, all intersecting 3D objects will be selected.
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6.7.10 Smooth

Smooths the selected entity. Select "Object Tab >
Smooth", and the following dialogue will pop up:

Set number of iterations and whether to display
smooth effect, click Confirm to apply.

Parameter Description:

Iterations: Controls number of vertices that are added
to the element to smooth the mesh.

Show: The smooth effect will be displayed.

Hide: The smooth effect will not be displayed.

TurboSmooth Show Smooth

B © show
Iterations: =
— () Hidden

Note: When the number of iterations is 0, only display smoothness is active.

6.7.11 Measure

Selects a ling or plane on an editable polygon, enter the number of equal segments, and add vertices or lines evenly to divide

the ling or plane. Select the item "Element Tab > Measure" and the dialog box pops up:

1. Object: You can choose lines, planes, and solids.

Ohject Method
line One line
I Plane Twa lines

0 solid

Equipartition parameter

Segment: |2 = +
Shrink: |0 - - +
Slider: |0 oo +

Apply Cancel

(1) Line: "One line", an equal division of the selected line.
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(2) Plane:
(1) One line, one plane: An equal division of the selected plane according to the vertical direction of the selected
line.
(2) Multi-line: Equally divide the associated planes based on the selected polyline.
(3) Solid:
(1) One line: The volume is divided equally according to the vertical direction of the selected line.

(2) Two lines: The volume is divided equally according to the two lines chosen.

2. Equipartition parameter: You can enter the value directly, or click the s button to adjust how many segments you want to
add, or you can drag the slider to adjust it.
(1) Segment: The default value is 2, means an equal division into 2 parts.
(2) Shrink: Moves all newly generated segment lines or points, either towards the center or towards the ends.
(3) Slider: Offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes, both lines must

belong to the same entity and must be coplanar.

6.7.12 Select by Name

Selects the object by name.

Select the "Object Tab > Select by Name" item and the following dialog box will appear.
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Choose A Body By Mame

|| Caze sensitive

Modeld01 Sort

Modeloo2

Modeldn3 D alphabet sequence
I By color
| By size

1. Screening:
(1) Search box: Search for entity names, with support for fuzzy searches, where the names of models that match the
criteria are selected in the list.
(2) List of names: The names of entities under the list can be selected singly or multi-selected (by pressing ctrl or shift).
(3) Sort: Search results can be sorted alphabetically, by RGB value of the color or by size.
2. All: select all entities in the list.
3. Click the Confirm button to select the entities filtered in the list in the scene.
Note:
(1) Double-click on the entity name to position it in the middle of the view and maximize its display.
(2) You can select all models with the same initials by entering the first letter of the model name in the list in the search
field.

(3) The name selection is only valid for entities with free-form properties.

6.7.13 Attach

Attaches multiple editable polygons into one volume for easy editing and mapping operations. Select the "Object Tab > Attach"
item, and select the volume and attached objects.

Note:
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(1) Additional entities cannot select instance entities that are homologous to the subject.
(2) The editable polygon subsets when appended are all elements.

(3)To detach, you can use the detach function under element.

6.7.14 Extrude Line

Extrudes a selected line into a plane. Select "Object Tab > Extrude Line" and select the line to open the dialog box shown
below.

1. Parameter settings.

Squeere Undefined Line

(1) Squeeze direction.

) Squeeze direction
(D Select "Horizontal  squeeze"  to

Horizontal squeeze ) Vertical squeeze out
squeeze the line horizontally into a

plane. Sgueeze parameter

(2) Select "Vertical squeeze" to squeeze Squeeze value: 1.000 =
lines in the vertical direction to form a Segment: 1 =
plane.

(2) Squeeze parameters. R

Sealing begi
(1)Squeeze value: Used to set the = Bean

Sealing end
squeeze value.

(2) Segment: Used to set the number of

segments in the squeeze direction.

(3) Sealing parameter: When selecting a closed
line for squeezing, the sealing parameter
can be set to control whether the beginning and end are closed.
2. Click "Confirm" button to generate editable polygons according to the set parameters.
Note:
(1) The "squeeze" command may be executed on only one line at a time.
(2) Only "Vertical Squeeze" can be selected for 3D lines, and there is no squeeze effect for lines drawn in the Z-axis

direction.

6.7.15 Lattice
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Converts a line segment or edge of a drawing into a cylindrical structure with optional polyhedrons on the vertices, mostly

used to produce frame of buildings. Select "Object Tab > Lattice" and

select Editable Polygons to open the following dialog box. Crystal Lattice
1. Parameter settings. Parameter
(1) Parameter: Show points anly

Show lines anly

(1) Show points only: Only points of editable
polygons will be shown. O Eoth

(2) Show lines only: Only the lines of editable Line

. Radius:  0.150 c
polygons will be shown. s

Mumber of sides: 5

(3) Both: Displays both points and lines of editable
Angle:  g.oon

polygons. Ignore hidden edges

(2) Line. __|End sealing

(1) Radius: Sets the size of the radius of the volume S

generated by the crystal lattice. T B

Icosahedron

(2) Number of sides: Sets the number of edges of the

: . Radius: 0.150] =
cross-section, the larger its value the more —_—

rounded it is. Cancel

(3) Angle: Set the angle of lattice lines. \ 4

(4) Ignore hidden edges: Check this checkbox to
|attice only the visible edges; uncheck it to lattice all edges.
(5) End sealing: Check this checkbox to cap the volume generated by the latticed lines to make a closed shape.
(3) Point.
(1) Tetrahedron, octahedron, icosahedron: For setting the basic shape of the node.
(2) Radius: Used to set the radius of the node, i.e. the size of the node.
2. Click the "Confirm" button to generate it.

Note: Editable polygons cannot be latticed twice, and latticed lines cannot be angularly rotated.

6.7.16 Boolean

Two intersecting bodies can be intersected, subtracted or combined to produce a new object. Select "Object Tab > Boolean",

select the subtracted object, and then select the reference object, you can directly do subtract operations; enter “I”, select two
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objects for intersection operations; enter “U”, select two objects for merging operations.
Note:
(1) The two objects on which the Boolean operation is performed must be closed models.

(2) The order in which the two objects are selected during the subtraction operation affects the result of the operation.
6.7.17 Mirror

Generates a mirror copy of the selected volume. Select "Object > Mirror", select the object, enter “N”, the entity generated
by mirroring is not an instance of the original entity; enter “Y”, the entity generated by mirroring is an instance of the original
entity. Select the object to be mirrored to open the dialog box shown below.

1. Parameter settings.

Mirrering

(1) Mirror axis: Used to set the symmetry axis or symmetry plane of the Miror axils
mirroring. Where "offset" is used to set the offset distance of the ox "
Y ¥z
mirrored object from the original object. , .
(2) Clone current selection: Used to set whether to keep the original entity. Offet: o000 |2
2. Click the "Confirm" button to generate it. e
© o doning
Note: Copy
(1) Mirroring is affected by the in-situ position and is mirrored by its own Instance
axes when the in-situ position is turned on.
Cancel
(2) When the mirror-generated entity is an instance of the original entity,

the original entity will be changed when internal changes such as

point/line/plane/element are made; when it is not an instance, they are not affected by each other.
6.7.18 Instance

Entities and their properties can be assigned to other editable polygons. When an instance object is modified, other instance
objects bound with it will change as well. Select "Object Tab > Instance" item, first select the instance representative, and then

select other editable polygons, enter to confirm. To revoke instancing, enter “U” and press Enter and select the object you want to

revoke instancing.

Note:

(1) Objects after instantiation, when making internal changes such as point/line/plane/element, other instanced objects

will also change.
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(2)If the instance is moved, rotated, or scaled under the volume level, the instance object does not change with it.

6.7.19 Loft

Causes the selected section to generate a volume along the specified path. Select "Object Tab > Loft" to open the dialog box

shown below.

1. Align Pivot: The loft cross-section is, by default, centered on the path,
and it can be proportionally aligned to different positions as desired.
2. Parameters:
(1) Angle: Sets the rotation angle of the loft cross-section.
(2) Path: Sets the number of path segments.
(3) Step: When the section is a line, you can set the fineness of the
graph cross-section.

3. Mirror Horizontal / Mirror Vertical: Set the mode of mirroring.

After setting the above parameters, click " bl button, select a path, and
select lines or planes of editable polygons as the lofting object. Click Apply, and

an editable polygon will be generated by lofting the selected object.
6.7.20 Array

The array operation allows multiple identical bodies to be copied at the

same time and for these objects to be arranged in space in a certain order and

Align Pivot

« e s
1 ® »
Parameters
Angle: 0,000
Path: |5 =
Step: |3 =

Mirrar Horizontal

Mirror Vertical

form. Select "Object Tab> Array" item, select the object, and the following dialog box will pop up.

1. Parameter Note:
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(1) Offset distance: Sets the spacing between each array

object along the X, Y and Z axes.

X
(2) Rotation angle: Sets the angle at which the array object is Offset distance: 0,000 =
rotated. Rotation angle:  0.000 =
2. Amount: |.e. the number of copies generated. ¥
3. After setting the parameters, click "Confirm" button to generate Offsetdistance:  0.000 2
it Rotation angle:  ©-000 =
Note: Z
. - . . Offset distance:  0.000 =
(D The array is affected by the in-situ position, which when e .
. Rotation angle:  0.000 =
turned on arrays by its own axes. —_—
Mumber: 2 =

(2) Adjusting the number and Z-axis rotation angle to

achieve a circular array. e

(3 In the case of a ring array, for the same editable

polygon, if the axis position changes, the array shape

changes.

6.7.21 Adjust Pivot

Changes the position of the editable polygon axis. Select "Object Tab> Adjust Pivot", and select the object, the following
dialog box will pop up.

1. Axial transformation.

Adjust Pivot

(1) Set axis center to center: Resetting the axis to

Axis center transformation

the position of the object's center.

. . . Set axis center to center| | Set axis center to bottom
(2) Setaxis center to bottom: Placing the axis at the

Custom Axis reset

point of minimum Z value of the object's axis.

(3) Custom: Customize the position of the axis, cancel

drag the axis or axis to move it, see "Move" for k

details.
(4) Axis rest: Reset the axis location back to default.

2. Click the "Confirm" button to apply the axis settings.
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6.7.22 Align

Moves the selected object so that it has the same X, Y, or Z coordinates as the other objects. Select "Object Tab > Align" item,

select the reference object, and then select the current object,

the following dialog box will pop up. Center Aligned
1. Alignment position: Aligning the coordinate values of Alignment pasition
the current object with the reference object by O x Axis Y Axis Z Axis

different alignments. L Xz ¥z

2. Click the "Confirm" button to apply the current

settings. | V.

Note: Turning on the in-situ position only affects the

coordinates of the reference object, while the current object is always aligned to its own coordinates.

6.7.23 Shape Merge

Projects the line or plane onto a selected plane. Select "Object Tab > ShapeMerge" item, select editable polygons, and then
select Line or plane.
Note:
(1) The selected line or plane is projected onto the plane closest to the editable polygon.
(2) The lines are selected must be in the same plane and closed.

(3)The selected plane must be flat.

6.7.24 Shell

Increases entity thickness in its local normal direction or the reverse direction. Select "Object Tab > Shell", and the following

dialogue will pop up:
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Parameters:

Parameters

Inner Amount:

QOuter Amount:

Segments:

Select

Select Edges ||

Inner Faces | |

0.000

1.000

Straighten Corners ||

Outer Faces | |

Inner Amount; Increase thickness along the opposite direction of local normal.

Outer Amount: Increase thickness along the direction of local normal.

Segments: Divide the added thickness into segments.

Select:

Select Edges: Select the edges of the segments of added thickness.

Straighten Gorners: The thickness of corners will be the same as the entered thickness while executing the shell command.

Inner Faces, Outer Faces: Select inner faces or outer faces.

After the parameters are set, click "Confirm" to apply.

6.8 Solid Editing Panel

6.8.1 General Extrude

Extrudes a selected plane or line of a volume.

Note:

(1) General extrusion supports buildings, lines, planes, and volumes.

(2)Lines are not involved in extrusion.

6.8.2 Extrude Cross-section
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Selects a closed area on a plane of an entity and extrude it into a volume.

6.8.3 Make Arc

6.8.3.1 Strings into Arcs

Arcing a plane or part of a plane on a volume. Select "Modeling Tab > Solid Editing Panel> n Make Arc > H
Strings into Arcs" item. There are two types of arcing.
1. To arc the whole plane, select a plane or plane on the volume and specify or enter a value to determine the arcing distance.

The effect is shown in the following figure.

2. Type “P” and press Enter to specify two points for local arcing. The effect is shown in the following figure.

Before After

Note:
(1) Plane arcing supports planes, volumes, buildings, convex balconies, and concave balconies.

(2) When plane arcing a building, only its vertical planes may be manipulated.
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(3) Dragging the arced node to adjust the length, position and distance of the arc.

(@) Chord length arcing does not support curved planes.

6.8.3.2 Tangents into Arcs

Arcing a straight edge of a prong or plane on a volume. Select "Modeling Tab > Solid Editing Panel> “ Make Arc >

- Tangents into Arcs", select the edge or plane to be arched, enter the radius of the corner, you can specify the mouse or enter
a value less than or equal to the maximum radius
to determine the radius of arcing.
Note: Tangent arcing supports planes,
volumes, buildings, convex balconies, and

concave balconies.

6.8.4 Multi-plane Loft

3D solids are created by lofting between several cross-sections. Select "Modeling Tab > Solid Editing Panel > _] Multi-
plane Loft", there are two loft methods.

1. Lofting by straight grain effect. Select lines or planes to be generated in the selected order.

5
=
>

Before

2. Type “F” and press enter to loft with Smooth Fit Effect.
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Note: The generated models differ in the order in which the sections are selected.

6.8.5 Single-plane Loft

6.8.5.1 Move

Places the plane vertically and tangentially to the selected path. Select "Modeling Tab > Solid Editing Panel > D Single-

plane Loft > D Move", select the line or plane as cross-section, then specify the base point on the section, select the path, and
specify the placement point of the section on the path.

Note:

(1) If the cross-section and the path are coplanar, no volumes can be generated, so it is necessary to use "Placement".

(2)The location of the cross-section is where the volume is generated.

Before

6.8.5.2 Mirror

Page 199 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

Mirrors the selected plane along the specified edge to adjust its location. Select " Modeling Tab > Solid Editing Panel >

D Single-plane Loft > EE Mirror", select the line or plane as the cross-section, select the path as the mirror axis, and mirror

the section.
Note: The cross section must be on either N PN
> B > ™.
. . ~ 7 >
side of the path range, otherwise the ( T // ) Pt //
™ ~ ™~ -
mirroring will not succeed. i“*\w/’/ {“‘“ﬂ///
6.8.5.3 Path Generation Before After

Generates a volume along the specified

path. Select "Modeling Tab > Solid Editing
SIS T
: ~
Panel > D Single-plane Loft > E Path qf:/‘ / — )/
a.xﬂ/

=

Before After

Generation ", select the line or plane as cross-

section, then select the path. You can select

multiple lines as the path line.

6.8.6 Lathe

Rotates a 2D entity around an axis to generate a 3D entity. Select "Modeling Tab > Solid Editing Panel > Lathe", select
the object to be rotated, line or plane, specify the starting point of the axis. In the command line prompts there are three ways to
specify the axis.

1. After specifying the start and end points of the axes, generate entities around the axes at the angles entered.

2. Press return and pick the line as the axis of rotation.

3. Enter X, Y, or Z and press Enter to form a rotation axis parallel to a coordinate axis. For example, enter X to specify the X-

axis base point through which a rotation axis parallel to the X-axis is generated following the command line prompt. Using

the selected axis as an example, the effect is shown in the following figure.
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Before After

Note: A line wrapped around an axis generates a plane, and a plane wrapped around an axis generates a volume.

6.8.7 Split Entity

Splits an entity into multiple entities. Select "Modeling Tab > Solid Editing Panel > ﬁ Split Entity " and select the plane

of the object to be split.
1. Creates a splitting plane directly at the specified
point. Specifying points and orienting the splitting

plane to split the volume.

Bafore After

2. Enter “S” and press Enter to split the volume with

the selected split line.

3. Type “H” and press Enter to draw split lings in
the same way you would draw a polyline to split

a volume.

Note: Befare

@ Splitting objects does not support
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building components.

@ Splitting lines does not support 3D polylines and spirals.

6.8.8 Union

Creates a new solid by joining two or more solids. Select "Modeling Tab > Solid Editing Panel > |1r Union", select multiple

intersecting entities and perform union operation.

Before After

Note:
(1) Merging objects supports planes, volumes, buildings, and flower pools.
(2) The building and the volume are merged as entities to produce the building.

(3) Entities, other than buildings, must be of the same type to be merged.

6.8.9 Subtract

Creates a new solid by subtraction. Select "Modeling Tab > Solid Editing Panel > [ Subtract ", select the subtracted

object, then the reference object to perform the subtraction operation.
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Note:
(1) The objects to be subtracted and the reference objects can be planes, volumes, buildings, flower pools and water
bodies.

(2) The newly generated entity attributes after subtraction follow the subtracted object.

6.8.10 Intersect

Creates a new solid from overlapping two solids. Select "Modeling Tab > Solid Editing Panel > Intersect", select two

intersecting entities and perform the intersection operation.

Before After

Note:
(1) Intersection object can be planes, bodies, buildings, flower pools and water bodies.

(2) The newly generated entity attributes after intersection follows the first object selected.
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6.9 Generate Panel

6.9.1 Line/Plane Conversion

Converts a line whose beginning and end are connected enclosing a closed area into a plane, or converts a plane into a line.

Select "Modeling Tab > Generate Panel > E Line/Plane Conversion" and select the line or plane to convert.

Properties

&) = Plane
Alias
| B Color attached to layers 124,184.158
\, 3 54
AN
\ | 2
\\ | Building number offloors 0
\ Elevation 0.00
u
|
A\ =

6.9.2 Polysolid

Draws or extracts edges on a volume, and stretch them into planes or volumes. Select "Modeling Tab > Generate Panel >

Polysolid" item to open the following dialog box.

Drawing Line And Surface Body

EERLNE]

1. Free drawing: Draws line entities freely and stretch them into planes or volumes. Click on the [5 button to draw a line in
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the same way as a polyline, right click to end the drawing. After the cursor captures the axis is highlighted in yellow, move
or enter a value, right click to end, and stretch it into a plane; to stretch it into a volume, continue to move the mouse to

stretch or enter a value.

. Draw along the edge: Draws along the edge of the entity to obtain a line entity, and you can stretch it into a plane or a

volume. Click on the ) button, specify a point on the edge of the entity, move the cursor along the edge, right click to

end the drawing, and stretch or enter the stretch distance.

. Select a building component: Draws along the floor line of a building or component to obtain a line entity, which can be

stretched into a plane or a volume. Click on the button, specify a point on the floor line of the building or component,
and stretch or enter the stretch distance.
Note:
(1) Building components support the selection of balconies, windows, doors, roofs.

(2) When picking a point, picking a corner point that is coplanar cannot get the edge.

. Select objects: Selects lines, edges of planes, and edges of volumes to stretch them into planes or volumes. Click the )

button, select the object and stretch or enter the stretch distance.

o Lo X Xo
draw draw draw Generate
Line » Ploygon *  Solid »

6.9.3 Extract Single Plane

Extracts the outline of the specified plane of the entity and generates the plane by the outline. Select "Modeling Tab > Generate

Panel > [

Extract Single Plane" and select the entity you want to extract the plane from.

6.9.4 Plane Offset
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Creates plane entities that are equidistant from all sides of the original plane. Select "Modeling Tab > Generate Panel > E
Plane Offset", select the plane to be offset, specify the offset position directly or enter the value to be offset.

Note: When entering a distance, positive values are shifted outward and negative values are shifted inward.

6.10 Redefine Attribute Panel

6.10.1 Convert To Building Type
Defines and attributes non-specialized entities and externally imported models as specialized building entities, Select

"Modeling Tab > Redefine Attribute Panel > mConvert To Building Type", Select non-specialized entities or externally imported

models, right-click to end definition.

Delete entities converted to buildings:

1. When only one object is converted, left click on the mouse to select the object and click the “Delete” button on the keyboard
to delete the entity.

2. When converting multiple objects at the same time, if you want to delete one of them, you need to press “Ctrl” +“Shift”
on the keyboard at the same time and then click the left mouse button to select the object that needs to be deleted, and then click

the “Delete” button on the keyboard to delete the entity.

Page 206 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

Note:

(1) The definition of particle entities, light entities, plant entities, animated entities buildings are not available.

(2) Supports grouped entity definitions, if there are unsupported entities within the grouping, they are excluded and the

remaining entities are defined.

(3) Objects are grouped when multiple object definitions are selected.
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7 View Menu

This chapter presents a range of commonly utilized 3D viewing tools, which can be employed by the user to fine-tune the

project's visual impact for optimal results during the design process.
7.1 Perspective Panel

7.1.1 Pan

Moves the position of the view without changing the position or scale of the objects in the drawing. Press and hold the middle

mouse wheel enables Pan operation as well.

7.1.2 Orbit

Dynamically moves the observer around the model while maintaining the same focus point. Pressing “Ctrl + middle mouse
wheel” enables orbit view as well. If you have an entity selected and then use this function, the view is rotated with that entity as the

center point.

7.1.3 Centering

Zooms to display the largest extents of all objects. It calculates all extent of objects and the original coordinates of drawings

will not be modified. Select Centering tool to fix these problems.

7.1.4 Full View

Displays all entities in the workspace to the maximum extent possible. Enter “Z” and press Enter at the command line. Enter E

and press Enter can achieve full map operation as well.
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Houseplan

Material Scene Video Services

Y & es | & > {F id T

Pan Orbit Centering Full |Frame View Eye Front Window Previous Hide Hide  Unhide
View lelection Control View Face View View Selected Unselected
Perspective 3D Navigate View Tools

7.1.5 Frame Selection

Maximizes the display of the selected model or structure. Select the " View Tab > Perspective Panel > E&# Frame Selection"

item to center the selected object in the view. If there are no selected objects, the effect is the same as in "Full view".

7.2 3D Navigate Panel

7.2.1 View Control

Switches current workspace 3D perspective view from different directions. Click
on the corresponding blue arrow to set the view direction, and click on the "Flat" button

in any view, the view will turn to the flat state.

7.3 View Tools Panel

7.3.1 Eye View
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Turn on human eye view perspective. Select "View Tab > View Tools Panel > Eye View", follow the command line prompts,
set the height offset, and specify the site location. The angle of view will automatically shift to the current eye height, and the default
is the sum of the site height and the offset height. You can continue to enter values to adjust, and the view will be lowered or raised.

Press and drag the left button in the scene to view around by human perspective.

Note:
(1) Height offset means height of human eye. Height offset + height of site location = final eye height.
(2) After designating a position, you can rotate the view by dragging the mouse to browse, or use the arrow keys 1, |,

«, — on the keyboard to rotate and move the operation.

7.3.2 Front Face

Selects the plane on the volume to display its front view.

7.3.3 Window View

Maximizes the display of selected area, and enables full display and return to the previous view. Select Window View tool, and
directly specify a two-point box range to zoom in on the view within that range. At the command line prompt, enter “E” to display

the full view; enter “P” to return to the previous view.

7.3.4 Previous View

Returns to previous view performed.

7.4 Hide Panel
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7.4.1 Hide Selected

Hides the selected entities. Select "View > View Tools > E Hide Selected" and select the entities to hide.

7.4.2 Hide Unselected

Hides unselected entities. Select "View > View Tools > H Hide Unselected", select entities, and hide all other entities.

7.4.3 Unhide

Unhides entities. Select the "View > View Tools > H Unhide" item to display the hidden entities in the view.
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8 Material Menu

Material refers to the texture of an object and can be seen as a combination of object material and texture. In rendering programs,
it is the combination of the various visual properties of the surface, referring to the color, texture, smoothness, transparency,

reflectivity, refractivity, luminosity, etc. of the surface.

8.1 Material Panel

8.1.1 Image
Automatically calculates the texture of the plane of an entity and attaches the image material to the entity at the appropriate

size. Select "Material Tab > Material Panel > Image", the following dialog box will appear.

© singleside () Layered () Multifaceted () Single entity
[#-- Residential building
[#-- Office building

..... Commerdial building % +
----- School
..... Hospital

1 2

[#-- Ancient building Standard

Parameter adjustment Reflection map  Bump map
& ¥ oiffuse: [l 120,120,120

Specular Color: - 0,0,0
3 4

emissive: | .00

Yy

Smoothness: 0 |
Specular level: 0 [ ]
4 + _———
Glow: g 1
5 [

Anisofropy:  1x

HCRECRE

afv] | £

Opacity: 100

Alpha test: 0 =1
4 + - ) - )
Color adjustment | UV Transformation ) Double-sided display

1. Apply Material
(1) Single-side: Applies the material on a single side of an entity, and paste a whole material image on one plane. Click
"Single-sided" button, the cursor will change to a straw, and select the material in the dialog box or pick the material
of existing entity.
(2) Layered: Paints materials according to the floor of the building.

(3) Multifaceted: Paints multiple sides of the entity continuously, and calculate the texture size automatically according
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to the height. Click "Multi-sided" button, select the material, select the starting plane of the entity.
(4) Single entity: Paints the material on the entire entity.
2. Material Adjustment.
(1) Preview window.
(1)  Apreview window can be added after double-clicking on the default material in the dialog box or after drawing
a material on a scene entity.
(2) Right-click on the preview image to reset one or reset all the materials in the preview window, view the path
of the material, and add the material to the Favorites directory or overwrite the original material with the adjusted

material.

Apply Textures

(® single-side () Element (O Layered (_) Single entity () Group () Multi-select () MultiPolygon

Reset
Wall space Reset all
Window
Image path
Doar L=l
Glass screen wal Add to Favorites
Handrail Overwrite
Housetop 1 £ >
Glass
Metal Standard ~
Tie Parameter adjustment  Reflection map Bump map
Wood
Road Diffuse: 244,153,30
Slabstone
Bottom of the pool Specular Color: - 45,45,45
Emissive:
Parapet wall
Ground Smoothness: | 149 = 1
Specular level g, 5 = 1
Glow: [o =1
Anisotropy: | 1x ~
Opacity: | 100 z 1
Alpha test: [g =1
olor adjustment| UV Transformation [] Double-sided display

(3) Drag and drop the material to a new preview window to copy the material.

(2) Material effects: The dialog box is preset with five material effects: standard, glass, metal, wood and dirt, which can
be selected in the drop-down menu.

(3) Parameter adjustment: Adjustment of the parameters of the material. Glow is only effective at night.

(4) Color adjustment: Adjusts the color parameters of a material, click "Color Adjustment" button to open the dialog box

shown below.
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Color Adjustment X

Hue:
Saturation:
Brightness:

Contrast:

.
ll

B 3

A

3 1% B 1T me
TN
T TN TNETE s

%

Reset

Users can adjust different color parameters like hue, saturation, brightness and contrast.

After adjusting the parameters, click on the "Save" button to save the adjusted parameter values and apply them;
click "Reset" button to restore all parameter values to their default values.
(5) UV Transformation: Adjusts the UV animation rate of the material to make it have dynamic effect. Click the "UV

Transform" button. Adjustment of parameters changes material effects in real time.

UV Animation
Speedu 0.0 % |

speedV 0.0 [ I

(6) Double-sided display: Checks to display both sides of the entity after painting the material; uncheck to display one
side of the entity after painting the material.

(7) Reflection map: Adds a reflection map to the material and adjust the parameters to make the material more realistic.
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(8) Bump map: Adds a bump map to the material to give it a bumpy feel.
3. Add material.
(1) Click the right mouse button in the category list to open the context menu, as shown above.
(1) New: New material type.
(2) Delete: Deletes the newly created material type.
(3) Edit: Modifies the name of the new material type.
(4) Import: Select the folder and import the folder's material images.
(5) Import cpr: Select the cpr format file and import the material.
(6) Export cpr: Export the material in the catalog to cpr format
(2) Right-click on the material image or on a blank space to open a context menu to remove or add materials.
Note:
(1) External images can be in jpg, png, dds formats.

(2) You can drag an external image into workspace, select the paint method and object to paint it.

8.1.2 Material

7
Paints the material on the entity with the default texture parameters. Select "Material Tab > Material Panel > Material" to

open the following dialog box.
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© singleside () Element () Layered () Single entity {_) Group (_) Multi-select {_) MultiPalygon
Wall space
Window
Glass screen wall
Handrail
Housetop 1 2
Glass
Metal Standard e
Tile Parameter adjustment Reflection map  Bump map
Wood
Road oiffuse: [l 120,120,120
Slabstone -
Bottom of the pool Specular Color: - 0,0,0
Parterre 3 4 L
Emissive: 0,0,0
Parapet wall - e e
Ground Smoothness: 0 = |
Favorites
Specular level: 0 = [ ]
Glow: p =1
5 5 Anisofropy:  1x £
Opacity: 100 = 1
J ‘ Alpha test: 0 =1
3 Color adjustment | UV Transformation ) Double-sided display
L.

(1) Single-side: Paints a material on a single side of an entity, applying the material to the plane in accordance with the
default texture.

(2) Element: Paints the material on a single element of the attached entity. Only for elements in editable polygons.

(3) Layered: Paints materials according to the floor of the building.

(4) Single entity: Paints material on the entire entity.

(5) Group: Paints material on the entities in a group.

(6) Multi-select: Selects multiple entities to paint the material at same time.

(7) Multiolygon: Paints materials onto multiple planes of editable polygon entities.

8.1.3 Coating

Paints coating onto entities. Select "Material Tab > Material Panel > ﬁ Coating" to bring up the following dialog box.
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Base color(B):

N NN .
H YN N
HENNENENNMN
s B 8 B B B
8 8 B B B 0 B |
B B B B B8 BN

Custom color(C):
AN EE . Hue(): 0 Red(R): 250
HEEN ' B Saturation(S): 0 Green(G): 250
© single-side (| Single entity ) Group CoIorlPunty(O) Brightness(L): 250 Blue(B): 250
_ layered

[ Multi-select Add to custom color(A)

"Custom colors" are saved in the software, so you can add frequently used colors to "Custom colors" for future use.

When drawing in colors, the RGB values drawn in can be inaccurate due to ambient light effects.

8.2 Edit Panel

8.2.1 Adjust Texture

Adjusts the display scale, orientation, and position of entity materials. Select "Material Tab > Edit Panel > Adjust Texture

" to open the following dialog box.
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1. Zoom:; Adjusts the scale of material textures. Adjust Textures
2. Rotate: Adjusts the orientation of the material Zoom
Horizontal |0.708 2
texture. ¥
Vertical 0.708 =
3. Panning: Adjusts the position of the material - +
Rotate
texture. Angle o000 *
4. Face Editing: Modification of the material — = g =
texture of a single side. Horizontal [0.000 5 .
5. Body Editing: Modification of the texture of the Vericll  [0.000 =
a
same type of material on a single entity.
Body Editing Modify All Mirror Horizontal |~ Mirror Vertical

.

6. Modify all: Modifies the textures of all

materials of the same type in the scene.
7. Mirror Horizontal: Mirrors the selected single-sided, single-volume or full material in the horizontal direction.
8. Mirror Vertical: Mirrors the selected single-sided, single-volume, or full material in the vertical direction.

Note: You can use the "Material" function if you want to apply an adjusted texture to another entity.

8.2.2 Replace Material

Replaces materials of the same type on multiple or all entities in the scene. Select "Material Tab > Edit Panel > Yl Replace

Material ".
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Replace Material

I Multiselect @ all
Wall space

1. Multi-select: Replaces the same type of material on the selected entity. Click on the "Multi-select" button, select the
default material or the material of the entity on workspace, then select the object to replace the material, and finally select

the material to be replaced.

2. All: Replace the same type of material on all entities. Click on "All" button, select the default material or the material that
draws the entities on workspace, and then select the material to be replaced.

Note: "Replace Material" only replaces the texture and material effect, not the UV of the texture.

8.2.3 Free Adjustment

The material textures of the entities are mapped to the appropriate projection and adjusted to refine the effect of the project.

Select "Material Tab > Edit Panel > = Free Adjustment".
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Free Adjustment

BEOEE | B & |Osmeste Omittoeied Osoty O
Range
L |1.000 =1 . +
Y
W | L000 =1 - + {»-:ﬁ:
|'\J.'.
H |1000 = - ¥
Amount
U | Looo = - 0y .
{,,qaz-
.rl]_|.-\.l
v |1000 =1 . - 2
Panning
U |0.000 =1 . +
-
v |0.000 -] . + {»:ﬁ:
|LJ.'.
W |0.000 =1 - ¥
Rotate
U |0.000 =
-130 0 180
v |0.000 =
- i
-180 0 180 {’5:.:.:
W |0.000 =
-130 0 180
Scale
U |1ooo0 = - 1
Vo
v 1000 S + {»::f:
|'\J_'.
W | 1000 =1 . 1

1. Material texture projection method.
(1) Cube Retextures the material of an entity as a rectangle projection.
(2) Cylinder: Retextures the material of an entity as a cylindrical projection.
(3) Sphere: Retextures the material of an entity as a spherical projection.
(4) Plane: Retextures the material of an entity as a planar projection.
(5) Surface: Retextures the material of an entity as a default projection.

2. Mirroring.

(1) Mirror Horizontal: Mirrors in U-direction selected single-sided, multi-sided, single-body or all materials.
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(2) Mirror Vertical: Mirrors a selected single-sided, multi-sided, single-body or all materials in the V-direction.
3. Adjustment:

(1) Single-side: Selects a single plane and adjust the material on the single plane.

(2) Multifaceted: Selects multiple planes, and adjust the materials on multiple planes.

(3) Body: Selects a single entity, and adjust the material on the entity.

(4) All: Selects multiple entities to adjust the materials on all entities.
4. Parameter adjustment.

(1) Range: Sets the length, width and height of the edit box.

(2) Amount: Sets the number of times the material texture is repeated.

(3) Panning: Sets the offset distance in the UVW direction of the material texture.

(4) Rotate: Sets the rotation angle in the UVW direction of the material texture.

(5) Scale: Sets the scale of the material texture in UVW direction.
Note:

(1) Free adjustment does not support the selection of file entities (fox/skp/osgb models, image maps, matching entities,

plant entities, skeletal animations).

(2)Click on the blue texts to reset the parameters.

8.2.4 Match Material

Matches and applies a selected material of existing plane, volume or building to other ones. Select "Material Tab > Edit Panel >

Match Material" to pick a material. You can choose the painting method according to the command prompt. There are five
types of painting methods.

1. Direct select the entity material to totally match another entity.

2. Pick a material, type “D” and press Enter to apply the material to a single plane.

3. Pick a material, type “L” and press Enter to apply the material to a single floor of the building.

4. Pick a material, type “M” and press Enter to apply the material to multiple entities.

Note: "Pick Material" not only mimics the texture and material effect, but also mimics the uv of the texture, which is different

from "Replace Material .
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8.2.5 Glass Effect

Applies glass effect to existing glass component. Select "Material Tab > Edit Panel > D Glass Effect".
1. Single-select; Click on the glass material to

apply a glass effect to the selected glass o _ _
Single dlick to select the entity. Double dlick to select all glasses

component.
2. Select All: Double-click the glass material to
apply a glass effect to all glass components.

Note: Supports the selection of balconies,

windows, doors, dormer windows, and glass

curtain walls. The effect can also be applied to

glass materials on other entities.

8.2.6 Outside Wall Region

Zoning of the building's vertical planes and the gables to allow for material painting to refine the project's effect. Select "Material

Tab > Edit Panel > Outside Wall Region".

1. Horizontal area: Draws horizontal zones. Click the Q button to
Outside Wall Region

O mo8 =

specify the starting position or enter “C” on the command line to

[

select by floor.

(1) After specifying start and end points, then follow the command —
line prompts to select another vertical plane.
(2) To draw by floor, enter “C” and press Enter, specify directly or

enter the number of floors to determine the starting floor, then

determine the ending floor, then select other vertical planes as - -

prompted on the command line.

2. Vertical Area: Draws vertical zones. Simply click on the |]:| button

and follow the command line prompts to specify the start and end positions.

3. Horizontal Surround: Draws a zone through the floors. Click on the = button to specify the starting position or enter “C”
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on

the command line to select by floor, in the same way as for "Horizontal Area".

4. Graphic projiction: Defines closed lines or planes as zones or project onto a building to automatically generate zones.

Clicking on [=l] button and select a plane or closed line will allow the selected object to be projected onto the building to

generate a zone.

5. Bring to top: Adjusts the display order of overlapping zones. Click on the T | putton and select the overlapping zones to

display the selected zone on top.

Note:

(1) Snap needs to be turned on when drawing zones.

(2)Floor Zoning can only be drawn or defined on the above-ground part of a building, and they belong to the building
and are changed when the building is moved, deleted or copied.

(3)Roofs do not support Floor Zoning for drawing horizontal areas.

() For image mapping, the cursor click point must be projected on the building and the selected object must be < 2
m from the building for the mapping to be successful.

(5) Double-click on the Floor Zoning to drag and drop the clip point to edit or press Delete to delete.

(6) Double-click on a building to select all zones on it.

(7) When the height of a building changes, the zones selected by floor also changes.

Checking the Floor Zoning allows modifying the hierarchical relationships in the right-hand property column.

(9) Please use the "single-body" paint method when painting the zoned material.

8.2.7 Material Optimization

Optimizes and merges same materials. Select "Material Tab > Edit Panel > Material Optimization" to apply this function.

Use this feature to optimize material efficiency when the scene is large.

8.2.8 UV Editor

UV Editor can adjust the textures of model materials. The interface is a 2D space and the UV textures dynamically change with

related 3D

model. While adjusting texture coordinates, if the UV texture is complicated, just execute the Mapping UVs feature to

update the 2D texture coordinates of the 3D model, and the curved faces will be cut into proper shells, which are displayed on the
same plane and available to be exported to other drawing software to apply textures for the 3D model. After that, the UV Editor also

supports to perform necessary minor adjustments.
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Select "Material > Edit Panel > UV Editor", and the following window will pop up:

UV Editor n

State  UVSnapshot  MappingUVs  Cut  Sew  Unfold  Layout Tool -=—Ribbon

Y R uf

® " E |5vmm v | [Mon | |-€—Status Bar

8.2.8.1 State

Switches texture border display, shades UV shells, and toggles whether textures are shown in UV Editor. Select "UV Editor >
State", and the dropdown menu will be as follows:

1. Texture Borders: Toggle display of texture borders on UV shells. If on,
Texture Borders

Distortion Shader

the borders will be shown in yellow highlight.
2. Distortion Shader: Determine the stretched or compressed areas by Image
coloring the shell. Red means stretched, and green means compressed.
The darker the red, the more stretched, and vice versa. White means normal.

3. Image: Toggle whether to show textures in UV Editor.
8.2.8.2 UV Snapshot

Exports the current UV images to external files. Select "UV Editor > UV Snapshot", and the following dialogue will pop up:
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UV Snapshot >

File name: | | |

1024

Size(pixel):

Color Value: -

Parameter Description:

1. File name: Set the name and save path of the current UV images. Click L === | button, enter a file name, and specify a file
location.
2. Size (pixel): Set the size of current UV maps.
3. Color Value: Set the border color of UV maps.
After setting these parameters, click Confirm to export.
Note:
(1) Exporting cannot be done if no models are selected.
(2) Under point, ling, or UV vertex mode, the entire model in the UV editor will be exported even if only partial is selected;

under poly, ele, or UV shell mode, only selected part will be exported.

8.2.8.3 Mapping UVs

Mapping includes automatic, planar, spherical, and cylindrical mapping. Select the appropriate mapping method based on the

general shape of the model. Select "UV Editor > Mapping UVs", and the following dialogue will pop up:

Mapping UVs >

Automatic LIV [

Flanar UV ¥ ¥

]

Spherical Uy

Cylindrical Uy
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Parameter Description:
1. Automatic UV:

Automatic UV tries to find the best UV placement by projecting from multiple planes. It creates UV coordinates for the
selected object or polygon, with the default being six projection planes. Click the dropdown button to select the number of
projection planes and set projection plane parameters to affect the result of automatic UV mapping. The more projection

planes, the fewer stretched and compressed planes there are. As shown below:

Model in the 3D scene Unfolded maps in the editor

When using automatic UV mapping, the 3D view will display projection planes, gizmo, and rotation axis relative to the

screen with the selected object in the center, as shown below:
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Projection Plane

Gizmo

Rotation axis
relative to screen

v
Coordinate Axes

(1) Projection planes are blues planes with an opacity of 60%. Each border of a projection plane is displayed in either
red or green, corresponding to the UV coordinate axes, the axes of the viewport of the mapped model.
(2) The gizmo can be moved, rotated, and scaled to adjust the bounding box of the 3D model to change the mapping
result.
(1) Move: Put the cursor on the axis, axial plane or axial center of the gizmo. When the gizmo is highlighted in
yellow, hold down left mouse button to drag.
(2) Rotate: Click on the rotation axis relative to the screen to activate. Put the cursor on any rotation axis, and
when the axis is highlighted in yellow, hold down left mouse button to drag.
(3) Scale: Click on the cube at the end of the axes and put the cursor on a cube. When the cube is highlighted in
yellow, hold down left mouse button to drag.
2. Planar UV
Use planar UV to create UV texture coordinates for the selected object. The default is the X-axis. Click to select X, Y, or Z axis

and generate a projection plane based on that axis, as shown below:
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Model in the 3D scene Unfolded maps in the editor

When using planar UV, the border will be shown with the selected object as the center in the 3D view, as shown below:

Border
Frame

(1) The border frame is shown in "FH" shape. Move and scale the border frame to change the width to height ratio in the
mapped result to avoid distortion.
(1) Move: Put the cursor on the cube at the center of the border frame. When the cube is highlighted in yellow,
hold down left mouse button to drag.
(2) Scale: Put the cursor on the corner or the midpoint of an edge. When the point is highlighted in yellow, hold
down left mouse button to drag.

(2) Click the intersecting lines on the frame to activate gizmo and rotation axes relative to screen. Click again to hide
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them. See Automatic UV for detailed instructions on gizmo and rotation axes.
3. Spherical UV
Use spherical UV to create UV texture coordinates for the selected object. This projection loops around the mesh. It's

best used for completed closed spheres without holes. The effect is shown below:

Model in the 3D scene Unfolded maps in the editor

When using spherical UV, the bounding frame will be shown in the 3D view with the selected object in the center, as

shown below:

(1) There are cubes of different colors on the bounding circles which can be used to adjust the position and size of the
bounding circles.

(1) Green cube: Put the cursor on the green cube, and when it's highlighted, hold down left mouse button to drag
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the cube and the bounding circle will be changed along the local Z axis.
(2) Red cube: Put the cursor on the red cube, and when it's highlighted, hold down left mouse button to drag the
cube and the bounding circle will be changed along the local X axis.
(3) Blue cube in the center: Put the cursor on the blue cube in the center of the bounding circle, and when it's
highlighted, hold down left mouse button to change the scaling of the bounding circle.
(4) Blue circle: Put the cursor on the blue circle, and when it's highlighted, hold down left mouse button to change
the rotation of the bounding circle.
(2) Click on the cubes on intersecting lines to activate gizmo and rotation axes relative to screen. Click again to hide
them. See Automatic UV for detailed instructions on gizmo and rotation axes.
4. Cylindrical UV
Use cylindrical UV to create texture coordinates for the selected object. This projection loops around the mesh. It's best

used for completed closed cylinders without holes. The effect is shown below:

Model in the 3D scene Unfolded maps in the editor

When using spherical UV, the bounding frame will be shown in the 3D scene with the selected object in the center, as

shown below:
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(1) There are cubes of different colors on the bounding circles which can be used to adjust the position and size of the
bounding circles.
(1) Green cube: Puts the cursor on the green cube, and when it's highlighted, hold down left mouse button to
drag the cube and the bounding circle will be changed along the local Z axis.
(2) Red cube: Puts the cursor on the red cube, and when it's highlighted, hold down left mouse button to drag
the cube and the bounding circle will be changed along the local X axis.
(3) Blue cube in the center: Puts the cursor on the blue cube in the center of the bounding circle, and when it's
highlighted, hold down left mouse button to change the scaling of the bounding circle.
(4) Blue cube connected to the center: Puts the cursor on the blue cube, and when it's highlighted, hold down
left mouse button to change the rotation of the bounding circle.
(2) Click on the intersecting lines to activate gizmo and rotation axes relative to screen. Click again to hide them. See

Automatic UV for detailed instructions on gizmo and rotation axes.
8.2.8.4 Cut

Separates UV along selected edge to create UV borders. Select "UV editor > Cut", put the cursor on the edge to be cut, and
when the edge is highlighted in white, hold down left mouse button and hover over it.
Note:
(1) The cut function can be used in the UV view and the 3D view.
(2) Before the cut command is finished, the selected cutting line is green by default. Hover over the green line and it will

be sewed.
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8.2.8.5 Sew

Sews the UV along selected edge to sew two separated lines together. Select "UV editor > Sew", put the cursor on the edge
to be sewn, and when the edge is highlighted in white, hold down left mouse button and hover over it.

Note: When the cursor hovers over sewn edges, the sewing is done automatically.
8.2.8.6 Unfold

Unfold UV along cut lines. By unfolding the UV onto a 2D space, texture drawing can be easily done and applied to the model.
Select "UV Editor > Unfold", and select the model to unfold.
Note: UV make up the UV grid, similar to how vertices make up polygon meshes. The unfolding process is like cutting a piece

of cloth and laying it on top of a table.
8.2.8.7 Layout

Automatically arranges the UV shells to maximize the space utilization from 0 to 1. It can also set the size of UV shells. Select

"UV Editor > Layout", and the dropdown menu is shown below:
Layout Along

Texel Density

1. Layout Along: Automatically arrange the UV shells to maximize the space utilization from 0 to 1. Click Layout Along and the

following dialogue will pop up:

Layout Along x>

Texture Map Size(pixel): | 1024 =

Shell Padding: | 10,000

Freserve 30 Ratios: [

Apply Reset

(1) Texture Map Size (pixel): Set the resolution in UV space to calculate the pixel filling value.

(2) Shell Padding: Set the pixel gaps between UV shells.
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@ ~ O El|[+] [ [0 smmeme ] b

(3) Preserve 3D Ratios: Toggles the shells will be scaled according to their corresponding area on the 3D model;
untoggled: the shells will be scaled according to the size of the shells after unfolding.
After setting the parameters, click Apply to get the layout. Click Reset to reset to default.
2.Texel Density: Sets the size of UV shells by specifying the amount of texels included per unit. Click Texel Density and the

following dialogue will pop up:

Texel Density et

Pixels per unit: |3 140

After setting the density, click Get to show the texel density of selected part; click Set to scale the UV shell to fit the

specified texel density.
8.2.8.8 Tool

The texture borders may be unable to be detected for unfolded external models imported to this software. Or models made with

this software might sometimes be unable to show the texture borders. You can solve the issue by using the Refresh Shell command.
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Select "UV Editor > Tool", and the dropdown menu is shown below:
1. Refresh Shell: Gets the texture borders of UV shells.
. . Refresh shell
2. Orient to Edges: Selects an edge on the shell as reference, rotate this siresh she
Orient to Edges
edge to make it parallel to the u axis or v axis to adjust the direction of
the shell. The rotation direction can be set by the angle between the
selected edge and the u or v axis. Normally the rotation direction is toward the side with the smaller angle. If the angle is
exactly 45 degrees the direction will be on the u axis.

Note: Orient to Edges can only be used under the line mode.

8.2.8.9 Status Bar

Before entering a sub-mode, the default state does not allow editing in the unfolded model view. Click a button on the status

bar to enter editing mode. Different buttons correspond to different editing objects.

1. Point; After clicking button, only points can be selected in the editor, and the shared points of which are selected at

the same time automatically.

2. Line: After clicking == button, only lines can be selected in the editor, and the shared lines of which are selected at the

same time automatically.

3. Polygon: After clicking D button, only polygons can be selected in the editor.
4. Element; After clicking button, only elements can be selected in the editor.

5. UV Vertex: Used alongside Point. Click E button, and point button is automatically selected. Select points in the 3D
view and all corresponding UV vertices in the editor are selected as well. And the shared points of the selected points in the
editor won't be selected automatically.

6. UV Shell: The button cannot be used by itself. It must be used in conjunction with the Point, Line, or Poly button. After

P

clicking Lt--

r
boo

button and anyone of the Point, Line or Poly button, and select part of the model in the editor, which will be

shown in points, lines, or polygons.

7. UV Symmetry: Make another part with a symmetry relationship in the UV view to get the same change as the selected part.

For example, after making the modification of source objects, clicking the button, selecting the source objects and

right click, a bold symmetric line appears, you can select the bold symmetric lines or hold down Ctrl while dragging with
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the left mouse button to adjust the position of the bold axis vertically and horizontally to determines where the symmetric

shell is placed in the UV Editor workspace. Then, specify the symmetric plane in the 3D entity and right-click.

UV Editor [ |

State UV Snapshot  MappingUvs ~ Cut  Sew  Unfold  Layout Tool

® ~ B 6 [][] Do e v ]

8. Symmetrize: This option is for models that have a symmetry relationship in the 3D view. After selecting the symmetry axis,
a part of the model is selected and the symmetric part of the model is also selected at the same time. You can click the

dropdown button to select the axis, and then operate in the editor.

9. Material: The checkboard is the default material of the software, mainly used to check whether the UV shells are stretched.
Additionally, the material information will also be shown in the dropdown list.

Note: When entering point, line, or element mode in the editor, select a point/line/UV shell, and the corresponding

point/line/UV shell in the 3D view will also be selected.

8.2.8.10 Toolbar

1. Move: Clicking the button, in addition to selecting an entity in the UV Editor window for the move operation, you can

also select an entity in the 3D view for the move, which corresponds to the Move command in the advanced modeling. The

object is moved in the following ways.

(1) Move directly, click on an object and drag the mouse directly to move the object.
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(2) Select and move. Add the object to be moved to the selection set first, and move it by specifying the reference point

in the selection set as the base point.

(3) Right-click the Move button and set the move distance of the selected object in the pop-up window.
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Move Transform Type-In

7. 0.000

The direction of movement is determined by the mouse and the current reference coordinate system. 2D coordinate
system is displayed in the UV Editor window, the object can only move in 2D plane, it has linkage with the advanced modeling
interface movement. To restrict the object to move in the X or Y axis, click directly on the axis to temporarily lock the

corresponding axis, you can also use the "constraint" related commands in the advanced modeling window to lock the axis.

2. Rotate: Clicking the ¥ button, in addition to selecting an entity in the UV Editor window for the rotate operation, you can
also select an entity in the 3D view for the rotate, which corresponds to the Rotate command in the advanced modeling.
The object is rotated in the following ways.

(1) Direct rotation, click on an object and drag the mouse directly to rotate the object.

[0.00.0.00,-41.92]

(2) Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying the reference
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point in the selection set as the base point.

(0.00,0:08,-109.38]

(3) Right-click the Rotate button and set the rotation angle of the selected object in the pop-up window.

Rotate Transform Type-In

The direction of rotation is determined by the mouse and the current reference coordinate system; the UV Editor window shows
a 2D coordinate system, the object can only be rotated in the 2D plane, it has a linkage with the rotation of the advanced modeling
interface. To restrict the object to rotate in the X or Y axis, click directly on the axis to temporarily lock the corresponding axis, you

can also use the "constraint" related commands in the advanced modeling window to lock the axis.

3. Scale: Click the |E| button, select an object, in addition to selecting an entity in the UV Editor window for the scale operation,
you can also select an entity in the 3D view for the scale, which corresponds to the Scale command in the advanced

modeling. The object is scaled in the following ways.
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(1) Direct scaling, click on an object and drag the mouse directly to scale the object.

(2) Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the reference

point in the selection set as the base point.

(3) Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window.
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Scale Transform Type-In

¥: 100,000 vy, 100,000  z o: 200,000

The direction of scaling is determined by the mouse and the current reference coordinate system; the UV Editor window
shows a 2D coordinate system, and the object can only be scaled in the 2D plane, which is linked to the scaling of the advanced
modeling interface. To restrict the object to scale in the X or Y axis, click directly on the axis to temporarily lock the

corresponding axis, you can also use the "constraint" related commands in the advanced modeling window to lock the axis.

4. Ring Select: Click on the button, set the interval, select an object, and appropriate lines will be selected.
5. Loop Select: Click on the . button, set the interval, select an object, and appropriate lines will be selected.

6. Target Select: Click on the H button, hold down left button, and hover over points to select them.

7. Borders: Click on the & button, select an object, right click to select points, lines, polygons, and UV vertices on the

outermost ring of the UV shell.

8.3 Display Panel

8.3.1 Backface Cull

The Backface Cull command determines whether the back faces of polygon planes are culled and not displayed. Select

"Material Tab > Display Panel > =8 Backface Cull" to apply this function. The direction the polygon normal faces determines

whether it is displayed when Backface Cull is enabled.
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Polygons that are facing away from the viewport or polygons that are inside of an object and facing the viewport are not

displayed, if you click the Backface Cull feature again, they can be displayed again.
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9 Scene Menu

In the process of planning and designing a project, the layout of the scene is particularly important. It reflects the style and
design effect of the final plan, and also reflects the scenery ability and aesthetics of the designer. This chapter talks about the creation
of roads and site entities, the arrangement of background entities, and the insertion of skeletal animation elements, so that the user

can flexibly use the functions when arranging the scene and make the project present a delicate and realistic effect.

9.1 Road Panel

9.1.1 Urban Road
Urban roads are the main traffic routes in the city or outside residential neighborhoods. Houseplan 2.0 provides templates for

urban roads to facilitate quick drawing. Select "Scene Tab > Road Panel > |IEI] Urban Road" to open the following dialog box.

Urban Road

Onedane  Twodane Threedane Fourdane

Sidewalk: 2.0000

Lane: 8.0000 White single line -~ Dotted line

Sidewalk: 22,0000

Total width: |12, 0000

1. Draw urban roads: Select the lane type and set the parameters in the dialog box, click "Confirm" button, and then draw
directly at the specified point in the sceneMATERIAL Can be drawn continuously; enter “U” to go back to the previous step
and right-click to end the drawing.

2. Line to Road: Import or draw the line entity representing the road in the scene, select the lane type and set the parameters
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in the dialog box, click "Confirm" button, enter C in the command line, select the line and right click to finish. The selected
line entity will be converted to an urban road.

3. Parameter Description: In the dialog box, switch the Tab page to select the lane type (e.g., "two-lane roads"), set the sidewalk
width, lane width, separation width, and other parameters. "Total width" is calculated automatically according to the width
of the sidewalk, etc. In the right side, check the sidewalk to be displayed and set the color, single and double lines and
dashed line style of the sidewalk. If you want to set a different width, you can modify the value below separately.

Note:

@ When drawing a curved road, "tangent arc" means the section of the arc road is tangent to the previous section of
the road, "convex arc" means the ends of the arc road are drawn before specifying their radius, and "three-point arc' means the
specifying second and third points of the arc in sequence to generate the arc road.

@ When a road is drawn with a turning point, a range of arc radius is given based on the angle between two roads,
with the default arc radius being the width of the road.

@ When roads that are drawn and converted from lines cross, the road surface and pavement and other components
are automatically fused. When road segments are moved or deleted, the roadway with which they were originally fused also
automatically handles the boundaries.

@ For roads that are drawn and converted from lines, they are made up of individual sections and road corners,
requiring all sections to be selected for overall movement.

® For roads that are drawn and converted from lines, after selecting a road section, drag the midpoint to move the
road section, and drag the start and end points to change the position of their ends. Dragging will snap to the height of the
target point, e.g., if the road has a start elevation of 10, if the start is dragged to the 0 plane, the start elevation will also change
to 0.

@ Fillet: Refers to the curved sharp corner of the road surface generated between intersecting roads. The corner is
selected and its radius can be changed by setting it in the property palette or by dragging and dropping the edit point.

@ Inthe property column:

> Click on the type to switch to another type of road. When switching back to urban roads, the pavement width
needs to be set manually.

> Width and area exclude sidewalks.

> It's possible to modify the start and end elevations to give the road a three-dimensional form.

> Plasticity affects the size of the triangular mesh calculated inside the road. The smaller the value, the more

detailed the road rendering will be, but the performance will also be greatly reduced. A suitable plasticity value can
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be set as appropriate.

9.1.2 Residential Street

Residential roads refer to the main access roads in an area dominated by residential buildings, and this function is used to

map or quickly generate residential roads by converting lines. Select " Scene Tab > Road Panel > [n] Residential Street" to draw
a road or convert the road according to the command line prompt.

1. Draw residential roads: You can draw a curved road according to the command line: input “A” to draw as "tangent arc", input
“B” to draw as "convex arc", input “C” to draw as "three-point arc". Can be drawn continuously; enter “U” to go back to the
previous step and right-click to end the drawing.

2. Line to Road: Imports or draws the line entity representing the road in the scene, select the lane type and set the parameters
in the dialog box, click "Confirm" button, enter C in the command line, select the line and right click to finish. The selected
line entity will be converted to a residential street.

Note: The property palette allows you to modify information about parameters such as type, width, starting point elevation,

endpoint elevation, curbstone width, length, area, shapable etc.

9.1.3 Edit Road

9.1.3.1 Rounded Corner

Generates rounded sections of both roads. Select "Scene Tab > Road Panel > Edit Road > E Rounded Corner",
according to the command line prompts, select two road sections and specify or enter the turn radius. You can connect two sections

of the road to generate rounded corners.

Rl
I

Befaore

Note:

(@ Cannot round corners on parallel sections.
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@ The maximum turning radius is automatically calculated based on the angle between the two roads, and the default

radius is generated by the width of the road.

9.1.3.2 Extend Road

Uses the road a line as the boundary so that the selected road extends to the boundary. Select "Scene Tab > Road Panel >

Edit Road > Extend Road", according to the command line prompts, first select the road section or line to be used as the

boundary , and then select the road section to be extended. You can extend the selected road to the boundary.

Note: When selecting an extension section, the cursor must point at the end closer to the boundary, otherwise the extension

fails.

9.1.3.3 Fillet

Modifies the turning radius of the two connecting roads. Select "Scene Tab > Road Panel > Edit Road > IE Fillet",
according to the command line prompts,
respectively select the road on the two
connected straight edge, enter or use cursor to
specify the radius of the arc.

Note: Drawing a road requires that the

. . Before After
straight edge of the road on the same side

of two connected sections be selected and

that the two sections must blend.

9.2 Facilities Panel
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9.2.1 Building Area

Building area refers to the area that can be used for building plans, this feature is used to draw and define the building area.

Select " Scene Tab > Facilities Panel > Building Area" and there are two ways to generate it.
1. Draw the building area directly by draw polylines.

2. Enter D and press Enter to select the horizontal plane or closed line and define it as building area.

9.2.2 Greening

9.2.2.1 Flower Pool

A flower pool is a fenced area for raising flowers and planting trees, a small structure enclosed by brick masonry or concrete
structure for planting flowers or shrubs. The pool is filled with planting soil and provided with drainage holes; its height generally

does not exceed 600 millimeters. This feature is used to draw and define flower pools.

DUC'
Select "Scene Tab > Facilities Panel > Greening > Flower Pool" and there are three ways to generate it.

1. Directly drawing the flower pool in the same way as a polygon.

2. Enter “S” and press Enter to draw the flower pool in the same way that a three-dimensional polygon is drawn.

3. Enter “D” and press Enter to select the plane or closed line, and define it as flower pool.

Note: The property palette on the right side of the screen allows you to adjust the parameters for the height and side width of

the planter.

9.2.2.2 Hedge

Hedge, also known as wall tree or trellis, a tree or other plant that grows prostrate in patches along a wall or trellis, also refers

to the wall or trellis to which such a tree is attached. This function is used to draw and define hedges.

[

Select "Scene Tab > Facilities Panel > Greening > 753 Hedge", enter values to determine the width and height of
the hedge respectively, there are three ways to generate.

1. Draw hedges directly by drawing polylines.

2. Enter “D” and press Enter, select a line and define it as a hedge.

3. To draw a hedge along a line, enter “Y” and press Enter and follow the command line prompts to draw it.

Note: The parameters for the height and width of the hedge can be adjusted in the properties bar on the right.

9.2.3 Water
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A volume of water is one of the recurring elements in a landscape setting. This function is used to draw and define a water

surface or pool.

Select "Scene Tab > Facilities Panel > Water" to open the dialog box shown below.

Draw Water Bodies

H &

s

Clear water

Pond Still water

Ocean

© Map reflection ' Real time reflection

Water surface color: - 39,777,122

Specular Color: - 120,120,120

Smoothness: 255 = |
Specular level: 0,1 = |
Reflection intensity: & 2 |
Fresnel offset: 0,4 = |
Fresnelindex: 4 = |
Water speed: 0.5 = |
Water ripple ratio: 0.5 =] B

Ripple height: 0.0s00 =/ 1

Opadty: 0,25 = |

1. Drawing water surface: click on the

=
—rs

button and there are three ways to generate it.

(1) Drawing the water surface in the same way that polygons are drawn.

(2) Enter “D”, press Enter and select the horizontal plane, horizontal closed line, and define as a water surface. To auto-

generate a water surface, enter “Z” and press Enter, select the entity that you want to auto-generate the water surface,

and specify it directly or enter the height value to enter.

Note:

(1) Automatic generation is generally used to generate water surfaces in low-lying areas of the terrain.

(2) The entities that support automatic water surface generation are terrain, planes, and roads.

2. Draw pools: See "Draw water surface" for more details.
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3. Paint; Click =] button, select the type of water volume in the dialog box (clear water, pond, lake, still water and sea), you
can paint to the water volume, plane or any other entity. Right click in the scene, you can also draw the water volume
material, paint to the water volume, etc.

Parameter Description:

1. Map reflection: Water reflections according to a preset map.

2. Real time reflection: Water surface reflections in accordance with the actual environment.

3. Water surface color: Sets the color of the water.

4. Specular color: Add a specular map to the water surface.

5. Smoothness: Controls the degree of smoothness of the material when exposed to light.

6. Specular level: Controls the level of specular brightness.

7. Reflection intensity: The magnitude of the reflection effect; the higher the value, the stronger the reflection effect.

8. Fresnel offset: The reflectance of the surface directly facing the viewer (or incident light); this value is lower for water
materials.

9. Fresnel index: Decay of the Fresnel curve.

10. Water speed: The rate at which water flows.

11. Water ripple ratio: Controls the proportion of the water ripple tiling, the higher the value the denser the water ripple.

12. Ripple height: Sets the ripple height of the water surface.

13. Opacity: Sets the opacity of the water surface.

9.2.4 Steps

9.2.4.1 Stairs Along Lines

Along Line Steps are steps that are generated along existing outlines. This function is used to define steps.

Select "Scene Tab > Facilities Panel > '_—I Steps > Stairs Along Lines", first enter the value to determine the number

of steps and the width of the top plane of the steps, then set whether to generate steps at both ends, select a line or a point on the

edge of the entity, directly specify or enter a value to determine the length of the step; if you want to close the steps along the edge

of the entity, enter “C” and press Enter.

Note: The width of the top plane of the steps is the width of the topmost step.

9.2.4.2 Fixed Position Stairs

Page 248 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

In-Place Steps are custom generated steps based on an existing outline. This function is used to define steps. Select "Scene

Tab > Facilities Panel > '_—l Steps > Fixed Position Stairs", select the side of the plane to generate steps, and enter the
value to determine the number of steps to be generated.
Note:
(1) The edges of a plane generating a step may be multiple edges.
(2) When the distance from the building is less than 0.2 m, the "Step in place" is automatically associated with the

building.

9.2.5 Fence

A fence is architecturally a heavily rectilinear spatial partition structure used to enclose, divide or protect an area, generally

enclosing the wall of a building volume. Select "Scene Tab > Facilities Panel > SESS8 Fence".

1. Bounding wall
Bounding wall
(1) Click | putton to draw
s 5] B
the fence in a direct Bounding wall Gate

polyline.

(2) Click =1 button to select

a line as the fence.

Bounding wall01 Bounding wall02

(3) Select the fence type and

click B button to select

and change the fence

type.

Bounding wall03 Bounding wall04

Wall height: | 2,0000

(4) Fence Height: Click on the
drop-down arrow or enter

a value directly to change the fence height.
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2. Gate: Switches to the Gate Tab, just double click or drag the selected gate type and place it in the scene.

Bounding wall

Bounding wall Gate

~

LA P

Entrance door01 Entrance door02

= ™

Entrance door03 Entrance door04

9.3 Environment Panel

9.3.1 Label

Turns on/off the labels of particles and lights for easy selection of particles, lights entities. Select "Scene Tab > Environment

(o,

Panel > B Label" to turn/off the labels of particles and light entities. Please close the tab when publishing effects and recording

roaming videos to avoid affecting the effect.

9.3.2 Particle Entity

Adds dynamic fountains, smoke, vapor, and other particle entities to the scene to complete the scenario effect. Select "Scene

Tab > Environment Panel > n Particle Entity".
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Defoliation
- I
Fountain "F:ﬁ';* :
Smoke T
Spray o
Water Vapar Defoliation 01 Defoliation 02

Defoliation 03

1. Place entity: Double-click on a particle entity in the gallery or drag it directly on workspace.
2. To edit an entity library: Right-click on the list of entity categories:

(1) New: Creates a new particle entity category.

(2) Delete: Deletes the newly created particle entity.

(3) Clear: Removes all newly added particle entities in the selected category.

(4) Edit: Renames the newly created particle entity category.

3. Add: Right-click on a blank space in the library window, click "Add" and select particle entity in workspace to add it.
4. Delete: Right-click on the thumbnail and click "Delete" to delete the added particle entity.
5. Parameter Description:

(1) Particle amount: The higher the value of the parameter, the greater the number and density.

(2) Particle lifetime: The time the particle exists, the higher the value the lower the particle density and the longer the
particle exists.

(3) Initial speed: The higher the value, the faster the speed.

(4) Acceleration: There are three values representing the velocity of xyz in three directions, the larger the valug the faster
the velocity, for example: with an x-axis velocity of 5 and a y-axis z-axis velocity of 0, the particle is deflected in the
x-axis direction.

(5) Initial scale: Refers to the size of the particle at the beginning, the larger the value the larger the particle.

(6) Final scale: The size at the end of the particles' lifetime.
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9.3.3 Light Entity

Add spotlights, floodlights, and other lighting entities to the scene to complete the effect. Select "Scene Tab > Environment

Panel > Light Entity" to open the dialog box shown below.

Floodlight

Spotlight a

Floodlights 01 Lawn Light 01

1. Place entity: Double-click on a light entity in the gallery or drag it directly on workspace.
2. To edit an entity library: Right-click on the list of entity categories:

(1) New: Creates a new light entity category.

(2) Delete: Deletes the newly created light entity.

(3) Clear: Removes all newly added light entities in the selected category.

(4) Edit: Renames the newly created light entity category.
3. Add: Right-click on a blank space in the library window, click "Add" and select light entity in workspace to add it.
4. Delete: Right-click on the thumbnail and click "Delete" to delete the added light entity.
5. Spotlights parameters description:

(1) Activation: Double-click to activate or deactivate.

(2) Radius: The size of the light range.

(3) Direction: Direction of light.

(4) Light cone: The greater the value the greater the range of light radiation.

(5) Attenuation: The higher the value the lighter is concentrated.
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(6) Light intensity: The higher the value the brighter the light.

(7) Specular intensity: The higher the value the stronger the highlight.
6. Floodlights parameters description:

(1) Activation; Double-click to activate or deactivate.

(2) Radius: The size of the light range.

(3) Light intensity: The higher the value the brighter the light.

(4) Specular intensity: The higher the value the stronger the highlight.

7. There is no lighting effect during the day, and the lights turn on automatically at night.

9.3.4 Scene Entity

Adds different types of components as exterior design. Select "Scene Tab > Environment Panel > . Scene Entity" to open

the dialog box shown below.

Amusement facilities

Bench

Bilboard ,ﬂ * *
Bridge rd

Canopy Amusement facilities Amusement facilities Amusement facilities
Communal fadlities

Corridor frames

Featured landscape
Glass volume
Pavilion

Person

Public building Amusement facilities Amusement facilities Amusement fadlities
Residence

Sports field

Street lamp
Transportation fadlities
Vehide

Spacing: 10,0000  Setback: 0.0000 W 0] ==

1. Place entity.

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace.

(2) Place along the line: Selects the model, click foe button and place the entities equally spaced between the specified

start and end points.
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(3) Place along the object: Selects the model, click = button. If you select a road, you can arrange along the road; if
you select water volume, you need to select a point as the starting point of entity arrangement to place along the

water volume.

(4) Select Layout: Selects the model and click == button to place the entities along the road in three ways.
(1) Enter “C” and select "Urban Road" for the equal-spacing placement of entities.
(2) Enter “Q" and select "Residential Road" for the equal-spacing placement of entities.
(3) Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities with equal spacing.
Note:
(1) Previews that appear in grey in the gallery will automatically download if clicked. They can be placed in the
scene when they are downloaded.
(2) Margin distance refers to the horizontal distance of the starting point of the arrangement from the beginning of

the road or water volume. As shown in the figure below.

Margin distance

2. To edit an entity library: Right-click on the list of entity categories:
(1) New: Creates a new model category.
(2) Delete: Deletes the newly created model.
(3) Clear: Removes all newly added models in the selected category.
(4) Edit: Renames the newly created model category.
3. Adding objects: Right-click on a blank space in the library window, click "Add Object" and select a model in workspace to
add it.
4. Add File: Right-click on the blank space in the library window and click "Add File", the following dialog box will pop up.

After selecting the cpi or fbx file, click the "Open" button to add the selected file.
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() flower.cpi
[ flower.fbx
@ pool fbx

() stone.cpi

E stone.fbx

Faroms | - | File (*.cpii flx) -

Open Cancel

5. Delete model: Right-click on the thumbnail and click "Delete" to delete the newly added model.

9.3.5 Vegetation Entity

Adds vegetation entities to the scene to refine the scene. Select "Scene Tab > Environment Panel > (B \iegetation Entity"

to open the dialog box shown below.

Vegetaion Entity

Aguatic plant !
Flower
Shrub + +
Tree

Aguatic plants 01 Aguatic plants 02 Grass 01

Iris 01 Iris 02 Iris 03
Lotus 01 Lotus 02 Lotus 03
Spadng: 10.0000  Setback: 0.0000 i, Ol o=

1. Place entity.

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace.

0
(2) Place along the line: Select the model, click == button and place the entities equally spaced between the specified

start and end points.
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(3) Place along the object: Select the model, click = button. If you select a road, you can arrange along the road; if

you select water volume, you need to select a point as the starting point of entity arrangement to place along the

water volume.

(4) Select Layout; Select the model and click == button to place the entities along the road in three ways.

(1) Enter “C” and select "Urban Road" for the equal-spacing placement of entities.
(2) Enter “Q" and select "Residential Road" for the equal-spacing placement of entities.
(3) Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities with equal spacing.
Note:
(1) Previews that appear in grey in the gallery will automatically download if clicked. They can be placed in the
scene when they are downloaded.
(2) Margin distance refers to the horizontal distance of the starting point of the arrangement from the beginning of
the road or water volume.
2. To edit an entity library: Right-click on the list of entity libraries:
(1) New: Creates a new model category.
(2) Delete: Deletes the newly created model.
(3) Clear: Removes all newly added models in the selected category.
(4) Edit: Renames the newly created model category.
3. Add object: Right-click on a blank space in the library window, click "Add Object" and select a model in workspace to add

it.

G flower.cpi

4. Add File: Right-click on the blank space in the library bz flower fx
@ pool.fbx

window and click "Add File", the following dialog box @ stone.cpi

@ stonefbx

will pop up. After selecting the cpi or fbx file, click the

File name: | v| File (*.cpi;*.fbx) ~

"Open" button to add the selected file.

5. Delete model: Right-click on the thumbnail and click

"Delete" to delete the newly added model.

9.3.6 3D WareHouse

Quick access to the Sketchup 3D Warehouse website. Select "Scene Tab > Environment Panel > 3D WareHouse". Go

to Sketchup 3D Warehouse website.
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Note: We are not affiliated with Trimble. This button serves as a quick access tool, but users will need a valid SketchUp account

to download materials from the 3D Warehouse.

9.3.7 Environment

Applies weather, lighting and fog effects to the environment, and support customizing environment parameters. Select "Scene

Tab > Environment Panel > Environment". The dialog box shown below pops up:

Environment X

Weather

. h

Clear Sky 75]Jnrise Sunset Snow Rain Might

= Effect Parameter

Night Vision Settings

1. Weather: Double-click on a weather image to apply the corresponding weather effects.
(1) Enter a value in the text box or drag the slider to adjust the azimuth and altitude angle parameters of the sun. When
shadows are on, adjusting the azimuth and altitude will affect the effect of the shadows.

2. Effect Parameters: Click on "Effect Parameters" and the dialog box will look like this:

Environment X
Weather
- ]
Clear Sky _S-unnse Sunset Snow Rain Might
|— Effect Parameter
Type Parameter
=] Sun Position ~
Location Location
Direction -53.000000
Height 36.000004
= Sky
HDR High Dyna... 0.543413
SSAQ Range 2.500000
SSAQ Intensity 1.000000
Light Blocking ... 0.500000
Light Blocking R... 1.000000
Sun Color [l 235,193,156 v
< >
+ Might Vision Settings

Solar, ambient, fog effect, volumetric light and HDR parameters can be modified separately to enhance the ambient effect.
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(1) Sun Position

Location: Click on the blue font to quickly locate the position of the sun in the scene.
Direction/Height: Adjusts the sun's direction and height by entering values or dragging the slider. When

shadows are enabled, these adjustments will change how the shadows look.

HDR High Dynamic Range Factor: Adjusts the brightness and color range using HDR technology for more
realistic and detailed visuals. Enter a value or drag the slider to adjust.

SSAO Range/SSAOQ Intensity: Screen Space Ambient Occlusion (SSAO) enhances shadow details and depth
by simulating how light is occluded between objects. Adjust the range and intensity by entering a value or
dragging the slider.

Light Blocking Intensity/Light Blocking Radius: Controls how much light is blocked in shading techniques
like SSAQ. Use the slider or enter a valug to adjust.

Sun Color: Sets the sunlight color. Select a color directly from the color panel.

Sun Color Multiplier: Adjusts the brightness of the sunlight color. Use the slider or enter a value to modify.
Sun Specular Multiplier: Controls the intensity of reflections (highlights) caused by sunlight on surfaces.
Adjust with the slider or by entering a value.

Sky Golor: Defines the color of the sky. Choose a color directly from the color panel.

Sky Color Multiplier: Adjusts the brightness of the sky color. Use the slider or enter a value to make changes.
Ground Ambient Light Color: Defines the ambient light reflected from the ground, which affects the scene's

overall tone. Choose a color from the color panel.

10) Ground Ambient Light Color Multiplier: Adjusts the intensity of the ground ambient light. Enter a value or use

the slider to modify.

11) Minimum Ambient Light Height: Specifies the lowest height at which ambient light has an effect. This

parameter controls vertical light distribution, simulating base lighting for terrain, buildings, or other scene

elements under natural conditions. Adjust with the slider or by entering a value.

12) Maximum Ambient Light Height: Specifies the highest height at which ambient light influences the scene.

(3) Cloud

1)

This parameter defines vertical light distribution, ensuring realistic and precise lighting effects. Adjust by

entering a value or using the slider.

Sun Influence: Controls how much sunlight affects the clouds in the scene. Adjust by entering a value or
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using the slider.

Sky Influence: Controls how much skylight affects the clouds in the scene. Adjust by entering a value or using
the slider.

Custom Sun Color: Allows you to customize the color of sunlight affecting the clouds. Select a color directly
from the color panel.

Custom Sun Color Multiplier/Influence: Adjusts the intensity of the custom sunlight color's effect on the
clouds. Modify by entering a value or dragging the slider.

Custom Sky Color: Allows you to customize the sky color affecting the clouds. Choose a color from the color
panel.

Custom Sky Color Multiplier/Influence: Adjusts the intensity of the custom sky color's effect on the clouds.

Modify by entering a value or dragging the slider.

Fog Color (Bottom): Defines the color of the fog starting at ground level, typically used to simulate low-
altitude fog. Choose a color from the color panel.

Fog Color (Bottom) Multiplier: Adjusts the intensity of the bottom fog color. Higher values make the color
more prominent. Enter a value or drag the slider to adjust.

Fog Height (Bottom): Sets the starting height of the bottom fog. Determines where the fog begins to appear
in the scene. Enter a value or drag the slider to adjust.

Fog Density (Bottom): Controls the thickness of the bottom fog. Higher density reduces visibility. Adjust by
entering a value or using the slider.

Fog Color (Top): Defines the color of the fog near the sky, often used for a gradient effect when combined
with the bottom fog color. Choose a color from the color panel.

Fog Color (Top) Multiplier: Adjusts the intensity of the top fog color. Higher values make it more visible. Enter
avalue or drag the slider to modify.

Fog Height (Top): Sets the maximum height of the top fog. Determines how far the fog reaches upward. Adjust
by entering a value or using the slider.

Fog Density (Top): Controls the thickness of the fog at higher altitudes. Adjust by entering a value or dragging
the slider.

Color Height Offset: Adjusts the transition point for the fog color change between bottom and top, creating a

natural gradient. Modify using a value or slider.

Page 259 of 283



Houseplan 2.0 Fast, Easy, and Powerful 3D Design Plan

10) Radial Size: Defines how the fog spreads radially around a center point. Adjust by entering a value or dragging
the slider.

11) Radial Foliage: Adjusts fog behavior around vegetation, emphasizing or reducing its effect on trees, grass, etc.
Modify using the slider or a value.

12) Final Density Clamp: Limits the maximum fog density to prevent it from becoming overly thick and obscuring
visibility. Adjust by entering a value or using the slider.

13) Global Density: Sets the overall fog concentration throughout the scene, affecting all other density-related
parameters. Adjust using a value or slider.

14) Slope Start: Defines where fog begins to appear on inclined surfaces like hillsides. Adjust by entering a value
or using the slider.

15) Slope End: Specifies where the fog effect stops on inclined surfaces. Modify with a value or slider.

16) Slope Weight: Controls how strongly the fog changes along slopes, affecting its visibility in sloped regions.
Adjust by entering a value or dragging the slider.

(5) Skylight

1) Sun Intensity: Adjusts the brightness of sunlight in the scene, significantly impacting overall lighting. Modify
by entering a value, dragging the slider, or selecting a color from the color panel.

2) Sun Intensity Multiplier: Fine-tunes the effect of sunlight intensity. This parameter multiplies the base intensity
for more precise control. Enter a value or drag the slider to adjust.

3) Mie Scattering: Simulates light scattering by larger atmospheric particles like water droplets or dust, creating
a halo effect around the sun and hazy conditions. Adjust using a value or slider.

4) Rayleigh Scattering: Models light scattering by small particles (e.g., air molecules). Responsible for blue
skies and red sunsets by scattering shorter wavelengths like blue light more efficiently. Enter a value or drag
the slider to adjust.

5)  Solar Anisotropy Factor: Controls the directionality of sunlight scattering. Higher values simulate more direct
and concentrated sunlight. Adjust by entering a value or using the slider.

6) Wavelength (R): Adjusts the scattering of red light in the atmosphere, influencing the sky's reddish tones.
Modify by entering a value or dragging the slider.

7)  Wavelength (G): Controls the scattering behavior of green light in the atmosphere, affecting overall sky
coloration alongside other wavelength parameters. Enter a value or drag the slider to adjust.

8) Wavelength (B): Determines how blue light scatters, significantly impacting the sky's blue appearance. Adjust
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using a value or slider.

(6) HDR
1) Film Curve Shoulder Scale: Adjusts the compression of highlights to preserve detail in bright areas and
prevent overexposure. Higher values soften the transition in highlights. Modify by entering a value or dragging
the slider.
2)  Film Curve Midtones Scale: Controls brightness and contrast in mid-tones, enhancing details in the medium
brightness range. Adjust using the slider or by entering a value.
3) Film Curve Toe Scale: Alters the appearance of shadow areas, either improving dark details or enhancing
shadow depth. Enter a value or drag the slider to adjust.
4)  Film Curve White Point: Defines the pure white point in an image, impacting overall brightness and contrast,
especially in bright scenes. Adjust by entering a value or using the slider.
5) HDR Saturation: Modifies overall color saturation. Higher values make colors more vibrant, while lower values
reduce saturation, making the image appear grayed out. Adjust via the slider or by entering a value.
6) HDR Contrast: Adjusts overall image contrast. Higher contrast intensifies the difference between light and
dark, while lower contrast flattens the image. Modify by entering a value or using the slider.
7)  Color Balance: Changes the overall tonal balance to correct color casts or create specific visual effects (e.g.,
adding blue for a cooler tone or red for warmth). Adjust directly using the color panel.
(7) Volumetric Lighting
1) Sun Ray Attenuation: Adjusts how much sunlight fades as it passes through a medium, controlling the
dimming effect over distance. Modify by entering a value or dragging the slider.
2)  Custom Sun Ray Color: Allows you to set a custom color for sun rays, selected directly from the color panel.
3) Sun Ray Color Weight: Determines the intensity of the custom sun ray color's effect on the overall lighting.
Adjust using the slider or by entering a value.
4) Sun Ray Visibility: Controls how visible the sun rays are within the scene. Adjust by entering a value or
dragging the slider.
(8) Color
1) Saturation: Adjusts the vibrancy of colors. Increasing saturation makes colors more vivid, while decreasing it
makes them appear faded or grayscale. Modify using the slider or by entering a value.
2) Contrast: Changes the difference between the brightest and darkest areas of the image to enhance or reduce

the image's depth. Adjust with the slider or by entering a value.
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(10) Snow

1)
2)

Brightness: Controls the overall lightness or darkness of the image. Adjust using the slider or by entering a
value.
Hue: Shifts the base color tones of the entire image, allowing for creative or corrective color changes. Adjust

by entering a value or using the slider.

Rain Effect: Enables or disables the rain effect. Use the drop-down menu to toggle it on or off.

Rainfall Intensity: Adjusts the amount and strength of rainfall in the scene. Modify by entering a value or
dragging the slider.

Puddles: Controls the appearance and impact of water accumulation on surfaces. Adjust using the slider or
by entering a value.

Reflection: Modifies the intensity of reflections caused by rain on surfaces. Adjust by entering a value or

dragging the slider.

Snow Effect: Enables or disables the snow effect. Use the drop-down menu to toggle it on or off.
Snowfall Intensity: Adjusts the density and strength of snowfall within the scene. Modify using the slider or

by entering a value.

(11) Shadow

1)

Depth Map: A texture storing the distance between objects and the light source, used in shading calculations
to determine if a pixel is in shadow, ensuring accurate shadow rendering. Adjust by entering a value or
dragging the slider.

Grading: Adjusts the brightness or color of shadowed areas, useful for achieving specific visual styles or
enhancing shadow details. Modify by entering a value or using the slider.

CSMO Offset: Adjusts the depth offset of the first Cascade Shadow Map to minimize Z-fighting and reduce
artifacts. Modify by entering a value or dragging the slider.

CSMO Slope Offset: Fine-tunes the offset based on surface slopes to stabilize shadows on various terrains.
Adjust using the slider or by entering a value.

CSMO Distance: Defines the distance range covered by the first cascading shadow map. Adjust by entering a
value or using the slider.

CSM1 Offset: Adjusts the depth offset for the second Cascade Shadow Map to prevent artifacts. Modify using

the slider or by entering a value.
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7)  CSM1 Slope Offset: Adjusts the slope-based offset for the second Cascade Shadow Map. Adjust using the
slider or by entering a value.

8) CSM1 Distance: Defines the distance range covered by the second cascade shadow. Adjust by entering a
value or dragging the slider.

9) CSM2 Offset: Adjusts the depth offset for the third Cascade Shadow Map to minimize artifacts. Modify using
the slider or by entering a value.

10) CSM2 Slope Offset: Fine-tunes the slope offset for the third Cascade Shadow Map. Adjust using the slider or
by entering a value.

11) CSM2 Distance: Specifies the distance range covered by the third cascade shadow. Adjust by entering a value
or using the slider.

12) CSM3 Offset: Adjusts the depth offset for the fourth Cascade Shadow Map to reduce artifacts. Modify by
entering a value or dragging the slider.

13) CSM3 Slope Offset: Adjusts the slope offset for the fourth Cascade Shadow Map. Modify by entering a value
or using the slider.

14) CSM3 Distance: Defines the distance range covered by the fourth and final cascading shadow map. Adjust
by entering a value or dragging the slider.

15) Exponential Split Weight: Controls the spacing between cascade levels using exponential weights, affecting
how shadows transition between cascades. Adjust by entering a value or using the slider.

16) Distance: Sets the maximum distance covered by global shadows. Beyond this range, objects will not cast
shadows. Adjust by entering a value or dragging the slider.

(12) Deferred Lighting

1) Lighting: Controls the overall lighting settings during the deferred lighting process. Toggle this option by

selecting "on" or "off" from the drop-down menu.
(13) Show Setting

1) SMAA: Reduces edge jaggedness (aliasing) in computer graphics, enhancing the visual quality of images.

Toggle this option by selecting "on" or "off" from the drop-down menu.

3. Night vision settings: Click on " Night vision settings " and the dialog box will look like this:
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Environment X

| . h

Clear Sky Sunrise Sunset Snow Rain Might

“ 9

= Effect Parameter

Weather

|— Might Wision Settings

Night Vision Settings

Light Up Type: [ Enclosed Balcony [ Glass Door
[ Glass Window [OLight Strip
Lighting Rate: g4 I ]
0 0.2 04 0.6 08 1
Brightness: |40 = ]

The lighting category, lighting rate and brightness can be modified separately to adjust the lighting effect in night mode.
(1) Light up type: Controls the lighting status of the corresponding category in the scene.
(2) Lighting rate: Controls the number of entities lit in the scene. The higher the value of the lighting rate, the more
entities are lit, and vice versa.
(3) Brightness: Only affects the brightness of the it solid material.
4. Operating Instructions
(1) Switching environments: Double-click the different environment preview images under the Weather module to switch

the corresponding environment effect in the scene, as shown in the following figure:

The first six environments are system default environments, which only support modifying effect parameters and copying. Right-

click on the preview image to expand the menu, as shown below:
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Environment

Sunset Snow Rain

= Effect Parameter

Might Vision Settings

Click the right mouse button in a blank area or customized environment to display the More Functions menu, as shown in the

following figure:

Environment

Weather

|| Environment

Weather

Clear Sky Sunrise

Sunset

New

Import

Export All Custom ltems

Night Vision Settings

Ll
Clear Sky
Night

Snow Rain

[ |

_Sﬁnrlse Sunset Snow Rain

Edit
Copy

Replace Preview

Export

Save
Teter
Reset

night Vision Settings

(2) Copy: Duplicates the selected custom environment and places it at the end of the weather preview list.

(3) New: Creates a new scene using the same effect parameters as the current scene. The current view will serve as the

weather's preview image.

(4) Export: Exports the current weather settings in .epr format.

(5) Export All Custom Items: Exports all customized environments at once.

(6) Import: Imports an environment file in .epr format.

(7) Edit: Allows editing of the name for the environment's preview map.

(8) Replace Preview: Updates the environment's preview image to reflect the current view.

(9) Save: Saves any modified effect parameters for the selected weather.

(10) Reset: Resets the effect parameters for the selected weather to their original values before modification.

9.3.8 Shadow Variation

Simulates the dynamic changes in shadow patterns throughout the day to enhance realism and visual variation. Select "Scenes
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Tab > Environment Panel > Shadow Variation".

Shadow 4

Display Shadows Paramenter Setting

[ 9 gy 1 14 15 1B|
=

Check “Display Shadows”, drag the slider or modify the time directly to show the shadows of the sunshine at different moments
of the day.

Click “Parameter Settings” to set the parameters for performing shadow changes.

Paramenter Setting X

Geographic Position

Latitude: " ' " @®n  Os aity
Longitude: ° ' " ®E Ow Beifing

Analysis Time
Gregorian Calendar Date: (2024/11f19 [ERd Height Angle: 825" 147

=

Azimuth: 55°35' 31
Begin From: |08:00:00 =

Sunrise 7: 9:10
End at: |16:00:00 2| Sumset 16:50:49

1. Geographic location: Sets east longitude and west longitude, south latitude and north latitude value. And you can also click

on the “City” button to select a city.

Major City [Latitude][Longitude] X l

China

& India

- Mumbai 19°04" 72°52"

--Mew Delhi 28°3@° 77°12"

--Bangalore 12°58’ 77°34"

--Calcutta 22934* 88°22"
Chennai  13°04° 80°14°

--Hyderabad 17°22’ 78°28°

- Ahmedabad 23°02' 720347

--Poona 18°31" 73°51"

- Srinagar 34°05" 74947
Lucknow 26°50° 80°56°

--Jaipur 26°55" 75°49"

--Cochin 09°58" 76°16"

[+ Turkey

Add Edit | Delete Cancel

The dialog box provides the latitude and longitude of some countries and their cities, and you can create, edit, or delete cities and

their latitude and longitude. After selecting a city and clicking the “Confirm” button, the main dialog box displays the corresponding
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latitude and longitude.
You can click on the Add button or right click at the blank area to create a new country, then click the Add button or right click on

the country to add new city.

Country b City e
Country Name: |:| Latitude: " ’ " ®N  Os
Longitude: ° ’ " @®E Ow
Cancel p—

(1) New: Creates new country or city.

(2) Edit: Edits the city name and location.

(3) Delete: Deletes the city or country.

2. Analysis time: Sets a day and a time period in the calendar day.

(1)  Gregorian Calendar Date: Select the date.

(2) Begin from: Sets the sun variation begin time.

(3) End at: Sets the sun variation end time.

Note:

(1) Height Angle and Azimuth Angle: The Height angle (altitude angle) is the angle between direct sunlight and the
horizontal plane. The azimuth angle is the angle between the horizontal projection of direct sunlight and the south direction. It
is 0° when facing south and negative before noon.

(2) Begin From and End At: Calculates the solar altitude and azimuth angles automatically based on the specified

|atitude, longitude, and date, determining the sunrise and sunset times accordingly.

9.3.9 Optimization

Sets anti-aliasing, visual balance, and arc segments to adjust the entity effects in workspace. Greater values are not necessarily

better. Select "Scenes Tab > Environment Panel > BSES Optimization".
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Optimization
Ant aliasing: 1 | 4 3
Visual balance: 1 | 10 5.00
Arc segment: 1 | 10 5.00

Apply Reset

1. Anti-aliasing
Removes jagged display and aliasing to make the view smoother and prettier. Set the value of anti-aliasing and click

"Apply". The Anti-aliasing button on the right bottom corner can turn this effect on or off as well, as shown below:

|sometric | Perspective | Shadow | Anti-Aliasing | Light Projection

2. Visual Balance

Simplifies surface details of entities to reduce the geometrical complexity of a scene while not affecting the visual effects.
Set a value to increase the performance of the scene without losing noticeable graphic details. Drag the slider or enter a value
to change the LOD display distance. Entities farther away will be displayed in simpler models or not rendered at all; entities
close to the viewpoint will be displayed in detailed models.

Note: During drawing, if imported drawings are not visible, it could be that the imported drawing is too big and the

viewpoint is too far away. Increase the value of LOD and the drawing should display normally.
3. Arc Segments

Sets the display effect of arcs and curved planes. Drag the slider or enter a value directly to adjust the number of segments.
The smaller the value, the fewer the segments, and the more efficient the rendering; the greater the value, the more detailed
the arcing effect, but the performance will be lower.
Note: Arc segments affect the following entities:

(1) Line: Sphere, arc, ellipse, elliptical arc.

(2) Edge: The edge of planes and volumes that contain sphere, arc, ellipse, or elliptical arc.

(3) Curved plane: Individual curved plane entity or curved plane on volumes. In other words, all non-flat planes are

affected.

9.4 Animation Panel
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9.4.1 Skeletal Animation

Adds animated objects to the scene to add animation effects. Select "Scene > Animation Panel > EE Skeletal Animation"

to open the following dialog box.

Skeletal Animation

Bird
Butterfly
Fish
Persaon

Bird 01 Bird 02 Bird 03

Bird 04 Bird 05

Velodity: 7.00 m/s ~ Height: 10,0000 m

1. Apply the animated entity:
(1) Select the animated entity, set the moving speed and insertion height;
(2) Double-click the animated entity model or drag it to the scene to insert it.

2. Edit the animation entity library:
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When right click the animation library

Skeletal Animation X
entity list: aird
Butterfly

(1) New: Creates a new skeletal g‘esr“m
animation entity category; b=

Delete
(2) Delete: Deletes the newly created E:ar

It
Import

skeleton animation category;

(3) Empty: Empties all the newly
added skeleton animation entities in
the selected skeleton animation

Category; Velocity: mfs ~ | Height: m

(4) Edit: Renames the newly created

skeleton category;
(5) Import: Selects the folder and import the fbx file in the folder.
3. Add models:
(1) Add file: Right click on the blank space of the right part of the window, click the "Add File", and then select fbx file
in the pop-up dialog box.

(2) Delete: Right click on the model and click "Delete" to delete the newly added model.

9.4.2 Play Animation

Plays the animation or stop playing the animation according to the set path. Select "Scene Tab > Animation Panel > B :

Play Animation" to start or stop playing the movie.

9.4.3 Wavy Path

Adds undulating paths to animated entities, generated when drawing based on the height of the specified point. Select "Scene

Tab > Animation Panel > m Wavy Path", select the animated entity, and draw the undulation path.
Note:
(1) If there is no control point for snapping in the scene, the drawn path is a horizontal path, and you need to click the
"Edit Path" command to modify the control point, see "Edit Path" for the specific operation.

(2) The property palette allows you to adjust parameters such as frequency of the animated entity, whether it moves itself,
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whether it follows the path, the path speed, whether the movement mode is single or circular and whether it casts a

shadow.

9.4.4 Edit Path

Edits the drawn animation path. Select "Scene Tab > Animation Panel > Edit Path" to open the dialog box shown below.

1. Selection: Click " ' button to select the animated entity or click on the name of the animated entity on the left side of the

dialog box to display its path and control points in the scene and its control points and height on the right side of the

dialog box.

2. Undulating Path: Click & button to draw

Edit Path

undulating paths.
ap [; o & X
3. Move: Click ¥ button and select the control Velocity: 080 mfs v
. Person\Person || | Control point . Height e
point to move. Person'.Person | 1 point 0.0 100
Butterfhy’ Butter 3 b
. * point 0.0
4. Delete: Click %< button to delete the 40 | 5
[Delete animation 0.1
selected control point. Clear path D:D
, . . , & point 0.1 0 C{C
5. Right-click on the name of the animated entity 7 point 0.0
on the left side of the dialog box to open the 8 point 0.0 “
context menu;
(1) Delete animation: Deletes the selected N -100

animated entity and its path.
(2) Clear path: Removes the animation path
of the selected entity.
Note:
(D Itis not permitted to delete or move the first control point.
(2) Double click on the blue text "height", and all points below the selected row will be modified to the height value of

the selected row.

9.4.5 Erase Path

Oy
Clears the defined animation path. Select "Scene Tab > Animation Panel > Erase Path" and select the entity you want
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to delete the animation path from.

9.4.6 Show Path

%y

Shows or hides the defined animation path. Select "Scene Tab > Animation Panel > <888 Show Path" to show or hide the

defined animation path.
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10 Video Menu

To facilitate users to experience the real 3D model world, Houseplan 2.0 outputs HD video based on the real environment path

to show the effect of the design dynamically in all aspects.

10.1 Path Panel

10.1.1 Draw Path

Draws roam path in the scene. Select "Video Tab > Path Panel > Draw Path" to draw a path in the scene.
Note:
(1) The drawing is captured in three dimensions.
(2) After drawing a path, when drawing it again, continue along the last path by default.
(3)If you want to redraw it, you can click on "Delete path" command and draw it again.
(@) If the previous path needs to be saved, save it in the "Video Highlights" before clearing the path.
(5)If the drawn path line is not saved in "Video Highlights', the path line information will not be recorded, and the path

will be lost when the file is opened again.

10.1.2 Grounded Path

Draws video paths that adhere to the ground in the scene, enabling video to undulate with the ground automatically when

roaming. Select "Video Tab > Path Panel > Grounded Path" to draw a path in the scene.
Note:
(1) The ground includes the earth, the terrain and the roads.
(2) When there is a superposition of ground entities, the path falls on the higher entity.
(3)When the two paths are drawn by switching between them, the drawn path is generated in the same way as the

newly drawn path.

10.1.3 Edit Path

Edits the current roaming path. Select "Video Tab > Path Panel > ﬁ Edit Path" and the following dialog box will appear.
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G+ X o~ + Input paints: | 2979.03,1027.74,0
Height
Control point| Camera height | Height Angle Azimuth Velocity |Angular Velocity 100
C 1 00000 079031027.740979.031027.740 20
2 0.0000 Lock Up Front View 2.0 10.0 0
3 0.8481 Overlook Front View 2.0 10.0
4 1.0108 Frant View Frant View 2.0 10.0 0.0
5 10.0000 Front View Front View 2.0 10.0 -
6 10.0000 Frant View Frant View 2.0 10.0
-50
-100

1. Control Point Parameters: Click on an item in the dialog box to modify it.

(1) Camera height: The height of the camera when roaming to that point, either by entering the value directly, or by
dragging the right slider to change it.

(2) Height Angle, Azimuth: Seta horizontal and vertical viewpoint when roaming, click the drop-down list and select
"Pick", you can use the selected point in the scene as the viewpoint. After that, select the control point, you can
modify the coordinates of the point at the top of the "Enter Viewpoint".

(3) Velocity: Speed at which the roaming is running.

(4) Angular velocity: Speed at which the camera turns, which needs to be increased to match if the camera is going

too fast.

(5) Blue Font: Select a value and double-click the blue font above the column to change all the values below to the

same value as that item.
2. Clicking “* button to move the selected control point and allow capturing.

3. Click the - | button to delete the selected control point.

4. Clicking =" | button to move the selected control point horizontally without changing the height of the control point.

5. Click the -+ button to add control points to the path line.

Note: Grounded paths do not support panning.

10.1.4 Delete Path

Deletes the currently drawn roaming path. Select "Video Tab> Path Panel > o Delete Path" to automatically clear the
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roaming path in the scene.

10.2 Video Panel
10.2.1 Roaming Operation

Implement roaming effects and generate roaming videos. Select "Video Tab> Video Panel > Roaming Operation" to

open the following dialog box.

Roaming Operation

<] (4] ]

ME o

1. Click on the LI button to open the dialog box shown below.
(1) Click on "Detailed Parameters" to open the "Edit Path" dialog box, refer to the "Edit Path" item for details.

(2) Select "Temporary Parameters" and the dialog
. _ , Path Roaming Settings
box will to Confirm like this.

(1) Moving speed: Enter the speed at which O Detailed parameters

Terpotary pararmnekers

the viewpoint moves when roaming.
Moving speed: | 20.0 m/s

(2) Path height: Enter the horizontal height of
Path height: | 1.2000 Meters

the roaming viewpoint.
View: Front View

(3 View: Select the camera view, which

. . . Video size:  1920%1080 w
contains five options: Front, Overlook,

Look up, Left, and Right. Video quality:  High v

(3) Video Size: Sets the size of the generated video.

Select "Custom" in the drop-down list to open

the dialog box shown below.

Enter width and height dimensions and click "ok" button to add it to the video size list.
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Width: 1920

Height: 1030

Note: The larger the size, the larger the file generated. Considering that saving data to the hard disk takes up system
resources and affects the recording process, please choose the right size according to your computer performance.
(4) Video quality: Sets the video quality, including High, Medium, and Low. After setting the parameters, click on the

"Confirm" button to roam according to the settings.

2. Click on the EI button to start roaming through the scene according to the drawn path and its parameters.
3. Click on the EI button to stop roaming.
4. Click on the EI button to pause the roaming and click again to continue the roaming.

5. Click the =21 button, set the save path and file name and then start roaming and record the roaming process as *. mp4, *.

mkv, *. mov format files.

10.2.2 Roam Path List

Saves the current roam path or apply a saved roam path. Select "Video Tab > Video Panel > Roam Path List" to open

the following dialog box.

Roam
Mame Turning paint Length
Path name: namel Save
Rename

[&] [=] [u] Delete item

0% 25% 505 75% o 100%

A Delete all

0.0%
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1. Save path; Enter the path name and click the "Save" button to save the current drawn path.

2. Apply path: Double-click on the line where the path is located in the dialog box to invoke the path.

3. Context menu: Right-click in the list to open the "Context menu", you can delete or rename the path.

4. Click on the I+] button to set the path roaming parameters.

5. Click on the button to start roaming through the scene according to the drawn path and its parameters.

6. Click on the El button to stop roaming.

7. Click on the E button to pause the roaming and click again to continue the roaming.

8. Click the =i button, set the save path and file name and then start roaming and record the roaming process as *.mp4,

*

.mkv, *.mov format files.

Note:

@ Modified paths require a click on “Save” to update the path to the latest.

@ When saving a path to a video set, the ambient weather is also recorded in the path information.

10.3 Camera View Panel

10.3.1 Camera View List

Saves the viewpoints in the scenario for quick positioning. Select "Video Tab > Camera View Panel >

List", the following dialog box will pop up.

Camera View List

Camera View

B =

Mame

1
2
3
4

OoOoooa

Camera position

61,51,2
64,28,-22
-3026,1184,418
7938,7969,6460

3166,5969,510

Camera viewpoint View type
82,51,2 Perspective
65,28,-21 Perspective
-3025,1185,417 Perspective
7938,7909,0401 Isometric
Rename(M)
Delete item(5)
Delete all{D)

Enter the viewpoint name and click B button to save the current viewpoint to the list. Check the viewpoint and click =
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button to export the viewpoint to local in image format. Right-click on the viewpoint name to open the context menu, which allows
you to rename, delete and delete all the viewpoints. You can also remove the viewpoint all together by right-clicking in the blank

space of the dialog box.
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11 Others

Houseplan 2.0 provides some common tools and shortcuts to help users categorize and manage entities in the process of

designing solutions in an organized and efficient manner.

11.1 Graphic Class Control

When designing entities or elements, you can use the layer control function

Graph Ceontrol

for easy operation management. Click ﬁ button to open the dialog box shown Close the selected dass

Close dasses other than selected

below.
Turn off the selected layer

Click on each item to close or open the class, layer and background. For Turn off the selected outer layer
All classes open

example, click on the "Close the selected class" button to select the entity to be R ———

closed. For example, if you select a building, you can turn off the main volume of Close underlay DWG

. Open underlay DWG
the building and the balcony and other components.

Note: You can also click on the top of the software to have control over the

graph class layers, as shown in the following image.

| building - I[l@ building bod) —

(1) Click on the checkbox [¥] in front of a class or  in front of a layer to turn a single class/layers on or off.
(2 Double-click the checkbox [#] in front of the category to close all categories. Double-click again on [l to open all

categories.
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(3) Classes and layers are linked. For example, if you close the

class on the left, the corresponding layer on the right closes with it.

11.2 Right-Click Context Menu

If you right-click on the workspace, a context menu will pop up with the
following commands; Last command, Orbit, Eye View, Full View, Frame
Selection, Pan, View Control, Previous View, Front Face, Window View, Polyline,

Rectangle, Polygon, Box, Extrude Building, General Extrude, Copy, Move, Rotate,

Erase, Hide Selected, Hide Unselected, Unhide.
For more operation details, see the description of each of these commands

above in this guide.

11.3 Orthogonal

Restricts the operation to horizontal or vertical orientation.

1. Click on REHMEASERMEN bytton at the below the command line to turn the orthogonal function on/off,

2. Right click on button to open the context menu, as shown below.

(1) Conventional: Switches to the normal orthogonal orientation.

. . «~  user ocrthogonal
(2) User Orthogonal: Switches to the user orthogonal direction. There

conventional
are three methods of access.

(1) Direct selection of solid edges, as orthogonal directions.

(2) Angles may be entered as orthogonal directions, as prompted on the command line.

(3) Enter “D” to specify two points and plot the orthogonal direction, and “C” to clear the defined orthogonal
direction and return to the default state.

Note: Set user orthogonal, i.e., re-designate the direction of the positive half-axis of X-axis. In some project drawings,
the orientation of land, roads and other entities is not according to the default XY axis direction of the system, so for the

convenience of drawing, you can define your own orthogonal direction.

11.4 Polar Axis

During drawing and editing, you can turn on the polar axis to easily obtain capture points in the X-, Y-, or Z-axis direction.
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11.5 Snap

When drawing or editing, you can turn on the snapping function to assist in the operation for precise positioning.
1. Click the m button below the command line or press the F3 key to turn snapping on or off.
2. Right-click on m button to open the context menu, as shown below.

setting

Snap Mode Settings

Select "Setting" option to open the dialog box shown below.

. . kd Endpoin | Center of cirde
You can set snapping options, where "plane” refers to the surface of a plane & Eent L] come

Midpoint Closest point
or SO|Id | Intersection Flane

Perpendicular point

Click the "Select All" button to check all the boxes; click the "Confirm"

Mouse pick box {0-50):  ©
0

button to apply the settings. Mouse capture frame(2.20): 10
Cursor length (1-100): 5_

Note: When snapping to the circle center of an arc, you need to hover the

cursor over the edge line to display the center of the circle. Select al Cance

11.6 Follow

B hutton at

Displays distances and angles at the mouse pointing position when drawing and editing objects. Click
the bottom of the command line to turn the follow function on/off. The angle displayed is the angle with the positive half-axis of the

X-axis.

11.7 Reference

When drawing and editing objects, a temporary extension line, vertical line, or a polar axis through an entity's endpoint,

midpoint, or other capture points is displayed as a dashed line when the cursor passes over that point, so that the user can specify

a point at the extension line or capture the intersection of multiple reference lines. Click Mtk button at the bottom of the
command line to turn the reference function on/off. The reference is based on snapping and requires snapping to be on in order to

use it.
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11.8 Isometric

Switches the design environment to isometric mode. Click the Isometric button in the bottom right corner to turn the feature

on, and click it again to turn it off. As shown in the figure below.

Perspective | Shadow | Anti-Aliasing

Light Projection

11.9 Perspective

Switches the design environment to Perspective projection. Click the Perspective button in the bottom right corner to turn on

the feature, and click it again to turn it off. As shown in the image below.

Shadow | Anti-Aliasing

Light Projection

11.10 Shadow

Simulates the shadow shading effect of the project. Click the Shadow button in the bottom right corner to turn the feature on,

and click it again to turn it off. As shown in the image below.

Isametric | Perspective | Shadow | Anti-Aliasing | Light Projection

11.11 Anti-Aliasing

Jaggies are eliminated and the edges of the image are softened to make the edges of the image look smoother and closer to
the physical object. Click the light blocking button in the bottom right corner to turn on the feature, and click it again to turn it off.

As shown in the figure below.

Light Projection

Isometric | Perspective

Shadow | Anti-Aliasing

11.12 Light Projection

Ambient light masking, which depicts the effect of blocking out surrounding diffuse light when objects and objects intersect
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or are close together. Click the Light Projection button in the bottom right corner to turn on the feature, and click it again to turn it

off. As shown in the figure below.

Isometric | Perspective Anti-Aliasing | Light Projection
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