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1. GstarCAD 2024 for Linux System Requirement and Installation

1.1. System Requirement

Users can visit www.qgstarcad.net to download GstarCAD 2024 for Linux package to your computer or server.

Before installing GstarCAD Linux, please confirm whether the specifications of your PC meet the following requirements:

®  Hardware Requirement

CPU: AMD 64.
RAM: 512MB or above.
Display Resolution; 1024*768 or above; 32-bit true color (at least).

Hard Disk: The system and installation disk need more than 500MB of space.
To improve performance, it is recommended that the software be installed and stored on a solid state drive (SSD).

® (S (Operating System)

Ubuntu, Debian, Astra Linux System

1.2, Installation

GstarCAD 2024 for Linux Install Wizard will guide the user to install the software in the operating system completely and
successfully.

Please follow the steps below to install GstarCAD 2024 for Linux:

1. Double-click the GstarCAD 2024 for Linux.deb file downloaded.

GstarCAD20245...

GstarCAD20245P1_LINUX_EM_20240329.deb
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2. The GstarCAD Linux Installer dialog box will pop up. Click Install Package button to start installing GstarCAD 2024 Linux
version.

4 Package Installer - gstarcad — QApt P...

G Package: gstarcad
Status: All dependencies are satisfied.

Description ] Included Files C

e

transportation, surveying, and
petrochemicals. Whether for viewing,
creating, editing, or outputting various
drawings, it can be easily accomplished in
an environment independent of the
Windows system. To ensure the legal
rights and interests of users, please comply
with the relevant provisions of the 'End
User License Agreement' when installing
and using GstarCAD.

@ Install Package % Cancel

3. Authentication is required to give the privileges to install. Please input your password and click OK button.

=! Authentication Required — PolicyKit1 KDE Agent

® Install or remove packages

An application is attempting to perform an action that requires
Authentication is required to perform this action.

ﬂ Details == Cancel
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4.

5.

Click Close button to finish installing GstarCAD 2024 for Linux.

P4 Package Installer - gstarcad — QAptP.. _ O

config files
| application files

» systemctl

# Generated by iptables
*filter

TNPUT |

F

#® Close

The booting icon is shown on your desktop after installing.

GstarCAD 2024

Before installing GstarCAD, please confirm whether the specifications of your PC meet the following requirements:
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2. Starting up GstarCAD 2024 for Linux

2.1. The User Interface

You can enjoy working at GstarCAD 2024 for Linux environment in different ways. You can display and rearrange elements like
the toolbars, display the command bar, switch between workspaces, change the interface themes and enable the status bar. The
toolbars and command bar can also be floated anywhere on the screen or docked as well.

Utilities Clipboard

= x T ELE B

21.1.  Quick Access Toolbar

Display the frequently used tools like: New, Open, Save, Undo, Redo, Save As, Plot, etc. Moreover you can customize it (adding
more commands from the drop-down button) or showing it bellow/above the ribbon.

< 2D Drafting

Minimum Ribbon
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2.1.2.  Workspace

2.1.2.1.  Workspace Switching

Switch between workspaces (2D Drafting and GstarCAD Classic). What' more, GstarCAD 2024 for Linux provides many color
themes, such as Blue, Black, lightblue and so on. You can choose your favorite color theme directly.

R BHB Savavy@ oppuafi
File Edit View Insert For

Home

Line Polyline Circle Arc Moy Blue

Draw o

21.22.  Workspace Command

The WORKSPACE command allows you to create, modify and save workspaces current. You can customize GstarCAD ribbon or
classic workspace to suit interface environment needs much easier.

Workspaces are sets of menus, toolbars, palettes, and ribbon control panels that are grouped and organized so that you can
work in a custom, task-oriented drawing environment. When you use a workspace, only the menus, toolbars, and palettes that
are relevant to a task are displayed. In addition, a workspace may automatically display the ribbon, a special palette with
task-specific control panels. You can easily switch between workspaces. The following task-based workspaces are already
defined in GstarCAD: 2D Drafting and GstarCAD Classic.

If you execute WORKSPAGE command, the following prompts are displayed:

Set Current: Sets a current workspace.
Save As: Saves a current interface configuration as a workspace.

Edit: Opens the Customize User Interface dialog box, Customize tab, where you can make modifications to a workspace.
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Elements Customization | Workspace Customization | Transfer
Customization List: Properties
All Customization Files -l&| 8] (85

»
= QuickAccess Toalbars Name GCAD

» £ Ribbon
» BT Toolbars Display Nam., GstarCAD
» T Menus Filename

» B Shortcut Menus

Q =]
Command Source
1 0 EXPRESS
2 3 Point GCAD
3 3D Adjust Clip Planes GCAD
4 3D Adjust Distance GCAD
5 3D Align GCAD
6 3D Align GMODELER
7 3D Array GCAD
8 3D Array GMODELER
9 3D Constrained Orbit GCAD

Workspace
My Workspace = (2D Drafting

Rename: Renames a workspace.
Delete: Deletes a workspace.

Menu Display and Order

Move Up

Enter workspace to rename [RibbenToolbars [¥]GstarCAD Classic
RibbonToolbars |7 4>

Settings: Opens the Workspace Settings dialog box, which controls the
display, menu order, and Save settings of a workspace.

When Switching Workspaces
@ Do not save changes to workspace

(") Automatically save workspace changes

8K [ Cancel | [ Help |

21.3.  Menu Bar

The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you can find the
follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Text, Dimension, Modify, Window, Help, Express and 3D.
RSB Savrhv®:

File Edit Vie Insert Format Draw Text Dimension Modify

Home Insert Annotation Layout View Export Application Help S Mesh Express

Line Polyline Circle Arc Move Copy (

Draw



Chapter2_Starting Up GstarCAD 2024 for Linux

2.1.3.1.  Menus and Shortcut Menus

You can use any of the option on the Menus from the menu bar at the top of the
drawing area. Choose one of the following methods to use a menu:- On the

menu bar, click a menu name to choose the menu or to expand a list of options.-
Press Alt and the key for the underlined letter in the menu name to open the
corresponding menu item list, and then choose menu items from it. For example,
to edit the drawing file, press <Alt+E> to open the Edit menu.

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you right click an object, status
bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut menu depend on what you clicked.

2.1.3.2.  Shortcuts Customize

A faster way to invoke a command is customize its shortcut. The CUSTACC command allows you to customize, delete or
modify existing command shortcuts. To access this command go through the menu bar, under tools, select customize and
choose Shortcuts Customize. After that, the shortcut customize window will pop up. As you can see, there is a list of shortcuts
command that you can easily modify, delete or even make a new one over an existing one.

5 Shortcuts Customize

[l | Mame Button Source il New...
Clean Screen CTRL+0 GCAD -
[ command Line CTRL+9 GCAD
[ copy Clip CTRL+C GCAD
S RS—— 81 Copy with Base P... SHIFT+CT...  GCAD
5 o S = b
Command Command properties CTRL4R CTRL4R GCAD
Search Command ist: _comm 5 Command - & Cut CTRL4 GCAD
Tags .
—— < [en — S-S S S B DesignCenter CTRL42 GCAD
— Name Carmand Lre (®ext CTRLIQ  GCAD L
Command Display N.. COMMANDUINE | _ 2 Hyperirk. . CTRL4K GCAD
o MAND ALLAS Description Displays or hides the... | = Magnifier CTRL4E GCAD
E Advanced
HIDE COMMAND LINE Elemert ID 1D_CmdLine D Mew... CTRL+HMY GCAD
UNDEFINE COMMAND = Images L bopen CTRL+0 GCAD
Large image RCDATA_32_COM "
Small image RCDATA_16_COM. EE‘]Paste CTRL+V GCAD
£3]Paste as Block SHIFT+CT...  GCAD
S Fiot... CTRL4P GCAD
O e ——— 5 22 Properties CTRL+1 GCAD
B quocac R s
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If you want to create a new one, just click the New button and the customize command window will pop up. Then you can
search the command or select one from the command list. For example, you can input “command line” and then select the
requested command. Notice that it will display the command properties by selecting the requested command at the right side

of the window. After selecting the command, press OK. @ i
NMame Button Source il MNew...
Then the set shortcut window will pop up. You can input the desire T e
[z Command Line CTRL+8 GCAD
keyword(s). For example, you can set the shortcuts SHIFT+D. If you want to Dewop e oo |
opy with Base P...
delete a created shortcut command, invoke the command CUSTACC and v pili
. . & cuf +
then select the delete button from the Shortcut Customize window. oo s co L
G Set Shortcuts -2,
1 0 Magrifier CTRL4E GCAD
Command: Mew. .. CTRL+M GCAD
T g oo
&5]Paste as Blodk SHIFT4CT...  GCAD
Set Shortcuts Siriot... CTRL4P GCAD
SHIFT+D L ropertes bl -
(o J[ concel |

2.1.4.  The Ribbon

The ribbon consists of several panels, which are organized into each tab according to their task label. The tools and controls in
gach panel are also available in toolbars and dialog boxes.

)- Drawing1.dwg

Utilities Clipboard

Panel Tab Expandable panel Expandable tools button

| W~ =] u [— B v 2D Drafting s

Home Insert Annotation 3D Layout View Manage

Tab: The ribbon is structure by tabs. Every tab =
displays a series of panels with its own tools o & o e T3
(commands or thumbnails) easier to select or pick.

= B B & 4« - 4 v 20 Drafting -

Panel: The panel shows the most used tools. Some
thumbnails have an expandable tools button that can
be expanded in a drop-down method. In addition,
most of panels at home tab have an expandable panel
that shows up more commands related.

Home Insert Annotation 3D Surface Mesh Layout

i‘ rJ .= zz= Table

Expandable Panel: The expandable panel is located at the bottom of the panel. If you
click at the bottom of the panel, more commands related will be displayed.
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Expandable Tools Button: Some thumbnails (tools or commands at the panel) have an expandable
tools button that can be expanded in a drop-down method. If you click this button, all the related

tools will be displayed.
@ Center, Radius

/") Center, Diameter

Concentric

3 Point
: Tan, Tan, Radius

b Tan, Tan, Tan

2.1.5.  Appearance

You can manage the interface’s theme plus show/display toolbars, menu bar, file tabs and status bar.

)- Drawing?.dwy

G ToolBar X

] Dimension -
[ Draw
(] Draw Order
o o g | e | cipvons [insert
rorn Ol Layout
D Modiy
[ Modiy 1
[[]Properties
Cltayer
(style
[JOSNAP
[ Refedt
[ Reference
[Render
[ Modeing
[]Solid Edting
1 Standard Annotation v

Heo

4+ = v B A E 2




Chapter2_Starting Up GstarCAD 2024 for Linux

2.16.

Drawing Area

Your drawings are displayed in the drawing window.

21.7.

)
Bl B2 B3 ﬂ
T (R ( % L
oLy L] LN\
IS
o T R T v -

Toolbars

Toolbars partially contain buttons that start commands. When you mave your mouse or pointing device over a toolbar button,

the tooltip displays the name of the button.

The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well
as Microsoft Office standard commands such as New, Open, and Save. GstarCAD 2024 for Linux classic workspace initially
displays several toolbars by default:

Draw toolbar l//7D00rQo~roo A EHED =A%
Draw order toolbar
Modify toolbar levacun o/ /O -aam
Properties toolbar :
Layer toolbar

Style toolbar

Standard toolbar i SRS MBB YD

10
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2.1.7.1. Displaying and Hiding Toolbars

GstarCAD 2024 for Linux provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can
also move and dock toolbars. To choose which toolbars to display:

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right
of the interface) to open the Toolbar dialog box.

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK.

G ToolBar *

[] Dimension A
Draw

[]Craw Order

Insert
[ Layout
[ Modity I
[]Properties
[Layer
[ Style
[ZOSNAP
[JRefedt
[JReference
[JRender
[IMadeling

[]Selid Editing

[15tandard Annotation ~

B Ao Em A A

Eame OB/ /ON0--ddwm

0K Help

To make floated a horizontal docked toolbar,
and hold the left side of it and drag around the
need.

To make floated a vertical docked toolbar, just click and hold the top of it and drag around. To dock any toolbar, just
double-click at the left side of it.

2.1.7.2. Starting Commands Using Toolbars

To start a command from a toolbar, click a HW/ /A Do O ( oo ML EHEDE A
command button and respond to the prompts.

[ Revision Cloud (REVCLOUD) }

2.1.8.  User Coordinate System (UCS)

The icon indicates the orientation of the drawing in two dimensional space.

|

M 4 » M :Model /layoutl /layout? i+

11
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2.1.9.  Model Space and Layout Space tabs

Click a tab to switch between the drawing of your model and a printed layout.

4 AREASUM SAMPLE FOR DEMO.dwg 4 AREASUM SAMPLE FOR DEMO.dwg

Baseball Field
Area summatory

Baseball Field

4 4 » ¥ ‘ Model [ Layoutl M 4 » w4 Model j Layoutl

2.1.10. Command Window

The Command window accepts command and system variable input and displays prompts that guide you through the
command sequence. You can press Gtrl+9 to toggle the display of the command window.

2.1.10.1. Enter Commands on the Command Line

Type the full command on the command line and press ENTER or

Command Line

TG, CdrTCeT

SPACEBAR, or right-click on your pointing device to start the command.  [command: circle

Some commands also have abbreviated names (aliases).

2.1.10.2. Specify Command Options

Once you have entered a command on the command line, it
displays a set of options or a dialog box. To choose a different
option, enter one of the options in the brackets (either uppercase
or lowercase letter is OK), and then press ENTER or SPACEBAR

>>Resuming CIRCLE command.

Command: “Cancel”

Specify center point for circle or [3P /2P /Tir/Arc/Muttiple]‘osnap

ISpecify center poirt for circle or [3P/2P/Tir/Arc/Muttiple]:Cancel* ||

CommandiSPLINE

Pl [

‘Command Line

TG . GG
|Specify center point for circle or [3P/2P /Ttr/Arc/Multiple]-'osnap
>>Resuming CIRCLE command.

Command: Tance™
Command: SPLIN

ISpecify center point for circle or [3P/2P /Tir/Arc/Multiple]:“Cancel

\Specify first point 01 [Object]: © |

12
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2.1.10.3. Execute, Repeat and Cancel Commands

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been
entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To
cancel a command in progress, press ESC.

, | Snap and GRid | Polar Tracking | Obiect Sniap | Dynamic Input | Quick Properies [ 14 [
2.1.10.4. Nesting a Command e R
Object Snap modes
[ (¥ Endpoint ¢ [ClParalel Select Al
To use a command inside an active command, type an apostrophe before A Flwdpon & [iseton
. . O [V]Center b [7] Perpendicular
you type the command. For example, you tumn on the object snap while you Htorsitoria 5 EiTges
are drawing a circle, thus you can setup Object snap mode before continuing L X e
¢ [[]Quadrant R [C]Apparent intersection
rawing. 5 [ Intersection o [F] Distance from Endpoirt 100
drawing
=[] Extension - [[|Divide  Segments 3
. i X i 1) Talrad;;roxtan &mapgm,pauseomﬁepmmwh;l:ma o
Command: circle>Specify center point for circle or [3P/2P/Ttr (tan tan 7 S paneove e
radius)]: ‘osna
)J: osnap e —
(Setup object snap mode as Center in Draft Settings dialog, and then Mode!  Toyoutt  LayouZ
close the dialog to go on performing CIRCLE command) oy et | e fo cirele ar [3p/2p/Tes/avcrmuttiplerconcentric) o

|07 [ [ N 0 TR

2.1.10.5. Enter System Variables on the Command Line

System variables are available for controlling
how certain commands work. For example, :
GRIDMODE is used to control the grid status S S S
ON or OFF.

2.1.10.6. Using the Prompt History Window

The Prompt History window displays a history of the
commands and prompts issued since you started the
current session of GstarCAD.

ion/Fillet/Thick th/Oblique]:
ions/Rotation]:

To display or close the Prompt History window press

F2 Speci or [Hor/Ver/Ang/Bisect/Offset]:
) point:

ugh point: *Cancel*

To view entries in the Prompt History window, just
drag the scroll bars or use the Up (1) and Down (|)
arrows to display previously used commands. ] e

2.1.10.7. Switch Dialog Boxes and Command Line

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the
command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as
well:

13
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-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.

-EXPERT controls whether certain waming dialog boxes are displayed.

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1,
OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even
when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.

2111, Status Bar

Display information such as the current cursor coordinates,
Snap, Grid, Ortho, Polar, Osnap, Otrack and other settings. In
addition to displaying information, the status bar is a quick
way to access many features. You can click status bar items to
make changes, and right click items to display short cut
menus that allow you more choices. By default, the status bar
is shown as the picture below:

The status bar icon also can be show as text button, right click Enabled

v Uselcon

on one of the icon of the status bar, uncheck the "Use Icon" 3
Settings...

option and you will get another method to show the status bar.

2.1.12. Properties Palette

You can modify the value or properties of object(s) you wanted in each column. The Properties palette shows all properties of
the specified object. When selecting multiple objects, the Properties palette shows the command properties of the selected
objects. If none of the object is selected, the Properties palette displays the general properties of the current layer, View
properties as well as the UCS information. By default, double-click an object opens Properties palette if the Properties palette is
hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external reference or gradient
fill.

O|goos|45] 32 14__ 23
i ‘ 27x3 i 2x45°
[, . 3 R L e BT
</ : ﬁ \ i
|l 9 © e \\
3| 8 i z
N = = S |
. @ ‘ /% 35 M22x1,5-6g
A 2w /% 55
x5 | 60 100

195

14
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GstarCAD also supports Quick Properties, which is a set of objects
properties displayed through the Properties Palette. You can
customize your own Quick Properties; you can decide to show your
preferred object type with selected object properties to save the
limited drawing space. You can set the objects properties to
display in quick properties from CUI.

2.1.13.  NAVICUBE

The NaviCube is a navigation tool that is displayed when you are working in 2D model space or 3D visual style, which allows
switching between standard and isometric views easier. It consists of a cube, compass and options, is draggable and clickable,
and supports switching to any available preset views, rolling the current view, or setting the current view as the Home view.
You can enter the NAVICUBE command, or click Ribbon  View 3D Tool » NaviCube to control whether to display the
NaviCube in the drawing area. When the value is ON, the NaviCube is displayed, when the value is OFF, the NaviCube
disappears.

Appearance of the NaviCube: The NaviCube is displayed in one of two
states: inactive and active. When your cursor is not touching the
NaviCube, it’s inactive, it appears partially transparent by default so that
it does not obscure the view of the model. When you move the cursor
over it, it becomes active, it is opaque, so the view of the objects in the
current view of the model may be obscured. And you can other
properties of the NaviCube within the Settings option.

Inactive Active

15
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Cube: Itis in the top right comers of the
drawing area over the model, and shows the
current viewpoint of the model. When moving
the cursor over it, you are able to click the
faces, corners or edges to change the views
conveniently, as well as click on the cube and
drag it to roll the current view. Face

e

Compass: The compass is displayed below the NaviCube
and indicates the north direction defined for the model. You
can click any of the directional letters on the compass to
rotate the model.

When the view is “Front* “Back” "Left” or "Right”, some
little triangle buttons will display around the cube, which
allow you to switch between adjacent views by clicking
them.

»  When clicking the triangle button at the right or left side, the view is switched to its right or left adjacent view. So, you
can continuously switch between different views and rotate the navigation cube horizontally by clicking these two
buttons.

> When clicking the triangle button at the top or bottom side, the view is switched
to top or bottom view. The top and bottom triangle buttons can only be clicked
once.

>  When clicking the triangle button at corners, the view is switched to the edge view
of two adjacent views. The corner triangle buttons can only be clicked once.

16
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Options Menu:
» Home: Changes to Home view

> NaviCube Settings: Opens NaviCube Setting window

On-screen: Identifies the in the viewport where the NaviCube is displayed.
Navicube size: Specifies the size of the NaviCube.
Inactive Opacity: Controls the opacity of the NaviCube when inactive.

Show UCS Menu: Controls the display of the UCS drop-down menu.

Zooms to extents after view change: Specifies if the model is forced to fit the current viewport after a view change.

Orient Navicube to current UCS: Controls whether the NaviCube reflects the current USC or WCS.
Show compass below the Navicube: Controls the whether the compass is displayed below the NaviCube tool.
Restore Default: Restore NaviCube settings to default values.

3D views: Displays view control list.

Coordinated system: Controls coordinate system.

Upside down: Changes to the view side which is parallel to the current view side.

90° Clockwise: Rotates 90 degrees clockwise.

90° Counter Clockwise: Rotates 90 degrees counterclockwise.

Right-click Menu:

»

>

Home: Goes back to Home view

Set Current View as Home: Specifies the current view as the

Home view. Home

Set Current View as Home
MaviCube Setting

Help

NaviCube Settings: Opens the NaviCube Setting window.

Help: Open Online Help system, Home — Commands — N —
NAVICUBE command.

17



Chapter2_Starting Up GstarCAD 2024 for Linux

2.2, Customize the Drawing Environment

In GstarCAD 2024 for Linux, there are different elements of the working environment that can be customized to fit your needs.

2.2.1.  Set Interface Options

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment.

(5 opiom ==
Currert profile: «<<Unnamed Profile>> &) Cument drawing Drawing1.dwg
Display | Open and Save | Plot and Publish | User Preferences | Draw | Selection set | Profiles | Cloud storage | * | »

Window Blements Display resoiution
Appearance Theme: [GelaCAD % L) 1000 A and cirle smoothness
[7] Display menubar Display file tabs. 08 ¢ Segments in a polyline curye
Display Drawing status bar ] Display scroll bars £ 05  Rendared obisct smoothness
] Use large buttons for Tookbars 9 Cartowines per asface
Show ToolTips
Display

[ coen T J [2]2an and zoom weh raster & OLE
Layout Regen Options &) [7] Highlight raster image frame only

() Regen when switching layouts &) [7] Apply solid fill

&) (] Show text boundary frame only

(©) Cache mods tab and last layout
[ Dray true sihouettes for solids and surfaces

@ Cache model tab and all layouts

Crosshai size
Layout elements
Dispay Layout and Model tabs s
Display printable area Fade cortrol
Display paper background Xref display

Riaplay popcr shodow! e
7] Show Page Setup Maniagerfor new layouts In-place edt and annotative reprosentations
Create viewport in new layouts i

[ ok ][ Cancel ooy | [ Hel

2.2.2.  Settings of Modifying Interface

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog
box, Open and Save tab, select Automatic Save and enter the interval in minutes.

Cument profile: <<Unnamed Profile>> a Cumrent drawing: Drawing1.dwg

File Display i Plot and Publish I User Preferences I Draw I Selection set I Profiles I Cloud storage | * | *

File Save File Open
Save as: k] Number of recently-used files
[MoCﬁD 2018 Drawing(".dwg) '] [ Display full path in title

Maintain visual fidelity for annctative objects Application Menu

Maintain drawing size compatibili
@ - EL 5 Mumber of recenthy-used files

[ Thumbnail Preview Settings... ]

50 Incremental save percentage Yrefs
Demand load Xrefs:
Enable

i) Retain changes to Xref layers

File Safety Precautions
Automatic save

80 Minutes between saves

Create backup copy with each save a Allow other users to Refedit cument drawing
[ Full4ime CRC validation

GRX Applicati
[] Maintain a log file Applications

v File extension for temporary files Proxy images for custom objects:

Security Options... [Show proxy graphics

Display digital signature information

oK | [ Cancel
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Color (Display tab): Specify the background colors used in the layout and Model tabs and the color used for prompts and
crosshair.

Font (Display tab): Change the fonts used in the window and in the text window. This setting does not affect the text in your
drawings.

Search Path (Files tab): Set the search path to find drawing

Cument profile: <<lUnnamed Profiles: & cu
support files such as text fonts, drawings, linetypes, and [

hatch patterns.

1 Display I Open and Save | Plot and Publish I User Preferenc

Search paths, file names, and file locations:

% Support File Search Path
% Woaorking Support File Search Path

53]
[+
- E Customization Files
e E Help and Miscellaneous File Mames
H- E Text Editor, Dictionary, and Font File Names
Cument profile: <<lUnnamed Profiles> &) Curert dra - E Print File, Spoaler, and Prolog Section Names
| File |D|5D|E\‘J’j Open and Save | Plot and Publish | User Preferences | Dr: £ E Printer Support File Path
- [ Automatic Save File Location
Window Elements Display resc )
(GaarcaD ] 1000 - {{y Color Book Locations
Theme: |Gst - G
fopearence Theme = = [ E Template Settings
Digpl b: +/| Display file tab: &
sPEymEntRar ey e tebs & 8 []----% Tool Palettes File Locations
+f| Digplay Drawing status b /| Displ Il b &
Py SEwing SEE R SPeY gero bars & 05 [ % Puthoring Palette File Locations
[ Use large buttons for Toolbars § .
= 4 [J----% Log file location
Show ToolTips ) )
Display perf Ej----% Temporary Drawing File Location
I [ Colors... ] [ otz ] I e []----% Temporary Exemal Reference File Location
Layout Regen Options & [Hi E]----% Texture Maps Search Path
(©) Begen when switching layouts -El ‘n‘: i) [ DGN Mapping Setups Location

2.2.3.  Save and Restore Profiles

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled. By
default, your current options are stored in a profile named Default. The current profile name, as well as the current drawing
name, is displayed in the Options dialog box.

5 Options ] 5 Export Profile
Cument profile: <<Unnamed Profile>> &) Curent drawing Drawing.dwg Savein: || GeaCADZO1S ~ @ e mE-
Fle | Display | Open and Save | Piot and Publish | User Preferences | Draw [ Selection set | Profiles | Cloud storage | * | > -
Mame Date modified Type Siz
Avalable profiles I
— b Mo items match your search.
- il B
i K
Profile name:
New DWG JP workstation
v
Desatption: ti
Classfied project el
Jers e @
<[ i | b
Fle name: Drawing! -
Aoply Hep Save astype: Corfiguration File{" ARG) - [ cancel |

GstarCAD 2024 for Linux stores the profile information in the system registry and saves it as a text file (an ARG file) and also
organizes essential data and maintains changes in the registry as required. If you make changes to your current profile during a
session and you want to save those changes in the ARG file, you must export the profile. When you export the profile with the
current profile name, GstarCAD updates the ARG file with the new settings. You can re-import the profile to update your profile
setting.
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2.2.31. MOVEBAK Command

The new MOVEBAK command changes the destination folder for drawing backup (BAK) files. Once you specify a path, the

drawing’s BAK files is placed in that path after every save operation.

Enter new value for MOVEBAK, or for none <current setting>:

Entera . (Period) for none or type the folder name

If you enter ".", the MOVEBAK folder name is cleared and new BAK files will be created in the original folder.

2.3. Customize User Interface

Brief introduction of CUI dialog box:

1. CUI dialog box: Now the CUI dialog box is divided into three tabs: Elements Customization, Workspace Customization and

Transfer tab.

5 Customize User Interface. == = |
& Elements Customization | 2 ockspace Customizsiion | == Transfer
Customization List: R B
P - 58
& & Panels -
=& Annotate - Tt E
[=] Panel Dialog Bex Launcher |
=5 Rewl
Properties ]
BEE Ress! Defauk
E Disploy
Name Automatic Test Numbeing 3
E Appearance
Buitton Style ‘SmalwithouTes
& Command
Command List: A Comemand Name Automatic Text Mumbering
al & M5 Descaption Automatic Text Numbeting
%’ ‘g E’ EI Command Display Name:
Command Souce E Moo “CC_TCOUNT
o EXPRESS - Tags
12 3Pcint GLAD 5 Access
2B 2 Adust Cio Flanes GCAD KesTin
= £ :r e Eﬁ.‘; Tockg Thie Automatic Test Numbeting
0 Aaray GLAD E Advanced
I 30 Constrained Orbit GCAD Element D
& 2 Contnunus Ditt eap Clement I
0OFy GCAD  Images. i
3 Fres Oitit LD
ajo 30 Minor GCAD
A, 30 Move BLAD
T+ 30 Dbt GCAD
€& 30 Osnap Seffings. GCAD
45 D Pan BCAD
2 W Dok [=wt s =
spply. o Cancel =
2. Right click menu: Context menu is available for different interface element as shown below:
E Buick hccess Toolbars
ﬁ“ - . = = o
' - Rename FZ2 =-E3 Ribbon = Quick hccess Toolbars
I I3 Tabs =3 Ritbon
Rastore - Tabs
=] Panels
Reset =-{5] Annotate — Text
Hew Fanel Panel Dislog Box Launch
Find. .. Hew Row
] 1 Hew Famel
Replace. .. Remame  F2 = pnnota  Hew Row
Annota  New Sub—Panel
Delete Annots  Hew Drop-down
Arnots  p4d Separator
Taplicate
Copy Delets
Copy
=
Find Tuplicate
Blocl [ .
eplace. .. Command List:
£ Help Find .
All Commands
Eeplace. ..
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3. Find command: There are several methods to quickly find out the command you want, with these methods, you never need
to browse the command from the top of the list until the end which greatly enhance your work efficiency.

1

Command List:
'AII Commands v

Command
0
45
[T Add Bias
i Add Column
“.c Add Row
Adjust Character
& Align Tool
Angular
28C Arc-Aligned Text

Area Sum
E Arrange Frame Automatically
“, Arange Tool

7A 8hach | sader ta Snnatation

2 3

Source
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS
EXPRESS

EXPRESS
FYXPRFGS

4 5¢

YED0

1- Filter the command by Category: Click the button right side and select the category the

command belongs which will reduce the command search scope

2-Filter a command by entry relevant keywords: For example, input “dimension” in the filter, all
the commands contains the word “dimension” will be shown, reducing the number of

commands to browse.

Command List:

Command List:

All Commands v

o

GCAD Commands
ExFRESSCommand
Custam Commandz
Contral Elements
File:

Edit

g

Ingert

Format

Tools

Draw

Dimenzion

Madify

|AII Commands b ‘ |dimansiun

Command Source
NL’: change dimension text ExPRESS
conzhaint settings, dimensional GLCAD
dimersion GLAD
WA dimension edit GCAD
dimengion precision GLCAD
Wy dimension text edit GLAD
WMy dimension update EXPRESS
"Q dimenszion, align text, angle GLCAD
1 dimension, align text, center GCAD
,.:_. dimenszion, align text, left GCaD
dimenszion, align text, home GCAD
,._",. dimension, align text, right GCAD
"? dimension, aligned GCah

¥ @O

v

3- Command cleaner: If you input the keywords in the filter, the icon

standard command name and description.

Command List:

[AII Commands

Command
I Replace Block

wiIIautomatically change to which is used

to clean the content in the filter, meanwhile, the following command list will retum to the default state.
4- Find and replace: In Find tab input the command you want to find out and click Find Next, the command you searched will
be positioned accurately. In replace tab, you can replace one command with another command, but we suggest not change the

=7 Replace Block
-~ Reset Aray
o2 Reset Aray
.. Reset &ray
Reset Block
Reset Dim Text Valu
Reset Dim Text Valug
Reset Mapping Coorg
1% Restore Config
.. Restare Viewports

Revision cloud

@ Ignore case
Restrict Search to:

Reverse Main Customization File{gcad cuix)
Reverse Direction

Find Selected Command

Search string found in command ‘Revision Cloud’ property

‘Command Name’ at position 0.(1/2)

Reverse Direction
Revision Cloud

21



Chapter 2_Starting up GstarCAD 2024 for Linux

5- Create a new command: If it is necessary to add secondary development program command to the command list, you can
set the items follow the current command settings as shown below.

»

Properties

E Command
M armne Array
Dezcription
Command Dizplay Mame ARRAY
Macro “CC_array
Tags
B Advanced
Elerment [D
B Images
Small image RCOATA_16_ARRRAY
Large image RCDATA_1E_ARRRAY

Restore and reset:

If all the customization operation has been finished, but you made some | e e

5 Elements Customization Iﬁ workspace Customization | = Transfer

Customization List:

mistakes when customizing CUl or you are not satisfied with the effect,

restore and reset can help you recover to the original settings. [ Customization Files

Restore: Restore the backup Settings, click "Apply" button, the data BW
before modifying will be saved as backup files which are used for o  Restore

recovery. s ::t

Reset: Recover to the initial setting when first installing GstarCAD. Replace... Launcher

- Multiline Text

Single bed 1

BT Single bed 2

2.4. Tool Palettes

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool
palette are called tools. You can create a tool by dragging an object onto the tool palette. To
open the tool palettes just press CTRL+3 or Type TOOLPALETTES command.

Linetype CONTINUOUS.
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2.5, Design Center

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents:

-Browse for drawing content on your E|le-2- Q& aEHE -
. Falder Open Drawings ] History I

computer or a networked drive. e — ] e
View definition tables for named objects | ™ & et o D i

. I3 Block
and then insert, attach, copy and paste the Slmer
definitions into the current drawing. ?ii‘,fime

. == Linetype

-Create shortcuts to drawings and folders
that you access frequently. [x]
-Add content such as xrefs, blocks to a
drawing. =
-Drag drawings, blocks to a tool palette I
for convenient access. -

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and
related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles
within a drawing.

Open Drawings: A list of currently opened drawings is displayed. If you click a drawing file and then click one of the definition
tables, you can load the content into the content area.

History: A list of previously opened files is displayed. If you double-click a drawing file from the list, you can load the content
into the content area.

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those.
When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save
shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are
stored in the Favorites folder.

2.6. Clean Screen

Now, if users want to maximize drawing space, they can press the keywords Ctrl+0 or select the icon (Clean Screen) located in
the right corner of the status bar. After executing this command, Toolbars and dockable windows (excluding the main menu bar,
command line and status bar)will automatically be cleaned. This function can provides better visibility as large as possible to

make it easier to fully understand every details of the drawing.
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2.1. Lock Ul

Lock Ul locks the position and size of toolbars and dockable windows such as Design Center, Properties palette, etc. To unlock
them temporarily, hold down CTRL key. LockUI setting is stored as a bit code using the sun of the following values:

0 Toolbars and windows not locked

1 Docked toolbars locked

2 Docked or anchored windows locked

4 Floating toolbars locked

8 Floating windows locked
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3. Create, Open, Save, Recover a Drawing and Manage Drawings

3.1. Create a Drawing

3.1.1. Create a New Drawing Using Default Settings

When the system variables FILEDIA and STARTUP are setto 1,
typing NEW at the command bar, it opens Startup dialog box, from — —
which you can use Default Setting, Template or Wizard to create a = Ql

new drawing. Select a Fle:

File Path

rE Create New Drawing I RS J

Open Drawings

You can select either imperial or metric units for the new drawing.

Imperial measurement system: The drawing uses internal default g | [ Bowse... ]
values with default boundary is 12 x 9 inches. =

Modified

Metric measurement system: The drawing uses internal default

values with default boundary is 429 x 297 millimeters.

3.1.2.  Create a New Drawing Using a Setup Wizard

From the Startup dialog box, you can select "Use a Wizard" tab to
create a new drawing by the wizard. There are two wizard options
illuminated as follows:

Wizard Description
Set the units, angle, angle measure, angle direction, and area for your new
drawing. Based on the template geadiso dwt

Advanced Setup Wizard:

[ ok ] [ Comeed |

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings
such as units of measurement style, precision, direction, and orientation based on template gcadiso.dwt.

Units 3 N Enter the area you want to represent using
Full scale unts. Example: to draw in an
Angular \ area 12x 9 meters, enter 12 under Width and 9 under
. ﬁmmdmwmmm ; Length.
- i , Angle Measure Vidth:
> AN
N Deg/Mn/Sec Angle Direction - NN
o g QA
3 o | :
o * Area i NN Length:
. — S 297
s N Select the direction for angle measurement
Gl \ ©East N ) 1
\ =
® Ange Measure > North
Angle Direction - RN ¥ B
: 180 ) el
o \ 5 South 210
N s Angle M Back | [ Fosh | [ Cancel
- ; Y
Angle Directi - =\
N = o
3 Aea \ s
‘ .
N
Back | [ MNet | [ Cancel
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CemrEs
Quick Setup Wizard: From this option, you can specify units of measurement, El Ql ﬁl Use template
precision of displayed units, and grid limits based on template gcadiso.dwt.

Select templates:

geadiso.dut

Browse...

Template information
Ne Template information.

3.1.3.  Create a New Drawing Using Template

When you need to create several drawings with the
default settings, you can save time by creating a

G Select Template Fil

< GstarCAD » R19 » en-WW » Template »

v [ 43 [l Search Template

. . . . Organize v New folder =~ 0 @
template file designed to create the same drawing files et tame :
. . B Desktop . SheetSets 2018/8/2215:21
so that you does not need to specify default settings 4 Dovesds B oo
42 Dropbox & geadiso 2018/8/2215:21
gach time you start. Conventions and settings commonly B recentPlaces |
stored in template files include: unit type and precision, e S
. . » o Homegrou
title blocks, borders, and logos, layer names, snap, grid, o
4 (8 Computer
and ortho settings, grid limits, dimension styles, text et
i > g DATA (E) ~ |4 . v
styles and Linetypes. -

Also when the system variables FILEDIA and STARTUP
are set to 1 and 0 separately, typing NEW opens Select Template dialog box, from which you can select the desired one or use
the default template by clicking the arrowhead button next to the Open button.

3.2, Open a Drawing

3.2.1.  Opena Drawing

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files,
drawing standard (dws) files and drawing template (.dwt) files. You can also
open and check drawings that you suspect are damaged.

Ctrl+O

To open an existing drawing:  File > Open Xy W
. . | Lookin:  J, DWG v G EIE] Preview ¥
Command line > OPEN Using shortcut> - B - onemodtied Type P
CTRL+0 | 2 s | s
< ﬁ helicopterl 2019/8/1211:05 DWG File

' , | iy sy | b
-In the dialog box, choose the type of file you
want to open. ' e

[

-Choose the folder containing the desired O ;
. . Ch, Fie name: Open_|v
file.-Choose the drawing you want to open, and it

then click the Open button or Double click on the
drawing you want to open.
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3.2.2.  Multiple Open Drawings
You can open multiple drawings at one time. There are several methods for switching a drawing to another.

- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.
- You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use
Arrange Icons to align icons if there are several minimum drawings.

AEBBDESavevg
File Edit View Insert 0 t Text Ex

Home Insert otation Layout

Line Paolyline Circ Arc Move Copy y ay Text

Draw o Annotatig

B ammemdEmMm B~
Drawingl.dwg B Drawing2.dwg [l

3.3. Save a Drawing

3.3.1.  Save a Drawing

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In
addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created
your drawing using a template, saving the drawing does not alter the original template.

To save a drawing: ~ File > Save Command line > SAVE Using shortcut> CTRL+S

A& HD Savav € 2DDrafting

File | Edit View Insert Format Tools Draw
Home [ Mew.. Ctrl+N

@ Open.. Ctrl+0

B Open third-party drawings(R)...

Line
[ Close

B Import...

Attach...
@or . -
H Save Ctrl+5

Ctrl+5hift+5

B E

Remark: When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a
directory and type a name for the drawing.
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3.3.2.

You can specify to save drawing files automatically in order to minimize the lost data

once a problem occurs.

Save Your Drawing Automatically

Current profile: <<Unnamed Profile:

Fle | Display || Operiand Save ] Plot and Pubiish | User P

Fil: Save
Save as:
[AutoCAD 2018 Drawing(* dwg) -

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

If you start the automatic save option, your drawing is saved at specified time intervals.

[ Thumbnai Preview Settings... |

50 Incremental save percentage

By default, system assigned the name filename. sv§ for temporarily saved files, filename
here refers to current drawing name.

File Safety Precautions
Automatic save
30 Minutes betwsen saves
Create backup copy with each save
[T Fulltime CRC validation
[Z] Mairtain a log file

v File extension for temporary files

Display digital signature information

5 Write Block

Source
Block:
() Entire drawing

3.3.3.  Save Part of a Drawing File

Base point
You can use BLOCK command or WBLOCK command to create a new (3] pecoon
drawing from part of an existing drawing. You can select entities or a block j 3E
definition in your current drawing and save them in a new drawing file. The z oo
description also can be saved in the new drawing. Bestiation

File name and path:

E:\Program Files\Gstarsoft'\New Block dwg

Objects

Select objects
(@ Retain

() Convert to block

(2) Delete from drawing
& No object selected

Insert units I\nches

[ ok [ cancd | [ hHebp |

3.3.4.  Save to a Different Type of Drawing File

Choose the format from Save as Type in the Save Drawing As dialog box, you can save a drawing to an earlier version of the
drawing format (DWG) or drawing interchange format (DXF), or save a drawing as a template file.

To save a different format:

File > Save As Command line > SAVE AS Using shortcut > SHIFT+CTRL+S

5 Save drawing as

Savein: |, Drawing and picture - 0 =mE
. Name Date Type g4 | Prevew:
- £ VESSEL(L) 2015/10/19 .. DWG File
&)1 100TRIBUNA PRIMC recover_recover 2015/7/102..  DWG File
L) ACAD-ARQUITECTURA - CENTRO COME...  2015/6/1 5146  DWG File =
[; L) ENTREGA FINAL - copia 2015/5/18 2. DWG File H
I &) Trituradora 2015/5/138... DWG File
530 MODEL SAMPLE recover 2015/4/14 1. DWG File
&30 model_recover 2015/4/141.. DWG File
I‘ &) DUPLEX_SAN_MARTIN_CAPAS 2015/4/418... DWGFile |
& centro comercial -40 2015/4/110... DWG File
L) ENTREGA FINAL LUCANO DELGADO 2015/3/20 2. DWG File
|| LG pap T ], '
o wing[* dwg
& ARQUITECTU  FAD 2013{LT2013) Drawing(* dwg) DWG File
&) DRAWING S8 m::gﬁg ﬁg{\[mi% BEWNF gwg; DWG File
~ o "2007) Drawing (" dwg)
~ &5 PDF UNDERL] s 406 aD 20041 T2004) Drowing - dwg) DWG File
("‘wl &30 model utoCAD RM{LEWETZCE‘JF)Q%EDWWF d}“ﬂ' ) DWG File
= - o rawing(" dwg]
&) DRAWING S yocp, DrawingStandard (" dws) DWG File
Liestadio  |AtoCAD Drawing Templatel” dnt) DWG File
[ALtoCAD 2018 DXF(" dd)
2 o
QimsT. epuca e D o o BXFr ) DWG File
130 MODEL ${AtoCAD 2010LT2010) DXF" ) DWG File 2
ol ALtoCAD 2007(LT2007) DXF("chf) v
[ ACtoCAD 2004(LT2004) DXF[ cbf)
| ALtoCAD 2000(LT2000) DXFT cif)
Fie rame: [ALtoCAD R12/LT2 DXF(" )
Save astype /utoCAD 2018 Drawing("dg) - [ cancel |
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3.3.5. DWG Convert

DWGCONVERT command converts one or a bunch of selected drawing files to another dwg version available. The newly
generated file can overwrite the original one, and it can also be compressed into a self-extracting EXE file or a ZIP file to
facilitate batch format conversion of the entire project drawing.

s
EPORTIVO PLANTAS dwg
rales

lace)
g ko1 545153’;‘;“ j;“; Comeelo 200 rslac)
W) 1344463999 dwg
¥ el 1344464123dwg
VI g 1344465690 dwg

TANDARD

Convert to 2010 finplace)

3.3.6.  Batch conversion between graphical file formats

Converts one or a bunch of selected drawing files

to an older or current DWG version available. The BN
newly generated file can overwrite the original file, == ok
and it can also be compressed into a L )
self-extracting EXE file or a ZIP file to facilitate
batch format conversion of the entire project - (.
drawing. Sl

Steps to Convert DWG files to different format

1. Click “File”>"DWG Convert” in tum

2. Click “DWG Convert” dialog box >"Add File” (Near the bottom)

3. In"Select File” dialog box, you need to browse to the folder where the graphics file is to be converted.

4. Click the graphic file name, and then click “Open”.

5. In “DWG Convert” dialog box, click “Conversion Setups”. In “DWG Convert” dialog box, create a new Conversion Setup
(NEW), modify existing Conversion Setup (MODIFY) or select a previous Conversion Setup, and then click “CLOSE”.

6. In “DWG Convert” dialog box, click “CONVERT”.

7. I the Conversion Setups specify an EXE or ZIP file, browse to the desired destination folder, then double-click the file to
select it. If needed, input a new name for the file.

8. Click “SAVE”.
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3.3.7.  Use Backup Files

GstarCAD creates a backup file with the current drawing name and a ".bak" extension to save the previous version of the current
drawing when launching "backup automatically" option.

3.3.8.  Reduce the Time Required to Save a Drawing File G 0_

Cumert: profile: <<Unnamed Profile>> 4
In order to reduce the time of saving a drawing file, you can specify i | File | Display i Open and Save 3 Plot and Publish | User Pre
the incremental save percentage on the Open and Save tab of Options ' File Save
dialog box or from the ISAVEPERCENT system variable. Save as:
| AutoCAD 2018 Drawing(" dwa) -

The incremental save updates only the portions of the saved drawing :::2::: :':”‘:LT:::Z::;‘I’;:EE e

file you changed. Drawing files will contain a percentage of [
potentially wasted space when you use incremental saves. This
percentage increases after each incremental save until it reaches the
specified maximum value, and then a full save is perform.

Thumbnail Preview Settings...

50 Incremental save percentage

3.4. Recover a Drawing Fp—— <<Unamed Prfie>> i

| [Fie | Display |iOpen and Save § Piot and Publish | User Pre

File Save

Sveas

3.41. Recover a Damaged File [AtoCAD 2018 Drawing(" dwg) -

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

You can recover some or all of data by reverting to a backup file or using commands |

to find and correct errors if a drawing file is damaged. A drawing file may be damaged 2 ) R avepecaior
File Safety Precautions

by a hardware failure, power outage and system crash. You had better create a backup Mewm

S0 Minutes between saves

file if the drawing is important.

Create backup copy with each save
[ Full4ime CRC validation
[] Maintain a log file

In the Open and Save tab of Options dialog box, you can specify the backup file are 5l ccenson ortemporay fes
created when you save drawings and set the proper interval time for saving. Then a

Display digital signaturg information

backup copy file with a ".bak" extension is created when you save the named drawing
once again. After that, a backup file is always updated while you executing the command SAVE or SAVEAS.

You can use RECOVER command to check and attempt to open a damage file. Then uses AUDIT command to find and correct
errors.

To open a damaged file:  File > Drawing Utilities> Recover

Command line > RECOVER

G Select Files ]
Lock Drawing end picture > 0F @
Name Date Type Size Tags S
- 2015 drawings 2014/11/28...  File folder
&1-UBICACION POL... 2011/3/201... ICAD Draw 1,906 KB ﬁ’ﬁ
B2PUNTAGENER.. DML, ICADDw..  2191KB .
&30 casa de playa33... 2014/6/510.. 21278 g ER
& 3d chancado 20129261 60,829 KB
&30 IRRIGATION M. 2004/1/7 14, “ 4,509 KB ———
&30 MODEL SAMPLE  2015/1/271... ICAD Draw 1375KB ___ Endrie..
| #y & 3D MODEL SAMPL... 2015/4/141...  ICAD Draw 1,413 KB -
{230 model 151728 1... _ICAD Draw 672K8 ] L
&30 model recover  2015/4/14 1., 686 KB
- & 3d rendering 2002/4/511... 40KB
30 SYNC HOUSE FL.. 2012/9/191... ICAD Draw 680 KB
L3DVILESAVOVE  2014/4/148..  ICAD Draw 1144 K8
= &0 214/7/113.. ICAD Draw SATE KB
% B 3upedalish 2007/7/196.. ICAD Draw 5682KB
&3-POLIDEPORTIVO... 2011/3/201... ICAD Draw. 1734 KB
Fie name 30 mocel o |7
Fies of type. Drawang(" dwg) | Cancel
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-In the dialog box at Files of Type, choose the type of file you want to recover.
-Choose the directory containing the damaged file.
-Choose the damaged file you want to recover and Click the Open button or Double click on the drawing you want to open.

To check errors fora drawing file:  File > Drawing Utilities > Audit Command line > Audit

4 1\ Model

-
Command: AUDIT

Fix any emors detected? [Yes/No] <N=Y
120165 objects audied

Total emors found during audit 0, fieed 0

= X

Command:

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit

2. Input Y or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter.

3.4.2.  Drawing Recovery Manager

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened
drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files
that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup

File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of
backup.

Drawing Recovery Manager x
Skip to automatic save file local

When program or system stopped by accident, the drawing files need to recover are sorted

= BLOCKS2

into the following types. BLOCKS 2_1_5038.5v§

aig BLOCKS 2.dwg

-Recovered drawing file saved when program fails (DWG)
-Temporary saved file (sv$)

-Backup file (BAK)

-Source drawing file (DWG)

Preview: ¥
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4. Control the Drawing Views

41, Redraw and Regenerate a Drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by
refreshing, or redrawing, the display.

To redraw (refresh) the current window display:  View > Redraw Command line > REDRAW

To regenerate the current window:  View > Regen Command line > REGEN

N view e
2 Redraw
5N TOOL.d

Regen

5 Regen Al
Zoom
Pan
Orbit
Viewports

& Named Views..

3D Views

% (7 Hide
% Visual Styles
] Render

' Display
= Toolbars..
.

b1 Model { Layoutl /Layout2

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision.
Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the
appropriate screen coordinates.

4.2 Magnify a View (Zoom)

ViR Insert Format Tools Draw Dimension Modify Window Help Express

You can use ZOOM command to zoom in or zoom out the

, , @ Redraw hut View Manage Export Help
drawing view to meet your need. You can change the Regen )dwy_ BEARING DRAWING.dwg  LAYOUTBYPATH SAMPL
e . . . & Regen Al %/ v 7 ﬁ: F !
magnification of your drawing at any time. The cursor changes = @ et o |famds
to a magnifying glass when a zoom tool is active. Zoom out to Pan V| @ | previons o a
. . , Orbit 4 indow !
reduce the magnification so you can see more of the drawing, et e I
or zoom in to increase the magnification so you can see a & 3”;:_““%--- % z'
iews » enter
portion of the drawing in greater detail. gl @ Object -
Visual Styles » @ I L
. . X Render 3 a Out
Remark: If you are working in a layout viewport and cannot Disply @
zoom, the layout viewport may be locked. The scale and view [ |eebes B || tents

do not change in model space while panning or zooming in a locked layout viewport.

32



Chapter 4 Control the Drawing Views

421.  Zooming Methods

To zoom, you can use any of the following methods:

-To define the portion of the drawing to zoom, create a window.

-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.
-If you have a mouse with a wheel, rotate the wheel to zoom in and out.

42.2. Zoomto Magnify a Specified Rectangular Area

You can specify a rectangular area defined by two comers to display the objects within that area as large as possibly. The
lower-left corner of the specified area becomes the lower-left comer of the new view.

To zoom in to an area using a window: ~ View > Zoom> Window Command line > ZOOM

-Choose View > Zoom > Window
-Select one corner of the window around the area you want to magnify.
-Specify the opposite corner of the window around the area you want to magnify.

P00 Insert Format Tools Draw Dimepsion Modify Window Help Express

Eile Edit View Insert Fgrmat Toals Draw Dimension Modiy Window Help  Expresd

«Z Redraw but View Manage Export Help Express Home Insert Annotation 3D Layout View Manage Export Help
Regen DRAWING.dwg 4 LAYOUTBYPATH SAMPLE.dwg _ x MECHANICAL DRAWING.dwg
T Regen Al r 1
Zoom » | @), Realtime I 1
b ' Previous | ——q
Orbit '@, window |
Viewports » | 6B Dynamic 1
T Named Views.. @, Scale I 1
3D Views @ Center 1 I
(7 Hide a 1
Visual Styles @ 1
Render & 1 I
Display @, I 1
= Toolbars... @, 1 I
! |
I I
Modify Window Help Express

423. Zoom in Real Time :

Realtime option zooms dynamically by moving your pointing device up or
down. By right-clicking, you can display a shortcut menu with additional
viewing options.

To zoom in real time:  View > Zoom>Realtime
Command line > RTZ0OOM

3D Orbit

Zoom Window
Zoom Original

-Choose View > Zoom > Realtime from the main menu. R\ ¢ r " Zoam Btens
-Hold the left mouse button, then drag the cursor forward to zoom in and move back to zoom out.
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4.2.4. Displaying the Previous View of a Drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire
drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps
back through up to 25 successive zoomed or panned views.

4.25.  Zooming to a Specific Scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of
the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at
the center of the current viewport remains centered on the screen.

To zoom to a specific scale relative to the current display: View > Zoom >Scale Command line > ZOOM

-Choose View > Zoom > Scale from the main menu.

-0On the Zoom toolbar, click the Zoom Scale.

-Type ZOOM in the command line, choose the Scale option, and then press Enter.
-Type the scale factor, followed by an x (such as 2x).

-Press Enter.

File Edit View Insert Format Tools Draw Dimension Modify Window Help Express

el Insert  Format

& Redraw
Regen

F5 Regen Al

Zoom

Tools Draw Dimension Modify Window Help Express

Insert  Annotation 3D layout  View  Manage  Export  Help  Express
‘OUTBYPATH SAMPLE.dwg % MECHANICAL DRAWING. dwg

but
DRAWING. dwg

View  Manage  Export  Help  Express

» Reattime
s

b Previous
s

Oorbit Window
3 Dynamic

Scale

Viewports
@ Named Views...
30 Views »

(7 Hide
Visual Styles 3
Render »

Center
Object
In

Out

All
Extents

Display ,
= Toolbars..

DL LD PRPROE O

W < » " Model {Layoutl {LayoutZ

P o
first point as displacement>:
mmand: ZOOM

pecfy comer of window, enter a scale factor (nX or nXP), or
[All/Center/Dynamic/ Exterts. Previous/ Scale/Window/Object] <redl time>: SCALE
Erter a scale factor (X or nXP): 3

4.26. Displaying the Entire Drawing

Z00M Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display
the objects on layers that are turned off but do not include objects on frozen layers.

Z00M All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger.

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar
displays the drawing to its extents, making the image fill the display to the greatest possible magnification.
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43. Pan and View

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing
horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space. The
only change is the portion of the drawing displayed. To pan, you can use any of the following methods:

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting
point of the pan. The second point indicates the amount of pan displacement relative to the first point.-To pan in real time, use
the Pan Realtime tool on the Standard toolbar.

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.

ViR Insert Format Tools Draw Dimension Modify Window Help Expr

To pan inreal time:  View > Pan>Realtime Command line > PAN
@ Redraw i Manage
Regen

-Choose View > Zoom > Realtime from the main menu. T Regendl
Zoom 3

-Move the cursor in the direction you want to pan. = F
-To stop panning, press Enter, ESC or choose Exit from the shortcut menu. et '

Realtime

Point
Left
Right
Up

Viewports 3
& MNamed Views..

3D Views 3

@ Hide

Visual Styles 3

To pan using a mouse with a wheel:

Render 3

-Press and hold the wheel, and then move the mouse in the direction you
want to pan (The MBUTTONPAN system variable controls this feature.)

Display 3
- Toolbars...

44, Display Multiple Views on Model Space

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can
divide one window into multiple windows. You can also open and display multiple drawings.

4.41.  Set Model Space Viewports

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one
viewport, the others are updated simultaneously.
You can do the following operations at the model

J'.27) Insert Format Tools Draw Dimension Modify Window Help Express

T Regen Al

space viewport: oo , .
P » o
-Set Snap, Grid, and UCS icon modes; Pan; Zoom; e E Z’m;‘”‘“"“’“
| New Viewports...
. 3D Views 3 1 Viewport
and restore named views. = —
-Save orientations of UCS with individual viewports. — e
. Display , | @] Polygonal Viewport
-When executing a command, you can draw from okl =11
B Join

one viewport to another.

-Name a viewport arrangement in order to you can
reuse it on the Model tab or insert it on a layout tab. .
-When you work on 3D models, is helpful setting up

different UCS in individual viewports.
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442. VPMAX/VPMIN

VPMAX allows you to expand the current layout viewports and switch to Model Space for editing without worrying about

messing up viewports’ scales and limits, while VPMIN allows you to restore the current layout viewport.

System Variable Description Value Value Description
Controls whether { imize th t 0 Do not maximize
ontrols whether to maximize the curren
VPMAXIMIZEDSTATE ,
viewport (read-only) .
1 Maximize
4421, VPMAX

Expands the current layout viewports to fill the screen and switches to Model Space for editing.

You can enter the viewport maximized state in the following four ways:

> Enter the VPMAX command in the Layout Space, and then click to select the viewport to be maximized; (when there

is only one viewport in the layout, the viewport will be maximized directly without the need to select)
»  Enter the VPMAX command after selecting a viewport in the layout space;

» Double-click the viewport border in the Layout Space;

4422 VPMIN

Exits the maximized state and returns to the current Layout Space.
You can exit the viewport maximized state in the following three ways:
> Enter the VPMIN command;
»  Double-click the blue border line;

> Click the minimize viewport icon on the status bar in the Layout Space. [_T‘
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4.43. Working with Multiple Views of a Single Drawing

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple
windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the
display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others.
And also you can switch from one window to another at any time.

To create multiple views: View > Viewports Command line > VPORTS

-Choose View> Viewports-In viewports menu, choose 1, 2, 3, or 4 viewports.
-Type h if you want the horizontal orientation, or type v if you want the vertical orientation.

To join two views:  View > Viewports > Join Command line > VPORTS

-Choose View > Viewports > Join -Click anywhere inside the window you want to keep.
-Click anywhere inside the adjacent window you want to join to the first window.

To restore a named window configuration:

-Type -VPORTS system variable at the command line and press ENTER.
-Then type Restore.
-Then type the name of the window configuration you want to restore.
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4431, VPSCALE

The VPSCALE (viewport scale) command reports the real scale of the current viewport of a selected layout viewport.

1. You can open a recent drawing with layouts or create a new viewport on layout space with a desire scale according to paper
format.

2. Type VPSCALE command on the command line, and then select the edge of the viewport.

3. The command line will show the correct viewport scale according to unit measure you are working with.

4. Notice the status bar shows the right scale of the selected viewport only at layout space.

110
116

1:20

. 1:30

1:40

1:50

1100

21

41

81

10:1

1001

1/128" = 10"
— e /64" =1-0"
132" 210"
1/16" =1'-0"
332" =1'0"
1/8" = 10"
316" =1-0"
14" =107
3/8"= 10"
12" = 10"
4= 10"
=10
iodel j Layoutl 1-1/2 =14
gmmand: VPSCALE 3"=10"
elect edge of viewport. 6 10gr

ayoutz £+

101
Custom...

" Hide Xref scales

0.0014, -0.0060, 0.0000

4.4.4.  Working with Multiple Drawings

With the multiple document interfaces, you can open and work on several drawings at one time, you can copy, cut, or paste an
entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can
see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu,
the following three methods that determine how drawings are arranged are provided for user's choice.

B Cascade
= Tile Horizontally

B MECHANICAL DRAWING.dwg Tie Verically

vy w0
S HI 0
-Cascade o & ot SicTONar | B0

Amange kcons

Window.

-Tile Horizontally NI ]| e e

B2
G5

-Tile Vertically
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445, View Manager

With the view manager, you can create, set current, update layers, edit boundaries,
and deletes named views, and switch quickly between each views, it is helpful to
reduce many unnecessary view adjust operation.

Lens lergh frm) |50

45. Specify a 3D View o) (o (=

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can
specify a new viewpoint to create new objects or modify the existing objects.

451.  Setthe Viewing Direction

You view three dimensional drawings by setting the viewing direction. The viewing
direction establishes the viewing position, When you view a drawing from the
default viewpoint (0,0,1), you see a plan view of the drawing. You can change the
viewing direction to look at the drawing from a different vantage point or to work on

From: From:

a three dimensional mode! from a different orientation. Kaus: 2700 KPlane: 900
To set a new viewing direction:  View >3D Views > Viewpoint Presets [ ) [ cnca | [ e

Command line > DDVPOINT

-Choose View > 3D Views > Viewpoint Presets
-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the needle according to your preference.
Then click OK button.

To display a plan view of the current drawing: View > 3D Views > Plan View Command line > PLAN

-Choose View > 3D Views > Plan View from the main menu.
-It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you want.

File Edit B0 Insert Format Tools Draw Dimension Modify Window Help

iew  Manage  Export  Help

4 ALIGN TOOL.d Regen (QUTBYPATH SAMPLE.dwg MECHANICAL DRAWING.dwg OVERLAPPING SELECTION.dwg Drawing3.dwg sample.dwg 3
T Regen Al
Zoom ,
Pan v
orbit v
Viewports 3
Named Views... s
3D Views » Viewpoint Presets.. @ Viewpoint Presets ==
£ Hide iz 4 [Set Viewing Angles
Visual Styles 3 m Top @) Absolute to WCS (") Relative to UCS

Current UCS
World UCS
Named UCS

€9 SElsometric
@ NElometric

From: From:
X Axis: 315.0 XY Plane: 35.3

Set to Plan View

[ ok ] [ cancdl | [ hep |

1« 4 » n\Model {Layoutl /Layout2
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45.2. |sometric View

Pl Insert Format Tools

You can define perspective views of a Regen

T% RegenAll
model to create realistic effects. Select Zoom >
predefined standard orthographic and o I

isometric views by name or description. @

Mamed Views...

Viewports ,

Draw Dimension Modify Window Help

but ~~ View Manage Export  Help
‘QUTBYPATH SAMPLE.dwg ~ MECHANICAL DRAWING.dwg  OVERLAPPING SELECTION.dwg  Drawing3.dwg  sample.dwg

These views represent commonly used == paver
options: Top, Bottom, Front, Left, Right, e % -

and Back.In addition, you can setviews ~_ oe |5 I
from isometric options: SW (southwest) Al

Isometric, SE (southeast) Isometric, NE s
(northeast) Isometric, and NW (northwest) i

[sometric.

45.3. Draw 2D Isometric Views

>

With Isometric Snap, you can create 2D objects that appear to be 3D solids.

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one
of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.

Snap type
@Grdsnap
@® Rectangular snap
O Isometric snap

5 Drafting Settings x
Snapand GRd  Polar Tracking  Object Snap  Dynamic nput  Guick Properties 1< >
[snap On (F3) [J6nd on (F7)

Snap spacing Grd style

Display dotted grid in
ST ] 2D model space
Snap Y spacing 0] Bock ecor

[ Sheat/layout
Equal X and Y spacing

Grd spacing

Grd X spacing:

o
_E

Display grid beyond Limés
[0 Fallow Dynamic LUCS
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454, Setlsometric Grid and Snap

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle
is setto 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work

on any of three isometric planes, each with a pair of associated axes.

-Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and

150-degree axes.

-Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and

150-degrees axes.

-Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and

30-degrees axes.

[ B
e —| 9 O o]
Snap and GRid | Polar Tracking I Cbject Snap I Cynamic Input I Magnifier | Symmetr| 1| ¥
[ Srap On (F3) [ Grid On (F7) T
Snap spacing Grid style o p
L Digplay dotted grid in:
EEDEETER 05 []2D model space
Snap Y spacing D5 [ Block editor
[ SheetAayout
Equal X and Y spacing
Grid spacing
Snap type Grid X spacing: E
(@ Grid snap Giid Y spacing: 0.5

@ Rectangular snap

() lsometric snap

Major line every: 5

Grid behavior

Left

[¥] Adaptive grid ng h t
[ Allow subdivision below arid
spacing

Display grid beyond Limits 30 o
[ Follow Dynamic UCS

150°

oK Cancel Help

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying
one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes.

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can
draw the top plane first, and switch to the left plane to draw another side, and then switch to the right plane to complete the

drawing.
L. Orthe Mode(F8)

T # N

Top plane

Left plane Right plane
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455, Change a 3D View Dynamically

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically.
With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or
zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. GstarCAD
supports more orbit options like Free Orbit, 3D Continuous Orbit, Orbit along the X-axis, Orbit along the Y-axis, Orbit along
Z-orbit and 3D Orbit Center. Additionally users can create two new meshes through DISH and DOME commands. To close 3D
Orbit, press Enter, ESC or choose Exit from the shortcut menu.

4.5.6. Hide Lines or Shade 3D Objects

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are lo cated
behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to
remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much
clearer, but you cannot modify hidden-line or render views.
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45.7. Add Simple Shading to 3D Objects

Although hiding lines can enhance the drawing and clarifies the design,
shading produces a more realistic image of your model. You can
modify shaded objects as you normally would. When a shaded object
is selected, the wireframe and grips appear on top of the shading.

45.8. Section Plane

SECTIONPLANE command creates a section object that acts as a cutting plane through 3D objects and saves the selected section plane as a
2D or 3D block. You can move the section object dynamically in a 3D model or in a surface area. You can use the active section to analysis
model by moving the section object in the object. Create cross-sectional views that can be saved or reused.

£ | Sectio nmﬁnhgi
~ -

Section Plane

Select section plane

A\ (No section plane objects selected)
2D section/elevation block creation settings
3D section block creation settings

@ Live Section settings

Active Live Section

Show Yes

Face Hatch Predefined/SOLID
Angle 0
Hatch Scale 1
Hatch Spacing |1
Color Color 8
Linetype
Linetype Scale |1
Lineweight

Continuous

Default

Apply settings to all section objects

4.6. Render

Rendering creates a 2D image based on a 3D scene. It
shades the scene's geometry using the lighting you've
set up, the materials you've applied, and environmental
settings such as background and fog. At a basic level,
you can use the render command to render your model
without applying any materials, adding any lights, or
setting up a scene. You cannot move or adjust this light.
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5. Precision Tools and the Properties of Drawings

5.1. Specify Units, Angles and Scale

Specify the units of measurement you want to use, their format, and other conventions.

5.1.1.  Set the Units Format

You can set the display format of the unit that includes: scientific,
decimal, engineering, architectural and fractional notation. To enter
architectural feet and inches format, you can indicate feet using the
prime symbol ("), for example, 72'3. You do not need to specify
inches by entering quotation marks (").You can set the unit type and
precision in the Quick Setup wizard, the Advanced Setup wizard, or
the Units Control dialog box. These settings control how your
coordinate, offset, and distance entries are interpreted, and how
coordinates and distances are displayed.

To open drawing units dialog:  Format > Units Command ling >
UNITS

5.1.2.  Set Angle Conventions

You can specify the location for angle 0 and the positive direction for the angle measurement: clockwise or counterclockwise.

You can also specify the format and the number of decimal fraction.

(

Length Angle
Type: Type:
’Decimal v] ’Decimal Degrees v]
Precision: Precision:
(0.0000 ~] [o ~|
[ Clockwise
Insertion scale
Units to scale inserted content:
Inches v]
Sample Output
1.5000, 2.0039, 0.0000
3.0000<45, 0.0000
Lighting
Unite for specifying the intensity of lighting:
[Intemational hd
OK | [ Cancel | [ Diection.. | [ Hel

-Specify the measurement unit and precision: The units include grad, radian,

surveyor's unit and degree, minute and second.

-Specify where the angle measurement starts from: east, west, south, north or
others. For example, to enter a coordinate relative to the current coordinate for a
property ling that is 54 feet, 7 inches long with a bearing of 60 degrees north,

12 minutes, 6 seconds east, enter @54'7"<n60d12'6"e.

-Specify the positive direction: counterclockwise or clockwise. The angle 0 can

be set to any location.

"5 Direction contml‘ M‘I

Base Angle
(@ East

() North
() West
() South
() Other

I

0
50
180
270
Pick / Type

[ ok ][ cancel
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51.3.  Setting Scale Factors Standard scale ratios and equivalent text heights

Instead of drawing to a particular scale, you draw everything full size in the Scale Scale factor  Text height
program. When you print your drawing, you can assign the scale at which 116" = 1-0" 192 24"
the drawing is to print. Scale, however, does affect the way a few elements | /g = 1.q¢ 96 1o
such as text, arrows, or linetypes print in your drawing. For example, when 316" = 10 - 0
you draw text, you need to determine the text size so that when you print it
later at a particular scale, the text height is correct. 174 =1-0" 48 6"
3/8" = 1-0" 32 4
After you determine the eventual scale of your finished drawing, you can 12" = 1 24 g
calculate the scale factor for the drawing as a ratio of one drawing unit to
the actual scale unit represented by each drawing unit. Yo =110 16 2!
1" =1-0" 12 1.5"
The following table shows some standard architectural and engineering 112" = 10 8 "
scale ratios and equivalent text heights required to create text that measures
1/8 inch high when you print the drawing at the specified scale. S 4 05"
1" =10 120 15"
You can use these scale factors to predetermine the size of your drawing to 1 — o 240 30"
make sure that it fits on a specific size paper when you print it. You control
the size of your drawing by the drawing limits. To calculate the drawing =< e @
limits to match the size of your paper, multiply the dimensions of your 1" = 40' 480 60"
paper size by your scale factor. 1 = 50 600 750
1" = 60’ 720 90"
1" = 100" 1200 150"

5.2, Drawing Limits

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make
sure that you do not create a drawing larger than can fit on a specific sheet of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper
measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x
96), which allows a 1-inch margin around the edges of the

[Fed Tools Draw Dimension Modify Window Help

4 H & Layer..
prlnted Image L= ta:eritata;ManagEr..
Layer tools
@ Color.
To set the drawing limits: ~ Format > Drawing limits e
Command line > LIMITS
B¢ Text Styl
&, Dimension Style...
Plot Style...
-Choose Format > Drawing Limits D v o\ Model {Layout {Loyou2
. . . ’ Sa ommang. G
-Specify the x-coordinate and y-coordinate of the upper right & i i oot ok spoce ks
&/ Thickness pecify lower left comer or [ON/OFF]<0.0000.0.0000:: 34
drawing limit and the lower left drawing limit. You can also click o o o A0
. . L . , . I Rename... peciy upper ight comer <420.0000.237.0000>: 96 L
Select to specify the drawing limits by selecting points in the 19447541, 1154 8542, 0 snar oro (TSN
drawing.
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5.3. Grid and Grid Snap

The grid is a rectangular pattern comprised of minor

and major lines extended over the drawing area.

Displaying grids and using grids snap improve the

performance of regenerating. When you tum Snap

mode on, the cursor adheres or snaps to the invisible

grids. Grid and snap settings are effective tools to use

in your drawing to ensure accuracy. In addition, the

cursor can be restricted to move orthogonally only or

Layoutl /Layout2

guides can display on the screen automatically at

specified polar angle increments. e —

Settings.
z OsaP | oTRACK o | MopEL

5.3.1. Change Grid and Snap Spacing

You can turn Grid and Snap on and off and specify their spacing
on the Snap and Grid tab at the Drafting Settings dialog box. Grid
spacing does not have to match snap spacing. A wide grid
spacing can be used as a reference while a closer grid spacing
helps you specify points accurately.

v

L.

Model  ayoutl | Layout2

On
Off

x
n

Command: RECOVER
Command: UNTTS Settings.. |

Uselcon

5.4. Use Object Snaps

Object snaps enable you to quickly select exact geometric points on
existing entities without having to know the exact coordinates of those
points. With object snaps, you can select the endpoint of a line or arc, the
center point of a circle, the intersection of any two entities, or any other
geometrically significant position. You can also use object snaps to draw

entities that are tangent or perpendicular to an existing entity.

[ — ol
5 Drafting Settings u
Snap and GFRid | FPolar Tracking I Object Snap | Dynamic Input I Magnifier I Symmetr| * | * I

Snap spacing Grid style

Display dotted grid in:

i 05
Snap X spacing [ 2D model space
Snap Y spacing: 05 [ Black editor
[ Sheet Aayout
Equal X and Y spacing
Girid spacing
Snap type Grid X spacing: 05
@ Grid snap Grid Y spacing 0.5
(@ Rectangular snap Major line every: 5 =
(© Isometric snap Grid behavior
Adaptive grid
[ Allow subdivision below grid

spacing
Display grid beyond Limits
[ Follow Dymamic UCS

oK Cancel Help

B
e s v

ayoutl / Layout2

SNAP GRID ORTHO POLAR [eiyiVi gy ejiblaey LWEIGHT [
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5.4.1.  Setting Object Snaps

You can set object snaps using any of the following methods:

-Choose Tools > Drafting Settings > Object Snap, and then click
one of the object snap tools.

-On the Object Snap toolbar, click one of the object snap tools.
-On the status bar, right-click on the Object Snap button to choose
Settings.

-Press and hold down the Shift key while right clicking anywhere

within the drawing window to display the object snap shortcut menu,

and then choose the object snap you want to set.

5 Drafting Settings.

‘ Snap and GRid | Palar Tlackmgl Object Snap I Dynamic Input | Magnifier | Symmet| * | "

[~ Object Snap On {F3)
Object Snap modes

Object Snap Tracking On (F11)

O Endpoint o [Paralel Select Al
iy [ Midpaint (=) [ Insertion
O [V Center b [ClPempendicular

[] Geametric Center 75 [ Tangent

% [[Node = [ Nearest

¢ [l Quadrant B [l Apparert intersection

> Intersection o3¢ [ Distance from Endpeint 100

= [ | Edension -x- [[|Divide  Segments 3

1) Totrack from an Osnap point, pause over the poirt while in a
5  command. Atracking vector appears when you move the cursor. To
stop tracking, pause over the point again

oK Cancel Help

o

Additionally, you can find an option called Distance from Endpoint. This option allows snap a certain distance from any
endpoint of objects like line, arc, spline, pline, ellipse arc, mline and any other lines. As long as you pass the cursor over an
object from its endpoints, you will see a green snap point at accurate distance.

@40
NN W 815,
jiass \\\\ \\\\\ \\* \\ NN \ \\\\\\\ N |
s 50mm distance from endpoint i i \\ i/// / }
o o) x /// {
s} Qd .
a AH

Another option called Divide Segments allows snap the divided segment points of objects like line, arc, spline, pling, ellipse

arc, mling and any other lines. Before, if you want to find the divide point, first you need to generate the divided points object,

then snap those points to draw. Now as long as you pass the cursor over an object mentioned above, you will see a green snap

point at accurate distance.
- +— /‘,—\ — - —

5.4.2.  AutoSnap Tools

The automatic snap tool is a visual aid tool for snapping that help
you see and use object snaps more efficiently. When any object
snap is on, the system displays a marker and a tooltip when you
MOVe your cursor on over a snap point. AutoSnap turns on
automatically when an object snap is on. By default, AutoSnap
marker, tooltip and magnet are on. You can change the settings of

<<Unnamed Profile>>

&) Current drawing.
—
[ Fie | Display | Open and Save | Plot and Publish | User Preferences ||} D@ § Selection set | Profiles | Cloud storage |+ [ *

Curent profie: Drawing1.dwg

“AfoSnap Sehngs AutoTrack Settings

Marker
Magnet
Display AutoSnap tooltip

7] Display AutoSnap aperture bax

‘AutoSnap Marker Size

a {I

Object Snap Options
lonore hatch obiects
[ 1gnors dimension extension lines

(] Beplace Z value with current elevation

Display polar tracking vector
Display full-screen tracking vector
Display Auto Track tookip

Alignmert Poirt Acquistion
1@ Agtomatic
©) Shift o acquire

Aperture Size

ok ][ Cconcel Poply

b |
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AutoSnap on the Options dialog box. AutoSnap consists of the following snap tools:

-Marker. The object snap location is displayed when the cursor moves over or near an object. Marker shape is determined by
the snap it is marking.

-Tooltip. Indicates which part of the object you are snapping to in a flag at the cursor location.
-Magnet. Attracts and locks the cursor onto the nearest detected snap points.

-Aperture box. Surrounds the crosshairs and defines an area within which, when you move the cursor, system evaluates objects
for object snaps. You can determine the aperture box is displayed or not, and the aperture box size can be changed too.

JCCTEl Draw Text Dimension Modify Windol

5.5. Use Polar Tracking and Object Snap Tracking puressie X
v Command Line CTRL+9
Clean Screen CTRL+0

8¢ Spell Check

Auto tracking includes polar tracking and object snap tracking. You can turn themonand off by 5 en
repressing POLAR and OTRACK buttons on the Status Bar. When the polar tracking mode is on, o e .

Isolation >

the cursor moves along the specified angle. When the object snap tracking is on, the cursor o '
moves along an alignment path based on the snap point. e }
% Data Extraction...

55.1.  Polar Tracking o e

e :
Guides display on the screen automatically at the polar angle increment that you specify when - s D
polar tracking is turned on. For example, if you draw a line with angle increment set as 65 [ orftng setings.. ]
degrees with polar tracking turned on, the rubber-banding line displays at 65 degree S .
increments. o ’
To enable polar tracking and specify the polar angle increment:
1.Do one of the following:-Choose Tools > Drafting Settings from the main menu.
-On the Object Snap toolbar, click the Object Snap Settings button. e ==
~Type DSETTINGS in the command line and then press Enter. e
2.Switch to the Polar Tracking tab. R i
3.Select the Polar Tracking On checkbox. v C—

New
= Polar Angle mezsurement

x - © Absolte

4.Do one of the following to specify the
polar angle increments: [« CTFETVETT [
-Select an angle from the Increment Angle
drop-down list.

-Mark the Additional Angles check box and click New to define a custom angle
increment.
5.Click OK.

Remark: To toggle polar tracking on and off at any time, click the Polar Tracking button on the status bar or press F10.
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To draw objects using polar tracking:

-Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or LINE

You can also use polar tracking with editing commands, such as COPY and MOVE.
-As you move your cursor to specify points, notice the dotted polar tracking line that /
appears at the tracking angles you specified. Points you specify while the line is
displayed conform to the polar tracking angle.
ou2 |

AP GRID ORTHO [elWiyeiniEvl OTRACK LWT e

M(

5.5.2.  Object Snap Tracking

Object snap tracking can track along alignment paths that are based on object snap points and display tooltips at the acquired
points. After you acquire a point, horizontal, vertical and polar alignment paths relative to the point are displayed when the
cursor moves over their drawing path. For example, you can specify a point along a path that is based on an object endpoint or
midpoint or an intersection between objects.

You can also use system variable TRACKPATH to control the display of polar and object snap tracking alignment paths.

pain
Endpoint: 46.3636 < 0°

5.6. Use Orthogonal (Ortho Mode)

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or
orthogonally. For example, when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180
degrees, or 270 degrees. As you draw lines, the rubber banding line follows either the horizontal or vertical axis, depending on
which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to
orthogonal equivalents within the current isometric plane. Ortho mode and polar tracking cannot be on at the same time.
Turning on Ortho turns off polar tracking.

To fast enable orthogonal drawing:
[Specify et point._ &[T |[<0° |

-Press F8 or press the ORTO button at the status bar g
SNAP  GRID [gelyigle] OSNAP ] OTRACK DYN ] MODEL -
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5.7. Working with Linetypes

A'linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. You can assign linetypes to
objects by layer, or by specifying the linetype explicitly. And also, you can specify its scale, I

) ) ) i ] @ 03 QIREH -
load more linetypes into the program from a linetype library file, and create your own = Bayer -

custom linetypes.

Bylayer

ByBlock

Continuous

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and e e
BYBLOCK. You cannot rename or delete these linetypes.

————— FENCELINEL

Mare...

Remark: You should not confuse these linetypes with the hardware linetypes provided by
some plotters. Both linetypes of dashes produce the similar effects. However, if you use
both linetypes at the same time, the results can be unpredictable.

5.71.  Load Linetypes

GstarCAD includes the linetype definition files gcad.lin and gcadiso.lin. If you select geadiso.lin, you can use 1SO pen-width
option when you plot.If you want to know what linetypes are already available, you can display a list of linetypes that are loaded
in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files contain several complex linetypes.

= B ™
5 Linetype Manager 5 Load or Reload Lin M
IrepetEe . Load Delete File. b cadin]
Sh 1l - Invert fitter
R ] g -
Available Linetypes
Current linetype:  Bylayer —
Linetype Description |;
Linetype Appearance Description BANKLINET |E ‘
i Bylayer —_———— BAMNKLINEZ Stone Bank Ao_o_o_o_o_o_o_o_o_.
ByBlock —_— BANKLINEZ Stone Bank B-000Q000000 .
Continuous ——— Continuous BANKLINE4 Gravel Bank _o._o._o._0._0._0._..
PHANTOMZ —--—--———--— Phantom (%) __ ____ ___ ___ BANKLINES Sand Bank _." 7 _ S
BANKLINES Grass Bank
BANKLINEY S
i BAMKLINES . I
Details BANKLINES FERERERRLErrennnnnntl
Global scale factor:  1.0000 BATTING Baiting 53555555555555555555...
Cument ghject scale:  1.0000 BORDER Border _ . _ . __ ._ _ -
BORDER2 Border (&) . B
Use paper space units for scaling 1.00 Millimeters
0K Cangel Hel
oKk | [ cCencel | [ Hep [ J | N e

age  Export  Help

5.7.2.  Change the Linetype of an Object D T AN e e
w e | HaBsPaE TextLnear et oy | ST ]
You can change the linetype of an object by changing the — oo
linetype of the layer the object is on, reassigning the object to P
another layer, or by specifying a linetype for the object e o -7

directly.
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5.7.3.  Set the Current Linetype
C.I) MR Ar_.l gq @ B
Hh»g'xg o Mh{:fi*m’*—
By default, all objects are created using the current linetype, - O - — e ———

which is displayed in the Linetype Control on the Properties i i
toolbar. To modify this current linetype, you can select a linetype

and make it current in the Linetype Manager dialog box. If the
current linetype is BYLAYER, objects are created using the
linetype assigned to the current layer.

Lnewegt
Hypednk
Thckness

If the current linetype is BYBLOCK, objects are created using CONTINOUS linetype until they are grouped into a block. When
you insert the block, it acquires the current linetype setting.

To make the linetype current;
Select a linetype from the Linetype Control pull-down list on the Properties toolbar, which is set to the current linetype.
5.7.4.  Control Linetype Scale

You can set global or individual scales for objects to control the display of linetypes. The Global Scale Factor and Current
Object Scale are displayed in the Linetype Manager. The Global Scale Factor value is stored in the system variable LTSCALE,
which changes the linetype scale globally for new and existing objects.

The Current Object Scale is stored in the system |G Linetype Manager

variable CELTSCALE, which specifies the [thuTh:p S e
linetype scale for new objects. In a layout, you Comtiveme: S
can use system variable PSLTSCALE to adjust — p— —
the linetype scale in different viewports. ::::;

Continuous ————— Continuous
Remark: Setting the linetype scale too large or o i
too small may result in a line pattern looking like _
a solid line, depending on what the scale view is D;En": Giobal secle factor. 1.0
or at what scale the drawing is printed. Deserption Curent ghject seale:  1.0000

[7] Use paper space unts for scaling 150 pen width 1.00 Milimeters

0K | [ cancel | [ Hep

To set the current individual linetype scale:
Format > Linetype Command line > LINETYPE

-Choose Format > Linetype -Click the Show Details button.-In the Current Object Scale field, type the linetype scale that you
want to make current.-Click OK.

To change the global linetype scale:  -Choose Format > Linetype-Click the Show Details button.-In the Global Scale Factor
field, type the global linetype scale that you want to change. Then click OK button.
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5.8. Working with Layers

Layer Properties Manager —
ama snxv
] ] » jm - on :,.:. L:-a Color Limetype Lineweight  Plot Style g r-rwv-—-:m—.g" Descrption
Layers are like the transparent overlays you use in manual Al g B
T o\ =1 2
drafting. You use layers to organize different types of drawing o ¢ 3
o RefE & e 7]
information. Each object in a drawing exists on a layer. When
you draw an object, it is created on the current layer. = —
v 4 Shows 8layens. total §layers [ ok ]| coxe Aooly. Help

5.8.1.  Create and Name Layers

You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you
create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype
CONTINUQUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype,
visibility, and other properties.

To create a new layer:  Format > Layer Command line > LAYER

-Choose Format > Layer-Click the New Layer button.
-Type a name for the new layer and then click OK.

To change a layer name in the current drawing:

-Choose Format > Layer -In the Layer Properties Manager dialog box, click the name of layer you want to change.
-Type a new name and click OK button.

5.8.2.  Setting the Current Layer

Layer Properties Manager [r——
Curent layer: HIDE
S8R G > 5 X

When you start a drawing, objects are created >|[Smm 1 = o Free Lg Cor_Lniope Lnewot Pt Sfe Pt New vewpaners_Desorton
P= | g X ' EW. Contru.. — Defaut Co (=] ]
in the current layer. By default, the layer 0 is Z R 2 S Rmevm el B
7 = El
set to the current layer, but you can also create e i & P W et a \
s IR s &
a new one and make it current. Any subsequent TSR R . %
objects you create are associated with the
»
current layer and use its color and linetype. 2 somtommatos T | o | |

To make a layer current:

-Choose Format > Layer -In the Layer Properties Manager dialog box, select a layer and then click the Set Gurrent button to
make the layer current.-Click OK.

5.8.3.  Removing Layers

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer Properties Manager.
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5.8.4.  Controlling Layer Visibility

A layer can be visible or invisible. Objects on invisible
layers are not displayed and do not print. By controlling
layer visibility, you can turn off unnecessary information.

To turn layers on or off:  Format > Layer
Command ling > LAYER

-Choose Format > Layer
-Click the icon under "On" tab in the layer list.
-Click OK button.

5.8.5.  Locking and Unlocking Layers

Locking a layer prevents you from accidentally
modifying its objects. You cannot edit a layer when it is
locked (but visible and thawed). If you lock the current
layer, you can still add new objects to it. You can also
change the linetype and color associated with a locked
layer. Unlocking a layer restores full editing
capabilities.

To lock or unlock layers:  Format > Layer
Command line > LAYER

-Choose Format > Layer from the main menu.
-Click the icon under "Lock" tab in the layer list.
-Click OK button.

5.8.6.  Controlling Layer Printing

Controlling layer printing is another way you can
specify which objects print in your drawing. By
controlling layer printing, you can turn off unnecessary
information during printing. When you turn off printing
for a layer, objects drawn on that layer are still visible,
but they do not print.

-

Layer Properties Manager &

Current layer: LINES
£ B H &> X

»

»

‘PREEEED

Status NameIOn AIFreeze Lock Color Linetype Lineweight Plot Style
X W Coes == Defautt Color 7

}w
Default

% " WMW. HIDDEN2 — Defaut
& @' EW. Continu.. — Defaut
& @' MW. Continu.. — Defaut
n o
{

' [ 82 HIDDEN2 — Default Color_|

IDOQOVO® F

(=

All: Shows 8 layers, total 8 layers

Layer Properties Manager p

Current layer: LINES

B 6% &> 5% X

» || Status Name On Freeze | Lock . | Color Linetype Lineweight Plot Style Plot New viewport freeze De
s 3 % Ba— - B
<7 CENT v ke @), | Locks or unlocks layer globally for entire drawing =
o Defpo.. b G o= ]
~Z  HIDE 0 o @ B W._ HIDDEN2 — Defaut Color 7 @ 3
o layerl ) o 3 G B W.Continu.. — Defaut Color 7 & o
7 layer2 ) Eed @ B W.Continu.. — Defauk Colr 7 @ )
7 REFE ¢ O Gl 82 HIDDEN2 — Defaut Colr 82 & o)

L] . = )
»

S>> Al Shows 8 layers, total 8 layers

[ Layer Properties Manager 4

Current layer: LINES
SR G > X

EEEREE

»

> || Status Name On

0 o
CENT. o
Defpo ol
HIDE £
Layer 1 o3
Layer2 o3

Lk

o

Froes lock a Coor Lnetpe Liewsoht Pt Sie| Pt | New viewpot foeze Descrotion

B W. Continu.. — Defauk Color_ a
M 152CENTER — Defauk Color_152  § PIOF

B W, Contins.. — Defouk Color 7 Determines if layer is plottable or not for entire drawing
W W.. HIDDEN2 — Defaut Color_7 2

B W.Continu... — Defauk Color_7 ]

W W. Continu... — Defauk Color_7 2
[l 82 HIDDEN2 — Defaut Color_8 -

E~ Al Shows 8layers. total 8layers

To turn layer printing on or off: ~ Format > Layer Command line > LAYER

-Choose Format > Layer

-Click the icon under "Plot" tab in the layer list.

-Click OK button.
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5.8.7.  Setting a Layer's Print Style

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print
styles that you set up to control what objects look like when they print, without actually changing the objects in the drawing. If
your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style
tables automatically determine printing requirements by the color assigned to a layer or an object.

To change the print style assigned to one or more layers (only in a drawing that uses named print style tables):

Format > Layer Command line > LAYER =
Color Linetype Lineweight Plot Style & | Plot New viewportfr.. Description
_Choose Format > Layer M White  Continuous D:faun Calor_7 Plot Style: N
i . i E72 Continuous Defautt Color_72 Changes plot style for entire drawing
-Click the name of Plot Style in the layer list to open Select Plot 4D Cortmuoue T e =
W10 Continuous Defautt  Color_10 =] =)

Style dialog box, from which, you can specify the desired plot style.
-Click OK button.

5.8.8.  Freeze or Thaw Layers

You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or
shaded images. When a layer is frozen, objects drawn on that layer are no longer visible.

To freeze or thaw layers:  Format > Layer Command line > LAYER

-Choose Format > Layer
-Click the icon under "Freeze" tab in the layer list.
-Click OK button.

Layer Properties Manager
-

Current layer: LINES

B4 &y 453 XV
» || Status Name On Freeze | Lock a Color Linetype Lineweight Plot Style Plot  New viewpol
= 9 - H Freeze: - m—— = @ E‘j
Z m : g Freezes or Thaws la.)fegloa.uy for e| drn~g i g S
7 HIDE J Eed W W.. HIDDEN2 — Defautt Color_7 [=] o)
7 Llayerl J o3 B W..Continu.. — Defauk Color 7 @ 2
W.. Continu... — Defaut = )
M 82 HIDDEN2 — Defaut Color 82 (& o)
I W.. Continu... — Defautt Color_7 [v] )

5.8.9.  Setting the Layer Color

[ Select Color w

Layer Properties Manager

Each layer in a drawing is assigned a color. Curet layer: Layer 1
GstarCAD uses the BYLAYER color as the default o 2
color setting for object creation so that new o : -
\ \ &7 Defpo £ 3 i
objects are drawn in the color of the layer on ~  HE B \
which they are inserted. * !
Q

»

| @~ Al: Shows 8layers, total 8 layers
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To change the layer color;  Format > Layer ~ Command line > LAYER
-Choose Format > Layer

-Click the icon under "Color" tab in the layer list to open Select Color dialog box, from which, you can specify the desired color
through index, true and color books tabs—Then click OK button.

5.8.10. Setting a Layer's Linetype

Each layer uses a default linetype. Linetype determines the appearance of objects both on the screen and when printed. It's
recommendable to assign the BYLAYER linetype to any objects that you draw on that layer.

To change the linetype assigned to one or more

Layer Properties Manager

layers: Format > Layer ~ Command line > [
SR &% XV — "
> atus ze a
A R = |
r=4 CENT. o’ &) W 152CENTER
<7 Defpo o3 G  EW. Continuous Linctype Appearance Descrption
27 HIDE o @)’  EW. HIDDEN2 e T ——— Corter________| \
-Choose Format > Layer Ltz O y— E— i'
H . . . &7 REFE ol " me2wopEN2 | 0 TTTTTT
-Click the Linetype name in the layer list to open o unes - TR
Select Linetype dialog box, from which, you can ——— =
» ————— =

specify the desired linetype. -Click OK button.

5.8.11. Setting a Layer's Lineweight

Each layer uses a default lineweight. Lineweights determine the thickness of objects : jﬂewm:
both on the screen and when printed. All new layers are assigned the DEFAULT T —
) ) o . ) ) ) ) Lineweight | P 005 )
lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight =i o ‘ |
assigned to a layer, you can easily change it using Layer Properties Manager. e p.ismm
" on o v
. . N — Defautt Coll 0.30 mm
To change the lineweight assigned to one or more layers:  Format > Layer — Defaut Co Z
. riginal: efaul
Command line > LAYER R
[ ok ][ coneal | [ nHep

-Choose Format > Layer
-Click the Lineweight name in the layer list to open Lineweight dialog box, from which, you can specify the desired lineweight.
-Click OK button.

5.8.12.  LAYULKALL

If you have a lot of layers locked and " rere e e i:z;ode“‘;hﬁmle?"_“_vf"'v —_—
need to unlock them all in you drawing, L/ P—MD Q AF O~ F_Eome«.issvetchi}wwrorf’; 4~ =8 << <ss:c=
you can input LAYULKALL command to AR i R LI 'F:; B

unlock all  the locked layers @ wvukauaws |?§5§§‘ s
immediately. | ‘ = qmuw
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5.9. Displaying Lineweights

Lineweights are displayed differently in paper space layout than model space. Lineweights are useful for graphical
representations of different objects and information.

5.9.1.  Display Lineweights in Model Space T ——
b;: M Byl ayer .
—
In model space, a 0-value lineweight is displayed as a B -
pixel, and other lineweights are display with a pixel width = y
proportional to their real-unit value. In model space, e
lineweight display does not change with the zoom factor. e
A lineweight value that is represented by a width of oy
several pixels is always displayed using the same 5
number of pixels. In model space, press LWT button on =

the status toolbar to turn lineweight display on and off. i s

Area 22265768

€4 b W \Model {Layoutl / Layout2

N oo [ o Lo Lo oo R

5.9.2.  Display Lineweights in Layouts

In paper space (layout tab), lineweights are displayed in exact plotting width. In plot preview and paper space, lineweights are
displayed in real-world units, and lineweight changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you
can control the lineweight plotting and scaling in a drawing. In paper space, press LWT button on the status toolbar to turn
lineweight display on and off. This change does not affect the lineweight plotting.

Properties 2 % |4 Drawingl.dwg = sample.dwg x

,,,,,,,,,,,,,,,,,,

General - r 1
Color M ByLayer ‘ ‘
Layer Lines
Linetype: — ByLayer | |
Linetype scale |7
Plot Sty BYCOLOR ‘ [
[l —o20mn [ [ |
Hootik | ga\uck
Thickness | Defaut | |

0.0

3D Visuslization ;oo 0 | [

Materals — 003 mm
—013mm

Geometry —0.15mm | |
Start X —0.18mm
Stan Y oo ‘ ‘
StanZ g | |

—0.35mm
Carag —0.40mm
Certer Y = 0.50mm | |
ceiwz  Zoam
EndX =070 mm | |
0.80

En =050 | |
EndZ -1 00mm
S | |
Statange  EE140mm
Edave  mmoonmm \ |
Total angle 211 mm
Aclengh | 1445314 L - - - - - - - - - - - - — = -
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5.10.  Spell Command

Users can check the spelling of all text as it is entered in your drawing with Spell command. Users can also specify the specific
language dictionary that is used and customize and manage multiple custom spelling dictionaries.

Check Spelling =)
Display the areas you want checked for spelling(yw)
Current custom dictionary(M)
(Engish v) [ seungm
Not in dictionary(N) Start(S
Proffessional e
AddtoD D)
uggestior ]
Prtesons | —m—
[Pofessional |
ChangelC) |
ChangeAlL) |
Close@ | | Help(H) ]

[
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6. Create Objects

Drawings are made up of objects. In general, you draw objects by specifying points with the pointing device or by entering
coordinate values at the command prompt.

6.1. Draw Linear Objects

6.1.1.  Lines

A'line consists of two points: a start point and an endpoint. You can connect a series of lines, but each line segment is
considered a separate line object. To draw a line:  Draw > Line Command line > LINE

1.Choose Draw > Line from the main menu. Point
2.Specify the start point. T
3.Complete the first line segment by specifying the endpoint. Y point
4 Press Enter to complete the command. "
X
To start a new line at the endpoint of the last line drawn, start the Ling 575, oy ooseomer 10
command again and press Enter directly at the "Specify first point:" m;,iiNE
prompt ? BN ORIl PoLsR | oshap | OTRACK o | mc
6.1.2.  Multilines

Multilines consist of several parallel lines, called elements.

You can determine the position of elements by specifying offset from the origin of each element. By default, multiline objects
contain two elements. You can create and save new multiline styles by yourself or modify existing mline styles.

To draw a multi-line: Draw > Multiline Command line > MLINE

1.Choose Draw > Multiline from the main menu.

2.Specify the start point.
H 1 £
3.Specify the endpoint. i« » ¥ \Model {Layoutl /Layou2 /
pecify start point or [Justification/Scale/STyle]:
4.Press Enter to complete the command. pociy nat poit:
pecify next point or [Undo]:
= |Specify next point or [Close/Undo]:
(< M“""‘”_‘ -528.9422, -129.3366, 0 sNAP  GRID ORTHO PoLAR [EENTSN
Currert Mutine Style:  STANDARD
Styles
Set Curert
5 New Multiline Styles:N
New .
Description: NEW STYLE|
Moy
Caps Elemerts
Rename gz Ed Offset Color Linetyoe
L B g 0500 BYLAYER  Bylayer
Delete Outer are: = B 05 BYLAYER ByLayer
Descrption: — A -
Fil
Preview: STANDARD ! et 2000
Color: MEyLayer
Display joints: B Linetypes: Linetype...
[ o [ coed | [ oo [ox ] [comea | [ o |

58



Chapter 6 Create Objects

6.1.3. Rays
Aray is a line in three dimensional space that starts at a point e
. . . . e
and extends to infinity. Because rays extend to infinity, they . DM/‘ o
are not calculated as part of the drawing extents. The default A —
. . . s === -
method for drawing a ray is to select the start point of the ray ~ —— o
and then specify its direction. | S ———
e 1:‘“‘::.;“ ;;?;splacemem,
pecify start point:
TO dl'aW d ray 114|, o UG RCT l poLar | osnap | oTRack D¥N | MODEL -
Draw > Ray Command line > RAY
1.Choose Draw > Ray from the main menu.
2.Specify the start point and the direction.
3.Press Enter to complete the command.
6.1.4.  Construction Lines
A construction line is a ling through a given point, oriented at a specified .
angle in three dimensional space and extending to infinity in both directions. :
You can also draw a construction line at a specific angle or at an angle _
: Endpoint: 6.4744 « 270°
relative to an existing object. N T S
To draw a construction line:  Draw > Construction Line Command ;
X
||ne > XLlNE W4 b #Model \:ayouﬂ Layout2
# Command: *Cancel*
B Command: *Cancel*
1.Choose Draw > Construction Line from the main menu. ormand. Coned
Command: “Cancel®
ZSpeCIfy a pOInt along the |Ine g::?ﬁl:p:ﬂ;f[HurNer/Ang/Ewsect/Oﬂset].H
. N . pecify through point:
3.Specify the direction. oty
4 Press Enter to complete the command. 114511 25, 0 EEETY oo osne | o

6.1.5.  Polylines

A polyline is a single object with connected sequence of line segments or/and arc
segments.When you draw a polyline, you can switch to different options. After you draw

.
more than one segment, you can close the polyline, undo or finish. i +

[Specify next point or_|[1] ][-58.3546

pey

4 4 » n Model /£ Layoutl 4 Layout2

To draw a polyline with straight segments: Draw > Polyline Command line >

BSpeciy start point

PLINE s Curent line-width is 0.0000
Speciy next point ar [Arc/Halfwidih/Length/Undo/Widih:
‘Speciy next point or [Arc/Closs/Halfwicth/Length/ Undo,Width]:
‘Speciy net point ar [Arc/Clase/Halfwicth,/Length/Undo/Width]:
‘Speciy next point ar [Arc/Close/Hawicth, Length/ Undo/Width]:
'Speciy next point or [Arc/Close/Halfwicth/Length/ Undo/Width -

1.Choose Draw > Polyline from the main menu. pp—— —
2.Specify the start point.
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3.Specify the endpoint of each segment.
4 Press Enter to end, or enter ¢ (close) to close the polyline.

To draw a line and arc combination polyline:
Draw > Polyline Command line > PLINE

1.Choose Draw > Polyline from the main menu.
2.Specify the start point.

3.Specify the endpoint.

4 At the command prompt, choose Arc.
5.Specify the endpoint of the arc segment.

6.To complete the command, Press ENTER.

To create closed polylines: Draw > Polyline Command line > PLINE

L
li#»_-

X

W < » " Model {Layoutl /Layout2

& [Specfy next pairt or [Arc/Close/ Halfwidth,/Lengih,/Undo /Width]
| [Speciy next pairt or [Arc/Close/Halfwidth/Length /Undo/Widih]

{Speciy next point or [Arc/Close/Haffwidih/Length/Undo/Width]: A

{Speciy endpaint of arc or
[Angle/CEnter/CLose/Direction/Haffwidth/Line/Radius/Second pt/Undo/Width]:
ISpecty sndpaint of arc or

< /Direction/ Haffwidth/Line/Radius/ Secand pt/Undo/Widthl:

GRID el el POLAR [eiyiH

When creating polylines with PLINE command, the Close option is only available if no less than two line or arc segments are
drawn. A closed polyline object is drawn if you connect the start point of the polyline to endpoint of the last line or arc segment

with a line or arc.

LWPalyline
Color Bylayer
Layer O

Linetype Bylayer

M4 4 » b 4 Model {Layoutl / Layout2

[Specify endpoirt of arc or

| K

(Specify endpoirt of arc or

[Specify next point or [Arc/Close/Halfwidth./Length,/Undo/Width]:
[Specify next point or [Arc/Close/Halfwidth./Length,/Undo/Width]): CLOSE

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo,/Width):

[Angle/CEnter/CLose/Direction/Halfwidth./Line /Radius./Second pt/Undo/Width]: LINE

Command:

[FIDAN ORTHO [Ze]RGEN OSHAP

To create wide polylines: Draw > Polyline Command line > PLINE

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE command. The Width and
Halfwidth options set the width of the next polyline segments you draw. You can set the width of individual segments and make

them taper gradually from one width to another.

o ssn

4 4 » M " Model £ Layoutl ; Layout2

K |Specify ending width <0.3000>:

(Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]
(Specify next point or [Arc/Close/Haffwidth//Length/Undo/Width].
ISpecify next point or [Arc/Close./Haffwidth,/Length/Undo,Width]
(Specify next point or [Arc/Close./Haffwidth/Length/Undo,/Width]
{Specify next point or [Arc/Close./Halfwidth./Length/Undo/Width]:

ISpecty next poirt or [Arc/Close.Haffwidth/Length/Undo/Width]

115 579,0 SNAP  GRID

ORTHO P
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To draw a boundary polyline: Draw >Boundary Command line > BOUNDARY

| ,

Pick Points

1.Choose Draw > Boundary from the main menu.
2.Specify the objects by doing one of the following:

Island detection

. . . Boundary retention
-Current viewport Define a boundary set with all e b
entities in the current viewport. if this option is Object type:
selected, any boundary set currently used will be Boundary set
canceled. =

[ ok ][ cameal |[ Hep |

-Existing set Click New button to switch to the drawing area, and prompt users to
select objects for defining boundary sets. Press Enter to return to the dialog box after selection. This option is only available
after selecting objects by using the New button.

3.Select the Island Detection option.

4 Click Pick Points.

5.In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired,
continue clicking inside additional closed perimeters.

6.To complete the selection, press Enter.

7.In the Boundary Creation dialog box, click OK.

v R R v : | tweolyline
| — l——r Color Bylayer
(B Layer 0
Linetype Bylayer
> >
M 4 b v Model / Layoutl f Layout? M 4 » ¥ s Model £ Layoutl A Layout2
¥ |Pick intemal paint: Selecting all objects... % |Analyzing the selected data... Emor analyzing intemal islands
B |Selecting everything visible ... 1 [Fick intemal point
IAnalyzing the selected data BOUNDARY created 1 polylines.
\Analyzing the selected data...Emor analyzing intemal islands Command
Pick intemal point: Command

11559.7166, 1350.4103, 0 SNAP  GRID ORTHO

11561.1469, 1351.7565, 0 SMAP  GRID ORTHO P

6.1.6.  Polygons

Creating polygons is a simple way to draw squares, equilateral triangles,
octagons, and so on. Polygons are closed polylines with between 3 and
1,024 equal-length sides.

To draw a polygon by vertex: Draw >Polygon Command line >
POLYGON

1.Choose Draw > Polygon from the main menu.
2.Type 6 to specify six sides for the polygon.
3.Specify the center of the polygon.

4.Specify the vertex of the polygon.

| pecify center of polygon or [Edge]:
|Enter an option [Inscribed in circle/Circumscribed about circle] <I>:1
) 3Spedfy radius of circle:
-423.689, -223.8862, 0 SNAP GRID ORTHO POLA
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6.1.7.  Rectangles

Rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite corners. The rectangle is
normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the rectangle to
any angle.

To draw a rectangle: Draw > Rectangle

Command line > RECTANG

1.Do one of the following: D
-Select Draw > Rectangle on the main menu. T»

-Click the Rectangle tool or type RECTANG command and press 0 Modal {0t Aoz ]

E n t e r 3& Specify first comer point or [Chamfer/Elevation/Fillet/Thickness/Width]: F
. v ecify fillet radius for rectangles <0.0000>: 10
ecify first comer point or [Chamfer/Elevation/Fillet/Thickness/Width]:
ecify other comer point or [Area/Dimensions/Rotation]:

-272.9449, -287.2165, 0 snap GRID  ORTHO POLAR (BRI OTRACK LW

2 Identify one corner of the rectangle or enter an option. Specify
first corner point or [Chamfer/Elevation/Fillet/Thickness/Width:

3.Identify the opposite corner of the rectangle or enter an option. Specify other comer point or [Area/Dimensions/Rotation]:

6.1.8.  Points

You can draw a point object formatted as either a single dot or as one of 19 other possible display styles.

To draw a point: Draw > Point Command line > POINT .
4

1.Choose Draw > Point > Single Point from the main menu. v 4 ﬁ%%

2.Specify the location of the point. Lﬁ -__

X

+ " Model {Layoutl Layout2

To draw several points:

mrman
mand: _POINT
odes: PDMODE=2 PDSIZE=3.0000

SNAP GRID ORTHO PolAR [EHTND

1.Choose Draw > Point > Multiple Point from the main menu.
2.Specify the location of each point.

To change the size and appearance of point objects: :ij S ?
Format > Point Style Command line > DDPTYPE kel

: O] O] Bl K] O]
1.Choose Format > Point Style from the main menu. ‘ jol Nel =10 =1jol

2.Under Point Style, select the style you want.
3.Under Point Size, specify the point size, or choose one of the options.
4 Click OK button. e s e

When you regenerate the drawing, all point objects change to reflect the new size and appearance settings.
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6.1.9.  Freehand Sketches

A freehand sketch consists of many straight line segments, created either as individual line objects or as a polyline. Before you
begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the segments, the more
accurate your sketch, but segments that are too small can greatly increase the file size.

To create a freehand sketch:

1.0n the command line, enter SKETCH and press Enter.

2.At the "Record increment" prompt, enter the minimum line segment length.

3.Move the cursor to the drawing area, then click or enter p (pen) to begin sketching.
4.Click or enter p (pen) again to lift the pen up and stop drawing, so that you can move
the cursor around the drawing area without drawing.

4 4 » b Model £ layoutl / Layout?

5.Enter R (Record) at any time to write into the drawing the line you're drawing and | R
those already drawn. ok Fon o4 32 Rar e Gt
. . . . 399 lines reconded. <Pen down>
6.Press Enter to complete the sketch and write all lines into the drawing. 7349126, 1347 9513, 0 P GRD ORTHO  POL
To erase freehand sketch lines:
1.While running the SKETCH command, enter E. If the pen was down, it moves up.
2.Move the cursor to the end of the line you drew last and then move it back as far along
the line as you want to erase. o Model {Layol ayouZ
3.To end the erasure and return to the sketch Command prompt, enter E. If you want to f,‘Ezm*::;g‘;;éé?“’[Z"”“”““”WEJ“’F””“"“”’H oo

change the current viewport while sketching, make sure the pen is up and all lines were
written into the drawing.

SNAP GRID ORTHO POLAR

6.2. Draw Curved Objects

6.21.  Arcs

An arc is a portion of a circle. There are numerous ways to define an arc, the default method uses three pick points, a start point,
asecond point and an end point. Using this method, the arc will start at the first pick point, pass through the second point and end
at the third point. Once you have mastered the default method try some others:

. 2nd
-3 points point
‘Start, Centel', End Start, Center, End
-Start, Center, Angle 1st 3rd
-Start, Center, Length poin joint
‘Start, End, Angle N /X star, End, Angle
-Start, End, Direction e
-Start, End, Radius x
'Center Stal't End M 4 » w4 Model ¢ Layoutl 4 Layout2 ‘
® Co d: _MTEDIT
-Center, Start, Angle ' [Command. ARC ﬂ
\Specify start point of arc or [Center]: {2

'Center, Stal't, Leﬂgth \Specify second point of arc or [Center/End]: <ORTHO Off > 7 = . g

C t. Speci{y ond DOIm pra— { Center, Start, Length
-vontinue -10668.9276, -560.3986, 0 SNAP GRID ORTHO POLAR e i
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To draw an arc by 3 points as sample: Draw > Arc >3 points

1.Choose Draw > Arc > 3 Points from the main menu.

2.Specify the start and second points. iter, Radius
3.Specify the endpoint.

nter, Diameter
6.2.2.  Circles

The default method for drawing a circle is to specify a center point and radius. You can draw
circles using any of following methods:

-Center, Radius

-Center, Diameter

-Concentric

-2 points

-3 points

-Tangent, Tangent, Radius

-Tangent, Tangent, Tangent

’hmhmhn

Center
point TRadius
point ___ mad

To draw a circle by specifying its center and radius:Draw > Circle> Center, Radius — E—
Command line > CIRCLE

1.Choose Draw > Circle > Center, Radius from the main menu. T Model eyl {Tojoutt
ZSpeclfy the center polnt j: SEEGSZ:;.QSufUCSnr[ZMs/Hpuim:fO&ad/FaceMew/X/Y/ﬂ 000>
3.Specify the radius of the circle. ot oo o i o i et

To draw a circle tangent to existing objects:
Draw > Circle>Tan, Tan, Radius Command line > CIRCLE

1.Choose Draw > Circle > Tan, Tan, Radius from the main menu.
2.Select the first tangent point on the object to be tangent with the circle.
3.Select the second tangent point on the object to be tangent with the circle. pecty i o object ot tangent of circke:
4.Specify the radius of the circle. e o St oo

6.2.3.  Ellipses
The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and then specify a distance
representing half the length of the second axis. The endpoints of the first axis determine the orientation of the ellipse. You can

draw ellipses using any of the following methods:

-Center  -Axis, End  -Ellipse, Arc
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To draw an ellipse by specifying the axis and endpoints; Draw > Ellipse>Axis
Command line > ELLIPSE

1.Choose Draw > Ellipse > Axis, End from the main menu.
2.Specify the first endpoint and second endpoint.3.Specify a distance for half the length
of the second axis.

To draw an elliptical arc by specifying the axis endpoints: Draw > Ellipse=Arc
Command line > ELLIPSE

1.Choose Draw > Ellipse > Arc from the main menu.
2.Specify the first endpoint.

3.Specify the second endpoint.

4 Specify the half length of the other axis.

5.Specify the start angle of the arc.

6.Specify the end angle.

6.2.4.  Splines

2nd
endpoint

1st e

endpoint

1« r n \Model {Tayoul /LayoutZ

Elselect object:

I speciy base point or [Displacement] <Displacemertt>: Speciy second point or <us
ko first point as displacement >

Command: ELLIPSE

‘Specify s endpoint of elipse or [Arc/Certer]

iSpeciy oth
2

dpoint of s
ofher axis or [Fot

GRID ORTHO FOLAR  OSN

2nd
endpoint

1st
endpoint

M 4 » W Model / Layoutl / Layout2

% lspeciy axis endpont of elipse or [Are/Center-ARC
8 ISpscify axis endpoint of sliptical arc or [Center]
ISpecity other endpoint of s

ISpeciy distance to other s or [Rotation]

‘Speciy start angls or [Parsmeter]: 15

ISpeciy end angle or [Parameter/Included angle]

CCommand:

Spline is a smooth curve that passes through a series of control points. Multiple points are required for drawing irregular
splines than can be closed as well, so the start and endpoints are coincident and tangent. The tolerance in a spline, describes
how precisely fits between multiple points (lower tolerance, more closely the spline fits the points). Usually there are two ways

to create splines:

-Create a spline converted from a polyling using Spline option of PEDIT command.
-Create a spline using SPLINE command.

To draw a spline:  Draw > Spline  Command line > SPLINE

1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.

4.Specify as many more points as you want.

5.When you have finished, press Enter.

To draw a closed spline: Draw > Spline Command line > SPLINE
1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.

4.Specify as many more points as you want.

5.When you have finished, on the command line, type C and press Enter.
6.To complete the command, specify the tangent point.

4 4 » » " Model {Layoutl / Layout2

* |Specify next poirt or [Close/Fit tolerance] <start tangerit>

4 Ispecify next poirt or [Close./Fit tolerance] <start tangert>
peciy neat point or [Close/Fit tolerancs] <start tangert>
pecify neat point or [Close/Fit tolerancs] <start tangert>
pecify neat point or [Close/Fit tolerancs] <start tangert>: C

Speciy tangent

and:

SNAP GRID ORTHO

4 4 » » “Model £ Layoutl / Layout?

Command: spine

S {Unknown command "spine”. Press F1for help.
Command: SPLINE

ISpecify first poirt or [Object]:

ISpecify next poirt:

ISpecify next point or [Close/Fit tolerance] <start tangert>
ISpecify next point or [Close/Fit tolerance] <start tangent>

-98.96 25,0 SNAP  GRID ORTHO POLAR

Specify next point or

W 4 » v " Model {Layoutl {Layout2

¥ |Specify nest paint or [Close/Fit tolerance] <start tangent>:
B ISpecy next poirt or [Close/Fit tolerance] <star tangent >:
pecfy nex point or [Close/Fit tolerance] <start tangert>:
pecify nest paint o [Close/Fit tolerance] <start tangent>:
peciy nest poirt or [Close/Fit tolerance] <start tangent >:
pecfy nexd poirt or [Close/Fit tolerance] <start tangernt>:
pecify next paint or [Close/Fit tolerance] <start tangent>:

-110.1425, 5,591, 0
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6.2.5.  Helix

Creates a 2D spiral or 3D spring. Initially, the default base radius is set to 1. During a

<=
drawing session, the default value for the base radius is always the previously entered 2 s -" -

base radius value for any solid primitive or helix. The base radius and top radius cannot
both be set to 0.

To draw a helix: Draw > Helix ~ Command line > HELIX
The following prompts are displayed: Number of tums = 3 (default)Twist = CCW (default)
1.Specify center point of base: Specify a point

2.Specify base radius or [Diameter] <1.0000>: Specify a base radius, enter d to specify the diameter, or press ENTER to
specify the default base radius value

3.Specify top radius or [Diameter] <1.0000>: Specify a top radius, enter d to specify the diameter, or press ENTER to
specify the default top radius value

4.Specify helix height or [Axis endpoint/Turns/turn Height/tWist] <1.0000>: Specify a helix height, or enter an option

.

M 4 » ¥ “Model {layoutl / Layout2

¥ (command: HELIX X Comman d

B [Tums = 3.0000 Twist <CCW & [~ STRETCH ™~
(Specify center point of base: \Speciy stretch point or [Base poirt/Copy/Undo/eXit]:
(Specify base radius or [Diameter] <12.6743> Commary d: Specify opposite comer

(Specify top radius or [Diameter] <5.5348>
(Specify helix height or [Axs endpoirt/ Tums/tum Height AWist] <30.0000>50

SNAP GRID ORTHO POLAR

6.2.6. Donut

Donuts are solid, filled circles or rings created as closed, wide polyline. The system variable FILLMODE controls whether to fill
the donut or not. FILLMODE is set to 1, creates filled donuts; if FILLMODE is set to 0, creates without filled.

To create a donut, you specify its inside and outside diameters and its center.

You can continue creating multiple copies with the same diameter by specifying
different center points. To create solid-filled circles, you can just assign the .
same value for the inside radius and outside radius. . ”'"""'”““'""”

To draw a donut; Draw > Donut ~ Command line > DONUT

H 4 + ¥ % Model £ Layoutl / Layout2

# pid>:n
& [Specify origin of UCS or [Z4is/3 paints/OBject/Face/View/X/Y/Z] <0,0,0>

1.Choose Draw > Donut from the main menu. Command: DONUT

1Specify inside diameter of donut <2.0000>: 10

2.Specify the inside diameter of the donut. ety ot danderof et 200007
3.Specify the outside diameter of the donut. Wmmm .
4.Specify the center of the donut.

5.Specify the center point to draw another donut, or press Enter to complete the command.

S| > GRID ORTHO  POLAR
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6.3. Create 3D Objects

With 3D models, you can: View entities in three dimensions, create three-dimensional entities, edit entities in
three-dimensional space, edit three-dimensional solids, display hidden-line and shaded views of three-dimensional entities.

6.3.1. 3D Thickness and Elevation

By default, the program creates new two dimensional objects with a zero elevation and thickness. The easiest way to create a
three dimensional object is to change the elevation or thickness property of
an existing two dimensional object. You can extrude any two dimensional
object into a three dimensional object by changing the thickness of the
object to a nonzero value. For example, a circle becomes a cylinder, a line
becomes a three dimensional plane, and a rectangle becomes a box.

To set the current elevation: Command line > CHANGE

4 4 » b " Model {Layoutl /Layout2

e
‘Specfy change pairt or [Fropeties]: P

1.Type CHANGE on the command line, and then press Enter after selecting & oty e B e TS Tk e

the two dimensional object(s).2.Enter P (Properties) and press Enter. S:;?*Q’EEZZLZZ;:E?f,ia‘ﬂimeem‘e,LWHQmm.mmmmm-
3.Enter E (Elev) and press Enter.

4.Specify a new elevation, and then press Enter.

121.97 69, 0 SNAP

To set the current thickness:  Command line > CHANGE

1.Type CHANGE on the command line, and then press Command Line x
Command: CHANGE =
Enter after selecting the two dimensional object(s). ) oot Sty opostecomer ouns
2.Enter P (Properties) and press Enter. :l?lle:f:ri::)grleupslw:nogrs[ET;“}EISE]LFLAVB(/LTWsl‘ltSca\e/LWBigm/Thidmsss/Matef
. al/Annctative]: T
3.Enter T (Thickness) and press Enter. Specty new thickness <0.0000>: 40
|| Enter property to change [Color/Hev/LAyer/L Type/tScale/L Weight/Thickness/Mater
4.Specify a new Thickness, and then press Enter. o Aenctatve -
Command: 4 r
6.3.2. 3D Faces ooty it ot s i
peciy second paint or [lnvisible]
pecty third point or [Invisible] <ext>
T — ’
. . . peciy fourth point or [Invisble] <create three sided face> E
You can create a three dimensional face, which pecty o ot vl >
pecky fourth point or [Invisible] <create three-sided face> L
consists of a section of a plane in three i i S T o

y

dimensional space. After you specify the fourth J< e e ]
x

point, the program continues to prompt you for

additional faces by alternating prompts for the third point and fourth point to
allow you to build a complex three dimensional object.

Z

To create a three dimensional face: Draw > Modeling>Meshes>3D Face kY

Ny

Command line > 3DFACE

*
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1.Type 3Dface on the command line.

2.Specify the first point of the three-dimensional face.
3.Specify the second, third, and fourth points.

4.Specify the third and fourth points for additional faces.
5.To complete the command, press Enter.

Command Line x

Comm;nd. RULESURF
Current wireframe density: SURFTAB1=6
6.3.3.  Ruled Surfaces (et e derety
ISelect second defining curve: -

Command: 4 r

You can create a ruled surface, which is a three-dimensional body that approximates the surface between two existing entities.
You select the two entities that define the ruled surface. These entities can be arcs, circles, lines, points, or polylines.

To create a ruled surface:Draw > Modeling>Meshes>Ruled Mesh ~ Command line > RULESURF

1.Type RULESURF on the command line.

2.Select the first defining object.

3.Select the second defining object.

6.3.4. Tabulated Surface

Tabulated surface meshes are used as a serial of paralleled polygon on
specified path, you should draw direction vector and original object before
creating a tabulated surface. The objects like a line, arc, circle, ellipse, or 2D
or 3D polyline can be used as outline curves for defining polygons.

Command Line

Command; TABSURF
To create an extruded surface mesh: Draw > Modeling>Meshes>Tabulated oo pnane
i Select object for direction vector:
Mesh ~ Command line > TABSURF Command:

1.Type TABSURF on the command line.
2.Select the object to extrude.
3.Select the extrusion path.

6.3.5.  Revolved Surface

Use REVSURF command to create a surface of revolution by rotating a profile of the object about an axis. The object to be
revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon, closed spline or torus. REVSURF is useful for
surfaces with rotational symmetry.

To create a revolved surface mesh: Draw > Modeling>Meshes>Revolved Mesh Command line > REVSURF

1.Type REVSURF on the command line.
2.Select the object to revolve.
3.Select the object to be used as the axis of revolution.
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4.Specify the starting angle.
5.Specify the number of degrees to revolve the object.

Command Line

Command: REVSURF

Curent frame densities: SURFTAB1=6 SURFTAB2=6
[Select objects ta otate

|Select object that defines the axds of revolution
ISpecify start angle <0>: 360

ISpecify included angle (+=ccw, -=cw) <380>

ICommand

6.3.6.  Solid Box

A solid box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the current
UCS. The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height maps to Z axis.
RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box using EXTRUDE.

To create a box: Draw > Modeling>Box Command line> BOX

1.Choose Draw > Modeling > Box from the main menu.
2.Specify the first corner of the base.

3.Specify the opposite corner of the base.

4.Specify the height.

6.3.7.  Solid Cone

Command Line

Command: BOX

[Specify first comer or [Center]:
|Specify other comer or [Cube/Length]
Specify height or [2Point]:

{Command: Specify opposite comer:

Command:

By default, the cone's bottom lies on the XY plane of the current UCS. The cone height is parallel to the Z axis. The apex
determines the height and orientation of the cone. You can draw a 2D circle and then use EXTRUDE to taper the circle at an
angle along the Z axis to create a solid cone. To complete the truncation, you can subtract a box from the tip of the cone with

the SUBTRACT command.

To create @ cone: Draw > Modeling>Cone ~ Command line > CONE

1.Choose Draw > Modeling > Cone from the main menu. ety heghtor [

2.Specify the center of the base of the cone.
3.Specify the radius or diameter.
4.Specify the height.

Command Line

ISpecify center point of base or [3P /2P /Tir/Bliptical]: Tancel™
Command: “Cancel*

Command: CONE

ISpecify center point of bass or [3P /2P /Trr/Blipticai]

pocty height or [2F /s endpoin
/Top radius] <66.4522>
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6.3.8.  Solid Cylinder

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of the current
UCS; the height of a cylinder is always parallel with the z axis. You can draw a circle and then use EXTRUDE to create a solid
cylinder.

To create a cylinder: Draw > Modeling>Cylinder ~ Command line > CYLINDER

1.Choose Draw > Modeling> Cylinder from the main menu.
2.Specify the center of the base of the cylinder.

‘Command Line

3.Specify the radius or diameter. ebrlave i idn/Festie/Concest Ot Concepod. 2
4.Specify the height. o o

] <112.2062>: <ORTHO On><ORTHO Of
6.3.9.  Sphere

The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel with the
z axis. You determine the size of a sphere by specifying either its radius or its diameter.

To create a sphere: Draw > Modeling> Sphere SPHERE

‘Command Line

[Select object: Specy opposite comer: 2found
ISelect object

1.Choose Draw > Modeling > Sphere from the main menu.
2.Specify the center of the sphere.
3.Specify the radius or diameter.

{Specify center point or [3P/2P/Tir]
|Specify radius or[Diameter]:
KCommand.

6.3.10. Torus

Atorus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of the current
UCS. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube (the
circle being revolved).

C Line
[Select object
Command: TORUS

To create a forus: Draw > Modeling>Torus  Command line > TORUS
(Specify center paint or [2P/2P/Ttr]:
[Specify raidus or[Diameter]:

Specify tube radius or [2Point/Diameter]:
Command:

1.Choose Draw > Modeling > Torus from the main menu.
2.Specify the center of the whole torus.

3.Specify the radius or diameter of the whole torus.
4.Specify the radius or diameter of the body of the torus.
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6.3.11. Pyramid

You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The base of the pyramid is always parallel to the xy
plane of the current UCS. You determine the size of the pyramid by specifying the base points and either the apex, the corners
of the top surface, or the endpoints of the ridge.

To create a pyramid: Draw > Modeling>Pyramid  Command line > PYRAMID

1. Choose Draw > Modeling > Pyramid from the main menu.
2. Specify the first point for the base of the pyramid.
3. Specify the second and third points.

Command Line
Command: PYRAMID

4 sides Inscribed Circumscribed

|Specify center paint of base or [Edge/Sides].

[Specify base radius or [Inscribed] <32 94662

{Specify height or [2P/Axis endpoint/Top radius] <141.6194>:

4. In the prompt box, choose Tetrahedron.
5. Specify the apex of the tetrahedron.

Command!

6.3.12. Wedge

You can create three dimensional wedges consisting of five surface planes. You determine the size of the wedge by either
specifying a second comer and the height; defining the wedge based on a cube having a given length; or specifying the length,
width, and height.

To create a wedge: Draw > Modeling>Wedge Command line > WEDGE

Command Line

{Specify height or [2Paint] <55.1953>: Cancel™
Command: WEDGE

Specify first comer or [Center]

[Speciy other comer or [Cube/Length]:
ISpecify height or [2Point] <55.1953>
Command:

1.Choose Draw > Modeling> Wedge from the main menu.
2.Specify the first corner of the base.
3.Specify the opposite corner of the base.4.Specify the height.

6.3.13.  Solids Extrude

EXTRUDE command, extrudes the profiles of the selected object along the chosen path to create solids. The entities you can
extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You cannot
extrude objects contained within a block or polylines that have crossing or self-intersecting segments.

To create an extruded solid: Draw > Modeling>Extrude ~ Command line > EXTRUDE

Command Line
{Command: EXTRUDE
ument wireframe density: ISOLINES=4
(Select objects to extrude: 1found
ISelect objects to extrude:
(Specify height of extrusion or [Direction/Path,/ Taper angle]
ICommand

1.Choose Draw >Modeling> Extrude from the main menu.
2.Select the object to extrude.
3.Select the extrusion path, or specify the height.

6.3.14. Solids Revolve

REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving axis can be X, Y axis of
current UCS as well as lines, polylines. Objects can be revolved are closed polylines, polygons, rectangles, circles, ellipses,
regions and so on.

To create a revolved solid: Draw > Modeling>Revolve ~ Command line > REVOLVE
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1.Choose Draw > Modeling> Revolve from the main menu.
2.Select the object to revolve.

3.Do one of the following to define the axis of revolution:
-Specify a start point and an end point.

-Type 0 and press Enter to select an object.

-Type x and press Enter to select the x axis.

-Type y and press Enter to select the y axis.

4.Specify the angle of revolution.

axis:
Specify angle of revelution <36@3:

Command: <l

6.3.15. Solid

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default method is to
specify the comers of the plane. After you specify the first two corners, the plane is displayed as you specify the remaining
corners. The program prompts you for the third point and then the fourth point.

To draw a quadrilateral plane:

1.Choose Draw > Modeling > Meshes> 2D Solid
2.Specify the first, second, third and fourth point.
6.Finish the command, press Enter.

6.3.16.  Flatshot

With FLATSHOT command you can create a 2D representation of all 3D objects based on the current view.The edges of all 3D
solids, surfaces, and meshes are projected line-of-sight onto a plane parallel to the viewing plane. The 2D representations of
these edges are inserted as a block on the XY plane of the UCS. This block can be exploded for additional changes.

Block Reference
Color Bylayer

Layer 0
Linetype BYLAYER

T Model Tayoutl
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Flatshot dialog box G (. e

Destination
Destination. Controls where the flattened representation is created. © Insert s new block
Insert As New Block: Specifies to insert the flattened representation as a block ©) Replace existing block
in the current drawing. | Selectblock
Replace Existing Block:Replaces an existing block in the drawing with the newly (No block selected)

created block. ©) Exportto afile

Select Block: Closes the dialog box temporarily while you select the block you
are replacing in the drawing. When you finish selecting the block, press Enter

Filename and path:

ChUsershovsiDocuments'\New Elock dwg

to re-display the Foreground lines
Block Selected / No Block Selected:Indicates whether a block has been = [yBock 7]
selected. Linetype: [ Continuous v |
Export to a File:Saves the block to an external file. Obscured lines
Foreground Lines:Contains controls for setting the color and linetype of lines e
that are not obscured in the flattened view. Colr. | ByBock -
Color: Sets the color of lines that are not obscured in the flattened view. e ’ Continous v
Linetype-Sets the linetype of lines that are not obscured in the flattened view. Hooearaa

] [ Cancel | [ Hep |

Obscured Lines: Controls whether lines that are obscured in the drawing are
displayed in the flattened view, and sets the color and linetype of these

obscured lines. Show:Controls whether
obscured lines are shown in the flattened representation. When selected, the 2D flattened representation displays lines hidden
by other objects.

Color:Sets the color of lines that lie behind geometry in the flattened view.
Linetype:Sets the linetype of lines that lie behind geometry in the flattened view.
Include Tangential Lines: Creates silhouette edges for curved surfaces.
Create.Creates the flattened view.

6.3.17. Creating Composite Solids

You can create composite three-dimensional solids by combining, subtracting, and finding the intersection of two or more
solids. With UNION command, you can combine the total volume of two or more solids or two or more regions into a
composite object.

To combine solids: Modify> Solid Editing>Union ~ Command line > UNION -

Command: UNION
1.Choose Modify > Solid Editing> Union from the main menu. \ e e oo, 2103
2.Select the objects to combine. Cormard

To subtract solids: Modify>Solid Editing>Subtract ~ Command line > SUBTRACT

1.Choose Modify>Solid Editing>Subtract from the main menu. ‘ ‘

Command Line
ICommand: “Cancel”™
ICommand: SUBTRACT

(Select solids, surfaces, and regions to subtract from
ISelect object: 1 found

ISelect object

Command
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2.Select the objects to subtract from one another.

To intersect solids: Modify> Solid Editing>Intersect Command line > INTERSECT

1.Choose Modify > Solids Editing > Intersect from the main menu.
2.Select the objects to intersect.

Command Line
mmand: "Cancel™
mmand: "Cancel™
mmand: INTERSECT
elect object: Specy opposite comer: 2found
elect object
mmand

6.3.18. POLYSOLID

The POLYSOLID command allows you to create 3D solid in a shape of a wall directly or by selecting existing polylines. A
polysolid is drawn the same way you draw a polyline, which is created with continuous straight and curved segments.

Command:
W roLvsoLo
Command: POLYSOLID

After inputting the POLYSOLID command, you will get 4 options (Object,
Width, Height, and Justification) in the command line and dynamic input
box.

> Type “Width” or “Height” to set width and height.

> Type Justify” to set justification (Left, Center, Right).

»  When you start drawing solid wall after clicking on your first point, it gives you 2 options (Arc, Undo) in the command
ling and dynamic input box. If you don’t input any of them, you can just continue drawing your lines.

> Ifyou type “Arc”, it can give you 3 options (Close, Direction, Line), you can draw the arc by 2 points or enter “Direction”

to draw the arc by tangency direction.

> You can also type “Close” to close your
polysolids or type “Line” to change back to line
again. If you type “Undo”, it will back to
previous point.

> Ifyou type “Object” in dynamic input box or in command line, you
can convert existing lines, 2D polylines, arcs, and circles into 3D
solids with default height, width, and justification. This feature only
allows select objects one by one.

PSOLWIDTH: System variable, sets the default width for the 3D polysolid.
PSOLHEIGHT: System variable, sets the default height for the 3D
polysolid.
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6.3.19. PLANESURF

You can input PLANESURF command or click Ribbon — Surface — Plan to create a planar surface by selecting closed objects or
specifying the opposite corners of a rectangular surface. When the corners of the surface are specified by the command, you
can create a surface parallel to the work plane.

@ REpRbaw 2D ing = BE GstarCAD 2024 Professional - [Drawing1.dwg]

Home  Insett  Annotation Suface  Mesh  layout  View  Manage  Export  BIM  Application  Help  Express  Collaberation

8 ¢ e

Offset NURBS
Create  t

Remove

Create

Drawingt.dwg

SURFU / SURFV: System variable, sets the number of lines displayed on the surface
DELOBJ : System Variable, decides whether to delete defining objects.

6.3.20. SURFOFFSET

. FE =R ~ 2D Drafting -
You can input SURFOFFSET command to create a parallel surface at a ) = - » DJ :
specified distance from the original surface. @ron LT Extrude
bl Loft . Revolve Q 0 ¢ Q
_ Offset NURBS Convert
. . . . . d dweep Create  to NURES
After selecting the surface and pressing enter, you will get 4 options (Flip =t

direction, Both sides, Solid, Expression) in the command line and dynamic ooy oD
input box.

> You can Offset the surface in one direction (the arrows will show on one side of the surface) by entering a distance or
select the point on the drawing.
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> Ifyou type “Flip direction”, the arrows will flip to another side.

> Ifyou type “Both sides”, you can Offset the surface in both directions (the arrows will show on both sides of the surfaces)

> Ifyou type “Solid”, you can Generate the surface to a solid after the offset

> Ifyou type “Expression”, you can enter a formula or equation to specify the distance of the surface offset.
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SURFACEASSOCIATICITY: System Variable, when the value is 1, Expression option will be displayed. This option does not
update the offset distance default value the next time you enter the command.
SURFACEMODELINGMODE: System Variable, when the value is 1, the surface will be a NURBS surface.

6.3.21. CONVTOMESH

You can input CONVTOMESH command or click Ribbon- Mesh — Convert to MESH to convert eligible 3D objects into meshes,
the objects will be smoothed at the same time in the conversion as well.

d

[E] convromesH HLInE
Command: CDP-IVTDP-‘-

Eligible objects include: solids, closed polylines, regions, 3D face, 3D surfaces, polygon meshes.

When the 3D entities that are extruded, swept, lofted, and revolved with arcs are converted to meshes, and the number of faces
and vertices after conversion cannot be displayed correctly

FACETERMESHTYPE: System Variable, controls the level of smoothness upon conversion (If the mesh type is not set to be
optimized, the converted object is not smoothed).

DELOBJ: System Variable, decides whether to delete defining objects.

6.3.22. CONVTOSOLID

M

You can input the CONVTOSOLID command to convert eligible
objects to 3D solids.

Eligible objects include: Drawingt.¢
» 3D meshes that completely enclose a volume
> Surfaces that completely enclose a volume

> Closed polylines and circles with a non-zero thickness property; wide polylines must have a uniform width

The Command has following limitations:

> You can select one or more objects to convert to solid, if any object in your selection set is in invalid for the command,
you will be prompted again to select the objects.

> It'snot available to convert planar surfaces or regions with contiguous edges to 3D solid.

> It'snot available to convert separate objects to 3D solid. If the surfaces enclose a watertight area, you can convert to a
solid with the SURFSCULPT command.

SMOOTHMESHCONVERT: System Variable, only supports value 3. Smoothness and optimization effect won’t be supported in

the version.
DELOBJ : System Variable, decides whether to delete defining objects.
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6.3.23. CONVTOSURFACE

You can input the CONVTOSURFACE command or click Ribbon- Mesh — Convert to SURFACE to convert eligible objects into
3D surfaces.

3D Surface Mesh Layout

Eligible objects include: 2D solids, 3D solids, Mesh objects, Planar
3D faces, Regions, Zero-width polylines with thickness, Polylines
with global-width, Lines with thickness, Arcs with thickness, Closed
plane curve.

SMOOTHMESHCONVERT: This System Variable only supports value 3. Smoothness and optimization effect won't be supported
in the version.

DEOBJ: System Variable, when sets the value to 0/3/-3, the defining objects won't be deleted, when the value is -1/-2, there
will be a two options for users to choose delete or not, when it is 1/2, the defining objects will be deleted.

6.3.24. CONVTONURBS

You can input CONVTONURBS command or click Ribbon- Surface — Convert to NURBS to convert solids and procedural
surfaces to NURBS surfaces. You can also convert meshes to NURBS surfaces after converting them to a solid or surface by
CONVTOSOLID or CONVTOSURFACE command.

W B B & . 4 - 2D Drafting

Home Insert Annaotation 30 Surface Ves oL View Manage Exp|

Drawing1.dwg

There are a series of new functionalities for NURBS control vertices editing and display, such as
e SHOW CV: Shows control vertices. You can adjust the NURBS surfaces by clicking the control vertices, you will get 4
options (Base, Copy, Undo, Exit) in your command line and dynamic input box.
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Base: Moves your control vertices according to the base point and second point you choose.
Copy: Copies a new NURBS surface and move it, the original surface won't be deleted.
Undo: Cancels the previous step.
Exit: Stops adjusting control vertices.

YV V V V

HIDE GV: Hides control vertices.

e ADD: Adds control vertices. After selecting the object, you will
get 2 options (Knots, Direction) to add control vertices and set
the position.
> Knots: Turns off the display of control vertices and allows
you to place a point directly on a surface. This option only
displays if you select a surface; it does not display for
splines.

> Direction: Specifies whether to add control vertices in the
U or V direction. This option only displays if you select a
surface; it does not display for splines.

e  REMOVE: Removes control vertices. There are at least 2 control
vertices in each direction.

DELOBJ : This System Variable decides whether to delete defining objects.

6.4. Create Regions

You can convert a closed object into a two dimensional region. After you create a region, you can modify it using the various
three dimensional tools. You can create regions from closed objects, such as polylines, polygons, circles, ellipses, closed
splines, and donuts.

Command Line
B Command: REGION
< " - “ Select object: Specify opposite comer: & found
To create a region: Draw> Region Command line > REGION ~ =8 5 === =@ B8 ekt

5] m : 1 loop extracted
: Lo : Created 1 ragion
B | EEE S R — and:

Layer 0

1.Choose Draw > Region from the main menu.
2.Select the objects to create the region and press Enter.

Linetype Bylayer

6.5. Create Revision Cloud

REVCLOUD command creates or modifies a revision cloud You can create a new revision cloud by selecting two corner points
or polygonal points, dragging your cursor or you can also convert an existing object such as a circle, ellipse ,polyling or spline
to a revision cloud.

Minimum arc leng = ormal T

pecify start po ) /Object/ 1/Freeha ify] <Objects:
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6.6. Create Break Line

Creates a polyline and inserts the breakline symbol. To use your own block for the breakline symbol, make sure that the block

contains two point objects on the Defpoints layer.

To create a revision cloud: Command line > BREAKLINE

1.Type BREAKLINE on the command line.

00|00
Q000
DCGO0

2.Specify first and second point for breakline.

kdine]

[oXeRNoR]
jeXeRpeRe)
o0 00

Block = BRKLINE DWG, Size = 1.00, Extension = 2.50
‘Specify first poirt for breakline or [Block /Size/Extension/sPecy line for brea

'Specify second poirt for breakline:
'Specify location for break symbol <Midpaint>:

Command

3.Specify location for break symbol.

6.7. Create Wipeout

Wipeouts are created using existing polygons, closed zero-width polylines made up of only line segments, or new polylines
that you draw while using the WIPEOUT command. Also you could use a circle object to be wipeout or even you can pick up a
closed polyline object containing arcs. For example, you can explode and outline a block definition shape (car) then join it as
polyline then wipeout this polyline and group it with the block definition and place it on your drawing as showing below.

To draw a wipeout: Draw>Wipeout Command line > WIPEOUT

1.Choose Draw > Wipeout from the main menu.
2.Specify the start point and endpoint of each segment.
3.After specifying the last endpoint, press Enter.

Wipeout

Layer 0

Color Bylayer

Linetype Bylayer

mmand: WIPEQUT
Joeciy firt poirt or [Frames/Polyine] <Poyine:>:

|| Il
i % Specify first point or [2349.431260.13
Pick polyiine or circle]| Frames | Circle

| | | | | |

[0, Model  Layoutt [ Layout

L o
WIPEOUT

Grouped Polyline

—

\

—
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6.8. Create table

The new Table function with TABLEDIT\TABLESTYLE\TABLEEXPORT command group are possible now to create and modify

table as well as to define the format of table. It is possible to export the table to CVS file and open it on Microsoft Excel.

To draw fable: Draw>Table Command line > Table

6.8.1.  Insert Table Dialog Box

Input TABLE command and press ENTER, and "Insert Table" dialog box will be open.

G tsen Table ==

Tatde Sije. Vation ter s

R e Somcty et core

Set col s

Frat row col e Tae

43D-CABA-78-45-10

| A3 0z | 15%
&

Table Style: Choose a table style from within the current drawing from which to
create a table. You can create a new table style by clicking the button next to the
drop-down list.

Preview: Controls whether a preview displays. If you start from an empty table, the
preview displays an example of the table style.

Insertion Behavior: Specifies the location of the table.

Specify Insertion Point: Specifies the location of the upper-left corner of the
table. You can use the pointing device or enter coordinate values at the
Command prompt. If the table style sets the direction of the table to read from
the bottom up, the insertion point is the lower-left comer of the table.

Specify Window: Specifies a size and a location for the table. You can use the

pointing device or enter coordinate values at the Command prompt. When this
option is selected, the number of columns and rows and the column width and
row height depend on the size of the window and the column and row settings.

Table Style

(oot ——) (3]

[V] Preview
Ha (Ha | Ha
ade(ade| ade
r r r
Insertion behavior
©) Specify insertion point
() Specify window
Column & row settings
Columns: Column width:
m s 63.5
Rows Row height:
B 8 1 = Line(s)
~) Specify window
Column & row settings
Columns: Column width:
m 1 63.5 =
Rows: Row height:
=g 6 = Line(s)

81



Chapter 6 Create Objects

Column & Row Settings: Set the number and size of columns and rows.

Insertion behavior

_) Specify insertion point

|
Columns Icon: Indicates columns. T
Rows Icon: Indicates rows. g e it

m s Automatic

") Bows: Row height:

B |Adomatic 8 2 Line)
Columns: Specifies the number of columns. When the Specify Window 'TSégi?e*i‘:s“e":tgon et
option is selected and you specify a column width, the Automatic option is
selected, and the number of columns is controlled by the width of the table. ?‘:Emncilfrr‘]"n:f"‘"°s Ty
If a table style containing a starting table has been specified, then you can mE Adtomatic 2
choose the number of additional columns you would like added to that e —
starting table. B [Atomatic s 6 =] Lines)
Column Width: Specifies the width of the columns. When the Specify 'hSégi?e'::i;:OH o
Window option is selected and you specify the number of columns, the Auto o Speciy window
option is selected, and the column width is controlled by the width of the Co'emncilruor:vnz:e*tings ——
table. The minimum column width is one character. [ Actomatic 835 =

) Rows: Row height:

B |Automatic 6 S Linefs)
Rows: Specifies the number of rows. When the Specify Window option is
selected and you specify a row height, the Automatic option is selected, and o=
the number of rows is controlled by the height of the table. A table style with
atitle row and a header row has a minimum of three rows. The minimum row o™ o seinss " T—
height is one line. If a table style containing a starting table has been m] Aot @ |
specified, then you can choose the number of additional data rows you e oo
would like added to that starting table. B Automatic| = Linefs)
Row Height: Specifies the height of the rows in number of lines. The height
of a line is based on the text height and the cell margin, which are both set PR
in the table style. When the Specify Window option is selected and you @ Comme: IR Cokem wadt:
specify the number of rows, the Auto option is selected, and the row m i
height is controlled by the height of the table. O Bows: Row height:

B Astomatic|: 8 2| Linefs)

Set Cell Styles: For table styles that do not contain a starting table, specifies a cell style for rows in the new table.
First Row Gell Style: Specifies a cell style for the first row in the table. The

Set cell styles
Title cell style is used by default. First row cell style: Title -
Second Row Cell Style: Specifies a cell style for the second row in the Second row cell style: Header M
table. The Header cell style is used by default. Al ther row cell styles:

All Other Row Cell Styles: Specifies a cell style for all other rows in the
table. The Data cell style is used by default.

Data
Header
Title
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6.8.2.  Table Style Dialog Box

Current Table Style: Displays the name of the table style that is applied to tables you create.

Styles: Displays a list of table styles. The current style is highlighted.
List: Controls the contents of the Styles list.
Preview: Displays a preview image of the style that is selected in the

Styles list. Z:;‘nenl TableSMeS:mpIe1 R

Set Current: Sets the table style selected in the Styles list as the S [_Set Curent |
current style. All new tables are created using this table style. o (L tew. )
New: Displays the Create New Table Style dialog box, in which you i Lt )
can define new table styles. Nioih
Modify: Displays the Modify Table Style dialog box, in which you can List: :;;

modify table styles. G

Delete: Deletes the table style selected in the Styles list. A style that
is being used in the drawing cannot be deleted.

6.8.3.  Create New Table Style Dialog Box

Specifies a name for the new table style and specifies the existing table style on which the new table style will be based.

New Style Name: Names the new table style. e »
Start With: Specifies an existing table style whose settings are the default [FabieStyieSampie2)
for the new table style. Start With: Cancel

Continue: Displays the New Table Style dialog box, in which you define | Standerd z) [ Heb |

the new table style.

6.8.4.  New and Modify Table Style Dialog Boxes

Starting Table: Allows you to specify a table in your drawing to use as an example for
formatting this table style. Once you select a table, you can specify the structure and
contents you want copied from that table to the table style. With the Remove Table
icon, you can remove a table from the current specified table style.

General Table Direction: Defines a new table style or modifies an existing table style. It
sets the direction of a table.

Down: The title row and the column heads row are at the top of the table.

Up: The title row and the column heads row are at the bottom of the table.

Preview: Displays an example of the effect of the current table style settings.

Cell Styles: Defines a new cell style or modifies an existing cell style. You can create
any number of cell styles.

Create Cell Styles Button: Launches the Create New Cell Style dialog box.

Manage Cell Styles Button: Launches the Manage Cell Styles dialog box.

New Table Style: TableStyleSample2

|Starting table

Select table to start D
fom &
General

ITable direction: Up v
Down

. T —
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Cell styles
Data

Title
Header

Create new cell styles
[Manager cell styles...

Format:

General

Type: Data v
General Tab

Properties

Fill Color: Specifies the background color of the cell.

Alignment: Sets justification and alignment for the text in the table cell.
Format: Sets data type and formatting for the Data, Column Heading, or Title
rows in a table. Clicking this button displays the Table Cell Format dialog box,
where you can further define formatting options.

Type: Specifies the cell style as either a tag or data.

Margins

Horizontal: Sets the distance between the text or block in the cell and the left
and right cell borders.

Vertical: Sets the distance between the text or block in the cell and the top and
bottom cell borders.

Cell styles
lHeader

General ITe,Q Borders

Properties

Fill color:
Alignment:
Format:
Type:

Margins

Horizontal: 1.5

Vertical: 15

[7] Merge cells on row/column creation

Cell style preview =
| aa
o

ok ][ Concel | [ Heo |

Merge cells on row/column creation: Merges any new row or column created with the current cell style into one cell. You can

use this option to create a title row at the top of your table.

Text Tab

Text Style: Lists the available text styles.

Text Style Button: Displays the Text Style Dialog Box where you can create or
modify text styles.

Text Height: Sets the text height.

Text Color: Specifies the color of the text. Choose Select Color at the bottom of
the list to display the Select Color dialog box.

Text Angle: Sets the text angle. The default text angle is 0 degrees. You can enter
any angle between -359 and +359 degrees.

Borders Tab

Lineweight: Sets the lineweight to be applied to the borders you specify by
clicking a border button. If you use a heavy lineweight, you may have to increase
the cell margins.

Linetype: Sets the linetype to be applied to the borders you specify. Choose
Other to load a custom linetype.

Color: Sets the color to be applied to the borders you specify by clicking a
border button.

Double Line: Displays table borders as double lines.

Spacing: Determines the spacing for double line borders.

Cell styles
[Haader v] @J
[Generalf Tet [[Borders]
Properties
Tot e =
Text height: 45
Text angle: 0
Cell style preview
‘ aa
oo
[ ok ][ Comcel | [ Hep |
Cell styles
[oas 2 B @
General | Text Iml
Properties
trepe:
cor
Double lines
Spacing: 1.125
) () (=) (@) (@) @)E)
Apply the selected properties to borders by clicking the
Cell style preview
‘ B
oo
[ ok [ cacel | [ Hep |
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7. Modify Objects

You can easily modify the size, shape, and location of objects. You can either, enter a command first and then select the
objects to modify, or you can select the objects first and then enter a command to modify them.

7.1. Remove Objects

You can use ERASE command to delete objects, whatever the methods you use to select objects. To restore the deleted objects,
use UNDO command. You can remove objects using one of the following methods: Delete objects with ERASE command, cut
the selected objects to the clipboard, or press DELETE to remove the selected objects.

7.2. Copy Objects

You can duplicate objects within the current drawing. The default method is to create a selection set and then specify a base
point, and a displacement point, for the copy. To copy objects at the specified distance, you can specify the distance directly
when the Ortho Mode or Polar Tracking is on.

Create only one copy of object one time:

1.Choose Modify > Copy from the main menu. <. % C“:m'm':d“'-c::
2.Select the objects, and then press Enter. o a1 cpposte comer 3fond
) |: ‘-r”””;},: [Current settings: Copy mode = Muttiple
30n the Command ||ne‘ type 0 (mode) N E S : Specify base point or [Displacement/mOde] <Displacement: O
) . \‘n,j,,»"' : p.acrfy base point or [Displ.acemem/mOl.ieJ/Multip\e] <[Tsplacemem> second
40n the Command ||ne’ type S (Slngle) ; 3 oint or <use first point as displacement>: <ORTHO On>
' second point or <use first point as displ: 2 |-lIE|

5.Specify the base and displacement point.
Create multiple copies for selected object one time:

1.Choose Modify > Copy from the main menu.

2.Select the objects, and then press Enter.

3.0n the command line, type O (mOde).

4.0n the command line, type M (Multiple).

5.Specify the base and displacement point of the first copy.
6.Specify the displacement point of the next copy.

7.To complete the command, press Enter.

Command Line

Py poee e
Enter a copy mode opt
Specify base point or [
rst poirt as displacems
{Specify second point
ISpecify second point ¢

7.3. Mirror Objects

You can specify a baseline to create a mirror image using MIRROR command. The mirror image is symmetrical with the
original one. So if you want to create a symmetrical objects, you only need to draw a half one, then create a full one using
MIRROR command. Besides picking start and end point to define mirror axis, you can also directly select objects as mirror axis
like a line, polyline, a line of block or an external reference drawing.
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To mirror objects:

 [Specly sscond pont f miver e[ |0 ]
1.Choose Modify > Mirror from the main menu. O ORONN ..

ISelect object; Speciy opposite comer: 7 found

2.Select the object, and then press Enter. m /\ f\ /\/\ et

ISpecty first poit: of mimor ine:

3.Specify the first and second point of the mirror line. S ST
4.0n the command line, if you want to retain the original objects, type N if you want to délete tfie originaFobjects; type ¥-—

Specify second paint of mirror lin

7.4 Offset an Object

You can use the offset to copy selected objects and align them offset to the original objects at a specified distance. You can
make offset objects using arcs, circles, ellipses, elliptical arcs, lines, two dimensional polylines, rays, and infinite lines.

To make an offset copy by specifying the distance:

1.Choose Modify > Offset from the main menu.

2.Specify the distance (select two points or enter a distance). Command Bar
Command: OFFSET
SSeleCt the Oblect to Oﬁset Parallel: [Through point]<Distance> <5»:3

Select objects:
[Both sides]<Side for parallel copy>:

4.Specify on which side of the object to place the parallel copy. Select objects:
5.Press Enter to complete the command. Cormand:

To make an offset copy passing through a point:

N |
1.Choose Modify > Offset from the main menu. ) (
2.0n the command line, type T (Through). . o " E;?EE::ETﬁmm o Creugh st oistamcens
3.Select the object to offset. | ; soies ol
4.Specify the point for the object to pass through. wo . e T

5.Press Enter to complete the command.

7.5. Create an Array of Objects

New array options are available to create copies of objects arranged in rectangular, polar, or path pattern. The new array is as a
whole (dynamic block). It can be dynamically adjusted the number of ranks, spacing and other related parameters through
Ribbon Panel, Properties and Grip.

To create a rectangular array: =

1.In “2D Drafting” workspace, click

“Home” > “Modify” > “Rectangular Array” in turn.

&
=
o
c
@©
i
(&)
QU
o
>
©
5

2. Select the object to be arrayed and press “ENTER”.
3. Inthe array preview, drag the grips to adjust the spacing and
number of rows and columns.
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You can also modify values in "Array" Ribbon .

To create a polar array:

1.In “2D Drafting” workspace, click
“Home” > “Modify” > “Polar Array” in turn.

2.Select objects to array.

3.Specify center point of array (array preview will be
showed).

4 Input “i” (items), and then input the number of items
to array.

5.Input “a” (angle), and then input the fill angle.

Array Polar

You can also select grips to edit array.

To create a path array

The best way to use Path Array is to create them at first.
And then you can use the tools or “Properties” of the
Ribbon to modify them.

1.In “2D Drafting” workspace, click
“Home” > “Modify” > “Path Array” in turn.

2.Select the object to array, and “ENTER”

3 Select an object (such as a line, a polyline, a 3D polyline,
a spling, a helix, an arc, a circle or an ellipse) to be as a
path to array.

4.Specify the way to distribute items along the path:

If you want to distribute items evenly throughout the path length, please click “Properties” panel in Ribbon > “Divide” in turn. If
you want to distribute items at a specific distance, you can click “Properties” > “Measure” in turn.

5.Move the cursor along the path to adjust the items.

6.Press “ENTER” to finish Array.

=
=]
@©
a
>
©
<

7.6. Move Objects

You can move objects to a new place without changing the objects. You can perform MOVE command and then select object (1)
to move; specify a base point (2) and Displacement point (3). The object is moved from point 2 to the point 3.

To move entities: OBJECT Comand: HOVE

R : Select objects:

Tt Opposite corner:Find out 1, total 1

E '\‘_’) ' Q éEIEFt, o‘bjacts:_ ) . .
1.Choose Modify > Move from the main menu. ~ *- ' Specify second point or <use first point ¢

|Specily second point or <use first point as displacement>: Hl 9.,7636] |.|< 0

2.Select the objects, and then press Enter.
3.Specify the base and displacement point.

OBJECT ;fz_

O

|specify stretch point or @‘ [36.0633] ||< 52° |
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To move an object using grips:

1.Select the object.
2.Click a grip to select it.
3.Drag the object to where you want to relocate it and press Click to release.

1.7, Rotate Objects

You can rotate the selected objects around a specified point. You can specify the rotated angle by specifying a point on the
drawing or entering the angle value directly. The direction that objects rotate depends on the value you enter is positive or
negative.

To rotate objects:

[Specify rotation angle or &[0 |[<69° |

OBJECT
1.Choose Modify > Rotate from the main menu. @

2.Select the objects, and then press Enter.
3.Specify the base point and rotation angle.

To rotate a selection set in reference to an Absolute Angle:

1.Choose Modify > Rotate from the main menu.
2.Select the objects, and then press Enter.

3.Specify the base point. AL Specify the base point:

4.0n the command line, type R (Reference). bt i::(;::ﬁh:;f”m e
5.Specify the reference and new angle.

|
[New angle <0s: || TEEG |[<20° | & =

select objects to rotate:
Opposite cerner:Find out 2, total 2
select objects to rotate:

7.8. Align Objects

You can align objects with another through move or rotation with ALIGN command.

To align and object to other as reference: OBJECT
[©] =
:"'/','j o gz’;;zzd;b;tzi::Find out 1, total 1
1.Choose Modify > Align from the main menu. DA e e ot
"""" Specify first destination point:
2.Select the object, and then press Enter. DESTINATIO Comand:
3.Specify the first source point. OBJECT

4.Specify the destination point.
5.Press Enter to finish the command.

7.9. Scale Objects

You can use SCALE command to scale the proportionality of the selected objects. You can type a scale factor or specify a base
point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a scale factor that is smaller
than 1 shrinks the object.
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To scale a selection set by a scale factor:

1.Choose Modify > Scale from the main menu. OBJECT
2.Select the objects, and then press Enter. @

3.Specify the base point. %7

4.Specify the scale factor.

7.10.  Lengthen Objects

Select objects:Find out 1, total 1
oo : select objects:

Specify the base point:

|specify scale factor or [Copy/Reference] <2.53:

[specify scale factor or

B ez ]

You can change the length of entities or the included angle of arcs. The results are similar to extending and trimming.This

command does not affect the closed entities.

To change the length of an object by dragging: OBIJECT

O]

1.0n the command line type LENGTHEN.

O]

New start point for line:

2.0n the command line, type DY (DYnamic). Cosergnicl select cbjects to change>: i

LENGTHEN

Select objects to change or [Mode]:

3.Se|eCt the Object yOU Wam tO Change. Edit length: [DYnamic/DElta/Percent/Total]<Select objects to list length>:DY [

New start point for line:

4.Specify the new endpoint or included angle.

7.11.  Stretch Objects

When stretching objects, you have to specify a base point and displacement point. You should use crossing selection to select
the desired objects. With using grip edition, you can also stretch objects.

To stretch an object:

OBJECT
1.Choose Modify > Stretch from the main menu. @

2.Select the objects using either a crossing window or a

[Specify secand point o <use first point as displacement>:

Crossing polygon’ and then press Enter g:i:zt 3;3:2:::10 stretch by crossing-window or crossing-polygon... o

Oppesite corner:Find out 3, total 3

3.Specify the base point. select objects:

Specify base point or [Displacement] <Displacements:

4.Specify the second point of displacement.

Specify second point or <use first point as displacement>: <[

To stretch an object using grips:

1.Select the object.
2.Click a grip to activate it.
3.Drag the grip.

4.Click to release.
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7.12.  Trim Objects

You can clip, or trim, objects so they end at one or
more implied cutting edges defined by other objects.
You can trim arcs, circles, lines, unclosed polylines,
and rays.

To trim an object:;

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.

3.Select the object to trim.
4 Press Enter to complete the command.

To trim several objects using the fence selection method:

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.

3.0n the command line, type F (Fence).
4.Specify the first point of the fence.
5.Specify the second point of the fence.
6.Press Enter to complete the command.

7.13.  Extend Objects

-

[Fence/Crossing/Project/Edge/eRase/Undo].

Select object to trim or shiftselect to extend or
[Fence/Crossing/Project /Edge/eRase/Undo]

[Fence/Crossing/Project/Edge/e

=} [Rase/Undo]

[Select object o tim or shift-select to etend o _|| I |12

---------------------

elect objects or <select all>:
elect object to tim or shift-select to extend or
[Fence/Crossing/Project/Edge/e Rase/Undo]: FENCE

pecify next fence point or
Undo]

@

<[ +

You can extend objects so that they end at a boundary defined by other objects. You can extend arcs, lines, two-dimensional
polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as

boundary edges.

To extend an object:

1.Choose Modify > Extend from the main menu.

2.Select one or more objects as boundary edges, and then press Enter.
3.Select the object to extend, and press Enter to finish the command.

To extend an object to an implied boundary:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.

3.0n the command line, type E (Edge).
4.0n the command line, type E (Extend).
5.Select the object to extend, and press Enter to finish.

[Fence/Crossing/Project/Edge/Undo]:

elect object to extend or shift-select to trim or
[Fence/Crossing,Project /Edge/Undo]:

[Fence/Crossing/Project /Edge
Undo]:

\ T
[Fence/Crossing/Project/Edge/Undo]:

elect object to extend or shift-select to tim or
[Fence/Crossing/Project/Edge/Unde]: |j
[FenceCrossing/Project/Ed e
e/Unda]: <[ b
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To extend several objects using the fence selection method:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.
3.0n the command line, type F (Fence).

4.Specify the first and second point of the fence.

5.Press Enter to complete the command.

7.14.  Create Breaks

V3T

next fence point or

[Select objects or <select all>:
[Select object to extend or shift-select to trim or
[Fence/Crossing/Project/Edge/Undo]: FENCE

pecify next fence point o _
[Undo]: 4

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must specify two
points for the break. By default, the point you use to select the entity becomes the first break point; however, you can use the
first break point option to select a break point different from the one that selects the entity.

To break an object:

1.Choose Modify > Break from the main menu.
2.Select the object.
3.Specify the second break point.

To select an object and then specify the two break points:

1.Choose Modify > Break from the main menu.
2.Select the object.

3.0n the command line, type F (First point).
4.Specify the first and second break point.

7.15.  Create Chamfers

£n
7

&0

o
il B |Command tine

‘Select object
‘Specity second break point o [First point]: FIRST

{Specty first break point:

mmmmm

IComman¢ d:

50

You can connect two nonparallel objects by extending or trimming them and then joining them with a line to create a beveled
edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how far to trim the
objects back from their intersection (distance distance method), or you can specify the length of the chamfer and the angle it

forms along the first object (distance angle method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyline segments, or you can chamfer

the entire polyline.
To chamfer two objects using the distance-distance method:

1.Choose Modify > Chamier from the main menu.
2.0n the command line, type D (Distance).
3.Specify the first chamfer distance.

4.Specify the second chamfer distance.

Command Line
Ommana: Lancel
Command: CHAMFER
"Trim" mode) Curent chamfer Dist1 = 20.0000. Dist2 = 20.0000
(Select first ling or [Undo/Polyline/Distance/Angle/Trim/mEthod /Muttiple]. D
(Specify first chamfer distance <20.0000>: 15
(Specify second chamfer distance <15.0000>
[Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]:
[Select second line or shift-select to apphy comer: “Cancel”
Command:
Command:
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5.Select the first object to chamfer.
6.Select the second object to chamfer.

To chamfer two objects using the distance-angle method:

1.Choose Modify > Chamfer from the main menu.
2.0n the command line, type A (Angle).

3.Specify chamfer length on the first line.
4.Specify chamfer angle from the first line.
5.Select the first object to chamfer.

6.Select the second object to chamfer.

To chamfer selected vertices in a polyline:

1.Choose Modify > Chamfer from the main menu.
2.Select one polyline segment where you want to
begin the chamfer.

3.Select the other polyline segment where you want
to end the chamfer.

To chamfer all vertices in a polyline:

1.Choose Modify > Chamfer from the main menu.
2.0n the command line, type P (Polyline).
3.Select the polyline.

7.16.  Create Fillets

T

Command Line

elect it ine or (U
peciy chamer leng
peciy chamer angle fror

i
ath onthe firs line <0.0000>: 15
mihe firs line <03: 20

ple]: ANGLE

e/

ine.
cond e or shift-select to apply comer

m

[Trm" mode) Currert chamfer Lengih = 15.0000. Angle = 20

mmand

Command Line

Command: “Cancel®

Command: CHAMFER

Trim" mode) Curent charfer Dist1 = 50,0000, Dist2 = 50.0000

‘Select fit ine or [Undo/Polyine/Distancs/Angle. Trim/mEthod Mutiple]: D

LWPalyline
Color Color150
Layer 0

Linetype Bylayer

peciy first chamfer distance <50.00003: 70
pecty second chamfer distance <70.0000>: 70
elect first line or [Undo./Poiyline, Distance/Angle.Trim/mEthod/Mukiple]
elect second line or shift-select to apply comer.
mmand:

LWPolyline
.| Color Color150

Layer 0

Command Line

(Command: CHAMFER
Trim'" mode) Current chamfer Dist1 = 5.0000, Dist2 = 5.0000

[Select firs Ine or [Undo/Polyine/ Distance./Angle/Trm/mEthodMutiple]: D
|Speciy first chamfer distance <5.0000>: 5

ISpeciy second chamfer distance <5.0000>

(Select firs line or [Undo/Polyine/Distance/Angle/Trim/mEthod/Muitiple]: P
[Select 2D polyine:

[7lines have been charfered

[Command

Linetype Bylayer

You can create a fillet using FILLET command. This command can apply to the objects such as arcs, circles, ellipses, lines,
polylines, rays, splines or construction lines. A fillet is an arc that connects two objects smoothly and has a specified radius.
An inside comer is called a fillet; an outside comer is called a round. Before creating fillets, you should ensure the distance
between each vertex is long enough to accommodate the fillet radius in order to insert a fillet arc. When the fillet radius is set to
0, no fillet arcs are inserted. If two polyline segments are separated by one arc segments, system deletes this arc segment and

extends the lines to intersect with each other.
To fillet two objects:

1.Choose Modify > Fillet from the main menu.
2.0n the command line, type R (Radius).
3.Specify the fillet radius.

4.Select the first and second object.

Boeeeee [ o

Command Line

{Command: “Cancel*

Command: FILLET

Cument settings: Mode = Trim, Radius = 0.0000

(Select first object or [Undo/Polyline/Radius/Trim/Muttiple]: RADIUS
(Specify fillet radius <0.0000>: 30

(Select first object or [Undo./Polyiine/Radius/Trim/Multiple]

(Select second object or shift-select to apply comer:

Command

ICommand
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To fillet an entire polyline:

Command Line

(Command: FILLET
Bloceaneeesed = Curent settings: Mode = Trm, Radus = 30.0000
. . . : H iSelect first obiect or [Undo//Poline/Radius/Tim/Mutiple]: R
1.Choose Modify > Fillet from the main menu. - Spoty i e 300000 9
: : ‘Select first object or [Undo//Polyine/Radius/Trin/Mutiple]: 8
. . : : nvald selection”
2‘O|’] the Command ||ne type P (P0|y||ne) i B----m Expects a poirt or Window./Last/Crossing/BOX/Fence/WPalygon/CPolygon/Alte/Undo/Po
’ ; H vine,/Radius/Trm,/Multiple
3 S | tth | | ; H ISelect first object or [Undo/Polyine /Radius/Trim /Multiple]: P
: H iSelect 20 polyine:
-O€IEC € pO y Ine. B B 17 lines were filted
[Command:

To fillet selected vertices in a polyline:

Command Line

1.Choose Modify > Fillet from the main menu. e
. . . ’(‘4 “-‘ elect first ab?em or [Ur\rdo/Pa‘M\ne/R;d\u:ﬁnm/Muhlp\e]: RADIUS
2.Select one polyline segment where you want to begin the fillet. L e s s
.’E " [Gelect second abject or shit select to apply comer:
3.Select the other polyline segment where you want to end the L oty e [EE [
fillet.

7.16.1. Trim and Extend Filleted Objects

While performing fillet, you can select Trim option to decide whether the
selected edges are extended to the endpoints of fillet arcs. By default, all
objects except of circles, ellipses, closed polylines and splines are trimmed FILLET>TRIM>TRIM FILLET>TRIM>NO TRIM
or extended when performing filleting.

7.16.2. Fillet Line and Polyline Combinations

LWPolyline
Color Magenta

If the objects to fillet are a line and a polyline, the line or its extension must
be intersecting with one of the polyline segments. With Trim option on, the
filleted objects join with the filleted arc to form a new polyline. pUNE& LINE L] PLINESLINE

7.16.3. Fillet Parallel Lines

You can fillet parallel lines, rays, and infinite lines. The first entity must be a '
line or ray, the second entity can be a line, ray, or infinite line. The diameter of  =———————

the fillet arc is always equal to the distance between the parallel entities. The PARALLEL PARALLEL
current fillet radius is ignored. LINES LINES FILLETED

7.16.4. InvertFillet

Invert Fillet has a very wide range of usage particularly in construction and
furniture industry. The FILLET command now offers a new option called
Invert. You can create a reverse fillet by this option.
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7.17.  Disassociate Compound Objects

You can convert a complex entity, such as a block or polyline, from a single entity into its component parts. Exploding a
polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual line and arc entities that you
can then modify individually. Blocks are converted to the individual entities, possibly including other, nested blocks that
composed the original entity.

Pr o X 04 Drawingldwg X 13

_ EEH
( - oo
olyline Eber i
e Autrnce Loy M = m Vit
& ; i -
Linetype “Mutiple™ ! - H
Linetype scale |1 i R el
Plot Style BYCOLOR o
e EXPLODE EXPLODE EXPLODE EXPLODE
L= PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES
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d 2 % |4 Drawingldwg X 3
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feakic PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES
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With the following exceptions, exploding an entity usually has no visible effect on a drawing:

-If the original polyline had a width, the width information is lost when you explode it.

-If you explode a block containing attributes, the attributes are lost, but the original attribute definitions are retained.

-Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they will
adopt the default color, linetype, lineweight, and print style until inserted into another block.

7.18.  Modify Polylines

Objects such as rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, cylinders, and
spheres, are all editable polylines. To modify a polyline, perform PEDIT command. The available options vary depending on
whether the selected polyline is a two dimensional or three dimensional object. If the selected object is not a polyline, the Edit
Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or lines
are joined endpoint to endpoint, they can all be selected and turned into one polyline.
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Properties & X 14  Drawingldwg
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7.19.  Modify Multilines

You can use the methods such as common editing commands, a multiling editing command and multiline styles to edit
multilines or their elements. You can use MLEDIT command to add or delete vertices for a multiline, to control the way two
multilings intersected (cross and T shape that can be closed, open or merged), to add multiline style or set multilines from the
existing multiline style, such as the number of elements, color, linetype, lineweight and the offset of each element.

To use a tosl, chck on the icon. Object sslection must be padommed after the tool has been ‘
selected

Muliines Edt Tools

mim [ == T
W i = Il
Clased Cross Closed Tee Comer Jont Gt Single D
L == || i ” Ll
A L il I
Opan Cross. Opan Tes Add Viertex Cunm
L — M ]| =
= = [}
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[ oo Hep

7.20.  Clip

The new CLIP command clips a block, external reference, image, viewport, and underlay (PDF or DGN) to a specified boundary. It can be
used to replace XCLIP IMAGECLIP VPCLIP PDFCLIP DGNCLIP commands.

7.21.  Add selected

You can use this function to create a new object of the same type and properties (such as colors, layers, lineweight, linetype
and scale factor) as selected object but with different geometric values.

For example, creating objects based on selected circles uses the general properties of the circle, such as colors and layers, but
prompt you to enter the center and radius of the new circle.
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Steps to use ADDSELECTED

1. Select the object which the new object bases on.

2. Right-click and select "Add Selected".

3. Create an object similar to the selected object according to the prompts.

722, Multiple

Executes a command repetitively, avoiding press enter or space bar key. Because this command only repeats command names,

all parameters must be specified each time. If we want to draw more than one circle, you can enter MULTIPLE, knock down
“ENTER”, and then enter the CIRCLE, “ENTER”, you can draw a circle without the need to press the call to repeat the circle of
the order in the process.

7.23.  Setby layer

Changes the property overrides of the selected objects to ByLayer including color, linetype, lineweight, and materials.

7.24.  MKSHAPE Command

The MKSHAPE command creates a shape definition based on selected objects. You can create custom linetypes easily. If you
create a shape that exceeds 2200 bytes of data, MKSHAPE creates complex geometry shapes to form a single shape.

1. Create a polyline object like a line, rectangle, circle or a closed object.
2. Type MKSHAPE command to save a .shp file with a proper name for your shape.

=
3. Enter the name of the shape and input a resolution value (lower value input equals polyline shape degraded, higher value
input equals similar shape as original polyline selected).

4. Specify an insertion point in drawing area, select the polyline created and press Enter.

5. If you want to insert the created new shape, execute SHAPE command and input its name.

6. Specify an insertion point, scale and rotation.
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8. Notes and Labels

8.1. Create Text

Create text, multiline text (mtext) and text that includes one or more leader lines.

8.1.1.  Single-Line Text

You can use TEXT command to create a single or multiline text. Each line text is an independent object which can be modified.
Before typing text, you can specify the text style and the way to align at the prompt of creating text.

Press ENTER if you have typed some characters, and then the command line prompts to input characters for the next row of text.
While creating single line text, you are also enabled to extend or compress certain single line text object in specified space to
meet with your need by means of selecting Align or Fit option from the TEXT command line prompt.

To create text:

1.Choose Draw > Text > Single Line Text from the main menu.
2.Specify the start point for the text.

3.Specify the height of the text.

4.Specify the text rotation angle.

5.Type the text, and then press Enter at the end of each new line.
6.To complete the command, press Enter again.

To specify the line text alignment:

1.Choose Draw > Text > Single Line Text from the main menu.

2.0n the command line, type J (Justify) and press ENTER.

3.Type an alignment option BR to align text at its bottom-right comer.
4.Type the text, and then press Enter at the end of each new line.
5.To complete the command, press Enter again.

8.1.2.  Multiline Text

Multiline text consists of one or more lines of text or paragraphs that fit within
a boundary width that you specify. When you create multiline text, you first
determine the paragraph's boundary width by specifying the opposite corners
of a rectangle. The multiline text automatically wraps so that it fits within this
rectangle. After defining the text frame, the system opens the In-Place Text
Editor, which is comprised of a text frame and the Text Formatting toolbar.
You can type text in the text frame and change the style from the Text
Formatting toolbar.

Command Line

Command: TEXT

Cumrent text style: "Standard” Teat height: 8.3532 Annotative: No
Specify start poirt of text or [Justify/Style]:

Specify height <8.3532> 5

[Specify rotation angle of text <0>:

IR :
m

‘Command Line

ISpectiy start point of text or [Justy/Style]: JUSTIFY

Enter an option [Align/Fit/Center/Middle,/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]: BR
ISpecfy bottom-right poirt of text:

{Specify height <5

|Specify rotation angle of text <03

ICommand!

i
7

o

Ultiline
Text sample

5]

‘Command Line

Command: MTEXT

Current text style: "Standard” Text height: 5 Annotative: No

|Specify first comer point:

Specify opposite comer or [Height /Justification./LinespacingRotation/Style Widt
h/Column):

97



Chapter 8 Notes and Labels

To create multiline text;

1.Choose Draw > Text > Multiline Text from the main menu.
2.Select the first and second corner of the text area.

3.In the Multiline Text window, type the text you want.

4 To create paragraphs, press Enter and continue typing.

Remark: Other text features please refer to the express tool guide.

On the toolbar, make format changes as follows:

1.To change the font of the selected text, select a font

from the list.

2.To change the height of the selected text, enter a new ﬂj“

value in the Height box.3.To apply color to the selected B () 1+
text, choose a color from the Color list. Multi: MULTILINE

4 Click OK on the toolbar or Press <Ctrl + Enter> Text Sample

Justify Multiline Text: You can specify the attachment point at the top left, top

center, top right, middle left, middle center, middle right, bottom left, bottom

center, or bottom right. The multiline text can flow left to right, right to left, top to —
[ et

bottom, or bottom to top. I !I\’i!;iﬁ-,Tlﬁ.,!NE‘ ‘

Format Characters within Multiline Text: During creating multiline text, you can
assign a new value to the selected objects to overlap the default setting. You can

MICEIEE

(BIZ[T T v ~ & WA

specify underlines, bold, color and fonts for a single or multiple characters, or > Uil
different text height. [0
e
Indent Multiline Text and Use Tabs: You can control the appearance of text objects | S ————— i
and create a list by specifying the tap stops and indenting text. The arrowheads MUL TILINE
on the ruler are used to define the indent of text (first line and paragraph). .

Specify the Line Spacing: The line spacing of multiline texts is the distance
between the baseline of one line of text and the baseline of the next line of text. [Bded =

28 Days Later =J2s5 -B I
You can right-click in the textbox and choose Paragraph to specify the desired — — B« asieu
line space when the cursor stays on the text frame. LTHIN o
SPACING
T
Create Stacked Characters: Stacked text is text or fraction applied to mark

icode MS 25 *+B J UGwv v & HBue

tolerance or measure units. Before creating stacked text, you have to use special =] [t mi| @ 00f 2| sn[lsc ]
characters to indicate the stacked place for the selected text. The following Im

| | ' | | | | '
contents present the special characters and illustrate how to create stacked text: Stacked 1/4

1
Stacked 4

! 4D|

=)
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-Slash (/): Stacks text vertically and separates them with a horizontal line.
-Pound sign (#): Stacks text diagonally and separates them with a diagonal line.-Carat (~ ): Creates a tolerance stack, which is
stacked vertically as well as not separated by a line. You can also use Stack button on the toolbar to create stacked text.

8.2, Work with Text Styles

The text style is applied to the text objects. You can use text style to control the text font, size, angle, direction and other
features. By default, the current text style is STANDARD, and you have to make other text styles current when you want to apply
them. The STANDARD text style has the following default properties:

(G Tetstyte
Current text style:  Standard
= Font
,ﬁ\-ne Fort Name: Font Style:
) (i 5 (Geats 2
[ Use Big Font
Size
I [ Annotative Height
[] Mateh text 0.0000
orientation to layout
[M’“ﬂ v] Cument Style Name
Upside down Width Factor:
1.0000
| Aa B b C C Backwards Obligue Angle:
[] Vertical 0
[y | [Ccamee ] [ b |
To create a text style: @ e .
Curment text style:  Style 1
L o
H natative Font Name: ont Style: —
1.Choose Format > Text Style from the main menu. S i) EE 5 e
2.Click New, type a new text style name, and then [ e Big Fort
click OK. ' [ —
3.Under Text Measurements, specify the Text Height, e
Al styles -
Width Factor, and Oblique Angle. e —
B 2.0000
4.Under Text Font, select the name, style, you want ARBOCe | B S
to use. [] Verical 30
5.Click Apply, and then click OK. [ | [ oo | [ e

8.3.  Create Leader /\/—‘ LEADER

8.3.1.  Leaders

ify next point or [Annotation/Format/Undo] <Annotation::
ify nead point or [AnnotationFormat/Undo] <Annotation::
next point or [Annotation/Format,/Undo] <Annotations: <ORTHO On»

A leader is a line or spline with arrowhead at one end, and fy et peinl or [nnotation/Fomat/Undol <Annatation>:

next point or [Annotation/Format,Undo] <Annotation::

annotations (Mtext, blocks as well as tolerance) at the other end. e
Fummand.
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Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is placed immediately adjacent to
the last point.

To create a leader and an annotation:

1.Choose Dimension > Leader from the main menu.

2.Specify the starting point of the leader.

3.Specify the endpoint of the leader line segment.

4.Specify additional leader line segment endpoints.

5.After you specify the last endpoint, press Enter.

6.Type the annotation, and press Enter to enter the next line of annotation text.
7.Press ENTER to complete the command.

8.3.2.  Mleader

Multileader is used to attach annotation to multiple leader lines. Multileader could be used to give additional information or
special instruction in a point or specific area on your drawing .It also has more capabilities like using multiline text or blocks as
leader content in our drawing. This version supports the complete multileader set options like Add Leader, Remove Leader,
Align and Collect.

84.  Modify Text

8.41.  Change Text

All of text objects can be moved, rotated, deleted and copied, just as like other objects. You can change the properties at the
Properties panel. You have two methods to modify single-line text:
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-To modify only the content of text, use DDEDIT command.

-To change text style, location, size and content, use PROPERTIES command to open Properties palette, from which, you can

make the relevant settings.
To edit single or multiline text:

1.Type DDEDIT and then press Enter.

2.Select the single line or multiline text.

3.If select the single line text, the Edit Text box will pop up, edit the text and then press Enter.

4 If select the multiline text, the In-Place Text Editor will pop, edit the text according as you need.

Text Formatting

[ Standard | @#rial Unicode MS |25 +B J UG & BRd - | [=] ox | ®|

==l mm @ o ] =f o |1 |

)

[Select an annotation object or [Unde].
ISelect an annotation object or [Undo]: "Cancel™ E
Command: DDEDIT

[Select an annotation object or [Undo]

To change single or multiline text properties: Yodify ®

Repeat U
Recent Input
2 Mtext Edit...

1.Select a single line or multiline text object.
2.Right-click the selected object and then click Properties on the shortcut menu.

Clipboard

(7 Erase
. . 4 Move
3.In the Properties palette, enter any new text in the Text Contents, and then change % Copy Selection
2| Scale
formatting and other properties as needed.4.You can also do double-click on the multiline i
text to open the In-Place Text Editor, from which, you can modify the contents and formats of v
Deselect All
teXt. [ QuickSelect..
@ QuickCalc
@ Find...
Poete %
R
I ] 8 m
Contents MODIFY
Sple NEW STYLE SAMPLE Hypedrk
: " e, "
idth factor ntents {\f@Anal Unicode
M l y o ;‘ﬁm S;e :::l;:m ‘@Azl Unicode MSb
‘ }é ; ! st Justy MC
E E= ‘m Direction By syle
: E‘:E . Q Test height
Line space factor 1
z fnn Line space distance 83333
: EW = Line space style At least
= = = mask No
Upside down No Defined with 224358
| Backward Mo Annctative No
Defined height 11.379
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9. Dimensions and Tolerances

Dimensions indicate the measurement values of objects (e.g. length or width), 3 1
distance or angles among objects, or the distance between feature point and the \ /
specified origin. You can create five basic types of dimensions: linear, angular, radial, 28

diametral and ordinate. Dimensions have several distinct elements: dimension text,
dimension lines, arrowheads, and extension lines.

1.Dimension text: A character string that usually indicates the measurement value, 4

includes prefixes, suffixes, tolerances, etc.

2.Dimension line: Indicates the direction and extent of a dimension. For linear dimensions, it displays as a line, for angular
dimensions, it displays as an arc segment.

3.Arrowhead: Usually displayed at both end of the dimension line. You can specify various sizes and shapes for arrowheads or
tick marks.

4 Extension lines: Extend from the object to the dimension line, in order to define dimension ranges.

9.1. Create Dimensions

You can create dimensions by selecting the entity to dimension and specifying the dimension line location, or by specifying the
extension line origins and the dimension line location.

9.1.1.  Horizontal and Vertical Dimensions

As you create linear dimensions, the system automatically applies a horizontal or
vertical dimension depending on the specified extension line origins or the O:Fq -

location where you select an object. However, you can create a dimension by ‘ j — | -
specifying it be horizontal or vertical. 60 5
Horizontal
To create a horizontal or vertical dimension: o
I b
o

1.Choose Dimension > Linear from the main menu.
2.Press Enter, and then select the object to dimension. Or, you can specify the first and second extension line origins.
3.Specify the dimension line location.

9.1.2.  Create Aligned Dimensions

In the aligned dimensions, the dimension line is parallel to the line passing
through the extension line origins. The aligned dimension is also parallel to the
objects you specify. The system creates the extension lings automatically.

To create an aligned dimension: \

1.Choose Dimension > Aligned from the main menu.
2.Press Enter, and then select the object to dimension. Or, you can specify the first and second extension line origins.
3.Specify the dimension line location.
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9.1.3.  Create Baseline and Continued Dimensions

Both baseline and continued dimensions are multiple linear dimensions. Baseline dimensions are measured from the same
baseline and continued dimensions are placed end to end. Before creating either baseline or continued dimension, you have to
create a linear, aligned, or angular dimension.

To create a linear baseline dimension:

60
1.Choose Dimension > Baseline from the main menu. 40 C
2.Specify a second extension line origin3.Select the next extension line origin. 20 B
4 Continue selecting extension line origins as required. A
5.To end the command, press Enter twice.
To create a linear continued dimension:
1.Choose Dimension > Continue from the main menu. 20 17 18
A B C

2.To select a starting dimension, press Enter.

3.Select the next extension line origin, and then press Enter. Or press Enter, and
then select an existing dimension to continue.5.To add continued dimensions,
continue selecting extension ling origins.

6.To end the command, press Enter twice.

0
9.1.4.  Create Rotated Dimensions
You can create rotated dimensions at a rotated angle you specify using DIMLINEAR

Rotated option. An example of a rotated dimension is shown in the following illustration.
In this illustration, the specified angle of the rotated dimension is equal to the angle of the slot.

9.1.5.  Create Angular Dimensions

Angular dimensions are used to measure the angle between lines or three points. You can dimension objects including circles,
arcs, and lines. When you create the angular dimension, you can modify the text contend and alignment before placing the
dimension line. 970

To dimension an angle between two lines:

1.Choose Dimension > Angular from the main menu.
2.Select one line.

3.Select the other line.

4.Specify the dimension line location.
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To dimension an angle encompassed by an arc: 161°

1.Choose Dimension > Angular from the main menu.

2.Select the arc. ;ﬂé

3.Specify the dimension arc location.

9.1.6.  Create Radial Dimensions

You can create radial dimensions for circles or arcs to measure their radial. The radial
dimension is a line with an arrowhead that points to a circle or arc.

To create a radial dimension:

1.Choose Dimension > Radius from the main menu.
2.Select the arc or circle.
3.Specify the dimension line location.

9.1.7.  Jogged Dimension

Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension". User can specify center
position to place the origin of dimension for replacing center point of circle or arc within radius dimension. DIMJOGGED
command is useful for creating dimensions in case that the center of circle or arc to be dimensioned is located outside the
layout and can't be displayed in its actual position either.

To create a jogged radius dimension: \

1.Choose Dimension > Jogged from the main menu.

2.Select a circle or an arc. Q_’L
3.Select center position as the dimension origin.

4.Specify a point to position the jog symbol.

9.1.8.  Create Diameter Dimensions

You can create diameter dimensions for circles or arcs to measure their diameters. Creating diameter dimensions resembles
creating radial dimensions. You can create various diameter dimensions based on the location and size of circles or arc, and the
settings of the dimension style.

To create a diameter dimension:
1.Choose Dimension > Diameter from the main menu. (DM‘

2.Select the arc or circle.
3.Specify the dimension line location.
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9.1.9. Create Ordinate Dimensions

Ordinate dimensions are used to measure the perpendicular distance from an origin point called the datum to a feature, such as
a hole in a part. Ordinate dimensions are comprised of a leader line with an X or Y value, and leaders are drawn along the
orthographic direction at the current UCS.

3 3 3 2

To create an ordinate dimension: P iy
. . . . 1733,84 / |

1.Choose Dimension > Ordinate from the main menu. 1726,27 rall gy
2.Select the point for an ordinate dimension. 1715,97 S I ‘ |
3.Specify the ordinate leader endpoint. 1706.16 -
9.1.10. Create Quick Dimension
Creates or edits a series of dimensions quickly by typing QDIM command.
To create a quick dimension; 20 17 18
1.Choose Dimension > Quick Dimension from the main menu.
2.Select the geometry to dimension, and then press Enter. \8
3.0n the command line, it will display "Specify dimension ling position, ®
or[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint
/Edit/seTtings] <Continuous>:".You can perform the operation as e e o
desired. The default is Continuous. i o

9.1.11. Create Arc Length Dimension

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. GstarCAD creates arc length
dimension by specifying extension line position directly after selecting arc by default. And use an arc symbol as arc length

dimension, which is differing from linear dimension and angular dimension. 26
To create an arc length dimension:
1.Choose Dimension > Arc Length from the main menu.
2.Select an arc or polyline arc segment.
3.Specify a point to position the arc length dimension.
9.1.12. DIMREASSOCIATE — B M &N -4 -0 Drating - 3

5

/ Home Insert Annotation 3D Surface Mesh Layout View M

You can input DIMREASSOCIATE command to A Tud L F kv i ey i el

, , R A AT e AR T o FH S A
associate or reassociate selected dimensions to Mitext g . ||| oimensio o

objects or points on objects.

Text ] Dimension
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After enabling the DIMREASSOCIATE command, you will be prompted to choose
associating particular dimension objects or associating all disassociated objects in the
drawing one by one.

[~ Select objects or D
Disassociated

It you select Disassociate option
All of dimensions that have any disassociated defining point with geometries in the drawing will be selected to associate or
reassociate one by one. You can press ‘Esc’ to stop the command, but associations you have made will be kept.

If you select any dimension objects
> When the defining point of selected dimension object doesn’t associate with the geometry, the X mark is displayed.

71 Specify first extension line arigin or | EEREFETRVTEXNTE

» When the defining point of the selected dimension object associates with the geometry, the X mark is displayed.

-If you press Enter or select ‘Next’ option, you are able to skip to the next extension-line origin point."

[1 Speciy first extension line origin or | [FRREFCRECFRPL]
nexi |seretotset

-If you select ‘Select object’ option, you are able to select a geometric object to associate with the dimension.

-If you press ‘Esc’, you will stop the command, but associations you have made will be kept.

9.2, Use Dimension Styles

You can control the appearance of dimensions by changing settings to help maintain dimensioning standards, you can store
these settings in dimension styles.
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9.21.  Dimension Styles

You can create, save, restore, and delete named dimension styles. Dimension styles provide a way for you to change various
settings that control the appearance of dimensions. You can change the following settings:

-Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between them.

-The positioning of the parts of the dimension in relation to one another and the orientation of the dimension text.

-The content and appearance of the dimension text and units of the dimension value.

To create a dimension style:

1.Choose Dimension > Dimension Style from the main menu.
2.In the Dimension Style Manager dialog box, click New.

3.Type the name of the new dimension style, and choose which
style started with and what kind of dimension used for. Then click

Continue.

5.In the New Dimension Style dialog box, change the dimension
settings as necessary. Repeat this step for each tab, as needed.

6.To end the command, click OK.

To rename a dimension style:

1.Choose Dimension > Dimension Style from the main menu.
2.In the Styles list do one of the following:

-Double click the required style.
-Right click on the required style
Rename.

3.Type the new name.

4.Click Close to exit.

name, and then choose

List:

Dont list styles in Xrefs

G Dimension Style Manager =
Currert: Dim Style: 1S0-25
Siyles Preview of: 150-25
!
Annoty™ Current
A 1502| G Create New Dimension Style e .
Standj
Now Sl Nore =
[Copy of 150-25] Cortinue lodiy
150-25 -
[ ] = mpare..
[F] Annotative ;]D
Use for:
List [ A1 dimensions -]
Al styles
Dont list styles in Xrefs
e
G New Dimension Sy newam e oz
Lines | Symbols and Arows | Text | Adjust | Pimary Units | Atemate Unts | Tolerance | |
Dimension Lines
Color 14,11
e
o 5
Lineweight ByBlack ~ i @O
o
Extend beyond ticks: : ’ ‘
Bassline spacing: 375 = fs)
e
Suppress: [] Dim line 1 [] Dim line 2
Edension lnes
Color M ByBiock ~|  Bdend beyond dimlines 125
= Offsetfrom arigin s -
Lrspeocine 2
[ Fixed length extension lines
Lineweight: ByBlock =
Length: 1
Suppress: [ Ext line 1 [ Edline 2
| [ok ] [ cancel | [ Hep
G Dimension Style Manager =
Curent Dim Style: 1S0-25
Siyles: Preview of: Standard
A Annotative Set Current
10-25
Set Current | 10159
[ faname — -,
Delete 11955 -
@ 20208 Qveride...
&0
\
RO.5045

Description

150-25 + Altemate precision = 2, Atemate
ratio factor = 25 4000. Attemate tolerance
precision = 2, Amowhead size = 0.1800,

Close

Help
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To delete a named dimension style

1.Choose Dimension > Dimension Style from the main menu.
2.In the Styles list, right click on the required style name, and then
choose Delete.

3.Click Close to close.

To display information about the current style:

& Dimension Style Manager [
Curert Dim Sty 150-25
Styles Preview of: Standard
A Annotative Set Current
15025
i Set Current Loisa =
Rename T /\
o5
Delete @ 20208 Qveride
&0°
N
RO.8045
List Desciption
150-25 + Atemate precision = 2, Atemate
es 7] ratio factor = 25,4000, Atemate fokerance

precision =
Dont it styles in Xrefs

2, Amowhead size = 0.1800,

(& Compare Dimension Styles @1
1.Choose Dimension > Dimension Style from the main menu. T [ -
2.In the Dimension Style Manager dialog box, click Compare. ) 2
3.In the Compare Dimension Style dialog box, choose the same ST e
B . B . . Description Variable Standard  NEW STYLE
dimension style from the Compare and With pulldown list. All properties Cor of mensonine. DWCLRD  ByBock B
for specified dimension style will be displayed. e DMy e
. . . Ext line color DIMCLRE  ByBlock Green
4.If you want to know the different information between two styles,
choose one style in the Compare box, choose the other in the With box,
and then you will see difference in the following tab. =
5.Click Close to close.
G Medify Dimension Style: NEW STYLE @‘

922 MOdIfy D|mens|0n Llnes Lines | Symbols and Arows | Ted | Adjust | Primary Units | Atemate Unis | Tolerance |

Dimension Lines

s
On the Line tab of the Modify Dimension Style dialog box, you can b = = i iy /\

. o ) ) ) Linewaht 11955

set the color of dimension lines, lineweight, ticks beyond extend Etend beyond s 5 I @ . E‘Dﬁi
line, baseline spacing, and visibility. gz s = e

Suppress [ Dim line 1 [ Dim line 2

Extension lines
9.2.3.  Modify Extension Lines Gobor Btend beyorddmines: 018

Linetype ext ine 1: S fomongi o B

Uity o e >

[] Fixed length extension lines

Extension lines have the following properties: color, lineweight, et — _— ;

Suppress: B line 1 [ Ext line 2
distance beyond extension lines, offset from start of extension lines,
and visibility. You can set these properties on the Line tab of the
Modify Dimension Style box: T S |

-The distance beyond extension lines means that how far the

extension lines extend beyond the dimension line.

-Start offset is the distance between the extension line origin and the start
of the extension line, also called extension origin offset.

9.24.  Choose Dimension Arrowheads

You can control the appearance and size of arrowheads or hook marks
placed at the ends of dimension lines. You can specify different arrowheads
for both ends of a dimension or leader lines. The First arrow is toward the
first extension line; The Second arrow is toward the second extension line.

G Modify Dimension Style: NEW STYLE

Symbols and Arows [Ted | Adust | Primar

ry Units | Altemate Units | Tolerance |

Amows

B Closed filed -
Leader.
89 Closed filed -

Amow sice:
018 =

Center marks
O Nene:

© Mark

© Line

Dimension Break

Break size:
375

10159

11955 /\
20208
&0° >
RO.B045

Arc Symbol
(©) Preceding dmension text
(©) Above dimension text

© None

Radius jog dmension
Jog angle: 5
Linearjog dimension

Jog height factor

15 ~ Text height

oK | [ Cancel | [ Hep
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To choose an arrowhead:

1.Choose Dimension > Dimension Style from the main menu.

2.In the Dimension Style Manager dialog box, select the style you want to change and click Modify button.
3.In the Modify Dimension Style dialog box, click the Symbols and Arrows tab.

4. Make your selections under the Arrowheads.
5.Click OK and then choose CLOSE to exit.

9.2.5.  Fit Dimension Text within Extension Lines

When there is no enough space between extension lines to accept
both of dimension text and arrowheads, you have to adjust one or
both of their placement. By default, the system fits them best
depending on the available space. You can specify other methods
to place them on the Adjust tab of the Modify Dimension Style
dialog box.

To format dimensions:

1.Choose Dimension > Dimension Style.

2.In the Dimension Style Manager dialog box, select the style you
wish to change and choose Modify.

3.In the Modify Dimension Style dialog box, click the Adjust tab.

G Modify Dimension Style: NEW STYLE

| Lines | Symbols and Amows | Text | Adiust | Primary Units | Atemate Units | Tolerance |

Fit options

 thers isnt enough room to placs both text and
amows inside extension lines, the first thing to
move outside the extension lines is:

10159

@) Either text or amows (best fit)
Amows

11355

) Both test and amows RO.28045

%) Aways keep text between et lines

[7] Suppress amows if they dont fit inside Scale for dimension features

[ Annotative

Text position ) Scale dmensions to layout

& 1.0000
When text is not in the default position, place it @ Use overall scale of

@) Beside the dimension line Fine Tuning
[ Place text manually

[] Draw dim line between et lines

) Over dimension line, with leader

) Over dimension ine, without leader

o RO /\>

[ cancel | [ Hep

4.Under Fit Options and Text Placement, select an option.5.Click OK and choose Close to exit.

9.2.6.  Fit Diameter Dimension Text

You can create various diameter dimensions based on text placement, fit options and the selection of "Always keep text between

ext lines" option on the Adjust tab. r

Modify Dimension Style: new dim style

Fit options
if there isn enough room to place both text and
amows inside extension lines. the first thing to
move outside the extension lines is

Etther text or amows (best fit)

Amows

Text

Both text and amows

[ @ Pivvags Koep tesd between o ines ]

Suppress amows f they don! fit inside

@37

Default horizontal User defined horizontal
placement text outside
circle, center mark,

no forced interior line forced interior line

placement dimension line
and arrows, no center mark,

Lines ISyvrbolsa\dMows]Tea Adjust | Primary Units | Atemat

L 166

Scale ford

Text and arrows inside
with inside horizontal
option selected
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9.2.7.  Align Dimension Text

Whether the text is inside or outside the extension
ling, it has no effect on the justification of dimension

text. You can choose whether the text is align with the

dimension lines or remains horizontal.
To align dimension text with the dimension line:
1.Choose Dimension > Dimension Style.

2.In the Dimension Style Manager dialog box, select
the style you wish to change and choose Modify.

3.In the Modify Dimension Style dialog box, click the

Text tab.
4 Make your selections.
5.Click OK and choose Close to exit.

9.2.8.  Position Dimension Text Vertically

The vertical text placement is the position of the
text relative to the dimension. You can place text
above, below, or centered within the dimension
line, or use the JIS dimensions.

9.29.  Position Dimension Text Horizontally

The position of text along the horizon is relation

to the extension lines. The settings include

Centered, At Ext Line 1, At Ext Line 2, Over Ext Line1, and Over Ext Line2.

9.2.10. Dimension Units

You can determine the appearance and format of the
primary and alternate dimension units. You can set
the primary units for linear and angular dimensions,
including unit format, numeric precision and so on.
These settings control the display of dimension
values.

Lines | Symbols and Arows | Tet | Adiust | Primary Units | Atemate Units | Tolerance |
Text appearance
Text sty Standard ~ =]
Text color: MW Red | !
Fill color: MGreen |
Teot height 25 =
Fraction height scale: 1 [5E]
[/] Draw frame around text Text aligrnment
Teat position ® Horizoridl
Vertical: Center -
(@) Aligned with dimension line
Horizontal Corter -
View Drection Fromeft o fight L] ©150 standard
Offset from dimline: 265 =
[ok ] [ comcel | [ Hep =
Lines | Symbols and Arows | Text | Adjust | Prmary Units | Atemate Units | Tolerance |
Text appearance
Text style: Standard -|=) I
Text color: BWRed -
Fill color, MGreen -
Text height: 25 T -
Fraction height scale 1
Draw frame around text Text alignment
TipE © Honzortal
Vetical Up v
) Aligned with dimension line
(e Over Ext Line 1 -
View Direction From fightto et L] ©1S0standard
Offset from dim line: 085 =
oK | [ Gamcel | [ Hep -
Lines | Symbols and Arows | Text [ Adjust | Primary Units | Atemate Units | Tolerance |
Linear Dimensions.
Ut formet: ﬂ.
Precision:
Fraction format:
o
Round off: I
Prefix:
Suffic Angular dimensions
Measurement scale Rt Formet Decimal Degrees - /ﬁ
Scale factor: 1
=
[ Apply to layout dmensions orl ly = S5
Zero suppression Zero suppressi
[T Leading Trailing [[Leading
Sub-units factor: s [l Triing

100

0lnches

Subunit suffx:

[ cames | [ e
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To round off dimensions;

1.Choose Dimension > Dimension Style from the main menu.

2.In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify.

3.In the Modify Dimension Style dialog box, click the Primary Units tab.

4 In the Linear Dimensions and Angular Dimensions fields, type or select the nearest value to which you want to round off
dimensions.

5.Click OK and choose Close to exit.

9.2.11. Alternate Units

You can create a dimension in two systems of measurement simultaneously in a drawing. This feature is helpful when you want
to add feet and inches dimensions in a drawing created using metric units. The alternative units appear in a square brackets ([])
in the dimension text. Alternative units can be applied to linear dimensions only.The precision for alternate units determines the
number of decimal places.

To create an alternate dimension: - : ——

Lines | Symbols and Arows | Text | Adiust | Prmary Uns | Atemate Units | Toirancel
Display aktemate urits
1.Choose Dimension > Dimension Style. o =
2.In the Dimension Style Manager dialog Precion
box, select the style you wish to change — R f _—
and choose Modify. - ~ [ae
3.In the Modify Dimension Style dialog box, me © Py v —
click the Alternate Units tab. Bluwo 7 Teing B
4.Click the Display Alternate Units check W .
box.
5.Make your selections.
6.Click OK and choose Close to exit. ok ] [[Cmed ] [_ieb

9.2.12. Display Lateral Tolerances

Lateral tolerance represents a value that the amount a measured distance can vary. You can control the degree of accuracy
needed for a future by specifying tolerances in manufacturing. These dimension tolerances indicate the largest and smallest
permissible size. You can also apply geometric tolerances to indicate deviations of form, profile, location, orientation, and
runout.

Deviation tolerances represent with the plus and minus values that are appended to the dimension values. If the deviation
tolerances are equal, the = signs precede them and they are known as symmetrical. Otherwise, the plus value locates above
the minus value.
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The vertical placement of tolerance values that is relative to the main dimension text can be specified. For example, you can
align the tolerances with the top, middle, or bottom of the dimension text.

[ Lines | Symbols and Amows | Text | Adiust | Primary Units | Abemate Unes | Tolerance |

Tolerance format
b = 14,150
et [Symmetical -]
° arm SYMMETRICAL
J
Deviation |
D}

Precision: ‘

Limits.
Basic

1

Upper value

[ %
’ Y DEVIATION
i
Lower value 0 & +0,5
@\\?’ 24 -0,6 24+0,5
Scaling for height: 1 =

Aktemate unit tolerance

Frecsion L e 3T -
Zero suppression
Zero suppression Leading Dfest
[C] Leading 0 Feet Traing s Top MIDDLE DOWN
[¥] Trailing 0Onches

oK | | Camced | [ Hep - | | ‘ | ‘ |

9.2.13. Set the Scale for Dimensions

Setting dimension scale depends on the method you use to lay out and plot drawings. Dimension scale has effects on the size
of dimension geometry relative to the objects in the drawing. In addition to text height and arrowhead size, dimension scale

affects offsets in dimension as well, such as the extension line origin offset. When you create dimensions, it's recommended to
set the size and offset to values that represent their actual plotted size. However, the tolerances, measured lengths, coordinates,

and angles cannot be applied to the overall scale factor. The method of creating dimensions in a drawing layout is shown as
follows:

-Dimension in model space for plotting in model space. If you want to create dimensions that are scaled correctly for plotting,

you have to set the system variable DIMSCALE to the inverse of the desired plot scale. For example, if the plot scale is 1/4, you
have to set DIMSCALE to 4.

-Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled automatically for
display in a paper space layout, you have to set the DIMSCALE to 0. This method is useful when you encounter the following
situations: the dimensions in a drawing need to be referenced by other drawings (xrefs); when you create isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport from being displayed in other layout viewports, it's
recommended to create a dimensioning layer for each layout viewport that is frozen in all other layout viewports.

-Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by specifying object

snap locations on model space objects. The dimensions created in a paper space layout do not need additional scaling: there is
no need to change the default value of DIMLFAC and DIMSCALE.
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9.3. Modify Existing Dimensions

You can modify all components of the existing dimension objects in a drawing either individually or by using dimension styles.

9.3.1.  Modify Dimension Style

You can modify all of properties of the
existing dimension objects in a drawing

using dimension styles. You can also create a

dimension style override to temporarily
change a dimensioning system variable

without changing the current dimension style.

If a dimension style is changed, the
dimension associated with that dimension
style updates automatically.

9.3.2.  Make Dimensions Oblique

G Dimension Style Manager

Tolerarce fomal

Curent Dim Stye: new dm sofe
Stles

Frevew of: newdm e

e oo

15025
e dim sfe

Upper vaue:
~ Lowar valus
Sealing o height.

Vertcal pastion [Down

Extension lines are normally created at a perpendicular angle to the

dimension line. You can change the angle of the extension lines, however, so

that they tilt relative to the dimension line.

To make oblique extension lines:

1.Choose Dimension > Oblique from the main menu.
2.Select the linear dimension, and then press Enter.
3.Type the obliquing angle, and then press Enter.

G New Dimension Style: new dim style 2

Tethad: [Symmetncal

0

Linca | Symbola end Awrow | et | Acust | Pamary Unis | Abemate Unda | Tolerance

-
Lo
/

Ahemate unt tolesance

Frecaion:
Zaro suporession

[%l  Quick Dimension

[ Linear
%y Aligned
@ Arclength
'} Ordinate

() Radius

) Jogged

Baseline

Continue

Dimension Space

Dimension Break.

Leader
Tolerance..
Center Mark
Inspection
Jogged Linear

I TI@0B4 +H T

Oblique
Align Text 3

&, Dimension Style...

Express

7
-

Remark: To align the oblique angle if you don't know the exact measurement, use snaps to pick two points on the entity.

9.3.3.  Dimension Jogged Linear

The DIMJOGLINE command is available for adding or removing jog

symbol for linear dimensions. The jog symbol is default to be placed at

the center point between first extension line and text. To relocate jog
symbol, you can adjust the position of dimension text or specify new
position to locate jog after reselecting dimension.

To add a jog to linear dimension:

1.Choose Dimension > Jogged Linear from the main menu.

2.Select a linear dimension.

3.Specify a point on the dimension line to determine the jog symbol, or

press ENTER directly to position the jog symbol in default place.

[T Modiy Window Help Express
% Quick Dimension Help

[ Linear
%y Aligned

Express

52

4F  Arclength
‘L Ordinate

& Radius
?) Jogged
(% Diameter
4 Angular
|57 Baseline

P Continue

\f, Dimension Space
T Dimension Break
X Leader
Tolerance...

(¥) Center Mark
I Inspection

W\ Jogged Linear
}H Oblique

Align Text »

&, Dimension Style...

1=l Override
¥ Update
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9.3.4.  Dimension Inspection

Dimension inspection is created to transmit the frequency of inspecting the part being dimensioned, the dimension value and
parts tolerance are ensured to be within specified range. Dimension inspection is composed by a frame and internal text and
contains utmost three kinds of information field: inspection tag, dimension value and inspection rate.

Inspection tag, used for mark the text of dimension inspection is located at the left side within the inspection frame.
Dimension value is the value before adding dimension inspection, which is located at the central part of the inspection

dimension including tolerance, text and measurement value.
Inspection rate is expressed by percentage, which is located at the right side

within the inspection frame, indicates required frequency of the part being created.

To create an inspection dimension:

1.Choose Dimension > Inspection from the main menu.

2.In the Inspection Dimension dialog box, click Select Dimensions button.
3.Select dimensions to add dimension inspection, and then press ENTER to finish
selection and return to the dialog box.

4 Select a shape for frame from the Shape option.

5.Click Label option to input label in the text box.6.Click Inspection Rate option to
input a value in the text box.7.Click OK.

To remove an inspection dimension:

1.Choose Dimension > Inspection from the main menu.

2.In the Inspection Dimension dialog box, click Select Dimensions button.
3.Select dimensions to remove dimension inspection, and then press ENTER to
finish selection and return to the dialog box.

4.Click Remove Inspection button.

5.Click OK.

9.3.5.  Adjust Dimension Space

Inspection Dimension T
»_ﬁ Select dmensions
Shape Label/Inspection rate
© Round 100%, v Label
EXT
rogder GOX100R) =
¥ Inspection rate
None XXX 100%
9%
| OK J Cancel Help
(EXT[77,94[957

77,94

Once you have created multiple paralleled linear dimensions or angular dimensions, you can adjust the space among these
paralleled lines with an equal value either default or specified. DIMSPACE command adjusts the space among paralleled linear

or angular dimensions or overlapped

77,94

dimensions automatically in case that Py
the original space is not equal values. If B —
38,77 7
you set the space value to 0 when
adjusting space among dimensions, 7
you can align selected dimensions at %
the dimension line as well. 4L

77,94

46,08

40,69
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9.4. Add Geometric Tolerances

Geometric tolerances show acceptable deviations of form, profile, orientation, location, and runout of a feature. You add
geometric tolerances in feature control frames. These frames contain all the tolerance information for a single dimension.
Geometric tolerances can be created with or without leader lines, you can create them with TOLERANCE or LEADER
command.

@.505-.525
|4 @.0050|A[DM™|[B]
A feature control frame consists of two or more components. The &me -
first feature control frame contains a symbol that represents the Do et
geometric characteristic to which a tolerance is being applied, Zecjn‘dar;”;:"um
for example, location, profile, form, orientation, or runout. Form Primary Datum
tolerances control straightness, flatness, circularity and Niodiier
cylindricity; profiles control line and surface. In the illustration, ;’;:::;ym e
the characteristic is position. Z“‘:I' ;h'lzl
Symbol
9.4.1.  Geometric Tolerance Dialog Box
Specifies the symbols and values for a feature control frame.
1. Geometric Characteristics symbol (menu) 1 2 3 4 5 6
2. Tolerance Zone form (toggle) . ' | =
3. Tolerance zone value : v Kv v l l '
Sym Tolerance 1 Tolerance 2 Datum 1 Datum 2 Datum 3
4. Material condition symbol (menu) o ] T B e |
5. Datum reference 1 of 3 H N HE | m | | ‘
6. Datum reference 2 of 3 z [T oo 0 Projected Tolerance Zone: [ «— 7 |
7. Projected tolerance zone symbol (toggle) ==
8. Projected tolerance zone value (ox J[ concel J[ Heo |
9. Datum identifier l—— — = =
9.42.  Geometric Tolerance Symbols
The geometric tolerance symbols and their characteristics are shown in the following.
1. Position (Location) 8. Flatness (Orientation)
2. Concentricity or Coaxiality (Location) 9. Circularity or roundness (Form)
3. Symmetry (Location) 10. Straightness (Form)
4. Parallelism (Orientation) 11. Profile of a surface (Profile)
5. Perpendicularity (Orientation) 12. Profile of a line (Profile)
6.  Angularity (Orientation) 13. Circular runout (Runout)
7. Cylindricity (Orientation) 14. Total runout (Runout)
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1112 13 14

9.4.3.  Material Conditions

Depending on control type, you can add a diameter symbol prior to the tolerance value, and specify a material condition
symbol behind this value. You can apply material conditions to features that can vary in size.

9.4.4.  Datum Reference Frames

A datum reference consists of values and modifying symbols. A datum is a theoretically exact geometric reference that
measures and verifies a theoretically exact point, axis, or plane. The system provides up to three datum reference letters and
relative symbols followed by the tolerance value.

9.45. Projected Tolerance Zones

Projected tolerance zones control the height of the fixed perpendicular part of the extension area, and control tolerance
accuracy by positional tolerances. Before you set the symbol to projected tolerance zones, you set a height value to specify the
minimum projected tolerance zone.

9.46. Composite Tolerances

A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a feature or for features
that have different datum requirements. Before you create a dimension and add a composite tolerance for a drawing, you have
to specify the first line of a feature control frame and then choose the same geometric characteristic symbol for the second line
of the feature control frame. The specified geometric symbol compartment is extended over both lines. Then you can create a
second line of tolerance symbols.

To add a geometric tolerance:

1.Choose Dimension > Tolerance from the main menu.

2.In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to insert.
3.Under Tolerance 1, click the first black box to insert a diameter symbol.

4.In the Text box, type the first tolerance value.

5.To add a material condition, click the second black box and click a symbol to insert it.

6.Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value.

7.Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.

8.Click the black box to insert a material condition symbol for each datum reference.

9.In the Height box, type a projected tolerance zone height value, if appropriate.

10.To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box.
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11.In the Datum Identifier box, add a datum value and then click OK.

12.In the drawing, specify the location of the feature frame.

| £ TOLERANC dwg ¥
4X05,5
4| @s,5@[@s,2[alB]C]|
46,590 0,3
ABC
—--|14 300|———|28 500[——‘
8 : ! (G Geometric Tolerance E
:_1 Sm  Tolerance 1 Tolerance 2 Dstum1  Detum2  Dotum3
xd T s T . T N B A B A-: H - B: B R
I = — HE | W | | | | | | |
n o
| :.. g o Height: 03 Projected Telerance Zne: [
® S 7 i
L [ ok Concel | [ Hep |
-B. g
v i [ 57,010 - 8834 | |-
i_ —
x el ]
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10. Blocks, Attribute and reference

Block Definition

10.1.  Create and Insert Blocks et

Usually, blocks are several objects combined into one that j z

you can insert into a drawing and manipulate as a single ; 0

object. Blocks can help you better organize your work, Setings

quickly create and revise drawings, and reduce drawing file 8::::, 7

size. (S— ‘
Open in block edtor

Objects Q Behavior
Specify On-screen Annotative
[, | Select objects Er‘ Match b
Retan »
Scale unformly
@ Convert to block
Delete V| Alow exploding
3 objects selected
Description
0K | Ccancel

10.1.1. Create Blocks

Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a single object. A
block can consist of visible objects such as lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks
are stored as part of the drawing file. You can use several methods to create blocks:

-Combine objects to create a block definition in your current drawing.

-Create a drawing file and later insert it as a block in other drawings.

To create a block for use within a current drawing:

1.Choose Draw>Block> Make from the main menu.

2.In the Block Definition dialog box, enter a block name in the Name

box.

3.Click Pick point button to specify the insertion point for the block in
the drawing area.

4.Click Select objects button to select the objects for the block, then

press Enter after selection. Then click OK button.

10.1.2. Create Nested Blocks

-
S
id »

?_.:)-.-J:
F—

LN ;o
!* Objects to Block "‘ I“

You can define blocks and other blocks as nested blocks so as to simplify the organization of complicated blocks. With nested
blocks, you can build a single block out of several components. But you should notice that blocks that reference themselves

cannot be inserted.
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10.1.3. Create Drawing Files for Use as Blocks 5 wieno
Source
You can create a block as a separate drawing file that you can insert .;g-i:dmwmg
into other drawings. — _
Pick paint Select objects
To save a block as a separate drawing file: X0 © Retan
() Convert to block
& U () Delete from drawing
1.0n the command line, type WBLOCK. = Enimne R
2. Under Source area, choose one of the following: Destination
File name and path:
-Block: Saves existing block object to a separate drawing file. ™
-Entire drawing: Saves the entire drawing to a separate drawing file. iset s, Milineter 7
-Objects: Saves those objects you select to a separate drawing file. ok ][ cmes | [ B0 ]

3. Under Destination area, type the name of the drawing file you want to create and choose the saved path, click OK to save.

10.1.4. Change the Base Point of Drawings to Be Used as Blocks

When inserting a drawing file into another drawing as a block, by default, system uses the origin (0,0,0) of WCS as the base
insertion point. To specify different insertion point, you can use BASE command. Next time you insert the same block, system
uses the new insertion point by default.

10.1.5.  Update Changes in the Original Drawing

Once the drawing file has been inserted into another drawing as a block, the original drawing changes as well. But the block
having been inserted will not change. If the block happens to change along with the original drawing, you should attach it as
external reference but not as a block.

10.1.6. Use Paper Space Objects in Blocks

Objects created in paper space are not contained in the block when it is being inserted into the drawing. You can convert the
objects in paper space as block or save as an individual drawing file before inserting into other drawings.

10.1.7. Insert Blocks

You can insert blocks and other drawings into the — =
current drawing. When you insert a block, it is treated I::: 1 - (i— @
as a single object. When you insert a drawing, it is — —
added to the current drawing as a block. You can then i R WS"”";““""" |
insert multiple instances of the block without reloading Yo w—
the original drawing file. If you change the original Zi! Unt:  Mimeten

Unform Scale Factor: 1

drawing file, those changes have no effect on the
current drawing unless you redefine the block by
reinserting the changed drawing.

o) (o) (e
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To insert a block:

1.Choose Insert > Block from the main menu.

2.In the Insert Block dialog box, under Insert, click Block Name.

3.In the Name box, select the name of the block you want to insert.
4.If you want to use the pointing device to specify the insertion point, scale, and rotation, select Specify On-Screen. Otherwise,

enter values in the Insertion Point, Scale, and Rotation boxes.

5. Click OK to insert.

To insert an entire drawing into the current drawing:

. o =
1.Choose Insert > Block from the main menu. S - @
2.Click Browse to specify the file from the Insert Block dialog box. 7
3.You can use the default insertion point, scale, and rotation or S Scale Rotaton
select Specify On-Screen and enter values in the Insertion Point, T T o
Scale, and Rotation boxes. Y. 0 Yo e
4.If you want the objects in the block to be inserted as individual = & Uk S Misae
objects instead of as a single block, select Explode. Precondition a0 i
is the block you created is allowed to explode. e ——

5.Click OK to insert.

10.1.8. Modify a Block Definition

You can redefine all instances of a block within the current drawing. To redefine a block that was created in the current drawing,
you create a new block using the same name. You can update all the blocks in the current drawing by redefining the block. If
the block was inserted from a separate drawing file that was subsequently updated, reinsert that block to update all other

instances in the current drawing.
To redefine a block in the current drawing:

1.Choose Draw > Block > Make from the main menu.
2.In the Block Definition dialog box, type the name of the
block you want to redefine in the Name box.

3.Click Pick point button to specify a point as the insertion
point for the block in the drawing area.

4.Click Select objects button to select the objects for the
block, and then press Enter after selection.

5.Click OK.

6.Click Yes in the prompt box that displays to redefine the
block in the current drawing.

5 Block Definition

Name:
1 -

Base point Objects

"1"is already defined as a block. What do you want to do ?

Number of 1 block reference in the drawing:1

the
‘Yes: Redefine block, No: Don't redsfine block:

[ Open in block editor

0K

| [ cancat | [ Hep
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10.1.9. Remove Block Definitions

Too many block definitions in a drawing file may
affect the drawing size. To reduce the size of a
drawing, you can remove unused block definitions.
Erasing a block reference from a drawing may
delete the block reference but retain the block
definitions in the block definition table. Using
PURGE command can help removing unused block
references from your drawing in order to reduce
the drawing size. You should erase all references
from a block before you can purge the block
definition.

10.1.10. Define and Use Block Attributes

Named Objects

© Yiew items you can purge
View items you cannot purge

Items not used in drawing:

! Confirm each item to be purged
Purge pested items
Unnamed Objects

Purge Zerodength geometry and empty text obje

[ owoe ]

((Pugeas | [ gose ] [

An attribute is a particular object that you can save as part of a block definition. Attributes consist of text-based data. You can
use attributes to track such things as part numbers and prices. Attribute values are either fixed or variable.

To define an attribute:

1.Choose Draw>Block> Define Attributes from the main menu.
2.Under the Attribute, type the tag, prompt, and default text.
3.Under Insertion Point, specify the location of the attribute, or
click Specify on-screen to select a point in the drawing.
4.Under Mode, select the optional attribute modes.

5.Under Text Settings, specify the text characteristics.

6.To add the attribute to the drawing, do one of the following:
-Click Define to add the attribute and keep the dialog box active
S0 you can define another attribute.

-Click Define and Exit to add the attribute and end the
command.

To edit an attribute definition:

1.0n the command line, type DDEDIT.

2.Select the attribute definition text to edit.

3.Modify the attribute tag, prompt and default in the Edit Attribute
Definition that displays.

4.Click OK.

5 Attribute Definiti

Mode

[ Invisible

[F Canstartt

[ Verify

[ Preset

Lack position
|| Muttiple lines

Insertion Point
Specify on-screen

S
A8

Z

Mlign below previous attibute definition

[
Attribute
Tag:
Prompt:
Defauit @
Teat Settings
Tt e
|| Arnotative
Tent height: 25
Rotation: 0
Boundary width: ffg
[ ok | [ camee | [ Hep |

5 Edit Attribute Definitio

Taa:
Prompt:

Default:

STEW|

small stew

OK

| [ cancel | [ Heb
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10.1.11. Modify Block Attributes

You can use the Block Attribute Manager to modify attributes in
block definitions. For example, you can modify the following items:

-Attributes of blocks can be displayed after modification.

-Text properties that define how attribute text is displayed in the
drawing.

-Properties that define the layer that the attribute is on and the
attribute line's color, weight, and type

HOW MANY BODIES? 3

To edit an attribute attached to a block:

1.0n the command line, type DDATTE.
2.Select the block to edit. The Edit Attributes dialog box displays
all the attributes attached to the block you select.

3.Edit the attribute values as necessary. Then click OK. Canel oo

. Data Extraction - Define Data Source (Page 2 of 8) ﬂ'
10.1.12. Extract Block Attribute Data ;

Data Source
@ Drawing/Shest set

. . . Include curent drawing
Enter EATTEXT to start Attribute Extraction if the blocks St ot e ot i &
in the drawing contain attributes. You can extract block Dring s e =
. . . . | B Flder Extraction settings
information according to the wizard prompt and CBgmie || Elbractobics fombods
generate list so as to overview the attributes information (9] Extract objects fram xrefs
of the blocks. You can get guide information from the Dinculue xrefs i bock counts
wizard until you accomplish selecting drawings, blocks Bxract from

. I () Objects in model space I
and block attributes. I
., . . [ oK J [ Cancel ] [ Help ]

With the extract block attribute data function, you can

gasily create list using drawing data through extracting attribute information and export to external files.

10.1.13. Synchronize Attributes

The ATTSYNC command applies attribute changes in block definitions to all block references of the same name. You can use
this command to update instances of blocks containing attributes that were redefined using the BLOCK or BEDIT commands.
ATTSYNC does not change any values assigned to attributes in existing blocks. ATTSYNC removes all changes of format or
features that are made by ATTEDIT or EATTEDIT commands. And it also deletes all extended data associated with blocks and
might affect dynamic blocks and blocks created by third-party applications.

10.2.  Reference Other Drawing Files (Xrefs)

External references provide additional capabilities not available when you insert a drawing as a block. When you attach an
external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it.
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External references are useful for assembling master drawings from component drawings. Use external references to coordinate
your work with others in a group. External references help reduce the drawing file size and ensure that you are always working
with the most recent version of a drawing.

10.2.1. Attach External References

When a drawing is attached to current drawing as external reference, it will be linked to the drawing, any changes to the
referenced drawing may affect the external reference in current drawing. External references are inserted into the drawing as
block definitions and used as single objects, but you should distinguish the external references and blocks.

To attach an external reference:

1.Choose Insert>External References from the main menu.

2.Click the DWG icon at the top left of the window.

3.In the Select Reference File dialog box, specify the drawing file to attach and then click Open.

4.In the External Reference dialog box, under Reference Type, choose how you want to insert the drawing:
-Attachment: Inserts a copy of the drawing and includes any other drawings references.

-Qverlay: Lays a copy of a drawing over your original drawing

5.Make any additional selections and then click OK.

6.If you marked Specify On-screen for any items, follow the prompts to attach the external reference

External Reference x

& -]o- o
Reference Name Status Saze
N Orawngt Opened
2,3 80052 Loaded 163.0K8

L&( BLOCKS 2DYNAMIC BLOCKE  Notreferenced 0.00 KB
LY B0OKS 20MNAMIC BLOOKE  Unloaded

External Reference
N 3 Color Bylayer 3

‘@ " ,
3 e D
§ Unetype Bytayer I ——
: Status
sze
......... Type
OATE
Save path
Found At

10.2.2. Control the Properties of Referenced Layers

You can control the visibility, color, linetype, and
other properties of an xref's layers and make these
changes temporary or permanent. If the VISRETAIN e
variable is set to 0, these changes apply only to the '
current drawing session. You can also control the
fade display through XDWGFADECTL variable. In
addition you can control Xref layer properties directly
into the Layer Manager Properties dialog box.

S §

e
i
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o
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10.2.3. Xref Clipping Boundaries j “M’Z“;f;“s 7
e
You can control whether to display clipping boundary of xref ==l ——
through setting system variable XCLIPFRAME. Also you can Clip % oo
Xrefs by selecting the option on the menu bar: o g

Modify > Clip> Xref 0 e

% Lengthen

'
+ B mage

= Trim
—/ Bdend
[
¢ Joi
f Chamfer
{ Fillet

3D Operations
Solid Editing

reak
in

10.2.4. Nestand Overlay External References

¥ Change Space

3, Beplode

Xrefs can be nested in another xref and attached to current drawing. In the process of attaching, you can select insertion
position, scaling factor and rotation angle for xrefs.

10.2.5. Binding an Xref to a Drawing — ‘

To provide a copy of a drawing containing external references to someone else, you must o]

. . . . @ Unload
also provide all the external reference files. Binding the external references makes them a o moe )
permanent part of the drawing, which is similar to inserting a separate drawing as a block.

Detach
Bind...

Path

:(l)u can bind external references by doing right click to the selected Xref
Ie. Bind Type

() Insert

10.2.6. Refresh Xrefs

You can refresh the Xref by clicking the refresh button located at the top of the External Reference Dialog Box.

10.3.  DGN Underlay

In GstarCAD 2024 for Linux version, the full DGN files are supported
and related commands such as DGNIMPORT, DGNATTACH,
DGNADJUST, DGNMAPPING, etc are available. Now you can import
and attach as underlay a Microstation native format.
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104.  DWF Underlay

GstarCAD supports DWF Underlay, you can insert a DWF file as Underlay.

10.5.  PDF Underlay

] Select Reference File

Look in:

™

<
B

-4

File name

Files of type:

J Drawing and picture - 0
Name Date Type Size
1. 2015 drawings 11/28/2014 .. File folder
1. test drawing 12/17/2014 ... File folder

<[ i

If you receive project drawings in the form of a PDF file, you can reuse that PDF data in your own GstarCAD drawing files.

| Select Reference File | Attach PDF Underlay Y [
Loskin: |, Drawing and picture - @frmEr
Name: (PDF UNDERLAY - Browse
= Name Date Type Size Tags
i 112015 drawings 11/28/2014 .. Filefolder Select e o more poges from POF e
J. test drawing 12/17/2014 ... File folder
F5PDF UNDERLAY 10/24/2014 ... Adobe Acr... 4,301 KB Eatiin= Sm
I FEPlano Seccional La .. 4/14/20146... Adobe Act.. 201 kB ] Specify Onvscreen
.
1 1
\; Insertion Point
*
[] Speciy On-sereen
Rotation
= T ] Do
(O .
w
<[ ]
Fie name: PDF UNDERLAY - Open
Flescitwe:  [PDFfies( pd) - Cancel T | ==
PDF files(" pdf) =

After inserting the PDF file as underlay, then you can start
drawing or placing geometry at specific point of the underlay.

What's more, you can adjust the underlay display like contrast, fade, monochrome, and colors for background through the

properties palette.

POF UNDERLAY - 3
3

E\GSTaRCAMPRNN
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10.6.  About Clipping Underlays

The clipping boundary can be specified as a
limited portion of the external reference graph,
block reference, graphics, viewport, and underlay.
You can clip external reference such as DGN, DWF,

IMAGE, PDF and other underlay or block reference. B
You can use clipping boundary to determine the

external reference or block reference section that LU
you want to display, or to hide the redundant parts

of the reference inside or outside the boundary by
the following methods.

- 4

=

i
'
{

ON | OFF | Clipdepth | Delete | generate Polyline 4 P

The boundary can be a polyline, a rectangle, or a polygon whose vertexes are limited within the global scope of the underlay.
You can modify the boundary of the graphics to be clipped. When you clip the graphics, you do not change the object in the

external reference or block, but only change the way they are displayed.

Clip PDF

Clib AlemboLg

10.7.

Edit Reference Tab

With REFEDIT function allows you to edit blocks as reference. Users can access this function from toolbar in the classic
interface and also there is an edit reference panel in ribbon interface. In edit reference panel, users can select the options like
save changes, discard changes, add to working set and remove from the working set base on block modifications. Now you can

edit an xref or a block definition directly within the current drawing.

Home rser Annotstion 30 Layout tanage  Export Tous Application
Reference Edit [

BD

\dentily Reference | Sattings
Reference name Frevew —
IR®-1G 17 HATCH BOUNDARY IMPROVEMENT
£@ G17 HATCH BOUNDARY IMPROVEMENTpersor
£ G17 HATCH BOUNDARY IMPROVEMEN Tplarnta ’-'!:_gg -
£3 G17 HATCH BOUNDARY IMPROVEMENTplarta -
£ G17 HATCH BOUNDARY IMPROVEMENTplanta !% I-
£ G17 HATCH BOUNDARY IMPROVEMEN Tplanta i
£ G17 HATCH BOUNDARY IMPROVEMEN Tplanta N
£@ G17 HATCH BOUNDARY IMPROVEMENTplanta ~ T "
o i ’
Path:  FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017\G17 FEATURES DWG\G17 |
© Automatically select al nested objects.
Prompt to select nested objects |
Coc ) cmen [ b ]

CHle?#Q

Repeat REFEDIT
Recent Input

(74 | Edit Xref In-place

Open Xref
Clip Xref

External References...
Clipboard
Isolation

Erase
Move

Copy Selection
Scale

Rotate

Draw Order
Group
Deselect All
Select Similar
[¥ Quick Select...
QuickCalc
@ Find...

% Properties
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The objects that you select from the selected xref or block are temporarily extracted and made available for editing in the current
drawing. The set of extracted objects is called the working set, which can be modified and then saved back to update the xref or
block definition.

Reference Edit Dialog Box

Identify Reference Tab: Provides visual aids for identifying

E Reference Edit
what to edit and control how it is selected. e — e
5Reference Name: Displays the reference selected for Reference name
. iy " R REFEDIT ENHANCEMENT]
in-place editing and any references nested within the I e

£8 REFEDIT ENHANCEMENTiarbusto03

selected reference. If multiple references are displayed, £ REFEDIT ENHANCEMENTplantas04
. . £& REFEDIT ENHANCEMENTiplantas04
choose a specific xref or block to modify. Only one can be £ REFEDIT ENHANCEMENTpantas04
£33 REFEDIT ENHANCEMENTplantas04
edited in place at a time i e e e e
. . .. . Path: FNGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017\G17 FEATURES
Preview: Displays a preview image of the currently selected © Automaticaly select al nested objects

Prompt to select nested objects

reference as it was saved in the last drawing. The reference
preview image is not updated when changes are saved.
Path: Displays the file location of the selected reference. If it is a block, no path is displayed.

Automatically Select All Nested Objects: Controls whether nested objects are included automatically in the reference editing
session.

Prompt to Select Nested Objects: Controls whether nested objects must be selected individually in the reference editing
session.

([ox J[ Comcel | [ Hep |

Settings Tab -

Create Unique Layer, Style, and Block Names:  Controls whether
layers and other named objects extracted from the reference are
uniquely altered. If selected, named objects in xrefs are altered
(names are prefixed with $#8), similar to the way they are
altered when you bind xrefs. If cleared, the names of layers and
other named objects remain the same as in the reference
drawing. Named objects that are not altered to make them
unique assume the properties of those in the current host
drawing that share the same name.

Display Attribute Definitions for Editing: Controls whether all
variable attribute definitions in block references are extracted
and displayed during reference editing. If Display Attribute
Definitions for Editing is selected, the attributes (except constant attributes) are made invisible, and the attribute definitions are
available for editing along with the selected reference geometry. When changes are saved back to the block reference, the
attributes of the original reference remain unchanged. The new or altered attribute definitions affect only subsequent insertions
of the block; the attributes in existing block instances are not affected. Xrefs and block references without definitions are not
affected by this option.

Lock Objects Not in Working Set: Locks all objects not in the working set. This prevents you from accidentally selecting and
editing objects in the host drawing while in a reference editing state. The behavior of locked objects is similar to objects on a
locked layer. If you try to edit locked objects, they are filtered from the selection set.

|dertify Reference

Create unique layer, style, and block names
[ Display attribute definitions for editing
Lock objects nat in working set
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10.8. PDF Import and Export

AERBE

You are able to import TrueType text, the geometry, and raster (G Rt finiie
images from a PDF file or underlay into a current drawing as .-
GstarCAD objects. -
B 0 'S oenmry o

‘;} = No items match your seaDr:: edtes e H

H u

1’ % l xport

= -

@ =

Fie name: Drawing? - (
Saveastype:  [PDF Fies(pd) o)

GstarCAD 2024 for Linux also supports to export to PDF file format. You can access this feature from File button - Export - PDF
or input EXPORTPDF from the command line.

10.9.  OLE Objects Display and Export

OLE objects are a common type of data object in the Windows system. These objects can be almost any data type, such as text,
bitmap images, and vector graphics, but to read and write OLE are quite difficult in Linux systems. GstarCAD supports OLE
objects in Linux systems. It can accurately display existing OLE objects in graphic files, including DWG, Word, Excel,
PowerPoint, Microsoft Equation 3.0, Notepad, Paint images, and other data types. It achieves the exchange and sharing of OLE
objects between different applications under Windows or Unix-like systems.

In addition, the OLE2NATIVE command has been added to export OLE to the corresponding format.

10.10.  SHP Import and Export

SHP files are a commonly used format for geographic information data, capable of storing the spatial positions and related
attributes of geometric shapes. Typically, this file format includes multiple files such as .shp, .shx, .dbf, .prj, among which .shp
is used to store spatial information of vector data, .shx is the index file for geometric features, and .dbf is used to store attribute
information of vector data. These three files are essential. GstarCAD 2024 for Linux supports importing SHP files into the
current drawing and allows for editing. It also supports exporting the current drawing to SHP files. You can use IMPORTSHAPE
command to import SHP file to eidt.
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11. Hatches and Raster Images

11.1. Hatches

11.1.1.  Define Hatch Boundary

To create a hatch, you should define hatch boundaries first by means
of selecting objects to be hatched or picking a point inside the

desired object. A hatch boundary can be any combination of objects,

such as lines, arcs, circles, and polylines that forms an enclosed
area.

11.1.2.  Control the Hatching in Islands

You can specify methods of hatching objects in outermost boundary as normal, outer and ignore. Normal is the default hatch
pattern. Besides, you can view hatching results of different types in the Islands area on Hatch tab of the Hatch and Gradient

dialog box.

Normal: Hatch the pattern from the outer boundary to inside. Hatching process will be stopped when encounter inner crossing
points, and continue hatching until second inner crossing point appears.

Outer: Hatch from the outer most layer of configuration, and keep the internal blank.

lgnore: Ignore internal objects, only hatches outer objects.

To select objects for hatching:

1.Choose Draw > Hatch from the main menu.

2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:

Normal, Outer, Ignore:

NORMAL ISLAND OUTER ISLAND

IGNORE ISLAND

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other

options. Existing objects are always retained.
4.In the Boundaries, click Select Objects button.
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5.In the drawing, click the objects to be hatched individually, and then press Enter when done.
6.In the Hatch and Gradient dialog box, click OK.

Select an area for hatching:

1.Choose Draw > Hatch from the main menu.
2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:
Normal, Outer or Ignore.

///

7N @ .

NORMAL ISLAND OUTER ISLAND IGNORE ISLAND

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other
options. Existing objects are always retained.

4.In the Boundaries, click Pick Points button.

5.In the drawing, click inside the closed perimeter of a boundary. If desired, continue clicking inside additional closed
perimeters.

6.To complete the selection, press Enter. Then click OK button.

11.1.3. Choose and Define Hatch Patterns ﬁ M
= D At et s

Hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can <

select a hatch pattern from a set of predefined patterns, or you can define a 5 S

pattern of your own. The hatch pattern you used most recently is the default e e o

pattern the next time you add hatching. The program supplies predefined S EE] S

standard hatch patterns, which are stored in the ICAD.pat and ICADISO.pat

hatch pattern library files. — ‘
qu“ -

To specify a predefined hatch pattern: Tl D

1.Choose Draw > Hatch from the main menu. i’

2.In the Hatch and Gradient dialog box, click the Hatch tab.
3.Beside Type, click Predefined to apply a scale factor to make the pattern larger or smaller than the default size.
4 Enter the scale factor as a percentage of the default.
5.Enter the angle in degrees (1-360). The default angle is clockwise, you can change the angle of any hatch pattern by entering
a numerical value. ’

6.Enter the ISO pen width. This option is only available if
you select existing ISO hatch pattern in the Pattern option.
7.To copy the pattern properties from an existing hatch,
choose Inherit Properties.
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8.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative
hatch updates automatically if you move any of its boundaries.
9.To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.

To specify a user-defined hatch pattern;

1.Choose Draw > Hatch from the main menu.

2.From the Hatch and Gradient dialog box, click the Hatch tab.

3.Beside Type, in the Type list, click User Defined.

4.For Spacing, enter the line spacing for the pattem.

5.To copy the pattern properties from an existing hatch, choose Inherit Properties, and select a hatch pattern from a hatched
object in the drawing.

6.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative
hatch updates automatically if you move any of its boundaries.

7. To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.

Hatch | Gradient Boundaries
T Add: Fick poirts
To use a predefined library pattern: - = u{
:"':m leii | (7051 50 [oe Prsdeined [Cuman] I
1.Choose Draw > Hatch from the main menu. e |3
. PR ANSIZ6 B ANSI31 ANSI32 ANSI33 ANSI34
2.Click the Hatch tab. o e &
) ] - mssis . b
3.Select a Predefined type. il A L A
. . AR-BRELM
4.To select a predefined pattern, do one of the following: psnsm
-In the Pattern list, click the pattern name. T
-Click the graphical representation of the hatch pattem. R s
E 2X2BRIKC
5. To continue, add a hatch by selecting objects or picking e
BL APPIANZ
points to selected area or boundary you want to hatch. Sttt AP AN
— Sg:;gw ANS! Iron, Brick, Stone mason
BOARDWN

5 Haich and Gradie

Boundaries

Options in Gradient tab:

CrnlorE = i Add: Pick points
PR o | Draw Order: Assigns a draw order o a hatch or fill. You can place a
o hatch or fill behind all other objects, in front of all other objects, behind
I | I I ] the hatch boundary, or in front of the hatch boundary.
1 ...
._J - Layer: Assigns new hatch objects to the specified layer, overriding the
L= S current layer. Select Use Current to use the current layer.
. —_—
rientation - ) .
[E] Centered i 0 Transparency: Sets the transparency level for new hatch or fills,
Trnsparenoy: overriding the current object transparency. Select Use Current to use the
, ,
v [ current object transparency setting.

Inheri Properties
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11.1.4. Hatch to Back

In order to avoid a filling pattern blocks any text, label or other graphics on the current drawing, you can set the display order of all the fill
pattems to back position from all other objects with HATCHTOBACK command.

{0 HATCHIEERER
HATCH
@ HATCHEDIT
HATCHGENERATEEOUNDARY
HATCHSETBOUNDARY

HATCHSETORIGIN

11.2.  Work with Raster Images

You can view and manipulate raster images and associated file paths in your drawings.

11.2.1.  Attach, Scale, and Detach Raster Images

Raster images consist of a rectangular grid of small squares or dots known as pixels. Raster images can be copied, moved, or
clipped as well as a normal object in the drawing. You can also adjust the contrast, transparency, image quality and image
frame visibility. Additionally, when inserting raster images, the file format depends on the content of the file rather than the
extension name. The following are all the image file formats supported:

Allimage files(* jpg *.bmp *.gif * jpeg *.tif *.tiff * tga *.png *.pex *.cal *.psd *.dib *.rle * jpf * jpx * jp 2K * jpc *.jps *.jpe * pdd * psdt *.pbm * pgm * ppm *.pnm *.pfm *.pam *.vda

11.2.2.  Attach Raster Images

Use IMAGEATTACH command to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or 24-bit color image files
to a drawing. The image file can be inserted as blocks as many times as you like once attached to the current drawing, you can
clip the attached raster image and setup its lightness, contrast, fading and

transparency. — i L)

Sae PREVIEW Pathtye Scale
] Specty Onscreen

To attach a raster image: an (s

e e— S
i 2015125110818 uKe V! Specty Onecreen Rotataton
1 2015120110121 1'03 L X Specfy On-Screen
1.Choose Insert > Raster Image reference \ = ; e

from the main menu. LI .
2.Specify a file to attach, and then click Open. | & =™ i
3.In the Image dialog box, in the Insertion ! o

. . . L s Code=) [m=
point and Scale, click Specify on-screen. : — B
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Specify an angle value in Rotation, and then click OK.
4.Specify a insertion point.
5.Specify a scale.

11.2.3. Scale Raster Images

Model / Layoutl / Layout2

You can specify scale factor in the Image dialog box, otherwise to attach it by its original size. The raster image will be scaled
by the specified factor, the scale factor is used without unit by default.

11.2.4. Detach Raster Images

Raster images can be detached if it no longer needs to use in the drawing, a specified image detached from the drawing
together with its multiple copies, links and definitions, but the original image file will not be influenced.

11.2.5. Modify and Manage Raster Images

Controls the properties such as displaying and clipping boundary of raster images. You can view and manipulate attached raster
image and change its saving path in Image Manager. Users can turn on/off image boundary in current view using IMAGEFRAME
command and setting up the values 0 (off) 1(on).

To turn image frames on or off for all images:

1.Choose Modify >Qbject> Image > Frame

2.Do one of the following to toggle frames off and on:
-Type value 1 to display and print frames for all images in a
drawing.

v

L.

Model { Layoutl / Layout2

-Type value 0 to hide all frames on the screen and during . ———
iﬁ!;;::i';?:;ii e
printing. -
To clip an image in the shape of a rectangle and polygon: & | =& = e N
g | Dok At Aueos Eano oot || G @ tmeg
Annotative Object Scale , 5“
i i AWING SAMPLE MECH4, dwy = ewport
1.Choose Modify>Clip> Image z 7 | e
Q Copy
2.Select the edge of the image you want to clip. e
3.Type N (New boundary) to create a new clipping j o
boundary. S=
4.1t you choose Rectangular: Fx sele
-Define the first corner of the clipping rectangle. <" Lengthen

-Define the second corner of the clipping rectangle. The

selected image is clipped so that only the interior of the \ NS
rectangle is visible. \ ‘

5.1f you choose Polygon:
-Select the points for the polygon, and then press Enter when the polygon is complete. The selected image is clipped so only
the interior of the polygon is visible.
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11.2.6. Change Raster Image Brightness, Contrast, and Fade

Use IMAGEADJUST to adjust displaying result and lightness, contrast and fade that are related to the display and plot effect
when plotting drawings. IMAGEADJUST does not affect the original raster image as well as other instances of the image.

Image Adjust E
Brightness 20151202100143
Dark & Tint 28
Contrast
Low {2} High 50
Fade

11.2.7.  Improve the Display Speed of Raster Images

You can adjust the display speed by setting the raster image quality. The image quality is sorted into high and draft levels, If the
quality is set to draft, the image will be displayed with some granular materials, however with faster display speed.
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12. Layout, Plot and Publish Drawings

6 rogeseup o I ===
12.1.  Create Multiple-View Drawing Layouts B oo o
Page setups
Currert page setup <None>
12.1.1.  Overview of Layout
A layout represents a plotted page on which one or more model views are —
displayed. GstarCAD provides two collateral working environments as Model Seleced age st s
Device name ===
and Layout tab. You can create thematic models on Model tab. Multiple slides P :“':W“tl X
lot size: rom template...
of the model can be set in Layout tab. Use these general steps to prepare your - Delete
. e . SRR Rename
drawing for printing multiple layouts: e Move or Copy..
R Select All Layouts —

Activate Previous Layout

1. On the Model tab, create your drawing. Actvate Model Tab
2. Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create BerpSa e
a new Layout tab. plot-

3. Create at least one layout viewport on the Layout tab. Use each viewport to help control
which portion of the drawing prints and at what scale.

4. Specify additional settings for the layout, such as the scale of the drawing, print area, print style tables, and more.
5. Print or plot your drawing.

Export Layout to Medal...

Hide Layout and Mode tabs
L‘J

You can right click on Layout tab and select "New layout" to create a new layout, and also import layout from template. Options
on Shortcut menu are listed:

12.1.2.  Work with Model Space and Paper Space

Model space is generally used for creating and editing drawings.
Preparations for plotting are usually working on paper space for the
drawings on layouts are close to the plotting effects. / \

Model space is an area in which you create two dimensional and three I \J
dimensional objects based on either the World Coordinate System ¥ 4
(WCS) or a user coordinate system (UCS). The contents of paper space ===
represent the paper layout of your drawing. In this work area, you can
create and arrange different views of your model similar to the way you P e 1
arrange detail drawings or orthogonal views of a model on a sheet of paper.

Layout tab is enabled to make relevant plot settings. Paper space is provided
in each layout option, and you are allowed to create viewports and specify
page setup such as paper size, orientation and location that can be saved
together with the layout.

Block Reference
Color Bylayer
[t
Y Linetype Bylayer
l— X

Layout1 {Layoud

You can save and name the page setup and apply it to other layouts when setting pages. You can also create new layouts using
existing layout template file (DWT or DWG).

Click on the Model tab, you can view and edit objects in model space.
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12.1.3.  Specify Layout Settings

Once created a drawing in Model tab, you can toggle to Layout tab and setup the layout for plotting, such as paper size,
drawing orientation and so on. You can right click on the Layout tab to create new layouts or import from template files, and
then click Modify button on the Page Setup Manager dialog box to set the page.

12.1.4. Select a Paper Size for a Layout

The paper size here refers to the size of the drawing. When you start Plot dialog box in Layout tab, you can assign the paper
type from pull down list of the Paper Size text box. The Paper size is directly previewed from the sketch with its size and units.
The available paper types provided in the pull down list are decided by the current configuration. If you want to configure
plotters to export raster images, you must specify output size by pixels. The paper size can be customized in the Plotter
Configuration Editor.

12.1.5. Determine the Drawing Orientation of a Layout

G Page Setup - Layoutl ==

Page Setup Flot style table {oen assignments)

The drawing orientation is sorted into Landscape and Portrait, e [SE—

which decide the plotting orientation of the drawing to be seen on A

As displayed

a paper. Once specified the drawing orientation, you can control e
whether to plot the top or the bottom of the drawing by selecting

Plot Upsize-down option. The changes setup in Page Setup dialog MMM' J

box are still saved in layouts. Certain page settings can be o -

replaced by customized plot settings, but the settings will not be T | o imamal

Yoo Nilimeters [ Scale ineneights

saved in the layout unless you click Apply to Layout option.

12.1.6. Adjust the Plot Offset of a Layout

You can offset the geometry on the paper by entering a positive or negative value in the X and Y Offset boxes. Changing the
plotting origin may change the position of drawing on papers. The plot origin locates at

the left lower corner of plotting area with offset value of 0 relative to X and Y direction. Select Center on Paper if the specified
plot area is part of the drawing rather than the whole layout, which changes the position of plot origin.

Plot with origin (0,0) Plot with origin (10,10)
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12.1.7. Set the Plot Area of a Layout

You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot option is drawing limits which
means plotting all the objects within the drawing paper. The plot origin is (0,0), located at the left lower corner of the page. Do
the following methods to select a plot area:

5 Page Setup - Layoutl ]

-Layout: Plots all the objects within the drawing paper.

-Window: Set the Plot Scale for a Layout, Plots any portion of the
drawing you specify within the rectangle window. Click the Window
button to use a pointing device to specify opposite corners of the
area to be plotted, and then return to the Plot dialog box.

-Extents: Plots the portion of the current space of the drawing that
contains objects. i
-Display: Plots the contents displayed in current view. L0 i LT

Fitto paper
Ssle: (14 -]
to pritable area) 10000 [Milimeters ]
© For
et

limeters || Certer the piot 10000 unts

-

12.1.8.  Set the Plot and Lineweight Scale for a Layout

When you specify a scale to output your drawing, you can choose Fit to Paper to scale the drawing to fit onto the selected
paper size. Usually, the objects in model space are displayed at the scale set in layout viewports. To plot the objects in model
space with the scale specified in layouts, you assign the scale to 1:1.Even if plot scale of layouts is assigned, it's enabled to
scale the lineweight at a certain scale. Scaling the lineweight is nothing to do with the plot scale when plotting drawings, which
is mainly used for the lines included in the objects to be plotted.

12.1.9. Create Layout from Template R
e b Do’ Jead iy 49 Look Template 4
Right click on the Layout tab to select from template | A= i
option to import DWG or DWT file directly, using E
information of existing template to create new layouts. 1
System provides template file with extension name -
as .dwt. Layout templates from any drawing templates N
can be imported into the current drawing. - [l e

( Locate ] [ FndFle.. |

To create a new layout from an existing file:

1. Choose Insert>Layout>Layout from Template
2. Inthe dialog box, select the desired template file, and then click Open. In the Insert Layout(s) dialog box, select the layout(s)
you want to insert, and then click OK. You can choose multiple layouts by holding down Ctrl while selecting layout names.

12.1.10. Create and Modify Layout Viewports

On a Layout tab, you must create at least one layout viewport to see your model. Each layout viewport is created as a separate
entity that you can move, copy, or delete. Any changes you make in one layout viewport are immediately visible in the other
viewports (if the other layout viewports are displaying that portion of the drawing). Zooming or panning in the current viewport
affects only that viewport.
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Create layout viewports:

1. On the command line, type MVIEW.

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or
4 separately, or specify two opposing corners to create a
custom viewport.

3. Choose the viewport arrangement, typing H (Horizontal) or V
(Vertical).

4. Do one of the following:

-To arrange the viewports to fill the current graphic area, type F

(Fit). -To fit the viewports within a bounding rectangle, specify
the corners of a rectangle.

I\Fiewpor'ts: [ON/OFF/Fit/Lock/2/3/4/Polygen/Object]<First corners:FIT ¢ [ |
You can create a single layout viewport, or you can divide the graphic area into many viewports arranged
[Horizontal/Vertical/Above/Below/Left/Right].

Err—
Layer () g

Color W Red

Linetype CONTINUOUS
Linetype scale  |1.0000
Lineweight BYLAYER
Hyperink

To modify layout viewport properties:

1. Click the border of the layout viewport whose
properties you want to modify.

Center-X 5.3829

2. Open the Properties palette through the menu e
option "Tools > Palettes>Properties" or "Modify > . Y'

Properties".
3. In the Properties palette, select Standard Scale,
and then select a new scale from the list. The scale you choose is applied to the viewport.

Turn Layout Viewports On or Off:

1.Click the desired Layout tab.

2. Type MVIEW and then press Enter.
3. Type ON or OFF.

4. Select the edge of the layout viewport to turn on or off, then  [cemen
press Enter.

Create Non-rectangular layout viewports:

Use Object and Polygonal options of MVIEW to create irregular viewports,

Select Object option to convert objects created in paper space to viewports. While selecting
Polygonal option to draw irregular polylines including arcs and lines which are enabled to
gither intersect or three vertexes at least, the polyline will be closed automatically.

12.2.  Plot Drawings

When a drawing is completed, you can output it using several methods. You can plot the drawing on paper or create a file for
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use with another application.

12.2.1. Plot Settings —
Page Setup Plot style table {pen assignments)
When you create a drawing, you do most of your work on N i /e
. . . Printer/Plotter Shaded viewport options
the Model tab. At any time you can print your drawing to Naae (e et
. | Lo Plotter Mone Qualty
see how it looks on paper. It's easy to startup printing, P
. . Description: The |ay:gn:mn ;zeh‘: ;:231 unless a new plotter —
and then later creates layouts and custom print settings to ez e e rons
enhance your printed output. e — Nl S
n . Plot paperspace last
To start printing:
What to plot. Fit to paper [F] Plot stamp on
Scale: | User define [] Save changes to layout
1. Choose File > Plot from the main menu. o
) ] = ol |IDE © Landscape T
2. Set the printer and relevant parameters, and then click o [Pt oscdoun
0K Previem Poslyto Layout ok [ conesl ][] [«]
12.2.2. Set Paper Size = T— T —
- A4_{210.00_x_297.00_MN)
Page Setup 1
You can assign the paper type from pull down list of the Name: [chone> e
62.00_MM)
Paper Size text box. If you want to setup paper size, you "::':;’_P“’“’M ggggﬁiﬁg
. . . ime. btz gégg:mm)
should configure plotters first, all the available plotters are Piter Hane i
. . Location: Nt applicable ‘sg; gg,m
both system plotters of Windows configured and non-system Dot Tl v b it v ot o L
configuration name is selected. 420.00_MM)
driven. e o
[150_A4_@210.00 x_257.00_1am) - Sz
To select a printer or plotter:
1. Choose File > Plot from the main menu.
2. From the Name list in Printer/Plotter area, select a printer or plotter you want to use, and then click OK.
12.2.3. Position the Drawing on the Paper
You can adjust the position of the drawing to be plotted on a paper before plotting.
To specify the print area origin:
1. If necessary, click the desired Layout tab or the Model tab.
2. Ghoose File > Plot from the main menu. Ry —— 1000 [Mimelon =)= Drawingaetsion
L. x 04958 Willmeters 7] Certer the plot 2946%  units i .
3. Do one of the following in the Plot Offset area: ) B
T[0T o= Scale lineweights [F] Plot upsidesdown
-To center the specified print area on the printed — e e = ®

page, select Center the Plot check box.

-To specify an origin for the print area, type the X and Y coordinates.

4. Select OK, and then click Apply to Layout.

layout.

Saves changes that you make in the "Plot dialog box” to the
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1=}

12.2.4. Set Drawing Orientation oy

Flot options
[7]Plot in background

Flot cbject ineweights

The drawing orientation determines whether to plot a drawing portrait or landscape. If you

Number of copies

. . . . . 1 Plot with plot styles
select Landscape, plots the drawing using the length edge as horizontal. While selecting P —
Portrait to plot the drawing using its minor edge as horizontal Changing, the drawing R
. . . . . . . . ine [T Save changes to layout
orientations just like rotating the paper under the drawing. Meanwhile, selecting Plot ij: '
upsize-down to control whether to locate the drawing upsize-down on paper. Sl
TEEIE [ Plot upside:down
oty | [ OK | Cawel |[ Hep |(®
12.2.5. Set Plot Scale
Plot scale of the drawing can be specified directly from the Scale . S
pull-down list in Plot Scale area of Plot dialog box. You can also s i S Csmecremos

plotting. For example, if you select the paper size to mm, entering 1
under mm and 10 under Units blank produces a plotted drawing with
gach plotted unit represents 10 actual millimeters.

. . . (. efines the exact scale for the plot. Custor defines a user-
choose User define to set desired plot scale, or choose Fit to Paper to 1 e o2 custom scle by ntrng he
. . . 15 rawing units,
scale the drawing to fit onto the selected paper size. The plot scale o SryrET—
. . . . . 120

together with plot unit and drawing unit must be specified before 5 joc ] L ]©
41
&1
1

=l

i

To automatically scale the drawing for printing:

Plot scale
Fit to paper

Hide paperspace objects
[ Plot stamp on

1. If necessary, click the desired Layout tab or the Model tab.

Scale: | User define [] Save changes to layout

2. Choose File > Plot from the main menu. 0 (] :  Oeveo et
3. To scale the drawing to fit on one printed page, in Plot Scale, click Fit to P o e

Socale lnewsights [F1 Plot upside-down

Paper.
4. Select Apply to Layout and click OK.

[movtomos |[ ok |[ concad |[ meb |

12.2.6. Set Plot Options

The following options show plot pattems with instructions on how to plot objects.

-Plot in Background. Specifies the plot is processed in background. -Plot
Object Lineweights. Specifies that lineweights assigned to objects and layers Qualty
are plotted.

-Plot with Plot Styles. Plots a drawing with specified plot styles. Plots st

lineweights automatically once by selecting this option automatically. If you do Nuberf coiee :°‘°?':°‘I“”:;e'g"’°
- 1 = lot with plot styles

not select this option, objects are plotted with their assigned properties and not Plot paperspace las

Hide paperspace objects

with the plot style overrides. per (9] it stamp on =

-Plot Paperspace Last. Plots model space geometry first. Paper space geometry ~=esee |
1.0000 = Drawing orientation

is usually plotted before model space geometry. m— © Pt
-Hide Paperspace Objects. Suppresses the plotting of objects that are located s pevuune e

[ mooytolayor [ ok |[ Concdl |[ we | @
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behind other objects regardless of how it's displayed on screen. This option is only available in the Layout tabs.
-Plot Stamp on. Horizontally or vertically places the plot stamp information on a specified comer of a drawing. The plot stamp

settings can be saved to log file, also cannot be saved.

-Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout if you click OK.

12.2.7. Specify the Area to Plot

To specify a portion of the drawing to print, if necessary, click the desired Layout tab or the Model tab.

1. Choose File > Plot from the main menu.

2. Under Print Area, click one of the following:

-Display — Plots the current view on the screen.

-Extents — Plots the contents within the specified drawing
extents.

-Limits/Layout — Plots the contents within the specified
drawing limits or entities in the printable area.

(]

Page Setup

Name

Printer/Flotter
Name:
Plotter.
Location:

Description

Plet to File

Paper size

[150_A4_(210.00_x_297.00_MM)

-Window — Plots the portion of the drawing contained in the
specified window. Click the Window button to use a
pointing device to specify opposite corners of the area to be

plotted, and then return to the Plot dialog box.
3. Select Apply to Layout and click OK.

Plot sty table (pen assignments)
[shone> -] A ] [Mene -l
Shaded viewport options
[ Nare Shadeplet  [Aedspiaed
sy
Net applicable
The layout will net b plotted urless a new plotter
corfiguration niame is selected Plot options
[7] Plot in background
Plot chject lineweights
(] Plot with transparency
] 1
Plot with plot styles
Plot scale Plot paperspace last
Fit to paper Hide rspace objects
Scale: [ Userdefine 1Pt samp cn
Save changes to layout
rrfable area) 1.0000 =
Drawing oriertation
linfeters 7] Certerthe: plot @ Portrit X
e ] Plot upside-down
ok [ Caneal [ ek ] [%]

12.2.8. Preview a Plot

Viewing a drawing before printing gives you a preview of what your drawing will look like when it is printed.

To preview a drawing before printing:

1. If necessary, click the desired Layout tab or the Model tab.
2. Choose File > Plot Preview from the main menu.
3. Do one of the following:

-To print the drawing, click preview and click Plot on the top left comer

of print preview.
-To return to the drawing, click the off button or press Esc.

12.2.9. Use Plot Styles

G Plot-Model

Page Senp

Mane: [cHonms

Prrtse/Pltar

Hape DWG Ta PDF ol

Fis ofse frign set o pntable ares)

% N Miimeses [7] Garter th pict

Plot styles help you control what your drawing looks like when it is printed. Because plot
styles are saved in plot style tables, which are files located on your computer, you can reuse
them to help eliminate the need to reconfigure your print settings each time you print a
drawing. A drawing can use one type of plot style table at a time. There are two types of plot
style tables: -Color-dependent plot style tables (CTB) contain a collection of plot styles

Plot style table (pen assignments)

E—

None

51 DWF Virtual Pen:
Fill Patterns cth
gead.ctb

c Grayscale ctb

~ monochrome cth

Screening 100%.
Screening 25%.ctb
Pl Screening 50%.ctb
Screening 75%.cth

New...
Cpen...

5 .cth

cth
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based on each of the 255 index colors available in a drawing.-Named plot style tables (STB) contain a collection of plot styles
that you define. They can vary regardless of color.

To assign plot style tables:1. If necessary, click the desired Layout tab, or click the Model tab.
2. Choose File > Plot from the main menu. & e s TN e

Fom View

3. Under Plot Style Table (pen assignments), select a plot style table in the one of == e
the following: None: Applies no —
plot style table. Objects plot according to their own properties. v— —
-Monochrome: Plots all colors as black. iy
-New: Creates a new plot style table. e G—
4. Select Save Changes to Layout, and then click Apply to Layout. ot e
Filstyle: gt eyte -

.

To Modify plot style tables:

[ savetGose | [ cCancal | [ Hep

1. Choose File > Plot from the main menu.

2. Under Plot Style Table (pen assignments), click the plot style table you want to
modify, and then click the button to display “Plot Style Table Editor”.

3. Click the General tab on Plot Style Table Editor, and then do any of the following:
-Enter a new plot style description.

-Select Apply global scale factor to non-ISO linetypes to apply the scale factor
-Enter a scale factor to apply to non-IS0 linetypes used for any plot style in the
current plot style table. e
4. Click the Form View tab, and then do any of the following: ‘
-Make changes to a color-dependent plot style by selecting it in the Plot list, and
then make color, linetype, or lineweight changes for the plot style in Properties area.
Your changes are saved automatically for the selected plot style.

-Make changes to a named plot style by selecting it in the Plot list, and then make color, linetype, or lineweight changes for the
plot style in Properties area. Your changes are saved automatically for the selected plot style.

-Add a new plot style by clicking Add Style. Enter a new name, and then click OK. Select the options for the plot style.
(Available for named plot styles only.)

-Delete a plot style by selecting it in the Plot list, and then click Delete Style. (Available for named plot styles only.)

5. Click OK.

5 Plot Style Table Editor - gead. S
(GERE | Fom View

Flot style table fle name:
geadct

Description

Fie Information
Number of styles: 255
Path: C:\Users\ovs\App Data'\Roaming \Gstarsoft\GstarCAD\R19\en-W.. \gcad ctb
Version:1.0
Legacy (can be used to import old DWGs)

‘Scale factor

[ SavctCose | [ Camed | [ Hep |

12.2.10. Plot Files to Other Formats

Plot files have various formats. You can output drawings in any image formats with unique plotter driver.

| Page Setup Plot style table {pen assignments)
Name: [(Nnne> v] [ Add... ] [gcad cth - ]@
Printer/Plotter Shaded viewport options
Name:  [|DWG ToPDFpc3 ~|| Popeties.. ||  Shadepit  [As displayed -
Canon iR2318/2320 UFRII LT -
Plotter: Default Windows System Printer pc3 Quality
DWF& ePlot pc3
Location DWW Fx ePlot (XPS Compatible) pcd 100
Description: DWG To PDF(Third Party Pdf Plot Driverhpc3 i
el | DV/G To PDFpc3 ‘E| '
| PublishToWeb JPG pe3 — Flet options
Pt 1o Eiel Publish TolWieb PNG po3 = [] Plet in background
| Plot object I ht:
Paper size MNumber of copies R
Plot with transparen
(150 A4 (210.00x 257.00 MM) - 1 0 sparEney
Plot with plot styles
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12.2.11. Publish Drawings

Specifies drawing sheets that you can assemble, reorder, rename, copy, and save for publishing as a multi-sheet drawing set.
You can publish the drawing set to a DWF, DWFx, or PDF file or send it to the plotter named in the page setup for hardcopy
output or as a plot file. The following options are displayed in the Publish Dialog Box:

Publish v
s""'l"‘33 N 2 Publish Options Information
r— BRE
& J Location: C:\Users\ovs\Documents\
Publshto: 4 Fie Type: Mutisheet fie
[an«nm-ednpageuhp '} Naming: Specfy name
V] Agomatically load all open drawings § Layer information: Dont inchude
Merge Control: Line overwrte
6 7 8 9 10 :
Sheet Name 1 1 DOWF 1D PageSetw 13 saws
= UnsavedDrawing 1-Model ﬁ'_ <Defauk None> " No emors
&7 UnsavedDrawing 1-Layout 1 & <Defauk None> +” No emors
£J UnsavedDrawing 1-Layout2 & <Defauk None> ” No emors
&l DRAWING SAMPLE MECH4-Model & <Defauk None> o No emmors
£J DRAWING SAMPLE MECH4-LOCKI} & <Defauk None> & No emors
£J DRAWING SAMPLE MECH4-LOCKI} & <Defankt None> o No emrors
Publish Output

Selected Sheet Details | 5 |
Source drawin 1 |

— Number of copies: {7 | inchude plot stamp 19 & 20
Layout Name 1 - .
= 7] Publish in background 2) | E 22
Plot size Precision: 18 -
Bt ocale = |Open in yiewer when done ) 3
Page setup de
[ heeowas |14 [ pown ][ Cmes | [ teo ]

1. Load Sheet List Button: Displays
the Load Sheet List dialog box, in
which you can select a DSD file or a
BP3 (Batch Plot) file to load.

2. Save Sheet List Button: Displays
the Save List As dialog box, in which
you cansave the current list of
drawings as a DSD file.

3. Sheet List: Displays the current
drawing set (DSD) or batch plot (BP3)
file.

4. Publish to: Defines how to publish
the list of sheets. You can publish to

gither a multi-sheet DWF, DWFx, or
PDF file.

5. Automatically load all open
drawings: When selected, the
contents of all open documents are
automatically loaded in the publish
list.

6. Add Sheets Button: Displays the
Select Drawings dialog box, in which
you can select drawings to add to the
list of drawing sheets.

7. Remove Sheets Button: Deletes the
selected drawing sheets from the list
of sheets.

8. Move Sheet Up Button: Moves the
selected drawing sheets up one
position in the list.

9. Move Sheet Down Button: Moves
the selected drawing sheets down one
position in the list.

10. Preview Button: Displays the
drawing as it will appear when plotted
on paper by executing

the PREVIEW command.

11. Sheet Name: Combines the
drawing name and the layout name
with a dash (-).
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12. Page Setup/3D DWF:Displays the
named page setup for the sheet. You
can change the page setup by clicking
the page setup name and selecting
another page setup from the list

13. Status: Displays the status of the
sheet when it is loaded to the list of
sheets.

14/15.Show and select sheet details:
Displays and hides the Selected Sheet
Information and Selected Page Setup
Information areas.

16. Publish Options: Opens

the Publish Options dialog box, in
which you can specify options for

publishing.

17. Number of Copies: Specifies the
number of copies to publish.

18. Precision: Optimizes the dpi of
DWF, DWFx, and PDF files for your
field: manufacturing, architecture or
civil engineering.

19. Include Plot Stamp: Places a plot
stamp on a specified corner of each
drawing and logs it to a file.

20. Plot Stamp Settings: Displays

the Plot Stamp Dialog BoxPlot Stamp
Settings Dialog Box, in which you can
specify the information, such as
drawing name and plot scale that you

want applied to the plot stamp.

21. Publish in Background:Toggles
background publishing for the
selected sheets.

22. Send the Sheets to the Plotter in
Reverse Order: When selected, sends
sheets to the plotter in reverse of
default order. This option is available
only if the Plotter Named in Page
Setup option is selected.

23. Open in Viewer when Done: When
publishing completes, the DWF,
DWFx or PDF file will open in a viewer
application.
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13. Create and Edit Dynamic Blocks

Dynamic block references contain grips or custom properties that change the way the reference is displayed in the drawing after
it is inserted. Dynamic blocks allow you to insert one block that can change shape, size, or configuration, instead of inserting
one of many static block definitions.

Some dynamic blocks are defined so that geometry within the block can only be edited to certain sizes specified in the block
definition. When you use a grip to edit the block reference, tick marks are displayed at the locations of valid values for the block
reference. If you change a block property value to a value other than one specified in the definition, the parameter will adjust to
the closest valid value.

13.1.  Dynamic Block Editor

You can access the Block Editor by typing the edit command or by double-clicking the block without attribute. The Block Editor
ribbon interface will show as below, the black arrows mark the stand for parameters, while the yellow lighting is the symbal for
action. It will pop-up toolbars in a classic interface.

=/ Mone  Insert  Amotate 3D  Vier  Manage  Output  Block Editor | Help  Express Style ~ - = X
B o gf S tUCE geaR tuLLURGs g xBL Y
Sl AE4® AR R R = -
ave Define Update Parsmeter Action 5B Visibility Close Block
Block Attribute B+ BY H Y B E State Editor
Hanage Tool Parsnster Action Parsmeter Sets Visibility Close
Properties 2 x
(Mo saection w8 |3
stretch 2
Layer 0
Color W ByLayer
Linetype ByLayer
Linetype scale 1
stretch 1 Lineveight  BYLATER
Thi ckness o
Center-X
TextFlip 2 e
CenterZ
Y teh Hei ght
& strel v
FlipState UCS icon on  Tes
skt ' UCS nene
Snap on ¥o
’:{> é; scale
vvislblity Grid on ¥o
! A d
distance Block nane
TextFlip 3 Scale unifoaly No
Fllpsmw l Allow exploding Yes
| Unit Millineter
b D
T escription
x[SeTect objects: -~
aPpposite corner:Find out 2, total 2
Select objects:
Current settings: Copy mode = Multiple
Specify base point or [Displacement/mOde] <Displacement>:
Specify second point or Cuse first point as displacement): v
Fomnand: an 5
1584.2007, =364, 0815, 0 SNAP GRID OKTHD | POLAR | OSKAP | OTRACK | L¥T | DIN | MODEL | e

13.1.1.  Dynamic Block Editor Tool Panels

Using the tools in this Tool Panel to define, edit and modify dynamic blocks definitions , makes it very convenient and fast.

Manage block.

Save or Save as the default block; Create or edit another E(E)I &
Save 5
Elock

Manage
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Tool Parameter Sets
Define, edit or update the block attribute. You can add the parameter set on this panel.

r
=
r

=N - |
RTRTRTERY

. A
o T oL :
lefine Up:l-:te ‘{:"u {’ {’u IEE IEE IEE IE"‘S IE"‘S
Attribute ﬁ; e v|:| E]
Tool Parameter Sets
Parameter
You can add parameters for Dynamic Blocks on this panel.
[ R AL - Visibility
IS A= s h This panel is specially used for Visibility editing.
Parameter EO —;3—_ :
o s % 0@
arameter . B -
Wisibility
State
Action Visibility
You can add actions for Dynamic Blocks on this panel.
i % B & Close
1 B ¢ i It is used to exit the Block Editor. Before exiting, some
Aetion o oo commands like save or open etc. might not work.

fetlon X

Close Elock
Editor

Cloze
13.1.2. Parameters

Define custom properties for the dynamic block by specifying positions, distances, and angles for geometry in the block. You
add parameters to a dynamic block definition in the Block Editor. In the Block Editor, parameters have an appearance similar to
dimensions. Parameters define custom properties for the block. Parameters also specify positions, distances, and angles for
geometry in the block reference. When you add a parameter to a dynamic block definition, the parameter defines one or more
custom properties for the block.

A dynamic block definition must contain at least one parameter. When a parameter is added to a dynamic block definition, grips
associated with key points of the parameter are automatically added. You must then add an action to the block definition and
associate the action with a parameter.

Parameters also define and constrain values that affect the dynamic block reference's behavior in a drawing. Some parameters
can have a fixed set of values, minimum and maximum values, or increment values. For example, a linear parameter used in a
window block may have the following fixed set of values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set to a parameter allows you to limit how the block
reference is manipulated in a drawing.

Point Parameter Defines an X and Y location in the drawing. A point

'ﬂ parameter can be associated with a move or stretch action.
Icon:

Command: BParameter—0
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Linear Parameter

4 [
Icon:

Command: BParameter—L

Shows the distance between two anchor points. Constrains
grip movement along a preset angle. A linear parameter can
be associated with a move, stretch, scale or array action.

Polar Parameter
o
lcon;

Command: BParameter—P

Shows the distance between two anchor points and displays
an angle value. You can use both grips and the Properties
palette to change both the distance value and the angle. A
polar parameter can be associated with a move, scale,
stretch, polar stretch, or array action.

XY Parameter

IDD
[con:

Command: BParameter—X

Shows the X and Y distances from the base point of the
parameter. It can be associated with a move, scale, stretch,
or array action.

Rotation Parameter

Icon:ﬁ\n

Command: BParameter—R
Defines an angle. The rotation angle can be in any value, or
be defined in a range or a specified value.

Alignment Parameter

Icon: *

Command: BParameter—A
Definesan X and Y location and an angle. An alignment
parameter always applies to the entire block and needs no

action associated with it. An alignment parameter allows the
block reference to automatically rotate around a point to
align with another object in the drawing. An alignment
parameter affects the rotation property of the block.

Flip Parameter

=N
[con:

Command: BParameter—F
A flip parameter flips objects. You can associate a flip
parameter with a flip action.

Visibility Parameter

=

[con: 5

Command: BParameter—V

Controls the visibility of objects in the block. A visibility
parameter always applies to the entire block and needs no
action associated with it. In a drawing, you click the grip to
display a list of visibility states available for the block
reference.

Lookup Parameter

[con: Ij

Command: BParameter—K

Defines a custom property that you can specify or set to
gvaluate a value from a list or table you define. It can be
associated with a single lookup grip. In the block reference,
you click the grip to display a list of available values. You
can associate a lookup parameter with a lookup action.

Base Point Parameter
+5

Command: BParameter—B

Defines a base point for the dynamic block reference relative
to the geometry in the block. Cannot be associated with any
actions, but can belong to an action's selection set.

[con:
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13.1.3. Actions

Actions define how the geometry of a dynamic block reference will move or change when the custom properties of the block

reference are manipulated in a drawing.

Move «&%

ICommand:BActionTool—M

A move action causes objects to move a specified distance
and angle such as a point, a linear, a polar, an XY parameter,
etc, moves all objects in a selection set in a/any direction.

Scale

Command:BActionTool—S

A scale action such as a linear, a polar, an XY parameter, and
so0 on, scales the selected objects in the direction of the
parameter. Users can manipulate the grips in different way
by changing the properties and values in the Properties
palette.

Stretch [+
Command:BActionTool—TA stretch action causes objects to

move and stretch a specified distance in a specified location.

A stretch action associated with a point, a linear, a polar, an
XY parameter, etc.

Polar Stretch

Command:BParghieter—Pin A
polar stretch action rotates, moves, and stretches objects a
specified angle and distance when the key point on the

associated polar parameter is changed through a grip or the
Properties palette.A polar stretch action can only be applied
to a polar parameter.

Rotate (%

Command:BActionTool—P

A rotate action is always associated with a rotate parameter.
Selected objects can be rotated freely, or the way the grips
are ma&lﬁhlated is different in the Properties palette.

Flip
Command:BActionTool—F
A flip action is always associated with a flip parameter.

Aray BY

Command:BActionTool—A

An array action is associated with a linear, a polar, an XY
parameter, etc, copies and arrays selected objects in
different way.

Lookup [E]

Command:BActionTool—L

A'lookup action can only be associated with a lookup
parameter.

13.1.4. The General Steps of Creating a Dynamic Block Definition

In order to get a Dynamic Block Definition, improve block editing efficiency and avoid repeating modifications, we can create

Dynamic Block by the following steps.

Step1: Planning

Before creating Dynamic Block, it is essential to plan Dynamic Block, plan the functions, appearance, the method of drawing
and required Parameter(s) and Action(s) which are needed to achieve prospective functions.

Step2: Draw geometric figure

The included basic pixel during Dynamic drawing, of course, you can draw these pixel in Block Editor.

Step3: Add Parameter and Action

This is the most pivotal step when creating Dynamic Block. When editing the Parameter and Action, you not only consider the
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achievement of Parameter and Action, but also consider the readability of Dynamic Block and the convenience of Modification,
let the action point of the Parameter attach on the corresponding pixel as far as possible, and put the Action near to its relevant
parameter, if there are more Parameters and Actions, they still need to be renamed for understanding, editing and Modification.

Step4: Test Dynamic Block
Save and Exit Block Editor, start the Dynamic Block test to check if it reaches to the prospective effect.

13.2.  Dynamic Blocks Creation Samples

See what you are able to do within the Dynamic Block Editor, and get the most out of your design. See the follow samples:
13.21.  Base Point Parameter

Although the majority of parameters only taken into effect when operations are matched with

actions, there are exceptions, base point parameter is one of them. - = wsﬁi f‘ S ¢
Visibility : Close Block

State Editor

Visibility Close

1. Define blocks: Define block and draw a circle in the block editor, as shown.

2. Add base point: Click "base point" parameter on the parameter panel, put the parameter on
the center of the circle according to system prompt, as shown in the below illustration.

n L QLR A W R oav o, ms
I = .t V. ¥ 1 - o
ﬁ t Qa E ﬁ’

Paran % A Parame

T s
\b/

3. Insert block: Save and exit block editor, insert the block in the model. You
can realize, base point becomes the insert point of the block after adding the
base point parameter. Please note, if you set an insert point via the block define
dialog box, and add a base point parameter as well, the base point is the default
insert point.

[Epecify insertion point or 3| [Kze= ]

13.2.2.  Visibility

Using the Visibility Parameter function, you can control the display and hide a certain view in Dynamic Block.

1. Prepare view: Prepare a three cars view and define as block.
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2. Add Parameter of Visibility: Enter into Block Editor by Double-clicking the Block or right- click the menu, click the button
Visibility of Parameter in the Parameter panel, appoint the position of the Parameter according to the system prompt, as shown
below.

WVisibility

3. Edit the states of Visibility: Double click the button Visibility, the Visibility States dialog box will be displayed. In the dialog
box, you can rename, new and remove the Visibility States. In order to control the visibility of the three cars view in this example,
we click on new for the three Visibility States as shown in the following picture.

Click the following button as shown in the picture and choose roadster in the pull down menu.

Visibility States():

o e s
. Roadster m Truck
ViSTHILIAY, pr—
State Roadster [k DeletelD]
Vi
cars =
Truck

[ ok ][ cancel |[ HebH) |
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Click the “Invisibility” button in the Visibility tool panel, select truck and car, make them I= % O NI 4
invisible in the “roadster” state, as shown in the following picture, after selecting, press B s

enter to confirm. For the state of “Car” and “Truck”, set them in the same way. ~

4, Move and Adjust: After finishing the editing of the Visibility States, move the three cars
view to make them overlap as shown in the picture bellow.

5. Test Dynamic Block: Insert the edited Dynamic Block into a drawing, select Dynamic Block and click the grip of Visibility
Parameter, choose one item in the pop-up pull-down list, Dynamic Block will change the display state automatically, as shown
in the following picture.

13.2.3. Alignment

/

Alignment Parameter can give dynamic blocks the function of alignment automatically, which can /
save the step of rotating the blocks. Roughn/e S

Select the icon of the alignment parameter. Specify the location and the aligned orientation of the
parameter following what the computer asked as shown in the picture, the dotted line is the align
orientation.

1. Add an alignment parameter for a roughness symbol: Draw a roughness symbol in the Block Editor. <\ )
Y.
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2. Test the dynamic block; Insert the roughness dynamic
blocks, move the align grips, the symbol will align with \
the interface of the dimensions, as shown pin the picture ¥

below. W 7777777777 7777 \ [> W 77777777777772,
- | i 8 g |

Flip: When you use the "roughness symbol block" to label the spare parts, the symbol is sometimes already in the right position,
however, the characters' direction is not right. We need to add the "character flip" function to receive the correct label.

1. Add flip parameter: Click the "flip" parameter button, add the flip parameter W/ visiblity

; ; ; !
according to prompt, as shown in the picture. i 4 Roug ess

2. Add flip action; Click the flip action button on the action panel, match
parameter and object for the action. Herein, we choose "roughness" as the object, and position the action button, as shown in

below picture. l
flip 2
Use the same method to add a

itz 4 g o 1 pair of flip parameter and action  pypstate 4 Roug €SS % flip 1
% " of the vertical direction, as Y

shown: -

VVisihlity FlipState 1
% Vvisiblity

13.2.4. Point Movement

- 1 ] |

1. Draw a drawing: Draw a drawing and define it as a block.

Position
=
g
e
@

2. Add point parameter: Click point parameter on the tool bar, define the parameter

position according to prompt, as shown in the picture.

3. Add move action: Click move action button on action panel, match parameter and object for the action, and define the
position. The position of action label does not affect the effect of the dynamic block, however, for the sake of beauty&
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convenience, try to put the label near the related parameter.

Select Objecté Select Objects.

L
Placed action
4, Test dynamic block:Insert the dynamic block, drag the blue grip, then move the ,
keyway to the right accordingly, as shown in below picture. Obviously, the dynamic W
block can achieve the expected results. Please pay attention, if it is not run with ortho '

constraint, the keyway can move towards every direction because the direction of the Pomne
) ) Movement
point parameter is random, the _ »
|

| |
characteristic of the parameter L]‘; k

decides the characteristic of M = ] I ’ | ) ) B

action. R

13.2.5. Linear Movement

Actually, limited to the demand of the material mechanics characteristics, keyway is only allowed to be placed on the central
line. So, a horizontal movement is enough for keyway and the movement to other direction is not meaningful. Next we will take
advantage of the linear parameter to define the keyway’s movement direction on the central line of the step shaft.

1. Draw: Draw the follow drawing and define it as a block.

o WS | WERUPPE S — -

Distance

2. Add linear parameter: The way of adding a linear parameter is similar to A‘
dimension, both try to put the absorption point of the parameter on the central \%>
ling of the step shaft.

Distance

3. Add Move Action: Different from the point move, after specifying the T T e,
parameter, the system will prompt: Specify parameter that is related to
movement. Select right grip of parameter as “Related parameter point”, as _,_QE'QQ,/ > =1

shown in the following picture.

The parameter point we mentioned corresponds to the operate point of Move. Distance
After exiting Block Editor you can drag this point to make dynamic block
change correspondingly. After selecting the related parameter point you can )
specify the move objects for action, as shown in the following picture. Place . - B
action label, save and exit dynamic block.

153



Chapter 13_ Create and Edit Dynamic Blocks

4 Test Dynamic Block: Select dynamic block and drag the right grip of the
parameter. Meanwhile, no matter how the cursor moves, the keyway is limited
to the central line of the step shaft. That is to say with the limitation of the B =
lingar parameter, the dynamic block can only move along the direction
specified by the linear parameter.

imtance Distance 0.8001

e W -ﬂ ------------ Angl.
13.2.6.  Number of Grips 5 dhve S

! Dist minimum

Dist maximum

In the Block Editor, select the lingar parameters, change Base Location Start Foint
ties Tes
the number of grips to “1” in the properties panel. Chain &

Save and exit the Block Editor, choose the Dynamic Block, you will
find that one grip has disappeared. In fact, after changing the number .
of grips from “2” to “1”, the first thing that disappeared was the basic e : ;
grip of parameters, namely the first point when adding parameters. e - :
Position-X 62.0178
1327, Angle Offset R e =
—) 4 Distance muttiplier |1
Angle offset 30
Open Block Editor, choose the Angle offset from 0°to 30°in | = = ctiiiane [Maim
the action property, save and exit the block editor o
o
Select the Dynamic Block and then move the right side grip. You will find it e
can only move in the direction of 30°as it is shown in the follow picture. The - B
direction of action can change according to the Angle Offset. '*_/ _ B

13.2.8. Linear Stretch

During a mechanical design, we often need to change the position as well as the dimension of the keyway. In this section, we
will add Linear Tensile function for the keyway on the step shaft.

Distance

1. Add linear parameter:
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2. Add stretch action: Click the stretch action button on the action

panel, choose parameter according to prompt and define right
grip as key parameter point, as shown in below picture. The black
object is the operational object of the action, the broken line
frame is the stretch frame, objects intersect with stretch frame will

be stretched, objects which will be selected by the stretch frame

will move.

3. Test dynamic block: Exit from block editor, drag stretch grip to stretch

the keyway, as shown in the picture.

13.2.9. Parameter Value Set

For mechanical designs, we often need to stretch the keyway to a certain length. Now, let us see how to realize an accurate
stretch. Pick linear parameter in block editor, click entry frame which is on the right side of" distance type" on the Properties

panel, a drop-down menu will pop up.

Therein, none is the default option, which means it
can stretch optionally. With the other two options,
you can defing the maximum and minimum number

respectively.

%Stretcb Start-Y
End-X

56.6813
24.1734
57.4814
End-T 24.1734
Label offset 2.4279
Distance 0.8001

Base Location Start Point

Show Properties|Tes

Chain Actions No

"Increment" means stretch increasingly, a Value set

appears as shown below after selecting increment. If you choose "list', a
Value set appears as shown in below picture, the dynamic block can
only be stretched according to the number in the list.

Click the text frame which is on the right side of the "distance
value list", one button with ellipsis on it will appear. Click this
button, a "Add distance" dialog box will be displayed. Add

three numbers “17.“1.5”.“2" in the dialogue box, as shown in

below picture.

Exit from block editor and stretch the right grip, you will see
several gray lines appearing on the right side of the keyway,
and the keyway can only be stretched to the gray line position,
as shown in below picture. Obviously, by value list, you can define certain numbers of the stretch, to realize an accurate stretch.

| [umber of Grips|1

st e Tt iamant
[Dist increment 0 Dist type 1ist
Dist minimum o z 5
Dist walue list |0, 3001
Dist maximum
Add Distance Value 3.3
Distances to add
|
08001
1
15
Dist type list
s e o
=

%Eﬁ =
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13.2.10. Symmetrical Stretch

There is an easy way to realize the two-way stretch which is adding
two actions of stretch. Though it can realize a two-way stretch, the %Left e
action of stretch is independent. The parameter needs some

additional setup to realize the two-way symmetrical stretch.

Right (Stretch)

LinearParameter

RS

-First, add two stretch actions for parameter, and select the two grips
of the two parameters as the relevant point of each action.

-Second, in the misc, modify the base location from "Start Point" to "Mid Point", like shown in the picture below. Save and exit
the block editor.

For the convenience of watching the effect, we drew a vertical center line in the middle of T
the keyway, and then stretched the grip to the left side of the keyway or the right side, as T )
shown in the picture below. As the grips are moving, the two-way symmetrical stretch is -
realized.

{:’ s -
13.2.11. Distance Multiplier

Take the step shaft as an example, if we stretch the left part of the step shaft and the w

keyway still is at the center point of the smaller diameter shaft after stretching. Then, we
use the “Distance Multiplier” property of action to achieve the aim. Jer — = B e |l

1. Add linear parameter and stretch action for step shaft: - st
Hide the right grip of the parameter point, the action stretch

box is as in the following picture, the bolded object is the
action operation object.

2. Add Move Action for keyway: Select the left grip of the i "
linear parameter when moving, stretching the related

parameter points. Move the objects of action and select the —————
whole keyway, as in the following picture. — — _
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3. Modify distance multiplier of action: Select Move et e it SRR S P

Action and modify the default value from 1 to 0.5 in the

l’ Hove

property of the distance multiplier, save and exit the L [P slih

block editor.

4 Test Dynamic Block: Stretch leftwards grip and with the grip moving leftwards,
the smaller diameter shaft will appear with a stretch effect, the keyway will also
move leftwards accordingly, meanwhile, the keyway is in the center of the
smaller diameter shaft of the step shaft all the time. Although Stretch and Move
have a common parameter, when the Distance Multiplier of Move is modified to
0.5, the displacement of Move can only stretch 0.5 times of the displacement.

13.2.12. Chain Action

+-—=

If you want to realize a symmetric stretch without changing the keyway center and the length of smaller diameter shaft changes

with the stretch at the same time, how can you realize that?

1. Add stretch for Step Shaft: Add stretch parameter and action for step

shaft as the following picture shows. There into, the bolded objects -

indicate the operation object of action. Because the follow-up operation

W Stretch
¢ LinearParameter

will not stretch the step shaft by grips of this linear parameter, the grip’s

number of the linear parameter can be modified to “0”. *

%St retch

="

2. Add linear parameter for keyways: Set the base point i
position of the line parameter as “Center” in order to e L i
realize the symmetric stretch function. ﬁ

;;;;;;

PRNTEN
57.4814
24.1734
1.3798
0.8001

3.Add the stretch rightwards action for the keyway and realize chain action: Select the “Distance” linear parameter and modify

the chain action of prosperity from “NO” to “Yes” as the following picture shows:

jE;Stretch

LinearParameter
[ f-—

Distance

%Strefr Right)
1

= - -

55.57T5
241734
-2.252
3.5200
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Add the Stretch Leftwards action for keyway as the following picture shows.
Special Note: Do elect “Distance” for the linear parameter to stretch
leftwards the operation objects set. This is a necessary procedure of the

%Sue\ch

LinearParameter

g treteh (Lefd ﬁstm"

Distance

ight)

chain operation.

4 Test Dynamic Block: After dragging the left grip, not only the keyway will
stretch bi-directionally and symmetrically but also the smaller diameter shaft of
the step shaft will stretch automatically. This is a chain action. The realization of
a chain action has two important procedures: First, modify the property value of
the parameter that need to happen as linkage and modify the property of “chain
action” from “NO” to “YES”. Second, elect the parameter of objects that are
elected to linkage action to set.

13.2.13. Scale Action

==h—

Scale Action can be matched with the Linear Parameter, Polar and XY Parameter to achieve various Dynamic effects.

Linear Scale

1. Draw: Finish drawing an access hole in a model space and define it as a block, as shown in the

following picture.

2. Add Linear Parameter: Enter into Block Editor to add a linear
parameter. The start point of the Linear Parameter is the center
of the circle, and choose the number of grip as “1”as shown in
the following picture.

3. Add Action: Click the Scale icon on the Action Panel, appoint parameter for
Action and box the whole access hole as Action Object, as shown in the
following picture.

4. Test Dynamic Block: Exit from Block Editor and insert the Dynamic block,
after pitching up the Dynamic Block, drag the triangle grip, the objects
(nuts) will scale with it.

Start-Y 0

End-X 12

End-Y 0

Label offset  [-15.0527
Distance 12

Angle

Dist type None
Dist minimum 0O
Dist maximum
Base Location Start Point
Show Properties Yes

Chain Actions No

Womber of Grips|f] v

Number of Gri,:

Number of grips associated to

5 object
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Polar Scale

When we move the Scale Grip of the Access Hole on the left of circle center, namely move the
base point of the Linear Parameter to the left of the circle center, we will find that the block does
not have a corresponding Scale, as shown in the following picture.

The reason for this is that the Endpoint of the Linear Parameter cannot cross its base point, so
we change the Linear Parameter to be a Polar Parameter, we do not change any other
operations, as shown in the following picture.

Exit from Block Editor, Drag the grips of the Access hole Block again,
you can see, that after the change from Linear Parameter to Polar
Parameter, we can drag the grip to scale the dynamic block in any
direction.

13.2.14. Scale Character

In this section, we will explain some Scale characters using XY Parameter and Scale Action in a paired example.

1. Drawing graphics: Draw the graphics which need a dynamic block and define them as a block as below:

O

2. Add XY Parameter: Entry Block Editor, add XY Parameter. Parameter adding is similar to Linear Parameter. Pick the first point
of the parameter from the left bottom corner of the rectangle as the base point, the second point from the top right comer and
change the Number of Grips to “1”. Then add Scale Action, as shown below.

é ﬁScale
;? B

istance

jE;Scale
(:i) Y Distance

o
f-

X Distance

I3

HEdl
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3. Test the Dynamic Block: After exiting the Block Editor, drag the grip of the top right (-
corer of the rectangle, you can see the whole dynamic block is scaling as the grip is [ _______________________________ /
moving. It is easy to find that both the circle and the rectangle scale by the base point ’

of the XY Parameter. ? Q

5. Modify Action Base: Modify Base type: go back to Editor, select Scale Action and change the default “Dependent” to
“Independent”.

[Scale type  [UT Scale

‘B Scale
Fd Baze-f

s [pase-y
o Y Distance

Eae

X Distance

+

Scale type XY Seale

Specify new base: Single click the right input box of “Base-X" and -%ra;c ﬁgh@
“Base-Y”, you can manually input the coordinate value or you can ¥ Titaiames m .1
single click the small button with ellipsis dots on the right of the ST
input box and snap the base point, as shown: * +

X Distance
Specify the base point by crosshair and the circle center as base point. After o
exiting Block Editor, scale the dynamic block. After modifying Base type and i ,/
position, the scale center of the dynamic block changes from the XY Parameter |
base point to the new specified base point (center of the circle).
6. Scale Type: There is “Scale Type” in the Scale Action B -
Properties. The default value is “XY Scale”. If you choose ‘f[!!j;ScaE %

Y Distance

“XY Scale”, the dynamic block scales whenever the scale
grip moves to X axis or Y axis. If you choose “X Scale”, it

scales only when the grip of the scale moves to X axis. =
Same, when you choose “Y Scale”.

X Distance

13.2.15. Rotation

In this section, we are going to use a rotation parameter and rotate action to add a dynamic rotate function n
to view index symbols (English system) which are frequently used in architectural drawings.
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1. Draw a drawing: Draw a view index symbol and define as a block, as shown in below picture. Please define view number and
drawing number as attribute text, so as to revise whenever you want.

2. Add rotation parameter: Pick the center of the circle as the first point of the parameter, system default it as the rotation point,
set angle type as "increment", and define its number as 15 degree, as shown below.

3. Add rotate action: Click the rotation action
button on the action panel, match parameter,
object and position for the action and select the
whole index symbol as the object of the action.

Rotation

4. Test dynamic block: Exit from block editor and insert the block, { N
drag rotation grip to reach the effect of rotation, as shown in below 101 / |:>
picture. 4

13.2.16. Polar Stretch
We use the Polar Stretch function of Dynamic Blocks to draw the section symbol in this section.

1. Draw, Mirror and Define as a Block: The follow drawing includes the attribute text which can be modified as you need. Then
mirror this drawing and define the mirrored object as a block.

A oA A

2. Add action and parameter for the attribute text: Add Point
Parameter and Move Action for text and change the Chain
Action to “Yes” .It is ready for next step to create Chain
Action for Polar Stretch Action.
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¥
3. Add Polar Parameter and Action: Add Polar Parameter whose first point A
should be the center of the section symbol. This point will be the rotation
center of the Polar Parameter. Follow the instructions below:

Distance

%PolarStretch
gition
Move

1. Pick the right grip of the Polar Parameter as an associated parameter point and specify the Stretch box (Fig. 3.1).
2. Select objects to stretch and the “position” Point Parameter together, which can accomplish that the text and section symbol

are moving together (Fig. 3.2).

3. Specify objects which rotate only for Polar Stretch Action (Fig 3.3).

4. Specify Action symbol location (Fig 3.4)

5. Repeat the above steps to add the same parameter and action order for the left part.

Distance

=
—

Fig 3.1

Distance

Is

Fig 3.2

{ é—/posit

%Move

Distance

A A

ﬁ Move

Fig 3.3

Distance

Fig 3.4

It is better if you hide the grips which are not associated with the Polar Stretch Parameter as below:

;E;PolarStretchl Distancel

positionl

fruna B

Distance

PolarStretch

osition
Move
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4, Test Dynamic Block: Open the graphic which
needs to be dimensioned and insert the completed
dynamic block (Fig 4.1).

Drag the grip of the dynamic block, the section
symbol can be stretched outward and rotated .
around the center, and you finish the section | |
symbol mark (Fig 4.2). ‘ |

Fig 4.1 Fig 4.2

Before modification

13.2.17. Polar Stretch Action Characteristics -

&) A
Modify the grips’ number of the polar parameter in the section symbol dynamic block ¥odified
in the last example to display both of the two grips of the polar parameter. From the A I— T "I A

following picture we can see that the central grip is clearly different before and after.
Before modifying, the central point was actually the base point of the block, and this was the insert point. But after modifying,
the center point of block is the base point of the polar parameter.

Clicking central grip can move the grip to any direction. Meanwhile, the dark blue insert point of block will appear again, as
shown in the following picture. Obviously, the insert point is only covered by the base point of the polar parameter. The base
point of the polar parameter can move arbitrarily, but for the block it seems that no = o

change is happening. But is it true? A I_ . “l A

L A
In order to confirm if the block changes or not, we move the grips on Ar o d -I A E:> Ar = h
both terminals and we can find that the section symbol does not center
on the dark blue base point when changing but it takes the base point of == A r _
the polar parameter as a rotate center, as shown in the following picture. Ar o _] A E:> Vi ']A

Enter block editor, move up the parameter and the other settings do not change.

Distance

%PolarStretchl Distancel & &l %Polarstretch

—d

Bt X
pos1t1onlm ’ osition
%Movel Nove

Exit block editor, move the right grip and you can see that = ]
rotate center moves up along with the parameter. From the 'r = -‘ A : Ar

examples above it is difficult to understand that the polar
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parameter cannot move arbitrarily like the point parameter and linear parameter, the reason is that the base point of the polar
parameter specifies the rotate center of the object, once the parameter is moved, the rotate center will move accordingly. That
the rotate parameter cannot move arbitrarily has the same reason.

13.2.18. Array

For the Array function of Dynamic Block we need to use Array Action, we use Array Action to match with Linear Parameter, Polar
Parameter, XY Parameter to achieve various Arrays.

Linear Array

1. Draw: Draw a parts list and define it as a block.

o, Name Number | Materials Norm Note

2. Add Linear Parameter: After adding Array Action, we can drag the two grips of the Parameter to make a list array, but
obviously, we hope just to achieve an up array of the blank bar, not a down array, so to avoid a mistakes, we should hide the
grip under the Parameter, as in the following picture.

Lﬁé Ar ra}ﬁ St[éaél:r)_llceeArray

i) = X

No. Name Number | Materials Norm Mote

3. Add Array Action: During the add Array Action, the system will require to appoint space between columns. The space
between columns is the distance between the objects that the array created. Here, the line width is 7mm, for the line between
the lines a close up array can be chosen, we appoint that the space between the columns is 7mm.

Arr ayD{i stance

‘B Tanlebrray
7

G

jua)

No. Name Number | Materials Norm Note

4. Test Dynamic Block: Insert Dynamic Block, drag the top right corner grip upwards, the line number of the part list will be
added automatically, as in the following picture.

No. Name Number | Materials Norm Note
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=Y
XY Array
Compared with Linear Array, XY Array 1 ' [
has a vertical direction Array. [ 74 '
Polar Array

We see a Dynamic Block example as follows, after
dragging grip, the effect will be as in the following

picture. You can see, not only can we stretch the fence,

but we can also rotate the direction casually, this is the
effect combining Polar Stretch with Polar Array. ¥

Enter into Block Editor; stretch, the ways of adding Array I [
Action as shown in the following picture, the bold object

expresses the relevance with the selected action. The Polar

Parameter determines the way of Array directly, the Polar Array

will regard the direction of the Polar Parameter as Array

direction, achieving Array functions in any direction. Y %Arm?

D
)
P

—>> <

T : %Stretch 7 W Stretch

Distance
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14. Share Date between Applications

14.1.  Net Framework Support

.NET API enables you to manipulate the application and drawing files programmatically with libraries that are exposed and can
be accessed by many different programming languages such as VB.NET, C# and Managed C+ + .etc. Users are able to
automate tasks such as creating and modifying objects stored in the database of a drawing file or change the contents of a
customization file.

14.2.  ObjectARXAPI

GstarCAD 2024 for Linux GRX is compatible with AutoCAD ObjectARX 2020 APIs, programs can be successfully compiled,

loaded and used without editing code, which saves a lot of time in migrating applications developed with AutoCAD ObjectARX.

14.3.  Copylink Command

Using COPYLINK command, Users can copy the current drawing view to the Clipboard and then paste the contents of the
Clipboard into another document as a linked OLE object.

14.4.  Python Interface

GstarCAD 2024 for Linux adds the Python development interface type which expands the ecosystem of secondary development.
Python, as a simple and widely used programming language, has a large number of third-party libraries that can easily facilitate
data exchange between various applications. Users can use Python to extend the functionality of the GstarCAD platform software,
such as creating customized commands, customizing graphics and views, accessing and modifying various types of graphical
data in drawings, implementing custom drawing and drawing analysis algorithms, and more.

14.5.  Lisp Debugger

You can enter the VLISP or VLIDE command, or click Ribbon » Manage * Applications > Visual LISP Editor to launch the
Visual Studio Code as the Lisp Debugger in GstarCAD 2024 for Linux, in which you are able to edit, and debug Lisp programs
conveniently.

(G R
File  Edit
ome

Insert
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If you haven't installed the Visual Studio Code software, a warning will pop up, asking you to install it first.
If the Visual Studio Code software has been installed
inyour PC, it will be opened in a few seconds. You
can visit VS Code official website
(https://code.visualstudio.com/docs/getstarted/userin
terface) to learn more details.

GstarLisp:This extension adds support for Lisp files to
Visual Studio Code. It allows you to edit and debug
your lisp programs with GstarCAD. When you start VS
Code through GstarCAD, it will install the GstarLisp
extension for you by default. And when there is a new
version of the GstarLisp extension, it will be updated automatically the next time you start VS Code through GstarCAD. Or, you
can also search and install it in marketplace.

1. Open File
You are able to open LSP files or DCL files and debug
them when the VS Code is opened and GstarLisp
extension is installed.
> Click the GstarLisp extension icon, then click
"Open Folder" icon, select the folder, and
the .Isp and .dcl files will be filtered out.

»  Click the file in the list to open it in the
editing area.

> Click the refresh button to reload the selected
file if you need.

)
395,Col21 Spacesi2 Windows 1252 CRUF LsP & O

c:ifoo (/ abecdefghiiilst)
2 Ed' F'I (entmake (list (cons @ "line") (cons 1@ (list @ @ @)) (cons 11 (list 1
. Edit File
(setq a 1235

What you can do to edit the program with GstarLisp
extension in VS Code:

> Syntax highlight E:::l ;(;;St e BREED S (s i ) (SR O B F LD
> Code folding (e

> Smart hints e e

> Autocompletion zsetq o (list 123 3.323 "444.22" (cons "p" 222) (list j k 1) p r s))
> Code snippets Ei:;za:ksezsenq Ist (cons ii 1st)) (setq ii (1+ ii)))

(princ)

)

(setq value)
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3. Debug
Basic debugging steps include:
» Step 1. Launch VS Code

> Step 2. Open a LSP file ora DCL file
> Step 3. Add debug configurations and edit launch.json
> Step 4. Choose a debug configuration: GstarLisp-Launch or GstarLisp-Attach
> Step 5. Click Run>Start Debugging (or Press F5)
GstarLisp-Attach:

Allows you to attach to a running instance of the GstarCAD application to debug the current LSP or DCL file.

N

arlisp-Att:

which can be ¢
or run. GstarLisp-Launch
Node.js
Run and Debu¢ \eh App (Chrome)
. Web App (Edg
To customize Run and Dek *~ PP ¢ dge)

. e sion for LISP.
and create a launch  Install an extension for LISP..

As long as you choose GstarLisp-Attach configuration, you need to select a running GstarCAD instance as debug adapter. If
there is no running GstarCAD instance in your PC, a warning will pop up, and the file can’t be debugged.

< d_printAndDrawlsp X (]

-2 GstarCAD 2023 Professional (Preview)[Trial day left 67] - [VLISP.dwg]
|5 PID:2996
Lpeipun
treal "\n radius”
*2r))

Visual Studio Code X

6 Couldn't find a debug adapter descriptor for debug type ‘attachglisp’ (extension might have
failed to activate)

] Open ‘launchjson’ Cancel

GstarLisp-Launch:
Launches a new process of the GstarCAD application to debug the current LSP or DCL file.

: RUN

which can be d S AR
or run. GstarlLi

Node.js

Run and Debuc \wep, App (Chrome)

To customize Run  \Web App (Edge)

As long as you choose the GstarLisp-Launch configuration, you need to specify the absolute path of the gcad.exe file in the
extension settings of the GstarLisp extension (path format C://Program files//Gstarsoft//GstarCAD2023//gcad.exe)
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: RUN

which can be |d. “u - — - —
or run (repeat (setq idx (ssiengtir sei)
x (1- idx)
Run and Debug ent (ssname sel idx)
enx et ent)
To customize Run and ug, 1st (vlax-ename->vla-object d
and create a la

GCAD doesn't exist. Verify and correct the folder path to

the product executable.

Source: GstarlLisp (Extension)

4, Debug Actions
Once a debug session starts, the Debug

toolbar will appear on the top of the editor.

Note:

>

\4

Step In
F11
Step Over

Continue / Pause: Jumps to next F10
breakpoint. Play/Continue
Step Over: Completes current FS

line and moves to the next line of

code in the current function.

Step Into: Completes the next line of code. If this line contains a function, go to the first line of the function's code
and stop.

Step Out: Completes all the code in the current function and return you to the previous function that "called" this
function.

Restart: Restart the debug session.

Stop: Stops the debug session.

Step Out

Shift + F11

Restart

Ctrl + Shift + F5

Stop/Disconnect
Shift + F5
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> In GstarLisp, press F10 to complete current line and move to the next line of code, while in AutoLisp, press F10 to
complete current line, and then press F10 to move to the next line.
> When you click the Restart icon:
e  (starLisp-Attach configuration: Current debugging session will not be stopped, and the debugging will be
restarted in the current CAD instance.
e  GstarLisp-Launch configuration: Stops the current debugging session, end the current CAD instance (without
asking whether to save the drawing), and then re-launch a new CAD instance for debugging.
> When you click the Stop icon:
e  GstarLisp-Attach configuration: Stops debugging session, but keeps current CAD instance.
e  GstarLisp-Launch configuration: Stops debugging session, end the current CAD instance (without asking
whether to save the drawing).

5. Run View
Once a debug session starts, the Run View windows will appear on the left of the editor, include:

> VARIABLES ~ VARIABLES

The Locals and Last Value windows show variable values while you are debugging. The
windows are only available during a debugging session. The Locals window shows
variables defined in the local scope, which is usually the current function or method. The
Last Value displays the value of the last changed variable.

v Last Value

> WATCH LAST-VALUE®: 1

While you're debugging, you can

use Watch windows to watch variables and
expressions. The windows are only available
during a debugging session.

Watch windows can display several
variables at a time while debugging. You are
able to add, edit or remove expressions by Remove Expression
right click on the Watch windows. errens -l Epreesens

Add Expression
Edit Expression

Copy Value

> CALL STACK
s CALL STACK PAUSED ONSTEP [

The Call Stack windows display a list of all the procedures that have been C:FoO foolsp 93
executed. It lists the name of the function or procedure that is currently on
the stack. In GstarLisp, the call stack mainly displays the name of the
called function.
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> BREAKPOINTS + BREAKPOINTS

Wl
A breakpoint is a setting that you can add to a line of code to temporarily pause the M user unhandled
execution at that line. Breakpoints can be toggled by clicking on the editor margin or using

F9 on the current line. The Breakpoints windows allow you to control all breakpoints. Remove Breakpoint

Remove All Breakpoints

B foolen FAG

Enable All Breakpoints

Disable All Breakpoints

Reapply All Breakpoints
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15. |FCIMPORT

You can enter IFCIMPORT command or click File  Import # Other Formats to import an IFC file.

File name: IFC_fleT V| [Copen I+

Files oftype: IFC file(*.ifc) ~ Cancel
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16. Innovative Features

16.1. Line Enhancement

ANGLE (A) option is added for line command, with this option you can get a fast way to draw a line without assistance of the
polar or a xline. You can directly input the angle value refers to X axis as well as you can take other line as reference to input the
angle value and even you can input the angle value directly refers to previous line.

Practice example:

To draw the red line in Figure 1-1, the steps as
below:

1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4. Specify angle [Reference] <0>:35(Software will take the X axis as e
Figure 1-1

reference)
5. Length of line: 500

To draw the red line in Figure 1-2, the steps as below:
1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4. Specify angle [Reference] <0>:r

5. Select a line object: (Please select the reference ling)
6. Specify an angle: 38 7. Length of line: 500

To draw the red line in Figure 1-3, the steps as below:

1. Execute line command (to draw the line 1).

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]: |

4. Specify length: 300

5. Specify next point or [Angle/Length/Undo] (to draw the line 2): a —
6. Specify angle [Reference/reference to Previous/Included angle] <0>: p(Here Figure 1-3
you can try reference to Previous option which will take the extension of the

previous line as reference)

7. Specify an angle: 127

8. Length of line: 500

9. Specify next point or [Angle/Length/Closed/Undo]:a (to draw the line 3)

10. Specify angle [Reference/reference to Previous/Included angle] <0>: 1 (Try Included angle option)

11. Specify an angle: 37

12. Length of line: 400
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16.2.  Polyline Enhancement

Polyline

The ANGLE (A) option in polyline command which its behavior is similar as the one in ling
command is also added in Polyline. There are still three choices for angle option, you can either Rectangle
input angle value which takes X Axis as reference as well as you can input “reference to Previous”
angle or “Included angle”. In CAD software, many objects are consisting of Polyline, for example:
rectangle, polygon and revision cloud, donut. Now these functions are classified under the
Polyline drop down list where you can access them quickly.

Rotated Rectangle

“ Polygon

Revision Cloud

o Donut

16.3.  Rectangle Enhancement

OBLIQUE(O) is a new added option to draw an rotate rectangle. The behavior of oblique option is similar as the behavior in line
command. With oblique option, you can locate the angel of bottom line and the length to get a rotate rectangle, you can draw
an oblique rectangle which has specific angle with X axis and horizontal or has random angle refer to any line.

Practice example:

To draw the rotate rectangle in Figure 1-4, the steps as below:

1. Execute RECTANG command and input oblique option or click the rotate
rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]: a(Input Angle option) 2
4. Specify angle [Reference] <0>:20 X Axis Forward Direction
5. Enter rectangle width: 800 Figure 1-4

6. Enter rectangle height: 350

To draw the rotate rectangle when there is a reference line in Figure 1-5, the steps as below:
1. Execute RECTANFG command and input oblique option or click the rotate

rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]a

4. Specify angle [Reference] <0>:r

5. Select a line object: (Select the reference ling)

6. Specify an angle: 20

7. Enter rectangle width: 800 X Axis Forward Direction
8. Enter rectangle height: 350

y peterence

Figure 1-5
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16.4.  Circle Enhancement

CONCENTRIC(C) option is new added in circle command, you can input radius several times to create many concentric circle
after specify the circle center, with this new option, you can get concentric circle in a simple way.

Practice example;

To draw the concentric circle in Figure 1-6, the steps as below:

1. Execute circle command and input concentric option or click the
concentric icon in ribbon panel.

2. Specify center point for circle:

3. Specify the radius of circle or [Diameter] <400.0000>:100

4. Specify the radius of circle or [Diameter/Undo] <100.0000>:200
5. Specify the radius of circle or [Diameter/Undo] <200.0000>:300

16.5.  Copy Enhancement

R300

Figure 1-6

There are three options: measure (E) , divide (1D , path (P) options are added in copy command, user can easily finish the
drawing without the assistance of other operations such as divided by segment, by distance, array, or layout bypath in previous

version.

1. measure (E) when users need to copy objects with same distance and same direction, this option will be very useful.

3490

I

LR IR
® 2w
LR IS
® x %
LR IS
X xR
X 2 x

I

T
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800

266.67
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3. Path (P) After select the path option, you can select divide or measure option again to locate the count objects.

16.6. Rotate Enhancement

Multiple copy (M) option is added in rotate command, with this option, you can either copy many objects with different rotate
angles, or you can draw circles array.

When rotate, you can select multiple copy option and input several angle values; the software will rotate and copy the object
according to the value you input. You can try copy and rotate 45, 90,135 degree refers to the original object at a time such as
the following figure.

Practice example:

Rotate and copy objects in Figure1-7, the steps as below:

1. Execute the Command: ROTATE

2. Select object:

3. Specify the base point: (Select the center of the concentric)

4. Specify rotation angle or [Copy/Multiple/Reference] <135>:m
5. Specify rotation angle or [Between/Fill]: 45

6. Specify rotation angle or [Exit/Undo]: 90

7. Specify rotation angle or [Exit/Undo]: 135

If the adjacent object angle is fixed, you can select “angle between object (B)
or fill angle C(F) option, then input the angle and the quantity, this option can |
replace circle array.

Rotate and copy objects in Figure1-8, the steps as below:

1. Execute the command: ROTATE

2. Select object: (Select the center of the concentric)

3. Specify the base point:

4. Specify rotation angle or [Copy/Multiple/Reference] <30>:m
5. Specify rotation angle or [Between/Fill]: b

6. Specify rotation angle: 60 Fianret:s
7. Specify total number of items: 4
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Rotate and copy objects in Figure1-9, the steps as below:

1. Execute the command: ROTATE

2. Specify the base point: (Select the center of the concentric)

3. Specify rotation angle or [Copy/Multiple/Reference] <60>:m
4. Specify rotation angle or [Between/Fill]: f

5. Specify angle to fill<360>:

6. Specify total number of items: 1

16.7. QR Code

A QR code (quick response code) is a type of bar code that is 5 wos oo S

used to provide easy access to information through a mobile ot Tt
%

[=]
.li

Code can storage more information and is widely applied in many
fields, for example; product anti-fake, advertising push, web links,

device like smart phone or tablet. Comparing with barcode, QR -
data download, commodity transaction, Positioning/navigation, i

[=]

electronic documents, business card exchange, etc. Take B
. Pick Object
advantage of QR Code to make text and block attributes from your T e T 20 Code Porameters
. . . . = = = WVersion: __2 -
drawing scannable using any mobile phone or tablet with a camera. ||| eresetpate N
All you need is one of many available QR code reader applications pewmgliame | [pseadTme g
for your device. Type QRCODE to execute the command - —— ==
y P ' e E] Size: 33% 33

Copy barcode ] [ Save Image ] [ Insert ] [ Exit ]

Parameters of QR Code Creator as below:

Input: In input text area, you can input the text directly or you can pick text data from the drawing, also you can select the preset
data which can display automatically in the input text box.

Already entered:0/500: Displays the entered text number and the maximum Input text number.

Clear: Cleans all data displayed at input text area.

Pick Object: You can select three options to picking objects from your drawing.

Text: Picks text from drawing file, the text will display in input text box automatically after you picked up.

Block: Picks the attribute block from the drawing file, add the tag and value to the input text box. It is always used to pick the
information of the tab.

2D Code: Picks the QR Code from the drawing file to get the information of QR Code

Preset Data:  You can preset data, when the data is needed just check the corresponding option. The information will
automatically added to the input text area.

Drawing Name: When check Drawing Name option, the drawing name will display in the input text area.

Date and Time: ~ When check Date and Time option, the current date and time will display in the input text area.
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Parameters of Costumed Field as below:

Name>Add/Edit: ~ You can customize field that common used, when the field is needed, click the pull down list to find it out
and display it in input text box.

Customed field -
No: Input the field number. P
Name: Input the field name. No Name Value Add
Value: Input the field value. Delete
Add: Add new custom field.
Delete: Delete custom field.
Image: Company logo or others marked pictures can
be added to QR Code. You can also browse pictures
from your computer, JPG\BMP\PNG\TIF\TGA etc
formats are supported.
Delete:  Delete the picture selected. =S

QR Code Parameters: You can set QR Code image parameters before being inserted.

Version: Creates QR Code according to the data you input. Sets the QR Code version, the version
number will adaptively according to the increase of text.

Error Level: Error level for QR Code data generated.

Size: Set the width of QR Code. H (30%)\Q(25%)\M (15%)\L (7%): the compatibility of correcting
about 15% data error.

2D Code Parameters Code: QR Code system. Currently we support Code93.

Version: Scale: Set the QR Code printing scale, behind the scale option is the scale list. You can choose the

serleveh{L@®  ~] geale needed, meanwhile, the scale list can remind user the QR Code generating is related to the

Code: QRCode - - . . .

T — printing scale. Finally, it will generate as a block, the scale you set can be the block scale to

e = ensure the QR Code can be printed correctly in different printing scales.
Copy. Barcode: Copies an existing QR Code from your current T e
drang. [ brawing Name [ Date and Time e QRCode E
Save Image: Saves the QR Code as a picture, you can either paes M e T
use the picture to print or insert to other document or to CAD o (o) oskie | sz esxes
draWing. Copy barcode l [ Save Image I | Insert I [ Exit J

Insert: Inserts the generated QR Code to the drawing as a

block

Cancel: Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved
last time will be displayed.

16.8. Barcode

Barcode technology has been widely used in a variety of industries. In some design companies, barcode has also been used in
drawing management system, mainly used to corresponding paper documents and electronic drawing file, just by scanning the
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bar code in the paper drawing to identify quickly the corresponding part in electronic drawing file.

Bar Code Parameters Preview

Width: 30
Height: 10
CAD

Scale: 1

Gotar
B -

Display D3 Data Input

Code: otarCaD) seed

Pick [:opy barcode] [§ave Image] [ Insert ] [

-
¥
a
¥

Size: 3

Parameters of Bar Code Creator as below:

Width:  Set the bar code printing width.

Height:  Set the bar code printing height.

Scale:  Set the barcode printing scale, behind the scale option is the scale list, you can choose the scale needed, meanwhile,
the scale list can remind user the bar code generating is relate to the printing scale. Finally, barcode will generate as a block,
the scale you set can be the block scale to ensure barcode can be printed correctly in different printing scales.

Display Data: ~ Control whether display the data under the bar code.

Size: If “Display data” option is checked means option is activated, you can set the data height.

Code: Bar code system. Currently we support Code93.

Preview: Displays the bar code image and the data input.

Data input box: You can directly input bar code data, also can click seed to generate barcode.

Seed:  Generate barcode data by random algorithm. Click the "seed" button, the barcode data will generate randomly and
display directly to the data input box above.

Length:  Set the length of the bar code data. There are two ways: one is control the data length which manually input and
random generated. The other is control the data length that random generated, check the "seed" before activate this setting.
Pick:  Pick up text or bar code. If you pick the data, it will only obtain the data displayed, but if you pick the barcode, you will
get the information of barcode width, height and proportion and data

Save Image:  Save the barcode to BMP format picture, you can either use the picture to print or insert to other document or to
CAD drawing.

Insert:  Define the barcode generated as a block and take left bottom of the barcode as base point. You can insert the barcode
to the drawing file through the insertion point with the scale set before.

Cancel: Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved
last time will display.
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16.9.  Symmetric Draw

No matter it is AEC or MFG industry, there are many symmetric drawing shapes. The usual way to make a symmetric shape is to

draw the first half of the shape and then get another symmetric half by copy or mirror.

1

It is possible to directly draw symmetrical shapes with Symmetric Draw tool. When drawing the first half you get another half

:ﬂfﬁ] )
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automatically. The default symmetry axis is X-axis, but user can specify Y-axis or any line in the drawing as symmetry axis

reference.

Users can easily switch on/off this tool by clicking the Symmetric Draw button on the status bar. By the way, Symmetric Draw

tool supports all the drawing commands of GstarCAD.

Exploring Symmetric Draw Properties

Right-Click the Symmetric Draw button at status bar and select Settings option. The Drafting Settings dialog box will pop up. Now

let’s explore the properties under Symmetric Drawing tab.

Enable Symmetric Draw: Enables the symmetric draw tool if is checked.
Pick Symmetric Axis: You can pick X, Y, or a custom axis to start working
with.

Supported Objects: Symmetric draw tool supports line, circle, rectangle,

polygon, ray, polyline, ellipse, arc, xline and spline objects to be drawn
as symmetrical shape.

Select All/ Erase All: You can select or unselect all supported objects at
once.
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Symmetric Axis Effect
X Axis option: The objects drawn will take the X , o
coordinate system as invisible axis line. The effect of | \ H
X Axis is mirroring the drawn objects up or down

according to X coordinate system origin location. ‘ ‘ < ol .

“ < ot e =]
Y Axis option: The objects drawn will take the Y coordinate system as L T T
invisible axis line. The effect of Y Axis is mirroring the drawn objects M N B o R

right or left side according to Y coordinate system origin location.

Custom/Pick Axis option: The objects drawn will take the vector
orientation of a selected object as visible axis line. The effect of
Custom/Pick Axis is mirroring the drawn objects according to a
selected object vector orientation whether inclined, vertical or
horizontal.

Pick Symmetric Axis: At status bar, besides | T

Symmetric Draw button is located another button el -— — —- —\ -—{—
called Pick Symmetric Axis. The functionality of this — — o g

button is as same as Custom and Pick Axis options. . e

.\ Model {Layoutl [ Layout2 v'[}' P}ckSymmetric Ais ||
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16.10.  Outline Objects

Hatch

OUTLINE command is another
innovative tool of GstarCAD. This tool
allows extract the outline shape of
selected closed objects in a window
selection method. This outlined
shape is in fact a polyline object

created on the current layer that you W > _[_
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are working with.

For example, use this tool extract the outling shape of a floor plant house to later calculate its total area or to reference draw the
roof of it.

Remark: Other innovative features, such as Break Object, Block Break, Graphic Compare, Pline Boolean, Align tool, Arrange Tool,
AutoXLSTable, CAD Table to Excel, Text Incremental Copy, Statistics Summation, Text on line, GstarCAD Tools, Drawing
Compare, Drawing Lock, Batch Purge, etc. Please refer to the express tool guide.

16.11.  Area Table

4.5832 m2

Arcas

The enclosed area and object can be marked number or area,
and the area table can be generated at the same time. The — - e
area data can be exported to a text or table file. The values in ‘{N e hi,— :
the table can be changed automatically when the number or : |

area size is changed.

Steps to use Area Table:

1. Click Express Tools > Dimension > Area Table.

2. Popup "Area Table" dialog box.

3. Click “Pick Point” or “Select Obj” to mark area.

4

5

If the you checked "Generate Table", you need to determine the table location or the table to be added.
Click the available point coordinate to go directly to the next process. Or select the available existing area table to enter
the next process.

6.  After the table is created or selected, the area can be updated automatically by “Pick Point” or “Select Obj”.

16.12.  Automatically Layer

Predefines the association between object type and
the layer that should be drawn in a drawing. System U

-
(| 4
4]
g
[ =] |
it
E
Il
RER

automatically switches the current layer while

drawing the graph, and draws the graphic to the set |
layer. If the specified layer does not exist, the system will automatically create this layer based on the settings.
About Automatically layer dialog box:

Autolayer list:

Display the command name and the corresponding automatic layer settings.

Create a layer setting:

Create a new layer settings including the command name and the corresponding layer settings.

Delete layer setting:

Delete one or more selected automatic layer settings.

Enable Autolayer:
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After checking this check box, the software can automatically assign the layer based on the settings when drawing, if not
checked, it doesn’t work.

Save Settings:

Save your current settings to a text file.

Load Settings:

Read the settings file saved by the user and read the settings into the dialog box.

Clear Settings:

Clear all current auto layer settings.

Remark: the current settings only work for the currently edited drawing.

16.13.  Attribute Increment

Attribute Increment can sort and increment the
attribute value of the attribute block of the same yy S | Abas
name according to the way you set. The property

value of the attribute block is modified based on N 3 o
the sort value. For example, the attribute value of " . 4
the axis number is incremented by the way it is A : - 7
set. A %_l_ ES
About Attribute Increment dialog box

Auto Increa

All referenced properties of the selected block are automatically incremented, which is copied, inserted, deleted in the graph,
and the attribute number is automatically updated. When "ATTINC" is on, as long as the drawing is not closed, when copying,
inserting and deleting the block in the drawing, the property number can be updated automatically.

Increase the select:

Only the selected block is processed, and the selected block property is incremented by the order of creation.

Select a block:

Click “Select the block” button, and you can pick up a block from the graphics and acquire the name of the block. If there is no
attribute in the block you picked up, then prompt: The selected block has no attributes. And you need to pick up again.

Block:

Select a block in block list. If there is no attribute in the block you picked up, then prompt: The selected block has no attributes.
And you need to select again.

Select the attribute to increase:

Select the tags to increase. If the block only has one attribute, then the only attribute will be selected automatically. But if the
block has more than one attribute, then all the attributes will be displayed and you can select one or more attributes to increase.
Parameter:

Increment:

The attribute value of the selected block is increased by the increment value.

Add ration:

Add the same increment value to the increment number or letter of the attribute value in attribute block.

Increment Mode:

Here are 3 increment modes: Increase every number, Increase the last number and Increase the first number.
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Default option is Increase the last number. If there are numbers in the end, these numbers increase as a whole. If you select
Increase the first number, and here are numbers in the first, they also increase as a whole. If you select Increase every number,
gach number in the attribute value is incremented.

Increment Number;

The default number is “1”, and you can modify it if needed.

Sort:

Set the sort of increment as the followings: Draw Order, Select Order, Left to Right, Up to Down and The Path of Curve. The
default sort is Draw Order, you can select other sorts.

If you select The Path of Curve, system will prompt you to select a curve. the curve can be a curve or a polyline which intersects
with the selected block, and sort according to the order of the point which is closest to the insertion point of each attribute
block on the curve. If all the points are as the same point, then according to the distance between each insertion point of
attribute block and the curve to sort.

Negative Sequence:

Reverse the order above.

16.14.  Free Scale

FREESCALE command allows you to scales an object or a group of
objects without restrictions under three methods; Non-Uniform,
Rectangle and Free.

Non-uniform scale: The scale of X and Y axis can be input
separately.

Rect Scale: You can scale a graphic to match a rectangle frame. The rectangle does not need to be drawn, just specify two
diagonal points.

Free Scale: You can move or copy and scale the graphics in a closed quadrilateral frame to another closed quadrilateral frame,
which can be used to generate the pattern of tilting or perspective distortion graphics.
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