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1. Installation and Start-Up 

1.1 Computer Requirement 

To improve the design efficiency, standard display with resolution of 1024× 768 or higher is recommended.  

For ease of reference, multi display mode is recommended so that the operation guide and GstarCAD Architecture 

(here after can be called "GCA") could be opened and displayed on the screen at the same time.  

 

Please use the mouse with a scroll wheel which would be used for zooming. The scroll wheel would also be used 

for panning as a middle mouse button. 

 

An enormous number of 2D drawing operations under GstarCAD Architecture do not have many requirements on the 

graphics card. Most of the graphics card with the VRAM greater than 256 MB or even the CPU core graphics card 

would be worked. 

 

1.2 System Requirement 

The system requirements for GstarCAD Architecture works is as follows: 

Operating System: Windows7, Windows8, Window 10 

CPU Type: 32-bit (x86) or 64-bit (x64) processor 

 

1.3 GstarCAD Architecture Installation 

Please follow the steps below to install GstarCAD Architecture 2021: 

 

1. Double-click the executable file downloaded. 

 

 

 

2. Then the Gstarsoft Software License Agreement will pop up, you need to select I accept the terms of the license 

agreement to continue after reading User License Agreement, then click Next button. 
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3.  In “Select Features” dialog box, you can keep the checked features by default to get a successful installation. 

Click Browse and choose the destination folder where setup will install the files. Then click "Next" button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. In “Select Program Folder” dialog box, click the "Next" button to continue.  
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5. Then you just need to wait for a few minutes for the Overall Progress. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Then "GstarCAD Architecture Installation Wizard Complete" dialog box will pop up. Click "Finish" button to finish 

GstarCAD Architecture 2021 installation. 
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1.4 GstarCAD Architecture Object Introduction 

The graphics output primitive type of early DWG is fixed, which cannot be extended by the developers and users, the 

metafile is completely composed by the basic drawing object of various types like line, arc, text and dimension etc. 

These basic drawing object forms the complex construction drawings. 

 

1.5 Units 

GstarCAD Architecture supports various architectural drawing units including mm, cm, dm, m. Unit in this 

documentation is "mm" by default except for special statement. 

 

 

 

 

 

Example of "Unit" 

By default, when Drawing Unit = mm, it means 1uint=1mm in the model space of the DWG file. For example, the 

following distance 6000 represents the distance 6000mm and 6m. Dim Unit controls the Expression style of the 

Size Dimension. If Dim Unit=mm it means according to the present Drawing Unit, the following expression of the 

dimension should follow mm style. That is 6000 (mm), as shown. 

 

For example, if current Dim Unit = m, according to the present Drawing Unit, the following expression of the 

dimension should follow m style. That’s 6(m), as shown. 
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2. Function of Architectural Design 

This chapter of GstartCAD Architecture (here after can be called "GCA"), mainly introduces the drawing function. 

 

2.1 Axis 

2.1.1 Draw Axis 

The command which is called "Orthogonal Grid" in "Draw Grid" is used to generate orthogonal grid. Skew grid and 

unidirectional grid. 

 

Building Design→Grid→Draw Grid   

 

Click Building Design→Grid→Draw Grid, then Axis Grid dialog box pops up, choose the "Orthogonal Grid", enter 

the bay size value as follows:  

 

 

The method of the axis grid data entering: 

 

Click one of the radio buttons (Top, Bottom, Left and right). 

 

Type the axis grid data directly in the "Enter" bar, with each data separated by a blank space or a comma in English. 

Then click the "Enter", and the data will become valid. 

 

Enter the Bay size and Number in excel in the dialog box. Frequently used value can also be entered by clicking the 

corresponding value in the value list on the right. 

 

Return to step 1 and choose one of other radio buttons. Then follow the same steps to enter the axis grid data. 
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Explanation of Controls in dialog box: 

[Top] means the dimension of the bay on the top of grid. 

[Bottom] means the dimension of the bay at the bottom of grid. 

[Left] means the dimension of the depth size on the left of grid. 

[Right] means the dimension of the depth size on the right of grid. 

[Number] means the repetition times of data in "Bay Size" bar, which can be selected from drop-down list or 

directly typed in. 

[Bay Size] means the size data of the bay or depth, which can be entered by clicking the corresponding value in the 

value list on the right or selected from drop-down list, or directly typed in. 

[Enter] is used to type in a group of size data, with each data separated by a blank space or a comma in English. 

Then press "Enter", and the data will be typed into the Bay size column.  

[Angle] means the angle between bay and depth. The axis grid is Orthogonal Grid with the angle of 90 degrees by 

default. 

[Empty] is used to empty the axis grid data of one of the items (top, bottom, left, right). Other data remain 

unchanged. 

[Last Data] recover and display the data used for drawing the axis grid the last time. 

[OK] after clicking it, the user can draw Orthogonal Grid and save the related data.  

[Cancel] is to give up the axis grid drawing and data entering. 

 

User can execute the operation of data inserting, deleting, copying and cutting by right clicking the first button of 

each row. 

 

After typing in all the necessary size data in the dialog box, click the [OK] button, and the command line will show: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D- flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Move the axis grid by dragging its base point, and click to obtain the position where axis grid is to be placed, or 

make response to other options according to the prompts. 

 

If only the bay or depth one-way axis data is input, after click the [OK] button, the command line will give you a 

prompt of length of one-way axis<16200>. Please measure with mouse or type in the figure, after which the 

command line will show: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D- flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Move the axis grid by dragging its base point, and click to obtain the position where axis grid is to be placed, or 

make response to other options according to the prompts.   



Chapter 2 Function of Architectural Design 

20 

 

 

 

If the lower bay has the same data with the upper bay, it is unnecessary to click the button for lower bay. This also 

applies for depth. 

 

The input size shall be located based on the axis intersection at the bottom left corner of grid. 

 

Example of "Orthogonal Grid": 

Data typed for upper bay: 4*6000, 7500, 4500 

Data typed for lower bay: 2400, 3600, 4*6000, 3600, 2400 

 

Data typed for left depth: 4200, 3300, 4200 

Data of Right depth which are the same as those of left depth do not need to be entered. 

 

The angle of Orthogonal Grid is 90 degrees, between the bay and depth. 
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2.1.2 Wall to Grid 

Building Design→Grid→Wall to Grid 

 

After user selects Building Design→Grid→Wall to Grid, command line prompt:  

Please select wall<Exit>.  

User can either select the wall which is going to be used to generate the wall or press enter to exit.  

 

Wall to Grid is to generate the axis grid without axis number and dimension along the wall baseline. 

 

Example of "Wall to Grid": 

First, Draw wall by the "Draw Wall" command, and then execute the "Wall to Grid" command to generate the axis 

grid. 

 

In the example, the wall axis is generated according to the baseline of the wall drawing. 

 

2.1.3 Optimize Grid 

The command is mainly used to solve the problem that axis grid is too intensive after being generated by "Wall to 

Grid". 

 

Building Design→Grid→Optimize Grid 

 

After select Building Design→Grid→Optimize Grid, the command line prompts: 

 

Please select wall and axis line <Exit>: 

Select the area including all the axis line and the wall which need to be optimized and then press enter to complete 

the selection. 

 

After which, the extra axis line would be cut automatically and the optimization would be completed. 
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Example of "Optimize Grid": 

The drawing before axis optimization as follows, exterior wall has been identified and highlighted by blue bold line. 

The area is selected including all the axis grid and wall. 

 

The drawing after axis optimization is as follows. 

The function reduces extra axis in the drawing, and make it clean and beautiful. 
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2.1.4 Merge Grid 

The command is used to make the axis lines of different axis grid extending to the specified one to four boundary 

and being merged into one axis grid, meanwhile, the extra axis line would be cleared. Currently the command is not 

applied for non-orthogonal axis grid or multiple non-orthogonal arrayed axis grids. 

 

 

Building Design→Grid→Merge Grid 

 

After select and click Building Design→Grid→Merge Grid, the command line prompt: 

 

Please select axis needed to be merged and aligned<exit>:  

Here please select axis lines from multiple axis grids. It is not necessary to merge the axis lines from the same axis 

grid. 

 

Please select axis needed to be merged and aligned<exit>: 

Please go on selecting the axis lines or press enter to finish the selection. 

 

Please select aligning border<exit>:  

Four aligning borders would appear on the drawing, select the border with which the axis lines are to be aligned. 

After that, the command begins to merge the axis lines. 

 

Please select aligning border<exit>:  

Go on selecting other aligning borders; 

 

Please select aligning border<exit>:  

Press enter to finish the grid merging. 

 

Example of "Merge Grid": 

In the left picture, user selects the right and button border from the four available aligning borders after selecting the 

two axis grid. And the right picture shows the result after the command execution. 

 

In the left picture, user selects the left and top border from the four available aligning borders after selecting the two 

axis grid. And the right picture shows the result after the command execution. 
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2.1.5 Arc Axis 

The arc grid is composed of a group of concentric arcs and radial lines which do not pass the center of the circle. It 

is usually combined with other axis grid. The radial axis line on one end is always shared by two axis grid. 

 

Building Design→Grid→Draw Grid 

 

After selecting and clicking "Draw Grid", the "Axis Grid" dialog box would pop up, select the label "Radial Grid", click 

the radio button "Depth" and enter the data related to depth as follows: 

 

Enter the data related to central angle as follows: 
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The method of axis grid data entering: 

 

Type the axis grid data directly in the [Enter] bar, with each data separated by a blank space or a comma in English. 

Then click the "Enter", and the data will become valid. 

 

Enter the Bay size / angle and Number in the table of dialog box. Frequently used value can also be entered directly 

by clicking the corresponding value in the value list on the right, or in the data in the pull-down list. 

 

Explanation of Controls in Dialog Box: 

 

[Depth] means a series of room depth arrayed in the radial direction from inward to outward. The unit of them is 

millimeter. 

[Central Angle] means a series of room bays starting from the start angle and arrayed according to the rotation 

direction. The unit of them is degree. 

[Bay Size] means the size data of the depth, which can be entered by clicking the corresponding value in the value 

list on the right or selected from drop-down list, or directly typed in. 

[Angle] means the angle between the axis that compose the room bay which can be selected from drop-down list, 

or directly typed in. 

[number] means the repetition times of data in the [Angle]or[Bay size] bar which can be entered by clicking the 

corresponding value in the value list on the right or selected from drop-down list, or directly typed in. 

[Inner Radius] means the arc radius of the innermost circumferential axes starting from the center of the circle. The 

radius length can be obtained by picking two points in the figure. Its value can also be zero. 

[Start Angle<] means the angle between starting radial axis line and positive direction of X-axis. (Confirmed by the 

rotation direction) 

[Clockwise][Counter-Clockwise] means the rotation direction of the radial axis line. 
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[Axis Shared<] if user want an axis grips shares a radial axis line with the other axis grid, please specify the radial 

axis line in the drawing. The shared axis would not be drawn again. Meanwhile drag the radial grid to determine the 

direction when connecting with the other axis grid.  

[Enter] is used to type in a group of size data, with each data separated by a blank space or a comma in English. 

Then press "Enter", and the data will be typed into the Bay size column of the table.  

[Insert point] when clicking it, user can change the default base point position of the axis grid inserting.  

[Empty] is used to empty the data of the central angle or depth, and other data remain unchanged. 

[Last Data] recover and display the data used for drawing the radial grid the last time 

[OK] after clicking it, the user can draw radial grid and save the related data.  

[Cancel] is to give up the axis grid drawing and data entering. 

User can execute the operation of data inserting, deleting, copying and cutting by right clicking the first button of 

each row. 

 

After typing in all the necessary size data in the dialog box, click the [OK] button, and the command line will show: 

Insert point or [A-rotate 90 degree/S-flip vertical/D- flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>:  

Move the axis grid by dragging its base point, and click to obtain the position where axis grid is to be placed, or 

make response to other options according to the prompts. 

 

Example of "Radial Grid": 

Depth: 1500, 3000   Central Angle: 20, 3*30   Inner Radius: 

After all the necessary data being entered, press "Axis Shared" button, and then pick axis line with the axis label 2, 

then drag counter clockwise to complete the radial Grid drawing. 
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2.1.6 Grid Dimension 

Building Design→Grid→Grid Dimension 

 

Click the Building Design→Grid→Grid Dimension. 

 

 

The explanation of the controls in the dialog box: 

 

[Start Axis Label] when user do not want the start axis label to be the default value: 1(x direction) or A(y direction). 

Enter the customized start axis label which can be the combination of the number and letter. 

 

[Axis Tag Ruler] the axis tag can be the combination of letter, number and the hyphen between them, which is used 

to indicate the axis label of different area. The mentioned axis label could be set as "Change Consequent" or 

"Change Antecedent".  Default is "Change Consequent". 

 

[Dimension Size] the checkbox is default checked, in this case, the axis label and the dimension are marked at the 

same time. When the axis label is marked again, user can uncheck the checked box to avoid the dimension being 

marked again. 

 

[Dimension on other Side] axis label is applied for "One Side". When the checkbox is checked, the axis label is 

marked on the side where the axis line is selected, and the dimension is marked on another side. 

 

[Axis Label Shared] after it is checked, the number or letter of "Start Axis Label" will follow that of the existed axis 

label selected. 

 

[One Side] is used to mark the axis label and dimension only on the side where the axis bay or depth is selected. 

 

[Ignore partial axis] if some of the axis lines in the axis grid do not need dimension, please check this checkbox, 

and then the command line would prompt "Select The Axis Lines that Needn’t Dimension", please be noted that the 

first axis line can not be selected here. 

 

[Both Sides] is used to mark the axis label and dimension on the axis bay or depth of both sides 

The command firstly prompt user to select start and end axis between which the axis grid is to be dimensioned, 

interaction through commands is as follows: 

 

Select start axis line or intersected axis line to dimension. 

Please select end axis<Exit>: 
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There’s a tip here: After selecting the start axis line, press enter, then all the axis lines intersected with the start axis 

line are dimensioned, meanwhile the command line prompt "Select Start Axis Line or Intersected Axis Line to 

Dimension. 

 

After the "Ignore Partial Axis" checkbox is checked, the start axis line, the end axis line and all the parallel axis lines 

between them become highlighted, the command line then prompts: 

 

Select the axis lines that needn’t dimension: please select the auxiliary axis line which is not need to be 

dimensioned. Both of selection one by one and box selection are OK. The axis line selected would not be 

highlighted any more. Then press enter to complete the dimension. 

 

Select start axis line or intersected axis line to dimension: go on selecting other axis lines that need to be 

dimensioned or press enter to exit. 

 

Example 1 of "Grid Dimension": 

Now we will introduce the dimension shared by two types of axis grid by dimensioning the axis grid which is 

combined by Orthogonal Grid (grid 1) and Radial Grid (grid 2) as follows: 

 

Select start axis line or intersected axis line to dimension: select the axis line which is shared with the former axis 

grid to regard it as the start axis line. Pick P3 near the side where the dimension is to be marked. 

 

Please select end axis<Exit>: 

Select the end axis line. Pick P4 near the side where the dimension is to be marked. 

 

Label in Counter-Clockwise? [Yes/No]<Y>: N   

Enter n to change the default rotation direction into clockwise and complete the dimension of axis label 4-6. 
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Example 2 of "Grid Dimension": 

Enter the bay size: 2*6000    enter the angle: 6*60 

Requirement:  mark radial axis label in the counter clockwise direction and the hoop depth axis label 
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Click the Building Design→Grid→Grid Dimension, and check the "Dimension Size "checkbox in the dialog box, 

then the command line prompt: 

 

Select start axis line or intersected axis line to dimension: pick a point (P1) of the start radial axis line. 

 

Please select end axis<Exit>: 

Pick any point (P1) of the end radial axis line.  

 

Label in Counter-Clockwise? [Yes/No]<Y>: Y 

Select the axis line that needn’t dimension: 

 

At this time, in the circle axis grid, the dimension of the angle and the axis number of radial axis line has already 

been marked. The dimension would be default marked on outside, it is dragged into the internal side as shown in 

the picture. 

 

Execute the command again, the command line prompt: 

 

Select start axis line or intersected axis line to dimension: pick any point (P3) of the hoop axis line furthest from the 

circle point of the arc. 

 

Please select end axis<Exit>: 

Pick any point (P4) of the hoop axis line nearest to the circle point of the arc. Please be noted that the following 

command prompt are displayed especially for the circle axis grid. 

 

Select the axis line that needn’t dimension: select the axis line that needn’t dimension. 

 

Please select the horizontal line of round axis grid: pick point P5 on the radial axis line1. 

 

Please enter the starting axis number (.Empty Number) <A>: A 

Press enter to regard the default letter A as the starting axis number. 

 

Please pick mark position<Exit>: 

Drag the axis number and leader to point P6 and click to determine the mark position. 

 

2.1.7 Single Axis Dimension 

Building Design→Grid→Single Axis Dimension 

 

Single Axis Dimension applies to dimension isolated axes of elevation, section and detail drawing. If user does not 

enter axis number in the axis tag editing box, the null axis number would be created. The number of object created 

by this independent command, and has no relation with the existing grid number system. If user wants to establish 

relationship between single axis dimension and existing grid number system, the command "Connect Axis Number" 

should be used. 
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Click Building Design→Grid→Single Axis Dimension, then a dialog box pops up. Click the "Single Axis Serial 

Number" or "Multiple Axis Serial Number" radio button in it. In the case of "Single Axis Serial Number", enter the 

axis serial number in the "Axis Tag" text box as follows: 

 

In the case of "Multiple Axis Serial Number", if the "Continuous" checkbox is unchecked, multiple axis serial 

numbers with each data separated by a comma in English should be entered in the "Axis Tag" text box. Click "Text " 

radio box, then the second axis serial number entered and the axis serial numbers following are all displayed as text 

next to the axis number(the first axis serial number entered ) as follows; if the ellipsis checkbox is checked, the 

ellipsis would be displayed after the last axis serial number automatically as follows: 

 

 

Check the "Drawing" checkbox, then the second axis serial number entered and the axis serial numbers following are 

all displayed below the axis number (the first axis serial number be entered) in respective circles as follows. If user 
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wants the axis number to be null, please enter 1 or more commas in the "Axis Tag" text box. For example as follows, 

if two commas are entered in the "Axis Tag" text box, three null axis numbers would be displayed. 

 

 

If user wants the axis number to be continuous, please check the "Continuous" checkbox as follows. And then enter 

"Start Axis Number" and "End Axis Number". 

 

After all the necessary data are entered in the dialog box, please operate according to the command line prompt: 

 

Pick axis to be labeled<Exit>:  

Pick the axis line which is to be dimensioned. 

 

Pick axis to be labeled<Exit>:  
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Pick other axis line which is also to be dimensioned or press enter to exit. The results of the above different cases 

are as follows:  

 

 

2.1.8 Add Grid 

Building Design→Grid→Add Grid 

 

Click Building Design→Grid→Add Grid, in the case of orthogonal grid, the command interaction is as following: 

 

Select reference axis<Exit>: 

Pick the neighboring axis line to which the distance from the axis that is to be added is already known. 

 

Newly added label is secondary label, Yes or No? [Yes/No]<N>: 

 

Enter Y. Then the added axis line would be regarded as the Additional axis line of the reference axis line and the 

secondary label would be marked on it according to the related standard, e.g. 1/1, 2/1 etc. 

 

Enter N. Then the added axis line inserted at the specified position would be regarded as a main axis line and the 

main axis label would be marked on it. 

 

Distance away from the reference axis<Exit>: 

Enter 2400 for example .Move the cursor to the side of the reference axis line where the new axis line is to be added 

and enter the distance between the new added axis line and the reference axis line. 

 

Click Building Design→Grid→Add Axis Dimension, in the case of radial grid, the command interaction is as 

following: 

 

Select reference axis<Exit>: 

Select a radial axis line on the radial grid. 

 

Newly added label is secondary label, Yes or No? [Yes/No]<N>: 

 

Enter Y. Then the added axis line would be regarded as the Additional axis line of the reference axis line and the 

secondary label would be marked on it according to the related standard, e.g. 1/1, 2/1 etc. 

 

Enter N. Then the added axis line inserted at the specified position would be regarded as a main axis line and the 

main axis label would be marked on it. 
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Enter angle<Exit>:15    

Enter the rotation degree or pick in the drawing. 

 

While the user drag the cursor to pick the point which determines the rotation degree, the program would real-time 

display the position of the axis line that is to be added. After picking the point, a new axis line would be added at the 

specified position. 

 

2.1.9 Trim Grid 

Building Design→Grid→Trim Grid 

 

Users can use the command to trim the axis lines in the polygon they set or on one side of a line they set. 

 

Click Building Design→Grid→Trim Grid, and the command prompt is as follows: 

 

First corner point of the rectangle [P-polygon trim/F-axis aligns] <Exit>: F 

Then the "Axis Align" command interaction of displays in the command line as following: 

 

Please pick the start point of the trimming line or select a trimming. 

Line: pick the start point of the trimming line. 

 

Please pick a point to make sure which side is to be trimmed<Exit>: 

Click the side on which the axis line is to be trimmed. 

 

First corner point of the rectangle [P-polygon trim/F-axis aligns] <Exit>: P 

Then the "Polygon Trim" command interaction of displays in the command line as following: 

 

First corner point of the rectangle [P-polygon trim/F-axis aligns] <Exit>: 

 

If the first corner point is given, system regards it as "Rectangle Trim", and goes on displaying related prompt:  

Another corner point<Exit>: 

 

User picks another corner point of the rectangle. Then axis in the polygon they set would be trimmed. 

 

If "P" is entered, the program would begin execute polygon trim. The command line prompt: 

 

First point of the polygon<Exit>: 

Pick the First point of the polygon. 

 

Next point of polygon or [Back (U)] <Exit>: 

Pick the next point of polygon. 
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2.1.10 Switch Axis Line Type 

Building Design→Grid→Switch Axis Line type 

 

The command applies to switching the axis line type between dot dash line and Continuous line. 

 

 

2.1.11 Add Axis Number 

Building Design→Grid→Add Axis Number 

 

 

Click Building Design→Grid→Add Axis Number, then the command interaction is as follows: 

 

Please select axis label object<Exit>: 

 

Select the existing axis label object next to the new axis label that is to be added.  Please do not pick the existing 

axis line. 

 

Select position of new axis or [Reference point] <Exit>: 

 

Move the cursor to the side of the reference axis line where the new axis label is to be added and enter the distance 

between the new added axis line and the reference axis line. 
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2.1.12 Delete Grid Number 

Building Design→Grid→Delete Grid Number 

 

Click Building Design→Grid→Delete Grid Number, then the command interaction is as follows: 

 

Please select the Axis No. or [Set to not rearrange (Q), Current: Rearrange] to Delete<Exit>: 

User can select multiple axis No. that need to be deleted by window selection method. 

 

Please select the Axis No. or [Set to not rearrange (Q), Current: Rearrange] to Delete<Exit>: 

Press enter to exit the selection status, and the grid number would be rearranged automatically. 

 

2.1.13 One Axis Attached Multi Number 

Building Design→Grid→One Axis Attached Multi Number 

 

Click Building Design→Grid→One Axis Attached Multi Number, then the dialog box pops up as follows: 

 

Example 1 is to create the multi serial number with additional axis number excluded over the whole scope. 

 

First click the "Global" radio button and leave the "Including Additional Axis Number" checkbox unchecked, then 

select any of axis numbers which need to be copied according to the command prompt. 

 

Please select the Axis Number to copy<Exit>: 

 

When the "Global" radio button is clicked, By picking any of axis numbers which need to be copied, user can select 

all the axis numbers of the same axis number object, then the specified axis number would be copied on one side 

or both sides. 

 

Please select the Axis Number to copy<Exit>: 

Go on selecting the axis number of other region or in the other direction, or right click to exit the command. 
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Example 2 is to create the multi serial number with additional axis number included over the partial range. 

 

First click the "Part" radio button and check the "Including Additional Axis Number" checkbox, then select axis 

numbers which need to be copied according to the command prompt. 

 

Please select the Axis Number to copy<Exit>: 

Box select or select one by one the axis number objects which need to be copied. 

 

Please select the Axis Number to copy<Exit>: 

Right click to exit the command as follows: 

 

 

2.1.14 Axis Number Show and Hide 

Building Design→Grid→Axis Number show and hide 
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[Auto Hide/Display] hide the axis tags which are currently displayed, and display the axis tags which were hidden. 

 

[Hide Axis Tag] hide the selected axis tags which are displayed, and the axis tags which are currently hidden remain 

unchanged. 

 

[Display Axis Tag] display the selected axis tags which are currently hidden, and the axis tags which are currently 

displayed remain unchanged. 

 

[Process in Both Sides] when the checkbox is unchecked by default, the hiding or displaying of the axis tag would 

be processed in single side, when the checkbox is checked, the hiding or displaying of the axis tag would be 

processed in both sides. 

 

Example of "One Side Demonstration (Shown/Hide)": 

The operation example of the command interaction is as follows: 

 

 

2.1.15 Switch Between Main and Additional 

Building Design→Grid→Switch Between Main and Additional 

 

Click Building Design→Grid→Switch Between Main and Additional, the command interaction is as follows: 

 

Example of "Change Main Axis Label into Additional Axis Label": 

Please select the axis label or [Set to not rearrange (Q), Current: Rearrange] to convert between main axis number 

and additional axis number<Exit>: 

 

Select the main axis number "3" which need to be changed into additional axis number. 

 

Please select the axis No. or [Set to not rearrange (Q), Current: Rearrange] to convert between main axis number 

and additional axis number<Exit>: 

Press enter to exit the command, then the main axis number is changed into additional axis number 2/2, and the 

following axis number-1, as follows: 
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Example of "Change Additional Axis Label into Main Axis Label": 

Please select the axis label or [Set to not rearrange (Q), Current: Rearrange] to convert between main axis number 

and additional axis number<Exit>: 

 

Select the additional axis number "1/2" which is needed to be changed into main axis number. 

 

Please select the axis label or [Set to not rearrange (Q), Current: Rearrange] to convert between main axis number 

and additional axis number<Exit>: 

 

Press enter to exit the command, then the axis number 1/2 is changed into main axis number 3, and the following 

axes are rearranged as follows: 

 

 

 

2.1.16 Re-Sort Axis Number 

Building Design→Grid→Re-sort Axis Number 

 

Example of "Re-Sort Axis Number": 

Please select the reference Axis No. that need to rearrange: Pick the axis No. "1", that needed to be rearranged. The 

axis No. picked can be main axis No. or additional axis No. 

 

Please enter new label number (.null) <2>: A1 

Enter new label number that can be common axis No. or partition Axis No, but must be main axis No., when the 

partition Axis No. is entered, the command line would display further prompt: 
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Please enter axis number rule [change antecedent (B); change consequent (F)] <F>: F  

(Change consequently) as the axis number changing rule. 

 

Example of "Re-Sort Partition Axis Number": 

Please select the reference Axis No. that need to rearrange: Pick the axis No. "A-4" that is needed to rearranged. The 

axis No. picked can be main axis No. or additional axis No. 

 

Please enter new label number(.null)<2>: 

Enter new label. Number can be a common axis number, or partition Axis number, but must be main axis number. 

 

Please enter axis number rule[change antecedent(B); change consequent(F)]<F>: 

Use the default axis changing rule: change consequent. 

 

 

2.1.17 Reverse Axis Number 

Building Design→Grid→Reverse Axis Number 

 

The command has no interactive operation and would execute immediately on selecting axis label object that need 

to be rearranged reversely.  
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2.1.18 Connect Axis Number 

Building Design→Grid→Connect Axis Number 

 

The command interaction is as follows: 

 

Please select axis label object<Exit>: 

First select an axis No. as the base. 

 

Please pick labels to be connected<Exit>: 

Select the axis line that need to be connected as follows: 

 

Please pick labels to be connected<Exit>: 

Press enter to exit and complete the connection of the axis. After the connection, the related axis No. are all aligned 

with the first axis No. as follows: 

 

 

 

2.1.19 Grips Function 

The Grips of the axis numbers in the orthogonal grid: 
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The Grips of the axis numbers in the radial grid: 

 

 

Two arrows – shaped grips used to change dimension side are set on the axis number on both side of the grid and 

both of them are displayed by default as follows. User can hide the axis number on one side by Clicking the 

arrow – shaped grip, after the clicking, the arrow – shaped grip would change into a plus sign ( + ), User can 

also display the axis number on one side by Clicking the  plus sign, after the clicking, the  plus sign would 

change into an arrow – shaped grip again. 
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When only the axis number of one side is displayed, click the Arrow – shaped grip used to change dimension side 

on this side, the axis number this side would be hidden and the axis number on the other side would be displayed 

as follows. Program would never hide the axis number on both sides. 

 

 

Grip Used to Reverse Grid Serial Number: 

There are also some arrow – shaped grips in the axis number object of GstarCAD Architecture used to Reverse 

Grid Serial Number. Click the grid on one side, all the axis numbers on the related side would be reversed, after 

which the main axis number would remain main axis, so do the additional axis number. 

 

2.1.20 Axis Number In-Place Edit 

Axis number can be modified conveniently by In-place editing, double click the axis number to switch to in-place 

editing mode, and editing box would appear on the axis number, modify the axis number in it, then click any point 

outside the editing box. The new axis number can be rearranged by Re-sort Axis Number command. 

 

 

2.1.21 Axis Number Object Edit 

The axis number object would be highlighted when the cursor is moved on the axis number. 

Right click the highlighted axis number object and click "Object Edit" on the menu popped up, then the axis number 

objects editing command is invoked as follows: 

 

[M-hide label side/S-hide single-label/Add axis label/Delete axis. 

Label/re-Number axis label)/Re-sort axis number/Z-radius of bubble/Invert axis numbers] <Exit>: 

 

Enter hot key to invoke the functions in it. Here we just introduce several important ones, as the others are the same 

with the command with the same name. 

 

"M-Hide Label Side" is used to control the display status of the axis number. Display status can be switched 

between "Display Axis Number (hide axis number on the other side)", and "Hide Axis Number (display axis number 

on the other side)" and "Display Axis Number on Both Sides".  

 

"S-Hide Single-Label" 
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2.2 Column/Beam/Slab 

2.2.1 Concept of Column Object 

GstarCAD Architecture uses a custom object to represent the column and describes its location and shape with 

bottom elevation, column Height and column section shape parameters. Construction column is used in the design 

of Brick and Concrete Structure. 

 

If the column and wall are of the same material, the wall will be separated by the column when they meet and 

meanwhile they will form a whole. 

 

Generally, the column has sections such as rectangle, circle and polygon etc., column with the section of irregular 

shape can be created by clicking the "Select Pline to Create Irregular Column" icon or selecting "Irregular Column" 

in the "Shape" drop-down list in the dialog box of "Standard Column". 

 

Modification of batch of standard columns can be realized by the method of replace. 
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2.2.2 Standard Column 

Building Design→Column/Beam/Slab→Standard Column 

 

The steps to create a standard column are as below: 

 

Set the parameters of column, including section shape, dimension and material etc. 

 

Select positioning way for the column by clicking different position of column in the box with black background to 

change its alignment point. 

 

Type corresponding command lines for various positioning ways; 

 

Repeat the above 3 steps or press enter to finish the creating of the standard column. 

 

The detailed interaction process in as follows: 

 

Click Building Design→Column/Beam/Slab→Standard Column, then the dialog box would appear. After the 

selection of different shape, different text box group would display accordingly for the user to enter the related 

parameter. 

 

Take the example of the selecting the shape: rectangle, user can select one of nine points as the alignment point by 

clicking the relevant point of the column in the image box as follows: 
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Example of Selecting "Shape" with Circle: 

 

User can select one of five points as the alignment point as follows: 

 

The explanation of the dialog box controls: 

 

[Column Size] there is slight difference in parameter for different columns of different shapes. 

 

[Height] the default height depends on the current floor height. User can also enter height value by selecting 

frequently used value from the pull-down list. 

 

[Eccentric/Angle] 

[Material] it can be selected from the pull-down list. The type of the connection between the column and the wall 

depends on the material of them. The Material of the column currently includes Brick, stone, reinforced concrete 

and steel. 

 

[Shape] is used to set the type of the column section, the column section shape in the pull-down list include 

rectangle, circle, triangle etc.  User can select any of them as the column section shape. 

 

[Insert column] the progress gives the priority to capturing the axis crossing point to insert the column. In case of 

failure to capturing, column would be inserted to the point clicked according to the current UCS’s direction. 

 

[Insert columns along an axis] insert columns to the crossing point between the selected axis and other axis. 

 

[Insert columns at axis intersection] insert columns to all crossing points in the specified rectangular region. 

 

[Replace columns inserted] insert a new column (with new parameter) to the position of selected column and delete 

the original column. User can either do it one by one or do it in batch by window selection. 

 

[Select pline to create irregular column] create irregular column in place by closed pline existing in the drawing. 

 

[Pick parameter from an inserted column] read the parameter form an existing closed pline or column into the 

dialog box and regards it as the parameter of the new column, and then inserts the new column. 
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After all the necessary data are entered in the dialog box, click  [Insert column] button, the command line 

prompts: 

 

Insert or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-rotation/T-reset base point/G-reference point] 

<Exit>: 

 

Enter the hot key of the positioning method when inserting the column, the column being dragged would 

immediately change accordingly.  Insert it into the drawing at the proper time.  

 

After all the necessary data are entered in the dialog box, click  [Insert columns along an axis] button, the 

command line prompts: 

 

Please select an axis<Exit>: 

Select the axis line along which the columns are to be inserted. 

 

After all the necessary data are entered in the dialog box, click  [Insert columns at axis intersection] button, the 

command line prompts: 

 

The First Corner Point<Exit>: 

Pick two points as two end points of a diagonal line to specify a rectangle. 

 

Another corner point<Exit>: 

Pick the second corner point, after which the columns would be inserted in all crossing points in the specified 

rectangular region. 

 

After all the necessary data are entered in the dialog box, click  [Select pline to create irregular column] button, 

the command line prompts: 

 

Please select closed polyline, circle, hatch, bold polyline, T3 column block to convert to column<Exit>: 

Select the pline or hatch that need to be converted into irregular column. 

 

Please select closed polyline, circle, hatch, bold polyline, T3 column block to convert to column<Exit>: 

Press enter to exit. 

 

After all the necessary data are entered in the dialog box, click  [pick parameter from an inserted column] 

button, the command line prompts: 

 

Please select closed polyline or column <Exit>: 

Please select standard column or the pline which is to be converted to column. 
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Insert or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-rotation/T-reset base point/G-reference point] 

<Exit>: 

Enter the hot key of the positioning method when inserting the column, the column being dragged would 

immediately change accordingly. Insert it into the drawing at the proper time.  

 

Insert or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-rotation/T-reset base point/G-reference point] 

<Exit>: 

Press enter to exit. 

 

2.2.3 Corner Column 

Building Design→Column/Beam/Slab→Corner Column 

 

Click Building Design→Column/Beam/Slab→Corner Column, then the command line prompts: 

 

Please select corner of wall<Exit>: 

Select the wall corner where the corner column is to be created. 

 

Enter the proper parameter in the dialog box. 

 

After all the necessary parameters are entered, Press "Enter", then the related corner column would be inserted into 

the drawing. 

 

The explanation of the controls in the dialog box: 

 

[Material] material can be selected from pull-down list. The type of the connection between the column and the wall 

depends on the material of them. The Material of the column currently includes Brick, stone, reinforced concrete 

and steel. The default is reinforced concrete. 

 

[Limb] here the length of each limb is the same by default. The limb length can be adjusted by editing the grips of 

the column.  

 

[Limb Width] when the "Fixed Value" radio button is clicked, users can enter value of limb width according to their 

needs. When the "Auto Match Wall Thickness" radio button is clicked, the program would get the value of the 

thickness of the wall into which the corner column is to be inserted in an automatic way, users do not have to 

consider the width of the wall anymore, and the program would adjust the width of the corner column according to 

the wall thickness it automatically got. 
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2.2.4 Constructional Column 
Building Design→Column/Beam/Slab→Constructional Column 

 

Click Building Design→Column/Beam/Slab→Constructional Column, then the command line prompts: 

 

Please select corner of wall<Exit>: 

The following dialog box would be displayed. User has to enter the parameter in it and then select the corner of the 

wall with which the constructional column is to be aligned. 

 

 

User can adjust the length and width of the constructional column by dragging the grips. 

 

 

 

2.2.5 Create Irregular Column by Boolean 

Select the column→right click it→select Boolean from the menu popping up 

 

The conditions before the execution of the command:  

1. The column that needs editing;  

2. Rectangle or other closed shapes; 

3. The position of them has been arranged according to the needs. 

 



Chapter 2 Function of Architectural Design 

51 

 

Example of Creating Irregular Column by "Boolean": 

 

In this example, first we insert a rectangle column, then select it and right click to show the shortcut menu, and then 

click Boolean command in it to show the related dialog box. Click the "Subtraction" radio button and check the 

"Delete Second Operation Object" checkbox (it is checked by default) then do as per the prompt in the command 

line. 

 

Select second close outline object (Pline, Circle, Plate, Column, Wall Patch, Room, Roof, Apron etc.): select closed 

rectangle 1 

 

Select second close outline object (Pline, Circle, Plate, Column, Wall Patch, Room, Roof, Apron etc.): select closed 

rectangle 2 

 

Select second close outline object (Pline, Circle, Plate, Column, Wall Patch, Room, Roof, Apron etc.): press enter 

to create an I-shaped column 

 

2.2.6 Draw Beam 

The command is an important command used to draw construction beam. User selects beam type according to the 

size, type and material of the beam section offered by the construction engineer. Then place the beams in the plan, 

the top of the beam is aligned with the elevation of the related floor by default. The Method of drawing beam is 

similar to that of drawing wall. However, the inclined beam has to be drawn one by one. According to the different 

end section direction, inclined beam can be divided into "End Perpendicular to The Ground" and "End 

Perpendicular to The Baseline". The section is always calculated according to "Perpendicular to The Baseline". The 

explanation of the parameter is as follows: 



Chapter 2 Function of Architectural Design 

52 

 

 

Building Design→Column/Beam/Slab→Beam 

 

Click Building Design→Column/Beam/Slab→Beam, then the dialog box pops up: 

 

I Beam section and flat beam drawing dialog box: 

 

Rectangle Section, inclined beam drawing dialog box: 

 

The explanation of the controls in dialog box: 

 

[Elevation] it is stipulated that the top of the beam has to be aligned with the elevation position of the floor. The 

Elevation of the beam is equals to that of the related floor by default. When drawing flat beam, user only has to 

define one elevation. 

 

[Endpoint Elevation] when drawing inclined beam, user has to define start point elevation and end point elevation. 

 

[Eccentricity] 

 

[Rotation Angle] 
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[Inclined Beam] inclined beam is the beam with the different elevation of two ends. Check the "Inclined Beam" 

check-box; enter the different elevation of the start and the end point. Select the type of the end.  

 

[End Perpendicular to Ground] is inclined beam of one type, the end of which is perpendicular to the Ground 

(Floor). 

 

[End Perpendicular to Baseline] is inclined beam of the other type, the end of which is perpendicular to it’s owe axis 

line. 

 

 

2.2.7 Wall Line to Beam 

Building Design→Column/Beam/Slab→Wall Line to Beam 

 

Click Building Design→Column/Beam/Slab→Wall Line to Beam, the following dialog box pops up: 

 

Wall to Beam mode: when the "Wall to Line" radio button is clicked, the flat beam will be generated according to the 

section parameter defined in the dialog box, and the beam is drawn along the wall and from the top of the wall 

downward. 

 

Grid to Beam mode: Because of the properties of the inclined beam, user can not automatically create inclined 

beam under the mode of "Grid to Beam". Thus under this mode, the "Inclined Beam" check box cannot be checked. 
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Single Line to Beam mode: Under this mode, user can define inclined beam. Please be noted that, concerning the 

inclined beam, the elevation of the start point and that of the end point is different. 

 

The current default is Grid to Beam mode. Click the Grid to Beam radio button, the program would only select the 

grid layer and objects on it, and the command line prompts: 

 

Please select the grid to generate beam: Specify opposite corner to determine the gird selected. 

 

Please select the grid to generate beam: press enter to complete the selection. Meanwhile, the Beam’s created.  

 

Judge the closing status do the grid according to the grid layer, then delete extended axis line and create beam 

according to the parameter in the dialog box, the frequently used example of grid to beam is as follows: 

 

 

2.2.8 Add Beam Division 

Building Design→Column/Beam/Slab→Add Beam Division 

 

Building Design→Column/Beam/Slab→Add Beam Division, then the dialog box would be displayed as follows: 

 

Enter the parameter related to the beam adding in the dialog box, then the command line prompts: 
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Please select the reference beam segment for equal division<Exit>: 

Select the beam for equal division. 

 

Please the beam to be used as another boundary<Exit>: 

Select another beam opposite the beam selected in the first step. 

 

Please select the reference beam segment for equal division<Exit>: 

 

 

2.2.9 Draw Slab 
The command is an important command used to draw construction floor slab. User can place the slabs in the plan 

according to the slab thickness offered by the construction engineer. The top of the slab is aligned with the 

elevation of the related floor as well as the top of the beam by default. Slab can be classified into two types: flat slab 

and inclined slab. According to the different end section slab, inclined slab can be divided into "End Perpendicular 

to The Ground" and "End Perpendicular to The Baseline".  The explanation of the parameter is as follows: 

 

Building Design→Column/Beam/Slab→Slab 

 

After the user clicks Building Design→Column/Beam/Slab→Slab, the following dialog box would be displayed: 
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The explanation of the controls in the dialog box: 

 

[Slab Thickness] the slab thickness is calculated according to "End Perpendicular to Baseline". 

 

[Slab Location Point<] when the flat slab is to be drawn, press this button to pick the point and define the elevation 

of the top of the slab. When the inclined slab is to be drawn, press the button to pick the first and second points and 

define the rotation axis of the inclined slab, and pick the third point to define the position of the location points. 

 

[Draw Inclined Floor Slab] when this check box is checked, user has to pick three points and define the rotation 

angle of the slab and the position of the relation axis. When this check box is not checked, the second points do not 

need to be defined. 

 

[Elevation of the First and Second Point] when flat slab is to be drawn, user has to define the elevation of the top of 

the slab. When inclined slab is to be drawn, user has to define the elevation of the two points on the location line. 

 

[The Third Point Elevation] when flat slab is to be drawn, user does not need to define "The Third Point Elevation". 

When inclined slab is to be drawn, user has to define it.  

 

[End Perpendicular to Ground] it is the one type of inclined slab, the end of which is perpendicular to the Ground 

(floor). 

 

[End Perpendicular to Baseline] it is the other type of inclined slab, the end of which is perpendicular to its own axis 

line. 
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When the inclined slab is to be drawn, user should immediately click "Slab Location Point". By this way to instead 

of pressing enter after selecting the closed pline.  

 

2.2.10 Add Hole on Floor Slab 

The command is used to regard the closed pline pre-draw as the boundary of the hole and add the hole on floor 

slab.       

 

Building Design→Column/Beam/Slab→Add Hole on Floor Slab 

 

Click Building Design→Column/Beam/Slab→Add Hole on Floor Slab, the command line prompts: 

 

Please select floor slab to open a hole: select the floor slab on which the hole need to be added. Multiple slaps can 

be selected at a time. 

 

Please select floor slab to open a hole: press enter to complete the selection. 

 

Please select a profile of the hole on floor slab (closed polyline or circle): 

Select the closed pline or circle which is to be regarded as the boundary of the hole. Multiple pline or circle can be 

selected at a time. 

 

Please select profile of the hole on floor slab (closed polyline or circle): press enter to complete the selection. 

 

The example of "Add hole on Floor Slab" is as follows. User can change the size of the floor slab as well as the 

position of the hole added by dragging the grips. 
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2.2.11 Beam Slab Show/Hide 

The command is used to switch the show and hide of the beam and slab, as in a finished construction drawing, the 

beam and the slab do not need to be displayed. Generally the beam and the slab in the drawing have to be hidden 

except for the case of collision detection. 

 

Building Design→Column/Beam/Slab→Beam Slab Show/Hide 

 

There is no other command interaction here. 

 

2.2.12 Column Replacing 

Building Design→Column/Beam/Standard Column 

 

Enter new column data, and click the icon in the tool bar at the bottom of the dialog box as follows:  

 

Meanwhile, the command line shows: 

Select Replaced Column: user can either directly select the individual column that needs replacing or window 

select multiple columns which need to be replaced. 

 

2.2.13 Column Object Edit 
Double click the column which needs editing. Then the dialog box for object editing would appear. The dialog box 

is similar to that of standard column as follows:  

 

After the modification of the data in it, click OK to update the column selected. However, Object editing can only 

modify one object at a time. If user wants to do batch modifications, we suggest user use the column properties 

editing function which would be introduced as follows: 

 

2.2.14 Column Properties Editing: 

User can conveniently modify many professional properties of column object via object properties table. In this way, 

user can modify the parameter of column in batch easily. Take the example of converting column into project 

column. 
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Using the method of object selection or others, select multiple column object that need properties modification. 

 

User can modify the column parameters in the properties table, e.g. Change the current usage into project column, 

then the columns would be updated automatically. There are many new parameters in the property table like 

insulating layer and insulating layer thickness etc. 

 

 

2.2.15 Align Column to Wall 

Building Design→Column/Beam/Slab→Align Column to Wall 

 

Click Building Design→Column/Beam/Slab→Align Column to Wall, then the following dialog box would be 

displayed. 

 

First choose one of the three aligning modes by clicking one of the 3 icons, and no matter which is selected, the 

interaction method is the same. 

 

Please select the column to align<Exit>: 

Select multiple columns. 

 

Please select the column to align<Exit>: 

Press enter to complete the selection. 

 

Please select wall side<Exit>: 

Select the wall side to which the column is to be aligned. 

 

The left icon is used to align the nearest side of column with the selected wall side, which is mainly used for 

aligning the wall side with the column side in the civil architecture. 
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The middle icon applies to case of eccentric and used to align the column with wall again. 

 

The right icon is used to align the farthest side of column with the selected wall side, which applies to the factory 

building of which the whole wall is inside or outside the column. 
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2.2.16 Batch Export to Column 
Building Design→Column/Beam/Slab→Batch Export to Column 

 

Click Building Design→Column/Beam/Slab→Batch Export to Column, then the command line prompts: 

 

Please select closed polyline, circle, hatch, bold polyline, column block. 

Convert to column<Exit>: 

Box selected the polyline or hatch etc. which need to be converted into column. 

 

Please select closed polyline, circle, hatch, bold polyline, column block. 

 

Convert to column<Exit>: 

Press enter to exit the command. 

 

Successfully Convert 2 Columns. 

 

 

If user wants to combine multiple partial overlapping columns into one column, please right click the column and 

select "Boolean" from the shortcut menu popping up. 

 

2.2.17 Beam Object Edit 

Double click the Beam of which the parameter is to be modified. Then the Edit Beam dialog box would be displayed 

as followed. It is similar to the Draw Beam dialog box:  

 

After the parameter modification, click OK to update the beam selected. However, user can only use the function of 

object editing to modify one object at a time, if user wants to modify multiple beams at one times, we suggest user 

use the property editing function introduced as follows: 

 

Example of "Beam Properties Edit": 

Using the method of object selection or others, select multiple beam objects that need properties modification. 

 

User can modify the beam parameters in the properties table, e.g. Change the current section size into 200*400, 

then the beam would be updated automatically.  
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Example of "New Function of Beam Grips": 

In GstarCAD Architecture, user can convert straight beam into arc beam by the grip editing function, which can 

greatly improve the efficiency of beam editing. User can freely do it by stretching the middle grip. Another function 

of the middle grip is moving. User can switch the two functions of middle grip by press Ctrl as follows: 
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2.3 Wall 

2.3.1 Change Wall Length Along its Direction 

There are two arrow shape grips on both ends of the wall which can only be stretched along the direction of the wall , 

user can accurately change the length of the wall according to the given length value, during which the direction of 

the wall would remain unchanged, which effectively avoid the miss operation that the direction is changed 

unexpectedly. While the square grip instead of changing both the length and the angle of the wall. 

 

2.3.2 Convert Line Wall to Arc Wall 

In GstarCAD Architecture, the middle grip of the wall has two functions: one default function is to parallel move the 

wall. The other function is to convert the straight wall into arc wall. User can press ctrl to switch these two functions 

of the middle grip. 

 

 

 

2.3.3 Drag Wall with Win-Doors 

In GstarCAD Architecture, Both the straight wall and arc wall can be stretched to various directions along with the 

windows and doors on it, during which, the length and the angle of them can be changed at will. 
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Example of "Related": 

 

User can switch the different linkage status of the wall by clicking "Related On/Off" button in "Building Design→Wall

→Related on/off". 

 

When the button is switched to "Related On", if the middle grip of the wall is stretched, the related walls including 

the collinear walls and the associated wall would all be changed (e.g., extended) accordingly as shown in the 

picture below. The wall linkage function can also make the wall editing easy.  

 

There are two intelligent linkage modes of the wall: "Global Linkage" and "Partial Linkage". User can switch these 

two linkage modes by pressing ctrl before stretching the wall. 

 

Under the "Global Linkage" mode, when user stretches the wall grip, the other collinear walls would be moved along 

with it.  

 

Under the "Partial Linkage" mode, when user stretches the wall grip, only the wall stretched would be moved, while 

the other collinear walls would not be moved along with it.  

 

Under linkage mode (when the button is switched to "Related On"), the connected walls would be changed (e.g., 

extended) along with the wall whose grip is stretched. 

 

Example of "Global Linkage": 
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Example of "Partial Linkage": 

 

User can configure related parameters in "Settings and Help ->Settings->Config->Advance 

Option->System->Entity->Intelligent Linkage Mode".  User can select "Global Linkage" or "Partial Linkage" here 

as the default linkage mode. E.g., as shown in the following picture the Intelligent Linkage Mode is set as "Global 

Linkage". 

 

The wall linkage supports dynamic input. User can directly enter the accurate wall moving distance in the direction 

of stretching in the dynamic input box. As shown in the picture below, while stretching the wall upward, user can 

enter 500 in the dynamic input box and press enter. Then the wall moves upward by 500 under partial linkage 

mode. 

 

Except for common Orthogonal Wall, The wall linkage also supports the linkage of skew wall and the arc wall, during 

which the shape of walls would remain unchanged. 

 

Example of "Styles of Glass Curtain": 

In plane graph, there are two styles of glass curtain: three-line glass curtain and four-line glass curtain. User can 

configure related parameters in "Settings and Help ->Settings->Config->Advance 

Option->Entity->Win-door->Ribbon Win-Door in 2D". The default value for "Ribbon Win-Door in 2D Style" is 

"Change by Scale". The default value for "Display Three Scale for 2D Ribbon Window" is "150". When the print scale 
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of the glass curtain is larger than 1:150 (e.g.1:100), the glass curtain would be of 4-linestyle. When the print scale 

of the glass curtain is less than 1:150 (e.g.1:200), the glass curtain would be of 3-line style. 

 

 

2.3.4 Draw Wall 

Building Design→Wall→Draw Wall 

 

The software provided 2 types of wall drawing. There were ‘Single Wall’ and ‘Composite Wall’. Single Wall 

consisted of only one material. The Composite Wall consisted of many kinds of materials. Besides, by ‘Style 

Manager’ button, the users could jump to the page of material or wall style, in order to set up material or the 

combination of materials. 

 

User needed to select a type of "Wall Style", and then could draw it.  

 

The contents of Basic Parameter determined the geometric information and usage of the wall. In general, user just 

has to consider Usage=Common Wall. 

 

Then click the tool bar icon at the bottom of the dialog box and select one of the three drawing methods ("Draw 

Straight Wall", "Draw Arc Wall" and "Draw Rectangle Wall"). Then draw the wall in the drawing area. 
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The explanation of the controls in the dialog box: 

 

[Wall Type] It mainly sets the type of wall and the corresponding style parameters of the material. It can be divided 

into two types: "Single Wall" and "Composite Wall" 

 

[Single Wall] Single Wall only has one kind of material. When choosing Single Wall users can select the type of the 

Wall Material. 

Including many materials, just like a partition wall, Glass Curtain, Hatch Wall and Reinforced concrete etc. The 

program pre-defined the hiding relationship between different materials according to the density of them. 

 

 

[Composite Wall]Composite Wall is made of a variety of materials. When choosing Composite Wall the users have 

to select one type in the list and the detailed parameters of this type will be listed in the table below. However, the 

parameters can not be changed in the table and the specific modification method will be seen in Style Manager 
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[Style Manager]Style Manager is used to adjusting the wall material and wall style. When the users are currently at 

Single Wall They can click the Style Manager to end the current command of drawing wall and then jump to the 

page of setting material style. Here, users can build or edit all kinds of wall material parameters. But when the users 

are currently at Composite Wall they also can click the Style Manager to end the current command of drawing wall 

and then jump to the page of setting material style. Here, users can build or edit all kinds of wall material 

parameters and set different materials for different wall styles.  

 

[Height] / [Bottom Elevation]: "Height" represents the height of the wall, which is the height of the wall from the 

bottom to the top. "Bottom Elevation" is the elevation of the wall bottom, in other words, it is the height from the 

elevation 0 of the drawing to the bottom of the wall.  

 

[Usage] includes Common Wall, Sanitary Partition, Balcony fence, Project wall and Virtual Wall, of which the 

project wall is a new wall type. It has the new feature, which are no bold mode, no hatch, disintegration with other 

walls. 

 

"Only Snap Wall Baseline" switch: when the switch is on, only the baseline can be snapped during wall drawing, 

however, the wall boundary can not be snapped. Only when the switch is off can the wall boundary be snapped. 

 

"Switch Module" switch: when the switch is on, user can only draw walls of the construction module length. If user 

wants to draw the wall of any length, the switch has to be turned off. 

 

"Draw Wall" command interaction: 

 

Enter all the necessary data in the dialog box, and click "Draw Straight Wall" toolbar icon. The command line 

displays: 

 

Start point or [Reference point] <Exit>: 

The operation of drawing straight wall is similar to that of drawing line. User can enter the next point of the straight 

wall continuously or press enter to complete the drawing. 

 

Straight wall next point or [Arc wall (A)/Rectangular Wall(R)/Close(C)/return (U)] (SHIFT Key to switch left and right 

width<Another segment> : 

Draw wall lines continuously. 
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Straight wall next point or [Arc wall (A)/Rectangular Wall(R)/Close(C)/return (U)] (SHIFT Key to switch left and right 

width<Another segment> : 

Press enter to complete the drawing. 

 

Start point or [Reference point] <Exit>: 

Press enter to exit the command. 

 

Enter all the necessary data in the dialog box, and click "Draw Arc Wall" toolbar icon. The command line displays: 

 

Start point or [Reference point] <Exit>: 

Specify the start point of the arc wall. 

 

Arc wall endpoint or [Line wall (L)/Rectangular wall(R)] <Cancel>: 

Specify the end point of the arc wall. 

 

Specify any point on arc or [Radius(R)] (SHIFT key to switch left and right width) <Exit>: 

Specify any point on the arc wall base line or enter R and define the radius of the arc. 

 

2.3.5 Equally Add Walls 

Building Design→Wall→Equally Add Walls 

 

This command is for the first wall you selected. In accordance with the principle of equality as well as being 

perpendicular to the first wall you selected the user can create a new wall. This command is usually used to 

increase multi section wall between the two parallel walls. 
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This command is for

 

 

Click Building Design→Wall→Equally Add Walls, then the dialog box would be displayed as follows: 

 

Enter the parameter related to the wall to be added in the dialog box.  

 

It is worthy of note if you want to add the "Single Wall" button you have to select the Single Wall option and the 

Material parameter. The value of Total Width decides the width of Single Wall. If you want to add Composite Wall 

you have to select Composite Wall option and Wall style. The value of Total Width is decided by Wall Style. 

 

At this time, the command line prompts: 

 

Please pick the reference wall to create wall evenly spaced<Exit>: 

Selected existing wall to which new walls is to be evenly added. 

 

Please select wall as another boundary<Exit>: 

Select another wall opposite to the wall selected in the previous step. 

 

Press enter to complete the "Equally Add Walls". 



Chapter 2 Function of Architectural Design 

71 

 

Example of "Equally Add Walls": 

The left picture indicated the walls selected for "Equally Add Walls", and the right picture indicates the way of 

"Equally Add Walls": 

 

 

2.3.6 Line to Walls 

Building Design→Wall→Line to Walls 

 

Click Building Design→Wall→Line to Walls, then the dialog box would be displayed as follows: 

 

The radio box "Axis Grid to Wall" is clicked by default, at this time, only the axis grid layer and objects on it can be 

selected, and the command line prompts: 

 

Only the axis grid layer and objects on it would be selected, and the command line prompts: 

Specify two opposite corner points to determine the selection range. 

 

Only the axis grid layer and objects on it would be selected, and the command line prompts: 

Press enter to complete the selection set, meanwhile, the wall would be created. 

 

Judge the closure condition of the axis line on the axis grid layer. The program would delete the extra extended axis 

line and create interior and external wall according to the dialog box parameter. 
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Example of "Line to Wall": 

 

If the radio box "Single Line to Wall" is clicked, user can select the object on any layer. The dialog box is as follows: 

 

User can check the check box "Retain Baseline". The command line prompts: 

 

Please select objects to generate walls: Specify two opposite corner point to determine the range of selection or 

specify individual lines according to which the wall is to be generated. 

 

Please select objects to generate walls: press enter to complete the selection, meanwhile, the wall is created. 

 

2.3.7 Part Wall 

Building Design→Wall→Part Wall 

 

Click Building Design→Wall→Part Wall, the dialog box would be displayed and offer 6 kind of wall parting mode 

as follows: 
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The top left icon in the dialog box is "Break Wall in Any Point", which is used to break the wall in a given point. 

 

The command line prompts: 

 

Please select the point to divide wall or [Reference point(R)] <OK>:  

Directly select the breakpoint or enter R to user the reference point. 

 

Please select the point to divide wall or [Reference point(R)] <OK> 

Press enter to exit. Then the wall is broken in the given point. 

 

Already finished wall division! 

 

The icon at the right bottom of the dialog box is "Break Wall in Intersection", which is used to break the wall in the 

intersection. When users do not want to wall to be continuous, they can break it in this way. 

 

The command line prompts: 

 

Please pick the wall to break at intersection point<Exit>: 

Specify two opposite corner points to determine the selection range. 

 

Please pick the wall to break at intersection point<Exit>: 

Press enter to exit. Then the wall is broken in the intersection. 

 

Successfully Break Wall at Intersection! 

 

The icon in the middle of the dialog box is "Two Point Break Wall". When users do not want to wall to be continuous, 

they can conveniently break it in this way.  

 

The command line prompts: 

 

Select start point or [Reference point] <Exit>: R 
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Enter R to select the way of breaking the wall accurately according to the reference point. 

 

Reference Point: select the point easy to be located as the reference point. 

 

Select start point or [Reference point] <Exit>: 240  

Specify the direction with the cursor and enter the distance between the breakpoint and the reference point. 

 

Select end point or [Reference point] <Exit>: 

Follow the similar steps of specifying the start point. 

 

Reference Point 

 

Select end point or [Reference point] <Exit>:240 

 

Already finished wall division! 

 

Example of above 3 Ways of Breaking Wall: 

 

If users want to edit and modify the divided wall, they can double click the wall section, and edit the parameter of it 

in the dialog box. 

 

The 3 new added methods of wall separating: "Break Wall at Intersection in Region", "Column Break Wall", 

"Win-Door Break Wall" is as follows: 

 

 

 

2.3.8 Merge Wall 

Building Design→Wall→Merge Wall 

 

Building Design→Wall→Merge Wall, then the command line prompts: 

Please select walls need to merge<Exit>: 
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Select multiple wall sections which are needed to be merged. The wall section that can not be merged would be 

ignored with no problem occurring. 

 

Please select walls need to merge<Exit>: 

Press enter to exit the command. 

 

If only one wall section which has already been merged is selected and pressed enter to exit the command, the 

command line prompts: 

 

Selected walls are too few, cannot merge! 

 

Using the command to merge these External walls as follows, user would get the one wall object. 

 

If the walls selected to merge are of different properties, a dialog box would be displayed and prompts whether 

change their properties to merge them as follows: 

 

Click "Yes", then program would modify a few parameters and go on merging the selected walls. 

 

Click "No", then program would merge the wall with the same properties, then the prompt is likely to be displayed 

again, Click "No" again, then the wall with different properties would remain unchanged, and the walls with the same 

properties would be merged. 

 

As shown in the following picture, user intends to merge 6 wall sections, but the width of the second wall section is 

different with the others. During the merging, respond "No" to not allow the wall properties to be changed, then the 

user get 3 wall sections. 
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With GstarCAD Architecture, user can edit the wall object by many common command like "Offset", "Trim", "Extend" 

etc., during which the baseline of the wall do not need to be displayed.  

 

In addition, user can directly edit multiple wall sections by the command: "Erase", "Move" and "Copy". User can also 

use the specialized command to edit the walls professionally. User can double click the wall and enter the dialog 

box for object editing to modify the wall parameter in it easily. User can also stretch the different grips of the wall to 

modify the length and position of it. 

 

In GstarCAD Architecture, the wall object is totally automatic intelligent component. The walls would be connected 

automatically at the intersection, however, in other similar software, user have to use to modify wall corner 

command to connect the walls at the intersection. The difference of them is as follows:  

 

 

2.3.9 Wall Fillet 

Building Design→Wall→Wall Fillet 

 

Building Design→Wall→Wall Fillet, then the command line prompts: 

 

Please select first straight wall or [Frame selection (F)/set chamfer Radius(R), current value=0] <Exit>: 

Enter R to set the round corner radius. 

 

Please enter fillet radius<0>:500 

Enter the round corner radius e.g. 500 

 

Point selection mode: 

 

Please select first straight wall or [Frame selection (F)/set chamfer Radius(R), current value=500] <Exit>: 

Select the first wall of the round corner. 

 

Please select another wall<Exit>: 

Select the second wall of the round corner, then complete the creation of the fillet wall and exit the command. 

 

Frame selection mode: 

 

Please select first straight wall or [Frame selection (F)/set chamfer Radius(R), current value=500] <Exit>: 

Enter F to switch to frame selection mode. 
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Please box select two wall segments for chamfer or [point select (D)/set chamfer Radius(R), current=500] <Exit>: 

Frame select the wall corner which needs converting into fillet wall and complete the creation of fillet wall.  

 

Then the command line will go on prompting: 

 

Please box select two wall segments for chamfer or [point select (D)/set chamfer Radius(R), current=500] <Exit>: 

Go on selecting the other wall corner which needs converting to fillet wall or select other options, then press enter 

to exit the command. 

 

 

2.3.10 Wall Chamfer 

Building Design→Wall→Wall Chamfer 

 

Building Design→Wall→Wall Chamfer, then the command line prompts: 

 

Please select the first straight wall or [set Distance (D), current distance 1=0, distance 2=0] <Exit>: D 

Select the first wall of the chamfer wall or enter D to set the chamfer distance. 

 

Please specify the first chamfer distance<0>:1200 

Enter the first chamfer distance e.g. 1200. 

 

Please specify the second chamfer distance<0>:600 

Enter the second chamfer distance e.g. 600. 

 

Please select the first straight wall or [set Distance (D), current distance 1=1200, distance 2=600] <Exit>: 

Select the first wall of the chamfer wall 

 

Please select another straight wall<Exit>:  

Select the second wall of the chamfer wall. 
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2.3.11 Align Baseline 

Building Design→Wall→Align Baseline 

 

Click Building Design→Wall→Align Baseline, then the command line prompts: 

 

Please specify the new endpoint or intersection of the baseline or [Reference point] <Exit>: 

Pick an end point of the baseline as the align point. Please do not pick the point elsewhere except for the end point. 

 

Please select wall (Notice: the baselines of jointed walls will be associative) <Exit>: 

Select the wall object which needs aligning with the end point of the baseline. 

 

Please select wall (Notice: the baselines of jointed walls will be associative) <Exit>: 

Go on selecting the wall objects. Then press enter to exit.  

 

Please specify the new endpoint or intersection of the baseline or [Reference point] <Exit>: 

Pick other end points of the baseline as the align point 

 

Example of "Align Baseline": 

As follows, during which the operation of baseline alignment has been executed twice. 

 

 

2.3.12 Align Side Line 

Building Design→Wall→Align Side Line 

 

Click Building Design→Wall→Align Side Line, then the command line prompts: 

 

Please specify a point that will align the wall [Reference point] <Exit>: 
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Specify a point which you want the wall side to go through (as shown in the left picture). 

 

Please specify the wall side through the point<Exit>: 

Select the wall side which is to go through to point specified. 

 

 

2.3.13 Wall Offset 

Building Design→Wall→Wall Offset 

 

Click Building Design→Wall→Wall Offset, the dialog box would be displayed as follows: 

 

Leave the check box "Offset Wall" unchecked and re-define the parameter of the new wall as follows: 

 

The command line prompts as follows: 

 

Please pick the wall side to be offset<Exit>: 

Pick the wall side on the same side with the new wall that is to be generated. 

 

Please pick the wall side to be offset<Exit>: 

Press enter to complete the selection; meanwhile, the new wall is generated. 
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2.3.14 Wall Insulation 

Building Design→Wall→Wall Insulation 

 

Click Building Design→Wall→Wall Insulation, then the following dialog box would be displayed: 

 

Please select the object to add insulation, wall, column, one side of wall Model<Exit>: 

Select the wall side where the insulation is to be added. Insulation can be added to one wall at one time. 

 

Please select the object to add insulation, wall, column, one side of wall model<Exit>: 

Press enter to exit the command. 

 

In GstarCAD Architecture, the thickness of the left insulation layers and the right insulation layers can be different, 

and user can enter different inside and outside insulation layer thickness value in the wall object properties bar.  
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The smallest unit of wall insulation adding is wall section, thus sometime user has to break the continuous wall in 

the intersection with other walls first and then add the insulation on the wall section which is needed it, or else the 

insulation would be added on the Interior Wall via the continuous wall. As shown in the following pictures, these are 

the examples of adding outside insulation on the external walls which have been divided into several wall sections. 

The reinforced concrete wall and the brick wall all have to be broken in the intersection. 

 

 

2.3.15 Wall Editing tools 

After the wall is created, we can double click it and modify the wall segment via the "Object Edit" dialog box. To edit 

multiple wall segments, wall edit tool would be more effective. 

 

2.3.16 Change Height 

Building Design→Wall→Wall Tools→Change Height 

 

Lease find the wall, the column or the wall Patch:  select the construction object need to be modified. 

 

New Height<3000>: 

Enter new height of the object. 

 

New Elevation<0>: 

Enter new elevation of the object bottom (the elevation relative to the same floor). 

 

Do you want to maintain the distance under the windows wall [Yes/No] <N>: 

Enter Y or N to determine whether the sill height is to be modified accordingly.  

 

After the above interaction the height and the elevation of the wall, the column or the wall Patch would be changed 

according to the given value. If the elevation of wall bottom hasn’t been changed, it is no matter that the user 

responds Y or N in the last step. However, in the case that the elevation of wall bottom is changed, for example, the 
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elevation of wall bottom is changed from 0 to -450, if user respond Y in the last step, the distance between the sill 

and the wall bottom would remain unchanged and the sill height would be reduced by 450. If the user respond N in 

the last step, the distance between the sill and the wall bottom would be changed, and the sill height would remain 

unchanged. The details related are as shown below: 

 

 

2.3.17 Exterior Wall Height 

The command is similar to the command of "Change Height". The difference is that the command only applies to 

exterior wall. Before running the command, user should have executed the command of "Identify I/E Wall". 

 

Building Design→Wall→Wall Tools→Exterior Wall Height 

 

2.3.18 Generate Paralleled Line 

Building Design→Wall→Wall Tools→Generate Paralleled Line 

 

Select the command "Generate Paralleled Line" in the menu, then the dialog box prompts: 

 

Select from the pull-down list or enter the offset distance, or click "Select Offset<" button and pick two points in the 

drawing to get the distance between them as the offset distance, then the command line prompts: 

 

Please select wall side/ Wall Patch / Column<Exit>: 

Select the side of wall or column on the same side with Paralleled Line to be generated.  

 

Then command would go on prompting, user can press enter to exit. 
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2.3.19 Identify I/E Wall 

Building Design→Wall→Wall Tools→Identify I/E wall→Identify I/E wall 

 

Select the command "Generate Paralleled Line" in the menu, then the command line prompts: 

 

Please select all walls of the whole building (or win-doors) <All>: 

Select the walls of the building or the windows and doors on them. 

 

After the user pressing enter, program would automatically identify the exterior walls among the walls selected, after 

the identification, the command line prompts: 

 

Apply Red line to highlighting outside exterior walls. 

 

2.3.20 Highlight Exterior Wall 

Building Design→Wall→Wall Tools→Identify I/E wall→Highlight Exterior Wall 

 

Select the command "Highlight Exterior Wall" in the menu, then the identified exterior wall would be highlighted by 

red dotted line. While the exterior wall remains highlighted, user can zoom in and out the drawings at will. 

 

Exit highlight by clicking drawing area, pressing enter, or pressing ESC. 

 

2.3.21 Seal Wall End 

"Seal Wall End" command can be invoked by entering the related parameters in the properties bar, which applies to 

the wall object whose end is extended out. In properties bar, the default parameter for "Seal Wall End" is "Y" (the 

wall end is sealed by default). If special way of wall end connection is needed, user can enter "N" in the text box next 

to "Seal Wall End" in the properties bar. User can draw the end of the wall by line etc. instead of construction object.  
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2.4 Door and Window 

2.4.1 Create Door/Window 

Building Design→Door and Window→Door/Window 

 

Building Design→Door and Window→Door/Window, then the dialog box would be displayed as follows. Now we 

will introduce to you the door/window location method button at the bottom of the dialog box from left to right. 

 

 

2.4.1.1 Insert by Any Point on Wall 

Under this mode, Door/Window can be inserted in any position of the wall, the advantage of which is its fast speed 

however the disadvantage is it is hard to locate accurately, thus it is usually used in the stage of plan design. User 

can change the door open direction (inward or outward) by moving the cursor to different sides of the baseline. User 

can change the door open direction (left or right) by pressing shift. The position and the open direction of the 

Door/Window are totally fixed after the user click the wall.  

 

The command line prompts: 

 

Specify win-door insertion location (SHIFT key to switch left and right) <Exit>: 

User can insert the Door/Window in the wall by clicking the wall need inserting the Door/Window. User can also 

change the Door/Window opening direction by pressing shift. 

 

2.4.1.2 Intelligent Insert 

The command is used to insert the Door/Window automatically in the wall segment as per the related regulation, 

which is applied to the line wall and arc wall. User can also select "Fixed Distance to Axis Line" or "Fixed Distance to 

Wall" as the method of the offset distance determination. 

 

The command line prompts: 

 

Specify win-door location or [fixed distance to axis line (Q), current: fixed distance to wall] <Exit>: 

 

Drag the Door/Window and insert them at the appropriate position relative to the dividing line. 
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The regulation of "Intelligent Insert" is: divide the current wall segment which needs inserting Door/Window into 3 

parts by two purple temporary dividing lines. When the user Inserts the Door/Window in right or left side part, the 

program would regard it as that the Door/Window is to be inserted at given distance from the wall or axis. 

 

When the user Inserts the Door/Window in the middle part, the program would regard it as that the Door/Window is 

to be inserted in the middle of the wall as shown in the following pictures: 

 

 

2.4.1.3 Insert Along Wall by Order 

The user can start from the wall end point which is nearer to the picked point and insert the selected Door/Window 

at specified distance, after which the Door/Window can be inserted in sequence along the forward direction. User 

can modify the type and parameter of the Door/Window when inserting it in the wall. When the Door/Window is 

inserted in the arc wall in sequence, it will be located according to the arc length of the wall baseline. 

 

The command line prompts: 

 

Select a Wall<Exit>: 

Pick the wall line in which the Door/Window needs to be inserted. 

 

Enter Distance from Base point to Side of Win-door<Exit>:500 

Enter the value of the distance from the start point to the first Door/Window side. 

 

Enter Distance from Base point to Side of Win-door[S-flip vertical/D-flip inside and outside] <Exit>: 

 

Enter the value of the distance from the side of the previous Door/Window to that of the Door/Window which is to be 

inserted. 

 

2.4.1.4 By Dividing between Adjacent Axes 

The command line prompts: 

 

Please select the wall to insert window or [insert window to single wall (Q)] <Exit>: 

 

Example 1 of "By Dividing between Adjacent Axes": 

There are two groups of windows with two windows in each group. Find "Quantity" on the right of the dialog box and 

enter 2 in the text box next to it, which means continuously inserting two windows in each group. Enter 2 in the text 

box next to "Equal", which means inserting 2 groups of windows in the bay between two adjacent axes. 
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The software would arrange the Door/Window in the wall as per the given size of the individual Door/Window. If the 

value for "Equal" is changed, the distance between each group of windows would be adjusted accordingly. The 

effect drawing is as shown in the following picture. 

 

 

Example 2 of "By Dividing between Adjacent Axes": 

There are many bays between axes with 1 window in each bay between adjacent axes. The command supports the 

case that there are some columns in the wall. 

 

 

Please select the wall to insert window or [insert window to single Wall (Q)] <Exit>: 

Pick individual wall or frame select multiple wall object in which the windows are to be inserted.  Generally, the 

multiple walls in which the windows are to be inserted are exterior walls. 

 

Please select the wall to insert window or [insert window to single Wall (Q)] <Exit>: 

Press enter to complete the selection. The effect drawing is as shown in the following picture. 
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Example 3 of "By Dividing between Adjacent Axes": 

When one Door/Window is to be inserted in individual bay between adjacent axes, if there’s partition wall in the bay, 

it can be divided into two cases as follows. The program would handle them accordingly. 

 

In the bay between the adjacent axes, if the walls on both sides of the partition wall are merged, the Door/Window 

would be equally inserted in wall segment between the adjacent axes as shown in the picture below. 

 

In the bay between the adjacent axes, if the walls on both sides of the partition wall are broken in the intersection, 

the Door/Window would be equally inserted in the wall segment between the wall end point and the axis as shown 

in the picture below.  

 

 

2.4.1.5 By Dividing along a Wall Segment 

Similar to "By Dividing between Adjacent Axes", the command "By Dividing along a Wall Segment" is used to insert 

several Door/Window in the wall, which enables the wall segment between the Door/Window to be equal according 

to the shorter side of the wall. The command offers "Insert Window to Multiple Walls (Q)" option, which support 

both merged and segmented wall.  Under this option, when walls of different bay are merged, user can insert 

Door/Window in all the other related bays after selecting wall segment of any of the bays. In the merged wall, if 

there is Door/Window in the wall of one bay already, "Insert Window to Multiple Walls (Q)" is not available. 

 

 

Example 1 of "By Dividing along a Wall Segment": 

Within a relatively long wall segment of bay, set the value of "Equal" as 4 and insert the window. The parameter in 

the dialog box is as follows: 
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The command line prompts: 

 

Specify win-door insertion location (SHIFT key to switch left and right) or [Insert window to multiple walls (Q)] 

<Exit>: pick one point on the wall in which the Door/Window is to be inserted, then the Door/Window would be 

arranged in the wall automatically according to their size. 

 

 

Example 2 of "By Dividing along a Wall Segment": 

Within multiple relatively short wall segments of bays, set the value of "Equal" as 1 and insert the windows(insert 

one window in each wall segment of the bay), The parameter in the dialog box is as follows(the value of "Quantity" 

and "Equal" can be more than 1):  

 

Specify win-door insertion location (SHIFT key to switch left and right) or [Insert window to multiple walls (Q)] 

<Exit>: Q 

Enter Q to invoke the command "Insert Window to Multiple Walls (Q)". Then the command line will go on 

prompting: 

 

Please select the wall to insert window or [insert window to single wall (Q) <Exit>: 

Frame select the walls in which the window is to be inserted. The walls scope involved is the wall segments instead 

of the walls between the axes.  

 

Please select the wall to insert window or [insert window to single wall (Q)] <Exit>: 

Press enter to complete the selection. The effect drawing is as shown in the following picture. 
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2.4.1.6 Along Wall Segment at Given Distance 

The program select the wall sideline end point which is nearest to the picked point as the reference point and insert 

the Door/Window at the distance of specified wall segment length. The following example set the wall segment 

length as 100(mm); insert the windows near the wall corner and near the right side of column respectively.  

 

The command line prompts: 

 

Specify win-door insertion location (SHIFT key to switch left and right) <Exit>: 

Click the wall segment next to the column and insert the window. 

 

Specify win-door insertion location (SHIFT key to switch left and right) <Exit>: 

Click the wall segment next to the wall corner and insert the window. 

 

As shown in the following picture, the wall segment length depends on the value for "Offset" in the dialog box. Wall 

segment length is calculated from the side of the column or the side of the wall if there’s no column.  

 

 

2.4.1.7 From Axis by Given Offset 

The command is similar to "Along Wall Segment at Given Distance". The program would automatically search 

intersection between the axis line nearest to the picked point and the wall, and insert the Door/Window at specified 

distance from it. 
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2.4.1.8 Along Arc Wall by Angle 

The command is specially used to insert the Door/Window of line type in arc wall as per specified angle.  

 

The command line prompts: 

 

Select Arc Wall<Exit>: 

Select the arc wall. 

 

Angle of Win-door Center<Exit>:50 

Enter the angle value of the Door/Window which needs to be inserted. 

 

2.4.1.9 Fill in Wall Segment 

The wall would be filled with the Door/Window in the direction of their width.  When this command is invoked, the 

width parameter of the Door/Window would be automatically determined by the program. 

 

The command line prompts: 

 

Specify win-door insertion location (SHIFT key to switch left and right) <Exit>: 

Select the wall and press enter to exit. 

 

2.4.1.10 Upper Win-Door 

When there’s already a Door/Window in the wall, add another Door/Window with the same width and different height 

in the same wall above the existing Door/Window, which commonly used in the tall and large factory building. 

 

Click the icon "Upper Win-Door", and then enter the "Tag", "height" and "Sill High" of the Upper Win-door. After the 

inserting the tag of the upper Win-door would be displayed on the outside of the tag of the lower Win-door as 

shown in the following picture.   

Note: When this command is invoked, the elevation of the top of the Upper Win-door cannot be beyond the height of 

the top of the wall. 

 

 

2.4.1.11 Replace Windows/Doors 

The command is used to modify the window/doors in batch, including the converting of window/doors type. 
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Regard the current parameter in the dialog box as the target parameter and replace the existing window/doors in the 

drawing. Click "Replace Windows and Doors" button, then the check box used for parameter filtering would be 

displayed on the right of the dialog box. 

 

If user does not want to change some parameter during the replacing, please uncheck the related checkbox, after 

which, the parameter would remain unchanged and keep the same with that of the original drawing after the 

replacing. For example, if user does not want the width of the existing door to be changed when converting the door 

into a window, the "Width" check box should be unchecked. 

 

2.4.2 Group Door/Window 

Building Design→Door and Window→Group Door/Window 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Select win-door and tags to be combined: select the first win-door which needs to be combined. 

 

Select win-door and tags to be combined: select the second win-door which needs to be combined. 

 

Select win-door and tags to be combined: select the third win-door which needs to be combined. 

 

Select win-door and tags to be combined: press enter to complete the selection. 

 

Enter win-door tag<Empty>: 

MC enters the combined win-door tag, and converts the win-door selected into combined win-door. 
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2.4.3 Corner Window 

Building Design→Door and Window→Corner Window 

 

After the user clicks the command in the menu, the dialog box will be displayed: 

 

Enter the parameter in it, and the command line will prompt: 

 

Please select wall corner (SHIFT Key-switch window width) <Exit>: 

 

Position the cursor at the wall corner and preview the corner window automatically. User can press "Shift" to switch 

the width of the two windows. The effect drawing is as shown in the following picture. Click to insert the corner wall 

after the user is satisfied with the direction of the window width. 

 

Please select wall corner (SHIFT Key-switch window width) <Exit>: 

Go on selecting the wall corner or press enter to exit the command. 

 

If the user wants to create bay window, please check the bay window check box first, then the dialog box will expand 

as follows: 
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Double click the corner window to enter the corner window object editing. The following dialog box will pop up. 

User can click OK after the modification of the parameter to update the corner window. 

 

 

2.4.4 Ribbon Window 

Building Design→Door and Window→Ribbon Window 

 

After the user clicks the command in the menu, the dialog box will be displayed: 

 

Enter parameter in the above dialog box. If the bay window check box is not checked, the dialog box parameter is 

used to create ribbon window. The command line prompts:  

 

Select start point of banding window or [Reference point] <Exit>: 

Pick the exact point on the wall as the start point of the ribbon window. If user can not directly pick the point, please 

enter R to use the reference point. 

 

Select end point of banding window or [Reference point] <Exit>: 

Pick the exact point on the wall as the start point of the ribbon window. If user can not directly pick the point, please 

enter R to use the reference point. 

 

Please select walls that banding window through<Exit>: 

Select multiple wall segments the ribbon window is through. 

 

Please select walls that banding window through<Exit>: 

Press enter to exit command; the ribbon window created is as shown in the following picture. 
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If the user wants to create bay window, please check the bay window check box first, then the dialog box will expand 

as follows: 

 

Sideboard is added to the right side of the corner bay window, and the "Overhang" is 600.  After the execution of 

the command, the effect drawing is as shown in the right picture below. 

 

Creating ribbon window in the Circular Wall needs special handling. The example is as follows: 
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[Custom Outline] user can select the customized ribbon window outline that has been drawn in the drawing to 

generate the customized ribbon bay window, which would make the content expression of the drawing substantial. 

 

[Overhang] the distance at which the bay window overhangs the wall. 

 

[French window] if the checkbox "French Window" is checked, the sill line would not be drawn on the inside of the 

wall, and the sill height would be "0". 

 

[Left Sideboard/Right Sideboard] after the checkbox "Left Sideboard" ("Right Sideboard") is checked, the left side 

(right side) of the bay window would be converted to solid sideboard. 

 

[Sideboard Thickness/Sill Thickness] the "Sideboard Thickness" is 100 by default. The value of it can be modified 

after the user check the check box "Left Sideboard/Right Sideboard". 

 

The bay "Bay Window" check box is unchecked by default, in this case, the window drawn would be common 

window, and the window is arrange according to the wall. 

 

If user check the checkbox "Bay Window" and not check the "French window" check box, the window drawn would 

be common bay window. 

 

If user checks both "Bay Window" and "French window" check box, the window drawn would be French bay window. 

 

The program can number the ribbon window automatically according to the length, the rule of which can be set by 

the user in the interface of "Option Config" ->"Tag Settings". Program supplies 3 ways to calculate the length of the 

bay window in the corner: "Wall Internal Surface", "Wall Center Line" and "Wall External Surface" as follows. 
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The pane parameter of the ribbon window is "Auto Divide Window Pane" by default. The default width of each pane 

is 750. "Equal Divide Window Pane" is set as no by default. All the above parameters can be modified in the 

properties bar. 

 

[Auto Divide Window Pane] if the value of it is set as "Yes", the pane would be automatically divided along the 

ribbon window as per given width. If the value of it is set as "No", there would not be any pane in the ribbon window. 

 

[Pane Width] user can enter the pane unit width as per needs. Pane line would be inserted between the adjacent 

pane units. 

 

[Equal Divide Window Pane] if the value of it is set as "Yes", the command would equally divide the ribbon window 

according to equal dividing number calculated by the specified pane width, the width of the each target pane is 

roughly equivalent to the specified pane width. If the value of it is set as "No", the command would have the width 

of the pane in the middle part of the ribbon window equal to the specified pane width, and have the width of the first 

and last pane equal to the rest of the width. 

 

In plane drawing, there are two styles of ribbon window: three-line glass curtain and four-line glass curtain. User 

can configure related parameters in "Settings and Help -> Settings -> Config -> Advance Option -> Entity-> 

Win-door -> Ribbon Win-Door in 2D". The default value for "Ribbon Win-Door in 2D Style" is "Change by Scale". If 

current scale is larger than "1:150" (as 1:100), the style of ribbon curtain would be of "4-linestyle". When the print 

scale of the glass curtain is less than 1:150 (as 1:200), the ribbon curtain would be of 3-line style.  
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2.4.5 Shaped Hole 

Building Design→Door and Window→Shaped Hole 

 

After the user clicks the command in the menu, the dialog box will be displayed: 

 

Select closed polyline or circle which use for the hole outline<Exit>: 

Select the hole outline on the drawing. 

 

Select closed polyline or circle which use for the hole outline<Exit>: 

Select the wall in which the hole is to be inserted. 

 

The dialog box would be displayed as shown in the following picture: 

 

User can switch the hole style to one of the 4 styles by clicking "Hole 2D Display Style" image box. 

 

For example, after the first style is selected, the result of adding hole is as follows. A circular hole is added to the 

arc wall. 
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2.4.6 Win-Door Arrange 

Building Design→Door and Window→Win-Door Arrange 

 

After the user clicks the command in the menu, the dialog box will be displayed as follows: 

 

User can check the check box in row 1 and row 2, and set them as follows: if the "Wall Segment Length" is equal or 

less than 100, program will rearrange it to be 0, and if the "Wall Segment Length" is equal or less than 300, 

program will rearrange it to be 120, in which the value 100,300,120 can be modified as per user’s needs. There are 

3 checkboxes in row 3 related to "Align Win-Door to Center".  The rearrangement can be based on axis line or side 

of the wall and column. 

 

In fact, the above three conditions can be combined as per needs, and the command related to each parameter 

combination will be executed when there’s win-door which meets the requirement. 

 

Example of "Win-Door Arrange": 

Check the check box in row 1 and row 2, and set them as follows: if the "Wall Segment Length" is equal or less than 

100, program will rearrange it to be 0, and if the "Wall Segment Length" is equal or less than 300, program will 

rearrange it to be 120. Uncheck the "Align Win-Door to Center" check box. Then the command line will prompt: 

 

Please select the win-door to arrange<Exit>: 

Pick the individual win-door that needs rearrangement one by one or frame selecting multiple win-doors. 

 

Please select the win-door to arrange or [return (U)] <Exit>: 

Press enter to exit the command. 

 

After the user selects the win-doors which need rearrangement, the location of win-doors selected will immediately 

be rearranged as per the settings in the dialog box. Press enter to exit the command. The border of the wall segment 

would start from the intersected wall corner or column side. The example is as shown in the following picture. 
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Check the "Align Win-Door to Center" check box and uncheck the check box "Wall Segment Length…"in row 1 and 

row 2. Click the radio button "Axis Line" and set the "Middle Distance" as 1200. The setting is aimed to rearrange 

the win-door near the middle as per the axis line. The dialog box is as follows: 

 

The command line prompts: 

 

Please select the win-door to arrange<Exit>: 

Frame select the walls which need to be aligned to center. 

 

Please select the win-door to arrange or [return (U)] <Exit>: 

Press enter to complete the selection or click U to cancel. 

 

Check the "Align Win-Door to Center" check box, then the program would align the win-door between the axis lines 

to center as per the "Middle Distance" set by the user.  

 

2.4.7 Flip In/Out 

Building Design→Door and Window→Flip In/Out 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Please select the win-doors<Exit>: 

Select the win-doors which need to be flipped. 

 

Please select the win-doors<Exit>: 

Press enter to complete the select and the win-doors selected would be flipped. 
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2.4.8 Flip Left/Right 

Building Design→Door and Window→Flip Left/Right 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Please select the win-doors<Exit>: 

Select the win-doors which need to be flipped. 

 

Please select the win-doors<Exit>: 

Press enter to complete the select and the win-doors selected would be flipped. 

 

2.4.9 Tag Settings 

Settings and Help→Settings→Config→Tag Settings:  

 

The interface of "Tag Settings" is as follows, the controls vary according to different win-door types. 

 

The explanation of the controls in the dialog box: 

 

[Win-door Type] major categories of win-doors like window, door and hole, etc. 

 

[Type] sub-categories under each major category of win-door, for example, door can be further divided into fire 

rated door, civil air defense etc. 
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[Tag] content here is the tag for each win-door style. For example, with regard to the "Fire Rated Door A", prefix tag 

is "A-FR-D", thus the Fire Rated Door A whose width is 1 M and height is 2.4 M would be automatically numbered 

as A-FR-D1024. 

 

[Add Hyphen] is to add Hyphen "-" in English between win-door tag prefix and the sequence number. Then the 

win-door tag created would be like these:  M-1521 (by size); M-1 (in order) 

 

[By Size] the default tag rule is automatically adding tag by size. In this case the tag rule is prefix +width and height 

of win-door, e.g. RFM1224, FM-1224. 

 

 

[Round Off] when the "Round-Off" check box is checked, in the case of "Automatically Number The Win-Door by 

Size",  the program would number the win-door not only by the first two numbers of the width and the height, but 

also take the last two number into consideration. The last two numbers of width and the height will be handled in the 

way of "Round-Off". When the "Round-Off" check box is unchecked, the program would number the win-door only 

by the first two numbers of the width and the height. The last two numbers would not be taken into consideration 

and directly truncated. 

 

[In order] when the "In Order" radio button is clicked, the tag rule is prefix+ sequence number (nature number) like 

RFM1~RFM2, FM1~FM2. 

 

[Wall Internal Surface][Wall Center Line][Wall External Surface] user can click any one of the 3 radio buttons, the 

width of the ribbon window and the corner window can be calculated as per the rule selected as follows. The setting 

does not apply to common window. 

 

[Segmentation Tag] after the user check the "Segmentation Tag" check box, the program would number the ribbon 

window according to the width of each segment. With regard to the corner window as follows, the height of it is 

1500. Check the "Segmentation Tag" check box and "Round-Off" check box, and select "Wall Center Line" as the 

window width location. Then the tag of the corner wall would be COR-W (14+17)15. If the check box 

"Segmentation Tag" is unchecked, program would number the win-door according to the combined width of each 

window segment. Thus the tag in the above example would be changed into COR-W3115. 
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Example of "Round Off":  

1.  With regard to the window with the width 1050, height 1950, after the execution of "Round off", the auto tag by 

size would be M1120. 

2.  With regard to the window with the width 1050, height 1950, if the checkbox "Round off" is unchecked, auto tag 

by size would be M1019. 

 

2.4.10 Win-Door Tag 

Building Design→Door and Window→Win-Door Tag 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Number the win-door without tag automatically. 

 

Please select the range of the win-doors that require modifying tag: 

Select the win-doors that need tag modification using any selecting method system offers. 

 

Please select the range of the win-doors that require modifying tag: press enter to complete the selection. 

 

Please enter new Win-door tag [E-delete tag] <C1209>:  

Number the win-doors automatically according to the default rules and the size of the win-door hole; user can also 

enter other tags like C1. 

 

Renumber the win-door with tag on it. 
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Please select the range of the win-doors that require modifying tag: 

Select the win-doors that need tag modification using any selecting method system offers. 

 

Please select the range of the win-doors that require modifying tag: press enter to complete the selection. 

 

Please enter new Win-door tag [E-delete tag] <M1521>:  

Regard the existing win-door tag as default value. Enter new tag or enter E to delete the existing tag. 

 

2.4.11 Win-Door Management 

Building Design→Door and Window→Win-Door Management 

 

After the user clicks the command in the menu, the command line will prompt:  
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The explanation of the dialog box command icons and buttons: 

 

[Classification of the win-door] user can select different item from it to display different class of win-door. The pull 

down list includes: 

"Total", "Door", "Banding Window", "Conflict", "Unnumbered", "Already Numbered". 

 

[Select Project] select the project which needs win-door checking. The project is only opened during the checking, 

and will be closed immediately when the "Win-Door Management" is closed. 
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[Select object] is used to change checking range. The default checking range is the whole drawing or the whole 

project, in other words, all the project is selected as the checking range by default.  

 

[Refresh Table] refresh the existing win-door data in the interface of the win-door management according to the data 

in current drawing. 

 

[Floor Precedence Grouping] 

 

[Display Win-door Style] is used to display the 2D and 3D style at the bottom of the table, which are not displayed 

by default. 

 

[Tag] display the existing win-door tag in the drawing. With regard to the win-door without tag, the related cell is 

blank. 

 

[New Tag] it is the same with the "Tag" by default. It would become red after being modified by the user. After the 

user click "Apply", the color would be black again. 

 

[Number] the number in the parentheses is the number of the win-door with the same tag in a standard floor.  

 

[Width]/ [Height] this represents win-door width and height. 

 

[2D]/ [3D] display preview of the 2D and 3D style of the win-door.   

 

[Sill High] with regard the win-door with the same tag and different sill high, the related column title would display 

"Multiple". The case would not be regarded as "Conflict". 

 

[Apply] is used to apply the updated data in the win-door table to the current drawing and update the win-door 

object in the drawing accordingly. 

 

[Win-door Table] create the win-door sub schedule/schedule with win-door data of the current project or drawing. 

 

The color of the parameter in the table indicates which the win-doors are in the current DWG drawing. As shown in 

the following picture, the parameter of the second floor is black, while the parameters in the other floors are grey, 

which indicates that win-doors of the second floor are in the current drawing while win-doors of the other floors are 

not in the current DWG drawing. 

 

The row with background color in the table indicates the public parameter used for the win-door of certain style 

within the floor. When the parameter conflict within the floor occurs, there will be a word "Conflict" highlighted in 

red in the related cell. 
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If the 2D/3D style of the win-door with same tag is different, there will be related prompt in the table like C1215 

(Style conflict) .After the user click the "[Display Win-door Style]" icon, the 2D and 3D style of the win-door would 

be displayed in the image preview box as follows, which are not displayed by default. Then click the front button of 

each line as shown in the right picture below, user can find in the image box which win-door is of different style 

easily. 
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"Unify Current Group": update all the data of the win-door within the same tag group in conformity with data or 

style of the win-door within the tag group. First modify the parameter except for parameter for sill high in one row, 

then click the row and right click the first column of the row as follows. 
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2.4.12 Win-Door Sub-Schedule 

Building Design→Door and Window→Win-Door Sub-Schedule  

 

After the user clicks the command in the menu, the command line will prompt: 

 

Select the existing win-doors: select all the drawing or frame select part of the floor plane drawing that need 

statistics. 

 

System would display the dialog box first, in which the table header style of currently used win-door table is 

displayed. 

 

User can enter the table library by either clicking the "Select from Sheet" button or clicking the image preview box 

on the dialog box to select the headers which have already been imported into the sheet library/door and window 

sheet. Double click to select the "Traditional Door and Window Sheet", "Standard Door and Window Sheet" which 

are in the system library by default or select the door and window sheet of the company. 
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After the user selects the win-door style he need and press OK, the command line will prompt inserting the 

win-door Sub-Schedule. 

 

Please select position of win-door schedule (Top left corner point): pick the point in which the win-door 

Sub-Schedule is to be inserted. The standard style of the win-door Sub-Schedule is as follows. The program would 

gather statistics of the door first and then gather statistics of the windows. The following screenshot only displays 

the statistics of the door which are in the front of the win-door Sub-Schedule. 

 

IF user is not satisfied with the width, height or title of win-door Sub-Schedule generated, he can directly modify it 

by table editing or double clicking the win-door Sub-Schedule to enter in-place edit mode. User can also drag a 

row to other position.  

 

2.4.13 Win-Door Schedule  

Building Design→Door and Window→Win-Door Sub-Schedule  

 

When the current project is open, after the user clicks the command in the menu, the "Select Schedule Style" dialog 

box would be displayed as follows: 

 

User can click "Select from Schedule Library" as per needs or click the schedule preview image box to enter Sheet 

Library/Door and Window sheet and select the schedule header which has been imported into the library. Double 
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click to select the "Traditional Door and Window Sheet", "Standard Door and Window Sheet" which are in the system 

library by default or select the door and window sheet of the company. After the user selects the win-door style he 

need and press OK, the program would read in the floor and win-door data of each plane drawing in the current 

project and create the door/window sheet.  Then command line will prompt as follows: 

 

Please select position of win-door schedule (Top left corner point): pick the point in which the win-door Schedule 

is to be inserted. 

 

The command has the function of checking the win-door and report the error related. The win-door schedule would 

be exported as per the international win-door schedule standard. Number 0 would be displayed as blank in it. 

 

If user wants to modify the win-door schedule, please modify it via table object editing after the inserting of the 

win-door schedule. Please be noted the column of the schedule cannot be added or deleted directly. If user wants 

to modify it, please create a new schedule header and import it to the win-door schedule library.  

 

To know the process of creating a new project, the section "Project Management" can be read for reference. 

 

2.4.14 Tag Suffix 

Building Design→Door and Window→Door/Window Tools→Tag Suffix 

 

After the user clicks the command in the menu, the command line will prompt:  

 

Please select the win-door tag which is need to add affix or [change suffix, Current suffix] <Exit>: 

 

2.4.15 Win-Door Casing 

Building Design→Door and Window→Door/Window Tools→Win-door Casing 

 

This function is worked on Single Wall Only. After the user clicks the command in the menu, the dialog box will be 

displayed: 
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The radio box "Add Casing" in the dialog box is clicked by default. User can click the radio button of "Remove 

Casing" instead. After setting the parameter "Overhand" and "Casing Width", please move the cursor to the drawing 

area. Then the interaction in the command line is as follows: 

 

Please select win-doors<Exit>: 

Select the win-doors which need adding the Win-door Casing 

 

Please select win-doors<Exit>: 

Press enter to complete the selection. 

 

Click the win-doors casing side<Exit>: 

Pick the point on the side where the Win-door Casing is to be added. 

 

The command interaction of "Remove Casing" is similar to that of "Add Casing" and will not be described here. 

 

 

2.4.16 Threshold Line 

Building Design→Door and Window→Door/Window Tools→Threshold Line 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Please select the win-doors that require adding and removing door line<Exit>: 

Select the win-doors which need adding the threshold line. 

 

Please select the win-doors that require adding and removing door line<Exit>: 

Press enter to complete the selection. 

 

Please specify the side of door line or [Double sides operation (D)] <Exit>: 

Select one side of the wall where the threshold line is to be added. Press enter to execute the command. 

 

Threshold consists of 2 threshold lines, thus user has to execute the command again, during which, if the user 

select the side of the wall where there’s already a threshold line, the existing threshold line would be moved.  

 



Chapter 2 Function of Architectural Design 

112 

 

2.4.17 Window Lattice Expansion 

Building Design→Door and Window→Door/Window Tools→Window Lattice Expansion 

 

The steps of "Window Lattice Expansion" 

 

User can use "Window Lattice Expansion" to expand the original window lattice to plane drawing. 

 

After the user click the command in the menu, the command line will prompt: 

 

Select Win-door: select the win-door which needs to be expanded. 

 

Select position to expand<Exit>: 

Pick a blank position in the drawing. 

 

User LINE, ARC and CIRCLE to add the details to the window lattice, these line segment is required to be drawn on 

the layer 0. 

 

User can use the command "Window Lattice Mapping" introduced below to mapping the drawing of expanded 

window lattice to 3D effect. 

 

2.4.18 Window Lattice Mapping 

Building Design→Door and Window→Door/Window Tools→Window Lattice Mapping 

 

After the user click the command in the menu, the command line will prompt: 

 

Select window to mapping: specify the target win-door (can be multi selected) to which the window lattice is to be 

mapped. Press enter to exit. 

 

Notice: None Select will recover default window Sash. 

User can give up "Window Lattice Mapping" by press enter here. 

 

Select lattice for mapping: select the window lattice defined by the user. 

 

Select lattice for mapping: press enter to complete the selection. 

 

Select Base Point<Exit>: 
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Pick the base point of the window lattice on the drawing of expanded window lattice. Then the window lattice is 

mapped to the specified windows. The effect drawing is as shown in the following picture. 

 

 

 

2.4.19 Win-Door Prototype 

The command "Win-Door Prototype" is used by the user to customize the win-door. 

 

Building Design→Door and Window→Door/Window Tools→Win-door Prototype 

 

After the user click the command in the menu, the command line will prompt: 

 

Select Win-door:  select the win-door which is to be regarded as the win-door block temple in the drawing (Note: 

do not select the win-door with the casing). 

 

Prototype of 2D win-door: The environment of win-door Prototype is as shown in the picture below. The win-door 

which is regarded as the temple is placed in a wall hole horizontally. There is a base point represented by a red "×" 

in it, the size and the style of the win-door are exactly the same with that selected by the user. However, the 

win-door is no longer drawing block at this time, they are composed of the primitive and easy to edit including LINE, 

ARC, CIRCLE, PLINE, with which user can also draw his own win-door between the wall hole. User can also use 

pline with width to draw the door leaf with width hatch. 
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2.4.20 Import Win-Door to Library 

Building Design→Door and Window→Door/Window Tools→Import Win-door to Library 

 

When user imports 2D win-door in the library, there is no interaction. The current temporary document window 

would be closed and the dialog box of win-door library with the new win-door imported will be displayed. 

 

The win-door block imported in the library by the user would be named as "New Name" temporarily and would be 

imported automatically to the "My Library". 

 

In the dialog box of "Drawing Library" command, user can enter "My Library" to rename the name of the drawing 

block. User can keep the new drawing block in the "My Library" as well as move it into "System Library". The latter 

can be done in this way, right click "System Library" and select "Cancel Lock" to unlock the "System Library", then 

move the user drawing block from "My Library" to appropriate class of win-door in "System Library" as follows. User 

cannot move the new drawing block to "System Library" until he unlocks it. 
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2.5 Room and Roof 

2.5.1 Search Room 

Building Design→Room and Roof→Search Room 

 

After user clicks the command in the menu, the following dialog box will be displayed.  

 

The explanations of the controls in the dialog box 

 

[Mark Area] it determines whether room usable area is to be displayed. 

 

[Area Unit] it determines whether area unit is to be marked. The area unit is M2 by default. 

 

[Room Name]/ [Room Number] in construction plan, it is used to mark the room name. With regard to the other 

major, it is used to mark the room number. The room name and the room number can be marked at the same time. 

 

[3D Floor] is used to generate 3Dfloor along the boundaries of the room object. 

 

[Slab Thickness] is used to give the thickness of the floor when the 3D floor is generated. 

 

[Generate Building Profile Area] is used to calculate the construction outline area, which is the constituent part of 

the floor area. 

 

[Building Profile without Column] the measurement rule of the floor area. When calculating the floor area, user 

should ignore the protuberant decorative column and pilaster in the building profile. 

 

[Hide Background] is used to shield the hatch beneath the room mark with "Wipeout" function. 

 

Meanwhile, the command line will prompt: 

 

Please select all walls and balconies of a complete building<Exit>: 

Select the wall on the plan. 

 

Please select all walls and balconies of a complete building<Exit>: 

Press enter to complete the selection. 

 

Please select dimension position for building profile area<No dimension>: 

When generating building profile area, user has to specify the point where the mark is to be added. 
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Example of "Search Room" (Room Area Supports Adding Hole): 

 

If user failed to execute the "Search Room" command, in other words, the room which appears to be closed can not 

be found. In this case user has to check the room’s baseline to find if they are not closed at the intersection. In 

GstarCAD Architecture, the wall object can be merged. After the execution of the command, the merged wall would 

be divided into wall segments at the intersection automatically and form the rooms. If the distance of the wall 

baseline end point at the intersection is larger than the wall joint precision, the automatic division as well as the 

room generation would be failed.  

 

If the wall is not closed, user can neither execute the "Area Statistic" command. You can see several cases of wall 

connection as follows. If the "Search Room" is failed, please check carefully and adjust the walls by dragging the 

grips. 

 

Room area object can not be defined by "Copy", "Move" and "Mirror" command. It has to be defined by "Search 

Room" command. Even if the two rooms are symmetrical, if user copies the room by "Mirror" command, the 

problem of unconnected and malposition may exist. 

 

2.5.2 Room Object Edit 

After the execution of the "Search Room" command, the room object generated in the current drawing is displayed 

as the text object of room area. Users can rename the room as per their needs. User can double click the room 

object to enter the in-place editing mode and directly rename the room. User can also select it and right click 

"Object Editing", and edit the room number and name in the pop up dialog box. After the "Room Hatch" check box is 

checked, user can add hatch to the room. 
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The explanation of the controls in the dialog box: 

 

[Number] the automatic number related to each room, in other major, it is used to mark the room. 

 

[Name] is the name given by the user. It can be selected from the frequently used room name list on the right. The 

room name is related to the room number of the area statistics. When the type is hole, the default name is "Hole". 

Default name of other types are room.  

 

[Slab Thickness] when 3D floor is to be generated, user has to give the slab thickness. 

 

[Type] user can use the list to set the current room object type as "Room Area", "Hole Area", "Shared Area", "Balcony 

Area of Unit". 

 

[3D Floor] after it is checked, the 3D floor would be generated along the room object boundaries. 

 

[Mark Area] after checked this, the area data would be marked on the drawing. 

 

[Area Unit] after it is checked, the area unit would be marked. 

 

[Display Outline] after checked this, the outline of the area scope would be displayed, or else the outline can only 

be displayed by selecting the area object. 

 

[By Half Area] after it is checked, the room area would be calculated as half of the actual area, which applies to the 

room with the clear height less than 2.1m and larger than 1.2 m. 

 

[Hide Background] is used to shield the hatch beneath the room mark with "Wipeout" function. 

 

[Display Number/Display Name] is used to display room number or name in the room object. 

 

[Edit Name...] the button is available when user places the cursor in the name editing box. Then user can click the 

button to enter to the dialog box list to modify or add the name.  
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[Room Hatch] after it is checked, user can add hatch of the current pattern to the room object. The scale, color and 

pattern are selectable. User can click the image box to enter "Pattern Management" interface and select other 

patterns in it as well as select the proper color in the pull down list.  

 

The default name of the room object is "Room".  To simplify the entering of various room names, there are many 

room types and frequently used names related to each type in the object edit dialog box. User can select from it at 

will, and can also further customize more room name. After the user double clicks the room object edit and places 

the cursor in the name edit box, the category and room name list will be displayed in the interface as follows. 

 

Select the room category, for example, we select room here, then the list will show the room names related to room. 

If we select hall instead, then the list will show the names related to the hall. If the category is nether "Hall", "Hole", 

"Room" nor "Toilet", we can select "Others", and we can also click "Edit Name" to enter name list related to the 

current category, and add new room name to it. If users want to add the name alternative name related to each 

category, they can do it via: Settings and Help→Config→Tag Settings. 

 

After the room object is created, the boundary walls usually need modifying as per the design changing of the first 

part. One of the methods is to delete the original room object and search the room local. User can also directly add 

or remove the grips of the original room boundary line. Generally, the latter is more convenient. Room object 

provides the control method of adding and deleting the grips. User has to click the grip and press Ctrl, then drag to 

add one grip. User can also drag the grip and make it coincide with other grip to delete one grip. Take the following 

pictures for example, in order to add flue pipe to toilet, designer has to add two new grips to original room area 

boundary and adjust the location of the boundary line. 
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After the room area object is generated, in the plan, when the column object intersecting with the room is inserted, 

copied or deleted, the related area object would be automatically updated. 

 

2.5.3 Room Property Edit 

In GstarCAD Architecture, room object also provided the property bar editing function, which can modify the 

property of multiple room objects at one time. The method is as follows. 

 

If users want to modify multiple rooms’ name at one time, they can first select multiple room objects whose names 

need to be modified as the same one. Press Ctrl+1 to enter the property bar, then delete the "Multiple" in the text 

box next to "Room Name" and enter the name specified. 

 

In the property bar, the default "Room Type" is room area. User can modify it by selecting the proper room type from 

the pull down list as follows. 

 

 

2.5.4 Room Outline 

Room outline can be described as closed Pline. Room outline can also be converted into floor or regarded as the 

baseboard boundary etc. 

 

Building Design→Room and Roof→Room Outline 

 

After user clicks the command in the menu, the command line will prompt: 

 

Please specify one point in room or [set offset (F), current offset: 0] <Exit>: 

Pick any point in the room. 

 

After the interaction, the room outline would be generated. 

 

2.5.5 Sort Room 

Building Design→Room and Roof→Sort Room 
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After user clicks the command in the menu, the command line will prompt: 

 

Please select room object<Exit>: 

 

Generally, the sorting scope can be frame selected by picking the two opposite corner points. When partition 

number is needed, user can realize it by selection the region or multiple times’ sorting. 

 

Please select room object<Exit>: 

Press enter to complete the selection. 

 

Specify base UCS point<Apply current coordinate system>: 

Specify the origin related to the sorting this time. UCS here is a temporary user coordinates system used for room 

sorting. It has no effect on other command. 

 

First Number<1001>: 

 

The default number when the command is executed the first time. When user continuously executes the command, 

the number would be increased automatically. 

 

Please select room object<Exit>: 

 

After the first sorting, the command would repeat. User can press enter to exit the command. 

 

2.5.6 Area Inquiry 

Building Design→Room and Roof→Area Inquiry 

 

After the user click the command in the menu, the following dialog box will pop up, use can decide whether to 

generate the room object. 

 

 

Example of "Inquire Room Area": 

Click the first icon at the bottom of the dialog box, place the cursor above each room, then the current room area 

scope would be highlighted according to the current selection of area boundary ("Wall Side Line", "Wall Center 

Line" and "Wall Baseline"). If user does not want the room name and number to be displayed, please uncheck the 

"Generate Room Object". In this case, only the area is to be displayed as area mark. The command line would 

prompt. 
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Please pick a point on the screen<Exit>: 

 

When user places the cursor above the, the area would be displayed according to the current selection of area 

boundary. If user wants to mark the room with it, he has to specify a point in the drawing. When the cursor is moved 

to the outside of the plan, the floor area would be displayed. Taking the following pictures for example, they are 

respectively the cases of setting the area boundary as "Wall Center Line" and setting it as "Wall Baseline". 

 

 

Example of "Inquire Closed Curve Area": 

Click the second icon at the bottom of the dialog box. The command line will prompt: 

 

Select closed polyline, circle, or hatch pattern<Exit>: 

 

Here user can select the closed polyline, circle or hatch which represents area, then the area would be displayed at 

the location of the cursor, and the command line will prompt: 

 

Please pick the position for area dimension <Center>: 

 

Here user can press enter to add the area mark to the middle of the closed polyline. 

 

 



Chapter 2 Function of Architectural Design 

123 

 

 

 

 

Example of "Inquire Balcony Area": 

The command line would prompt: 

 

Select Balcony<Exit>: 

 

Here select the GstarCAD Architecture balcony object. Then the balcony area would be displayed at the location of 

the cursor. The command line will prompt: 

 

Please pick the position for area dimension <Center>: 

Here user can specify the point where the area mark is to be inserted. User can also press enter to add the area mark 

at the center of the balcony as shown in the following picture.  

 

In GstarCAD Architecture, The area of the balcony is calculated as half of the actual area of it by default. User can 

decide whether to calculate it in this way by setting the related parameter in "Edit Room" dialog box. 

 

Example of "Inquire Wall Outline Area": 

Please be noted that if area boundary is set as "Wall Side Line", the boundary of the frame selected area is the outer 

side of the wall, the command line will prompt: 

 

Select Wall<Exit>: 

 

Select the wall object and press enter to complete the selection. The highlighted preview box will be displayed as 

follows. 
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At this time user can modify the area boundary type. Then the related preview would be displayed immediately. The 

command line will prompt: 

 

Please pick the position for area dimension <Center>: 

User can press enter to add the area mark at the center of the wall side. 

 

Inquire of Polygon Area. The command line will prompt: 

 

Start point of Polygon<Exit>: 

Pick the first corner point of the polygon which needs area inquiry. 

 

Next point of line segment or [A-arc segment/Undo] <End>: 

Pick the second corner point of the polygon which needs area inquiry. 

 

Next point of line segment or [A-arc segment/Undo] <End>: 

Pick the third corner point of the polygon which needs area inquiry. 

 

Next point of line segment or [A-arc segment/Undo] <End>: 

Press enter to make the polygon closed. 

 

Please pick the position for area dimension <Center>: 

User can specify the insert point for the area dimension and create the polygon area object. 

 

Note: If the balcony plane is irregular, and user cannot use GstarCAD Architecture balcony object directly created 

the balcony area, user can use this command to create polygon area, and then edit it as Balcony Area of unit. 

 

2.5.7 Unit Usable Area 

Building Design→Room and Roof→Unit Usable Area 

 

After the user clicks the command in the menu, the following dialog box will be displayed.  

 

Enter the "Unit Type Number" and the "Household Number" in the "Unit Usable Area" dialog box. The former is the 

category of the unit types, the same unit type number can be repeated in different floor (unit) even if the area of 

them may be different. "Household Number" is the unique number which is used to distinguish the household. Then 

move the cursor in the drawing to respond the prompt in the command line. 
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Please select all room objects and balcony objects belonging to the same unit：Select the objects one by one or 

frame select area objects of each room belonging to unit 1-A. 

 

Please pick the position for area dimension <Center>: 

 

Press enter or specify the proper insert point of the dimension of "Unit Type No." and the area. 

 

 

2.5.8 Shared Area 

Building Design→Room and Roof→Shared Area 

 

Click the command in the menu. The command line will prompt: 

 

Please select room area object <Exit>: 

Select the existing room object.  

 

Please select room area object <Exit>: 

Select other room objects or press enter to complete the selection. 

 

Specify share type [A-shared by this floor/B-shared by whole building] <A>: 

If user wants to these room areas to be shared by the whole building, please enter B. 

 

The command will classify these areas into A-AREA-SHAR layer, and mark the rooms as "Shared by Whole 

Building" for the further area statistic. 
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2.5.9 Area Calculation 

Building Design→Room and Roof→Area Calculation 

 

Click the command in the menu. The dialog box will be displayed as follows: 

 

Meanwhile, the command line will prompt: 

 

Please select room area object, balcony, closed polyline, hatch pattern, or area’s text: 

Specify the first point for the frame selection. 

 

Please select room area object, balcony, closed polyline, hatch pattern, or area’s text: 

Specify the opposite point for the frame selection. 

 

Please select room area object, balcony, closed polyline, hatch pattern, or area’s text: press enter to input the 

selected content into the dialog box. 
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User can click the button, such as "+", "-", to do the calculation.  

Press "Enter", then the command line will prompt: 

 

Please specify area dimension position or [select area object(S)] <Exit>: 

 

Specify the position where the area calculation result is to be inserted. The progress would mark the drawing with 

the calculation result. Or press S to continue. 

 

If you want to output the calculation formula, please edit the formula in the edit box and delete the useless 

parentheses etc. Then click the button on the right of the edit box, the command line will prompt: 

 

Dimension position<Return>: 

 

Specify the position where the area calculation result dimension is to be inserted. The progress would mark the 

drawing with the formula and the result as follows: 

 

 

 

2.5.10 Area Statistic 

Building Design→Room and Roof→Area Statistic 

 

Click the command in the menu. The command line will prompt: 

 

Please select calculation types [A-area calculation of typical floor/B-project area calculation] <A>: A  

 

(If user wants to calculate area of project constructed of multiple floors, please enter B here) Press A to calculate 

the area of the current floor, the dialog box will be displayed as follows:   

 

The first table "Floor Area Schedule" is rationally calculated by relation of room usable area and shared area. User 

can preview the result on the screen or click "Mark in Drawing<" button to mark table on the drawing. Then the 

command line will prompt: 
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The second table "Unit Type Statistic Schedule" is rationally calculated by relation of room usable area and shared 

area. User can follow the same steps as the above to insert the table in the drawing.   

 

The third table "Unit Type Analytic Schedule" is rationally calculated by relation of room usable area and shared area. 

User can follow the same steps as the above to insert the table in the drawing. 

 

If user did not execute "Unit Usable Area" command to assign the room in advance, the program will prompt "Failed 

to Find Room Assigned or Invalid" and exit the command. 

 

2.5.11 Baseboard 

Building Design→Room and Roof→Room Layout→Baseboard 

 

After click the command in the menu, the dialog box would be displayed as follows: 

 

The explanations of the controls in the dialog box: 
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[Take from Section Library] After clicking the radio button "Take from Section Library", user can enter the baseboard 

section library. Double click the section pattern in the preview area on the right. 

 

 

[Pick Curves in the Drawing] after the user clicks this radio button, the command line will prompt: 

 

[Rectangle] the section of the baseboard is rectangle. 

 

[Section Size] refers to baseboard section height and thickness. Progress will regard the actual size of the section 

selected by the user as the default baseboard section size, which can be further modified by the user.  

 

[Connect Baseboard of adjacent Rooms at Door Opening] when it is checked, the baseboard would be connected at 

the door opening of the adjacent rooms. 

 

Enter proper size and pattern of the baseboard in the dialog box, the command line will prompt: 

 

Please pick rooms<Exit>: 

 

Move the cursor on the room to which the baseboard is to be added. The command will let the user preview the 

baseboard scope. Then please click the area of the proper room. 

 

Please pick rooms<Finish>: 

 

Go on adding the baseboard. 

 

Please pick rooms<Finish>: 
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Press enter to finish adding the baseboard, if user has checked "Connect Baseboard of Adjacent Rooms at Door 

Opening", the command line will show the following prompts: 

 

Please select door/hole needed to add baseboard<Exit> 

 

Select the door between the rooms or frame select the door opening. 

 

Please select door/hole needed to add baseboard<Exit> 

 

Press enter to complete the selection. The drawing of the baseboard is finished as follows: 

 

 

2.5.12 Arrange Sanitary Ware 

Building Design→Room and Roof→Room Layout→Arrange Sanitary Ware 

 

Click the command in the menu. The "Sanitary Ware Library" will be displayed. 

 

Simple explanation of the "Sanitary Ware Library": 

 

[Sanitary Ware Category Menu] display the category tree of the Sanitary Ware Library. 
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[Sanitary Ware Name List] display the drawing block name under the current category in the Sanitary Ware Library. 

 

[Sanitary Ware Drawing block Preview] display all the sanitary ware drawing block preview in the current library. 

 

System will give the proper layout method according to the type of the sanitary ware selected by the user. Double 

click the sanitary ware which needs layout in the preview box. User can arrange the sanitary ware in the drawing as 

per the pop up dialog box and command line. Classified according to the layout method, the list of sanitary ware 

layout operation method is as follows: 

 

Example of Using "Wash Basin", "Toilets &Urinal", "Shower Head", "Washtub and Mop Tub": 

 

Double click the sanitary ware which needs layout in the "Sanitary Ware Library", the related dialog box will pop up 

as follows: 

 

[Initial] if side walls and back wall are of the same material, it is the distance between the first sanitary ware 

inserting point and the wall corner point. 

 

[Spacing] the distance between the insert points of the multiple sanitary ware inserted. 

 

[From Wall] seat bedpan will be arranged against the wall, the value for "From Wall" is 0.  In the case of squatting 

pan, the default value for "From Wall" is 200.  
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Click the icon "Place along The Wall Inside". If the back wall is brick wall, and the side wall is hatch wall, the 

command interaction is as follows: 

 

Please select border line alone the wall <Exit>: 

On the inside of the sanitary ware back wall, pick a point near the end of initial distance. 

 

Insert the first toilet ware [B-inserting base point] <Exit>: 

 

Give a point near the position where the first sanitary ware is to be inserted. Then the user has to enter B to define 

the corner point as the base point, or else the initial distance will be shorted wrongly. If the walls related are all of 

the same material, the base point can be correctly and automatically obtained, thus user does not have to enter B to 

define it.   

 

Next one <End>: 

Take point near the position where the other sanitary ware is to be added. 

 

Next one <End>: 

 

After inserting all the necessary sanitary wares, please press enter to complete the interaction. Then the command 

will finish drawing the sanitary wares. The related parameter and the effect drawing are as follows: 

 

Clicked the icon "Place along The Existing Toilet Ware", the command interaction is as follows: 

 

Please select existing toilet ware <End>: 

Select the last sanitary ware starting from which you want to go on inserting sanitary wares. 

 

Next one <End>: 

 

Take point near the position where the other sanitary ware is to be added. 

 

Next one <End>: 

 

After inserting all the necessary sanitary wares, please press enter to complete the interaction. Then the command 

will finish drawing the sanitary wares. 

 

Click the icon "Uniform Layout", in this case, the parameters "Spacing" and "Initial" are still available. Two rules can 

be selected here: "Divide" (arrange according to the quantity of the sanitary wares) and "Measure" (arrange 

according to the distance between the adjacent sanitary wares). 

 

Clicked the icon "Uniform Layout" and "Divide", the command interaction is as follows: 

 

Please select the wall for arranging Sanitary Ware on the starting side or [Uniformly Distributed between two points 

(D)] <Exit>: 
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Click the "Initial Distance" side of wall. If there are Openings in the wall, please enter D and define the distance by 

two points. 

 

Please specify how many toilet wares to insert, current number of toilet ware<4>: 

 

Press enter to accept the default value or enter other value. Then the command will figure out the distance between 

the sanitary wares. 

 

Enter New Spacing, Current Spacing<1080>:1000  

 

Usually the user has to change the spacing value to integer, e.g. Enter 1000 here and press enter to finish the 

drawing. 

 

Click the icon "Uniform Layout" and "Measure", the command interaction is as follows: 

 

Please select the wall for arranging Sanitary Ware on the starting side or [Uniformly Distributed between two points 

(D)] <Exit>: 

 

Click the "Initial Distance" side of wall. If there are Openings in the wall, please enter D and define the distance by 

two points. 

 

Enter New Spacing, Current Spacing<991>:950  

 

Usually the user has to change the spacing value to integer, e.g. Enter 950 here and press enter to finish the 

drawing. 

 

 

Example of Using "Desktop Wash Basin": 
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Click the "Desktop Wash Basin" which needs layout in the sanitary ware library, the pop up dialog box is same as 

that of the common wash basin. The difference is common wash basin is Column Basin or Hanging Basin, and the 

desktop need not to be drawn. 

 

Click the "Place along The Wall Inside" icon. The command interaction is as follows: 

 

Please select border line alone the wall <Exit>: 

 

On the inside of the sanitary ware back wall, pick a point near the end of initial distance. 

 

Insert the first toilet ware [B-inserting base point] <Exit>: 

 

Give a point near the position where the first sanitary ware is to be inserted. Define the base point as the examples 

above if necessary. 

 

Next one <End>: 

 

Take point near the position where the other sanitary ware is to be added. 

 

Next one <End>: 

 

After inserting all the necessary sanitary wares, please press enter. Then the command line goes on prompting: 

 

Table Width<550.0>: 

 

Enter the table width in the command line. Then the table outline will be drawn as per the table width entered. 

 

Example of Using "Bathtub", "Washtub" and "Mop Tub": 

 

Select the bathtub in the sanitary ware library and double click the style you want, the pop up dialog box will be 

displayed as follows: 
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Select the bathtub size in the right size list, or enter other size. 

 

The command interaction is as follows: 

Please select a line to place toilet wares: 

 

Picking position or [A-rotate 90 degree/flip vertical/D-flip horizontal/F-align/R-change Angle/T-change base 

point/Q-reference point] <Exit>: 

 

Please select a line to place toilet wares: 

 

Example of Using "Trough Urinal": 

Find the category of urinal in the sanitary ware library and double click the sanitary drawing block, the dialog box will 

be displayed as follows: 

 

Enter appropriate parameter in the dialog box. The command interaction will be as follows: 

 

Specify internal endpoint in trough urinal [Flip (F)] <Exit>: 

 

Pick P1 on the inside of the wall where the trough urinal is to be installed. 

 

Specify internal endpoint in trough urinal [Flip (F)] <Exit>: 

 

Specify the end point (P2) of the trough urinal, or determine the direction with the cursor and enter the length of the 

trough urinal.  

 

User can preview the trough urinal direction throughout the drawing process. If the direction is incorrect, please 

enter F to flip it. The result is as follows:  
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Example of Using "Wash Trough": 

Find the category of wash trough in the sanitary ware library and double click the wash trough drawing block, the 

dialog box will be displayed as follows: 

 

Enter appropriate parameter. Then the command interaction will be as follows. 

 

Specify internal start point of wash trough [Reference point] <Exit>: 

 

Directly give the point P1 or enter R to use the reference point. 

 

Specify internal endpoint of wash trough [Flip (F)] <Exit>: 

 

Give the end point of the wash trough, or determine the direction with the cursor and enter the length of the trough 

urinal.  

 

User can dynamically preview the wash trough direction throughout the drawing process as shown in the left picture 

below. If the direction is incorrect, please enter F to flip it. The tap quantity will be automatically increased and 

aligned center with the extension of the wash trough length, the result is as shown in the right picture below. 

 

 

2.5.13 Sanitary Partition 

Building Design→Room and Roof→Room Layout→Sanitary Partition 

 

After click the command, the following dialog box will be displayed. The check box "With Partition Door" is checked 

in default, in this case, the customized sanitary partition would be inserted. If it is not checked, Trough Urinal 

partition will be inserted.  

 

Enter the parameter for "Partition Length" and "Partition Door Width", the command line will prompt: 

 



Chapter 2 Function of Architectural Design 

137 

 

Please use two points to select toilet ware. 

 

Start point<Exit>: 

 

Pick the point outside the toilet near the wall. 

 

End Point<Exit>: 

 

Pick the point on the other side of the row of toilet ware to which the partition is to be added. 

 

X toilet wares already selected.  As shown in the following picture, 4 toilet () ware is selected. 

 

The result of the command execution is generating the toilet whose width is equal to distance between the toilet 

ware as shown in the picture. User can modify the door by the command: "Flip In/Out", "Threshold Line" etc. 

 

2.5.14 Grid Hatch 

Building Design→Room and Roof→Room Layout→Grid Hatch 

 

Click the command in the menu. If there is no closed polyline in which the grid hatch is to be added, the command 

line will prompt: 

 

If the condition is satisfied, the following Grid Hatch dialog box will be displayed. 

 

Explanation of the "Grid Hatch": 

Controls Functions 

Double 

Direction 

Divide 

When it is checked, the hatch will be added in both direction as per the given angle and angle 

perpendicular to it. 
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Grid Spacing 

It is the given grid hatch distance, which can be selected from the frequently used data in the pull 

down list. When "Double Direction Divide" is checked, the distances between hatch grids on both 

directions are equal, in other words, the square grids will be added. 

Boundary 

It is an edge with given width in the grid hatch boundary. The width throughout the edge is equal, 

which can also be adjusted by the grips. 

Boundary 

Width 

Give boundary width in the grid hatch boundary. 

Display 

Boundary 

 

Angle 

The hatch angle of the grids. The frequently used angles include: 0,10,15,30,45,60,90. The angle is 

calculated from the x direction of current user coordinates. 

Base point 

Location< 

Is used to specify the alignment point position of the currently used pattern. 

Equally Divide 

Line Segment 

 

Equal Divided  

Divide Line 

Segment< 

 

Select 

Boundary 

One of the important operations. It is used to select the closed lines or closed walls which are used 

for hatch boundary definition.  And add the hatch according to the current parameters. 

Pick Point 

One of the important operations. It is used to select one point in the closed line or closed walls. 

Then the program would search for the hatch boundary around it and display the hatch preview.  

Enter appropriate parameter in the dialog box. Then command line will prompt: 

 

Please select the object boundary to divide or [Pick one point in object region for dividing (P)] <Exit>: 

 

Select closed polyline object used for division. 

 

If the above operation can be successfully completed, the dividing pattern defined in the dialog box will appear in 

the drawing immediately. Click to confirm.  If the given condition can not satisfy the requirement of the command, 

the command line will prompt as follows: 

 

Selection is invalid, please select again! Go on selecting the closed object or press enter to exit the command. 

 

Enter p in the command line or click the "Pick Point" icon in the dialog box, user is required to select one point in 

the region to divide, the command line prompts: 

 

Select one point in the region to divide or [select boundary of region to divide(S)] <Exit>: 

 

Select one point in the closed object. 

 

If the above operation can be successfully completed, the dividing pattern defined in the dialog box will appear in 

the drawing immediately. Click to confirm.  If the given condition can not satisfy the requirement of the command, 

the command line will prompt as follows: 
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Example of "Change Position of Hatch Base Point": 

User can not only modify the grid spacing, angle, hatch direction, but also can modify the base point location. After 

the user clicks the "Base Point Location<" button, the command interaction will be as follows: 

 

Please select alignment point in hatched region [Reference point(R)]: give the new position of the alignment point 

on the drawing to change the base point (alignment point, start point) of the grid hatch.  
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2.5.15 Search Roof Outline 

Building Design→Room and Roof→Search Roof Outline 

 

Click the command, the command line will prompt: 

 

Please select all walls (or win-doors) of a complete building<Exit>: 

 

Select all the walls of the same building in order to enable the program to automatically find the outline of the 

building. 

 

Please select all walls (or win-doors) of a complete building<Exit>: 

 

Press enter to complete the selection. 

 

Please enter distance offset outside wall<600>: 

 

Enter the distance offset outside the wall or press enter to use the default value. 

 

2.5.16 Rectangular Roof 

Building Design→Room and Roof→Rectangular Roof 

 

After the user clicks the command in the menu, the following dialog box will be displayed. There are four roof types 

which can be selected. 

 

 

After determine all the parameter of type and size, drag the roof in the drawing area to specify the location, size and 

initial angle of it. The dialog box does not need to be closed. The command line will prompt as follows: 

 

Select lower left point of main slope outside the external wall<Exit>: 

 

Pick the corner point of the rectangle wall long side. 

 

Select lower right point of main slope outside the external wall<Back>: 

 

Pick the other point of the rectangle wall long side. 

 

Select upper right point of main slope outside the external wall<Back>: 
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Pick the corner point of the rectangle wall short side adjacent to the second point selected. 

 

The roof height of the rectangle roof is calculated from the position of the base point to the position of the ridge 

elevation. (Eave board thickness is not included.) The following pictures are examples of "Rectangular Roof". 

 

The explanation of the controls in the dialog box: 

 

[Type] there are four roof types: "Gable and Hip Roof", "Hip Roof", "Double Slope Roof" and "Pyramid Roof". 

 

[Roof Height] the height from the inserting base point to the ridge. 

 

[Base point Elevation] the roof is regarded as an individual floor by default. The base point is located at the roof 

covering with the elevation of 0 by default. When the roof is placed on the wall top of its downstairs, the base point 

elevation should be equal to the height of the wall plus the thickness of the eaves board.  

 

[Eave Length] the distance from the eave to the outside of the wall. 

 

[Gable and Hip Height] it is the height of the vertical part on the sides of Gable and Hip Roof. When the value for it 

is 0, the roof type is changed to "Hip Roof". 

 

[Side Slope Angle] the angle between the horizontal and the slope located at the short side of the rectangle. The 

angle is subject to the roof height. Thus when the roof height is fixed, the side slope angle has a certain value range. 

 

[Gable Length] the extension length of the roof in the direction of double slope roof short side. 

 

[Thickness of Eave board] this is the thickness of the roof eave board which is calculated upward. This default value 

is 200. User can modify it in the property bar. 

 

[Ridge Length] the length of it is calculated by the side slope angle. User can modify it in the property bar. 

 

The object edit of the rectangle roof. Double click the rectangle roof object. Then the dialog box similar to the above 

will pop up. User can modify the related parameter in it and click OK to update the roof. User can also drag the grips 

to edit the roof. 
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2.5.17 Poly Roof 

Building Design→Room and Roof→Poly Roof 

 

Click the command in the menu. The command line will prompt: 

 

Select a closed polyline<Exit>: 

Pick the roof line. 

 

Please enter slope angle or [Height (H)] <30>: 

Enter the slope angle. 

 

Eave Length<600>: 

Enter the eave length if there’s eave. It should be equal to the offset entered during roof search. It is used for 

determination of the elevation. 

 

Then the four slope roof with equal slope angle is generated. User can modify it by the grip or dialog box method. 

There are two types of roof grips. One of them is vertex grip, another is side grip. User can drag the grips to modify 

the shape of the roof plane, but slope angle can not be modified in this way. 
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Double click the slope roof to enter the object edit dialog box. User can modify the slope angle of each slope.  

Click the button in front of the row, a red mark will be displayed on the related side line in the drawing. User can 

modify the parameter of the slope angle. User can modify the slope parameter in the edit dialog box. If set the slope 

angle of the end slope as 90 (no slope), the roof will be changed into double-slope roof. After the modification, 

click the apply button, user can immediately preview the change of the roof. The "Bottom Elevation" is the vertex 

elevation of pline which generates the slope roof. Because of the eave extension, the elevation of them is lower than 

the relative elevation of its floor. 

 

2.5.18 Double Slope Roof 

Building Design→Room and Roof→Double Slope Roof 

 

Click the command in the menu, the command line will prompt: 

 

Please select a closed polyline<Exit>: 

Select the polyline which is to be regarded as the slope room boundary. 

 

Please enter start point of ridge line<Exit>:  

Pick a point on one side of the roof boundary as the start point of the ridge line. 

 

Please enter end point of ridge line<Exit>: 

Pick a point on the opposite side of the roof boundary as the end of the ridge line. 

 

The "Double Slope Roof" dialog box will pop up. Set the parameter in it as follows: 

 

After entering all the necessary parameters please click enter, then the double slope roof is generated immediately. 

The set rule of the parameter is as follows: 

 

If the roof height is know, check the check box "Limiting Height" and enter the height value or enter the known slope 

angle and the ridge elevation (or click "Elevation Reference to Top of Wall<" to select the related wall in the 

drawing ), click "OK" to generate slope roof. 
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The explanation of the controls in the dialog box: 

 

[Left Slope Angle/ Right Slope Angle] enter the slop angle in each text boxes. No matter the ridge line is aligned 

center or not, the default Left Slope Angle and the Right Slope Angle are equal. 

 

[Limiting Height] check the checkbox to define the roof with the height instead of the slope angle. If the edge line is 

not aligned center, the left slope angle is not equal to the right slope angle. 

 

[Height] after checking the check box "Limiting Height", enter slope roof height here. 

 

[Ridge Elevation] ridge height calculated from z=0 in the drawing.  

 

[Elevation Reference to Top of Wall<]  

 

[Image box on the right] the 3D preview drawing will be displayed in it. User can rotate the roof by dragging the 

cursor, zoom it with the mouse scroll and pan it with the middle mouse button. 

 

User can modify the position of the Double Slope Roof by dragging the grips on its sides and ridge.  User can also 

double click the roof object to enter the dialog box and modify the roof slope. 

 

2.5.19 Pyramid Roof 

Building Design→Room and Roof→Pyramid Roof 

 

Click the command in the menu. The following dialog box will prompt: 

 

After determine all the parameter of type and size, drag the roof in the drawing area to specify the location, size and 

initial angle of it. The dialog box does not need to be closed. The command line will prompt as follows: 

 

Please enter position of roof center<Exit>: 

Pick the center point of the roof. 

 

Get the Second Point: drag the cursor, and get the intersection between the roof and the column (define the circle of 

the polygon). 

 

The explanation of the controls in the dialog box: 

 

[Roof Height] the height of Pyramid Roof. 

 

[Side Number] the index of the side of regular polygon roof. 
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[Eave Length]  

 

[Base point Elevation] the elevation of upper side of the roof connected to the wall. The Base point Elevation is 0 by 

default. 

 

[Radius] radius of roof polygon’s circumscribed circle. 

 

 

2.5.20 Dormer 

Building Design→Room and Roof→Dormer 

 

After the user clicks the command, the command line will prompt: 

 

Please select roof: select the existing roof to enter "Add Dormer" dialog box. 

 

The explanation of the controls in the dialog box: 

 

[Type] the types include: Triangle Slope, Double Slope, Three Slope, Trapezoid Slope and Flat-top Window as 

shown in the picture. 

 

[Tag] user can add Tag on the Dormer automatically according to the width and height of the window. The tag can 

be specified by user, too. 
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[Window Height/ Window Width] is the height and the width of the small window on the dormer. 

 

[Wall Width/ Wall Height] the width of the wall is on the front of the dormer. The height of the wall is on the side of 

the dormer. 

 

[Top Slope Height/ Slope] the slope roof height and slope angle of the dormer. 

 

[Display Tag] if the check box is checked, the tag will be displayed on the drawing. 

 

Clicking "OK" to close the dialog box, the plan of the dormer will be displayed for preview. Then the command line 

will go on prompt:  

 

On the slope Roof, drag the dormer to the insert position, in the opposite direction of the slope, the dormer would 

change its direction accordingly automatically. 

Please specify insertion position or [modify parameter(S)] <Exit>: 

 

Please specify insertion position or [modify parameter(S)] <Exit>: 

On the slope Roof, drag the dormer to the insert position, and press enter to exit. If user want to modify the 

parameter in the dialog box, please enter S here. 

 

Then the dormer with specified pattern is inserted on the roof. User can double click the dormer to enter the object 

edit and modify the related parameter in the dialog box. 

 

2.5.21 Rain Pipe 

Building Design→Room and Roof→Rain Pipe 

 

Click the command. The command line will prompt: 

 

Please specify inlet start point [Reference point/Diameter/Width] <Exit>: 

Specify the start point of the rain pipe. 
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Please specify outlet point [Diameter/Width] <Exit>: 

Specify the end point of the rain pipe. 

 

The command soon finished the drawing of the rain pipe as per the related regulation.  

Example of "Rain Pipe": 

 

User can enter D in the related command line to change the diameter of the rain pipe, or enter W to change the 

width of the rain pipe, or enter R to give the reference point of rain pipe start point. 

 

2.5.22 Drainage Slope Line 

Building Design→Room and Roof→Drainage Slope line 

 

Click the command. The following dialog box will be displayed.  

 

The explanations of the dialog box: 

[Catchment Line Drainage Slope Line] click the radio button to show the dialog box controls related to Catchment 

Line. 

 

[Divide Line Drainage Slope Line] click the radio button to show the dialog box controls related to Divide Line. 

 

[Length] is the length of the arrow from the start point to the end point. It is subject the arrow length in the final 

drawing. 
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[Styles] with regard to Catchment Line, there are two arrow styles available: half arrow and arrow.  Divide Line only 

has one arrow style: arrow. 

 

[Direction:] divide Line slope arrow has two directions: outward and inward. 

 

[Distance from Divide Line] refers to the distance between the first point or the end point of the arrow and the divide 

Line, which is subject to the length on the final drawing. 

 

[Draw Divide Line] checking the check box means drawing the divide Line and mark the slope arrow, or else only 

the slope arrow will be marked.  

 

[Angle] click the radio button. Specify the angle between the catchment Line and the eaves. If the radio button "One 

Side" is clicked, the default angle here would be 22.5 degree. 

 

[Slope Height] click the radio button. Specify the slope height in the dialog box. 

 

[Slope] checking it means marking the slope line with the slope, or else only the arrow dimension would be added. 

The content in the pull down list is 1, 2, 2.5, 3. 

 

[One Side/ Both Sides] the radio button is used to switch the one side and both sides of Catchment Line. 

 

[Text Height] refers to the text height of the slope dimension. 

 

[Text Style] refers to the text style of the slope dimension. 

 

Click "Catchment Line Drainage Slope Line" radio button and click angle radio button. Select the default value 22.5. 

Click "One Side" radio button to complete the dialog box parameter setting, the command line will prompt: 

 

Please specify the start point of drainage slope line<Exit>: 

Specify the start point for drawing the drainage slope Line. When draw it along the roof plane eave please use "One 

Side". When draw it from the ridge please enter D to use "Both Sides" 

 

Please specify the next point of drainage slope line or [end at middle Point (J)] <Exit>: 

Draw drainage slope line along the eave. Give one point P2 at the end of the slop line. 

 

Please specify the next point of drainage slope line or [end at middle Point (J)] <Exit>: 

Draw another drainage slope line along the eave. Give one point P3 at the end of the slop line. 

 

Please specify the next point of drainage slope line or [end at middle Point (J)] <Exit>: 

At the end of the slope line, give point P4 beyond the outside of the eave to draw the last segment of drainage slope 

line. 

Please specify the next point of drainage slope line or [end at middle Point (J)] <Exit>: 

Enter J to change to "End at Middle Point" mode. 
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Current mode: cut in the middle. 

 

Example of "Catchment Line – One Side": 

 

 

Example of "Catchment Line – Both Sides": 

 

 

Example of "Catchment Line – One Side – Slope Height": 

 

 

Example of "Divide Line – Both Sides": 

 

 

Example of "Divide Line – one Side": 
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2.6 Stair and Others 

2.6.1 Straight Stair 

Building Design→Stair and Others→Straight Stair 

 

 

Controls Functions 

Stair 

Width< 

The button is used to pick two points in the drawing in order to obtain the stair width. 

Start 

Height: 

The stair start height is calculated from the current floor. The stair height should be calculated 

from the start height. 

Stair 

Length: 

Straight stair’s tread width * riser height=stair length of plane projection. 

Stair Height: 

It refers to the total height of the Straight Stair. It equals to the sum of the riser height. If the stair 

height is changed, the program will adjust the step number according to the current riser height, 

and then it will calculate the rise height according to the new step number. 

Riser 

Height: 

Enter a rough riser height initial values, the program will calculate a design value closet to the 

initial value according to the stair height. As the step number is integer, and the stair height is a 

given integer, the riser height is not always integer. After the user give a rough value of it, the 

program will determine its accurate value via calculation. 

Step 

Number: 

This value for it can be entered directly or by stepping adjusting. It is calculated and rounded 

according to stair height and rough riser height, meanwhile, the riser height is modified. User can 

also change the step number, and the riser height will be calculated according to the step number 

as well as the stair height. 

Tread 

Width: 

The width of stair’s each tread. 

3D/2D 

Require 

3D/2D 

It is used to control the 2D and 3D preview of the stair. Some of the stairs only need 2D preview, 

and some of them only need 3D preview.  

Cutline 

Setting 

It concludes "No Cutline", "Down Cutline", "Double Cutline" and "Up Cutline". 

As Ramp 

If this check box is checked, the steps will be regarded as the distances of the anti slip strip, the 

stair will be generated as the ramp. There are related check boxes of "Strips Hatch" and "Floor 

Stand". 
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There are pop up prompts at the position of the blue words in the dialog box, user can browse it by put the cursor 

on the blue words. 

 

After the user enters necessary parameter in the dialog box and moves the cursor to the drawing area, the command 

line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Specify the insert position of the stair and rotate the stair if necessary. 

 

The straight stair is customized component object, thus it has the property of grips edit. User can also reset the 

parameter by object edit. 

 

The explanation of the stair grips function: 

 

[Modify width of flight] the stair is highlighted after being selected. User can select the middle grips on both sides 

and drag them to modify the stair width. 

 

[Move Flight] the grips at four corner points of the stair are used to move the stair. User can click any one of the 

four points and move the stair. The selected grip is regarded as the base point for the stair moving.  

 

[Change Cutting Location] on the stair with cutline, there are two grips on both ends of the cutline used for 

changing the cutline position. User can drag the grips to change the angle and position of the cutline. 

 

Note 

1. If user wants to generate the stair as the ramp, density of the anti slip strip is related to the steps number of the 

stair. Thus the steps number should be well selected in advance.  

2. User can give the stair length as the ramp length, but it would be changed a little by step number and tread width. 

 

Example of "Straight Stair": 
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2.6.2 Spiral Stair 

Building Design→Stair and Others→Spiral Stair 

 

After the user clicks the command in the menu, the dialog box shows: 

 

After entering the stair parameter in the dialog box, the user can determine whether the stair parameter entered can 

meet the requirement according to the dynamic preview window on the right of the dialog box. The options in the 

dialog box are similar to that of the straight stair. User can refer to the related description of the last section. 

 

After the user enters necessary parameter in the dialog box and moves the cursor to the drawing area, the command 

line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Specify the insert position of the stair and rotate the stair if necessary in order to insert the Spiral Stair. 

 

Spiral Stair is customized object. User can edit it by dragging the grips. The meaning of the grips is as follows. User 

can also double click the stair to enter object edit interface and reset the parameter. 

 

The explanation of the stair grips’ function 

 

[Change Inner Diameter] the stair will be highlighted after be selected, meanwhile, the seven grips will be displayed. 

If there is cutline in the Spiral Stair, there will be two more grips on both ends of the cutline. The grip at the middle 

of the stair’s inner circle is used to modify the inner circle radius. User can select the grip and drag the stair’s inner 

circle to modify its radius. 

 

[Change External Diameter] the grip at the middle of the stair’s ex-circle is used to modify the ex-circle radius. User 

can select the grip and drag the stair’s ex-circle to modify its radius. 

 

[Change Cutting Location] user can drag the grips to move the cutline of the Spiral Stair. 

 

[Move Flight] user can drag any one of the five points to move the stair. The selected grip is regarded as the base 

point for the stair moving. 
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2.6.3 Curve Stair 

Building Design→Stair and Others→Curve Stair 

 

After the user click the command in the menu, the command line will prompt: 

 

Please select left side line of flight (LINE/ARC) <Exit>: 

Select one line. 

 

Please select right side line of flight (LINE/ARC) <Exit>: 

Select the other line. 

 

After the above selection, the "Custom Stair" dialog box will be displayed as followed. The options in it are almost 

the same with that of the straight stair. 

 

After the user enters the necessary parameters and click OK, the stair with two specified lines as the side lines will 

be drawn. 
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Curve Stair is customized object. User can edit it by dragging the grips. The meaning of the grips is as follows. User 

can also double click the stair to enter object edit interface and reset the parameter. 

 

The explanation of the stair grips function: 

 

[Modify start point] the grip at the start point is used to control the start point of the stair side where the selected 

point is on. User can modify the length of the stair by modifying the start point on both sides. 

 

[Modify end point] the grip at the end point is used to control the end point of the stair side where the selected 

point is on. User can modify the length of the stair by modifying the end point on both sides. 

 

[Modify Arc/move sideline] the grip at the middle of the stair is used to control the stair width or arc radius. The 

exact function depends on the type of the side line. 

 

 

2.6.4 U-Shaped Stairs 

Building Design→Stair and Others→U-Shaped Stairs 

 

After the user clicks the command in the menu, the default folding dialog box will be displayed as follows. 

 

Click "Other" to expand the content folded as follows. 
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The explanation of the controls in the dialog box: 

Controls Functions 

Staircase 

Width< 

This is the total width of the U-shaped stair. User can click it and directly measure the staircase’s 

clear width from the plan and regard it as the total width of the U-shaped stairs. 

Flight 

Width< 

flight width initial value= （staircase width- Stair well width）/2 

User can click it and measure from the plan and regard it as the value of flight width. 

Stair Height: 

Refers to the total height of the U-Shaped Stairs. The value for it equals to the height of the current 

floor by default. User can further modify it according to the actual condition. 

Stair Well 

Width: 

Stair well width=staircase width-(2*flight width), the minimum well width can be set as 0. The 

above mentioned three numbers are interrelated. 

Sum of Steps: The default value of it is 20. It is a key parameter of the u-shaped stair. 

Steps of First 

Flight: 

The steps of first flight and the steps of second flight are calculated from sum of steps. If the sum of 

steps is odd number, the steps of second flight will be increased firstly. 

Steps of 

Second 

Flight: 

The steps of second flight equals to the steps of first flight by default. Both of them allow the user to 

modify. 

Riser Height: 

Enter a rough riser height initial value, and then the program will calculate a design value closet to 

the initial value according to the stair height and sum of the steps. 

Tread Width: 

This is the tread width in the stair direction. It is the parameter which the user has to determine in 

advance. However, after the check box "As Ramp" is checked, the value of tread width is used to 

calculate the strips width. 

Landing 

It has three options: "Rectangle", "Arc" and "None". If users want to customize the landing by 

themselves. These could be selected "None" here. 

Width of 

Landing: 

As per the specification of construction design, Landing depth should be larger than flight width. 

When selecting arc landing, user has to modify the value of the landing width, the minimum value 

of which should not be 0. 

Step Align 

Type 

When steps of the first flight does not equal to steps of the second flight, user can set the relative 

position of two stairs as "Aligned to Landing", "Center" or "Aligned to Floor". User can also adjust 

the relative position of two stairs at will by dragging the grips, in this case, the align type is "Free". 
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Floor Type 

The method of stair cutline drawing can be classified into 3 types according to the floor where the 

stair is: 1 With regard to the stair on the first floor, only the down cutline of the first flight will be 

drawn. 2 With regard to the stair on the middle floor, double cutline on the first flight will be drawn. 

3 With regard to the stair on the top floor, no cutline will be drawn on the first flight.  

Handrail 

Height/ 

Width: 

The default handrail height is 900, and the default handrail width is 60. 

Handrail 

Offset: 

On the drawing with the scale of 1:100, the value of it is 0.While on the drawing with the scale of 

1:50. The actual value should be marked. 

Landing 

Handrail 

Extend: 

It is used to set the extending length of the corner of the landing handrail. The default value of it is 

60. When the value is set as 0 or negative, the landing handrail is not extended.  

Floor Handrail 

Extend: 

It is used to set the extending length of the start and the end as well as the corner of floor handrail. 

The default value of it is 60. When the value is set as 0 or negative, the floor handrail is not 

extended. 

Handrail 

Connection 

It is checked by default. In this case, the handrails will be connected when it passes the landing and 

the floor. Or else, the handrail will be disconnected at the above mentioned position. 

Outside 

Handrail 

It is used to add the handrail outside the stairs. However, outside railing can not be added in this 

way. With regard of the exterior stair, outside railing needs to be added by the following method. 

With Outside 

Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside railing needs not 

to be drawn. 

Inside Railing 

The inside railing is drawn by default. In this case, the vertical inside railing with rectangle shaped 

column will be automatically generated.  

Up-stair 

Arrow 

It is checked by default. In this case, in the stair object, the arrow indicating the direction of up stair 

and down stair as well as the word "Up" and "Down" will be created according to the current 

coordinate system direction. 

Cutting Steps: 

When the stair is just regarded as stair, user can set the cutting steps by setting the position of the 

cutline midpoint according to the steps.  When the stair is regarded as the ramp, user can set the 

cutting steps by setting the position of the cutline’ midpoint according to the relative elevation. 

As Ramp 

If it is checked, the stair will be generated as ramp. "Length of Single Slope" edit box would be 

displayed in the dialog box for the user to enter the length. 

 

Note: 

1) Before checking the check box "As Ramp", user have to make sure that steps of the first flight 

equals to steps of the second flight, or else the slope length can not be accurately defined. 

2) The distance between the slope strips is set by the steps of the flight, thus steps of the flight 

should be well set before the user checks the check box "As Ramp". 

After confirming the stair parameter and type, the user can move the cursor to the drawing area to insert the stair. 

The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip  

horizontal/F-align/R-change rotation/T-change base point] <Exit>: 

Enter the key word to select different options, and specify the point to insert the stair. 
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Specify the inserting point and insert the U-shaped stair in the plan. Please be noted that, with regard to 3D view, 

the handrails of the stairs on different floors are different. For example, the stair on the top floor in fact only has 

handrail instead of any steps. 

 

U-Shaped Stairs is customized object. User can edit it by dragging the grips. The meaning of the grips is as follows. 

User can also double click the stair to enter object edit interface and reset the parameter. 

 

The explanation of the stair grips function: 

 

[Move Stair] the grips located on the two corner points of the stair landing are used to modify the position of the 

stair. 

 

[Modify Width of Landing] the grips between the landing and the steps are used to modify the width of the landing. 

After the modification, the stair will be automatically adjusted. 

 

[Change Stair Well Width] user can drag the grip to change the stair well width as well as the flight width, but user 

can not modify the staircase width with it. 

 

[Modify Width of Staircase] user can drag the grip to change the staircase width as well as the flight width, but user 

can not modify the stair well width with it. 

 

[Modify First Flight Position] the grip is at the midpoint of the end of the first flight. User can drag it vertically to 

change the position of the first flight. 

 

[Modify Position of Second Flight] the grip is at the midpoint of the first flight. User can drag it vertically to change 

the position of the second flight. 

 

[Modify Outreach of Handrail] the two grips are located at both ends of handrail. User can drag them to modify the 

outreach distance of the handrail at the landing and the floor slab. 

 

[Move Cutting Location] user can change the position of the stair cutting by dragging the grip along the stair. 

 

 

[Move Cutting Angle] user can modify the cutting angle by dragging the two grips.  

 

[Go up Stair Direction] the arrow grips are used to switch the go up stair direction. 
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The typical examples of U-shaped stair are as follows, in which the stair steps number mark can be entered in the 

text box "Upstairs Text" and "Downstairs Text" in the properties bar. 

 

 

 

 



Chapter 2 Function of Architectural Design 

159 

 

 

 

2.6.5 Multi-Landing Stair 

Building Design→Stair and Others→Multi-Landing Stair 

 

Click the command in the menu to show the following default folding dialog box. 

 

Click "Other" to expand the folded content as follows: 
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Explanation of controls in the dialog box: 

Controls Functions 

Drag Drawing  

Path Match  

 

Example of "Multi-Landing Stair": 

Baseline on the 

Left 

Drawing by dragging is by the standard of baseline. In this case, the stair is drawn on the 

right side of the baseline. 

Baseline on the 

Right 

Drawing by dragging is by the standard of baseline. In this case, the stair is drawn on the 

left side of the baseline. 

Left Along the 

Wall 

According to the upstairs direction, the sideline on the left of the stair will not be drawn. 

Right Along the 

Wall 

According to the upstairs direction, the sideline on the right of the stair will not be drawn. 

 

 

Please refer to the following project example. Click the radio button of "Baseline on The Right", set the stair width as 

1820. After the determining the parameter and the type of the stairs, drag the mouse to the draw the stairs in the 

drawing area. The command line will prompt: 

 

Start point<Exit>: 

Specify the start point P1 of the first flight. 

 

Enter Next Point or [path switch to left side (Q)] <Exit>: 

 

Specify the end point P2 of the first flight at the stair corner. "9, (9/20)" will be displayed here. 

 

Enter Next Point or [path switch to left side (Q)/Cancel last (U)] <Exit>: 

 

Specify the point P3 at the end of the landing and regard it as the start point of the second flight. 

 

Enter Next Point or [draw stair (T)/path switch to left side (Q) Cancel last (U)] <Switch to draw stair>: 

 

Here press enter to complete the drawing of the landing and switch to the stair drawing. 
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Enter Next Point or [draw platform (T)/path switch to left side (Q) Cancel Last (U)] <Exit>: Q 

 

Enter Q to switch the baseline position to make the following drawing convenient. 

 

Enter Next Point or [draw platform (T)/path switch to right side (Q) Cancel last (U)] <Exit>: 

 

Drag the mouse to draw stair, when "4, (13/20)" is displayed, click to give the point P4 as the end point of the flight. 

 

Enter Next Point or [path switch to right side (Q)/Cancel last (U)] <Exit>: 

 

Specify the point P5 at the end of the landing and regard it as the start point of the third flight. 

 

Enter Next Point or [draw stair (T)/path switch to right side (Q) Cancel Last (U)] <Switch to draw stair>: 

 

Here press enter to complete the drawing of the landing and switch to the stair drawing. 

 

Enter Next Point or [draw platform (T)/path switch to right side (Q) Cancel Last (U)] <Exit>: 

 

Drag to draw the flight till the end of the flight. "7, (20/20)" will be displayed here. Specify the endpoint of the flight: 

P6. 

 

Start point<Exit>: 

Press enter to finish the drawing. 
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2.6.6 Cross Stair 

Building Design→Stair and Others→Cross Stair 

 

Click the command in the menu to show the following default folding dialog box. 

 

Click "Other" to expand the folded content as follows: 
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Enter the stair’s parameter in the dialog box. User can determine whether the parameter entered can meet the 

requirement according to the dynamic preview window on the right. 

Controls Functions 

Staircase Width< 

The cross stair’s staircase width=2*flight width + stair well width. User can click the 

"Staircase Width<" button to directly measure the width in the plan. 

Flight Width< 

User can directly enter the flight width or click the "Flight Width<"button to directly 

measure the width in the plan. 

Stair Height: Actual height of stair should be entered here. 

Stair Well Width: Stair well width=staircase width-2*flight width 

Sum of Steps: 

The sum of the steps is calculated from the stair height and the rational riser height 

commonly used in the construction. 

Steps of First Flight: 

The steps of first flight and the steps of second flight are calculated by the sum of 

steps. When the sum of steps is even number, the steps of first flight and the steps of 

second flight are equal. 

Steps of Second 

Flight: 

The steps of first flight and the steps of second flight are equal by default. When the 

sum of steps is odd number, the steps of second flight would be increased firstly. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, 

and the stair height is a given integer, the riser height is not always integer. 

Tread Width: The width of each tread of the flight. 

Landing Width 

The landing width of the cross stair equals to the shortest distance between the flights. 

As per construction design specification, landing width should be greater than the flight 

width.  

 

Step Align Type 

When the steps of first flight and the steps of second flight are not equal, the length of 

the two flights are different, thus user has to determine the step align type. There are 

three options regarding it. 

Handrail 

Height/Width 

The default handrail height is 900, and the default handrail width is 60. 

Handrail Offset: 

This is the distance from the edge of the handrail to the edge of the flight. On the 

drawing with the scale of 1:100, the value of it is 0.While on the drawing with the scale 

of 1:50; the actual value should be marked. 

Floor Handrail 

Extend: 

It is used to set the extending distance of the handrail at the top of the stair and the 

handrail at the bottom of the stair (between the floors). 

Landing Handrail 

Extend: 

It is used to set the extending distance of landing handrail at the corner of the stair. 

With Outside 

Handrail 

The inside railing will be drawn by default. If user wants to draw outside handrail, please 

check the check box "With Outside Handrail" as per needs. 
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With Outside 

Railing 

User can check or uncheck it to determine whether the outside railing is to be drawn. If 

the outside of the stair is wall, the outside railing needs not to be drawn. 

With Inside Railing 

If user wants to draw customized railing or Solid Railing, please uncheck it. In this case, 

the default inside railing would not be drawn. 

Up stair Arrow User can determine whether add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where the 

cutting line is. 

Require 3D/2D In some cases, only 2D view is needed, and sometimes, only 3D view is needed.  

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the Spiral Stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The function explanation of stair grips: 

 

[Move Stair] in the grips displayed, user can drag the midpoint of the landing to move the entire stair, during which 

the selected grip is regarded as the base point for the stair moving. 

 

[Modify Width of Staircase] there is one grip at the midpoint of each of the four flights. User can drag it horizontally 

to change the staircase width and the length of the landing. 

 

[Modify Width of Landing] user can drag the grips vertically to modify the width of the landing. 

 

[Modify Width of Flight] there is a grip at the midpoint of the inside of each of the four stairs; user can drag any of 

them to modify the width of four flights at the same time.  

 

[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Move Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Handrail] there are grips at handrail of floor end and handrail end of landing, user can use them 

to change the outreach of the related handrail. 
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2.6.7 T Shaped Stair 

Building Design→Stair and Others→T Shaped 

 

Click the command in the menu to show the following default folding dialog box. 

 

Click "Other" to expand the folded content as follows: 
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Enter the stair parameter in the dialog box. User can determine whether the stair parameters entered can meet the 

requirement according to the dynamic preview window on the right. 

Controls Functions 

Stair Height: 

User can enter the total height of T Shaped stair’s two flights here, and user can 

also select the frequently used value for it in the pull down list. 

Sum of Steps: 

It is calculated from the stair height and reasonable riser height commonly used 

in construction. 

Steps of Side Stair: 

Steps of Middle Stair: 

The respective steps of T-shaped stair’s two flights. The steps of two flights are 

equal by default. User can further change them according to actual condition. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated 

by the construction specification according to the stair height. As the step 

number is integer, and the stair height is a given integer, the riser height is not 

always integer. User can also give the steps of side stair and steps of middle 

stair, and then the system will re-calculate the accurate value of the riser height. 

Tread Width: The width of the flight’s each tread. 

Width of Side Flight</ 

Width of Middle Flight< 

The respective width of flight of the two types. 

Landing Width: 

Length: 

The landing width is from outside of the side flight to the edge line of the 

middle flight.  The landing length is the distance between two side flights. 

Upstairs Location 

User can select one of two upstairs locations: "Center" and "Both Sides". The 

program will automatically handle the drawing of cutting line as well as the 

upstairs direction line. 

Inner Stringer/ Outer 

Stringer 

Is used to draw stringer type stairway. With the two check boxed, user can draw 

inner stringer or outer stringer or both of them. The parameter of the string 

height and width can be modified in properties bar. 

Floor Type 

The program will draw the plans of the stair according to the floor where the 

current plan is and the construction drawing specification. 
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Handrail Height: 

Handrail Width: 

The default handrail height is 900, and the default handrail width is 60. 

Handrail Offset: 

This is the distance from the edge of the handrail to the edge of the flight. On 

the drawing with the scale of 1:100, the value of it is 0.While on the drawing 

with the scale of 1:50; the actual value should be marked. 

Side Stair Handrail Extend: The extend distance of the handrail at the start of the two side stairs. 

Middle Stair Handrail 

Extend: 

The extend distance of the handrail at the start of the two middle stair. 

With Outside Handrail 

The inside railing will be drawn by default. If user wants to draw outside 

handrail, please check the check box "With Outside Handrail" as per needs. 

With Outside Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the 

outside railing needs not to be drawn. 

With Inside Railing 

If user wants to draw customized railing or board, please uncheck it. In this 

case, the default inside railing would not be drawn. 

Upstairs Arrow User can determine whether add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps 

where the cutting line is. 

Require 2D/ Require 3D 

In some cases, only 2D view is needed, and sometimes, only 3D view is 

needed. 

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the Spiral Stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

[Move Stair] in the grips displayed, user can drag the midpoint of the landing to move the entire stair, during which 

the selected grip is regarded as the base point for the stair moving. 

 

[Modify Width of Side Flight and Landing] the stair is highlighted after being selected. User can select the middle 

grips on side flight and drag them to modify the stair width and landing width. 

 

[Move Side Flight] there is a grip on the boundary between two side flights and landing, user can drag any of them 

to modify relative offset between two side flights and landing at the same time.  

 

[Modify Width of Middle Flight] there is a grip on both sides of the middle fight. User can drag any of them to 

modify the width of middle flight. 
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[Move Middle Flight] there is a grip on the boundary between middle flights and landing, user can drag the grip to 

modify relative offset between middle flight and landing.  

 

[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Modify Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Handrail] there is a grip on each end of stair handrail. User can use them to change the 

outreach of the related handrail. 

 

Example of "Drawing T-Shaped Stair":  

 

 

2.6.8 W-Shaped Stair 

Building Design→Stair and Others→W-Shaped 

 

Click the command in the menu to show the dialog box. The effect of the expanded dialog box is as follows: 
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The explanation of the stair grips’ function: 

Controls Functions: 

Stair Height: 

User can enter the total height of W-Shaped stair’s two flights here, and user can also 

select the frequently used value for it in the pull down list. 

Sum of Steps: 

The sum of the steps is calculated from the stair height and the rational riser height 

commonly used in the construction. 

Steps of Side Stair: 

Middle Steps: 

The respective steps of W-shaped stair’s two flights. The steps of two flights are equal 

by default. User can further change them according to actual condition. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, 

and the stair height is a given integer, the riser height is not always integer. User can 

also give the steps of side stair and steps of middle stair, and then the system will 

re-calculate the accurate value of the riser height. 

Tread Width: The width of stair’s each tread. 

Staircase Width< 

Staircase width can both be entered and directly measured from the drawing. Staircase 

width=middle flight width+2*(side flight width + stair well width). 

Width of Middle 

Flight</Width of 

Side Flight< 

The respective width of flight of the two types. 

Stair Well Width: Stair well width= (staircase width- middle flight width-2*side flight width)/2. 

Landing 

There are three options regarding it: "Rectangle", "Arc", "None". It has three options: 

"Rectangle", "Arc" and "None". If users want to customize the landing by themselves, 

option should be "None". 

Width: This is the width of landing. 

Step Align Type 

There are four options regarding it: "Aligned to Landing", "Center", "Aligned to Floor" 

and "Free". 

Upstairs Location 

User can select one of two upstairs locations: "Center" and "Both Sides". The program 

will automatically handle the drawing of cutting line as well as the upstairs direction 
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line. 

Inner Stringer/ Outer 

Stringer 

Is used to draw stringer type stairway. With the two check boxed, user can draw inner 

stringer or outer stringer or both of them. The parameter of the string height and width 

can be modified in properties bar. 

Floor Type 

The program will draw the plans of the stair according to the floor where the current 

plan is and the construction drawing specification. 

Handrail Height: / 

Handrail Width: 

The default handrail height is 900, and the default handrail width is 60. 

Handrail Offset: 

This is the distance from the edge of the handrail to the edge of the flight. On the 

drawing with the scale of 1:100, the value of it is 0.While on the drawing with the scale 

of 1:50; the actual value should be marked. 

Floor Handrail 

Extend: / Landing 

Handrail Extend: 

"Floor Handrail Extend" is the extending distance of the handrail at the slab. 

"Landing Handrail Extend" is the extending distance of handrail at the landing. 

With Outside 

Handrail 

The inside railing will be drawn by default. If user wants to draw outside handrail, please 

check the check box "With Outside Handrail" as per needs. 

With Outside 

Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside railing 

needs not to be drawn. 

With Inside Railing 

If user wants to draw customized railing or Solid Railing, please uncheck it. In this case, 

the default inside railing would not be drawn. 

Upstairs Arrow User can determine whether add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where the 

cutting line is. 

Need 3D/2D In some cases, only 2D view is needed, and sometimes, only 3D view is needed. 

Enter the stair parameter in the dialog box. User can determine whether the stair parameters entered can meet the 

requirement according to the dynamic preview window on the right. Click "OK" button. The command line will 

prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

[Move Stair] the grips at four corner points of the stair are used to move the stair. User can click any one of the four 

points and move the stair. The selected grip is regarded as the base point for the stair moving. 

 

[Modify Width of Landing] user can drag the grip at the midpoint of the landing to modify the width of the landing. 
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[Modify Width of Staircase] there is a grip at the midpoint on the outside of each side flight. User can drag the grip 

on either side to modify the width of the staircase. Meanwhile, the stair well width will be updated accordingly. The 

boundary on the other side would remain unchanged. 

 

[Modify Width of Side Flight] there is a grip at the inside of each side fight. User can drag the grip on either side to 

modify the width of two side flights at the same time. 

 

[Change Side Flight Position] there is a grip at the intersection between the outside of each side flight and the 

landing. User can drag the grip on either side to modify the relative offset between the two side flights and middle 

flight at the same time. 

 

[Modify Width of Middle Flight] there is a grip on either side of the middle flight. User can drag the grip on either 

side to modify the width of the middle flight. Meanwhile, the stair well width will be updated accordingly. 

 

[Change Middle Flight Position] there is a grip at the intersection between the middle flight and the landing. User 

can drag the grip on either side to modify the relative offset between the middle flight and side flights. 

 

[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Modify Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Handrail] there is a grip on each end of two stair wells; user can use them to change the 

outreach of the related handrail. 
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Example of "W-Shaped Stair":  

 

 

2.6.9 Double L-Shaped Stair 

Building Design→Stair and Others→Double L-Shaped Stair 

 

Click the command in the menu to show the dialog box. The effect of the expanded dialog box is as follows: 

 

After entering the stair parameter in the dialog box, user can determine whether the stair parameter entered can 

meet the requirement according to the dynamic preview window on the right of the dialog box. 

Controls Functions 

Stair Height: 

User can enter the total height of Double L-Shaped stair’s each flight here, and user 

can also select the frequently used value for it in the pull down list. 

Total sum of Steps: 

The sum of the steps is calculated from the stair height and the rational riser height 

commonly used in the construction. 

Steps of Side Stair: / 

Middle Stair Step: / 

Steps of Second Flight: 

The respective steps of Double L-Shaped Stair’s three flights. Steps of Side Stair and 

Middle Stair Step are equal by default. User can further modify them as per needs. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, 
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and the stair height is a given integer, the riser height is not always integer. User can 

also give the steps of side stair and steps of middle stair, and then the system will 

re-calculate the accurate value of the riser height. 

Tread Width: The width of stair’s each tread. 

Width of Side Flight/ 

Width of Middle Flight/ 

Width of Second Flight 

The respective width of the three flights. 

Length of Side 

Platform: / Width of 

Side Platform: 

The Length of Side Platform is the distance between the end line of the side fight and 

the outside of the second flight. The Width of Side Platform is the distance between 

the outside of the side flight and the end line of the second flight. 

 

Explanation of double L style stair: 

 Controls Functions 

Length of Middle 

Platform: 

Width of Middle 

Platform: 

Length of Middle Platform is the distance between the outside of the second flight and 

the end line of the middle flight. 

Width of Middle Platform is the distance between the two end lines of the two second 

flights. 

Upstairs Location 

User can select one of two upstairs locations: "Center" and "Both Sides". The program 

will automatically handle the drawing of cutting line as well as the upstairs direction 

line. 

Inner Stringer/ Outer 

Stringer 

Is used to draw stringer type stairway. With the two check boxed, user can draw inner 

stringer or outer stringer or both of them. The parameter of the string height and width 

can be modified in properties bar. 

Floor Type 

The program will draw the plans of the stair according to the floor where the current 

plan is and the construction drawing specification. 

Handrail Height: / 

Handrail Width: 

The default handrail height is 900, and the default handrail width is 60. 

Handrail Offset: 

This is the distance from the edge of the handrail to the edge of the flight. On the 

drawing with the scale of 1:100, the value of it is 0.While on the drawing with the scale 

of 1:50, the actual value should be marked. 

Side Stair Handrail 

Extend: 

The extend distance of the handrail at the start of the two side stairs. 

Middle Stair Handrail 

Extend: 

The extend distance of the handrail at the start of the two middle stair. 

With Outside Handrail 

The inside railing will be drawn by default. If user wants to draw outside handrail, 

please check the check box "With Outside Handrail" as per needs. 

With Outside Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside 

railing needs not to be drawn. 

With Inside Railing 

If user wants to draw customized railing or Solid Railing, please uncheck it. In this 

case, the default inside railing would not be drawn. 

Up stair Arrow User can determine whether add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where 

the cutting line is. 

Require 3D/Require 2D Is used to control the drawing of 2D view and 3D view. In some cases, only 2D view is 
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needed, and sometimes, only 3D view is needed. 

 

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base 

point]<Exit>: 

 

Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the Stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

In the grips displayed, user can drag the midpoint of the landing to move the entire stair, during which the selected 

grip is regarded as the base point for the stair moving. 

 

[Modify Width of Side Landing] user can horizontally drag the middle grip of side landing to modify width of the 

side landing. 

 

[Modify Length of Side Landing] user could vertically drag the end grip of the side landing to modify length of side 

landing. 

 

[Modify Width of Middle Landing] user can drag the middle grip of the second flight to move the flight as well as 

modify the width of middle landing and the position of middle flight. The second flight on the other side will remain 

unchanged. 

 

[Modify Length of Middle Landing] user can drag the middle grip of the middle flight to move the flight as well as 

modify the length of middle landing. 

 

[Modify Width of Side Flight] there is a grip at the midpoint of the inside of each of the two side flights. User can 

drag the grip on either side to modify the width of two side flights at the same time.  

 

[Modify Width of Middle Flight] there is a grip on both sides of the middle fight. User can drag any of them to 

modify the width of middle flight. 

 

[Modify Position of Second Flight] there is a grip at the intersection of each side landing and its adjacent second 

flight. User can drag the grip on either side to move the position of second flight as well as modify the width of 

middle landing. Meanwhile, the middle flight will remain unchanged.  

 

[Modify Width of Second Flight] there’s a grip at the midpoint on the inside of each second flight. User can drag the 

grip on either side to modify width of second flight. 
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[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Move Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Middle Flight Handrails]/ [Modify Outreach of Side Flight Handrails]: there is a grip at handrail 

end of each middle flight and side flight, user can use them to change the outreach of the related handrail. 

 

 

Example of "Double L-Shaped Stair": 

 

 

2.6.10 Triangle Stair 

Building Design→Stair and Others→Triangle Stair 

 

Click the command in the menu to show the dialog box. The effect of the expanded dialog box is as follows: 
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After entering the stair parameter in the dialog box, user can determine whether the stair parameter entered can 

meet the requirement according to the dynamic preview window on the right of the dialog box. 

 

The explanation of controls in the dialog box 

Controls Functions 

Stair Height: Actual height of stair should be entered here. 

Flight Width< 

User can directly enter the flight width or click the "Flight Width<"button to directly 

measure the width in the plan. 

Stair Well Width < 

It is the length of the segment connecting the adjacent two flights. The minimum value of it 

is 0.  Please refer to the pictures below. 

 

Steps of Single 

Flight: 

The steps of three flights are calculated from the stair height and the reasonable riser 

height commonly used in the construction. Steps of Sing Flight are further calculated from 

it.   

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, and 
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the stair height is a given integer, the riser height is not always integer. User can also give 

the steps of side stair and steps of middle stair, and then the system will re-calculate the 

accurate value of the riser height. 

Tread Width: The width of stair’s each tread. 

Show Landing 

When it is unchecked, the landing will not be displayed. In this case, users can draw non – 

standard landing by themselves. 

Width: / Thickness: 

The width of landing is the distance from the flight end line to the corner point of the 

landing as follows. The Thickness of landing is thickness of the landing slab along the z 

direction. 

 

Upstairs Direction 

As needs, user can select one of the two options: "Clockwise", "Counter-Clockwise". In this 

way, up stair flight and the cutting location can be modified. 

Handrail 

Connection 

It is checked by default. In this case, the handrails at each landing are connected. When it 

is unchecked, users can draw stair column or arc handrail etc.by themselves. 

Opening of Handrail 

Termination 

The ends of handrail at the landing is open, in this case, user can insert the component 

like stair column etc. easily.  

With Outside 

Handrail 

If user wants to draw outside handrail, please check the check box "With Outside Handrail" 

as per needs. If there are walls in the staircase, outside handrails usually need not to be 

drawn.  

With Outside 

Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside railing 

needs not to be drawn. 

With Inside Railing 

User can check it to draw inside railing as per needs. The inside handrail is drawn by 

default. 

Extend Distance: 

The extend distances of both ends of the handrail are equal by default. When the value for 

it is negative, the handrail will not extend beyond the stair end. 

Upstairs Arrow User can determine whether to add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where the 

cutting line is. 

Require 3D/ 

Require 2D 

Is used to control the drawing of 2D view and 3D view. In some cases, only 2D view is 

needed, and sometimes, only 3D view is needed. 

 

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 
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Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the Stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

[Move Stair] in the grips displayed, user can drag the grip at the midpoint of the flight to move the whole stair. 

During which the selected grip is regarded the base point for moving. 

 

[Modify Staircase Width] user can drag the grip at the intersection between the flight and the landing to move 3 

flights at the same time. In this way, stair well width and the staircase width can be modified. 

 

[Modify Staircase and Flight Width] user can horizontally drag the grip at the midpoint on the inside of the flight to 

modify the flight width and the stair well width. During which the staircase width would remain unchanged. 

 

[Modify Width of Landing] user can drag the grip to modify the width of landing. During which, the size and position 

of each flight will remain unchanged. 

 

[Modify Width of Flight] user can drag the grip at the midpoint on the outside of each flight to modify the width of 

three flights at the same time. During which the stair well will remain unchanged.  

 

[Change Section Position] user can drag the grip at the midpoint of the broken line to change the position of the 

broken line, during which the original angle of it will remain unchanged and the direction line of the stair will 

automatically updated. 

 

[Change Section Angle] user can drag the grip at both ends of the broken line to change the angle of it. 

 

[Modify Outreach of Handrail] user can drag the grips at the ends of handrail on the outside of each fight to modify 

the outreach of the handrail on the outside of flight, during which the handrail at the landing will remain unchanged.  
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2.6.11 Scissors Stair 

Building Design→Stair and Others→Scissors Stair 

 

Click the command in the menu to show the dialog box. The effect of the expanded dialog box is as follows: 

 

After entering the stair parameter in the dialog box, user can determine whether the stair parameter entered can 

meet the requirement according to the dynamic preview window on the right of the dialog box. 

 

The explanation of controls in the dialog box 

Controls Functions 

Staircase Width< 

The Scissors Stair’s staircase width=2*flight width + stair well width. User can click 

the "Staircase Width<" button to directly measure the width in the plan. 

Flight Width< 

User can directly enter the flight width or click the "Flight Width<"button to directly 

measure the width in the plan. 
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Stair Height: Actual height of stair should be entered here. 

Stair Well Width: Stair well width=staircase width-2*flight width. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, 

and the stair height is a given integer, the riser height is not always integer. 

Step Number: 

The sum of the steps is calculated from the stair height and the rational riser height 

commonly used in the construction. 

Tread Width: The width of stair’s each tread. 

With Cellar 

When the radio button "First Floor" is clicked, if there is a cellar, please check the 

check box "With Cellar", then a downward flight will be provided.  

Left Downward/ Right 

Downward 

Click one of the two radio buttons to determine on which side there is a flight 

regarded as downward flight.  

With Outside Roof 

When the radio button "Top Floor" is clicked, if there is an outside roof, please check 

the check box "With Outside Roof", then an upward flight will be provided. 

Left Upward/ Right 

Upward 

Click one of the two radio buttons to determine on which side there is a flight 

regarded as upward flight. 

Handrail Height: / 

Handrail Width: 

The default handrail height is 900, and the default handrail width is 60. 

Handrail Offset: 

This is the distance from the edge of the handrail to the edge of the flight. On the 

drawing with the scale of 1:100, the value of it is 0.While on the drawing with the 

scale of 1:50; the actual value should be marked. 

Extend Distance: 

The extend distances of both ends of the handrail are equal by default. When the value 

for it is negative, the handrail will not extend beyond the stair end. 

With Outside Handrail 

If user wants to draw outside handrail, please check the check box "With Outside 

Handrail" as per needs. Scissors Stair is relatively narrow, thus outside handrails 

usually need not to be drawn.  

With Outside Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside 

railing needs not to be drawn. 

With Inside Handrail 

User can check it to draw inside railing as per needs. There is firewall on the inside of 

the scissors stair, thus generally, the inside handrail is not drawn. 

With Inside Railing 

It is used to draw the inside railing. If the inside of the stair is wall, the inside railing 

generally needs not to be drawn. 

Upstairs Arrow User can determine whether to add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where 

the cutting line is. 

Require3D/ Require 

2D 

Is used to control the drawing of 2D view and 3D view. In some cases, only 2D view is 

needed, and sometimes, only 3D view is needed. 

 

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 
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Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the Spiral Stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

[Move Stair] in the grips displayed, user can drag the grips at the corner points to move the whole stair, during 

which the selected grip is regarded as the base point for moving. 

 

[Adjust Staircase Position] there is a grip at the corner point of each flight. User can horizontally drag it to change 

the relative position of the related flight. 

 

[Modify Staircase Width] there is a grip at the midpoint on the outside of each flight. User can horizontally drag the 

grip to modify the staircase width. 

 

[Modify Width of landing] user can vertically drag the grip to modify the width of landing, which has little meaning 

for the plans, while user can use it to adjust the landing slab in 3D modeling. 

 

[Modify Width of Flight] there is a grip at the midpoint on the inside of each flight. Use can drag any of them to 

modify width of two flights at the same time. 

 

[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Modify Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Handrail] there is a grip on each end of stair handrail; user can use them to change the 

outreach of the related handrail. 



Chapter 2 Function of Architectural Design 

182 

 

 

Example of "Scissors Stair": 

 

 

2.6.12 Rectangular Corner Stair 

Building Design→Stair and Others→Rectangular Corner Stair 

 

Click the command in the menu to show the dialog box. The effect of the expanded dialog box is as follows: 
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Enter the stair parameter in the dialog box. User can determine whether the stair parameters entered can meet the 

requirement according to the dynamic preview window on the right. 

 

The explanation of controls in the dialog box 

Controls  Functions 

Stair Height: Actual height of stair should be entered here. 

Riser Height: 

The program will calculate a design value within a reasonable range stipulated by the 

construction specification according to the stair height. As the step number is integer, 

and the stair height is a given integer, the riser height is not always integer. 

Tread Width: The width of stair’s each tread. 

Steps of X Flight: 

Use can directly enter the value for it or click the up and down arrow to make step 

modification. 

Width of X Flight< 

User can directly enter the flight width or click the "Flight Width<"button to directly 

measure the width in the plan. 

Flight Number: Click the "Flight Number" pull down list and directly select an integer from 2 to 4. 

Symmetry 

With regard to the Rectangular Corner Stair with 3 or 4 flights, the "Symmetry" check 

box will be provided. After it is checked, in the case of Rectangular Corner Stair with 3 

flights, the parameter of the first flight and that of the third flight are the same, 

meanwhile, the parameter of the third flight can not be edited. While in the case of 

Rectangular Corner Stair with 4 flights, the parameter of the first flight and that of the 

third flight are the same, and the parameter of the second flight and that of the fourth 

flight are the same, meanwhile the parameter of the third flight and that of the fourth 

flight can not be edited. 

Staircase Length< 

Staircase Length=length of the second flight + landing length on both ends. User can 

get the value of it by directly picking related points in the drawing. When the parameter 

entered is less than the permitted minimum value, the program will automatically use 

the minimum length to create the staircase. 
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Staircase Width< 

Staircase Width =length of the first flight + landing width on both ends. User can get 

the value of it by directly picking related points in the drawing. When the parameter 

entered is less than the permitted minimum value, the program will automatically use 

the minimum width to create the staircase. 

Floor Type 

The program will draw the plans of the stair according to the floor where the current 

plan is and the construction drawing specification. 

Show Landing 

When it is unchecked, the landing will not be displayed. In this case, users can draw 

non – standard landing by themselves. 

Up stair Direction 

As per needs, user can select one of the two options: "Clockwise" or 

"Counter-Clockwise". In this way, up stair flight and the cutting location can be 

modified. 

Handrail Connection 

It is checked by default. In this case, the handrails at the floor are connected. While if it 

is unchecked, user can draw Solid Railing or wall at the floor.  

With Outside 

Handrail 

If user wants to draw outside handrail, please check the check box "With Outside 

Handrail" as per needs. If there are walls in the staircase, outside handrails usually need 

not to be drawn.  

With Outside 

Railing 

It is used to draw the outside railing. If the outside of the stair is wall, the outside railing 

needs not to be drawn. 

With Inside Railing 

User can check it to draw inside railing as per needs. The inside handrail is drawn by 

default. 

Top End Extend: / 

Bottom End Extend: 

User can respectively enter the extend value of the handrail’s top end as well as the 

bottom end.  When the extend value is negative, the handrail will not extend beyond 

the stair end. 

Up stair Arrow User can determine whether add arrow line indicating the up stair direction. 

Cutting Steps: 

User can select the cutting position of the stair, which is defined by the steps where the 

cutting line is. 

Require 3D/ Require 

2D 

Is used to control the drawing of 2D view and 3D view. In some cases, only 2D view is 

needed, and sometimes, only 3D view is needed. 
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Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Specify the insert position of the stair and enter related option to flip or rotate the stair if necessary in order to insert 

the stair. 

 

The stair is customized component object, thus it has the property of grips edit. User can change the properties of 

the stair by dragging its grips. User can also double click it and reset the parameter by object edit. 

 

The explanation of the stair grips’ function: 

 

[Move Stair] in the grips displayed, user can drag the grip at the midpoint of the flight to move the whole stair. 

During which the selected grip is regarded the base point for moving. 

 

[Modify Width of First and Second Landing] user can drag the grip at the midpoint of the second flight to move the 

second flight as well as modify the width of first and second landing. 

 

[Modify Length of First Landing]/[Modify Length of Second Landing] user can horizontally drag the grip at the 

midpoint on the outside of the first flight or third flight to move the first or third flight as well as modify the length of 

first and second landing. 

 

[Modify Position of X Flight] the grip is on each end of the landings. User can drag the grip to modify X flight’ 

position in certain range, meanwhile, the staircase size will remain unchanged. On both ends of the flight, when 

there’s no space for moving, the grip will become ineffective. 

 

[Modify Width of X Flight] the program provides grip on the inside of each flight. User can horizontally drag the grip 

to change the width of each flight. When the check box "Symmetry" is checked, user can horizontally drag the grip 

to change the width of two flights and the opposite one at the same time.  

 

[Move Cutting Location] user can drag the grip at the midpoint of the cutting line to move cutting location, during 

which the original angle of it will remain unchanged, and the direction line of the stair will be automatically updated. 

 

[Move Cutting Angle] user can modify cutting angle by dragging the grips on both ends of the cutting line. 

 

[Modify Outreach of Starting Handrail] / [Modify Outreach of Ending Handrail] 



Chapter 2 Function of Architectural Design 

186 

 

 

 

Example of "Rectangular Corner Stair": 

 

 

2.6.13 Elevator 

Building Design→Stair and Others→Elevator 

 

After the user clicks the command in the menu, the dialog box shows: 
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Example of "Without By Stair Well Size": 

Firstly, select the type of elevator from the "Elevator Class" pull down list. Then select the serials of it and enter the 

value for load weight. At this time, the related elevator car size and the door width will be displayed on the right. 

User can select the door type and quantity of the elevator in one lift well. The door type determines whether the door 

of elevator will open from one side or from both sides. Then user can draw it according to the command line 

prompt:  

 

Please select wall line that located elevator door<Exit>: 

 

Select the wall on which the elevator door is to be located, the command will search the related rooms on both 

sides of the selected wall as alternative lift well, in which the elevator car and the balance weight will be displayed. 

The command line will show following prompt: 

 

Select balance weight (red) location<OK>: 

Drag the cursor to switch position of the lift well as well as position of the balance weight (it is indicated by red 

color in the drawing) as follows, and click to fix the position of the current lift well and the balance weight.  

 

If the balance weights of multiple elevators are in the same direction, user doesn’t need to specify the position of 

every balance weight. In this case, please right click the mouse or press enter at the proper cursor position to 

complete the drawing of the multiple elevators.  

 

Select balance weight (red) location<OK>: 

If the quantity of the elevator is greater than 1, the prompt will be displayed. User can specify the positions of the 

second and more balance weights. 

 

After finishing all above operation, the program will prompt "Complete Drawing a Group of Elevators." 

 

Please select wall line that located elevator door<Exit>: 

Start to draw elevator of another group or close the dialog box to exit the command. 

 



Chapter 2 Function of Architectural Design 

188 

 

If the program failed to search the elevator well, the user will enter the alternative scheme of three points positioning 

prompt. 

 

Not found rectangular staircase, please manually specify staircase location and size! 

 

Select first corner point<Exit>: 

Pick a point P1 as one corner point of the elevator well; 

 

Select second corner point<Exit>: 

Pick another corner point P2 adjacent to the first point specified.  

 

Determine Elevator Depth<Exit>: 

Pick a point P3 to determine the elevator depth. 

 

Please select wall line that located elevator door<Exit>: 

Select the wall to locate the elevator door. 

 

Select balance weight (red) location<OK>: 

Select the target position of the balance weight. If there are multiple elevators, the prompt will be repeated. 

 

After the above operation, the program will prompt: "Complete Drawing a Group of Elevators." 

 

Please select wall line that located elevator door<Exit>: 

Start to draw elevator of another group or close the dialog box to exit the command. 

 

As shown in the left picture below, it is an example of single elevator drawing. As shown in the right picture below, 

it is an example of multiple elevator drawing. The following picture shows the above two layout schemes. 

 

When multiple elevators are to be drawn, if user checks the check box "Auto Add Partition Wall", the command will 

draw the partition wall between the elevators according to the wall materials and the wall width given in the dialog 

box. 
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When the elevator load weight selected is too heavy, and the elevator size is too large for the elevator well. The 

command line will prompt: 

 

Elevator capacity too small! 

 

At this time, the user can press enter to exit the current process and return back to the dialog box to select other 

lighter load weight. 

 

Example of "By Stair Well Size": 

Firstly, check the check box "By Stair Well Size", then select the door type, door width, elevator quantity. The car 

width and car depth will be drawn according to the size of the select elevator well and the reserved distance. 

 

Please select wall line that located elevator door<Exit>: 

Select the wall line to locate the elevator door. As shown in the following picture, the command will automatically 

search the elevator well to draw the elevator car and the balance weight. 

 

When the program failed to search the elevator well, user will enter the above mentioned alternative scheme. User 

has to give three points to position the range of elevator well. 

 

Select balance weight (red) location<OK>: 

Drag the cursor to switch position of the lift well as well as position of the balance weight (it is indicated by red 

color in the drawing) as follows, and click to fix the position of each balance weight one by one.  

 

Then the command line will prompt: "Complete Drawing a Group of Elevators." 

Then user can press enter to start to draw new elevators or close the dialog box to exit the command. 

 

The elevator shown in the following picture is drawn via the command "By Stair Well Size". If the elevator door need 

not to be drawn, user can use the command: "Door and Window" → "Door/window" → "Replace 

Windows/Doors" command to replace the default elevator door as the "Simple Elevator Door". The "Simple Elevator 

Door" can be selected from "2D Door Library" → "System Library" → "Sliding Door". 
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2.6.14 Escalator 

Building Design→Stair and Others→Escalator 

 

After the user clicks the command in the menu, the dialog box shows: 

 

Single Stair Escalator: 

 

 

Double Stair Escalator: 

 

When the user checks the checkbox "As Ramp" and sets "Incline Angle" as 0, the dialog box will be as follows. 
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Horizontal Moving Sidewalk: 

 

User may not be able to accurately set the running direction and the installing direction of the elevator in the dialog 

box. When inserting the elevator, user can enter related option to flip or rotate the stair if necessary in order to 

further set the direction of the elevator. User can also uncheck the "Up Stair Arrow" in the dialog box so as not the 

mark the elevator with the running direction. Then use the "Arrow Leader" command to add it. The comment text of 

up stairs and downstairs direction can be modified in the properties bar, too. 

 

The explanation of controls in the dialog box 

Controls Functions 

Stair Height: The design height from the escalator’s first working point to the escalator’s second 

working point.  

Stair Width: It refers to the clear length of the active step (with skirt deflector on both sides 

excluded) 

Step Distance: It refers to the distance from the escalator’s working point to the end line of the steps. 

In the case of Horizontal moving sidewalk, "Step Distance" is 0. 

Platform Distance: It refers to the distance from the escalator’s working point to the end line of the 

escalator platform installation. In the case of Horizontal moving sidewalk, platform 

distance needs to be reset by the user. 

Incline Angle: It refers to the incline angle of the escalator. With regard to the escalator, the alternative 

values for incline angle are 30 and 35 degree. With regard to the ramp, the alternative 

values for incline angle are 10 and 12 degree. When the incline angle is 0, it will be 

regarded as Horizontal moving sidewalk. The interaction interface and the parameter 

will also be changed accordingly. 

Single Stair/Double 

Stair 

User can create double escalators at one time or just create single escalator. 

Parallel/ Crossover The incline directions of double stairs can be set as same or opposite.  

Distance: It refers to the clear distance between the adjacent skirt deflectors of the double stairs 

escalator. 
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As Ramp After it is checked, the alternative values for incline angle are 10 and 12 degree. The 

horizontal length of it will be recalculated, too.  

Up stair Arrow It is checked by default. In this case, The escalator will be marked with the upstairs and 

downstairs directions and the two stairs will run in opposite direction. 

Run in Same 

Direction 

After it is checked, the two stairs will run in same direction. 

Floor Type It includes three interlocked buttons, which respectively indicates that the current floor 

where the escalator is first floor, middle floor or top floor. 

Open Hole User can use the "Open Hole" function to draw the escalator which needs open hole in 

the top floor slab. In this case, the escalator beyond the hole’ range will be hidden. 

After the check box "Open Hole" is checked, the lower section of the escalator will be 

hidden. A grip concerning it will be provided. User can drag it to modify the length of 

the hole. 

 

Click "OK" button. The command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Select the direction, pick the accurate insert position and rotate angle to insert the escalator. 

 

The explanation of the stair grips’ function: 

 

[Modify Width of Flight] the stair will become highlighted after being selected. User can select the middle grips on 

both sides and drag them to modify the stair width. 

 

[Move Stair] the grips at four corner points of the stair are used to move the stair. User can click any one of the four 

points and move the stair. The selected grip is regarded as the base point for the stair moving. 

 

[Move Landing Distance] user can drag the grip to modify the landing distance of the escalator. 

 

[Move Step Distance] user can drag the grip to modify the step distance of the escalator. 

 

[Modify Flight Distance] user can drag the grip to modify the clear distance between two flights. 

 

[Hole Distance] user can drag the grip to modify the length of the part of the escalator on the top floor which is 

hidden by the hole. Meanwhile, the escalator beyond the hole’ range will be hidden. 

 

[Move Cutting Location] on the flight with broken line on it, user can drag the grip to modify the angle and the 

position of the broken line.  

 

The diagram of the grips in double stair escalator on the top floor is as follows: 
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The diagram of the grips in escalator on the middle floor is as follows: 
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The diagram of the grips in Horizontal moving sidewalk is as follows: 

 

 

Example of "Escalator": 

 

 

2.6.15 Add Handrail 

Building Design→Stair and Others→Add Handrail 

 

After the user clicks the command in the menu, the command line will prompt: 

 

Please select flight or path curve (Line/Arc/Circle/Polyline): select the flight or existing curve. 

 

The following dialog box will be displayed: 

 

Enter the value for size in it. Then the handrail can be generated. 

 

Double click the Handrail. Then a pop up dialog box for handrail object edit will be displayed. 
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The explanation of the controls in the Handrail dialog box: 

 

[Shape] the alternative shapes include Square, Circle and Solid Railing. Appropriate size parameter should be 

entered in the dialog box below it. 

 

[Alignment]  

[Add Vertex<] 

[Delete Vertex<] 

[Change Vertex<] 

 

 

2.6.16 Connect Handrail 

Building Design→Stair and Others→Connect Handrail 

 

Click the command in the menu. The command line will prompt: 

 

Select handrail to connect (mind the vertex sequence): select the first handrail that needs to be connected. 

 

Select handrail to connect (mind the vertex sequence): select the second handrail that needs to be connected. 

 

After the user presses enter, the two handrails will be connected. The example of "Connect Handrail" is as follows:  
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2.6.17 Balcony 

Building Design→Stair and Others→Balcony 

 

"Common Balcony" dialog box: 

 

 "Closed Balcony" dialog box: 

 

The tool bar at the bottom provides 6 methods to draw the balcony, there are "Concave Balcony", "Rectangle 

Triangle Balcony", "Internal Corner Balcony", "Offset Drawing along Wall", "Custom Draw", "Select Existed Path to 

Generate" . After the check box "Balcony Beam Height:" is checked, user can enter the value for it to create balcony 

of beam type. 
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The parameters of the balcony with the Common balcony and closed balcony included are as follows:  

 

Explanation: "Outreach" includes "Insulation Thickness" and "Eave Length". 

 

The explanation of the controls in the "Balcony" dialog box: 

 

[Railing Width:] the width of the balcony railing, or the wall width of the closed balcony. The default value of it is 

100. 

 

[Railing Height:] is the height of the balcony railing. The default value of it is 1000. 

 

[Ground Elevation:] the elevation of the balcony ground relative to the current floor. The default value of it is "-100". 

(The balcony is 100 below the current floor). 

 

[Balcony Slab Thickness:] this is the thickness of balcony slab. The default value for it is 100. 

 

[Balcony Height:] with regard to the closed balcony, it refers to the height from the bottom of the railing or the 

bottom of the balcony slab to the top of the banding window.  

 

[Outreach:] this is the outreach distance from the outside of the exterior wall to the outside surface of the railing. 

 

[Balcony Beam Height:] when it is checked, beam style balcony is to be draw. User has to enter the value fro the 

balcony beam height. The default value is 200. 

 

[Closed Balcony] when it is checked, closed balcony is to be drawn. It is composed of banding window and the wall 

whose width is same as that of the railing. There is no wall segment here by default. User can create it by dragging 

the grip "Change One Side Window Width". 

 

[Sill Height:] the sill height of the closed balcony. The default value of it is 1000. 

 

[Eave Length:] with regard to the closed balcony, it refers to the eave length of the balcony slab and roof slab which 

is calculated from the outside of the wall. The default value for it is 100. When there is no eave, the value for it is 0. 

 

[Insulation Thickness:] the thickness of the external insulation layer of the wall used to make the balcony closed. 

The default value for it is 20. 
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[Top Floor Balcony] when it is checked, it means the closed balcony is the top floor balcony on top of which the 

slab needs to be added. The item only has influence on the 3D modeling and the section plan. 

 

The grips of the closed balcony are as follows, user can drag the grip "Change One Side Window Width" to adjust 

the length of the wall on both sides of the banding window in closed balcony. Initially, there is no wall on both sides 

of the banding window. And in this way, user can increase it. 
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User can double click the unclosed balcony to show the object edit dialog box for unclosed balcony as follows: 

 

User can double click the closed balcony to show the object edit dialog box for closed balcony as follows: 

 

There are two special functions in the balcony object edit dialog box, one is to switch the display of the each 

balcony railing, the other is to open window in wall of closed balcony. 

 

"Railing Switch<" button. 

 

Modify the display characteristics of the balcony railing in the dialog box, and click "Railing Switch<" button to 

enter the drawing to select the related railing. The command line will prompt: 

 

Please select the balcony boundary to add or remove fence<Exit>: 

Select the balcony boundary to add or move fence. 

 

Please select the balcony boundary to add or remove fence<Exit>: 

Here repeat the selection of the balcony boundary to switch between the display and hide of the balcony rail. 

 

Example of "Insert window to balcony" 

Modify the balcony wall parameter in the dialog box. Click "Insert Window to Balcony<" to enter the drawing and 

insert the window. Click OK to update the closed balcony. After the user clicks the button, the command line will 

prompt: 
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Please select window start point [Reference point(R)/entire closed Window (F)] <Exit>: R  

Generally, user has to pick a reference point for accurate positioning.  

 

Reference Point: Generally, the end point (P1) of the balcony wall is to be selected as the reference point. 

 

Please select window start point [Reference point(R)/entire closed Window (F)] <Exit>: 500   

Enter the length of the wall segment beside the window. 

 

Please select window end point or [Reference point] <Exit>: R  

Generally, end point is hard to position, too. This reference point is needed to be picked. 

 

Reference Point: pick a reference point that is easy to position. Generally, pick the other end point (P2) of the wall. 

 

Please select window end point or [Reference point] <Exit>:500  

Enter the length of the wall segment. 

 

Please select window start point [Reference point(R)/entire closed]:  

Press enter to exit the command interaction. 

 

User can drag the grip on each side of the window to make them coincide so as to delete the window inserted in the 

closed balcony as follows: 

 

 

Example of "Creating Balcony": 

(1) The drawing of common balcony: 

 

Click the command in the menu and modify the balcony parameter in the dialog box. Then click the "Concave 

Balcony" icon. The command line will prompt: 

 

Start point of balcony<Exit>: 

Specify the start point of the balcony railing P1 on the outside of the external wall and drag to the endpoint of the 

balcony along the direction of the balcony length. 

 

End Point of Balcony or [F-reverse to the other side] <Cancel>: F 
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If you see the preview of the balcony is on the inside of the external wall, it indicates that the wall is to be generated 

on the inside of the external wall by default, thus please enter F to flip the balcony. 

 

End Point of Balcony or [F-reverse to the other side] <Cancel>: 3000   

Enter the balcony length or specify the end point (P2) of the balcony. Then the balcony will be generated. 

 

Start point of balcony<Exit>: 

Press enter to exit the command or go on drawing other balconies. 

 

(2) Custom Draw: 

Click the command in the menu and modify the balcony parameter in the dialog box. Then click the "Custom Draw" 

icon. The command line will prompt: 

 

Start point<Exit>: 

Pick the intersection point between the side railing of the balcony and the external of the wall as the start point (P1) 

of the balcony.  

 

Next Point of line segment or [A-arc segment/Undo] <End>: 

Pick the outline point (P2) of the balcony railing. 

 

Finally, specify the intersection point (P5) between the side railing and the external of the wall as the endpoint of the 

balcony. Press enter here. Then the command line will go on prompting: 

 

Please select adjoining wall (or win-door) and column: 

Here please select the two wall segments connected to the balcony. 

 

Please select the side adjoining walls: 

Red line is the wall side automatically recognized, if you are agree with it please press enter to accept it. 

 

User can also pick other railing line as the side connected to the wall or the other balcony as so on. The railing line 

picked will not be drawn.  

 

Start point<Exit>: 

Press enter to complete the balcony drawing or draw balcony elsewhere.  
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(3) Select exiting path to generate. 

Click the command in the menu and modify the balcony parameter in the dialog box. Then click the "Select exiting 

path to generate" icon. The command line will prompt: 

 

Select one curve (LINE/ARC/PLINE) <Exit>: 

Pick a section of existing path curve. 

 

If the PLINE is not closed, the balcony drawing in this case is similar to the condition of directly drawing the 

balcony. 

 

Please select adjoining wall (or win-door) and column: 

Press enter or select the wall or window connected to the balcony. 

 

Please select the side adjoining walls: 

Pick the sides which are coincident with the wall. 

 

(4) The drawing of closed balcony  

Click the command in the menu and check the check box "Closed Balcony" in the dialog box. Modify the balcony 

parameter including the "Eave Length". Then the command line will prompt: 

 

Start point of balcony<Exit>: 

Specify the start point of the balcony railing P1 on the outside of the external wall and drag to the endpoint of the 

balcony along the direction of the balcony length. 

 

End Point of Balcony or [F-reverse to the other side] <Cancel>: 

Specify the end point (P2) of the balcony. Then the balcony will be generated. 

 

Start point of balcony<Exit>: 

Press enter to exit the command or go on drawing other balconies. 
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Note:  

Apart from drawing balcony object, solid railing balcony of "0 Height" can be custom-made via the dialog box. User 

can further draw handrail, railing and wall segments so as to create complex open combined balcony. 

 

The parameter regarding the division of the closed balcony’s banding window is set as "Auto Divide Window Pane" 

by default. Each of the pane width is 750 by default. "Equal Divide Window Pane" is set as "No". All above parameter 

value can be modified via properties bar of the balcony.  

 

The explanation of properties bar parameter of division of the closed balcony’s banding window: 

 

[Auto Divide Window Pane] if user sets the value of it as "Yes", the pane will be automatically divided along the 

banding window according to the given pane width. 

 

[Pane Width] user can enter the pane unit width as per needs. Pane line would be inserted between the units. 

 

[Equal Divide Window Pane] if user sets the value of it as "Yes", the pane will be equally divided. The command will 

calculate the dividing number according to the pane width entered and divide the pane accordingly. The actual pane 

width is roughly equivalent to the pane width entered. If user sets the value of it as "No", the pane will not be equally 

divided. The panes will be aligned center according to the pane width entered. After the alignment, the width left will 

be given to the first and the last pane. As shown in the following picture, the balcony length is 5000. If the pane will 

not be equally divided, the middle 5 panes will be equally divided, and the width of the first pane and the last pane 

will be the remainder 625. If the pane will be equally divided, the band window will be divided into 7 equal parts, 

and the actual pane width will be 714 which is nearest to the pane width 750. 

 

The left picture shows properties bar parameter of division of the closed balcony’s banding window. The right 

picture shows the appearance effect of the related balcony under the 3D view 
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2.6.18 Step 

Building Design→Stair and Others→Step 

 

On the tool bar from left to right, there are three function zones: "Drawing Methods", "Step Types" and "Base Level". 

User can use these functions to create steps of various types as per needs of engineering. 

 

(1)Drawing methods includes: "Endpoint Location", "Centralized Positioning", "Centralized Positioning", "Draw by 

Offset along Wall", "Draw by Existing Path", "Custom Draw", "Rectangle Single-Side Step", "Rectangle Three-Side 

Step", "Rectangle Internal Corner Step", "Arc Step". 

 

(2)Step types includes: "Common Step" and "Suck Step". 

 

(3)Base level includes: "Based on The Platform", "Based on External Outline". 

 

The explanation of the controls in the steps dialog box: 

 

The meanings of the dialog box parameters are as follows: 

 

 

The steps style predefined also includes the following types: 
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The dialog box of balcony object edit is as follows. User can double click the step to show it. Modify the data 

concerning the steps in the dialog box, and click "OK" to update the steps.  

 

 

Example of "Steps Creating": 

(1)Draw by offset along wall:  The dialog box parameter is set as follows:  

 

The command line will prompt: 

 

First Point<Exit>: 

Pick a point at the intersection between the start side and the wall. 

 

Second Point<Cancel>: 

Pick a point at the intersection between the start side and the wall. 
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Please select adjoining wall (or win-door): 

Select all of the walls, the steps are to pass and press enter to draw the steps. 

 

(2)Draw by existing path. The command line will prompt: 

 

(3)Custom Draw: The command line will prompt: 

 

Start point of Step Platform Outline<Exit>: 

Specify the point P1 to draw the steps platform. 

 

Next Point of line segment or [A-arc segment/Undo] <End>: 

Directly pick each vertex (P2-P7) to draw the steps platform. 

 

Next Point of line segment or [A-arc segment/Undo] <End>: 

Press enter to complete the drawing. 

 

Please select adjoining wall (or win-door) and column: 

Here pick the two adjoining walls. 

 

Please select the side adjoining walls: 

Dotted line indicates that the sides are selected. Then press enter to draw the steps. 

 

2.6.19 Ramp 

Building Design→Stair and Others→Ramp 

 

Click the command in the menu. Then the following dialog box will be displayed: 
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The explanation of the controls in the Ramp dialog box: 

 

The meanings of the dialog box parameters are as follows: 

 

Enter the related parameter concerning the modification of the ramp in the dialog box. Then command line will 

prompt: 

 

The ramp has following styles. The insert point is at the midpoint of the ramp’s upper side. 

 

 

2.6.20 Apron 

Building Design→Stair and Others→Apron 

 

Click the command in the menu. The following Apron dialog box will be displayed. 
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The explanation of the controls in the Apron dialog box: 

 

[Floor level difference from ground:] here enter the height difference between the indoor floor and outdoor ground. 

The default value of it is 450. 

 

[Plinth Offset from Outside Wall:] here enter the offset value between the external wall and its plinth. 

 

[Apron Width:] here enter the width of the apron. The default value of it is 600.  

 

[Create platform from ground level]  

 

[Apron around Column/ Apron around Balcony/ Apron around Wall] after the check boxes are checked, the apron 

will be created around the column, balcony and wall, or else the apron will go through these components. User can 

determine whether to check them as per needs.  

 

[Automatic Draw] the program will search for the closed external wall and automatically generate the apron object, 

which demands that the "Identify I/E Wall" command is executed in advance. 

 

[Custom Draw] user has to specify the base points of the apron path one by one to dynamically draw the apron 

object. The generation direction of the apron is determined by the user. 

 

[Select existed path to generate] select existing line, pline or circle as the apron path to generate the apron object. 

The pline here need not to be closed pline. 

 

Set the parameter in the dialog box displayed, and select the first icon "Automatic Draw". Then the command line 

will prompt: 

 

Please select all walls(or columns, or balconies) of a complete building<Exit>: 

After all the related walls are selected, the apron, plinth and the interior floor will be generated according to the 

requirement of the dialog box. 

 

Set the parameter in the dialog box displayed, and select the second icon "Custom Draw". Then the command line 

will prompt: 
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Please enter start point of apron<Exit>: 

Specify the start point of the apron path. 

 

Straight Line next point or [Arc Line (A)] <End>: 

Specify the second point of the apron path. 

 

Specify Direction: determine the direction of the apron generating by specifying a point on the side where the apron 

is to be generated. 

 

Straight Line next point or [Arc Line (A)/return (U)] <End>: 

Go on to specify point to give the next point of the apron path.  

 

Straight Line next point or [Arc Line (A)/return (U)/Close(C)] <End>: 

Go on to specify point to give the next point of the apron path and press enter to complete the apron drawing. 

 

Set the parameter in the dialog box displayed, and select the third icon "Select Existed Path to Generate". Then the 

command line will prompt: 

 

Please pick pline or circle as an apron path<Exit>: 

Select effective path object including line, pline, arc and circle. 

 

Specify Direction: determine the direction of the apron generating by specifying a point on the side where the apron 

is to be generated. Then the prompt on the first line will repeat. 

 

Please pick pline or circle as an apron path<Exit>: 

Press enter to complete the apron drawing. 

 

Example of "Apron Drawing": 

The following picture is the example of the apron drawing with [Apron around Column/ Apron around Balcony/ 

Apron around Wall] unchecked. 

 

The following picture is the example of the apron drawing with [Apron around Column/ Apron around Balcony/ 

Apron around Wall] checked. 
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Example of "Drawing Apron with Method of [Custom Draw]": 

 

 

Example of "Drawing Apron with Method of [Select Existed Path to Generate]": 

 

 

Example of "Apron Edit": 

Object edit: double click the apron object to invoke the object edit command and edit the apron. 

 

Select [Add vertex/Decrease vertex/S-change grips/W-modify width/E-modify elevation] <Exit>: A 

Enter the option hot key to add vertex, after which the command line will prompt: 

 

Select new vertex position: give the accurate position of the new vertex via "Snap" function. Press enter to complete 

the edit. 
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Grip edit: click the apron object to active the grips as follows. User can edit the apron as well as modify the width of 

apron’s individual section by dragging the related grip. 

 

Properties edit: After Pressing "Ctrl+1" and selecting the apron object, user can see the relation between the 

apron’s vertexes and its coordinates in the properties bar. User can also click the arrow besides the vertex bar to 

switch the parameter for different vertexes as well as modify their coordinates. 
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2.7 Elevation 

2.7.1 Building Elevation  

Building Design→Elevation→Building Elevation  

 

Click the command in the menu. The command line will prompt: 

 

Please enter elevation direction or [F-front/B-back/L-left/R-right] <Exit>: F 

Enter shortcut key or give two points according to the sight direction in order to point out the direction of building 

elevation generation. 

 

Please select axis to show in elevation drawings: 

Generally here select the axis in the same direction as the elevation. It’s useless to select the axis number. 

 

The Building Elevation setting dialog box will be displayed: 

 

If there is correct building floor definition in the current project manager interface, the prompt of saving elevation 

file will be displayed, or else the elevation file can not be generated. 

 

The hiding calculation is automatically done by the arithmetic. When the stair railing uses complicated shaped 

railing, as these kinds of railings has abundant entity sides, the hiding calculation will spend much more time. 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Multi-floor hidden-line 

Removal(Quality Optimize)/ 

Single-floor hidden-line 

Removal(Speed Optimize) 

The former takes the hiding of adjacent floors into consideration, thus the speed is 

slower. However, the precision is better. 

Ground and Floor Level 

Difference(m): 

The height difference between the indoor floor and outdoor ground. 

Plot Scale  1: Set he plot scale of elevation generation 

Dimension: 

Left Side/ Right Side 

Control whether there will be dimension in the vertical direction on the left side and 

the right side of the section. The dimension includes floor elevation mark and size 
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dimension. 

Draw Floor Lines Control whether to draw the horizontal line between the floors  

Floor Number Mark Is used to add the floor number mark. 

Mark Between Two Floors Is used to add the floor number mark between the floors. 

Styles 

User can select the style of the floor number mark from the pre-set floor number 

styles: "1F", "1-F", "1/F", "F1", "F-1". The default style is "1F". 

Bracket 

When both of the floor elevation and floor number are to be added, user could use the 

style with bracket like "(1F)". 

 

After proper parameter has been selected and entered in the dialog box interface, please click "Generate Elevation" 

button to enter standard file dialog box. The default file path is the path of the current project file folder. The 

software provides default elevation file name as follows. 

 

Click "Save" to generate elevation file as follows. 

 

 

In the elevation drawing, Elevation Mark has been defined as the specialized elevation object in GstarCAD 

Architecture. It includes base elevation and associative elevation. The axis object here includes all the axis number 

of the plan’s axis lines in the same direction as the elevation. The axis number of axis line selected will be displayed, 

and the axis number of the axis line that was not selected will be hidden. User can use the "Axis Number 

Show/Hide" command to show the hidden axis number. 
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Axis Line in Elevation Axis Number: 

Select the axis number object in the elevation drawing and press "Ctrl+1" to show the properties bar, which 

provides the option of "Display Axis Line or Not". It is set as "No" by default. In this case, the axis line is from the 

axis number to the position of "0 Elevation", when it is set as "Yes". 

 

 

2.7.2 Component Elevation  

Building Design→Elevation→Component Elevation  

 

Click the command in the menu. The command line will prompt: 

 

Please enter elevation direction or [F-front/B-back/L-left/R-right/T-top] <Exit>: 

Enter F to generate the front elevation. 

 

Please select building components to get elevation: 

Select the stair plan object. 

 

Please select building components to get elevation: press enter to complete the selection. 

 

Please select position<Exit>: 

Drag the generated elevation and specify a point at proper position to insert it. 
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2.7.3 Elevation Win-Door 

Building Design → Elevation → Elevation Win-Door  

 

Click the command in the menu and the "Elevation of Win-Door" will be displayed as follows: 

 

There are five main functions involved in the dialog box. They are: "Insert Elevation Win-Door", "Modify the Size of 

Elevation Win-Door", "Replace the Elevation Win-Door", "Modify the Location of The Elevation Win-Door" and 

"Delete the Elevation Win-Door". We will introduce these functions to you as follows: 

 

2.7.3.1 Insert(Insert Elevation Win-Door) 

Click the image box on the left of the dialog box and select the elevation win-door block required in the pop-up 

drawing library interface. As shown in the following picture, select the drawing-block and double click, and you will 

return back to the dialog box. 
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Check the "Height" and "Width" checkbox in the elevation win-door dialog box and enter the required size of 

elevation win-door as follows: 

 

Insert the elevation win-door in the elevation drawing as per the prompt in the command line. 

 

Insert or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/E-outline/R-rotation/T-reset base point] <Exit>: 

Specify a point to insert the win-door, during which the left bottom corner point of the win-door is regarded as the 

base point for inserting. 

 

2.7.3.2 Replace Type(Replace Existing Elevation Win-Door) 

When the existing win-door need to be replaced, please click the "Replace Type" radio button in the "Elevation of 

win-door" dialog box first as follows: 

 

 

The function is similar to "Insert Elevation Win-Door" function. Click the image box on the left of the dialog box and 

select the elevation win-door required. Double click it to return back to the elevation win-door dialog box, and the 

command line will prompt: 

 

Please select Win-doors to be replaced<Exit>: 

Select the elevation win-door need to be replaced in the drawing. 

 

Please select Win-doors to be replaced<Exit>: 

Complete the replacement and press enter to exit. 

 

During the process of elevation win-door replacing, as per the design of the elevation win-door library, user can 

replace the existing win-door by the European classical win-door with decoration cover in the elevation drawing 

library according to the hole’ size as follows: 

 

 

2.7.3.3 Modify Size(Modify Size Of Existing Elevation Win-Door) 

When the size of the existing win-door needs to be modified, please click the "Modify Size" radio button in the 

"Elevation of Win-Door" dialog box. The following picture shows the example of win-door width modification. 
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In the dialog box user can check the check box "Height" or "Width" and modify the parameter regarding one of them 

with that of the other unchanged, user can also check both of the two checkboxes and modify the parameters of 

them at the same time, then operate as per the prompt in the command line.  

 

Please select Win-doors to be modified<Exit>: 

Select the elevation win-door need to be modified in the drawing. The win-door size will be changed symmetrically, 

during which the midpoint of the window sill is regarded as the alignment point for size modification. 

 

Please select Win-doors to be modified<Exit>: 

After the modification, please press enter to exit. 

 

2.7.3.4 Modify Location(Modify Location Of Existing Elevation Win-Door) 

When the location of existing win-door needs to be modify, first please click the "Modify Location" radio button in 

the elevation win-door dialog box, and move the location of the win-door as per the prompt in the command line. 

The interaction prompt of this function is the same with that of the previous one.  

 

 

2.7.3.5 Delete Win-Door (Cancel Existing Elevation Win-Door) 

When the existing win-door needs to be deleted, first please click the "Delete Win-Door" radio button in the 

elevation win-door dialog box. Then please operate as per the prompt in the command line. 

 

Please select win-door to be deleted<Exit>: 

Select the win-door that needs to be deleted as per prompt. 

 

Please select win-door to be deleted<Exit>: 

Press enter to exit. 

 

Note: Only when the "Insert" or "Replace Type" function is selected, can the user enter the elevation win-door 

drawing library by clicking the image box. User can not enter it under other functions 
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2.7.4 Elevation/Section Grid 

Building Design → Elevation → Elevation/Section Grid 

 

Click "Elevation/Section Grid" command in the menu, and the following dialog box will be displayed. Enter 

parameter in it. 

 

Click "Restore Last" button, and the parameter entered last time can be restored as follows: 

 

Switch to one of the three radio buttons: "Axis Line Space", "Left Floor Height", "Right Floor Height" and enter the 

appropriate parameters. It is similar to the "Axis Grid" dialog box. 

 

The explanation of the controls in the dialog box: 

 

[Extension Length:] the extension position of the current axis line or floor axis line. It includes four directions with 

"Top", "Bottom", "Left", "Right". 

 

[Length:] the extension length of the axis line or floor axis line in some direction. It will be kept till user reset it. 

 

[Axis Line Space] is the size of the axis grid. The details of it are subject to the direction of the elevation or section.   

 

[Left Floor Height] the floor height indicated on the left of the grid. 

 

[Right Floor Height] the floor height indicated on the right of the grid. 

 

[Number] is the repeat times of the data in the "Bay Sizes/ Floor Height" bar. User can enter the value by selecting it 

from the pull down list or selecting bay sizes/ Floor Height from the value bar, user can also directly enter it. 
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[Bay Size/Floor Height] user can enter the value by selecting it from the pull down list or selecting bay sizes/ Floor 

Height from the value bar, user can also directly enter it. 

 

[Enter] is used to type in a group of size data, with each data separated by a blank space or a comma in English. 

Then press "Enter", and the data will be imported into the Excel. 

 

[Clear All] is used to empty the axis grid data of one of the items ("Axis Line Space", "Left Floor Height", "Right Floor 

Height"), and other data will remain unchanged. 

 

[Restore Last] recover and display the data used for drawing the axis grid the last time. 

 

[OK][Cancel] 

[OK] after clicking it, Elevation/Section Grid will be drawn and the related data will be saved.  

[Cancel] is to give up the axis grid drawing and data entering. 

 

User can execute the operation of data inserting, deleting, copying and cutting by right clicking the first button of 

each row. 

 

The command interaction of Elevation/Section Grid: 

 

After typing in all the necessary size data in the dialog box, click the [OK] button, and the command line will show: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

Move the axis grid by dragging its base point, and click to obtain the position where axis grid is to be placed, or 

make response to other options according to the prompts. 

 

If the data for "Left Floor Height" and the data for "Right Floor Height" are the same, user do not have to enter the 

data for "Right Floor Height", and vice versa. 

    

The base point of the Elevation/Section Grid is the grid intersection point at the left bottom corner.  The 

intersection point position of multiple floor building’s grid line on each plan with the same axis number should be 

the same. 

 

Example of "Elevation/Section Grid": 

The value for "Axis Line Space" is entered as: 4200, 4200. The value for "Left Floor Height" is entered as: 4*3000. 

The value for "Right Floor Height" is entered as: 3600, 2400, 2100, 3900 .The grid drawn is as shown in the 

following picture, in which the size dimension was added later in order to indicate the parameter of floor height and 

the axis space. 
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2.7.5 Floor Axis Dimension 

Building Design→Elevation→Floor Axis Dimension 

 

Click the command "Floor Axis Dimension" in the menu, and the following dialog box will be displayed. 

 

User can set the parameter for "Floor Dimension" and "Axis Dimension", and add dimension to the left and right floor 

as well as the bottom of axis grid according to the prompt in the command line. The order of the axis can be from 

left to right, and it can also be from right to left. 

 

The explanation of the controls in the dialog box: 

 

[Start Floor:] here please enter the floor number related to the start floor axis line that needs adding the dimension 

regarding floor elevation.  

 

[Start Elevation (M):] enter the elevation of the floor that needs adding the dimension. 

 

[Mark Floor No.] It is checked by default. It is used to add the floor number at the end of the elevation dimension 

symbol according to the given floor number type. 

 

[Floor No. Style:] GstarCAD Architecture provides many floor number dimension styles, like 1F, 1-F, 1/F, F1, F-1 

and so on.  

 

[Add Bracket] after it is checked, it indicates that the bracket is to be added on both sides of the floor number. 
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[Start Axis Number:] here enter the start axis number used for axis dimension. 

 

Example of "Floor Axis Dimension": 

The result of the "Floor Axis Dimension" is as showing in the following picture. 

 

 

2.7.6 Elevation/Section Dimension  

Building Design → Elevation → Elevation/Section Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please line select the first, second dimension line, and win-door! 

 

Specify First Point of Line<Exit>: 

Pick a point P1 at the inside of the exterior wall across the elevation win-door (please refer to the left of the 

following picture). 

 

Specify Second Point of Line<Exit>: 

Pick a point P2 near the outside of the first dimension line, and the third dimension line (win-door dimension line) 

will be drawn 8mm from the second dimension line. 

 

Select other win-doors: select other win-door or press enter to exit the command. 

 

Example of "Elevation/Section Dimension": 

The result of the dimension of the win-door on the elevation or section is as follows: 
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Note：As the name and the position of the top floor are usually further specified by user, Dimensions for them are 

not added in this way. 

 

2.7.7 Rain Pipe 

Building Design→Elevation→Rain Pipe 

 

Click the command in the menu, and the following dialog box will be displayed. 

 

The command line will prompt: 

 

Please select start point<Exit>: 

Specify the start point of the rain pipe. 

 

Please select next point <Exit>: 

Specify the next point of the rain pipe. Then parallel rain pipe will be vertically drawn between the above two points 

specified. 

 

 

2.7.8 Column Elevation 

Building Design→Elevation→Column Elevation 

 

Click the command in the menu, and the dialog box will be displayed as follows: 
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The command line will prompt: 

 

Start Angle: enter initial projection angle of the plane column or use default value. 

 

Included Angle: enter the included angle of the plane column or use default value.  

 

Number of Meshes: enter the quantity of the elevation projection line or use default value. 

 

Enter the first corner point of rectangular<Select Boundary>: 

Pick the first corner point of the column’s elevation boundary. 

 

Enter second corner point of rectangular<Exit>: 

Pick the second corner point of the column’s elevation boundary. 
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2.8 Section 

2.8.1 Building Section 

Building Design→Section→Building Section 

 

Click the command in the menu, and the command line will prompt: 

 

Please select a section mark: select the section mark on the first floor. 

 

Please select axis that will appear in section drawings: Generally we select the first and the last axis line or press 

enter to ignore axis. 

 

Here "Building Section" dialog box will be displayed. It includes basic information as follows: 

 

Select or enter appropriate parameter in the dialog box and click "Generate Section" button, and user can enter 

standard file dialog box. The default file path is the path of the project file folder. The section file will be named 

according to the serial number of the selected section symbol by default as follows:  

 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Multi floor hidden line 

Removal(Quality Optimize)/ 

Single floor hidden line 

Removal(Speed Optimize) 

The former takes the hiding of adjacent floors into consideration, thus the speed is 

slower, but its hiding effect is better. 

Ground and Floor Level 

Difference(m): 

The height difference between the indoor floor and outdoor ground. 

Plot Scale  1: Set the plot scale of section generation. 
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Dimension: 

Left Side/ Right Side 

Control whether there will be dimension in the vertical direction on the left side and 

the right side of the section. The dimension includes floor elevation mark and size 

dimension. 

Draw Floor Lines Control whether to draw the horizontal line between the floors. 

Floor Mark No. Is used to add the floor number mark. 

Mark Between Two Floors Is used to add the floor number mark between the floors. 

Styles 

User can select the style of the floor number mark from the pre-set floor number 

styles: "1F", "1-F", "1/F", "F1", "F-1". The default style is "1F". 

Bracket 

When both of the floor elevation and floor number are to be added, user can use the 

style with bracket like "(1F)". 

If there is correct building floor definition in the current project manager interface, the standard file dialog box will 

be displayed via which user can enter the section’s file name and saving path to save the section file, and then click 

"OK" to generate the section file as follows. If there is no correct building floor definition in the current project 

manager interface, the section file can not be generated. 

 

As we have to express floor slab in the section drawing, GstarCAD Architecture can automatically add the floor lines 

for the user to create slab thickness by "Offset" command. If user has already created the floor slab model with the 

"Slab" or "Search Room" command, the "Building Section" command will generate the floor slab line according to 

the floor slab thickness. 

 

In the section drawing, Elevation Mark has been defined as the specialized elevation object in GstarCAD Architecture. 

It includes base elevation and associative elevation. The axis object here includes all the axis number of the plan’s 

axis lines in the same direction as the elevation. The axis number of axis line selected will be displayed, and the axis 

number of the axis line that was not selected will be hidden. User can use the "Axis Number Show/Hide" command 

to show the hidden axis number. 

 

In the section drawing, the created wall, column, beam, slab are all composed of simple CAD lines, thus we can use 

CAD edit command to modify them or use the command under the "Section" menu to thicken them or fill them with 

patterns. 
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Select the axis number object in the elevation drawing and press ctrl+1 to show the properties bar, which provides 

the option of "Display Axis Line or Not". It is set as "No" by default. In this case, the axis line is from the axis number 

to the position of "0 Elevation". When it is set as "Yes", axis line will be displayed. User can drag the grip of the axis 

number to change the length of the axis line as follows. 

 

 

2.8.2 Component Section 

Building Design→Section→Component Section 

 

Click the command in the menu, and the command line will prompt: 

 

Please select a section mark: select the section mark defined by the "Section Symbol" command in the symbol 

menu. 

 

Please select building components need to get Section: select the components intersected with the section mark as 

well as the components that can be seen in the direction of section view.  

 

Please select building components need to get section: press enter to complete the sectioning. 

 

Please select position<Exit>: 
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Drag the section drawing generated and specify proper position to insert it. 

 

2.8.3 Wall Section 

Building Design→Section→Wall Section 

 

Click the command in the menu, and the following dialog box will be displayed: 

 

The command line will prompt: 

 

Please select start point of wall<Exit>: 

Specify the start point of the section wall 

 

Please select end point of wall<Exit>: 

Specify the end point of the section wall 

 

Then the wall section will be drawn. 

 

2.8.4 Win-Door Section 

Building Design→Section→Win-Door Section 

 

Click the command in the menu, the "Section of Win-Door" dialog box will be displayed. We can see 5 main 

functions in it, they are: "Insert Win-door", "Modify Height", "Replace Type", "Modify Elevation", "Delete Win-Door". 

 

2.8.4.1 Insert Win-Door (Insert Section Win-Doors): 

 

The command line will prompt: 

 

Select bottom of section baseboard<Exit>: 

Click the bottom of section wall and press enter. 
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Win-door Location<2000>:900 

The value that is to be entered here is the distance from the top of the lower win-door to bottom of the upper 

win-door. The win-door will be inserted in the section wall in sequence according to the exiting section wall in the 

drawing.  

 

Win-door Location<2000>:1500   

The win-door will be inserted in the section wall in sequence. 

 

Select bottom of section baseboard<Exit>: 

Press enter to exit the command. 

 

The win-door inserting will not be failed until the top of the win-door to be inserted is beyond the top of the wall line. 

When it occurs, the program will exit the command and prompt: "Win-door is beyond the wall". 

 

 

2.8.4.2 Replace Type(Replace Section Win-Door): 

Select the "Replace Type" option and click the image box and select win-door needed in the "Section Win-Door 

Library". 

 

Click the image box on the left of the dialog box and enter the "Section Win-Door Library". Double click and select 

the section win-door needed as follows:  
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The command line will prompt: 

 

Please select Win-doors to be replaced<Exit>: 

Here please frame select multiple section win-doors that need to be replaced, at this time, all the win-door selected 

will be replaced with the win-door of the same style. 

 

Please select Win-doors to be replaced<Exit>: 

Press enter to exit the command. 

 

2.8.4.3 Modify Height: 

Select the option "Modify Height", and the following dialog box will be displayed. 

 

Modify the height parameter of the target win-door in the dialog box and operate according to the prompt in the 

command line. 

 

Please select Win-doors to be modified<Exit>: 

Here in the section drawing, user can select multiple section win-doors whose heights need to be modified. 

 

Please select Win-doors to be modified<Exit>: 

Press enter to exit the command. 
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2.8.4.4 Modify Elevation: 

Select the option "Modify Elevation", and the following dialog box will be displayed. 

 

Then operate according to the prompts in the command line: 

 

Please select Win-doors to be modified<Exit>: 

Select the win-door that needs to be modified in the drawing, e.g., the window on the top floor as shown in the left 

picture. 

 

Win-door Location<0>:700 

Enter the new distance between the window sill to the top of the lower window, e.g., enter 1200. Please be noted 

that the distance is not calculated from the current floor slab.  

 

Please select Win-doors to be modified<Exit>: 

Press enter to exit the command, and the location of the win-door will be modified as follows. 

 

 

2.8.4.5 Delete Win-Door: 

When you want to delete existing win-door, please click "Delete Win-Door" radio button in the "Section of 

Win-Door" dialog box, and operate according to the prompt in the command line. 

 

2.8.5 Lintel Section 

User can use this command to draw predefined lintel section with gray scale hatch over the section win-door. 

 

Building Design→Section→Lintel Section 
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Click the command in the menu, and the following general "Lintel Section" dialog box will be displayed by default. 

 

User can modify the height of the lintel in it or set the "Lintel Type" as "Terraced", in this case, the dialog box will be 

as follows: 

 

User can modify parameters of Terraced lintel’s 4 section and lintel’s inserting direction, and them operate 

according to the prompt in the command line. 

 

Please select section win-door need to add lintels<Exit>: 

Pick the section win-door the lintel needs to be added to. User can select multiple win-doors here. 

 

Please select section win-door need to add lintels<Exit>: 

Press enter to complete the selection. 

 

All kinds of win-door lintel style i as follows: 

 

 

2.8.6 Hatch Section 

Building Design→Section→Hatch Section 

 

Click the command in the menu, and the following dialog box will be displayed. 
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Click the pattern on the left of the dialog box, and the following "Pattern Management" dialog box will be displayed. 

User can select different hatch material patterns to fill in the section.  

 

On the right of "Section Hatch" dialog box, user can set the parameters like angle, scale hand so on. 

 

If we select options: "Independent Hatch" and "Island Detection", we do not have to close the region which is to be 

selected in advance, as GstarCAD Architecture will automatically find the closest closed region to fill in. 
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The command line will prompt: 

 

Please select close region to fill<Exit>: 

Frame selecting the boundary of the region need to be filled in. 

 

Please specify region to fill<Exit>: 

Specify a point in the first region that needs to be filled in. 

 

Please specify region to fill<Exit>: 

Specify a point in the other region that needs to be filled in or press enter to complete the section hatch. 

 

The following picture indicates the wall section hatch effect of different material patterns: 

 

 

2.8.7 Section Bold 

Building Design → Section → Section Bold 

 

Select the command in the menu, and the following dialog box will be displayed: 

 

The command line will prompt: 

 

Please select curves to bold (Line/Arc/Circle/Polyline) <Exit>: 

Specify opposite corner: 2 found 

 

Please select curves to bold (Line/Arc/Circle/Polyline) <Exit>: 

Go on selecting or press enter to complete the selection. 

 

The bold effect is as follows: 
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2.8.8 Cancel Bold 

Building Design→Section→Cancel Bold 

 

Click the command in the menu, and the command line will prompt: 

 

Please select bold line to recover to thin line: select the wall line that has already been thicken or press enter to 

retain all the bold wall lines. 

 

Please select bold line to recover to thin line: go on selecting or press enter to complete the selection. If user wants 

to dis-select line, please press ESC to exit the command. 

 

 

2.8.9 Stair Section 

Building Design→Section→Stair Section 

 

Click the command in the menu, and the standard "Stair Section" dialog box will be displayed. 
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With this dialog box user can draw multiple flights of which each flight with different parameter    is drawn one by 

one according to the predefined parameter as follows: 

 

Example of "Drawing Section Stair": 

The example is to draw 4 segments of stair section with railing under "Automatic Turning" function, and the flight 

height and the step number of each flight are different. Click "Stair Section" command and enter the related dialog 

box. Click "Other" button to expand the dialog box and set the parameter. User can click the button again to fold the 

dialog box. Click the radio button "Left-Inclining", and check the check box "Automatic Turning", "Railing". There are 

landings on both ends of the first flight as shown in the following picture. Then drag the cursor to the drawing area, 

and the command line will prompt: 

 

Please insert point: here pick a point at one end of the staircase of "0 Elevation", and the stair’ direction will be 

automatically changed and the stair will be switched to visible stair. Then click "Select Landing" button to set the 

stair as "No Landing on The Right". 

 

Please insert point: pick a point at the top surface on the right of the landing, and the stair’ direction will be 

automatically changed and the stair will be automatically switched to section stair and set as "No Landing on The 

Left".   

 

Please insert point: pick a point at the top surface on the left of the landing, and the stair’ direction will be 

automatically changed and the stair will be automatically switched to visible stair and set as "No Landing on The 

Left". 

 



Chapter 2 Function of Architectural Design 

236 

 

Please insert point: pick a point at the top surface on the right of the landing and press enter to complete the 

drawing of the 4 flights. The result is as follows. Finally, please use "Handrail Joint" command to connect the 

handrails. 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Switch Base point 

Is used to determine the base point (red ×) position on the stair. It can be switched 

between the end of the left and the right landing. 

Railing/ Solid Railing The two checked boxes are interlocked .user can select one of them or select none of them. 

Hatch Fill the section stair and landing with color. And does not fill in the visible area. 

Flight Height< The height difference between the left and right landing of the current flight. 

Staircase Length< 

This is the total length of the current stair case. User can get the value for it by clicking the 

button and specify two points on the drawing .User can also enter to value for it directly. 

Staircase Length=stair length + Left Landing Width + Right Landing Width. 

Step Number: 

It is the step number of the current flight.  

User can click the up arrow and down arrow to adjust it. 

Tread Width: The tread width of the current flight. User can enter or modify it. 

Riser Height: 

It’s the riser height of the current stair. It is calculated by the flight height and the step 

number. 

Step Slab Thickness: Refers to the step slab thickness of stringer stair. 

Stair Slab Thickness: Refers to the stair slab thickness of slab stair. 

Left Landing Width</ 

Right Landing Width< 

Left Landing Width and Right Landing Width of the current staircase. User can get the value 

of them by specifying two points in the drawing or direct entering. When both of them are 

set as 0, the stair case length will be equal to stair length. 

Surface Layer 

Thickness: 

The decoration surface layer thickness of the current flight. 

Handrail Height: The height of the current flight’s handrail or solid railing. 

Handrail Thickness: The handrail thickness of the current flight. 

Outreach of Handrail: 

The distance from the start position and the end position of the current flight to the outer 

edge of the handrail joint (It can be set as 0). 

Pick Stair Data< 

Pick stair data from plane stair object.in case of U-shaped stair, only the first flight’s data 

will be picked. 

Stair Beam After it is checked, user can enter the height and width of the stair beam section in the edit 
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box. 

 After user select stringer stair, the parameter will be displayed. 

 

Note：The directly created multiple flights section flight has property of flight hiding. 

 

The railing of the stair drawn by operating step by step and adding the flights one by one can not be automatically 

hidden, please use "Trim" command in CAD to handle it by your self. 

 

2.8.10 Stair Railing 

Building Design→Section→Stair Railing 

 

Click the command in the menu, and the following dialog box will be displayed. 

 

The command line will prompt: 

 

Enter start Point of handrails<Exit>: 

 

Enter end point of handrails<Exit>: 

…… 

Then the above prompt will be repeated, with which user can draw the stair railing for each flight. Please press enter 

to exit the command when necessary. 

 

2.8.11 Stair Railing Slab 

Building Design→Section→Stair Railing Slab 
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The operation of this command is the same as that of the "Stair Railing" command. 

 

2.8.12 Handrail Joint 

Building Design→Section→Handrail Joint 

 

Click the command in the menu, and the following dialog box will be displayed. 

 

In the dialog box, set the "Outreach of Handrail" as 100. If user wants to add railing at the joint, please check the 

"Add Railings" check box. At this time, the command line will prompt: 

 

Please specify two points to make sure a pair of handrails to connect! Please select first corner point<Exit>: 

Specify the first point. 

 

Another corner point<Exit>: 

Specify the second point, and GstarCAD Architecture starts to handle the first pair of handrails (railing slabs), then 

the command line will go on to prompt: 

 

Please specify two points to make sure a pair of handrails to connect! Please select first corner point<Exit>: 

Specify the first point. 

 

Another corner point<Exit>: 

Specify the second point, and GstarCAD Architecture starts to handle the second pair of handrails (railing slabs), 

then the command line will go on to prompt as above. User can press enter to exit the command when necessary. 

...... 

 

The effect of the stair handrail joint is that closer segment hides the farther segment. The following picture shows 4 

examples of handling railing and railing slab with the "Handrail Joint" command. 
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2.9 Text and Sheet 

2.9.1 Concept of Tables 

Table properties: 

 

Double click the table frame to enter table setting dialog box, in which user can set the global properties like title, 

table row, table column, content and so on. 

 

Under the options of global properties in the table setting dialog box, if we check the check box "Force 

subordinate…" the parameter will influence the global, or else, it will influence the cells with no personalized 

setting. 

 

Under "Row Setting" or "Column Setting", if we check the check box "Inherit…" property of the row or the column 

will inherit the global setting in the "Table Setting" dialog box, or else the personalized setting of the row or column 

will become effective. 

 

User can only personalize the currently selected cell. 

 

The explanation of title properties: 

Controls Functions 

Hide Title It is used to hide title. 

Title Height: It is the height of the title bar when the table is printed out. 

Line Spacing 

Factor : 

The clear distance between lines of the title. The unit is the current text height. For 

example, if the "Line Spacing Factor" is 1, the distance between adjacent lines of the title 

will be a blank line. The parameter determines the density of the title lines. 

Title is out of 

border 

If it is checked, the title bar will be canceled, and the title text will be out of the table 

border. 

 

The explanation of the horizontal line parameter properties: 

Controls Functions 
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Horizontal Line 

If it is checked, there will be no horizontal line between all the rows in the whole 

table, and the parameter under it will be invalid. 

Property of Row 

Height 

It is used to set the association property between the row height and other related 

parameters. It includes 4 options, and it is free by default. "Fix" means the row 

height will be set in "Row Height" and remain unchanged.  

 

"At Least" means user can modify the row height by dragging the grip, but the row 

height will not be less than the row height set in the global setting.  

 

"Auto" means the cell text connect in the row selected is allowed to automatically 

wrap, and whether it will happen depends on whether the column or cell the text 

content is in has already been set as "Auto Newline". 

 

"Free" means there will be multiple grips added at the front of the row, and user can 

freely drag the grips to modify the row height. 

Force subordinate row 

to inherit 

If it is checked, all the rows in the whole table will be displayed according to the 

property set in this page, or else, the setting will influence the cells with no 

personalized setting, and the cells with personalized setting would remain 

unchanged. 

 

The explanation of the vertical line parameter properties: 

Controls Functions 

No Vertical Line 

If it is checked, there will be no vertical line between all the rows in the whole table, 

and the parameter under it will be invalid. 

Force subordinate 

column to inherit 

If it is checked, all the columns in the whole table will be displayed according to 

the property set in this page and the properties not involved will remain unchanged. 

Or else, the setting will influence the cells with no personalized setting, and the 

cells with personalized setting would remain unchanged. 

 

 

The explanation of the text parameter property: 

Controls Functions 

Line Spacing Factor: The clear distance between text lines in the cell. The unit is the current text height. 

Force subordinate 

column and cell to 

inherit text property of 

table 

If it is checked, all the texts in the cell will be displayed according to the property 

set in this page and the properties not involved will remain unchanged. Or else, the 

setting will influence the cells with no personalized setting, and the cells with 

personalized setting would remain unchanged. 

 

2.9.2 Table Row Edit 

Building Design→Text and Sheet→Sheet Edit→Table Row Edit 

 

There is a "Table Row Edit" command in the right key menu, first select the table that is to be edited, right click it 

and select the "Table Row Edit" option in the pop up menu, then move the cursor to select the row in the table. 
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The explanation of the row parameter: 

Controls Functions 

Inherit horizontal 

parameter of Table 

If it is checked, the row object currently operated will be displayed according to the 

parameter setting of the global table row. 

Force subordinate cell 

to inherit text 

parameters 

If it is checked, all the texts in the cell will be displayed according to the property 

set in this page and the properties not involved will remain unchanged. Or else, the 

setting will influence the cells with no personalized setting, and the cells with 

personalized setting would remain unchanged. 

 

2.9.3 Table Column Edit 

Building Design→Text and Sheet→Sheet Edit→Table Column Edit 

 

There is a "Table Column Edit" command in the right key menu, first select the table that is to be edited. Right click 

it and select the "Table Column Edit" option in the pop up menu, then move the cursor to select the column in the 

table. 

 

The explanation of the column parameter: 
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Controls Functions 

Inherit Vertical 

Parameter of 

Table 

If it is checked, the column object currently operated will be displayed according to 

the parameter setting of the global table column. 

Force 

Subordinate Cell 

to Inherit 

If it is checked, all cells in the column currently operated will be displayed according 

to text parameter set in this page. 

No Vertical Line 

After it is checked, the vertical line between the adjacent columns will not be 

displayed. However, in this case, the adjacent cells will not merge. 

Auto Newline 

After it is checked, the text in the table column can automatically wrap after it is 

beyond the cell width. Besides, we also have to use "Property of Row Height" to make 

the cell suitable for the text. 

 

Grip edit: 

 

User can adjust the size of the table by dragging the grips as follows. The column widths of table initially generated 

are the same by default. User can use the grip to change it to reasonable width. User can also adjust the row height 

by grip, text height or newline according to the difference of "Row Height" property. The right bottom corner point is 

used to change the size of the table in any proportion. The width and height of the row and column will be 

automatically changed to reasonable size accordingly. If "Property of Row Height" is set as "Free" or "At least", the 

grip used to change the row height will be provided. 

 

 

2.9.4 Text Style 

Building Design→Text and Sheet→Text Style 

 

Click the command in the menu, and the dialog box will be displayed as follows: 
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The explanation of the controls in the dialog box: 

Controls Functions 

New... 

It is used to create new text style. First name the new text style, then select the Chinese 

font or English font and the related parameter of width and height. 

Rename... It is used to rename the text style. 

Delete 

Delete the text style that has not been used in the drawing. Text style that has already 

been used cannot be deleted. 

Style Name 

Display current text style name. User can select other predefined text styles from the 

pull-down list. 

Width Factor: It is the ratio of the text width to text height. 

Chinese Font: Set the Chinese font that composes the text style. 

Text Width 

Orientation: 

It is the ratio of English text width to Chinese text width. 

Text Height 

Orientation: 

It is the ratio of English text height to Chinese text height. 

English Font: Set the English font that composes the text style. 

TTF style 

If we use the windows system font TTF (e.g. "Arial Unicode" etc.), we only have to set the 

Chinese parameters, as the TTF font has both Chinese font and English font. 

Preview 

It is to make the parameter of new text style effective. User can preview the effect of the 

text written in the edit box according to the current text style. 

OK 

It is used to set the text style regarding the style name as the current text style and exit the 

text style definition. 
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2.9.5 Single Line Text 

Building Design→Text and Sheet→Single Line Text 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Text: 

User can enter text and symbols here. The text that has already been inserted in 

drawing will be reserved, which makes it convenient for the user to enter the content 

of the same type again. User can simply select the text from the pull-down list. 

Text Style 

Select the text style that has been defined by CAD or GstarCAD Architecture text 

style command from the pull-down list. 

Alignment Select the alignment of the text and the base point. 

Rotation< Enter the rotation angle of the text. 

Text Height< 

It refers to the height of the text on the drawing finally printed out instead of the text 

height measured on the screen. There is a Multiple relation regarding the drawing 

scale between them. 

Hide Background 

After it is checked, the text will hide the background e.g. Hatch. This item made use 

of the CAD Wipeout image hiding property. The hiding function will exist with the 

text movement. 

Superscript/Subscri

pt 

Select part of the text that needs to be converting to superscript or subscript, and 

click the icon of superscript or subscript. 

Text in Circle 

Select part of the text on which the circle needs to be added, and click the icon for 

adding circle. 

Reinforced symbol

s 

Move the cursor to the position where the reinforced symbol needs to be inserted, 

and click the related reinforced symbols. 

 

Example of "Single Line Text in-Place Editing": 

Double click the single line text on the drawing to enter in-place editing status, and the edit box will be directly 

displayed on the drawing. The text will always been in the direction from left to right, which makes it convenient for 

the user to modify it. Please refer to the following picture. 
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2.9.6 Multi-Line Text 

Building Design→Text and Sheet→Multi-Line Text 

 

Click the command in the menu to show the dialog box. Enter the content of each line in the content area and select 

multi-line text parameter. As shown in the following picture, it is an example of text alignment when the alignment 

text is decimal point. 

 

The explanation of the dialog box control’s function: the meanings of the other controls are the same with those of 

controls in the single line text dialog box. 

Controls Functions 

Area for 

entering text  

Enter multi-line text in it. And it can also accept other text editing content from the clipboard.eg, 

the text edited by word can be copy to clipboard via hot key as "Ctrl + C". 

Line Spacing 

Factor: 

It refers to the clear distance between lines. And it is the height of the text finally printed. For 

example, when the "Line Space Factor" is 1.0, the distance between lines finally printed is 1 

mm. when the "Line Space Factor" is 0, the texts in the adjacent row is likely to be connected 

with each other. Thus, the "Line Space Factor" decides the density of the texts in the whole 

paragraph. 

Text Height< 

It refers to the actual height of text printed out (the unit is mm). GstarCAD Architecture will 

automatically adjust the size of the text in the model space according to the current scale.  

Alignment 

It decides the alignment of the text paragraph. The alignment includes: "Left", "Right", "Center" 

and "Justify". 

Text Alignment 

Here we can enter some character according which the multi-line text is to be aligned. 

Generally, the character is decimal point. In this case, multiple lines of numbers with decimal 

point are to be aligned according to the decimal.  

After editing the text content entered, please click "OK" button to complete the entering of multi-line text.  

 

There are two grips available for multi-line text. The grip on the left is used to move the whole text. The grip on the 

right is used to change the width of paragraph. 

 

When the width is less than the "Page Width" set in the multi-line text dialog box, the multi-line text will 

automatically wrap. The end position of the last line is subject to the alignment of the object. 
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As shown in the following picture, it is the example of text page width adjustment in the case of "Alignment: Left".  

Change the page width by dragging the grip, and the text that is too wide will automatically wrap. 

 

 

2.9.7 Text Increase 

Building Design→Text and Sheet→Text Increase 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the letter you want to incremental copy (Note: Press the CTRL to copy decreasingly, only operate on 

the single selected letter) <Quit>: 

In the text, please select the ordinal numbers’ digit that is to be increased, e.g., "1" in the following picture. 

 

Please specify the base point: 

Specify the base point position of copying. 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Specify the target position of copying. 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Specify the other target position of copying. 
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2.9.8 Text Auto-Adjustment 

Building Design→Text and Sheet→Text Increase 

 

Click the command in the menu, and the command line will prompt: 

 

Please select single line text: click the text that needs to be rotated, and press enter, and the text will be adjusted 

according to the correct direction as follows: 

 

 

2.9.9 Text Convert 

The command is used to convert the single line text of CAD format into GstarCAD Architecture single line text. 

 

Building Design→Text and Sheet→Text Convert 

 

Click the command in the menu, and the command line will prompt: 

 

Please select CAD single text: user can select multiple text strings in the drawing at a time, and then press enter to 

exit, after which no prompt will be displayed. 

 

The command only has influence on the single line text generated by CAD, and has no influence on multiple line 

text. 

 

2.9.10 Text Merge 

Building Design→Text and Sheet→Text Merge 

 

Click the command in the menu, and the command line will prompt: 

 

Please select single line text that requires merging<Exit>: 

Select multiple text strings and press enter to complete the selection. 

 

Please select single line text that requires merging<Exit>: [D-merge to sing line text] <Merge to multi-line text>: 

User can either press enter to merge the text selected as a multi-line text or enter D to merge them as single line 

text. 

 

Move to target position<Replace original text>: 

Drag the merged text to the target position and specify a point there to insert it in the drawing. 
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If the texts to be merged are very long paragraph, we suggest user merge them as multi-line text, or else the single 

line after the merging will be very long. 

 

Example of "Text Merge": 

There is an Engineering description as follows, which is the text object drawn by CAD.  We can convert them into 

multi-line text. 

 

After merging them, we have to modify the row distance by editing the multi-line text object. The result is as shown 

in the above picture. 

 

2.9.11 Unify Text Height 

Building Design→Text and Sheet→Text Merge 

 

Click the command in the menu, and the command will prompt: 

 

Please select text that is needed to be unified text height<Exit>: 

Select the texts whose height needs to be unified. 

 

Please select text that is needed to be unified text height<Exit>: 

Press enter to complete the selection. 

 

Please enter text height<3.5mm>: enter new height the texts’ heights are to be unified according to. 

 

2.9.12 Find and Replace 

Building Design→Text and Sheet→Text Merge 

 

Click the command in the menu, and the dialog box will be displayed as follows. In it GstarCAD Architecture 

provides simple and clear toolbar as operation commands and switch settings. If we place the cursor on the icon in 

the tool bar, the function prompt related will be displayed. 
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Take finding win-door tag for example. Enter "W" in "Find" edit box and click "Find" icon, the result will be as follows. 

If we click some line in the result, we can notice that there will be a red box displayed surrounding the related text. 

 

Match Full Text: When it is selected, user can find the charter string totally same as that entered in the "Find" text 

box. For example, if we enter "Number" in the "Find" text box, we can only find "Number" instead of "Win-Door 

Number". 
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Using Wildcard Character: When using wildcard to find text, user has to use half-width character instead 

of full-width character. The functions of "Using Wildcard Character" and "Match Full Text" can not be use at the 

same time. The explanation of the Wildcard is as follows: 

Wildcard Description 

# (pound) Matches any numeric digit. 

@ (at) Matches any alphabetic character. 

. (period) Matches any non-alphanumeric character. 

* (asterisk) or % (percent) Matches any string, including the null string. It can be used at the 

beginning, middle, or end of a string. 

? (question mark) Matches any single character. 

~ (tilde) Matches anything but the next pattern. 

[ ] (brackets) Matches any one of the characters enclosed. 

[~ ] (tilde and brackets) Matches any character not enclosed. 

- (hyphen) Specifies a range for a single character when inside brackets. 

‘(reverse quote) Escape character; reads the next character literally. 

, (comma) Enters a set when used between items. 

When the command "Replace All" is executed, there will be a dialog box displayed to report the result of 

replacement. When the command "Find" is executed, the finding result will be displayed in the command line. 

 

Example of "Find and Replace": 

What should we do if we want to replace the win-door number "CXXXX" with "WXXXX" in batch, during which the 

numbers in them should keep unchanged. 

 

What we have to do is just enter "C" in the "Find" edit box and enter "W" in the "Replace" edit box as follows, and 

them click "Replace All" icon to execute the replacement. 

 

After the execution of the command, the dialog box will be displayed to prompt: "Replace Completed, Total 

Replaced 6". The win-door number after the replacement is as follows: 
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2.9.13 New Table 

Building Design→Text and Sheet→New Table 

 

Click the command in the menu, and the dialog box of "New Table" will be displayed: 

 

Enter the title, row number and column number of the table in it and click "OK", and the command line will prompt: 

 

Upper left corner point or [Reference point] <Exit>: 

Specify the table’s position on the drawing. 

 

Click the table to select it, and double click the cell in which the text is to be entered, and the "In- Place" edit 

function will be available. In this status, user can enter the text in the edit bar. 

 

2.9.14 Full Screen Edit 

Building Design→Text and Sheet→Sheet Edit→Full Screen Edit 

 

Click the command in the menu, and the command line will prompt: 

 

Please select table<Exit>: 

Select the table to be edited. And the dialog box will be displayed as follows: 

 

User can enter the text of each cell in the table in the dialog box. 

User can edit the row and column like this: select the row or column and click the front of it, and the shortcut menu 

will be displayed as shown in the picture. (Please be noted that the row and the column can not be selected at the 

same time). Finally please press "OK" button to complete the operation of "Full Screen Edit". 

 

The maximization button in the "Full Screen Edit" interface applies to editing the table with abundant content. 

 

2.9.15 Table Split 

Building Design→Text and Sheet→Sheet Edit→Table Split 

 

Click the command in the menu, and the "Table Split" dialog box will be displayed: 
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The explanation of the controls in the dialog box: 

Controls Functions 

Row(Column)S

plit 

It is used to determine whether the Table Split will be according to row or column. 

With Title 

It is used to determine whether the initial table title (including the title out of the table) 

will remain there after the splitting. Please be noted that the title is different with table 

header. 

Header Rows: 

Get the table to be split and add the rows to the split table as the header according to 

the row quantity specified. 

Automatic Split Automatic split the table according to the row quantity specified. 

Specify Rows 

User should use it together with "Automatic Split". It is the new table’s row quantity 

excluding the header.  

 

Example of "Table Split" Command: 

Automatic Split: 

After setting in the dialog box the parameter regarding the splitting, please click "OK" button, and the new table after 

splitting will be automatically displayed on the right of the original one. 

 

Interactive Split: 

When "Automatic Split" is unchecked, the option of "Specify Rows" will not be available. 

 

Take "Row Split" for example, click "OK" button to start the interaction of row splitting. The command line will 

prompt: 

 

Select start row to split<Exit>: 

Select the starting row from which the table is to be split into new one. 

 

Select insertion position<Back>: 

Drag the new table and specify a position to insert it. 

 

Select start row to split<Exit>: 

Select the starting row from which the new table is to be split into new one. 

 

Select insertion position<Back>: 

Drag the new table and specify a position to insert it. 
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2.9.16 Table Merge 

Building Design→Text and Sheet→Sheet Edit→Table Merge 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the first table or [C-column merging] <Exit>: 

Select the table to be located in the front of the new table. 

 

Select next table<Exit>: 

Select the table to be located at the position following the previous table. 

 

Select next table<Exit>: 

Press enter to exit the command. 

 

After the above operation, the rows of the two tables are merged, and row quantity of the final table equal to the sum 

of the row quantity of the tables selected, in addition, the title of the first table will be used as the title of the new 

table. 

 

Note: If the column quantities of the tables to be merged are different, the column quantity of the final table is equal 

to the column quantity which is the largest one among those of the tables to be merged. The redundant table header 

of the table after merging can be deleted by user as per needs. 

 

Example of "Table Merge" Command: 

The following picture shows the case of merging two tables with different row and column quantities. If the column 

quantities of the tables to be merged are different, the column quantity of the final table is equal to the column 

quantity which is the largest one among those of the tables to be merged. 
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2.9.17 Add Row in Table 

Building Design→Text and Sheet→Sheet Edit→Add Row in Table 

 

Click the command in the menu, and the command line will prompt: 

 

Select insertion position of new row (Insert before This Row) or [A-insert after this row/S-copy current row] <Exit>: 

 

When user clicks the table, a rectangle cursor will be displayed. Please click the position where you want to add the 

row. Please refer to the following picture. 

 

User can also give response according to the prompt as follow: 

 

Select insertion position of new row (Insert before This Row) or [A-insert after this row/S-copy current row] <Exit>: 

S   

Entering S means the current row is to be copied as the added row. 
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2.9.18 Delete Row From Table 

Building Design→Text and Sheet→Sheet Edit→Delete Row from Table 

 

Click the command in the menu, and the command line will prompt: 

 

Select a row to delete<Exit>: 

When user clicks the table, a rectangle cursor will be displayed. Please click the row to be deleted. 

 

Select a row to delete<Exit>: 

The above prompt will be repeated here. User can delete one row at one time. When the row deleting is complete, 

user can press enter to exit the command. 

 

2.9.19 Table Export 

Building Design→Text and Sheet→Table export 

 

Click the command in the menu, and the command line will prompt: 

 

Export table to [Word (W)/Excel (E)] <W>: 

Select the type of the export file. 

 

Please select table: select a table object. 

The system will automatically start MS Office and create a new file and input the content of the selected table to it 

as follows: 

 

 

2.9.20 Table Import 

Building Design→Text and Sheet→Table import 

 

Click the command in the menu, if user has not open the Office file including the table, there will be a pop up dialog 

box prompting that you have to correctly open Office in advance. 
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After user opens the file with table included and box selects the range of the table to be imported, the command line 

will prompt as follows:  

 

Import table to current drawing [Word (W)/Excel (E)] <W>: E   

Select the type of the import file. If the type entered is different from the Office program currently opened, the above 

prompt will be displayed again. 

 

Only when the format of the file opened is same as the format entered above, will the command go on prompting as 

follows:  

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

 

2.9.21 Cell Edit 

Building Design→Text and Sheet→Cell Edit→Cell Edit 

 

Click the command in the menu, and the command line will prompt: 

 

Select a cell to edit or [M-multi-grid property)/X-cell exploded] <Exit>: 

Click and specify the cell to be modified, and "Cell Edit" dialog box will be displayed. 
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If the content of multiple cells need to be modified, user can enter M to select multiple cells. Then the command 

line will go on prompting: 

 

Please select the first point for confirming multi-grid to edit property or [S-single grid edit/X-cell explode] <Exit>: 

Specify two points to select multiple cells. 

 

Please select the second point for confirming multi-grid to edit property<Exit>: 

Press enter to complete the cell selection 

 

At this time, the "Cell Edit" dialog box will be displayed. In it user can only modify the text’s property instead of the 

text content. 

 

For the cells that have been merged, user can enter X to select "Cell Explode" option so as to turn the merged cells 

back into the original independent standard cells, and the partition lines between the cells will be recovered too. 

 

The command line will prompt: 

 

Select cell needs be split or [Single grid edit(S)/Multi-grid property (M)] <Exit>: 

Click and specify the cells to be modified. The text content of each cell after splitting is same as the content of the 

cell before splitting. 

 

2.9.22 Cell Increase 

Building Design→Text and Sheet→Cell Edit→Cell Increase 

 

Click the command in the menu, and the command line will prompt: 

 

Select the first cell<Exit>: 

Click the first cell in which the number has existed. 

 

Select the last cell<Exit>:  

Click the end cell where the number increasing ceases. 
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When the "Cell Increase" command is complete, the table will be updated accordingly.  

When clicking the end cell, if user presses shift at the same time, the number will be copied instead of being 

increased, if user presses Ctrl instead, the number will be decreased. 

 

Example of "Cell Increase" Command: 

 

 

2.9.23 Cell Copy 

Building Design→Text and Sheet→Cell Edit→Cell Copy 

 

Click the command in the menu, and the command line will prompt: 

 

Select target cell (Reselect source by CTRL) or [A-select text] <Exit>: 

Select in the table the cell with content in it and copy the content. 

 

Select target cell (Reselect source by CTRL) or [A-select text] <Exit>: 

Click in the table the target cell and paste the content of source cell here. 

 

Select target cell (Reselect source by CTRL) or [A-select text] <Exit>: 

Go on selecting the target cell in the table and paste the content of source cell here, or press enter to exit the 

command. 

 

2.9.24 Cell Accumulation 

Building Design→Text and Sheet→Cell Edit→Cell Accumulation 

 

Click the command in the menu, and the command line will prompt: 

 

Select the first cell<Exit>: 

Select the cell with the first number to be accumulated in it. 

 

Select the last cell needs to be accumulated<Exit>: 
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Select in the same column or row the cell with the last number to be accumulated in it. 

 

The result of cell accumulation is: xxxxx 

 

Select cell for storing accumulation result<Exit>: 

Select a blank cell in the table to store the result. 

 

 

2.9.25 Cell Merge 

Building Design→Text and Sheet→Cell Edit→Cell Merge 

 

Click the command in the menu, and the command line will prompt: 

 

Select the first corner point<Exit>: 

Select two points to specify the range of the cells to be merged. 

 

Select another corner point<Exit>: 

The "Cell Merge" is complete. 

 

The text in the cell after merging is centered. The text context is same as that in the first cell before merging. Please 

be noted that when picking the two corner points, please click the inside of the cell instead of picking the points on 

the horizontal or vertical line in the table. 

 

2.9.26 Cancel Merge 

Building Design→Text and Sheet→Cell Edit→Cancel Merge 

 

Click the command in the menu, and the command line will prompt: 

 

Select merged cells<Exit>: 

After selecting, the command will recover the structure of the cell’s original unit. 

 

2.9.27 Insert Block to Cell 

Building Design→Text and Sheet→Cell Edit→Insert Block to Cell 
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Click the command in the menu, and the "Insert Block in Cell" dialog box will be displayed: 

 

Click "Select Block<" button and the command line will prompt: 

 

Please select insertion block<Exit>: 

Select a existing block from the drawing (e.g., Composite Win-door), and come back to the dialog box and check 

"Scale Unify" as shown in the picture below. 

 

Meanwhile, the command line prompts: 

 

Select Insertion Cell or [Select block (B)] <Exit>: 

Specify the cells in which the block is to be inserted and right click the mouse to exit. 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Auto Set Size 

It is used to automatically make the size of the block just right for the cell in which 

it will be inserted. 

Scale Unify 

It is used to maintain the unification of the scale of X and Y direction when we insert 

the block to the cell. In this case, the block scale will remain unchanged when we 

modify the table size.  

Display attribute 

value 

When we insert the block with attribute to the cell, the attribute value will be 

displayed after inserting. 

Equal side 

It is used to automatically zoom the block when we insert it to the cell, which 

enable the block sizes in the x and y directions to be equal. 
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Select Block< 

Select from the blocks existing in the drawing the block to be inserted to the cell. 

Here both the GstarCAD Architecture block and AutoCAD block are OK. 

Select from 

Library... 

Enter GstarCAD Architecture drawing library and select the block to be inserted to 

the cell. 

 

Example of "Insert Block to Cell" Command: 

Click the cell when the cursor is moved to the cell in which the block is to be inserted. 

 

User can also insert block to the cells continuously as per needs. Then right click the mouse to exit the command. 

 

User can execute the "Cell Edit" command to modify the cell with block inserted. In this way user can carry on 

modification like replacing the existing block with new block, changing the scale and so on. The following dialog 

box will be displayed. 
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After the above mentioned operation, please press "OK" to complete the modification. User can execute "In-Place 

Edit" command to empty the cell with block inserted. Under the status of "In-Place Edit", the expression of the block 

will be displayed in the cell. User can empty the cell by pressing "DEL" to delete the expression. 
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2.10 Dimension 

2.10.1 Set Status of Dimension 

GstarCAD Architecture provides the "Dimension Auto-Adjustment" command in the menu. It is used to auto adjust 

the position of the dimension text when they are too crowed. 

 

 

2.10.2 Win-Door Dimension 

Building Design→Dimension→Win-Door Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please use line selection to select the first and second dimension line and walls! 

 

First point of the line<Exit>: 

Select a point P1 near and on the outside of the first dimension line. 

 

Second point of the line<Exit>: 

Select a point P2 on the inside of the external wall, and win-door dimension line will be drawn. And the distance 

between the third dimension line (win-door dimension line) and the second dimension line will be 8 mm. 

 

Select other walls: 

Select wall on which there are win-doors to be dimensioned. Then press enter to exit the command. 

 

Example of "Win-Door Dimension": 

The command can set the range of dimension association. When the position of the win-door in this range is 

changed, the dimension will be automatically changed accordingly. Next, we will cite two cases regarding the 

command. 

 

1. Automatically dimension the win-door on the straight wall and arc wall and generate the third dimension line 

according to the first and the second dimension line of the grid dimension in the plan. 

 

2. If there’s no first and the second dimension line of the grid dimension in the plan, the win-door dimension line 

will be generated at the second point given by the user. 
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2.10.3 Dimension Association of Win-Door Dimension 

The dimension object created by the win-door dimension command is associated with the win-door involved. When 

the win-door width is changed by win-door moving, changing width via grips, object edit, property edit（Ctrl+1）

or property matching via format brush, the win-door dimension will be updated associatively. The win-door 

association range is subject to the setting of the association range of the dimension object. Please be noted that 

only the win-door surrounded by starting dimension borderline, ending dimension borderline, dimension’ line and 

dimension association grips can be associated in order to avoid error operation. 
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GstarCAD Architecture provides three dimension association grips on the other side of the starting point, middle 

point and ending point of the win-door dimension object. User can modify the position of them by mouse dragging. 

User can also determine whether to start the dimension association of one or multiple dimension object by setting 

in the property bar. 

 

Note: 

1. After the win-door dimension, if we widen, move, insert, copy, or mirror the win-door within the range of the 

dimension line, the dimension will be updated associatively. 

2. Please pay attention to the difference between the dimension association and the "Related" in the status bar, the 

latter is the function that when we drag the grips of wall to modify it, the other wall related will be modified 

accordingly. 

 

Example of "Win-Door Dimension Association": 

 

 

2.10.4 Dimension's Association Range Setting 

The association operation between dimension object and the win-door has certain action range. Please be noted 

that the association operation will not be available beyond the range in order to avoid error operation. The range is 

controlled by the position of the specialized grip of the dimension object. The operation regarding the win-door 

dimension command determines the association range. As shown in the following picture, when the win-door 

dimension line is generated according to the first and the second dimension line of the grid dimension in the plan, 

the association range is the nearest distance from the point to the win-door, which has nothing to do with the points’ 

selection order. If there’s no first and the second dimension line of the grid dimension in the plan, the association 

range is the distance from win-door to the dimension line specified by the user. 
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2.10.5 Wall Thickness Dimension 

Building Design→Dimension→Wall Thickness Dimension  

 

Click the command in the menu, and the command line will prompt: 

 

Current dimension type: Total Width 

First point of the line or [Total width/Sub width] <Exit>: 

User could enter "T" or "S" to switch the current dimension type. 

 

First point of the line<Exit>: 

Specify starting point P1 at the position where the dimension is to be added. 

 

Second point of the line<Exit>:  

Specify ending point P2 at the position where the dimension is to be added. 

 

Example of "Wall Thickness Dimension with Type of Total Width": 

Please refer to the following picture. 

 

Example of "Wall Thickness Dimension with Type of Sub Width": 

Please refer to the following picture. 

 

 

2.10.6 Two Point Dimension 

Building Design→Dimension→Two Point Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Start point (Current Wall Line Dimension) or [C-wall center dimension] <Exit>: 
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Specify a starting point P1 at one end point of dimension line, or enter C to switch to "Wall Center Dimension", and 

the following prompt will be the same.  

 

End Point<Exit>: 

Specify an ending point P2 at the other end point of dimension line. 

 

Please select axes and walls to be excluded: 

User can exclude the axis and walls that need not to be dimensioned here. 

 

Please select axes and walls to be excluded: 

Press enter to complete the selection. 

 

Please select doors, windows, columns to be included: 

User can use any of the methods of primitive selection to select the primitive in the wall like win-door etc. 

 

Please enter other dimension points or [Reference point/Undo] <Exit>: 

Select other points or enter U to undo the previous selection. 

 

Please enter other dimension points or [Reference point/Undo] <Exit>: 

Press enter to complete the dimension. 

 

User can switch the object snap status (shortcut key F3) during the point selection. 

 

Example of "Two Point Dimension":  

Please be noted that the dimension line to be generated is on the connection line of P1 and P2. 

 

The following picture is the example of Two Point Dimension’ Wall Line Dimension. 

 

 

Example of "Two Point Dimension of Wall Center Dimension": 
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2.10.7 Internal Door Dimension 

Building Design→Dimension→Internal Door Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Dimension Mode: Base on Axis line. Specify two points across win-door, while the second point for dimension line. 

 

Start point or [A-wall segment length] <Exit>:  

Specify starting point on the other side of the win-door dimension or enter A to switch to "Wall Segment Length". 

 

End Point<Exit>: 

Specify ending point at the position of the dimension line. The connection line of the two points specified should 

cross the internal win-door to be dimensioned. 

 

Example of "Internal Door Dimension": 

The left picture below is the example of Internal Door Dimension based on Axis line. 

The right picture below is the example of Internal Door Dimension based on wall segment length. 

 

 

2.10.8 Quick Dimension 

Building Design→Dimension→Quick Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Select geometric patterns to add dimension: select the plane graph. 

 

Select geometric patterns to add dimension: select other objects or press enter to complete the selection. 

 

Please specify position of dimension line (Current dimension mode: Total) or [T-total/C-continuous/A-total plus 

continuous] <Exit>: 

 

When we select "T-total", the External Dimension will be created according to the total graph. 

When we select "C-continuous", the continuous line dimension will be created according to the object joint. 

When we select "A-total plus continuous", two dimension line with the distance of 8 mm will be created at the same 

time. 
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Example of "Quick Dimension’ External Dimension": 

Select total plane graph or part of it and use the default dimension mode: total. Then pull down and complete the 

External Dimension. User can enter T to add "Total plus Continuous" dimension line as follows: 

 

 

2.10.9 Stair Dimension 

Building Design→Dimension→Stair Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the stair to dimension<Exit>: 

User can dimension different part of the stair by taking the point at different position of it with cross cursor. 

 

Please determine dimension location<Exit>: 

Drag the dimension line and click at the position where you want it to be placed. 

 

Please select the stair to dimension<Exit>: 

Go on giving the other dimension point and press enter to exit. 

 

As shown in the following pictures, user can dimension different part of the stair by taking the point at different 

position of it with cross cursor, e.g., when we take point at railing, the dimension of the railing and the flight width 

will be created. If we take point at the landing on the other side, the dimension of landing width will be generated 

instead. 

 

Example of "Stair Dimension": 

The following picture shows the example of the dimension of Straight stair and U shaped stair. 
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2.10.10 External Dimension 

Building Design→Dimension→External Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select constructional link：After we give the first point, the command line will prompt: 

 

Specify opposite corner: 24 found 

After we give the opposite corner point, the command line will prompt "24 found". 

 

Please select constructional link: press enter to complete the selection. 

 

Please select first and second dimension line: 4 total 

 

Please select first and second dimension line: press enter to complete the drawing or go on selecting dimension 

line. 

 

Example of "External Dimension": 

Please refer to the following picture: execute the "External Dimension" command, frame select the opponent range, 

and select the first and the second dimension line. 

 

Press enter to complete the selection, and the "External Dimension" is complete as shown in the red box in the 

following picture. Please be noted that, with regard to the single bay, the second dimension line needs to be added 

manually. 
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2.10.11 Linear Dimension 

Building Design→Dimension→Linear Dimension 

 

Click the command in the menu, and the following dialog box will be displayed. The command has several 

dimension modes. First you have to select one of the dimension modes you need in the dialog box.  

 

1. Default Style (Drawing Unit-Dimension Unit): dimension unit determines the dimension style’s name, precision, 

scale factor (which depends on both the dimension unit and the drawing unit). 

 

2. Default Style (Scale Factor): dimension unit determines the dimension style’s name, precision. The scale factor 

needs to be entered manually. Besides the decimal, user can also enter fraction like 1/3, 1/1000. 

 

Under the mode of Default Style (Scale Factor), there is fix relation between the dimension style’s precision and the 

dimension unit as follows. The example of style name is as follows:  

 

When the dimension unit is mm and the scale factor is 5: the name of the dimension style would be A-DIM (5). The 

precision would be 0. 
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When the dimension unit is M and the scale factor is 5: the name of the dimension style would be A-DIM (5-M). 

The precision would be 0.00. 

 

3. "Directly select the style" mode: we do not have to set the dimension unit and scale factor, and we can directly 

select the dimension style from the existing dimension style list as shown in the red box in the following picture. 

 

4. Dimension view port mode: when we dimension the component in the view port under layout mode, the view port 

scale of the dimension style will be obtained from the view port object. 

 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Dimension 

Style: 

The default dimension style include Default Style (Drawing Unit-Dimension Unit) (like "A-DIM 

(mm-mm)" or "A-DIM (M-M)") and Default Style (Scale Factor) (like "A-DIM (0.5)"), user can 

directly select the dimension style from the existing dimension style pull-down list. 

Dimension 

Unit: 

User can select the predefined dimension unit: mm or m from the pull down list. When the unit mm 

is selected, the dimension will be integer. When the unit mm is selected, the dimension will be 

accurate to two decimal places. 

Scale Factor: 

It is the proportion of dimension to true size. When the dimension style is set as "Default Scale 

(Scale Factor)", user will have to input the scale factor by them self. E.g., supposing the drawing 

unit is mm, when the dimension unit is set as m, the scale factor should be 0.001. 

Select Block 

Scale Factor 

When we use the method of block zooming to active the multiple scales layout, the scale factor can 

be obtained from the zooming scale by selecting the related block, which is used to dimension the 

actual size of the block. 

 

The association status of the current dimension: User can enter D to switch the association’s turning on and off. 
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Start point or [Reference point(R)/Dimension associative on (D)] <Exit>: 

Pick the first dimension point as the starting point. 

 

Second Point<Exit>: 

Specify the second dimension point. 

 

Please pick the position for dimension line<Exit>: 

Drag the dimension line and position it by specifying a point. 

 

Please pick other dimension points or [Undo] <End>: 

Specify the dimension point by point. User can also enter U to cancel the operation in the last step. 

...... 

 

Please pick other dimension points or [Undo] <End>: 

Go on specify points or press enter to exit the command. 

 

Example of "Linear Dimension": 

Dimension architecture point by point as follows: 

 

 

Dimension road point by point as follows: 

 

Dimension the detailed drawing within the viewport under layout mode point by point as follows: 
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The drawing unit is M and dimension unit set in the dialog box is M. User can add "M" suffix after the width 

dimension by setting like this: click "Settings and helps>Settings>Config>Size Style" and enter "M" in the cell at 

the row "Linear Dimension(Bold Line)" and the column "Meter Suffix". 

 

2.10.12 Radius Dimension 

Building Design→Dimension→Radius Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select arcs needed to add dimensions<Exit>: 

Here please pick any point on the arc, and the radius dimension will be added to the drawing. 

 

2.10.13 Diameter Dimension 

Building Design→Dimension→Diameter Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select arcs needed to add dimensions<Exit>: 

Here please pick any point on the arc, and the Diameter Dimension will be added to the drawing. 

 

Example of "Radius Dimension" and "Diameter Dimension": 

Please be noted that when the radiuses are different, the position of the dimension text will be set automatically. 
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2.10.14 Angular Dimension 

Building Design→Dimension→Angular Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the first line<Exit>: 

Select the first line. 

 

Please select the second line<Exit>: 

Select the second line. 

 

Please determine dimension location<Exit>: 

Dynamically drag dimension between the interior exterior composed by the two lines to select the angle to be 

dimensioned, and then specify a point to determine the dimension position P3. Dimension boundary will start from 

the position point of the dimension. 

 

Example of "Angular Dimension": 

Please be noted that if you want to dimension the exterior angle, you only have to move the cursor to any position 

and preview the dimension effect when you are prompted to determine the dimension location. Then click to add 

dimension at the position you want.  

 

 

Grips of "Angular Dimension": 

User can adjust the position of the angular dimension and the length of the dimension boundary by dragging the 

grips of the angular dimension. 
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2.10.15 Arc Length Dimension 

Building Design→Dimension→Arc Length Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select curve segments to be added dimensions<Exit>: 

Select the arc wall or arc to be dimensioned. 

 

Please pick the position for dimension line<Exit>: 

Drag the dimension line to the position you want, which is similar to the linear dimension. 

 

Please pick other dimension points or [Undo] <End>: 

Go on select other arc length dimension point or enter U to cancel the previous one. 

...... 

 

Please pick other dimension points or [Undo] <End>: 

Press enter to complete the arc length dimension. 

 

Example of "Arc Length Dimension": 

 

 

2.10.16 Chord Length Dimension 

Building Design→Dimension→Chord length dimension 

 

The operation and function is same as Arc Length Dimension, please refer to the related example as shown in the 

following picture. 
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2.10.17 Reset Text Position 

Building Design→Dimension→Dimension Edit→Reset Text Position 

 

Click the command in the menu, and the command line will prompt: 

 

Please select text object need to reset: select GstarCAD Architecture dimension to be recovered. Multiple 

dimensions can be selected at the same time here. 

 

Please select text object need to reset: press enter to exit the command, and the system will recover all the text in 

the dimension selected to be in the initial position. 

 

2.10.18 Reset Text Value 

Building Design→Dimension→Dimension Edit→Reset Text Value 

 

Click the command in the menu, and the command line will prompt: 

 

Please select dimensions: select GstarCAD Architecture dimension to be recovered. Multiple dimensions can be 

selected at the same time here. 

 

Please select dimensions: press enter to exit the command, and the system will recover all the text in the dimension 

selected to the value measured actually. 

 

2.10.19 Trim and Extend 

Building Design→Dimension→Dimension Edit→Trim and Extend 

 

Click the command in the menu, and the command line will prompt: 

 

Start point or [Reference point] <Exit>: 

Pick a point at the position where the dimension is to be extended to or trimmed from. 

 

Please set the dimensional line for cutting and extending<Exit>: 

Pick point on one end of the dimension line to be trimmed or extended, and the related trim or extend operation will 

be completed. 
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Example of "Trim and Extend": 

Execute the "Trim and Extend" and use the "Extend" function to add external dimension. 

 

Execute the "Trim and Extend" and use the "Trim" function to add interior dimension. 

 

 

2.10.20 Remove Dimension 

Building Design→Dimension→Dimension Edit→Remove Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please specify a dimension bay to be removed<Exit>: 

Select the dimension text or dimension line in the dimension interval to be removed. 

 

Please specify a dimension bay to be removed<Exit>: 

Select other intervals to be removed or press enter to exit the command. 

 

 

2.10.21 Merge Dimension 

Building Design→Dimension→Dimension Edit→Merge Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select main dimensions<Exit>: 

Select the dimension line to be aligned with as the main dimension. 

...... 
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Select other dimensions to connect (shift-cancel mistaking selection) <End>: 

Select the other dimension line to be connected with.  The dimension lines can be either selected one by one or 

frame selected in batch. 

 

Select other dimensions to connect (shift-cancel mistaking selection) <End>: 

Press enter to exit. 

 

Example of "Merge Dimension": 

Execute the "Merge Dimension" command, and the result will be as follows: 

 

 

2.10.22 Dimension Break 

Building Design→Dimension→Dimension Edit→Dimension Break 

 

Click the command in the menu, and the command line will prompt: 

 

Please pick dimension line on the side needed to be broken<Exit>: 

Pick a point on the position where the dimension line is to be broken, and the dimension line will be broken. When 

selecting dimension line to preview, we can see the dimension line has been divided into two independent objects.  

 

Example of "Dimension Break": 

Execute the "Dimension Break" command to divide on dimension object into two dimension objects. We have to 

pick a point near the break position on the dimension line. The result will be as follows: 
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2.10.23 Bay Combine 

Building Design→Dimension→Dimension Edit→Bay Combine 

 

Click the command in the menu, and the command line will prompt: 

 

Please select bay to merge<Exit>: 

Box selected the dimension boundary between the bays to be merged with two corner point.  

 

Please select bay to merge<Exit>: 

Box selected other dimension boundary between the bays to be merged with two corner point.  

...... 

 

Example of "Bay Combine": 

Execute "Bay Combine" command and frame select dimension boundary arrow among three bays to combine them, 

and the result will be as follows: 

 

 

2.10.24 Bay Division 

Building Design→Dimension→Dimension Edit→Bay Division 

 

Click the command in the menu, and the command line will prompt: 

 

Please select dimension bay to be evenly divided<Exit>: 

Select the dimension line in the bay to be equally divided. 

 

Enter number of division<Exit>:6 

Enter the division quantity. 

 

Please select dimension bay to be evenly divided<Exit>: 

Go on executing the command or press enter to exit it. 

 

Example of "Bay Division": 

Execute "Bay Division" command to divide the bay into three segments, and the result will be as follows: 
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2.10.25 Equation Dimension 

Building Design→Dimension→Dimension Edit→Equation Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select dimension bay for equation dimension<Exit>: 

Select the bay dimension line to be dimensioned as Equation. 

 

Enter number of division<Exit>:5 

Enter equal division quantity as per the equation’s requirement. 

 

Please select dimension bay for equation dimension<Exit>: 

The dimension text in the bay will be displayed as equation. Press enter to exit the command. 

 

Example of "Equation Dimension": 

Execute "Equation Dimension" command to dimension the stair, and the result will be as follows: 

 

 

2.10.26 Equal Dimension Spacing 

Building Design→Dimension→Dimension Edit→Equal Dimension Spacing 

 

Click the command in the menu, and the command line will prompt: 

 

Please select reference dimension<Exit>: 

Select the dimension to be served as base point. During the "Equal Dimension Spacing", the reference dimension 

will keep still, and the position of other dimensions will be adjusted as per needs. 

 

Please select other dimensions: 

Select the other two dimension objects the spacing between which and the reference dimension is to be adjusted, 

during which both point selection and frame selection would be OK. 

 

Please select other dimensions: 

The prompt will be repeated until we press enter or space key to confirm. 

 

Please enter dimension spacing (size for plot) <8>: 

Enter the dimension spacing after print and press enter to exit the command. 

 

Note: 

1. The command only applies to the linear dimension. 
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2. In the step "Please Select Other Dimensions:", when we select multiple dimensions, the command will only 

handle dimensions in the same direction with the reference dimension. 

3. The command will save the last dimension spacing we used. 

4. With regard to the dimension spacing, we don’t have to take the scale into consideration and we just have to enter 

the dimension spacing after print. 

 

Execute the "Equal Dimension Spacing" command and select the reference dimension. Select the other two 

dimension objects the spacing between which and the reference dimension is to be adjusted, and the result will be 

as follows: 

 

 

2.10.27 Align Dimension 

Building Design→Dimension→Dimension Edit→Align Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please select reference dimension<Exit>: 

Select the dimension to be served as reference. Later we will regard its height as the standard for alignment. 

 

Choose other dimensions<Exit>: 

Select other dimensions to be aligned with the reference dimension. 

...... 

Choose other dimensions<Exit>: 

Press enter to exit the command. 

 

Example of "Align Dimension": 

Execute the "Align Dimension" command and select the reference dimension. And select other two dimensions to 

make them aligned with the reference dimension. The result will be as follows: 
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2.10.28 Subjoin Dimension 

Building Design→Dimension→Dimension Edit→Subjoin Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Pick the position for dimension points to be added or [Reference point] <Exit>: 

Select the dimension line segment to which the subjoining dimension is to be added. 

 

Please enter other dimension points or [Reference point/Undo] <End>: 

Snap and select the subjoining point or enter R to define reference point. 

 

If we enter R here, the command line will prompt: 

 

Reference point<End>: 

Pick the reference point, and specify the position line from the reference point. 

 

Pick the position for dimension points to be added or [Reference point] <Exit>: 

Enter accurate value to position the subjoining point along the position line. 

 

Pick the position for dimension points to be added or [Reference point] <Exit>: 

Continuously pick other subjoining point. The selection order makes no difference to the result. 

...... 

 

Pick the position for dimension points to be added or [Reference point] <Exit>: 

Finally, please press enter to exit the command. 

 

Example of "Subjoin Dimension": 

Execute "Subjoin Dimension" command to add the dimension, and the result will be as follows: 

 

 

2.10.29 Switch Angular Dimension 

Building Design→Dimension→Dimension Edit→Switch Angular Dimension 

 

Click the command in the menu, and the command line will prompt: 

 

Please angular dimension<Exit>: 

Click the angular dimension or chord dimension to convert it to other dimension mode. 
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Please angular dimension<Exit>: 

Press enter to exit the command. 

 

Example of "Switch Angular Dimension": 

Repeatedly execute the "Switch Angular Dimension" command to switch the three modes of dimension. The result is 

as follows: 

 

 

 

2.10.30 Dimension Convert 

The command is used to convert CAD dimension object to GstarCAD Architecture dimension object. 

 

Building Design→Dimension→Dimension Edit→Dimension Convert 

 

Click the command in the menu, and the command line will prompt: 

 

Please select CAD dimension: select multiple dimension at one time and press enter to convert them to GstarCAD 

Architecture dimension, after which the command line will prompt: 

 

0 cannot be converted, 1are converted successfully! 
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2.11 Symbol 

2.11.1 Elevation Dimension 

Building Design→Symbol→Elevation Dimension 

 

The functions of the "Vertical Elevation" and "Ground Elevation" are different. "Vertical Elevation" applies to elevation 

and section. The value of it is dynamically associative with the base elevation. When "Vertical Elevation" symbol 

moves along the y direction, the parameter will dynamically change. When "Base Elevation" moves along y direction 

or its value changes, the value of associative elevation will change accordingly. The "Vertical Elevation" dialog box 

is as follows: 

 

"Ground Elevation" applies to plans. It’s value will neither dynamically change with the position of the symbol nor 

changes according to the base elevation. The "Ground Elevation" dialog box is as follows: 

 

The styles of various elevations are as follows. We can use the mixture of symbols of base elevation, associative 

elevation and other elevations. 

 

Thus the command requires us to define the base elevation of the current drawing first. Select elevation style from 

the dialog box and check "Manually Input" check box, and then enter in the elevation bar the datum value that the 

base elevation represents. E.g., the frequently used datum elevation is 0.00 or known elevation design value. At this 

time the symbol of base elevation is displayed on the drawing, meanwhile, the command line will prompt: 
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Please select elevation dimension point in elevation<Exit>:  

Click the floor topping of the floor where the base elevation is located at. 

 

Please pick elevation direction<Exit>:  

Drag to select the direction of the elevation symbol to complete the definition of the base elevation. 

 

When we want to add associative elevation to the drawing where the base elevation already exists, the command 

line will prompt: 

 

Select datum elevation<Cancel>:  

Select the datum elevation to be associated with. As there might be multiple base elevations in the current DWG 

drawing, we have to select which one we intend to associate with. 

 

Please select elevation dimension point in elevation<Exit>:  

Select the position of the first elevation we are going to dimension. 

 

Please pick elevation direction<Exit>:  

Drag to select the direction of the elevation symbol so as to specify the direction of the elevation. 

 

Please pick the position of base line<Exit>:  

Drag to select the base line end point of the elevation symbol. 

 

Please specify next dimension point or [adjust direction and leader when adding Dimension (F)] drag the elevation 

symbol to give point at the next elevation position. The elevation value in the symbol will change with dragging. 

....... 

 

We can use "Multi-Floor Elevation" command to enter the multiple floor elevation with floor description. 

"Multi-Floor Elevation" is commonly used in ground elevation, it is also frequently used in the case that there 

are omitted floors in elevation or section. GstarCAD Architecture vertical elevation can be set as multi-floor style, 

and it can also be set as base elevation and associative elevation. When the base elevation is set as multi-floor style, 

the related associations are as follows：The associative elevation above it will be associated with the highest 

elevation number of the multi-floor elevation. The associative elevation under it will be associated with the lowest 

elevation number of the multi-floor elevation. For details please refer to the example 1. 

 

The explanation of the controls in the dialog box is as follows: 

Controls Functions 

Clear It is used to clear all the elevation data in the spreadsheet of multiple elevations. 

Accuracy: It is the parameter used to set the effective fractional digits of the elevation. 

Manually Input 

Check the checkbox, and the current vertical elevation can be entered manually. When it 

is unchecked, the elevation will be based on the position of the cross cursor. 

Auto Alignment The following elevation symbols are all in the same direction and vertically aligned. 

Base Elevation 

It is a group of vertical elevations’ reference datum with known elevation value in the 

drawing. It can also be the associative elevation associated with another base elevation.  

Associative It’s the vertical elevation associated with some base elevation. The ground elevation is not 
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Elevation associative elevation.   

Select Datum< 

It is used to specify the datum of the vertical elevation in the current drawing. After we 

specify the some point’s elevation as the base elevation, other elevations will be 

associated with the y coordinate of the object. Both moving the base elevation and 

moving the elevation associated with it will get the associative elevation updated 

automatically.    When we click the "Ground Elevation" radio button, the "Select 

Datum<"will not be available, which means the ground elevation is not associated with 

the base elevation. 

Equal Height 

 

Check the check box, and the heights of the floors within the range of the floor number 

will be the same. The related date can be added at the same time. When it is unchecked, 

we will have to add the different floor heights floor by floor. 

Add↑ 

When "Equal Height" is unchecked, "Add↑"button will be available. It is used to enter in 

the spreadsheet each floor’s elevation automatically calculated according to current initial 

elevation and floor number. 

Floor Number: 

We enter the floor number in order to add the elevation. Only when we enter the floor 

number larger than 1, can all the parameter of multi-floor elevations will be available. 

Floor 

Height(mm): 

This is the height of the floors whose floor number is entered in the "Floor Numbers" text 

box. 

Floor Number 

Style: 

In which user can select the commonly used floor number style like "None", "1F", "1/F" 

and so on. User can also enter other styles. 

Start Floor 

Number: 

The minimum floor number of a multi-floor elevation symbol. 

Text Alignment: 

It indicates the alignment relation between the elevation number and the elevation text 

baseline. 3 alignments are provided as "Align to Endpoint of Line", "Align to Start Point of 

Line" and "Center". 

Text Style: It is the text style used in the elevation dimension. 

Elevation with 

Bracket 

When it is checked, brackets will be added to the outside the elevation numbers of all the 

floors except for the first floor. 

Description with 

Bracket 

When it is checked, bracket will be added to the outside of the description of elevation. 

Leader Align to 

Description 

It is used to stipulate the alignment relation between elevation description and the leader. 

When it is checked, the end of the text base line will be aligned with the description. 

When we uncheck it, the description will be extended beyond the leader. 

Mirror Description 

When it is checked, the elevation description will be mirrored to the left side when we 

drag the elevation symbol’s leader to the left or mirror the elevation symbol to the left. 

When we uncheck it, the description will remain on the right side when we drag the 

elevation symbol’s leader to the left or mirror the elevation symbol to the left. 

In the elevation symbol, the triangle symbol is on the left. The elevation number is on top of the symbol. The 

description text is on the right of the elevation number by default.  The example of "Text Alignment" is as follows: 
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The effects of various combination of "Leader Align to Description" and "Mirror Description" are as follows: 

 

Edit of elevation object includes in-place edit, object edit and property bar edit. 

 

User can double click the elevation object to enter in-place edit mode, under which user can directly modify the 

elevation number as follows: 

 

To maintain the integrity of the object, the elevation text of multi-floor elevation can not be in-place edited. User can 

double click the common elevation and the multi-floor elevation to enter object edit mode, and modify the elevation 

text via spread sheet as follows: 

 

As shown in the following picture, we can also edit the elevation via grip edit function. User can drag the elevation 

object’s grip to modify the elevation symbol’s direction, text position as well as the multi-floor elevation’s column 

and row quantity. 
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The arrangement rule of the multi-floor elevation: if the multi-floor elevation is generated by "Equal Height" 

command, an up arrow grip will be provided. User can drag it to increase or decrease the floor quantity. If the 

multi-floor elevation object is not generated by "Equal Height" command and has multiple floor heights, there is no 

grip provided to modify the elevation floor quantity. As show in the right picture below, we must double click it to 

enter object edit mode so as to modify the floor quantity. 

 

 

Example of "Associative Elevation in Section with Multiple Floors": 

Suppose we wanted to dimension a section with elevation: 

 

1. Check "Base Elevation" and enter "7.2" for elevation in the first row of the spread sheet; Enter "3F" for floor 

No/Description; Check "Mirror Description"; and then click "With Baseline" icon. Dimension the section with base 

elevation. 

 

Here we are going to explain how to dimension the section with associative multi-floor elevation. Check "Base 

Elevation" and "Associative Elevation" at the same time; Check "Mirror Description"; click the icon "With Baseline" 

and "Auto Alignment"; Click "Detail" to expand the detail setting of  interface and check "Equal Height" in it; set the 

floor number as "3" and set Start Floor Number as "4"; Set the floor height as "3200". 

 

2. As per requirement, set "Floor Number Style:" as "1F". All the above operation continuously updated the data in 

the spreadsheet in the dialog box. 
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3. Operate as per the prompt in the command line as follows: 

 

Please select elevation dimension point in elevation<Exit>: 

Specify the position where the elevation is to be added. 

 

Please pick elevation direction<Exit>: 

Drag the elevation to make the elevation’s leader on the left. 

 

Please pick the position of base line<Exit>: 

Drag the base line to the dimension boundary. 

 

Please specify next dimension point or [adjust direction and leader when adding dimension (F)]: 

Press enter to complete the drawing of the associative multi-floor elevation. 

 

4. Finally, we have to dimension the section with an associative elevation with floor number. The vertical elevation 

will be complete as follows: 
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The elevation symbols of these floors are all associated together via associative base elevation and associative 

elevation. The elevation symbol filled with black color is associative elevation, in which the multi-floor elevation is 

both second-class base elevation and first-class associative elevation. The black color filled in the associative 

elevation and the base elevation is just for the recognizing proposes and will not be displayed when we print it out. 

 

Example of "Multi-Floor Ground Elevation": 

Suppose there’s a project, the heights of the basement and the 6 floors above ground are all 3.0 M, and they share a 

typical floor plan, in this case, we are about to add multi-floor elevation on the typical floor plan. 

 

1. Expand the "Detail" and in the "Detail" interface enter the start elevation of the first floor. (We can start from the 

negative elevation of the base room) "-3.0"; 

 

2. Set "Start Floor Number:" as "-1"; set "Floor Number" as "6"; set "Floor Height (mm):" as "Default-Height". 

 

3. As per needs, set "Floor Number Style" as "1F" and click "Add↑"button, and the elevation and the description 

will be completed in "-1F,1F,2F" order. 

 

4. As per needs, check the "Description with Bracket"; drag the elevation to the position of the dimension and click 

to place it. Please refer to the following picture. 

 

http://zhuanye.911cha.com/YXNmcXE=.html
http://zhuanye.911cha.com/YXNmcXE=.html
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2.11.2 Elevation Modify 

Building Design→Symbol→Elevation Modify 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

"Add/ Reduce" radio button determines whether to increase or decrease the elevation, which has nothing to do with 

the positive and negative of the number entered in the "Change Elevation Value(M):" text box. 

 

"Change Elevation Value (M):" elevation modification value (unit: m) should be entered here. The value can be either 

directly entered or specified by picking two points in the drawing.  

 

"Get Distance<" it is used to specify the elevation modification value by picking two points in the drawing.  

 

The command line’s prompt of Elevation Modify: 

 

Pick the object to modify its elevation<exit> 

Select the elevation object to be modified. Multiple elevation objects can be selected at the same time. Press enter 

to complete the selection and finish the modification. 

 

The command line’s prompt of "Get Distance<" 

 

Specify first point to indicate height change :< 6.480>: 

In the drawing specify two points used to obtain the elevation modification value.  

 

Specify second point: an elevation modification value will be returned and sent to the "Change Elevation Value (M):" 

text box. 

 

2.11.3 Elevation Inspect 

Building Design→Symbol→Elevation Inspect 

 

Click the command in the menu, and the command line will prompt: 

 

Select datum elevation<Exit>:  

Select the elevation symbol with correct value as the datum elevation. 

 

Select the elevation for inspection:  

Specify opposite corner: select other elevation symbols to be inspected. 

 

Select the elevation for inspection: 
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Press enter to complete the selection. The inspection result will be displayed. The first wrong elevation symbol will 

be in a red box. 

 

Selected elevation No. 5, 2 are wrong! 

 

No.2/1 wrong dimensions, correct dimensions (13.753) or [C-correct elevation/F-next one/X-exit] <correct all>: F 

Enter F to switch to the next wrong elevation symbol.  

 

NO.2/2wrong dimensions, correct dimensions (13.753) or [C-correct elevation/F-next one/X-exit] <correct all>: 

Press enter to revise the wrong elevation symbol according to the correct value. 

 

2.11.4 Elevation Align 

Building Design→Symbol→Elevation Align 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the elevation dimension to align or [reference alignment (Q)] <Exit>: 

Select multiple elevation objects to be aligned, or enter Q (with regard to this case, please refer to explanation 

below). 

 

Please select the elevation dimension to align or [reference alignment (Q)] <Exit>: 

Go on selecting or press enter to complete the selection. 

Please specify alignment point for elevation<Not change>: 

Drag the selected elevation objects and specify an alignment point to place it. And then right click the mouse or 

press enter or space key to exit the command. 

 

Please specify alignment point for elevation baseline<Not change>: 

If there’s an elevation object with baseline in the selected elevation objects, the alignment point of the base line 

also need to be specified as shown in the following picture. 

 

If we enter Q in the first step, the command line will prompt: 

 

Please select reference elevation dimension or [Free alignment (Q)] <Exit>: 
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Select an elevation object whose position is to be regarded as the reference position. Or enter Q to return to the 

above first command prompt. 

 

Please select the elevation dimension to align: 

Select other elevation objects to be aligned. 

 

Please select the elevation dimension to align: 

Go on selecting or press enter to complete the selection and finish the alignment. 

 

2.11.5 Arrow Leader 

Building Design→Symbol→Arrow Leader 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

In the dialog box, user can enter the text to be added at the end of the leader or at the top and bottom. The text 

history saved by the system can be selected from the pull-down list. 

 

Arrow leader can also be just the arrow without any text. In the dialog box there are also some functions used to 

modify the length and the style of the arrow. The length of the arrow is subject to the size of it on the final drawing. 

The unit of it is mm. The arrow style selectable includes: "Arrow", "Semi-Arrow", "Cross", "Point" and "None". 

 

In the dialog box enter the text to be added and set the parameter. Then operate according to the prompt in the 

command line: 

 

Next point of line segment or [A-arc segment/Undo] <Finish>: 

Specify the start point of the arrow. 

 

Next point of line segment or [A-arc segment/Undo] <Finish>: 

Draw the leader (straight line or arc line). 

 

Next point of line segment or [A-arc segment/Undo] <Finish>: 

Press enter to exit. 
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User can enter the in-place edit box by double clicking the text in the arrow leader, and user can modify text in this 

way. 

 

Example of "Arrow Leader" and "In-Place Edit": 

 

 

2.11.6 Multi Leader 

Building Design→Symbol→Multi leader 

 

Click the command in the menu, and the dialog box will be displayed: 

 

The explanation of the controls in the dialog box: 

 

[Superscript Text] place the text above the text baseline. 

 

[Subscript Text] place the text under the text baseline. 

 

[Arrow Style] there are four arrow styles selectable in the pull-down list: "Arrow", "Point", "Cross" and "None". 

 

[Text Height<] set the text height according to the size of the text in the final drawing or by specifying two points in 

the drawing. (The system will automatically perform the standard). 

 

[Text Style:] set the text style used in the multi leader. 

 

[Fixed Angle] it is used to set the fixed angle between the leaders. (The selectable range is from 0 to 90 degree) 

After it is checked, the angle of between the leaders won’t be changed when we drag the cursor. 
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[Multi-Point Collinear] if it is checked, when we add other dimension points, these leaders and the first leader will 

be collinear. It is used to dimension the material of the elevation and section. 

 

[Alignment of text with base line:] there are three text alignments: "Start", "Center" and "End". 

 

After the dimension content and the style in the dialog box has been set, please operate as per the prompt in the 

command line. 

 

Please specify the first point of dimension<Exit>: 

Specify the first point of the dimension leader. 

 

Enter leader position<Exit>: 

Specify the first point of the text base line. 

 

Select position of text base line<Exit>: 

Specify the end point of the text base line. 

...... 

Enter other dimension point<Finish>: 

Specify the end point of the second dimension leader. 

 

Enter other dimension point<Finish>: 

Press enter to exit. The result will be as follows: 

 

User can double click the multi leader object to enter the edit dialog box as follows: 

 

Unlike the above mentioned multi leader command dialog box, there’s an extra button "Add Mark Point<" in it, 

which is used to add leader and dimension points. 
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Example of "Editing Multi Leader": 

1. Multi leader object can also be easily edited by grips dragging. For example, the arrow or point will be 

automatically moved accordingly when we drag the dimension point. The text will be automatically moved 

accordingly when we drag the text base line. 

 

In addition, user can also double click the text in it to enter the in-place edit mode. 

 

2. All the dimension text above and under the multi leader object can use multi-line text. We have to enter the text in 

one line first. Then, we have to set the text style as multiline text in the property bar. Now we can drag the related 

grip to change the page width so as to convert the single line dimension text into multi-line text. 

 

 

2.11.7 Composing 

Building Design→Symbol→Composing 

 

Click the command in the menu, and the dialog box will be displayed: 
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The explanation of the controls in the dialog box: 

 

[Multi-line edit box] it is used to enter multi-line text. Each paragraph which we press enter to complete will be 

written on one base line. The text can automatically wrap with the decreasing of the text width. 

 

[Text On End] when the radio button is clicked, the text content dimension will be add to the end of the text baseline, 

which is commonly used in the architectural drawing. 

 

[Text in Line] when the radio button is clicked, the text content is to be added on the text baseline. And the text can 

automatically wrap according to the baseline length. It is commonly used in decoration drawing. 

 

[Dot Size:] When it is checked, multiple layers composing dimension can be generated. The additional prompt of 

"Please enter other dimension points<Exit>:" will be displayed in the command line. 

 

After finishing the editing of the dimension content and style in the dialog box, we can generate the dimension 

according to the prompt in the command line. 

 

Please specify the first point of dimension<Exit>: 

Click the end point P1 of the dimension leader. 

 

Please specify the second point of dimension<Exit>: 

Click the turning point P2 of the dimension leader. 

 

Please specify direction and length of text line<Exit>: 

Drag the text baseline and specify the end point P3 of it. 

 

When "Dot Size" is checked, the additional prompt of "Please Enter Other Dimension Points<Exit>:" will be 

displayed in the command line. 

 

Please enter other dimension points<Exit>: 

Go on selecting the points P4, P5 among the multiple layer dimension. 

 

Please enter other dimension points<Exit>: 

Select other points among the multiple layers dimension or press enter to begin to add another composing 

dimension. 

 

Example of "Detail Leader" and "Editing": 
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"Change Text Position" is used to modify start position of the dimension text. 

"Change Text Width" is used to modify the width range of the text. The text can automatically wrap with the 

decreasing of the text width. 

 

"Move (Delete) Dimension Point" it is used to modify the position of the leader dot. User can drag these grips to 

make the dots coincide with other dots so as to delete the extra dots. 

 

2.11.8 Index Symbol 

Building Design→Symbol→Index Symbol 

 

Click the command in the menu, and the following dialog box will be displayed: 

 

The controls in it are similar to those of the multi leader dialog box. The difference is the command can be 

classified into "Direction Index" and "Section Index". User can select one of them as per needs when generating the 

dimension. 

 

The new added "Alignment of Text with Base Line:" including 3 options: "Start", "Center" and "End", which is used to 

define the horizontal position of the Superscript Text and Subscript Text on the text baseline. Please refer to the 

following picture. 

 

When "Direction Index" radio button is clicked, the interaction in the command line will be as follows: 

 

Please specify index node position<Exit>: 

Pick the position where the index to be added. 

 

If we check the "Add Index Range", the following prompt will be displayed: 

 

Please specify index node range<0.0>: 

Drag one point on the circle and click at the proper position to define the range or press enter to switch to the next 

step instead of specifying the range. 
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Please specify line node position<Exit>: 

Drag the leader and specify the turning point of it. 

 

Please specify position of index label<Exit>: 

Specify the circle center to insert the index label. 

 

When "Section Index" radio button is clicked, the interaction in the command line will be as follows: 

 

Please specify index node position<Exit>: 

Pick the position where the index to be added. 

 

Please specify line node position<Exit>: 

Press F8 to turn on the ORTHO mode, drag the leader and specify the turning point of it. 

 

Please specify position of index label<Exit>: 

Specify the circle center to insert the index label. 

 

Please specify direction of section view<Current>: 

Drag the leader and specify the point so as to define the direction of the section view. 

 

User can double click the index symbol object to enter object edit dialog box. User can also double click the text in 

the index symbol to enter the in-place edit mode. There’s a new added side grip "Modify Index Number", user can 

drag it to increase or decrease the quantity of the index. (Drag outward to increase). In the case that there are more 

than two indexes, user can drag the index to the left to make it coincide with the other index so as to delete it. User 

can double click the text in the new added index symbol to modify the content of it. 

 

Example of "Index Symbol" and "Editing": 

The examples of "Direction Index" and "Section Index" and the editing of them are as shown in the following picture. 
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2.11.9 View Symbol 

Building Design→Symbol→View Symbol 

 

View Symbol can be classified into "Viewport Index" and "Viewport Number". Click the command in the menu, and 

the dialog box as well as the symbol object created will be displayed as follows. If the Drawing No is blank or "-", 

the blank position will be reserved. 
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As shown in the above picture, when we check "Viewport Index", we can draw viewport index like this. The feature of 

it is only one arrow direction is provided. The Viewport Index can index content with any viewport number on other 

drawings with any sheet number. If the tag or Drawing No is blank, the blank text area will be provided for user to 

add text in it in the future. 

 

 

As shown in the above picture, when we check "Viewport Number", we can draw Viewport Number like this. The 

feature of it is multiple arrow directions are provided. It can be used to index multiple viewport direction at the same 

time. It is commonly used in the interior design plans. When we only add text for one or two arrow direction, it will 

automatically change into single side or double sides view symbol. 

 

Drawing No.: the sheet number of the drawing indexed. If it is "-" or blank, it means the detail drawing indexed is in 

the current drawing. 

 

Tag: the number of the drawing indexed. The default value of it is 1-9 or A-D. 

 

Text Style: there are several predefined text styles selectable for symbol dimension. 

 

Fix Angle: when it is checked, the angle of the view symbol created will be fixed as the angle entered. When it is 

unchecked, user has to drag and rotate the view symbol created to adjusting its angle after inserting it in the 

drawing. 

 

Top, Down, Left, Right: the four pull-down lists are used to enter the number for four directions. 

Generally, the "Viewport Number" applies to the index for at least 2 directions, while the "Viewport Index" applies to 

the index for single direction. 
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After creating the view symbol, user can double click it to enter the object edit dialog box, in which user can edit or 

modify the parameter like tag, drawing No and so on. User can also drag the side grip to rotate the angle of it as well 

as drag the center grip to move it. 

 

2.11.10 Title Index 

Building Design→Symbol→Title Index 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

 

Title Index: the sheet number of the drawing indexed. If it is "-" or blank, it means the detail drawing indexed is in 

the current drawing. 

 

Index Tag: the number of the drawing indexed. The default value of it is 1. 

 

Scale: 1:20 user can enter the scale of the detail drawing here or enter "-" so as not to draw the scale of the detail 

drawing. If we uncheck it, the scale will not be added. 

 

Text Style: we can set the Text Style for the Index Tag and the Title Index via the text style box at the left bottom of 

the dialog box, and we can set the text style for the scale independently via the text style box at the right bottom of 

the dialog box. 

 

The meaning of the content in the title index object is as follows: 
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The grips of the title index object are as follows. User can drag the grips to move the title position and modify the 

position of the scale. 

 

The interaction in the command line will be as follows: 

 

Please select dimension position<Exit>: 

Specify a point to determine the position of the title index.  

Double click an exiting title index, and the dialog box will be displayed as follows: 

 

 

2.11.11 Section Symbol 

Building Design→Symbol→Section Symbol 

 

Click the command in the menu, and the dialog box will be displayed:  

 

 

In the tool bar from left to right, there are four drawing method of section symbol: "Draw Straight Wall", "Orthogonal 

Turning Section", "Draw Arc Wall" and "Draw Rectangle Wall". When "Section Drawing NO." is checked, section 

drawing NO related to the section drawing indexed by the section symbol will be added to the section symbol. 

Dimension Location has three options selectable: "Both Ends", "Start Point" and "End Point". Dimension Direction 

has two options selectable: "Along Cut Position Line" and "Along Section Direction Line" as shown in the following 

picture. 
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1. Orthogonal Turning Section 

 

Click the icon of "Orthogonal Turning Section", and the command line will prompt: 

 

Select the first cutting point<Exit>: 

Specify the first point P1. 

 

Select the second cutting point<Exit>: 

Specify the second point P2 along the section line. 

 

Select next cut point<Finish>: 

Specify the second point P3 along the section line. 

 

Select next cut point<Finish>: 

Specify the end point P4. 

 

Select next cut point<Finish>: 

Press enter to exit. 

 

The directions of the start point and the end point of the section symbol should be the same, in case of "Orthogonal 

Turning Section"; the turning position must include two points. Thus, the point that can not meet such requirement 

will be deleted. 

 

Select Section View Direction<Current>: 

Specify point P5 to determine the section view direction. 

 

2. Non-Orthogonal Section 

 

Click the icon of "Non-Orthogonal Section", and the command line will prompt: 
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Select the first cutting point<Exit>: 

Specify the first point P1. 

 

Select the second cutting point<Exit>: 

Specify the second point P2 (turning point) along the section line. 

 

Select next cut point<Finish>: 

Drag the section line and specify the third point P3 as per the turning direction required. 

 

Select Section View Direction<Current>: 

Specify point P4 to determine the section view direction. 

 

Click the icon of "Draw Rectangle Wall", and the command line will prompt: 

 

Select the first cutting point<Exit>: 

Specify the start point P1. 

 

Select the second cutting point<Exit>: 

Specify the end point P2 along the section line. 

 

Select Section View Direction<Current>: 

Specify point P3 to determine the section view direction. 

 

We can preview the symbol between the two points. Move the mouse to modify the direction or just use the current 

default direction by clicking the mouse or pressing enter, and then the dimension of the section symbol will be 

completed. 

 

Examples of "Draw Straight Wall" and "Orthogonal Turning Section": 
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Example of "Draw Arc Wall": 

 

 

Example of "Draw Rectangle Wall": 

 

After the section symbol dimension is completed, user can drag the related grip to modify the position and the 

section view direction of the section symbol. User can also double click the section symbol to enter the object edit 

dialog box so as to modify the section symbol. Please refer to the following picture: 
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2.11.12 Draw Cloud Line 

Building Design→Symbol→Draw Cloud Line 

 

Click the command in the menu, and the dialog box will be displayed: 

 

Check the check box of Number of Edition, and the prompt of "Please Set Location for Version Mark" will be 

displayed in the command line. Please refer to the following picture. 

 

In the dialog box, please select the cloud line style from the two options: "Common" and "Sketch". The sketch cloud 

line is much more eye-catching, but it will consume more graphics resources. 

 

Select the proper parameter in the dialog box and select one of the four cloud line drawing method from the tool bar. 

Here we will introduce the execution of each of the case respectively. 

 

The command line’s prompt of "Rectangular Cloud Line": 

 

Please specify first corner point<Exit>: 

Specify the left bottom corner point of the rectangular cloud line or exit the command by Right clicking the mouse 

or pressing enter or space. 

 

Please specify another corner point<Exit>: 

Specify the right top corner point of the rectangular cloud line or exit the command by Right clicking the mouse or 

pressing enter or space. 

 

Please the location for version mark<Cancel>: 

Check the check box of Number of Edition, and the prompt of "Please Set Location for Version Mark" will be 

displayed in the command line. User has to specify a point to place the triangle shaped version mark. 

 

The command line’s prompt of "Circular Cloud Line": 

 

Please specify center of circular cloud line <Exit>: 
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Specify the circle center of the circular cloud line or exit the command by Right clicking the mouse or pressing 

enter or space. 

 

Please specify radius of circular cloud line <Exit>: 

Drag the leader to specify a point or enter the radius of the circular cloud line. Then the cloud line will be drawn as 

per the parameter in the dialog box. 

 

Please the location for version mark<Cancel>: 

Check the check box of Number of Edition, and the prompt of "Please Set Location for Version Mark" will be 

displayed in the command line. User has to specify a point to place the triangle shaped version mark. 

 

The command line’s prompt of "Draw": 

 

Specify Start Point<Exit>: 

Specify a start point of the cloud line. 

 

Lead Cross Cursor along Cloud Path... drag the cross cursor to draw the cloud line. Specify a point near the position 

where the cloud line is to be closed, and the command will automatically close the cloud line. 

 

Please be noted that here we have to neither click the start point of the cloud line again nor right click the mouse. 

We can complete the drawing of the cloud line just by left clicking to specify a point. 

 

Please the location for version mark<Cancel>: 

Check the check box of Number of Edition, and the prompt of "Please Set Location for Version Mark" will be 

displayed in the command line. User has to specify a point to place the triangle shaped version mark. 

 

The command line’s prompt of "Select Existing Object to Generate": 

 

Please select the closed object to convert to cloud line<Exit>: 

Specify the closed object by clicking the curve line like closed circle, closed pline and so on or exit the command 

by Right clicking the mouse or pressing enter or space. 

 

Please the location for version mark<Cancel>: 

Check the check box of Number of Edition, and the prompt of "Please Set Location for Version Mark" will be 

displayed in the command line. User has to specify a point to place the triangle shaped version mark. 

 

2.11.13 Break Line 

Building Design→Symbol→Break line 

 

Click the command in the menu, and the dialog box will be displayed. In the tool bar from left to right, there are four 

methods for the break line drawing: "Single Break Line", "Double Break Line", "Rectangular Cut Line", "Polygon 

Shaped Cut Line". 
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Example of "Break line": 

 

"Single Break Line" mode has two types: "Auto Cut" and "Static". "Auto Cut" will hide the object on one side of the 

break line as follows. 

 

The interaction in the command line is as follows: 

 

Specify break line start point<Exit>: 

Specify the start point P1; 

 

Specify break line endpoint<Exit>:  

Specify the end point P2. Then the line joining P1 and P2 will be drawn as the break line. And both ends of the 

break line will extend beyond the object as per the Extension Length specified in the dialog box. (Extension Length 

in this example is 3MM). 

 

If "Static" is selected, the command will draw break line and return to the first step. If "Auto Cut" is selected, the 

following command prompt will be displayed. 

 

Please specify which side to auto cut<Exit>: 

Give a point P3 on the side where the object will be hidden. Then the break line will be drawn.  And the object on 

P3 side of the break line will be hidden. 

 

Specify break line start point<Exit>: 

Press enter to complete the drawing of the break line. 
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"Double Break Line" mode also has two types: "Auto Cut" and "Static". "Auto Cut" will hide the object between the 

two break lines. "Double Break Line" has two styles: "Single Line" and "Double Line". User can set the style of the 

double break line in "Settings and Helps / Settings /Config /Advance Option/ Entity /Cut Symbol/Double Break Line 

Style". 

 

The single line style of the double break line is as shown in the following picture. 

 

After the above mentioned style is changed, the double break line to be drawn later will be influenced. The existing 

double break lines will be updated to the current style. When the style is set as double line, the effect of double 

break line in the above picture will change as follows: 

 

The interaction in the command line is as follows: 

 

Specify break line start point<Exit>: 

Specify the start point P1. 

 

Specify break line endpoint<Exit>:  

Specify the endpoint P2. Then the line joining P1 and P2 will be drawn as the break line. And both ends of the break 

line will extend beyond the object as per the Extension Length specified in the dialog box. (Extension Length in this 

example is 3MM). 

 

Specify break line start point<Exit>: 

Press enter to complete the drawing of the break line. 
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The difference between "Auto Cut" and "Static" is whether to display the object between the double break lines. The 

default selection is "Auto Cut". In this case, the object between the double break lines will not be displayed. 

 

"Rectangular Cut Line" mode: user can select "Cut Internal" to hide the object part within the rectangular cut line as 

follows: 

 

User can also select "Cut External" to hide the object part out side the rectangular cut line as follows: 

 

The interaction in the command line is as follows: 

 

Specify break line start point<Exit>: 

Specify the start point P1. 

 

Specify break line endpoint<Exit>:  

Specify the endpoint P2. Then the line joining P1 and P2 will be drawn as the break line. 



Chapter 2 Function of Architectural Design 

313 

 

Please determine the reserved region<Exit>: 

Drag the rectangular shaped cutting range and specify a point P3 at proper position. The command will hide the 

object part within or out side the break line as per the cut way set in the dialog box. 

 

Specify break line start point<Exit>: 

Press enter to complete the drawing of the break line. 

 

The dialog box of polygon shaped cut line is shown as the picture above. In this case, the break line will not be 

drawn. 

 

user can either select "Cut Internal" to hide the object part within the polygon shaped cut line or select  "Cut 

External" to hide the object part out side the rectangular cut line as follows: 

After the execution of the command, if there are some extra objects out side the reserve range, it means this object 

exits independently and has no relation with the cutting range, user can directly delete them.   

 

The interaction in the command line is as follows: 

 

Please define cut boundary by selecting polyline :< Exit> 

Select the polygon composed of pline, and the dialog box will be displayed as follows: 
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The dialog box will be displayed as above. In it user can select "Cut Exterior"; User can also click "Set Break 

Border<" or set the border specified as the break line; We can click "Set No print Border<" to recover the break 

border back to the no printing border; We can also click "Set Break Point<" to add break symbol to the specified 

position so as to define a segment of break line. User can check "Hide Nonprinting Border" to hide the no break 

border so as not to interrupt the drawing (even if it is not checked, the no printing border will not be printed 

out).When all the border is set as no-printing border and the "Hide Nonprinting Border" is checked, four or more 

selectable no-printing points will be reserved. Then click OK button to complete the operation. 

 

When we want to modify the polygon shaped cut line, we can double click the cut line or the no printing point to 

enter object edit dialog box. 

 

Example of "Editing Cut Line Object": 

 

 

2.11.14 Symmetry Axis 

Building Design→Symbol→Symmetry Axis 

 

Click the command in the menu, and the command line will prompt: 

 

Start point or [Reference point] <Exit>: 

Specify the end point 1 of the symmetry axis. 

 

End Point<Exit>: 

Specify the end point 2 of the symmetry axis. 

 

We can drag the grips on the symmetry axis to modify its geometric parameter including length, end line length, 

inner spacing and so on. 
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2.11.15 Compass 

Building Design→Symbol→Compass 

 

Click the command in the menu, and the command line will prompt: 

 

North Arrow Position<Exit>: 

Specify the insert point of the compass. 

 

North Arrow Direction<90.0>: 

Drag the cursor or enter to angle to define the direction of the compass. The positive direction of x coordinate axis is 

0. 

 

The default direction of the compass and the character "N" is aligned with the upward direction of the current UCS. 

The character "N" is the component of the compass object. The size of it can be automatically adjusted as per the 

current scale. 

 

2.11.16 Title Mark 

Building Design→Symbol→Title Mark 

 

Click the command in the menu, and the dialog box will be displayed: 

 

Title Mark dialog box under the unit of mm. 
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Title Mark dialog box under the unit of m. 

 

Edit the drawing name in the dialog box and select the suitable style of it. Then add the title to the drawing 

according to the prompt in the command line. The distance between the drawing name and the scale can be 

adjusted by modifying the "Distance Factor" in the property bar. The factor indicates the multiple of the text height of 

the drawing name. 

 

The command supports the drawing with unit of m. We just have to add the correct drawing scale dimension 

according to the current unit, and the pull-down list of scale will provide the related scale series according to the 

different drawing unit. 

 

The scale in the drawing name is the current scale by default. If we do not want the scale to be influenced by the 

current scale, (e.g., add unified drawing name dimension to multiple detail drawings), we can check the "Record 

Scale" to make the dialog box remember the scale entered. 

 

Double click the title mark object to enter the dialog box, in which we can modify the setting of the style. Double 

click the drawing name text or scale text to enter the in-place edit mode, under which we can edit and modify the 

text. The grip for moving the title mark is set in the middle of it, which enable us to move it easily. 

 

Example of "Title Mark": 

The following picture shows two styles of Title Mark and the grip editing of them. When we drag the grip of "Move 

Scale Position", the scale and the drawing name will be moved in opposite directions away from the center. The 

result of dragging the grip of "Move Scale Position" is as shown in the right picture below. 
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2.12 Site Plan Design 

2.12.1 Draw Road 

"Draw Road" function is used to draw road in the site plan according to the current drawing unit (mm or m). The 

command can draw the residential road with road center line and specified chamfer radium. 

 

Building Design→Site Plan Design→Draw Road 

 

Click the command in the menu, and the dialog box will be displayed as follows. (The current drawing unit is 

"mm"). 

 

Click the command in the menu, and the dialog box will be displayed as follows. (The current drawing unit is "m"). 

 

Enter parameters in the dialog box, and the command line will prompt: 

 

Please specify road start point<Exit>: 

Specify the first point of the road baseline. 

 

Please specify the next point of road or [Arc road (A)] <Exit>: 

Specify the next point of the road baseline, or input option keyword and press enter. 

...... 

Please specify the next point of road or [Arc road (A)/retUrn (U)/Closed(C)] <Exit>: 

Go on specifying other points or press enter to exit. 

 

Please specify the next point of road or [Arc road (A)/retUrn (U)/Closed(C)] <Exit>: A 

Enter "A" to draw arc road. 

 

Please specify the next point of road or [Line road (L)/retUrn (U)] <Exit>: 

Specify the endpoint of the baseline of the arc road. 
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Middle Point in Arc Road<Exit>: 

Specify a point in the arc road. 

 

Please specify the next point of road or [Line road (L)/retUrn (U)] <Exit>: 

Specify the endpoint of the next arc road. When the drawing of arc road is compete, we can press L to switch back 

to straight road drawing mode. We can also press enter to exit the command. 

 

If the road being drawn is intersected or connected with existing road, the related wall will automatically be broken, 

connected and cleaned as follows: 

 

 

2.12.2 Road Chamfer 

Building Design→Site Plan Design→Road Chamfer 

 

Click the command in the menu, and the command line will prompt: 

 

Please box select road segments for chamfer or [chamfer by same radius (Q), current: concentric circles/chamfer 

Radius(R), current: R=5000.00] <Exit>: 

Specify two points to frame select multiple intersections to be converted into chamfer with same circle center. 

 

Please box select road segments for chamfer or [chamfer by concentric circles (Q), current: same radius/chamfer 

Radius(R), current: R=5000.00] <Exit>: Q 

Enter Q to switch to "same radius" chamfer mode. 

 

Please box select road segments for chamfer or [chamfer by concentric circles (Q), current: same radius/chamfer 

Radius(R), current: R=5000.00] <Exit>: 

Specify two points to frame select multiple intersections to be converted into chamfer with same radius. 

 

Please box select road segments for chamfer or [chamfer by concentric circles (Q), current: same radius/chamfer 

Radius(R), current: R=5000.00] <Exit>: 

Press enter to exit. 

 

As shown in the following picture, the shapes of the roads selected have been converted into chamfers. The 

dimensions in it were added later. 
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Note: At the turning of the road, the system will calculate the outer turning radius according to the inner radium so 

as to convert the shape of the turning into chamfer.  

 

2.12.3 Road Elevation 

Building Design→Site Plan Design→Road Elevation 

 

Click the command in the menu, and the command line will prompt: 

 

Please select datum elevation<Exit>: 

In the road select an existing first elevation object in the road as the datum elevation. 

 

Example of "Road Elevation Determined by Two Points": 

Please select second elevation or [enter slope (W)/Revise elevation(R)] <Exit>: 

In the road select another existing elevation object as the second datum elevation or enter W to input the slope. 

 

Please select baseline: select the road’s center line as the datum line. 

 

Please click to determine position<Exit>: 

Drag the cursor along the datum line. Specify a point to add the elevation to the place where the dimension is 

required. Please refer to the following picture. 

 

 

Example of "Road Elevation Determined by One Point and Slope": 

Please select second elevation or [enter slope (W)/Revise elevation(R)] <Exit>: W 

Enter W and prepare to input the slope value. 

 

Please enter slope value (positive value for upslope) (%) <0>:10 

If the value entered is positive, it means the elevation of the following given dimension point will be higher than the 

datum elevation. If the value entered is negative, it means the elevation of the following dimension point will be 

lower than the datum elevation. Please refer to the following picture. 
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Please select baseline: operation here is similar to that of the command of "The Road Elevation Determined by Two 

Points". 

 

Example of "Revise Existing Road Elevation": 

Please select datum elevation<Exit>: 

Select an elevation object as the datum elevation. 

 

Please select second elevation or [enter slope (W)/Revise elevation(R)] <Exit>: R 

Enter R and prepare to revise the existing road elevation. 

 

Please select fixed elevation<Exit>: 

Select the road elevation that will remain unchanged. 

 

Please select the elevation to modify<Exit>: 

Select the elevations to be revised. 

 

Please select baseline: 

Select the center line of the road as the baseline. 

 

2.12.4 Road Slope 

Building Design→Site Plan Design→Road Slope 

 

Click the command in the menu, and the command line will prompt: 

 

Select two road elevations to auto dimension or [manual Dimension (D)/sEt precision (E)] <Exit>: 

Select two adjacent elevations. 

 

Example of "Select Two Road Elevations to Auto Dimension": 

Select two road elevations to auto dimension or [manual Dimension (D)/sEt precision (E)] <Exit>: 

Press enter to complete the selection of the elevations. 

 

Please select baseline: 

Select the center line of the road. If there is no baseline, please press enter. Then the command line will regard line 

of the two elevations selected as the baseline. 

 

Determine Dimension Position: 

Drag the cursor along the baseline and specify a point to add the slope symbol. Please refer to the following picture. 

 

Select two road elevations to auto dimension or [manual Dimension (D)/sEt precision (E)] <Exit>: 
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Go on adding the slope symbol elsewhere or press enter to exit the command. 

 

Example of "Manual Dimension": 

 

Select two road elevations to auto dimension or [manual Dimension (D)/sEt precision (E)] <Exit>: D  

Enter D to select the option of "Manual Dimension". 

 

Specify the location to indicate road slope<Auto dimension>: 

Drag the cursor and specify a point where the slope symbol is to be added. 

 

Determine Dimension Direction: specify the slope arrow direction according to the cursor preview drawn from the 

slope position. 

 

Please enter road slope (%) <27.33%>:0.03  

Enter the slope. (The slope value should be expressed as percentage, e.g. we should enter 2.5 for 2.5%). 

 

Please enter road slope length (M) <36.57>:23.1 

Enter the slope length value. 

 

 

2.12.5 General Legend 

Building Design→Site Plan Design→General Legend 

 

Click the command in the menu, and the dialog box will be displayed. Select the existing general legend in it. We 

can also drag to arrange the order of the inserted legend. 
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In the list on the left of the legend dialog box, there are many already established General Legend blocks. We can 

select the name of the legend and click "Add>>" button to add the legend to the right list, which is the legend list 

to be inserted in the current drawing. Select some item in the drawing sample list and click "Delete<<" button, and 

the item can be deleted from the list. 

 

After the legend selection is finished, please pay attention to the command interaction: 

 

Specify sample location or [change base point (T)] <Exit>: 

Drag the base point and insert the legend in the drawing. The base point is at the center of the character "Legend" by 

default.  

 

When we enter T in the previous step, the command line will prompt: 

 

Enter Insertion Point or [Reference point] <Exit>: 

Click any position of the drawing to redefine the inserting point of the legend. 

 

Specify sample location or [change base point (T)] <Exit>: 

Drag the base point and insert the legend as follows. 

 

 

2.12.6 Parking Arrange 

Building Design→Site Plan Design→Parking Arrange 

 

Click the command in the menu, and the dialog box will be displayed as follows (The current drawing unit is mm). 

 

Click the command in the menu, and the dialog box will be displayed as follows (The current drawing unit is m). 
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After we set the parking parameters in the dialog box, we can draw the rectangular parking consisting of Pline 

according to the interaction in the command line without closing the dialog box.  

 

When the parking width is less than the parking depth, the parking will be arranged broad wise. When the parking 

width is larger than the parking depth, the parking will be arranged endwise. 

 

The parking width and the parking depth can be exchanged by click the "Exchange" button.  

 

As shown in the following picture, parking Style includes: "No Oblique Line", "Single Oblique Line", "Double Oblique 

Line" and "Car Model".  

 

The command line interaction is as follows: 

 

Please specify parking start point or [Arrange along curve (A)] <Exit>: 

Enter A, if the Parking Row style is "Single Row", the command line will prompt: 

 

Please select curve (line, arc, or polyline) <Exit>: 

Only by clicking can we select the object. We can also right click the mouse to return to the previous step. 

 

Please specify the parking side<Exit>: 

Click the side where the parking is to be added, and the parking will be generated, before which we can also right 

click the mouse to return to the previous step. 

 

Please specify parking start point or [Arrange along curve (A)] <Exit>: A 
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Enter A, if the Parking Row style is "Double Row", the command line will prompt: 

 

Please select curve (line, arc, or polyline) <Exit>: 

Only by clicking can we select the object. We can also right click the mouse to return to the previous step. The 

parking will be equidistantly generated on both sides of the baseline. 

 

2.12.7 Coordinate Dimension 

The command is mainly used to add survey coordinate or construction coordinate on the site plan. Here please pay 

attention to the direction of the coordinates:  x coordinate will be created as per vertical direction (north-south 

direction), and y coordinate will be created as per horizontal direction (East-west direction). 

 

The coordinate object added has the property of dynamical association: 1 when the datum coordinate object is 

moved, all the coordinate objects based on the datum coordinate will be updated automatically and dynamically. 2 

When the coordinate object is moved, the coordinate value of itself will be updated automatically and dynamically. 

 

GstarCAD Architecture allows us to create multiple independent datum coordinates, in other words, the command 

support multiple independent coordinate systems, which can be switched over between each other at will. 

 

Building Design→Site Plan Design→Coordinate Dimension 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

The operation process of the "Coordinate Dimension" command 

 

1. Add datum coordinate, insert a coordinate object according to the "Point of Land Boundary Line" given by the 

survey company and set the coordinate value of the point as the datum coordinate. 

 

2. Add the coordinates for other points according to the datum coordinate. 

 

Note: If multiple coordinate systems need to be created, user can switch current coordinate system by creating 

datum coordinate or selecting datum coordinate. User can distinguish different coordinate systems via arrow styles. 

 

2.12.7.1 Ordinary Coordinate 
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According to the current datum coordinate, specify each point where the coordinate dimension is to be added. (If 

we haven’t yet defined datum coordinate currently, the command will automatically switch to "Datum Coordinate"). 

The command line will prompt: 

 

Current drawing unit: mm 

 

Please enter coordinate dimension point or [enter location dimension point for coordinates (A)] <Exit>: 

Specify the point where the coordinate dimension is to be added (or enter option A). 

 

Please specify coordinate dimension direction<Exit>:  

Drag the cursor to define the direction of the leader and specify the endpoint of the dimension leader. 

 

If we select option A in the above command line, the coordinate can be entered by keyboard. 

 

Please enter coordinate dimension point or [enter location dimension point for coordinates (A)] <Exit>: A 

Enter option A and input the coordinate value to obtain the coordinate point. 

 

Please enter measured coordinates or [coordinates picked up on drawing (A)]: 2307435.257, 2497379.950 

Enter the measured coordinate and press enter, and the leader of the coordinate symbol leader of the related point 

will be displayed on the drawing. 

 

Please specify coordinate dimension direction<Exit>: 

Drag the cursor to define the direction of the leader and specify the endpoint of the dimension leader to complete 

the drawing of the coordinate. 

 

Besides entering the coordinate value by keyboard, we can also select option A in the above command line and 

select the single line text obtained by measurement to complete the coordinate entering. The command line 

interaction is as follows:  

 

Please enter measured coordinates or [coordinates picked up on drawing (A)]: A   

Enter A here and prepare to select the data. The existing single line text data in the drawing is as follows: 

 

Please pick up data for measured value on drawing(X coordinates): 

Select the single line text representing X coordinate data. 

 

Please pick up data for measured value on drawing(Y coordinates): 
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Select the single line text representing Y coordinate data. 

 

Please specify coordinate dimension direction<Exit>:  

Drag the cursor to define the direction of the leader and specify the endpoint of the dimension leader to complete 

the drawing of the coordinate. 

 

2.12.7.2 Batch Dimension Ordinary Coordinate 

 

"Batch Dimension Ordinary Coordinate" dialog box is as follows: 

 

 

1. In the dialog box check the feature points to which the batch dimensions need to be added. 

 

Meanwhile the command line will prompt: 

 

Current drawing unit: mm 

 

Please enter coordinate dimension point or [enter location dimension point for coordinates (A)] <Exit>: 

 

Please select the object to dimension its coordinates<Exit>: 

Specified opposite corner: N found, press enter to complete the selection. 

 

Please select the object to dimension its coordinates<Exit>: 

Press enter to exit the command. 

...... 
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2. After we check "Only Mark Layer", the "Pick<"button and the edit box will become available, in this case, only the 

feature points on the specified layer can be selected. 

Only these effective points will be used for batch coordinates creation. 

Click "Pick<"button and the command line will prompt: 

 

Please select object<Return>: 

Select the center line of the road and the line on the 0 layer. 

 

3. In this case, only the line segments on "0" layer and the center line of the road as well as the "Vertex of Polyline", 

"Intersection Point" and "Center" between them are the effective feature point. The points on other layers will not be 

regarded as effective feature points. Only these effective points will be used for batch coordinates creation. The layer 

name will be displayed in the edit box as follows. 

 

 

2.12.7.3 Datum Coordinate 

Insert a coordinate object according to the "Point of Land Boundary Line" given by the survey company and set the 

coordinate value of the point as the datum coordinate. 

 

Current drawing unit: mm 

 

Please specify datum coordinate dimension point<Exit>: 

Specify the point where the datum coordinate is to be created. Generally, it is the "Point of Land Boundary Line" with 

accurate coordinate value. 

 

Please enter north direction angle or [select compass (A)] <90>: 

It is determined by the north direction angle defined by the drawing. 

 

Please specify datum coordinate dimension position<Exit>: 

Drag the cursor to define direction of the leader and click to specify the end point of the dimension leader. 

 

Please enter measured coordinates for datum coordinates or [coordinates picked up on drawing (A)] 

<39.055,-34.891>: 2307374.516, 2497379.950  

Enter the measured coordinate given by the planning department. 

 

Please enter coordinate dimension point or [enter location dimension point for coordinates (A)] <Exit>: 
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Specify the other point where the coordinate is to be created. 

 

Please specify coordinate dimension direction<Exit>: 

Drag the cursor to define direction of the leader and click to specify the end point of the dimension leader. 

 

…Go on specifying other dimension point or press enter to exit the "Coordinate Dimension" command. 

 

 

2.12.7.4 Select Datum Coordinate 

 

"Select Datum Coordinate" can be used in the following two situations: 

 

1. When more than one datum coordinates are created in the drawing, it means multiple coordinate systems exist in 

the drawing. In this case, we have to select one datum coordinate to make the coordinates to be created associate 

with it. 

 

2. When there’s only one datum coordinate, user can use this command to convert the other ordinary coordinates 

into datum coordinates. 

 

The command prompt is as follows: 

 

Current drawing unit: mm 

 

Select datum coordinates<Exit>: 

Select the datum coordinate object as the current datum coordinate. 

 

Please enter coordinate dimension point or [enter location dimension point for coordinates (A)] <Exit>: 

 

Please specify coordinate dimension direction<Exit>: 

Drag the cursor to define direction of the leader and click to specify the end point of the dimension leader. 

 

…Go on specifying other dimension point or press enter to exit the "Coordinate Dimension" command. 

 

2.12.7.5 Align to WCS 

 

The command is used to make the known coordinate datum aligned with WCS coordinate value. 
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The left picture indicates that the blue coordinate of the know point is inconsistent with WCS. The right picture 

indicates that coordinate of the know point is consistent with WCS after the command is invoked, in other words, the 

coordinate value in the status bar is the coordinate of the position where the cursor is. The datum coordinate created 

in the drawing has the same value as the known coordinate in the left picture. 

 

Select the exiting coordinates object to obtain the known coordinate value the WCS is to be aligned with.  

 

Specify reference point or [existing coordinate dimension in Reference drawing(R)] <Exit>: R 

If there’s the coordinate object in the drawing, please enter R to select it. 

 

Select the GstarCAD Architecture datum coordinate object, and the command will deal with the drawing to make the 

WCS aligned with the selected coordinate according to its value. If the coordinates selected is not datum coordinate, 

we have to set it as datum coordinate first, and then the command will deal with the drawing to make the WCS 

aligned with the selected coordinate according to its value. 

 

2.12.7.6 The Object Edit and Property Edit of Coordinate Dimension 

 

1. Double click the ordinary coordinate object, and we will find the object edit command line prompt as follows: 

[Inquiry datum coordinate (Q)/Cancel associated with datum coordinates(C)/convert to datum coordinate 

(Z)]<Exit>: 
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When there are multiple datum coordinates in the drawing, it is used to know which datum coordinate is the current 

coordinates associated with. 

 

2. Double click the datum coordinate object, and we will find the object edit command line prompt as follows: 

 

[Modify measured coordinate value(G)/Set north direction angle(S)/associated with other coordinates(R)/inquiry 

associative coordinates(Q)/convert to ordinary coordinate(Z)]<Exit>: 

It is used to modify the parameter of the datum coordinate. 

 

Select the coordinate dimension object, press "Ctrl+1" to open the properties bar, in which we can modify the 

coordinate object’s text size, dimension precision, arrow style , dimension style, coordinate type, the datum 

coordinate, absolute coordinate position as well as determine whether it is associated with the datum coordinate 

and so on. 

 

2.12.8 Coordinate Inspect 

Building Design→Site Plan Design→Coordinate Inspect 

 

Click the command in the menu, the command line will prompt: 

 

The current drawing unit: mm 

 

Select datum coordinates<Exit>:  

Select current datum coordinate object; 

 

Select coordinate to be checked: 

Select the coordinate object to be inspected. 

 

Select coordinate to be checked: 

Press enter to complete the selection. Then the command line will prompt: 

 

Selected N coordinates, M of them correct, 0 associated, and2 errors! Meanwhile the red box will be added to each 

error coordinate one by one as follows: 

 

No.1/2wrong mark, correct mark X=2002.952, Y=3012.476) or [A-all correct/C-correct coordinate/D-correct 

position/X-exit] <next one>: C  

We can enter C to correct the error coordinates one by one. 
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No.2/2wrong mark, correct mark X=1997.609, Y=3016.134) or [A-all correct/C-correct coordinate/D-correct 

position/X-exit] <next one>: 

 

We can enter A to correct all the error coordinates. 

We can enter C to correct the error coordinates one by one. 

We can enter D to move the original coordinate to the correct position instead of modifying its value. 

 

If all the coordinate dimensions selected are correct, the command line will prompt as follows: 

 

Selected coordinate N, all correct! 

 

2.12.9 Elevation for Site Plan 

Building Design→Site Plan Design→Elevation for Site Plan 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

Regarding the elevation for site plan, the elevation style include: "Triangular Elevation", "Dot Elevation" and 

"Common Elevation". User can select one of them to create the elevation. When we select different options for the 

text alignment, the effects of different text position are as shown in the following picture. 

 

User can use solid elevation symbol or standard elevation symbol to create the relative elevation or annotation. The 

size of the elevation symbol can be defined by users via "Basic Settings" page of "Drawing Setting" command. 
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"Absolute Elevation Auto Conversion" when we check it and input the elevation relation in the Conversion 

Relationship box, the absolute elevation will be automatically calculated. And the Conversion relationship will be 

displayed in the dimension. 

 

When we enter text in the "Relative Elevation/Annotation" edit box, brackets will be added to the text and the text will 

be displayed as annotation. 

 

When it is unchecked, the absolute elevation will not be automatically calculated, and we can enter to annotation 

content in the edit box on the right of the dialog box above. 

 

Text Alignment "Center": it applies to the triangle elevation and dot elevation specialized for site plan. When we 

select "Center", the elevation text will be under the symbol. When we check "One Side", the elevation text will be on 

the right of the symbol. 

 

"Absolute Elevation=Relative Elevation+ Conversion Relationship", in which the "Conversion Relationship" is used 

to input the height difference between the relative elevation and the absolute elevation. For example, in the above 

picture 6.05 indicates the relative elevation 1.50; the absolute elevation 60.50. 

 

"Relative Elevation/Annotation" is used to input the relative elevation. The command will calculate the content of the 

absolute elevation box. 

 

"Arrange from Top to Bottom", "Align from Left to Right" are used to determine the relation between the absolute 

elevation and the relative elevation. There are two selectable arrangements. The example of the dimension is as 

follows: 

 

Example of "Site Plan Elevation": 

 

We can double click the elevation object to enter the in-place edit mode, under which we can directly modify the 

elevation value as follows: 

 

We can double click the non text part of the elevation object to enter object edit mode. We can modify the 

parameter in the dialog box displayed and click OK to complete the modification. 
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2.12.10 Tree Arrangement 

Building Design→Site Plan Design→Tree Arrangement 

 

Click the command in the menu, and the dialog box will be displayed. Select tree type and other parameters in it. 

The parameter should be set according to the drawing unit set in the current drawing. 

 

Click the command in the menu, and the dialog box will be displayed as follows (the current drawing unit is mm). 

 

Click the command in the menu, and the dialog box will be displayed as follows (the current drawing unit is m). 

 

When "Tree Group Arrangement" is selected, radio buttons in "Tree Selection" become invalid. 

 

In this case, we can only click the image box to select one of the four predefined tree types as follows: 
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The command line will prompt: 

 

Please Start by Left Clicking<Exit>: 

Here please click the mouse to specify the start point and drag the mouse to dynamically draw the trees according 

to the given radius and spacing. 

 

Left Clicking or Right Clicking to End! Click the mouse to complete the tree drawing. The effect of the drawing 

example is as follows: 

 

The feature of "Tree Group Arrangement" is the coincident part of the plane trees are automatically merged together. 

We can set the radius as "Fix Radius" or not, we can also set the spacing as "Fixed Spacing" or not. The effect of the 

different settings is as shown in the following picture.  

 

Regarding the other three drawing method, we can select the tree type via one of the three methods: "Pick Block by 

Point", "Select from Drawing Library" and "Select from File". Then please click the icon button. 

 

When we select "Pick Block by Point" and click the button, the command line will prompt: 

 

Please select the block for arrangement<Return>: 

Select in the drawing the existing block as the tree legend. 

 

When we select "Select from Drawing Library" and click the button, the drawing library for plant will be displayed as 

follows: 
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Select from the library dialog box the tree type and double click it, and we will return back to the "Tree Arrangement" 

dialog box. 

 

When we select "Select from File" and click the button, the standard open file dialog box will be displayed. 

 

We have to select the dwg file as the tree legend and click "Open" button in it, and we will return back to the "Tree 

Arrangement" dialog box. 

 

Besides "Tree Group Arrangement", there are three other drawing methods as follows: 

 

When "Pick" is selected, "Tree spacing" and "Spacing Auto-adjustment" will not be available as showing in the 

following picture. 

 

Please specify insertion point<Exit>: 

The tree legend will be inserted at the specified point one by one till we press enter to exit the command. 

 

When we select "Drag to Draw", "Spacing Auto-Adjust" option is unavailable. The dialog box is as follows: 
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The command line will prompt: 

 

Please enter start point<Exit>: 

Specify the first point of the path where the trees are to be arranged. 

 

Enter next point or [retUrn (U)] <End>: 

Specify the next point of the path where the trees are to be arranged. The prompt will repeat itself till we press enter 

to exit the command. 

 

When we select "Path Match", the dialog box will be as follows: 

 

If we do not check "Spacing Auto-Adjust", program will arrange a block on one end of the path, and then arrange the 

blocks along the path at given spacing. The final arrangement result is as shown in the following picture. 

 

When we check "Spacing Auto-Adjust", the program will first arrange two blocks on both ends of the path, and 

calculate: path length÷spacing value entered in the dialog box. Then round the result off to an integer which is the 

block quantity can be arranged. Then calculate the path length÷block quantity, and get the actual spacing between 
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the blocks and insert the blocks along the path according to it. e.g., the path length is 10000, the tree spacing 

entered in the dialog box is 3000, the final arrangement result will be as follows. 

 

When we check "Random Rotation", while arranging the trees, the progress will specify a rotate angle at random on 

the basis of the block’s base point. If we do not check "Random Rotation", all the blocks will be inserted in the 

drawing with the same rotating angle. 

 

Move the cursor in the drawing and arrange the tree according to the prompt in the command line. 

 

Please select line, arc, or polyline to be used as path<Exit>: 

Here select the curve (line, arc, or polyline) as the path where the trees are to be arranged. Both point selection and 

frame selection are supported. 
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2.13 File and Layout 

2.13.1 Project Management 

Building Design→File and Layout→Project Management 

 

Click the command in the menu, and the project manager interface will be displayed. 

 

User can use hotkey "Ctrl+~" to start and close the interface. "Project Manager" interface can be set as "Auto Hide", 

in this case, only a title bar will be displayed. When we move the cursor on the "Project Manager" title bar, the 

interface will be expanded automatically. The picture is the screenshot of "Project Manager" interface, in which the 

two items of "Sheet Set" and "Floor Table" are retracted by default. 

 

Clicked the "Project Management" pull-down list at the top of the interface, we can open the "Project Management" 

menu, in which we can select "Project Management" command as shown in the pull-down list at the middle of the 

above picture. In the "Project Manager" interface of GstarCAD Architecture2015, there are many command 

frequently used in elevation, section and 3D modeling. In the "Project Management" interface, we can handle 

multiple tasks involving the whole project like "Floor Composite", "Building Slice", "Collision Check", "Building 

Elevation", "Building Section", "Win-Door Management", "Win-Door Sub-Schedule", "Area Statistic", "Sheet List" and 

so on. 

 

2.13.2 New Project 

The command is used to create a new project for the current drawing, during which user have to name the project. 

 

Project Management→New Project 
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Click the command in the menu, and the following dialog box will be displayed. 

 

In the dialog box we have to specify the path to store the DWG file of the project and enter the name for the new 

project. The operation will be different according to different cases. Please refer to the following explanation 

regarding it. 

 

1. If you intend to create project first, and then draw the plane drawing, you can check "Create Project Folder" and 

specify the storage position for the project. In this way, a new folder named after the project name entered will be 

created under the project position, meanwhile, an "*.ipj" file named after the project name entered will be created in 

the folder as well. 

 

2. If you have already had a project folder for the project, you don’t have to create another one. In this case, please 

uncheck "Create Project Folder" and enter the path where the existing project folder is. The "*.ipj" file named after 

the project name entered will be stored in the existing project folder. 

 

3. Finally, please click "OK" button, and save the new project as "Project Name.ipj" file. 

 

2.13.3 Open Project 

Project Management→Open Project 

 

Click the command in the menu, and the "Open" dialog box will be displayed: 

 

In the dialog box, browse the project file (*.ipj) to be opened and click "Open" button to open the project file.  

 

Recent Project: click project name pull-down list-> Recent Project, and we can see the list of the project recently 

opened. We can open one of them by clicking. 
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User can open "Option Config" command>Advance Option>Project Management, and set "Auto Load Recent 

Project" as "Yes". In this cares, when we start GstarCAD Architecture, the recent project will be loaded automatically.  

By default, the recent project will not be automatically loaded when we start the program. If recent project need to 

be loaded frequently, we can set "Auto Load Recent Project" as "Yes" as follows: 

 

 

2.13.4 Sheet Set 

Sheet set is used to manage various drawing files belonging to a project, which can be operated by right click 

menu. 

 

The explanation of the sheet set’s right click menu command: 

 

[Add Sheet] it is used to add drawing file to the current category or project. Select existing DWG file from the hard 

disk or create new drawing. (We can create DWG file only when we double click the drawing). 

 

[Add Category] we can add new category for current project. E.g., adding new category of "Win-Door Detail 

Drawing". 

 

[Add Subcategory] it is used to add subcategory under the current category. E.g., adding "Plan 0511 Revise" 

category under "Plan" category. 

 

"Fold and Expand Directory Tree": User can click"-" and "+" to fold and expand the directory tree. 

 

[Rename] it is used to rename the category or file currently selected by the cursor. 
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[Remove] remove the category or file currently selected by the cursor from the tree directory. In this way, the file 

itself will not be deleted. 

 

[Open existing drawing] we can double click drawing file name in the sheet set directory tree to open the DWG 

drawing of the drawing file. 

 

[Adjust the drawing’s position] we can drag and drop the category or file icon in the tree directory to modify its 

position in the directory. 

 

The icon  on the title bar is "Sheet List" command, which is used to create the sheet list based on the sheet 

set of the current project. 

 

2.13.5 Floor Composite 

 

The explanation of the controls in the dialog box: 

 

[Explode into faces] the system would automatically divide the professional component within each standard layer 

into grid faces. User can modify them by the command stretch and so on. 

 

[Insert as Blocks] if it is checked, the 3D model generated is merely a block. The model can either be generated in 

the current drawing or in a new drawing. 

 

Click the radio button of "Generate a New Drawing" and click "OK", and the dialog box "Enter the 3D File to be 

generated" will be generated. In the pop up dialog box input the file name of the 3D model. Click "Save" and the 3D 

model will be exported. Open the 3D model and the set the visual styles as "Conceptual" and the effect will be as 

follows: 
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2.13.6 Floor Table 

Floor table is used to define the relation between floor number and the corresponding drawing or drawing region. As 

the plan of each floor may be either in one DWG file or in different DWG file, we provide two buttons to define region 

for each floor. With the buttons we can define different region corresponding to each floor in both same file and 

different file. 

 

The explanation of the operation of "Floor Table": 

 

[NO.] It is used to define the floor number. One floor can correspond to one drawing area, e.g.: floor number 1 

corresponds to the first floor plan drawing area. In addition, multiple floors can correspond to one drawing area. E.g., 

floor number 2-17 corresponds to plan drawing area of 2-17 standard floors. The floor number should be entered 

starting form the first row. 

 

The floor number of basement should be expressed in negative number, e.g., -1 for basement 1, -2 for basement 2. 

 

[Height] it is used to enter the floor height of the floor. The unit would be mm. 
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[File] click the blank file bar to show the button. Click the button, browse and select the file to define the standard 

floor. The file name will be automatically inputted. Notice: The "Insbase" point should be aligned in each DWG file. 

The screenshots before and after the operations are as follows: 

 

The button besides the first column: click the button to select the row. Then right click the button to show the menu 

used to operate the selected row. User can also double click the button to switch to floor plan the row represents. 

 

Down arrow: click it to add a row. 

 

The explanation of the floor tool command: 

 

Select file:  

First click the table row to select a floor. Then click the command to define a DWG file for the floor. 
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Box select floor:  

First click table row to select a floor related to the current drawing. Then click the command and box select the floor 

plan used to define the floor. 

 

Select the first corner point<Cancel>: 

Specify the first point used for box selecting the floor plan. 

 

Another corner point<Cancel>: 

Specify the second point used for box selecting the floor plan. 

 

Alignment Point<Cancel>: 

Specify an alignment point shared by each floor. 

 

[Floor composite] use the floor definition to create 3D architecture model. 

 

[Show and update the floor frame] click the icon to show and update the floor frame defining the current floor. 

 

[Close floor frame] click the icon to hide the floor frame displayed by clicking the "Show and Update the Floor 

Frame" icon. 

 

Example of operation:  

Click the icon "Show and Update Floor Frame", and we will see the floor frame shows as red line and text indicating 

the floor number and the floor height will be shown too. Alignment point will be displayed as X. If we want to modify 

the floor frame, we have to redefine it by re-executing the "Box Select Floor". Meanwhile, the original floor height 

data will remain unchanged. The floor height can be modified directly in the floor table. 
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2.13.7 Insert Frame 

Building Design→File and Layout→Insert Frame 

 

Click the command in the menu, and the dialog box will be displayed: 

 

 

The explanation of the controls in the dialog box: 

Controls Function 

Sheet Size 

There are 5 kinds of standard sheets: A4-A0. Click the radio button of one of them to select 

the sheet. 

Sheet Length: / 

Sheet Width: 

It is used to set the length and width of the sheet by entering number or show the length 

and width of the standard sheet. 

Horizontal/ 

Vertical 

It is used to set the sheet format as horizontal type or vertical type. 

Sheet Extension: 

It is used to set the sheet as standard sheet of lengthening type. User can click the arrow on 

the right and select the international lengthening type sheet.  

Customize: 

Besides defining sheet size in sheet width and sheet length, user can also select the size 

data provided in the "Customize" pull down list. 

Scale  

Set the plot scale of the frame, which should be the same as that in the "Plot Model" dialog 

box. The scale can be select from the list. If there’s no suitable scale in the list, user can 

also directly enter it. When the check box "Paper Space" is checked, the "Scale" control will 

become unavailable, and the scale will automatically be set as 1:1. 

Paper Space 

When the check box "Paper Space" is checked, the current view will be switched to layout 

space, and the scale will automatically be set as 1:1. 

Countersign 

If it is checked, we are allowed to add countersign bar on the top left of the frame. Click the 

button below to select the countersign bar from the drawing frame library. 

Standard Title If it is checked, we are allowed to add the title bar of the international style on the right 
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Block bottom of the frame. Click the button below to select the title bar from the drawing frame 

library. 

Full-length Title 

Block 

If it is selected, we are allowed to add title bar of user-defined style on the left or at the 

bottom of the frame. Click the button below to select the title bar from the drawing frame 

library. The command would judge whether the title bar to be inserted is vertical or 

horizontal according to its size. Then adopt reasonable inserting method and add the line. 

Right Alignment 

When horizontal title bar is inserted at the bottom of the frame, we can check "Right 

Alignment" to make the title bar aligned to right. Then we can insert accessory on the left of 

the frame. 

Accessory 

After the "Full-Length Title Block" is checked, "Accessory" will become selectable. Check 

"Accessory", and we will be allowed to add accessory bar on one end of the frame. Click the 

button below to select the accessory bar from the drawing frame library, which can be either 

the logo of the design department or the countersign bar. 

Insert Drawing 

Frame Block 

If it is checked, we will be allowed to directly insert the complete drawing frame with title 

bar and countersign bar in the current drawing without setting the sheet size and the sheet 

format. Click the button below to select the complete frame from the drawing frame library. 

 

Select the preset title bar and Countersign bar from the drawing library to make them as a part of the frame, then 

insert the frame. The use-method is as follows: 

 

1. We can first set in the dialog box the sheet we need as vertical or horizontal, and then set the sheet size as one of 

these sizes: A4, A3, A2, A1, A0. If we want to lengthen the sheet, we can select the related sheet of lengthening type 

from the "Sheet Extension:" pull-down list. If the sheet is of nonstandard size, we can set its length and width in the 

related length and width bar. 

 

2. If we want to insert it under paper space, we have to check the "Paper Space" check box, if we want to insert it 

under model space, we have to set the output scale. Then we also have to make sure whether the title bar, 

Countersign bar are needed, and whether the title bar we needed is "Standard Title Block" or "Full-Length Title 

Block". 

 

3. When we select the "Full-length Title Block", we have to click the "Select" button to enter the frame library and 

select transverse tile or vertical title. 

 

4. If there are other accessories need to be inserted, we have to click the "Select" button and enter the frame library 

and select the proper accessory like logo and so on. 

 

5. After we determine all the options, we can click the "OK" button, at this time a blue frame that can be dragged will 

be displayed on the screen. Move the cursor to drag the frame and see if the size and the position are suitable. Then 

specify a point at the proper position to insert the frame. If the sheet size or the direction is not suitable, we can 

click right button of the mouse to return to the dialog box and reselect the parameter.  
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Directly insert the complete frame predefined in the drawing library, the use-method is as follows: 

 

1. Check "Insert Drawing Frame Block" and click the related button to enter the drawing library and select the 

complete frame. In which each standard sheet and the lengthen sheet has to be import to the drawing library 

independently. And each frame needs to be the complete frame with the title block, countersign bar, accessories 

like logo etc. 

 

2. If we want to insert it under paper space, we have to check the "Paper Space" check box, if we want to insert it 

under model space, we have to set the output scale. 

 

3. After we determine all the options, we can click the "OK" button, at this time a blue frame that can be dragged will 

be displayed on the screen. Move the cursor to drag the frame and see if the size and the position are suitable. Then 

specify a point at the proper position to insert the frame. If the sheet size or the direction is not suitable, we can 

click right button of the mouse to return to the dialog box and reselect the parameter.  

 

After we click the "OK" button, if we are currently under the model space, the base point of the frame is at the center 

of the frame. Drag the frame and we will see the prompt in the command line. 

 

Select insertion position<Back>: 

Specify a point to insert the frame or click right button of the mouse or press enter to return to the dialog box to 

modify the parameter. 
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The feature of inserting the frame in paper space: 

 

When we check "Paper Space" in the dialog box, the drawing will be immediately switched to paper space, 

meanwhile, the command line will prompt: 

 

Select insertion position or [Z-align left bottom of drawing frame with original point of drawing] <Back>: Z 

User can specify a point to insert the frame or enter z to make the left bottom corner point of the frame aligned with 

the original point (0, 0), user can also press enter to return to the dialog box and further modify the parameter. 

 

The usage of preview image box: 

 

Preview image box supports mouse wheel and middle button. We can zoom and pan the frame displayed in it. And 

we can also see clearly the detail content in the title block inserted. 

 

2.13.8 Sheet List 

To execute the command, GstarCAD Architecture has the following requirements on the drawing frame: 

 

The frame must include attribute block (frame block or title block). 

 

In the attribute block, there must be the attribute with the tag of DRAW_NAME and DRAWING_ NUMBER, in which 

the spaces are not allowed to be inserted. For example, the following drawing name is not allowed. 

 

The command applies to the title block or drawing frame that has standard property name. The title block in the 

frame library is provided meeting the above requirement. 

 

User can double click the title block to change the default content to the real project content as follows. User can 

reference the template to modify the style of the sheet list and reimport it into the related drawing library. 
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We can invoke the command in this way "Building Design→File and Layout→Sheet List" or by clicking the related 

icon on the "Sheet Set" bar of "Project Manager" interface. 

 

Building Design→File and Layout→Sheet List 

 

After we click the command in the menu, the command will begin to search for frame in the sheet set of the current 

project. (If the drawing has not been added into the sheet set, the frame will not be found). The searching range 

includes the model space and the layout space. In which there are two layout spaces in the elevation drawing file, 

and each of them includes a drawing, thus, the drawing quantity is 2. The number "0" in front means no drawing is 

found in the model space. The number behind is the quantity of the frames (drawings) in the layout space. The 

catalogue generated by the command is automatically sorted by the drawing number of the frame filled out by the 

user. 

 

Then the user can click "Select File" to select other files taking part in the sheet list generation. As shown in the 

following picture, 7 DWG file has been selected, 8 drawings has been found according to the quantity of the frame 

inserted. Click "Generate List>>" button and insert the sheet list in the drawing. 
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The explanation of the controls in the dialog box: 

Controls Function 

Model 

Space 

It is checked by default. In this case, frames in the model space will take part in the sheet list 

generation. When we uncheck it, only the frames in the paper space will take part in the sheet 

list generation. 

Paper 

Space 

It is checked by default. In this case, frames in the paper space will take part in the sheet list 

generation. When we uncheck it, only the frames in the model space will take part in the sheet 

list generation. 

Select 

schedule 

from 

schedule 

library 

We can click the button to open the drawing list library. In which user can select and double 

click the sheet list template predefined in advance. The selected sheet list will be displayed in 

the image box on the left. 

 

Select File 

We can click the button to enter the standard file dialog box. And select the drawing file which 

is to be added to the drawing catalog list. 

Remove File 

We can click it to remove file from the drawing catalog list. Multiple files can be selected at one 

time by pressing shift key. Then click the button to remove the files from the list. 

Generate 

List>> 

WE can click it to complete the "Sheet List" command and exit the dialog box. Then user can 

insert the sheet list in the drawing. 

 

Choose position for inserting sheet list<Back>: 

Specify a point in the drawing to insert the sheet list. 
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In real project, there would be dozens of professional drawings concerning one project, thus the sheet list generated 

will be very long. For ease of layout, we can use "Table Split" command to split it into multiple tables. 

 

2.13.9 Define Viewport 

Building Design→File and Layout→Define Viewport 

 

Click the command, if the current space is paper space, it will be switched to model space. And the dialog box will 

be displayed as follows: 

 

Enter proper parameter in the dialog box. Generally, the viewport will be arranged horizontally, in this case, the 

angle between viewport and horizontal direction would be 0. What we have to do is to enter the viewport output 

scale. If we want to define a sloping viewport, we can use any one of the three methods: "Specify Angle between 

Viewport and Horizontal Direction:", "Angle Determined by Object" and "Angle Determined by Two Point". 

 

The explanation of command interaction of the latter two methods is as follows: 

 

1. Click the "Angle Determined by Object" button. Please be noted that the effective objects are axis line or wall. The 

command interaction will be as follows: 

 

Select the line or wall object to define horizontal direction of corner viewport<Return>:  

Select the line and the wall object. 

 

Then the angle of the object selected will serve as the direction angle. When we select the object from which the 

angle can not be obtained, e.g. circle, oval, arc, spline, block and so on, the dialog box will be displayed again, in 

this case, we can use "Angle Determined by Two Point" command instead. 

 

2. Click the "Angle Determined by Two Point" button and specify two points to determine the direction. The 

command interaction will be as follows: 

 

Specify first point to define horizontal direction of corner viewport<Return>: 

Specify the first point P1 used to define the horizontal direction of the viewport. 

 

Specify second point to define horizontal direction of corner viewport<Return>: 

Specify the second point P2 used to define the horizontal direction of the viewport. 

 

Then we will see the following command interaction. 
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1. If we will draw first before layout, in the model space, we have to specify two corner points used for viewport 

definition. Then the command line will prompt: 

 

Enter first corner point of drawing to layout<Exit>: 

Specify the first point of the viewport. 

 

Enter another corner point<Exit>: 

Specify the corner point of the viewport. 

 

Viewport Output Scale 1 :< 50>: 

Specify the scale of the current viewport. The default value of it will be obtained from the objected box selected. We 

can either press enter to use the default scale or enter new scale. 

 

Please specify the point to locate viewport<Drawing original point>: 

Model space will automatically be switched to layout space. Then drag the viewport and insert it in the proper 

position. 

 

2. If we will draw after layout, we can box select a blank area or select a viewport in the model space, and arrange it 

in the paper space. Please be noted that the scale should be the same as that of the drawing we are going to 

drawing. 

 

We can create multiple viewports with different scales. Then we can enter each viewport. 

 

Example 1 of "Define Viewport": 

Take the example of construction detail drawing. First draw in the model space the source drawing according to 

different scales of 1:10, 1:20 and 1:50, which prepares the source material for multiple scales layout. At this time, 

we can arrange the drawing position at random. We just have to make sure there is no over lapping parts between 

the drawings. 
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The following picture shows the effect that inserting the viewport in the paper space via "Define Viewport" command. 

At this time we have to take the arrangement of the viewports into consideration. The viewport can be further 

arranged after inserted. Spaces for annotation should be properly reserved at the bottom. 

 

 

Example 2 of "Define Viewport": 

Take the example of construction detail drawing of the stairs, in the model space the stair well 1 is external 

reference with rotation angle, thus we can not determine the rotation angle directly by selecting the object, in this 

case we have to determine the rotation angle by two points A and B. Then we have to define two layout viewports 
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(viewport 1 and viewport 2) ranges by specifying P1-P2, P3-P4. Set the scale as 1:50. For details please refer to 

the following picture. 

 

The following picture shows the effect that inserting the viewport in the paper space via "Define Viewport" command. 

We can see in the layout space all the viewports are automatically arranged orthogonally. 
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2.13.10 Cutting for Detail 

Building Design→File and Layout→Cutting for Detail 

 

Click the command in the menu, and we will see the following dialog box. First user has to set the plot scale of the 

drawing cutting area. In the example, as we are to execute "Cutting for Detail" command on the plan that is arranged 

obliquely, we have to click the "Angle Determined by Two Point" icon and select collinear two points to define the 

angle. Then determine whether to add break line. Meanwhile, the command line will prompt: 

 

The first corner point of rectangle or [Polyline clip (P)/PoLy line defined boundary (L)] <Exit>: 

User has to specify the two opposite corner points of the rectangle as per the given angle. 

 

Another corner point<Exit>: 

At this time, the program has completely intercepted the drawing within the cutting rectangle that we just defined. 

We can drag it with cursor. Mean while, the command line will prompt: 

 

Please click the insert location<Quit>: 

Specify the insert position of the partial drawing in the drawing. 

 

Check "Add Break Line" in the dialog box and specify the Break line Number as follows. If we need the effect of 

hiding border, we have to double click the border break line, and in the "Edit Cut Line" dialog box set some of the 

borders as "No Print Border" and check the "Hide Nonprinting Border". 
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Note: 

The "Plot Scale:" of the command is used to extract the annotation object like axis number and dimension and so on, 

and it does not zoom the drawing itself. Thus, we have to define the viewport according to the same scale when the 

layout is carried out. 

 

 

2.13.11 Change Scale 

The command is used to modify the scale of drawing within the specified region (including the scale of viewport 

object) in model space. If the scale is successfully modified, it will be served as the new current scale. 
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After the execution of the command, the size of the architecture object will remain unchanged, while the size of the 

annotation object will be changed. E.g., the command will change symbol size and the text height. 

 

The command can be invoked in the menu. Besides, we can use another method to execute it: Click the "Scale" 

button in the status bar at the left bottom corner. In this case, please select the annotation object whose scale is to 

be modified first, e.g. we select "Title Index" here. We can see the original scale of it is 1:100. Then press the 

"Scale" button and set the scale as 1:50, after which the size of the annotation object "Title Index" will be 

immediately be changed as follows: 

 

Building Design→File and Layout→Change Scale 

 

Click the command in the menu, and the command line will prompt: 

 

Please enter new print scale<50>: 

Please select entity need to change scale: Specify opposite corner: 

 

Please provide original print scale<50>: 

 

At this time, the position of the axis and the project symbol will change, please drag to modify the size of the 

viewport or enter model space to drag object like axis etc. to modify the drawing layout. 

 

After the scale is changed, the drawing size in the layout will change a lot. However, the size of dimension object 

will remain unchanged. As shown in the following picture, the height of axis number, detail drawing number, 

dimension texts are all the same. 
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2.13.12 Layout Rotate 

The command is used to rotate the whole object or just rotate the sub object in it like annotation etc., which can 

make sure the text direction meeting the requirement of the standard text direction when we adjust the visual 

direction of the drawing. For example, rotating the plan, arrange vertical frame etc. 

 

Building Design→File and Layout→Layout Rotate 

 

A-rotate Angle: it is used to rotate the sub object like annotation in the object. For example, when we use the 

command to rotate the description text of arrow leader, the main body of the object will not be rotated. 

 

As shown in the following picture, the text in the annotation object is displayed horizontally by default. If we just use 

the "Rotate" command to rotate the object, the text will remain displayed horizontally. "Layout Rotate/A-Rotate 

Angle" command will not rotate the whole object. It only rotates the horizontal text in it to new drawing visual 

direction as per needs. Please refer to the following picture. 

 

Click the command in the menu, and the command line will prompt: 

 

Select Object: 

Select the annotation object that is to be layout rotated. 

 

Please select layout rotate style [B-base on Base point/A-rotate Angle] <Base on Base point >: A 

Enter A to set rotation angel parameter. 

 

Set Rotate Angle<0.0>:90 

Enter the layout rotate angle value as per needs. 

 

B-base on Base point:  
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It is used to rotate the whole object. For example, when we rotate the compass, we have to rotate not only the main 

object of the compass but also the sub object: annotation N. 

 

Click the command in the menu, and the command line will prompt: 

 

Select Object: 

Select the annotation object that is to be layout rotated. 

 

Please select layout rotate style [B-base on Base point/A-rotate Angle] <Base on Base point>: 

Press enter to set the base point. 

 

Rotate Base point<Exit>: 

Specify the position of the layout rotate base point. 

 

Layout Rotation<0.0>: 

Enter the layout rotate angle value as per needs. 

 

Regarding the compass object, the two rotation modes of "Layout Rotate" command are as shown in the following 

picture. 

 

2.13.13 Convert Filter Dwg 

Building Design→File and Layout→Convert Filter DWG 

 

Click the command in the menu, and the "Convert Filter DWG" dialog box will be displayed: 
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In the dialog box, as per needs, uncheck the items to filter out the content on the needless layer. When it comes to 

nonstandard layer not drawn by GstarCAD Architecture, we can use "Change layer" button to specify the related layer. 

We can click "<<Preview" button to preview the drawing effect after the filtering so as to determine whether to 

generate the final drawing. As shown in the following picture, we can see the effect that we checked "Win-Door to 

Opening" and the special-purpose construction content like room, win-door number is removed. 

 

 

2.13.14 Explode 

Building Design→File and Layout→Explode 

 

We explode the customized professional object for the purpose of: 

 

The construction drawing will be able to be browsed and outputted under CAD instead of GstarCAD Architecture. 

 

In this way we can also prepare the 3D model for rendering. As many rendering software (renderer in CAD itself is 

included) does not support customized object, especially the material in the block.  

 

Click the command in the menu, and the command line will prompt: 

 

Please select Object need to completely explode: 

Select several objects need to be exploded. 

 

As the customized object will lose intelligent professional properties after explosion, we suggest user reserve the 

model before explosion and save the drawing after explosion as new file for ease of further possible modification. 
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The result of the explosion is related with the current view. If we want to get 3D drawing (the wall is to be exploded 

as 3D wire side or entity), we have to set the viewport as axonometric drawing first. We can only get 2D object in 

plan. 

 

We can not use the "Explode" command in CAD to explode the object, the command can only explode one layer, 

however, GstarCAD Architecture objects are of multiple layer structure, thus these objects can  be completely 

exploded only by "File and Layout/Explode" command. 

 

2.13.15 Layer-Std Convert 

Building Design→File and Layout→Layer-Std Convert 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

Select the layer standard before and after the conversion and the select the drawing area to be converted, and then 

press "OK" to complete the conversion. 

 

Original Layer Standard: the current layer standard before the conversion. 

 

Target Layer Standard: the layer standard defined in the layer management page of "Option Config" command. 

 

When it comes to the conflict of layer definition, the following dialog box will be displayed. According to the target 

layer standard, specify the matched layer name from the pull-down list, then press "Convert" to solve it. 
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2.13.16 Drawing Check 

Building Design→File and Layout→Drawing Check 

 

Click the command in the menu, and the dialog box will be displayed as the following left picture.  

 

 

Meanwhile, the command line will prompt: 

 

Please select object for inspection<Select all>: 

Frame select or press enter to select all. 

 

After we execute "Drawing Check" command, the result will be as shown in the above right picture, here we can 

click "Auto-Process" button to quickly solve the problem of "Wall Overlap Completely".  We can click "Delete 

Dimension" to delete the overlapped dimension. 

 

When the problem of "Wall Partial Overlapped" occurs, we have to click each row regarding the problem, and then 

the command will automatically adjust the view and check the problem one by one. The process of checking the 

overlapped wall object is as follows. 
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There will be a pull-down list at one end of the row in the dialog box, user can select one of the five commands in it 

to execute, which are "Dimension", "Ignore", "Delete Red", "Delete Blue " and "Merge", after which, we can click 

"Delete Dimension" button in the dialog box to delete the dimension from the drawing. If the range of auto-zoom is 

not suitable, we can uncheck "Auto-Zoom View when locating" and determine the zoom range by ourselves. 

 

If you are agree with the rule: "Two Overlapped Drawing Units will be Kept One; If One Drawing Unit Contains 

Another One, The Included One will be Removed", you can Click "OK" to solve the problem automatically. 

 

Confirm to auto process? Click "OK" to solve the problem automatically. 

 

If we select "Merge" provided in the list, part of the wall overlapped will be merged, if the walls to be merged are of 

different properties, the following dialog box will be displayed. 

 

Here please refer to the rule of "Merge Wall" command to select the proper item. 

 

After dealing with the overlapped object, click "Recheck" button, and the command line will prompt: 

 

Please select object for inspection<Select all>: 

Frame selecting the objects or press enter to select all. 

 

Not found errors in drawing! Which means problem regarding object overlapped in the drawing has been solved. 
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2.13.17 Drawing to 2D Wireframe 

Building Design→File and Layout→Drawing to 2D Wireframe 

 

Click the command in the menu, and the file dialog box will be displayed. 

 

Specify the file name and the path in "Enter New Created File Name" dialog box, then press "OK" button to generate 

the wireframe drawing file as follows: 

 

 

2.13.18 Drawing Filter 

Building Design→File and Layout→Drawing Filter 

 

Click the command in the menu, and the command line will prompt: 

 

Please select [hide Annotative object(A)/hide model oBject(B)/reCover visibility(C)/Delete annotative 

object(D)/delete modEl object(E)]: 

 

We have to enter the related hotkey in the bracket as per our needs of hiding, recovering and deleting the object. 

Then the command will be immediately executed and then exit. 

 

For example, we can enter A to hide the annotative object, at this time; the model object will be automatically open. 

Conversely, when we enter B to hide the model object, the command will automatically open the annotative object. 

 

Whether the object is to be regarded as annotation object is defined in the "Annotate.def" file, the objects that have 

not been defined in it will be regarded as model object. Annotation objects defined in the "Annotate.def" file 

provided by default includes not only the GstarCAD Architecture symbol object and the dimension object, but also 

the text and the dimension object of drawing platform. The format is as follows: 

 

Definition of Annotation Object: 

For example: "LINE 8 DOTE" means line on DOTE layer should be regarded as annotation object, in which "8" is the 

layer leading character. The layer name needs to be written in capital. 

 

TEXT 

 

javascript:void(0);
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MTEXT 

 

DIMENSION 

 

IAEC_TEXT 

 

IAEC_MTEXT 

 

IAEC_DIMENSION...... 

 

"Annotate.def" file is saved in the "Common" file folder. 
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3. Drawing Library 

This chapter of GstartCAD Architecture (here after can be called "GCA"), mainly introduces the library function. 

 

3.1 Concept 

3.1.1 Block Reference and External Reference 

There are many ways of block reference. The most common one is block insert. Unless otherwise stated, block 

reference just refers to block insert. Besides, there is a kind of reference called external reference. External reference 

automatically varies with external block, in other words, if external file changes, external reference will automatically 

be updated. Block reference has many other forms, e.g., Win-door object is also a kind of block reference. 

Furthermore, it references two block definitions: (one of them is 2D block definition and the other is 3D block 

definition). Different from other blocks, the win-door size is restrained by the wall object where the win-door is to be 

inserted, which is different from other blocks. 

 

 

3.1.2 Grip of Block 

There are five grips in GCA block. The grips at the four corner points are used to stretch block so as to modify the 

size of the block in real time. The grip in at the center is used to rotate block. If you want to control the size of block 

accurately, please start "Dynamic Input" in the status bar and enter accurate size. We can also right click to start the 

block’s "Object Edit". Select any grip and click <Ctrl>, and we can change its function of "Stretch" or "Rotate" to 

"move" function. And the grip selected will be served as the base point for moving. 

 

 

3.2 Object Edit 

We can use "Object Edit" to modify the size of the block. Select the block and right click the "Object Edit" command, 

and the "Block Edit" dialog box will be displayed, with which we can modify and edit block. User can select one 
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modification method from "Enter Size" and "Enter Scale". After resetting the parameter, please press "OK" to 

complete the modification. For detail please refer to the following pictures. 

 

 

3.3 2D Library 

2D Library is a drawing library group, which comprises many commonly used plane drawing’s libraries. User can 

double click the drawing blocks to arrange them in the plan. Please be noted that the blocks in the 2D Library are of 

the actual size, thus we do not have to zoom them according to the current scale when inserting them into the 

drawing. If we want to change the size of drawing block, we can modify the related parameter in the object edit 

dialog box. 

 

Drawing Library→2D Library 

 

Click the command in the menu, and the dialog box will be displayed: 
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3.4 Multi-View Library 

Multi-View Library is a specially constructed drawing library group, which comprises of a plane drawing library and 

a 3D drawing library. When the drawing block is inserted in the drawing, under the plane view, it will be of 2D effect. 

While under 3D view, it will be displayed as 3D model. To achieve the above effect, we have to set the drawing 

format in "Drawing Library->Block->Export" as "GstarCAD Object Block" instead of "Ordinary Block" and "Original 

Drawing Unit", or else the drawing inserted can only be displayed as 2D drawing. 

 

Drawing Library→Multi-View Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

 

As shown in the following picture, it is the effect of the same "Multi-View Drawing Block" under the plane view as 

well as under the 3D axonometric view: 
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3.5 2D Door Library, 2D Window Library, 3D Door/ Window Library 

Please be noted that the win-door block is saved as special block of 1*1 unit。 We have to use the specialized 

designed "Win-Door Prototype" and "Import Win-Door to Library" command under "Door and Window" tool menu to 

import win-door drawing block to library. We have to use "Door/Window" command under "Door and Window" menu 

to insert win-door block, and we can not insert the win-door in the wall by direct double clicking win-door block in 

the library. GCA provides these commands in drawing library menu to enable the users to conveniently maintain the 

win-door library. User can enter the win-door library and rename, move or delete these blocks. 

 

Drawing Library→2D Door Library 

 

Drawing Library→2D Window Library, 

 

Drawing Library→3D Door/ Window Library 

 

Click the command in the menu to enter the related win-door library and maintain it. We can see the commands in 

"Block" menu are not available, which means we can not import drawing block in these win-door libraries. The 

following picture is the screenshot of 2D Door Library, which is similar to that of the other two win-door library 

commands. 

 

 

3.6 Elevation Door/Window Library 

Drawing Library →Elevation Door/Window Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 
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When we invoke the Elevation Win-Door command in the Elevation menu, we can enter the above elevation 

win-door library to select elevation decoration window so as to replace the elevation win-door in the drawing. In this 

case, the command will replace the win-door according to the door opening size (the blue part in the drawing) 

instead of the size of the elevation win-door together with the accessory decoration’s external profile. It is because 

the elevation win-door is imported in the library and replaced according to a certain rules. When the elevation 

win-door is imported in the library, the elevation win-door is imported in the library, and a positioning point has 

been inserted at the top right corner. This point is for defining the "Hole Region". 

 

The left picture above shows an elevation window generated via "Elevation" command, while the right picture shows 

the effect after executing the "Elevation Win-Door/Replace Type" command.  The accessory decoration of the 

elevation win-door block has nothing to do with the win-door size. 

 

3.7 Sect Door/Window Library 

Drawing Library →Sect Door/Window Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

The library stores the blocks used in the "Win-Door Section" command. We can invoke the "Win-Door Section" 

command in the "Section" menu, and replace the elevation win-door with the block in the section win-door library. 
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The command will replace the win-door according to the wall opening region (the part in the red frame). The block 

inserted will automatically match the size of the opening. When the section win-door is imported in the library, a 

positioning point has to be inserted at the top right corner of the win-door related opening region as shown in the 

left picture below. 

 

 

3.8 Elevation Balcony Library 

Elevation Balcony Library provides several commonly used elevation balcony blocks, we can directly insert them in 

the elevation when using. We do not need to use specialized command to do it. 

 

 

Drawing Library →Elevation Balcony Library 

 

Click the command in the menu, and the following dialog box will be displayed: 
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When we import the elevation balcony in the library, please be noted the position of the inserting point is as follows. 

 

 

3.9 Railing Library 

Drawing library provides the 3D railing unit blocks for 3D modeling. We can obtain them from the drawing library 

via "3D Modeling/Railing" command. Please be noted when we customize it, the railing unit is imported as 2D 

drawing, thus we can not direct achieve the effect of the preview image as follows. The preview slide in the railing 

library is re-imported in the library according to the elevation direction via "slide" function. 

 

Drawing Library →Railing Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 
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3.10 Drawing Frame Library 

Drawing Frame Library stores frame blocks. We can obtain them from the drawing frame library via "File and 

Layout/Insert Frame" command. Please be noted that these block are imported to the library according to the actual 

sizes. 

 

Drawing Library →Drawing Frame Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

 

3.11 Sheet Library 

Sheet Library stores the table header block of the table, which is used in the "Door and Window/Win-Door 

Sub-Schedule" and "File and Layout/Sheet List" command. Please be note that these blocks are imported to the 

library according to the actual size of the table header. 

 

Drawing Library→Sheet Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 
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3.12 Section Library 

Section Library stores section line block for 3D modeling. We can obtain them from the drawing library via "3D 

Modeling / Path Surface / Select from Section Library" command. 

 

Drawing Library→Section Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

The section is composed of closed pline, when importing them to the library, please be noted that the block base 

point position of each section type is as follows: 

 

 

3.13 Curve Pattern Library 

Curve pattern is made of curve pattern units. The predefined curve pattern unit is similar to common block. It can be 

customized by user and imported to the curve pattern library. 

 

Drawing Library→Curve Pattern Library 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

When create curve pattern unit, please be noted that the inserting point has to be defined as the top left corner point 

instead of the default center point.  Please refer to the picture below: 
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3.14 Drawing Import 

To execute the "Drawing Import" command, we do not have to enter library management interface to. We can use the 

command to conveniently customize the block and import it to library. 

 

Drawing Library→Drawing Import 

 

Click the command in the menu, and the command line will prompt: 

 

Please select object: 

Please select the content to be imported to the drawing library and press enter to complete the selection. 

 

Please select object< (-76904.5, 45632.8)>:  

Specify the blocking inserting point. 

 

Create Slide (Please Zoom to fit) or [Back without creation(X)] <Create>: 

Use the mouse scroll wheel to zoom in/out the object selected and press enter when the size is suitable. 

 

"New Drawing to Library" dialog box will be displayed as follows, then select in it the target drawing library to which 

the object selected is to be imported. Generally, we select it from the pull down menu of the "Common Drawing 

Library". If it can not be found in "Common Drawing Library", we can click the "File" menu to find. 
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Enter in it the name of the new block. E.g., here we select the "Section Library" from "Common Drawing Library". 

Then we have to click "My Library" and click "OK" button to complete the operation of "Drawing Import". In this case, 

the new created block will be imported to "Section Library". We can add new type to my library as well as rename 

the block in it. 

 

3.15 DWG Library Management 

Click "DWG Library Management", and we will see the following dialog box: 

 

GCA drawing library interface includes 5 parts: "Tool Bar", "Menu Bar", "Classification Region", "Block Preview 

Region" and "Status Bar". The size of the dialog box can be adjusted at will. When we close the dialog box, its size 

will be recorded and served as the size of the dialog box opened again. The size and the relative position of 
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"Classification Region", "Block Name Region" and "Block Preview Region" can also be adjusted at will, which fit the 

user’s operation habit as well as the usage style of "Windows". 

 

The explanation of the controls in the dialog box: 

Controls Functions 

Tool bar It provides some commonly used button command used for drawing library operation. 

Menu bar 

It is similar to "Tool Bar" in terms of function. It provides commonly used command used 

for drawing library operation in form of pull down menu. 

Classification 

region 

It shows the tree directory of the current drawing library or drawing library group file.  

Block name 

region 

Name here is used to describe the related block (It is not the   block definition name after 

the block is inserted).One name match each drawing in the Block preview region. We can 

select one block name, and then click it to rename the block. 

Block preview 

region 

It is used to display the block slide or color picture under the selected classification in the 

Classification region. The block selected will be displayed in form of highlight. We can use 

scroll bar or mouse scroll wheel to browse the blocks in it. 

Status bar Display the block information and operation prompt according to different status. 

The size of the interface can be adjusted by dragging any corner point of the dialog box. We can also adjust the size 

of each region by dragging the borderline between the regions to. "Classification Region", "Block Name Region" and 

"Block Preview Region" provides us with corresponding right click menu. 

 

3.15.1 File Management 

The explanation of the command’s function 

Command  Content 

New （drawing 

library or drawing 

library group） 

Please enter the position or name of the new drawing library file, then click "OK" button.  

 

Open Select the existing drawing library file (*.dml). 

Add Select an existing drawing library file and add it to the current drawing library group. 
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3.15.2 View Management 

The explanation of the command’s function: 

Icon command Content 

Layout 

It is used to set the row quantity and column quantity of block slide displayed in the 

preview region for ease of browsing. 

Sort 

We can use the "Sort" icon command to sort the content of any drawing library according 

to letters or numbers. 

 

In the drawing library, if the first letter of the name of each block is different, "Ascending"/ 

"Descending" command is used to sort the blocks according to first letter of block name 

(A-Z or Z-A). If the text parts of the blocks’ name are the same, e.g. Tree drawing library, 

in order to distinguish them, there might be some number added next to the text part, e.g. 

Tree 2, Tree2…  In this case, "Ascending"/ "Descending" command will sort the blocks 

in ascending/descending numerical order. 

 

Switch View 

The content of the drawing library can be displayed as thumbnail or list, which is similar 

to the display mode of file in windows. 

 

As shown in the following picture, we can click "Switch View" and select list to make the 

blocks displayed in form of list. 
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3.15.3 Import and Remake of New Drawing 

The explanation of the command’s function: 

Icon command Content 

New Drawing to 

Library 

  

  

  

  

  

1. Invoke "Block/New Drawing to Library" command in tool bar; select the drawing unit 

composing the block according to the prompt in the command line. We can also right 

click at the blank Block preview region and click "New Drawing to Library" command in 

the pop up menu. 

 

2. Specify the block base point according to the prompt in the command line. (It’s the 

center point of the select objects by default) 

 

3. The command line will prompt: 

Create slide (Please Zoom to fit) or [Back without creation(X)] <Create>: adjust the view 

and press enter to complete the creation of the slide. Or enter X to cancel the import. 

 

4. User can select the block and right click it, and then select rename to modify the name 

as what we need. 

Batch Import to 

Library 

1. Invoke "Batch Import to Library" command in the tool bar. 

 

2. In the pop up dialog box we can use Ctrl and Shift key to select multiple files and click 

"Open" button to complete the "Batch Import to Library." 
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Remake Block 

1. Click in the library the block to be remade and invoke "Remake" command in the tool 

bar, and the command line will prompt: 

 

2. Select drawing unit to from block<Only recreate slide>. 

Select the drawing unit in the drawing according to the prompt in the command line in 

order to remake a block to replace the selected block. Then the command line will go on 

prompting: 

 

3. Create Slide(Please Zoom to fit) or [not to create(X)]<Create>:  

We can press enter to make new slide or enter X to cancel "Remake".  

 

If we do not select any drawing unit and just press enter in the first step, new slide will be 

created just according to the drawings displayed in the current view. Besides, the new 

slide will replace the old slide without updating the definition of the block. 

 

3.15.4 Export and Replace Block 

Command’s function explanation: 

Icon 

command 

Content 

Export 

Double click the block in the preview region or select one block and click "OK" button on the 

tool bar, and we will be back to the drawing operation region. We can position the block via the 

command line. And we can also set the size of the block via block edit dialog box as follows: 

 

We can select "Enter Size" in it and directly specify the final size of the block reference. If we 

select "Enter Scale" instead, we have to specify the size of the block reference according to the 

insert scale.  If "Unify Scale" is checked, the block’s zoom scale of the three directions (x, y ,z) 

will be the same. Here we do not have to close the dialog box. 

 

The command line will prompt: 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change 

rotation/T-change base point] <Exit>: specify the inserting point or enter option key word to 

modify the parameter. 

Replace 

Block 

It is used to replace the block reference existing in the current drawing with the selected block. 

In the pop up dialog box we can select "Keep Insertion Scale" or "Keep Insertion Size". 
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3.15.5 Block Export Format 

We can use "Block/Export" to export the block from the drawing library. There are 3 export formats: "GstarCAD 

Object Block", "Ordinary Block" and "Original Drawing Unit". The method of setting the format is as follows: First, set 

the export format, then double click a block in the block preview region, and the block will be export according to 

the format set. 

 

After we select any one of the 3 export formats and double click a block in the block preview region, the "Block Edit" 

dialog box will be displayed, in which we can enter the scale or size, for details please refer to the previous chapter 

of "Export and replace block". After the blocks of different formats are inserted in the drawing, their appearance will 

have no difference, while, their operation properties are different. The grips displayed are very different when the 

different formats are selected. As shown in the following pictures, when we select the three formats separately to 

export a dynamic block, the grips displayed are different. 
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When we export the dynamic block, the format of "Original Drawing Unit" would be a concise one. If we export the 

dynamic block in other two formats, we can obtain the dynamic block via explosion.  
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4. Common Tools 

4.1 Common Tools 

4.1.1 Inquiry 

The command is more convenient than "List", as when using it, we do not have to select object. When the cursor 

passes object, we can dynamically check the related data of the object in text box. When we click object, we can 

automatically enter object edit dialog box to modify it. After the modification, the command will go on. Take the 

example of wall inquiry. Detail info will be displayed on the screen. When we click wall, "wall edit" dialog box will 

be displayed. 

 

Common Tools→Common Tools→Inquiry 

 

Click the command in the menu, and cursor will be displayed on the drawing. When it passes object, text window 

will be displayed as follows, on which object type, common layer, color and line type are listed. 

 

Example of "Inquiry": 

 

 

4.1.2 Object Edit 

The command provides GstarCAD Architecture object’s professional edit functions. System would automatically 

recognize object type and invoke related edit interface to edit GstarCAD Architecture object. We can also double 

click object to start up the command. However, when user want to edit multiple objects of same type, property edit 

is more suitable. 

 

Common Tools→Common Tools→Object Edit 

 

Click command in the menu or double click object, and command line will prompt: 

 

Select object need to edit: select the object to be edited, and we will enter related dialog box or command line, 

which depends on GstarCAD Architecture object we selected.  
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4.1.3 Object Select 

The command provides function of object filter selection. First, select the object that serves as filter condition and 

select other object, and objects of same style will be chosen from complex drawings, and selection set to be 

operated in batch would be created. We newly provided new function of material filter. Column and wall can be 

selected with it. After the execution of the command, the selected objects are in the selection set. When we execute 

command that will prompt "select object" immediately, e.g. "Erase" command, we can enter "P" in command 

line(the previous) to use the selection set as a response. 

 

Common Tools→Common Tools→Object Select 

 

Click command in the menu, and the dialog box will be displayed: 

 

Explanation of controls in the dialog box: 

Controls Functions 

Object Style Filter selection condition is style of drawing unit object. E.g. select all PLINE. 

Layer 

Filter selection condition is layer name. E.g., if the layer of filter reference drawing unit is 

A, only the objects on layer A can be selected when we select object. 

Color 

Filter selection condition is color of drawing unit object. It is used to select object of the 

same color. 

Line Style 

Filter selection condition is line style of drawing unit object. E.g., it can be used when we 

are to delete dotted line. 

Block Name etc. 

Filter selection condition is "Block Name", "Win-door" "Tag", "Text or Column Size Style". 

It can be used to rapidly select block with the same name or Win-door and column with 

the same tag. 

Material Filter selection condition is material of column or wall. 

 

Check the check box in the dialog box to define filter option, and we will see interaction of the command: 

 

Please select one referenced entity [2-Restore last selection] <Exit>: 

Select object to be filtered. (E.g. walls) 

 

Prompt: Pick nothing is select all, break with ESC! 

Select Object: 

Frame select range or directly press enter to select all (all walls). The wall we need will be selected and the grips 

will be displayed, too. 

 

We can select object using multiple filter conditions. We can also use the command consecutively. In this case, 

results of multiple filter selection are superimposed. 
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The filter regarding column is according to height, material and area (which indirectly indicate the size of it). The 

command can not distinguish mirror columns with the same size. 

 

In "Customize", "2" is set as shot cut of the command by default. 

 

4.1.4 In-Place Edit 

The command is suitable for the text edit of almost all GstarCAD Architecture annotation object except for multi-line 

text. The command does not need pop up edit dialog box. We can directly modify annotation single line text at the 

place where it is. 

 

Common Tools→Common Tools→In-Place Edit 

 

Click the command in the menu, and the command line will prompt: 

 

Please select the object which is needed to modify text: select annotation object like symbol or dimension etc. 

 

At this time, edit box will be displayed on annotation text on the far left of the annotation object. We can press 

direction keys to switch to other texts. We can execute the command when we want to enter Win-door tag in the 

case that the Win-door tag is blank. If there are texts, we can just double click the texts to enter In-Place Edit. 

 

4.1.5 Reset Text Position 

The command can restore text in GstarCAD Architecture professional object to default position. 

 

Common Tools→Common Tools→Reset Text Position 

 

Click the command in the menu, and the command line will prompt:  

 

Please select text object need to reset: select object in any way and press enter to complete the selection. 
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4.1.6 Free Copy 

The command is effective on both CAD ordinary object and GstarCAD Architecture object. Before copying object, 

we can also rotate, mirror it or change insert point of it. And it is multiple-copy by default, which is very convenient. 

 

Common Tools→Common Tools→Free Copy 

 

Click the command in the menu, and command line will prompt: 

 

Please select object to copy: 

Select object in any way. 

Please select base point: 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: 

Drag object to target position and click to insert it or enter option hotkey. 

 

All the objected selected by user will be copied to target position with the dragging of mouse. The command 

supports multiple-copy, which can copy source object to multiple target positions. We can also re-customize copy 

using other options in prompt.  

 

4.1.7 Free Move 

The command is effective on both CAD ordinary object and GstarCAD Architecture object. Before moving object, we 

can also rotate; mirror it or Change insert point of it.  

 

Common Tools→Common Tools→Free Move 

 

Click the command in the menu, and command line will prompt: 

 

Please select object to move: 

Select object in any way. 

Please select base point: 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: drag object to target position and click to insert it or enter option hotkey.  

 

It is similar to "Free Copy", however, there’s no new object created. 

 

4.1.8 Move by distance 

The command is used to move drawing object accurately according to specified direction. It can reduce typing 

times and improve work efficiency. 

 

Common Tools→Common Tools→Move by distance 

 

Click the command in the menu, and command line will prompt: 

 

Please select object to move: select the object to be moved. 



Chapter 4Common Tools 

387 

 

Please enter offset(x, y, z) or [X-horizontal/Y-vertical/Z-off screen] <Exit>: enter complete displacement vector x, y, 

z or option keyword. 

 

Usually, User only have to modify object’s position in one coordinate direction, in this case, we can directly enter X, 

Y or Z to specify displacement’s direction. When user wants to move object vertically, please enter Z. Then the 

command line will prompt: 

 

Off screen<0>:  

Enter offset length or pick two points on screen to specify offset distance. Positive value means moving object 

upward, while negative value mean moving object downward. 

 

4.1.9 Free Paste 

The command is effective on both CAD ordinary object and GstarCAD Architecture object. Before pasting object, we 

can also rotate; mirror it or Change insert point of it.  

 

Common Tools→Common Tools→Move by distance 

 

Click the command in the menu, and command line will prompt: 

 

Insert point or [A-rotate 90 degree/S-flip vertical/D-flip horizontal/F-align/R-change rotation/T-change base point] 

<Exit>: drag object to target position and click to insert it or enter option hotkey. 

 

Here we can enter A、S、D、F、R、T to deal with object before pasting, and then drag object to target position and 

click to insert it. 

 

The command should be executed after the execution of "Copy" or "Copy with base point". It is based on copy and 

paste of clipboard. It is mainly used for data exchange between several documents or between CAD and other 

application program. 

 

4.1.10 Part Hiding 

The command is used to temporarily hide the object that hampers observation and operation. 

 

Common Tools→Common Tools→Part Hiding 

 

Click the command in the menu, and command line will prompt:  

 

Select Object: 

Select the object to be hidden. 

 

We can continuously execute the command multiple times to hide objects. Please use "Restore Visible" command 

to make the hidden object visible. 

 

4.1.11 Part Visible 

The command is used to display the object that we will pay attention to and temporarily hide other objects. 
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Common Tools→Common Tools→Part Visible 

 

Click the command in the menu, and command line will prompt: 

 

Select Object: 

Select object not to be hidden, and other objects will be hidden. Press enter to complete the selection. 

 

Example of "Part Visible": 

Execute the command and select the second floor serving as X reference of combined model, and all the other floor 

objects will be hidden and only the second floor is displayed as a whole.  

 

 

4.1.12 Restore Visible 

The command is used to make the object that is hidden by "Part Hiding" visible again. 

 

Common Tools→Common Tools→Restore Visible 

 

Click the command in the menu, and the object that is hidden by "Part Hiding" will become visible again. There’s no 

command prompt here. 

 

4.1.13 Layer Tools 

Layer tools can be invoked via not only command menu but also layer shortcut tool bar as follow:   

 

 

4.1.14 Layer Off 

The command is used to close layers by selecting objects on it. For example, we can select a piece of furniture to 

close the layer where the furniture is. 

 

Common Tools→Layer Tools→Layer Off 

 

Click the command in the menu, and command line will prompt: 

Select an object, and the layer where the object is will be turned off. 
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Select object<Exit>: 

 

Example of "Layer Off": 

 

 

4.1.15 Turn Other Layers Off 

Select several objects on the layer that is to be kept on, and all layers will be turned off except for the layer where 

the objects are. For example, if we only want to see walls and Win-doors, we can click walls and Win-doors to turn 

off layers where other objects are. 

 

Common Tools→Layer Tools→Turn Other Layers Off 

 

Click the command in the menu, and command line will prompt: 

 

Select object<Exit>: 

Select several objects, and all layers will be turned off except for the layers where the objects are. 

 

Select object<Exit>: Press enter to exit.  

All the layers will be turned off except for the layers where the objects selected are. 

 

Example of "Turn Other Layers Off": 

 

 

4.1.16 Turn Layer On 

The command lists the turned off layers of the current drawing and X-reference in dialog box for users to select and 

open them. The list of description  

 

Common Tools→Layer Tools→Turn Layer On 
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Click the command in the menu, and the following dialog box will be displayed. The layers currently turned off are 

listed in the layer list. The list also includes X-reference layer turned off. 

 

Select the layers to be turned on one by one and click "Apply" or "OK", and we can turn on the selected layer. When 

we click "Apply", we can see result without closing the dialog box.  

 

4.1.17 Freeze Layer 

The command is used to freeze layers by selecting objects on it. Objects on the frozen layer can be neither 

displayed nor operated. 

 

Common Tools→Layer Tools→Turn Layer On 

 

Click the command in the menu, and command line will prompt: 

 

Select object<Exit>: 

Select object on layer to be turned off. 

...... 

Select object<Exit>: 

Press enter to exit. These layers will be frozen (not be displayed). 

 

4.1.18 Freeze Other Layers 

Select several objects on the layer that is to be kept on, and all layers will be frozen except for the layer where the 

objects are. For example, if we only want to see walls and Win-doors, we can click walls and Win-doors to turn off 

layers where other objects are. It is similar to "Turn Other Layers Off" command. 

 

Common Tools→Layer Tools→Freeze Other Layers 

 

Click the command in the menu, and command line will prompt: 

 

Select object<Exit>: 

Select several objects on the layer that is to be kept on. 

...... 

Select object<Exit>: 
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Press enter to exit. All the layers will be frozen (not be displayed) except for the layers to be kept on. 

 

4.1.19 Thaw Layer 

Select needed layer from list of layer that has been frozen to thaw it. 

 

Common Tools→Layer Tools→Thaw Layer 

 

Click the command in the menu, and the dialog box will be displayed. The layers currently frozen are listed in the 

layer list. The list also includes frozen X-reference layer. 

 

Select the layers to be thawed one by one and click "Apply" or "OK", and we can thaw the selected layer. When we 

click "Apply", we can see result without closing the dialog box.  

 

4.1.20 Lock Selected Layer 

The command is used to lock layer by selecting an object on it. After we lock layer, we can not see any change of 

the drawing. There only difference is that object on the locked layer can not be edited. 

 

Common Tools→Layer Tools→Lock Selected Layer 

 

Click the command in the menu, and command line will prompt: 

 

Select object<Exit>: 

Select object on layer to be locked. 

...... 

Select object<Exit>: 

Press enter to exit. We can not see any change of the drawing. 

 

4.1.21 Lock Unselected Layer 

Select several objects on the layer that is to be kept on, and all layers will be locked except for the layer where the 

objects are. It is similar to "Turn Other Layers Off" command. 

 

Common Tools→Layer Tools→Lock Unselected Layer 
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Click the command in the menu, and command line will prompt: 

 

Select object<Exit>: 

Select object on the layer that is to be kept on. 

...... 

Select object<Exit>: 

Press enter to exit. All the layers will be locked except for the layers to be kept on. And the locked layer can not be 

edited. 

 

4.1.22 Reset Layer 

The command is used to restore layers operated by other commands introduced in the section to original layer 

status. 

 

Common Tools→Layer Tools→Reset Layer 

 

Click the command in the menu, and the system will directly execute the command without displaying any prompt. 

 

4.1.23 All Layers On 
The command is used to turn on layers turned off by "Layer Off" command. However, it won’t thaw or unlock frozen 

layers and locked layers. 

 

Common Tools→Layer Tools→All Layers On 

 

Click the command in the menu, and the system will directly execute the command without displaying any prompt. 

 

4.1.24 Layer Merge 

The command provides a dialog box interface for user to select multiple layers to be merged and specify a target 

layer after merging in it. 

 

Common Tools→Layer Tools→Layer Merge 

 

Click the command in the menu, and dialog box will be displayed as follows: 
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Operation steps: 

1. Select multiple layers to be merged in the dialog box. For example, we select "A-WALL-PATT" and 

"A-WALL-MSNW". User can also click "Select<" button and select layers to be merged in drawing. 

 

2. Enter target layer name or select layer name from pull-down list. User can also click "Select<" button and obtain 

target layer like "A-WALL". If we enter the new target layer name that has not been defined in drawing, the command 

will prompt:  

 

Click "OK" button to complete operation of "Layer Merge". 

 

4.1.25 Change Entity Layer 

Select object in drawing and transfer the object to specified layer. 

 

Common Tools→Layer Tools→Change Entity Layer 

 

Click the command in the menu, and command line will prompt: 

 

Please select the object to change layer<Exit>: 

Both frame selection and point selection are supported. We can right click the mouse to directly exit the command. 

 

Please select the object to change layer<Exit>: 

Go on selecting objects and right click the mouse to complete the selection. 

 

Please select object on target layer or [enter layer Name (N)] <Exit>: 

Click any object on target layer. We can right click the mouse to directly exit the command. When we enter N here, 

the following dialog box will be displayed. 
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Directly select target layer in it and click "OK" button, and command line will prompt: 

 

XX objects converted to A-WALL-PATT layer! 

 

If the target layer entered does not exist in drawing, the command will prompt: 

Layer does not exist, confirm create? 

 

4.2 Curve Tools 

4.2.1 Combine to Pline 

The command is used to combine connected lines, arcs or plines as a Pline. 

 

Common Tools→Curve Tools→Combine to Pline 

 

Click the command in the menu, and the dialog box will be displayed as follows: 

 

Precision unit is current drawing unit. All options are checked by default, which means execution conditions are 

"Same Layer", "Same Color" and "Same Line Style". User can select these options as per needs. E.g., when we 

uncheck "Same Color" check box, we can use the command to combine lines of different colors as a pline. 

 

Please select lines to be combined. 

 

Select lines to connect (line, arc, polyline): 

Select objects to be combined including line, arc and polyline. 

 

Select lines to connect (line, arc, polyline): 

Press enter to complete the selection. System will combine selected objects as a Pline as per combination 

condition specified in the above dialog box. 

 

4.2.2 Connect Segments 

The command is used to connect two co-linear segments, two arcs with same center and radius, tangent segment 

and arc, or intersected segment and arc. 

 

Common Tools→Curve Tools→Connect Segments 

 

Click the command in the menu, and command line will prompt: 
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Please select first straight line, polyline, or arc<Exit>: 

Click the first line or arc. 

 

Please select second straight line, polyline, or arc<Exit>: 

Click the second line or arc. 

 

The following picture shows the example of connecting lines. Please be noted that when we select arcs, we should 

pick the points near the ends to be connected. 

 

 

4.2.3 Break at Intersection 

The command is used to break line, Pline, circle and arc on the same plane at the intersection. All segments in the 

selected range can be broken at the same time. 

 

Common Tools→Curve Tools→Break at Intersection 

 

Click the command in the menu, and command line will prompt: 

 

Please box select range need to break intersection <Exit>: 

Specify breaking range with at least one intersection point included. 

 

Please box select range need to break intersection <Exit>: 

Press enter to complete the selection. 

 

The segment and arc passing through intersection point will be divided into two parts. The command can be 

effective on line, Pline, circle and arc. Multiple segments can be broken at the same time. Ellipse itself only serves 

as boundary and will not be broken by other objects. Please refer to the example as follows. 

 

 

4.2.4 Switch Dashed/Solid Line 

The command is used to switch line type of drawing object between dashed and solid Line. 
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Common Tools→Curve Tools→Switch Dashed/Solid Line 

 

Click the command in the menu, and command line will prompt: 

 

Please select objects to change line type: 

After selection, press enter to switch line type of drawing object between dashed and solid Line. 

 

Original dashed line will become solid line, and original solid line will become dashed line. If the effect of dashed 

line is not obvious, please use system variable "LTSCALE" to adjust scale of it. 

 

4.2.5 Bold Curve 

The command is used to create a thickened pline on original curve. 

 

Common Tools→Curve Tools→Bold Curve 

 

Click the command in the menu, and command line will prompt: 

 

Please select curves to bold (Line/Arc/Circle/Polyline) <Exit>: 

Select each line and arc to be thickened. 

 

4.2.6 Remove overlapped lines 

The command is used to delete extra overlapped object. Objects taking part in the handling includes lines, arcs, 

circles which are lapped, partial overlapped and totally over lapped. For Pline, we have to explode it first and then it 

can take part in the handling. 

 

Common Tools→Curve Tools→Remove overlapped lines 

 

Click the command in the menu, and command line will prompt: 

 

Select Object<Exit>: 

Frame select the range where the overlapped lines are to be removed. 

 

Select Object<Exit>: 

Press enter to execute removing, and the result will be displayed. 

 

4.2.7 Reverse 

The command is used to change direction of polyline, wall, line pattern, and path curve. For wall, it is mainly used 

to solve the problem that left wall and right wall are opposed after execution of "mirror" command 
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Common Tools→Curve Tools→Reverse 

 

Click the command in the menu, and command line will prompt: 

 

Select line, polyline, wall, line pattern, or path curve to reverse: 

Select object to be handled. For closed object, command line will prompt: 

XXXX change to anti-clockwise (clockwise)! 

 

4.2.8 Boolean 

Other than CAD Pline, the command also supports GstarCAD Architecture objects including wall, column, slab, 

room, roof, path curve and so on. The command is effective on both multiple objects and objects of different types. 

Like in-place edit, "Boolean" is a new added object editing method, which can be invoked via right click   shortcut 

menu. The command can be used as a flexible and convenient modeling and graphical clipping function. 

 

Common Tools→Curve Tools→Boolean 

 

Click the command in the menu, and the following dialog box will be displayed: 

 

In the dialog box, there are three operation modes: "Union", "Intersection" and "Subtraction". Select one of them. 

Command line will prompt: 

 

Select first closed outline object (Pline, Circle, Plate, Column, Wall Patch, Room, Roof, Apron etc.): 

Select the first operation object. 

 

Select first closed outline object (Pline, Circle, Plate, Column, Wall Patch, Room, Roof, Apron etc.): 

Select other operation object. 

 

System will calculate multiple object regions selected according to specified Boolean operation. 

 

Example of "Boolean": 

Add French bay window area to room area. 

Steps: 

1. Draw rectangle along inner side of French bay window (the red part in the picture). 

2. Select room area object. 

3. Click "Boolean" command and select "Union". 

4. Select red rectangle part as shown in the above picture. Press enter to complete selection. The result will be as 

follows: 
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Create a C shaped irregular column. 

Steps: 

 

1. Use "rectangle" command to drawing rectangle according to outer contour of irregular column. 

2. Use "Offset" command to create another rectangle according to thickness of irregular column. 

3. Drag right side of the inner rectangle till it is above the outer of irregular column. 

 

4. Click "Boolean" command and select "Subtraction" 

 

 

4.3 Pattern Tools 

4.3.1 Grid Hatch 

The command provides object hatch function of grid and strip-type pattern. Grid object created by the command is 

very convenient that it can be snapped and aligned, and we can also add boundary around it. Original point 

(alignment point)’position can be modified by grip dragging or method of specifying in dialog box at will. it is can 

satisfy the needs of complex pattern arrangement of ceiling, floor board, ground tile and wall brick in interior and 

construction design. For detail, please refer to the section of "Building Design→Room and Roof→Room Layout→

Grid Hatch". 

 

4.3.2 Hatch Wood Grain 

The command is used to add wood grain pattern to specified region. We can set size and hatch direction of wood 

grain pattern. It applies to drawing section and elevation of wooden grain in decoration and design. 
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Common Tools→Pattern Tools→Hatch Wood Grain 

 

Click the command in the menu, and the following dialog box will be displayed: 

 

If user needs to select other patterns, please click pattern region and select them from wood grain library as follows: 

 

Command line will prompt: 

 

The first corner point<Select boundary>: 

Specify the first corner point of rectangle boundary. 

 

Another corner point<Exit>: 

Specify the second corner point of rectangle boundary. 

 

Insert or [change Base point/Rotation/Scale] <Exit>: 

Drag wood grain pattern and specify a point to insert it. Then press enter to exit. 

 

 

4.3.3 Hatch Add Hole 

The command is used to edit existing pattern hatch. We can use it to add hole to exiting hatch pattern.  

Before execution of the command, there should be pattern hatch in drawing. We can both draw boundary used to 

add hole and use existing Pline or block as boundary.  
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Common Tools→Pattern Tools→Hatch Add Hole 

 

Click the command in the menu, and command line will prompt: 

 

Please select hatch pattern<Exit>: 

Select pattern hatch object to which hole is to be added. 

 

The first corner point of rectangle or [Circular clip(C)/Polyline clip (P)/Polyline defined boundary (L)/Block defined 

boundary (B)] <Exit>: 

 

Another Corner Point<Exit>: 

 

Define a rectangle clipping boundary by specifying two corner points: P1 and P2. We can also enter key word C to 

use circle clipping. Please refer to the following picture. Dotted line in drawing is used to show boundary clearly.  

 

If user wants to use existing closed pline as boundary, please enter L here. 

 

Please select closed polyline as clipping boundary<Exit>: 

Select pline that has already defined. 

 

Program will automatically add hole to pattern according to pline boundary. Hole’s boundary will remain there. 

 

4.3.4 Hatch Remove Hole 

The command is used to edit existing pattern hatch. We can use it to remove the hole created via "Hatch Add Hole" 

command from exiting hatch pattern and recover the integrity of hatch pattern.  

 

Common Tools→Pattern Tools→Hatch Remove Hole 

 

Click the command in the menu, and command line will prompt: 

 

Please select hatch pattern<Exit>: 
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Select pattern hatch object from which hole is to be removed. 

 

Please select point within boundary<Exit>: 

Pick a point in hole. 

 

Program will immediately remove hole and recover original continuous pattern. We can use the command to 

remove one hole each time. 

 

4.4 Other Tools 

4.4.1 Block Convert 

We can use the command to convert "block" into "GstarCAD block". 

 

Common Tools→Other Tools→Block Convert 

 

Select block<Exit>: 

Select block to be converted. 

 

Select block<Exit>: 

Press enter to complete selection. 

 

Please refer to the following pictures. We can see the difference between the blocks before and after conversion. 

The blue points are grips of each block. 

 

 

4.4.2 Block Rename 

When using the command, user can select part block and GstarCAD block need to be renamed. The block definition 

name of original block and block reference name not to be renamed will remain there. The command supports 

selection before execution.  

 

Common Tools→Other Tools→Block Rename 

 

Click the command in the menu, and command line will prompt: 

 

Please select the block to rename<Exit>: 

Select a block to be renamed. 
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Besides1 blocks with same name, please select the block to modify at the same time or [all reviSe(S)] <only modify 

current>: 

 

If there are multiple block references, there will be prompt having user to decide whether to rename the currently 

selected block or rename all of them. In order to avoid renaming all blocks by mistake, "only modify current" is the 

default option. 

 

No matter how we operate: just press enter or enter S, the following prompts are all the same. 

 

Please enter new block name<New (2)>: 

If new block name entered is a legal one, block name can be successfully modified.  

 

Change block name "New" to be "New (2)" succeed. 

 

If new block reference name entered is same as name of other block reference in the drawing, the following prompt 

will be displayed. 

 

Block name existed, please enter new block name! 

Please enter new block name<New (4)>: 

Enter new block name which is not the same as any block reference name in the drawing. 

 

4.4.3 Change Block layer 

The command is used to modify internal layer of block definition so as to distinguish property of block’s different 

part. 

 

Common Tools→Other Tools→Change Block layer 

 

The first column "Original Layer" is current layer name of block. The column can not be edited. 

 

The second column "New Layer" is current layer name by default. User can select layer name currently available 

from pull down list or enter new layer name in it. 

 

When we check the checkbox "Change color of all drawing units to be by layer", color of drawing unit in block will 

be subject to color of related layer. When we click "Select<" and select an existing drawing unit in drawing, layer of 

selected drawing unit will be serve as new layer. Click the command in the menu, command line will prompt: 

 

Please select the block to change its layer<Exit>: 

Select block and press enter, and "Modify Layer for Block" dialog box will be displayed. 

 

Click button at the far left of the row, and a triangle shaped symbol will be displayed which means we have selected 

the row and related layer is to be modified. The object in selected layer will be highlighted. 
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Operation steps: 

1. Select layer to be modified as current layer, e.g.: "Sample Layer". Enter new layer name "Sample New Layer" or 

select existing layer name in pull down list. 

2. After modification of layer name, effect of modification will be displayed in drawing in real time. 

3. Go on modifying other layer name. When we modification is complete, we can click "Apply" button to preview 

effect or we can click "OK" button to confirm modification, and we can also click "Cancel" button to cancel 

modification. 

 

 

4.4.4 Measure Boundary 

The command is used to measure outer boundary of selected object. Click the command in the menu and select 

object, and X, Y, Z value of maximum boundary of selected objects including dimension object and annotation 

object will be displayed. System will use dotted line frame to express maximum boundary of object. 

 

Common Tools→Other Tools→ Measure Boundary 

 

Click the command in the menu, and command line will prompt: 

 

Please select objects need to calculate extents<Exit>: 

Frame select object range to be measured. 
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Please select objects need to calculate extents<Exit>: 

Right click mouse or press enter to complete selection and exit the command. 

X = 25657; Y = 12788; Z = 2850 

 

Retain boundary frame? [Yes/No]<Y>: 

 

 

4.4.5 Unify Elevation 

The command is used to sort out 2D drawing including plan, elevation and section drawing in order to avoid 

inconformity of Z coordinate of each drawing object caused by inaccurate operation. 

 

Common Tools→Other Tools→Unify Elevation 

 

Click the command in the menu, and the following dialog box will be displayed. 

 

Command line will prompt: 

 

Select objects need to modify elevation <Exit>: 

The objects are selected, will be unified on Z coordinate. 

 

4.4.6 Search Profile 

We can use the command to automatically find internal and external outline in construction 2D drawing and add a 

closed thick line there. If we pick point inside the 2D drawing, internal outline of closed region where the point is 

will be found. If we pick point outside the 2D drawing, external outline of the whole 2D drawing will be found. It can 

be used to automatically draw bold line of elevation. 

 

 

Common Tools→Other Tools→Search Profile 

 

Click the command in the menu, and command line will prompt: 
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Please select entity which is needed to search outline: 

Select drawing object. 

Enter Line Weight<2000>:200 

Enter width value, or press enter to use the default value. 

 

Here user can move cross cursor to search 2D drawing for closed region. The region found will be highlighted. 

 

Select generated outline<Exit>: 

Click external boundary of building to generate outline. The effect is as follows: in the picture, the red line is external 

outline of elevation. 

 

 

4.4.7 Clip Drawing 

With the command, we can use selected rectangle window, closed curve or block boundary as reference to clip and 

delete GstarCAD block and CAD 2D drawing unit in plan. It is mainly used to handle shelter relation of component in 

elevation drawing. 

 

Common Tools→Other Tools→Clip Drawing 

 

Click the command in the menu, and command line will prompt: 

 

Please select object clipped<Exit>: 

Select elevation component to be clipped. E.g., we select balcony door. 

 

First corner point of Rectangular or [Polygon clip/polyLine fixes boundary/Block fixes boundary]<Exit>: 

Select the first corner point in drawing. 

 

Another Corner Point<Exit>: 

Select the second corner point in drawing to define clipping range and complete the clipping. 
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User can also use other option to set clipping boundary. Please be noted that the command can not clip CAD 

pattern hatch. 

 

4.4.8 3D Cut 

The command can cut not only SOLID model but any 3D model. It can be used under any UCS e.g., elevation UCS. 

It is convenient to generate section perspective model. Two result blocks generated after cutting is convenient for 

user to move or delete. The block is surface model which will be converted into 3DFACE after explosion. 

 

Common Tools→Other Tools→3D Cut 

 

Click the command in the menu, and command line will prompt: 

 

Please select 3D object that need to slice: 

Specify the first point. 

 

Please select 3D object that need to slice: 

Specify opposite corner point to determine drawing range. 

 

Select start point of cutting line or [Polyline slice (D)] <Exit>: 

Specify start point. 

 

Select end point of cutting line <Exit>: 

Specify end point. 

 

Example of "3D Cut": 

We can use the command to cut selected object into two parts with vertical surface specified by two points. Please 

refer to the following picture.  

 

 

4.4.9 Rectangle 
Rectangle created by the command is 3D object in common use defined by GstarCAD Architecture. There are 

abundant of diagonal pattern. We can drag its grips to modify its plane size. It can be used to express all kinds of 

equipment and furniture. 
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Common Tools→Other Tools→Rectangle 

 

Click the command in the menu, and the dialog box will be displayed: 

 

Explanation of controls in dialog box: 

Controls Functions 

Length/ Width Length and width of rectangle. 

Thickness Give Height of 3D rectangle to make it a cuboid. 

Elevation Relative elevation of rectangle. 

We can click icon in icon tool bar of dialog box to select form of rectangle to be drawn. We can also preselect base 

point position of rectangle, which is at the center of rectangle by default. 

 

There are three drawing methods of rectangle: "Drag Diagonal Draw", "Insert Rectangular" and "3D Rectangular". We 

have to enter rectangle parameter in dialog box and then insert it in drawing. The default drawing method is "Drag 

Diagonal Draw" which is related to the first icon in tool bar. User can go into drawing area and drag cursor to draw 

rectangle. Then command line will prompt: 

 

Enter the first corner point or [I-insert rectangle] <Exit>: 

Specify position of rectangle’s corner point. 

 

Enter the Second Corner Point or [I-insert rectangle/Undo the first corner point] <Exit>: 

Specify opposite corner point of rectangle or specify accurate relative coordinates. 
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5. Settings and Help 

5.1 Settings 

5.1.1 Drawing Settings 

There are two pages in the dialog box. "Basic Settings" page include parameters related to GstarCAD Architecture 

global setting. These parameters are just related to current drawing. In other words, once we modify these 

parameters, parameter settings of current drawing will change, but it has no affect on related parameter in new 

created drawing. 

 

Settings and Help→Settings→Drawing Settings 

 

At the bottom of the dialog box, we provide many convenient parameter management functions. The related buttons 

are: "Export", "Import", "Default", "OK" and "Cancel". 

 

Basic Settings: Once we set parameter in it, it will apply to the object that has been drawn in the current drawing.  

 

The explanation of Drawing Settings: 

Controls Functions 

Unit Setting: We can select different drawing unit and dimension unit as per our own needs. 
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Current Scale: 

It is used to set the output scale of the new created object. The scale will be displayed on 

the far left of the status bar. The default initial scale is 1:100. The setting has no affect on 

the existing drawing object. It only applies to the new created GstarCAD Architecture 

object. All the GstarCAD Architecture objects except block have a "Print Scale" parameter, 

which is used to control the objects’ 2D view. E.g., suppose there’s a wall line whose 

thick line width is 0.4mm, if we set the scale parameter of it as 200 and turn on the 

"thicken" button, we can measure in the model space: wall line thickness=0.4x200＝80 

drawing unit.  We can also directly set the current scale via the status bar. 

Default Height: 

It is used to set the default height used in the current drawing. The setting has no affect on 

the height of the wall, column and stair that has been drawn. It only serves as the default 

height of the new created wall and column. Please do not confuse the concept of current 

default height, the height in the floor table and the component height. 

Current default height: it only serves as the height of the new created wall, column and 

stair. 

The height in the floor table: it is used to position the floor in the z direction when we 

convert the standard floor to natural floor and stack them. 

Component height: After the component like wall and column is created, their height 

parameter has nothing to do with other global settings. Each component in a floor can 

have independent different height of its own so as to meet the requirement on the special 

cases like win-door between stairs, split-level and spring layer. 

Display Mode: 

2D (only display the 2D view of GstarCAD Architecture object): under 2D display mode, 

the object will be displayed as 2D view no matter in which viewport (plane view, 

axonometric view or perspective view.) Even if the object is under axonometric view, it 

will still be displayed as 2D plan. 

3D (Only display the 3D view of GstarCAD Architecture object): under 3D display mode, 

the current drawing will be displayed as 3D view according to 3D projection’s rule no 

matter in which viewport. 

Automatic (automatically judge from the view direction and determine whether to display 

the GstarCAD Architecture object in 2D or 3D mode): the system will automatically 

determine the display mode of the object according to the view direction of the viewport. 

When it is under plan view or top view, it will be displayed in 2D mode. While under other 

view direction, it will be displayed in 3D mode. Generally, it is the most convenient 

method. In this case, we can observe 2D and 3D expression effect in one screen at the 

same time. However, the performance will be lower than that of 2D or 3D display mode 

due to the objects’ regeneration caused by the change of the view direction and the range.   

Stair section: 

When we draw stair’s plan construction drawing, we need to draw cutline. The system 

provides both the Double Cutline and Single Cutline drawing method. 

Room Area Precision: It is used to set the dimension precision of room area. 

The explanation of Symbol Settings: 
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Controls Functions 

Bubble Text 

There are three bubble text styles selectable: "Fixed Width Factor", "Auto adjust Width 

Factor", "Text out of Range". 

"Fixed Width Factor": Width-height ratio of the text will be preserved, and text will be 

restricted by the diameter of the bubble. When the text includes a lot of characters, the text 

height will decrease.  

"Auto adjust Width Factor": The text height will be restricted by "Text Height Factor of 

Bubble Text", thus, when the text includes a lot of characters, each character will become 

narrow.  

"Text out of Range": width-height ratio of the text will be preserved and the text height will 

be restricted by "Text Height Factor of Bubble Text", however, text will not be restricted by 

the diameter of the bubble. 

 

Text Height Factor of 

Bubble Text: 

It is the ratio of Bubble Text height to the max text height that can be held by the bubble. 

The max value of it is 1.0 which indicates that the text occupies all the available height in 

the bubble. Its default value is 0.7. 

Factor of Annotation 

Text and Baseline: 

It is used set the distance between text and the baseline in symbol dimension object. The 

factor is the multiple of the text height. 

Dot Elevation Mark 

Diameter: 

It is used to set the size of the dot symbol used in "Elevation for Site Plan". 

Triangle Elevation 

Symbol Height: 

It is used to set the size of the triangular symbol used in "Elevation for Site Plan". 

Material Style: It is used for single wall/column hatch. Various hatch pattern and bold line width are provided. 
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The last row of "Material Name" is blank row. User can customize the new material name here. There is no 

restriction on the quantity of the customized material. The parameter of material’s hatch pattern, color and priority 

can be set at will. When we create wall and column, we can use the new added material here. 

 

There are two hatch levels: "Standard Hatch" and "Detail Hatch". User can use "Wall or Column Scale > 1:? Enable 

Detail Mode" to set the condition of starting detail mode. If the output scale of the object does not satisfy the 

condition, standard hatch will be used. If the output scale of the object satisfies the condition, detail hatch will be 

used. It effectively meets the requirement that different type of construction drawing has different detail level of hatch 

and bold. 

 

Note: When we are going to use bold or hatch function to print drawings, before which please do not keep the bold 

or hatch function on all the time so as to maintain the clarity of drawing as well as the high speed of drawing 

processing. We can start the functions just before we need to print drawings. In the case that we don’t have to use 

bold or hatch function to print drawings such as interior design or other plans used in non architecture major, 

please do not start the bold or hatch functions. 

 

Title  Function 

Material Name 

The name of the material used in wall or column. User can select different line width 

and international hatch legend for different material names. User can also customize the 

materials. There is no restriction on row quantity. 

c If the output scale of the object does not satisfy the condition of starting the detail mode 



Chapter 5Settings and Help 

412 

 

Material Bold and Hatch Settings: 

Bold and Hatch Control: 

Controls Contents 

Bold Wall or 

Column Inward 

When it is checked, the function of wall/column bold will be available. Bold line width 

can be defined in the above table. 

Hatch Wall or 

Column 

When it is checked, the function of wall/column hatch will be available. Hatch pattern 

can be defined in the above table. 

Wall or Column 

Scale > 1:? Enable 

Detail Mode 

It is used to set the condition of starting detail mode. 

If the output scale of the object does not satisfy the condition of starting the detail mode 

(Wall or Column Scale > 1:? Enable Detail Mode), standard hatch will be used. 

If the output scale of the object satisfies the condition of starting the detail mode (Wall 

or Column Scale > 1:? Enable Detail Mode) ,detail hatch will be used. 

Hatch Pattern 

Preview box 
Provide us with preview box of "Standard Hatch" and "Detail Hatch". 

 

Wall Style: By compositing varied material style, user could construct Composite Wall style. 

(Wall or Column Scale > 1:? Enable Detail Mode), standard hatch will be used. 

(Standard Hatch) 

Scale 

(Standard Hatch)The scale is used to adjust the proportion of Standard Hatch in case 

that the filling effects are too dense or too sparse. Its range is between 0.1 and 10. 

(Standard Hatch) 

Angle 

This button is used to adjust the angle of the Standard Hatch. 

Detail Hatch 

If the output scale of the object satisfies the condition of starting the detail mode (Wall 

or Column Scale > 1:? Enable Detail Mode), detail hatch will be used. 

Detail Hatch Mode Here we can use "Common Hatch" mode. 

(Detail Hatch) Scale 

(Detail Hatch)The scale is used to adjust the proportion of Detail Hatch in case that the 

filling effects are too dense or too sparse. Its range is between 0.1 and 10. 

(Detail Hatch) Angle This is used to adjust the angle of the Standard Hatch. 

Hatch Color 

We can use it to directly set the hatch color of wall and column, thus we no longer have 

to modify the wall and column hatch’s layer to set different color for them. The default 

setting of 256 means that the wall and column’s hatch color is the same as the color of 

their default layer (pub hatch). We can click the button on the right of the cell to change 

it to other colors. 

Standard Line Width 

If the output scale of the object does not satisfy the condition of starting the detail mode 

(Wall or Column Scale > 1:? Enable Detail Mode), "Standard Line Width" will be used. 

Detail Line Width 

If the output scale of the object satisfies the condition of starting the detail mode (Wall 

or Column Scale > 1:? Enable Detail Mode), "Detail Line Width" will be used. 
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Title  Function 

Wall Style Name 

The name of the Composite Wall Styles. User can select one of them for editing and 

customizing. 

New Create a new Wall Style with empty material. 

Copy Create a new Wall Style based on existing selection. 

Rename Rename one of existing Wall Style name. 

Delete Delete one of existing Wall Style name. 

Detail Property 

List all the setting material related to Wall Style which you select now. Here, the user 

can adjust the order and parameters of the material. 

No. The order of the material is adjusted by the button "Move Up" and "Move Down". 

Width(mm) 

By default, the thickness of the material is "BW" (By Width). That means that width of 

each material is set according to the given width of the command. Here you can also 

set the thickness of the material in detail. The unit is always mm. The program will be 

automatically converted according to the current drawing unit relationship. 

Priority 

Priority parameters for material display figure with a high value will hide the low figure. 

By default, this value is fetched from the "Material Style" Users can readjust priority 

parameters as needed. 

Material 

The material of the wall, users can click on one of all the columns and then choose the 

right material in the list. 

Standard Hatch 

Pattern 

Display the fill style of the material in Standard Hatch Pattern. The fill style is selected 

from Material. Users can not make adjustments. 
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(Standard Hatch 

Pattern) Scale 

Display the filling style ratio of the material in Standard Hatch Pattern. The filling style is 

selected from Material. Users can make adjustments. To ensure the good filling effect, 

numerical range is being 0.1-10. 

Detail Hatch Pattern 

Display the filling style ratio of the material in Standard Hatch Pattern. The filling style is 

selected from Material. Users can not make adjustments. 

(Detail Hatch 

Pattern) Scale 

Display the filling style ratio of the material in Standard Hatch Pattern. The filling style is 

selected from Material by default. Users can adjust to ensuring the appropriate filling 

effect. Numerical range is being 0.1-10. 

Add Add a new material into the current Composite Wall Style. 

Remove Delete a selected material in the current Composite Wall Style. 

Move Up Move up and sort a selected material in the current Composite Wall Style. 

Move Down Move down and sort a selected material in the current Composite Wall Style. 

 

5.1.2 Option Config 

The command is used to configure parameters of user design environment including "Layer", "text Style", "Size 

Style", "Win-door tag", "Room Type" and "Advance Option". Setting parameter in "Option Config" is similar to making 

template for new drawing. It would not update original parameter of current drawing. It only has an affect on object 

in new created drawing. For example, when we use "Option Config" to create a new text style for room area, the style 

can not be seen in text style command dialog box of the current drawing. Only after we execute "Search Room" 

command in new created drawing to obtain room area object, can we see the modified text style in object’s 

properties bar.  

 

Settings and Help→Settings→Option Config 

 

After Clicking "Option Config" command in the menu, in the pop up dialog box we can click "Layer", "Text Style", 

"Size Style", "Tag Settings" and "Advance Option" tab to go to the respective page.  

 

5.1.2.1 Layer 

"Layer" page provide us with layer name custom tools. User can customize layer name according to layer standard 

and keyword. There are two levels regarding it: "Basic Layer" and "Assemble Layer". If user want to modify layer of 

existing drawing object, Please be noted that there are two application methods regarding the command’s layer 

setting. 

 

Method 1: the predefined layer used by object is automatically activated when the object is drawn. However, the 

layer of object drawn before will remain unchanged. Please click "Layer Conversion" button in the dialog box or 

execute "Layer-Std Convert" Command. 

 

Method 2: the predefined layer will be applied to current drawing only when we need it. In the case, objects using 

these layers are not necessary. As long as we predefine the layer standard as per needs and click "Apply Layer Std" 

button in the dialog box as follows. 
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5.1.2.2 Text Style 

User can use "Text Style" page to manage the default text style used in annotation object of different purpose in the 

drawing. New parameter definition is effective on the new created object instead of existing objects. The existing 

object will keep the original style. 

 

Row of "Default Text" is used to set the default text style of single line text and multi-line text. Rows of "Room Area", 

"Axis Number", "Size", "Label" and "Door and Window Label" are used to set the default text’s style for the respective 

objects. 

 

5.1.2.3 Size Style 

"Size Style" page is used to manage various parameters related to the dimension style provided by the software. The 

new parameter definition is effective on new created object instead of existing object. The existing object will keep 

the original style. 
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5.1.2.4 Tag Settings (Win-door) 

"Tag Settings (Win-door)" page is used to create the rule of naming Win-door tag in current drawing. User can 

customize win-door tag prefix rule according to different category of Win-doors. "By Size" under "Tag Rule" on the 

right is used to number Win-door according to its width and height. GstarCAD Architecture provided corner window 

and ribbon window, and there are many dimension methods regarding them. GstarCAD Architecture also provided 

tag settings regarding them. When we check "Add Hyphen" and "Segmentation Tag", dimension will be added to 

corner window and ribbon window according to distance of each segment. For example, there’s a ribbon window 

with the first segment of 1 m, and the second segment of 2m. The height of it is 1.5m. Then the dimension would 

be like this: (10 + 20)15.  
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5.1.2.5 Tag Settings (Room) 

"Tag Settings (Room)" page is used to set the relation between standard room type and default room name. User 

can extend and modify room name definition used in current project. The room type and room name defined here 

will be displayed and selectable in room object edit dialog box. 

 

Room type and room name defined here will be served as basis of distinguish room, hall, bath room during 

residential building area statistic. 
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5.1.2.6 Advance Option 

 

Classification of "Advance Option": 

Advance Option content includes five chapters. Next we will introduce them one by one. 

 

System 

The chapter introduces system parameter of global control. It is divided into four parts: "Entity", "Draw Model 

Number", "Precision" and "Line type". 

 

System >Entity>Save 

"Save Proxy Object": The default value is "Yes". 

 

System >Entity>Intelligent Linkage Mode Switch 

"Automatic Linkage": The default value is "Yes". 

 

When we start up "Automatic Linkage", we start up two groups of linkage operations as follows: 

 

1. We start up linkage operation between walls. When we drag grip on walls and pipes, other walls and pipes 

associated to it will be moved accordingly. 

 

2. We start up linkage between Win-door and Win-door dimension. When we copy, move, delete Win-door or 

modify its size, the related Win-door dimension will change accordingly. 

 

"Intelligent Linkage Mode": The default value is "Global linkage". 
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We can select "Global linkage" or "Partial linkage" to control "Intelligent Linkage Mode". When we set it as "Global 

linkage", for co-linear walls, we just have to drag one wall segment of them, and the whole walls will move together. 

When we set it as "Global linkage", only the merged walls can move together. 

 

System >Entity> Baseline Color 

"Baseline Color": The default value is "77". 

Wall baseline is auxiliary line that will not be printed out. We can set color of it here. Please display wall baseline as 

per needs. 

 

System >Entity> Entity layer 

"Entity layer": The default value is "Default layer". 

It is used to set whether the default layer that we used layer standard to define or drawing’s current layer will be 

effective on new created object. 

 

System >Entity> Draw Model Number 

Switch on Draw Model Number. 

"Switch on Draw Model Number": The default value is "No". 

 

"Draw Model Number": This is a setting of stepping of wall drawing and Win-door positioning. Its value is 

determined according to construction design rule. 

 

"Wall Drawing Model Number": The default value is "300". 

It is the length stepping value of wall drawing. 

 

"Window Drawing Model Number": The default value is "10". 

It is the stepping value of Win-door positioning when we use "Free Insert" command to insert Win-door in the wall.  

 

System >Entity>Precision 

"Float-Point Calculation Precision": The default value is "0.000000001". 

It is an internal parameter. Generally, users do not have to modify it. 

 

"Distance Precision": The default value is "0.01". 

It is an internal parameter. Generally, users do not have to modify it. 

 

"Angle Precision": The default value is "0.0001". 

It is an internal parameter. Generally, users do not have to modify it. 

 

"Area Precision": The default value is "0.000001". 

It is an internal parameter. Generally, users do not have to modify it. 

 

"Volume Precision": The default value is "0.000001". 

It is an internal parameter. Generally, users do not have to modify it. 
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"Divide Arc Precision": The default value is "16". 

Equal division quantity of Arc. The following values are selectable: 8 12 16 20 24 28 32 36 48 64 96. Generally, 

users do not have to modify it. 

 

"Linear Precision": The default value is "200". 

Equal division distance. It applies to arc wall etc. The unit is MM. Generally, users do not have to modify it. 

 

"Wall Joint Precision": The default value is "20". 

If distances between walls are less than value of "Wall Joint Precision", they will be automatically connected or 

merged. 

 

"Pipe Joint Precision": The default value is "10". 

If distances between walls are less than value of "Pipe Joint Precision", they will be automatically connected or 

merged. 

 

System >Entity>Auto Line type Scale 

"Line type Scale": This is used to control line type (dotted line, or dash line etc.) segment length and space between 

them. Model Space and Paper Space have their own different "Line type Scale". 

 

"Enable Auto Line type Scale or No": The default value is "Yes". 

It is the switch of "Enable Auto Line type Scale". 

 

"Auto Line type Scale in Model Space": The default value is "1000". 

It is the "Auto Line type Scale" used in model space, which is shared by model spaces. The related system variable 

is "Ltscale". The default value is 1000. It has nothing to do with output scale. 

 

"Auto Line type Scale in Paper Space": The default value is "10". 

It is the "Auto Line type Scale" used in paper space, which is shared by each view port of paper space. The related 

system variable is "Ltscale". The default value is 10. It has nothing to do with view port scale. 

 

Entity 

This chapter introduces mode settings of five drawing objects of GstarCAD Architecture, including mode settings for 

"Text and Sheet", "Axis Label", "Win-door", "Dimension" and "Cut Symbol". 

 

Entity>Text and Sheet 

"Explode Type for Text": The default value is "Enable explode". 

 

There might be characters of different languages in a text object. Their heights of them are likely to be different. 

GstarCAD Architecture provides two explosion modes regarding as "Enable Explode" and "Disable Explode". If we 

select "Enable Explode", text height scale will remain unchanged after explosion. If we select "Disable Explode", text 

will keep a whole, which would make the operation on it convenient. However, it is likely to cause the inconformity 

of width- height ratio of the characters of different languages. Please refer to the following picture: Under "Disable 

Explode" mode, the character’s width and height change. Under "Enable Explode" mode, the characters’ 

width-height ratios remain unchanged. 
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Entity> Quicken Text 

"Quicken Text": The default value is "On". 

There are two options selectable regarding "Quicken Text" function. They are "On" and "Off". When we start up 

"Quicken Text" function, the precision will be decreased slightly.  

 

Entity>Axis Label 

"Color of the hidden Axis Label": The default value is "108". 

In order to distinguish hidden and shown axis label during axis label editing, we use color that has little contrast 

with screen to express hidden axis label. When background color is black, we used dark color, e.g., color 108. 

When background color is white, the color is no longer suitable, thus we have to modify it to color that has little 

contrast with screen, e.g., Hoar. 

 

Entity>Win-door 

"Ribbon Win-Door in 2D" is used to control three-line or four-line display of "Banding Window", "Arc Window", 

"Balcony Window" and "Curtain Wall" under 2D mode. 

 

"Ribbon Win-Door in 2D Style": The default value is "Change by scale". 

There are three options selectable regarding "Ribbon Win-Door in 2D Style": 1 "Change by scale" 2 "Fixed 

three-line" 3 "Fixed four-line". When we select "Change by scale" here, whether to use three-line or four-line is 

control by "Display Three Scale for 2D Ribbon Window". If the current scale is less than or equal to the value of 

"Display Three Scale for 2D Ribbon Window", three-line will be used to express Ribbon Win-Door. 

 

"Display Three Scale for 2D Ribbon Window": The default value is "150". 

If the current scale is less than or equal to the value of "Display Three Scale for 2D Ribbon Window", three-line will 

be used to express Ribbon Win-Door. E.g., given the scale of construction site plan is 1:250, which is less than 

1:150. In this case, three-line will be used to express Ribbon Win-Door. While in common construction plan, given 

the scale is 1:00, which is larger than 1:150, in this case, four-line will be used to express Ribbon Win-Door. 

 

Entity>Dimension 

Dimension Object Settings. 

"Line Dimension Style": The default value is "Bold line". 

 

"Line Dimension Style" including "chord length dimension" has three options selectable: 1 "Bold line" 2 "Thin line" 

3"Dot". The default style is "Bold line". 

 

"Angle and Arc Dimension Style": The default value is "Arrow". 

 

"Angle and Arc Dimension Style" has two options selectable: 1 "Arrow" 2 "Dot" The default style is "Arrow". 

 

"Dimension Auto-adjust": The default value is "Auto increase". 

 

"Dimension Auto-adjust" has three options selectable: 1 "Auto" 2 "Auto increase" 3 "Auto decrease". 
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Entity>Cut Symbol 

"Double Break line Style": The default value is "Single line". 

"Double Break line Style" has two options selectable: "Single line" and "Double line". The effect is as shown in the 

picture below. 

 

 

Command 

The chapter introduces the condition parameters required by some commands. 

 

Command>Axis and Column 

Command>Axis and Column >Wall to Axis 

"Min Wall Length": The default value is "500". 

 

"Min Wall Length": The minimum wall length required when we use "Wall to Axis" command to generate axis. If wall 

length is less than it, we can not use "Wall to Axis" command to generate axis. 

 

"Axis Extend": The default value is"1000". 

"Axis Extend" is the extend length in two direction of axis created by "Draw Grid" command. Please refer to the 

following picture. 

 

 

Command>Convert Filter DWG 

"Convert Filter DWG": Convert construction drawing into condition drawing as per requirement of each major. 

Classification Object name  Classification Object name 

"Axis Line" LINE,ARC "Axis Label" IAEC_AXIS_LABEL,IAEC_DIMENSION 

"Wall" IAEC_WALL "Win-door" 

IAEC_OPENING,IAEC_GROUP_OPENING,IAEC_CORN

ER_WIN 

"Column" IAEC_COLUMN "Stair" IAEC_*STAIR 

"Room" IAEC_SPACE "Toilet ware" IAEC_INSERT,INSERT 
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"Dimension" 

IAEC_DIMENSIO

N 

"Frame" POLYLINE,LWPOLYLINE 

"Text" 

IAEC_TEXT,IAEC_

MTEXT,TEXT 

    

 

Project Management 

The chapter introduces setting content of GstarCAD Architecture project management interaction interface. 

 

"Auto Load Recent Project" The default value is "No". 

 

It controls whether to automatically load recent projects when we start up the software. If we set it as "Yes", when we 

start up the software, recent project will automatically be loaded. 

 

Project Management>Floor Table 

"Floor Frame": This is a rectangular box used to define range of plan belonging to a standard floor. 

 

"Display Floor Frame": The default value is "No". 

Here we can set whether "Floor Frame" will keep on displaying after we complete the operation of defining floor 

frame. 

 

"Floor Line": In the command of "Elevation" and "Section", floor line is provided as auxiliary line at the position of "0" 

elevation. 

 

"Overhang of Floor Line": The default value is"1000". 

Here we can set of floor line’ extend length starting from exterior wall. 

 

Default 

Default>Common >Text 

"Coefficient of Text to Baseline": The default value is"0.3". 

It is the factor of distance between annotation on symbol leader line and text baseline. 

 

"Word Space": The default value is "Yes". 

This is the factor of keeping space between words when sentence has been exploded. Set "Yes", just like English 

language. Enable to be used as Japanese, Korean, Chinese languages. 

 

"Bubble Text Style": The default value is "Fixed width factor". 

Bubble text applies to axis number and index symbol. There are three bubble text’s styles selectable: "Fixed Width 

Factor", "Auto adjusted Width Factor", "Text out of Range".  

 

"Fixed Width Factor": Width-height ratio of the text will be preserved, and text will be restricted by the diameter of 

bubble. When the text includes a lot of characters, the text height will decrease. 

 



Chapter 5Settings and Help 

424 

 

"Auto adjusted Width Factor": The text height will be restricted by "Text Height Factor of Bubble Text", thus, when the 

text includes a lot of characters, each character will become narrow. 

 

"Text out of Range": Width-height ratio of the text will be preserved and the text height will be restricted by "Text 

Height Factor of Bubble Text", however, text will not be restricted by the diameter of the bubble. 

 

"Text Height Factor": The default value is"0.7". 

It is the ratio of text circle diameter to bubble internal diameter. The largest value of it is 1.0. 

 

Default>Common >Elevation Dimension 

"Triangle Size": The default value is"3". 

It is the height of elevation symbol triangle. The unit of it is mm. 

 

"Dot Size": The default value is"1.5". 

It is the diameter of elevation symbol dot. The unit of it is mm. 

 

"Precision": The default value is"0.000". 

Display precision of elevation value has following selectable options: 0 0.0 0.00 0.000 0.0000 0.00000. The default 

value of it is 0.000. 

 

Default>Common >Coordinate Dimension 

"Precision": Display precision of coordinate value has following selectable options: 0 0.0 0.00 0.000 0.0000 

0.00000. The default value of it is 0.000. 

 

Default>Common >Axis 

"Axis Circle Diameter": The default value is"8". 

It is used to set the diameter of axis circle. 

 

Default>Common 

"Display Mode" The default value is "Auto". 

"Display Mode" has three options: "Auto", "Complete 2D"and "Complete 3D". It is used to control whether drawing is 

displayed as 2D or 3D mode. If we select "Auto" here, drawing will be automatically displayed as suitable mode 

according to current view. In this case, under 2D plane view or side view, drawing will be displayed as per 

construction drawing rule. Under other views, drawing will be displayed as 3D projection line frame. If we select 

"Complete 2D", drawing will only be displayed as 2D drawing. If we select "Complete 3D", drawing will be displayed 

as 3D projection line frame according to current view. Please refer to the following pictures. 
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"Print Scale": The default value is "100". 

It is used to set initial print scale. Drawing unit is mm. 

 

"Detail Scale": The default value is "100". 

 

It is used to set initial detail scale. Drawing unit is mm instead of m. The scale is 1:100. The default value is "100". 

 

"Floor Height": The default value is "3000". 

It is used to set initial floor height. It only supports the case that drawing unit is mm. The default value is "3000". 

 

"Drawing Unit": The default value is "Millimeter". 

 

"Use UCS Angle as Default Layout Angle": The default value is "Yes". 

 

"Viewport Control": The default value is "None". 

 

It is used to control whether initially start up "By viewport scale" and "By viewport angle". It is only effective on new 

created object. The options include: "None", "Adjust by viewport", "By viewport scale" and "By viewport angle". The 

default value is "None", which means drawing object is not initially adjusted by current output scale instead of 

viewport scale or viewport angle. Besides, we can set the same property in properties bar for every GstarCAD 

Architecture object.  

 

After we set parameter for "Viewport Control", current scale and layout rotation in original object’ properties bar will 

be replaced. Please refer to the following picture: it is the example of setting "Viewport Control" as "Adjust by 

viewport". 

 

The scales of the two viewport are 1:100 and 1:50. 
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"Adjust by viewport": This applies to current drawing, block, X-reference, block X reference. When we start up 

"Viewport Control", object will have following new properties. 

 

"By viewport scale": Under model space, object will be adjusted by drawing’s current scale (at the left bottom 

corner of status bar), which is effective on reference and object in block. Under paper space, object will be adjusted 

by viewport scale (the scale that we set during viewport definition), which is effective on all customized object. 

Beyond layout viewport, the object will be adjusted by layout scale (the value is always 1:1). 

 

"By viewport angle": Under model space, object will be adjusted by WCS angle (0 degree), which is effective on 

reference and object in block. In layout viewport, object will be adjusted by viewport angle, which is effective on all 

customized objects. 

 

Architecture 

Architecture >Wall 

"Hatch": The default value is "No". 

 

It is used to set whether wall object is initially filled with hatch or not. The default value is "No", in this case, wall is 

not filled with hatch initially. 

 

"Bold": The default value is "Yes". 

It is used to set whether wall object is initially thickened or not. The default value is "No", in this case, wall line is 

not thickened initially. 

 

"Baseline": The default value is "Yes". 

It is used to set whether wall baseline is initially displayed or not. The default value is "No", in this case, wall 

baseline is not initially displayed. 

 

Architecture >Space 

"Name Number Display Mode": The default value is "Only display name". 

It is used to set initial dimension format of room area. There are three options selectable: "Only display name", "Only 

display tag" and "display name and tag". 

 

"Dimension Area": The default value is "Yes". 

It is used to set whether to add area dimension after the execution of "Search Room" command. 

 

"Dimension Unit": The default value is "No". 

It is used to set whether to add unit dimension after the execution of "Search Room" command. 

 

"Precision": The default value is"0.00". 

It is used to set area dimension’s initial precision. The following options are selectable: 0 0.0 0.00 0.000 0.0000 

0.00000. The default precision is 0.00. 

 

Architecture >Stair 

"Single Section": The default value is "No". 
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It is used to set whether cutline of stair is single line or double line. The default value is "No". 

 

5.1.3 Customize 

Settings and Help→Settings→Customize  

 

Click "Customize" command in the menu to start "Customize" dialog box interface. User’s personalized settings and 

modification can be saved and shared via the function of "Export", "Import" and "Default". Please be noted that 

"Default" only has impact on the parameters of "Customize" part. In the pop up interface, user can check or uncheck 

the parameters you want to restore. Please refer to the following picture. 

 

"Customize" function includes five pages. They are "Basic Settings", "Toolbox", "Menu", "Toolbar" and "Shortcut". For 

details please refer to the following explanation. 

 

5.1.3.1 Basic Settings 

"Basic Settings" tab includes the following content.  

 

"Right-click Operation", user can used it to control the display mode of the right click menu. It is divided in to two 

cases: "None Selected" and "Object Selected". 

"None Selected": there are three right click menu modes selectable: 

"Platform Right-click": it is the right click menu the same as that of GstarCAD platform. 

"Pop-up Common Menu": It is the right click menu predefined by GstarCAD Architecture. 

"Platform Right-click + Pop-up Common Menu(+Ctrl)": when we do not press Ctrl, it is the same as the first item, 

when we press Ctrl and right click at the same time, it will be the same as the second item. 

"Object Selected" there are two right click menu modes selectable: 
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"Platform Right-click": It is the right click menu the same as that of GstarCAD platform. 

"Pop-up Context Right-click Menu": It is the right click menu predefined according to the edit function of the 

selected object and the possible operation of the next step. 

"In-place Edit": User can use it to control the parameter of "Font Color", "Background Color" and "Font Height:" in the 

case of "In-place Edit". 

 

5.1.3.2 Toolbox 

"Toolbox" is a new type of interaction interface provided by GstarCAD Architecture. There are some commonly used 

menu groups on the left of the dialog box. Users can put the menu groups in the toolbox and organize them as per 

needs.  

 

 

5.1.3.3 Menu 

Menu is the most frequently used command set during our daily work. User can carry on individualized setting in 

the interface as follows: 
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5.1.3.4 Toolbar 

Toolbar is a bar of floating interface on which the icons are arranged. We can move it or press X button on the top 

right corner to close it. We can also right click the blank place of the standard toolbar and select "IAEC－＞ the 

toolbar customized by user" in the pop up menu to display it again. 
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Function Pool (the list on the left) includes all the command, the list on the right is the command list included in 

tool bar defined by GstarCAD Architecture.  

 

Select an icon from the left "Function Pool" and click the "Add >>"button, and we can add the icon to user 

customized toolbar region on the right of the dialog box. 

 

"Delete<<": Select the icon in the user customized toolbar region on the right and click the button, we can delete 

the icon that has been added here. 

 

User can select icons in user customized toolbar region and click "Move up" or "Move down" button to move the 

icon upward or downward. 

 

5.1.3.5 Shortcut 

One-click shortcut 

To start the command defined in "One-click shortcut" table, please click the radio button "One-click shortcut". 

 

We can use "Del" key to delete any definition of "One-click shortcut", and we can also modify the content in the 

"Command Name" bar so as to set other command as "One-click shortcut" command. 
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Note: Please do not use number 3 as "One-click shortcut" key to avoid the conflict with 3D commands beginning 

with 3, like 3DXXX.  

 

Short cut(PGP) 

Here we can define shortcut keys in the interface instead of common text editor. After we click "OK" button, 

"ACAD.PGP" file will be automatically modified and updated.  

 

Note: After we modify parameter in the dialog box and click "OK" button, "Reinitialize" dialog box will be displayed. 

We have to click the "Yes" button on it to make the modification effective. 
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5.1.4 Configuration Management 

The command is used to manage the GstarCAD Architecture configuration parameter installed in the computer. User 

can import or export these parameters in the form of configuration file via the execution of the command. 

 

Settings and Help→Settings→Configuration Management 

 

Click the command in the menu, and the command line will prompt: 

 

Please select config management option[Import/Export/Default]<Exit>: 

We can enter I or E and specify the storage path for the import file or select the export file in the pop up dialog box, 

or enter D to restore default values. 

 

5.1.5 Current Scale 

The command is used to define the current drawing scale of the annotation object, in other words, it directly control 

the size of the annotation object like text annotation, dimension, symbol and so on. The scale control in the status 

bar and the command are directionally associative. 

 

Settings and Help→Settings→Current Scale 

 

Click the command in the menu, and the command line will prompt: 

 

Current Scale<100>:50 

Here please enter the scale value we need. Then press enter to exit the command. 

 

Modify the current scale as 1:50 in the status bar, and we will see the current default scale is 1:50 in the command 

line when we execute the command. Modify the current scale as 1:100 via the command line. At this time, you will 

immediately see the scale in the status bar will be updated to 1:100. 

 

Besides, on the left of the drawing platform’s status bar, GstarCAD Architecture provides the pull-down control for 

scale setting. We can select the scale we need from the pull-down list according to the current drawing unit. If we 

can not find the scale we need in the pull-down list, we can click "Other Scale" in it and enter new scale we need in 

the edit box of the "Set Current Scale" dialog box. 
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5.2 Help 

5.2.1 Bug Report 

Settings and Help→Help→Bug Report 

 

Click "Bug Report" command in the menu, an outlook new mail writing box will be displayed as follows. We can 

write mail in it and click "Send" to send the mail. The execution condition of the command is that internet is 

available at present and your outlook account settings have been finished. In this case, you can send the bug report 

to support@gstarcad.net . 

 

 

5.2.2 Product Information 

When you encounter any problem when using GstarCAD Architecture, you have to let our technical support staff 

know version number of GstarCAD Architecture you are using for them to solve your problem accurately. 

 

Settings and Help→Help→Product Information 

 

Click "Product Information" command in the menu, we can see the detailed version number of the software on the 

pop up dialog box. 
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